Úvod

Navigation: »No topics above this level«

Úvod

 Return to chapter overview

Vážený uživateli,

jsme rádi, že jste si vybral náš produkt ADS - AUTOMATIZOVANÝ DOCHÁZKOVÝ SYSTÉM pro zpracování evidence docházky a řízení přístupového systému.


Základní funkce

Navigation: Úvod >

Základní funkce

 Return to chapter overview

Automatizovaný docházkový a přístupový systém slouží k evidenci docházky, sledování pohybu zaměstnanců v průběhu pracovní doby, k přípravě podkladů pro zpracování mzdové agendy a k otevírání turniketů, bran, dveří a závor dle přístupových práv. Program můžete používat pro sledování přítomnosti zaměstnanců - monitorování.

Používáním programu DOCHÁZKA dosáhnete omezení chybovosti při zpracování dat v docházce, lepšího využívání pracovní doby, kvalitativním zvýšením osobního přístupu zaměstnanců k pracovním povinnostem (zvýšení pracovní morálky), vyloučení neoprávněných přesčasových hodin. Můžete zamezit vstup osob do jednotlivých objektů podniku, na parkoviště, můžete povolit vstup oprávněných zaměstnanců do výrobní haly.

Program pracuje se čtečkami různých výrobců a je možno po dohodě použít čtečky jiných výrobců. Jako identifikační médium mohou být použity čipy dallas, karty a přívěšky pro bezkontaktní snímání, karty s čárovým a magnetickým proužkem a také otisky prstů.

Systém ADS je velmi flexibilní a může se přizpůsobit velkému množství variant zpracování docházky.

Touto příručkou se Vám pokusíme co nejvíce usnadnit práci se systémem.

Jakékoliv podněty a připomínky k příručce i samotnému systému rádi zpracujeme a budeme se snažit v maximální možné míře je zapracovat do dalších verzí systému k Vaší plné spokojenosti.

Tato příručka popisuje pouze software ADS na zpracování docházky. Příručka k instalaci a obsluze jednotlivých technických zařízení (hardware) je součástí dodávky kompletního docházkového systému.


Složení systému, provoz

Navigation: Úvod >

Složení systému, provoz

 Return to chapter overview

Kompletní docházkový nebo přístupový systém obsahuje tyto základní části:

· identifikační média - čipy, karty, přívěsky

· docházkové a přístupové terminály

· dveřní zámky, turnikety, závory, branky a brány

· kabeláž propojující hardware docházkového systému s počítačem

· počítač s volným COM portem nebo USB portem

· program ADS pro zpracování data

Zprovoznění a údržba systému:

· nainstalujete hardware a kabeláž

· do programu zadáte všechna potřebná data a nastavíte chování systému

· pracovníkům rozdáte identifikační media

Pravidelný provoz:

· pracovníci používají terminály, registrují docházku, otevírají dveře a ostatní zařízení

· program načítá data z terminálů a zapisuje je do databáze

· uživatelé editují data a zpracují docházku

· tisknete sestavy a exportujete data do navazujících systémů


Princip používání terminálů

Navigation: Úvod >

Princip používání terminálů

 Return to chapter overview

Vzhledem k rozmanitosti docházkových a přístupových terminálů a možnostem jejich nastavení a způsobů používání, není popis používání těchto zařízení součástí této příručky. Popis používání terminálů najdete v dokumentaci k danému konkrétnímu typu terminálu.


Princip používání identifikačního média

Navigation: Úvod >

Princip používání identifikačního média

 Return to chapter overview

Jedním ze základních principů korektní funkčnosti ADS je nutnost vysvětlení logiky zpracování informací docházkového a přístupového systému všem pracovníkům, kteří budou ADS používat.

Systém DOCHÁZKA nepoužívá princip párování operací (hledání navazujících počátků a konců). Pracovník používá identifikační médium k registraci události, kterou začíná provádět.

Pokud ráno přijdete do práce - registrujete příchod (začátek odpracované doby), odcházíte na oběd - registrujete oběd (Přestávku), přicházíte z oběda - registrujete příchod (stejný příchod jako ráno), odcházíte domů - registrujete odchod.

Příklad graficky:

6:00 si označím Příchod do práce (Začátek odpracované doby)

11:00 si označím Oběd (Přestávka)

11:30 si označím Příchod (stejný jako Příchod do práce)

14:00 si označím Odchod (odcházím domů)

Program automaticky zjistí, jaká byla Vaše předchozí činnost. Tuto činnost ukončí počátkem nové činnosti, kterou jste zaznamenali.

Nikdy nevolíte, co jste přestali dělat (to si program zjistí z předchozí operace), ale volíte to, co budete dělat.


Instalace

Navigation: »No topics above this level«

Instalace

 Return to chapter overview

Tato kapitola popisuje požadavky na software a hardware. Současně zde naleznete postup instalace software pro jednu stanici a také pro síťové prostředí.


Požadavky na hardware

Navigation: Instalace >

Požadavky na hardware

 Return to chapter overview

Minimální požadavky na hardware:

Procesor Celeron 1GHz, operační paměť 1GB, operační systém Windows XP, minimální rozlišení obrazovky 1280x768.

Doporučená konfigurace hardware:

Procesor Intel Core Quad 2.6 GHz, RAM 4 GB, operační systém Windows 7.

U konfigurace hardware platí pravidlo: čím výkonnější počítač, tím rychlejší a pohodlnější práce se systémem. V síťovém provozu (replikace) platí jako minimální konfigurace doporučená konfigurace.

Pro instalaci systému je potřeba jeden volný sériový port (COM) na počítači a možnost připojení napájecího zdroje na 230V pro napájení terminálu. Při větším rozsahu systému je nutné strukturu zapojení systému individuálně konzultovat.


Požadavky na software

Navigation: Instalace >

Požadavky na software

 Return to chapter overview

Programový systém je určen pro operační systémy Windows XP a vyšší a Windows Server 2003 a vyšší. Programový systém podporuje databáze: MS SQL server 2000, 2005, 2008, 2012 (včetně Express verzí), Firebird 2.5 (Win32/Linux) a Oracle 9, 10, 11.

Požadavky na instalaci komponent Windows pro korektní běh programu:

Windows XP/Vista/7/8

Není potřeba instalovat žádné komponenty. Všechny potřebné komponenty již systém obsahuje.

V případě Windows XP je vhodné upgradovat Mdac na poslední verzi. Poslední Mdac naleznete také na našich stránkách www.ron.cz.


Postup instalace

Navigation: Instalace >

Postup instalace

 Return to chapter overview

Distribuce produktu probíhá standardně pouze na CD. Instalační CD vložte do mechaniky. Po vložení se automaticky spustí instalační menu z CD. Pokud se menu nespustí automaticky, spusťte instalační program MENU.EXE z CD disku. Vyberte požadovaný program (WIN) a potvrďte, že chcete instalaci provést.

Spustí se Průvodce instalací, který vám pomůže instalaci provést. Čtěte pokyny průvodce a řiďte se jimi.

1.

Kdykoli můžete přerušit instalaci stisknutím tlačítka [image]. Pokračujte klepnutím na [image].

2.

Pruvodce instalaci licencni smlouva

Nyní musíte odsouhlasit podmínky licenční smlouvy, aby mohl být program nainstalován. Pokud zaškrtnete "Nesouhlasím s podmínkami licenční smlouvy", nebude možné pokračovat v instalaci. Proto zvolte "Souhlasím s podmínkami licenční smlouvy" a pokračujte stisknutím tlačítka [image].

3.

Pruvodce instalaci cilove umisteni

Tento krok umožní zvolit cílové umístění programu. Vyberte cestu pomocí tlačítka [image], nebo ponechte cíl beze změny a pokračujte v instalaci tlačítkem [image].

4.

Pruvodce instalaci soucasti instalace

Nyní vám program nabídne (pouze) možnost úplné instalace. Pokračujte tlačítkem [image].

5.

Pruvodce instalaci slozka v nabidce start

Dále vytvoříte zástupce aplikace ve vámi určené složce. Opět se posunete dál tlačítkem [image].

6.

Pruvodce instalaci instalace pripravena

V této chvíli vám průvodce instalací nabízí možnost překontrolovat všechna nastavení. Pokud se rozhodnete změnit kterýkoliv údaj, stiskněte tlačítko [image], nebo pokračujte stisknutím [image].

7.

Pruvodce instalaci instalace probiha

Nyní můžete sledovat průběh kopírování součástí programu do vámi zvoleného adresáře.

8.

Pruvodce instalaci instalace dokoncena

Po ukončení instalace uzavřete instalační menu stiskem tlačítka [image]. Program je nyní úspěšně nainstalován.


První spuštění

Navigation: Instalace >

První spuštění

 Return to chapter overview

Spuštění programu můžete provést:

- výběrem ikony na ploše, kterou zde automaticky umístil instalační program nebo

- výběrem položky v menu Start operačního systému Windows.

1.

Instalace_Dotaz pri prvnim spusteni

V první části spuštění programu se zobrazí následující Dotaz: "Toto je první start aplikace. Implicitní název souboru pro vytvoření databáze je: "C:\ProgramData\MZDY\data.fdb nebo data.mdb", přejete si vygenerovat databázi do tohoto cílového souboru?". Cesta k vygenerovanému souboru data.fdb nebo data.mdb je závislá na spouštěné aplikaci (programu - Mzdy, Docházka, Jídelna apod.).

V případě, že nemáte zakoupenou SQL verzi programu, zvolte [image] a postupujte oddílem 2a). Pokud máte SQL verzi programu, stiskněte [image] a pokračujte oddílem 2b).

2a)

Po potvrzení Dotazu se spustí okno, ve kterém bude probíhat generování databáze včetně tabulek.

Instalace_Nacitani preddefinovanych implicitnich zaznamu

Po vytvoření databáze podá program informaci, kterou potvrďte stiskem [image] . Tímto je instalace ukončena.

2b) Zvolte Typ připojení:

- MS SQL server - vyplňte zobrazená pole a poté vytvořte databázi (výhodou tohoto typu připojení je možnost vytvoření nové databáze).

Instalace_Prvni spusteni MS SQL server

· Název serveru - název nebo IP adresa SQL serveru.

· Uživatel - uživatelské jméno ("sa" - systém administrator).

· Heslo - heslo pro přihlášení k serveru.

· Databáze - můžete vybrat ze seznamu již vytvořených databází nebo kliknout na tlačítko [image]. Otevře se okno, do kterého uvedete název databáze. Poté potvrdíte dotaz o provedení restrukturalizace připojené databáze. Program provede restrukturalizaci dat a vygeneruje základní nastavení databáze. Základní seznamy budou vyplněny standardními hodnotami. Tyto hodnoty můžete samozřejmě nahradit.

- SQL server - slouží pro připojení k jiným typům databázových serverů pomocí OLE DB rozhraní.

Instalace_Prvni spusteni SQL server

Pomocí tlačítka [image] můžete vytvořit řetězec spojení:

· v záložce "Zprostředkovatel" vyberte "Microsoft OLE DB Provider for SQL Server"
· v záložce "Připojení" nastavte následující hodnoty:

1. Název nebo IP adresu SQL serveru;

2. Zadejte uživatelské jméno ("sa" - systém administrator) a heslo pro přihlášení k serveru;

3. Zapište nebo vyberte název databáze;

4. Proveďte test spojení, po úspěšném testu potvrďte tlačítkem OK.

- Soubor MDB - umožní připojit již vytvořený MDB soubor.

Instalace_Prvni spusteni MDB databaze

Do pole MDB soubor můžete zadat cestu k souboru ručně, nebo pomocí tlačítka [image], které pomocí průzkumníka umožní najít soubor pohodlněji.

- Firebird - umožní připojit již vytvořený FDB soubor.

Instalace_Prvni spusteni Firebird

Do pole FDB soubor můžete zadat cestu k souboru ručně, nebo pomocí tlačítka [image], které pomocí průzkumníka umožní najít soubor pohodlněji.


Instalace databázového serveru

Navigation: Instalace >

Instalace databázového serveru

 Return to chapter overview

Umístění databáze:

První volbou je umístění dat. Jelikož u síťové verze předpokládáme využívání dat více uživateli v síti, měli byste data uložit na síťový server. Pokud se rozhodnete data uložit na lokálním počítači, musíte jej nastavit jako sdílený a musí být spuštěn vždy, kdykoliv budou jiní uživatelé data potřebovat. Další nevýhodou umístění dat na lokálním počítači je riziko zhroucení a restartu běžně používaného počítače. Nekorektní uzavírání databáze může vést k poškozování této databáze. Proto jednoznačně preferujeme umístění dat na serveru, který je k tomuto účelu určen.


Instalace síťové verze

Navigation: Instalace >

Instalace síťové verze

 Return to chapter overview

Pokud máte zakoupenou síťovou verzi systému, máte několik variant rozložení systému.

Umístění programu:

Pro umístění aplikace je možné použít dvě varianty, z nichž každá má své výhody:

První variantou je instalace aplikace na všechny lokální počítače, které budou s daty systému pracovat. Na lokálně instalovaných aplikacích potom nastavujete cestu k databázi. Výhodou je jisté zvýšení rychlosti při spouštění systému. Nevýhodou je vysoká náročnost na údržbu takto nainstalované aplikace. Při instalaci update a upgrade systému musíte zajistit výměnu aplikace na všech těchto stanicích, což je velmi nepraktické.

Druhou variantou je umístění aplikace na server. Všichni uživatelé potom spouštějí tuto jedinou aplikaci, jejíž správa při update nebo upgrade je pro správce velmi snadná. V tomto případě je sice doba pro spuštění aplikace delší, při běžném provozu však nepodstatná.

Jak z výše uvedeného vyplývá, doporučujeme druhou variantu - umístění aplikace na server. Umístění aplikace na server však neznamená, že nemusíte na lokálním počítači zajistit podmínky pro správný chod aplikace. Aplikace potřebuje mít nainstalovány komponenty pro přístup k datům, viz kapitola Požadavky na software. Všechny potřebné soubory pro instalaci povinných komponent jsou obsaženy na instalačním CD. Při provádění instalace instalačním programem se všechny potřebné komponenty nainstalují automaticky.

Instalace samotná je identická s běžnou instalací, viz kapitola Postup Instalace.


Licence

Navigation: »No topics above this level«

Licence

 Return to chapter overview

Po nainstalování je program standardně v režimu demoverze. K tomu, aby program fungoval plnohodnotně, je nutné provést AKTIVACI. Aktivací se rozumí zadání licenčních parametrů z registrační karty.

Aktivace je způsobem ochrany programu před neoprávněným používáním jinými osobami.

POZOR: Nezapomeňte, že můžete program používat pouze v rozsahu, jaký vám dovoluje zakoupená licence. Užívání programu nad rámec licence nebo poskytnutí programu jinému uživateli je porušením zákona a v případě zjištění neoprávněného používání programu jsou autoři oprávněni chránit své zájmy i právní cestou.

Pro aktivaci otevřete okno pro zadání registračních údajů Systém/Správa databáze/Aktivace.

Aktivace aktivace programu

Ve formuláři jsou čtyři údaje zvýrazněny tučně. Tyto údaje musíte opsat z registrační karty přesně tak, jak jsou uvedeny. V případě, že budete mít v některém údaji chybu (nebude podle registrační karty), neproběhne aktivace úspěšně. Ostatní údaje ve formuláři, které nejsou zobrazeny tučně, nejsou pevně vázány a můžete je měnit.

· Název - povinný údaj. Po instalaci programu je v názvu firmy zadána firma RON Software. Tento údaj nahraďte názvem vaší firmy tak, jak je zadaný na registrační kartě.

· Název (druhý řádek) - pokud je v registračním formuláři uveden, musíte jej rovněž zadat přesně podle údajů v registraci.

· Ulice / Město / PSČ - adresa uživatele.

· Telefon - telefonní číslo uživatele.

· Fax - faxové číslo uživatele.

· Email - adresa elektronické pošty uživatele.

· IČO - povinný údaj. Zadejte podle registrační karty.

· DIČ - daňové identifikační číslo.

· Licenční číslo - povinný údaj. Zadejte podle registrační karty.

· Aktivační kód - povinný údaj. Zadejte podle registrační karty.

Pokud máte údaje správně zadány, stiskněte tlačítko [image] pro potvrzení. Nemáte-li v aktivaci překlep, ohlásí program, že aktivační kód byl identifikován a program bude převeden do ostré verze. Jestliže program nahlásí, že aktivace neproběhla v pořádku, musíte zadání údajů překontrolovat.

Pokud jste aktivaci provedli úspěšně, program se spustí v plně funkční verzi.

POZOR: Pokud máte nesprávně vyplněnou aktivaci, bude systém fungovat jako demoverze pro 3 zaměstnance. Pokud se někdy v průběhu práce pokusíte aktivaci změnit (např. vyměnit název firmy), systém se okamžitě přepne do režimu demoverze a bude požadovat zadání původní správné aktivace.


Princip práce s docházkovým systémem

Navigation: »No topics above this level«

Princip práce s docházkovým systémem

 Return to chapter overview

V této kapitole naleznete základní princip práce s docházkovým systémem. Jsou zde zdůrazněny jednotlivé kroky, které jsou potřebné pro správnou práci docházkového systému.


Princip práce

Navigation: Princip práce s docházkovým systémem >

Princip práce

 Return to chapter overview

Po přečtení této kapitoly byste měli pochopit princip práce s docházkovým systémem.

Vycházíme z předpokladu, že máte nainstalovaný program se založenou databází a připojena všechna zařízení docházkového systému (terminály, zámky, závory atd.). Jednotlivá zařízení jsou nakonfigurována v té míře, jakou není schopen obsluhovat program z počítače.

Práci s docházkovým systémem rozdělíme na dvě základní části.

Konfigurace a nastavení systému a naplnění daty potřebnými pro provoz. Toto nastavení provádíte hlavně ve fázi zprovoznění systému. Samozřejmě i v průběhu používání systému budete měnit své požadavky na zpracování docházky, upravovat nastavení a obsahy seznamů.

Pravidelný provoz - zpracování dat o docházce. Budete zpracovávat pravidelné informace z docházkových terminálů a tyto informace vyhodnocovat.


Postup práce s docházkou

Navigation: Princip práce s docházkovým systémem >

Postup práce s docházkou

 Return to chapter overview

Docházkový systém máte nainstalovaný a nyní musíte nastavit jeho funkce tak, aby splňoval Vaše požadavky.

Při prvním spuštění jste založili databázi, do které program automaticky doplnil některá základní nastavení.

Podrobný popis nastavení a vygenerování nové databáze najdete v menu programu Systém/Správa databáze/Nastavení parametru databáze.

Nastavení období

Docházkový systém pracuje v měsíčním režimu zpracování dat. Nastavení období je jednou z prvních věcí, kterou musíte v docházkovém systému provést. Postup pro vytvoření období najdete v kapitole "Nastavení/Výběr období"

Naplnění seznamů

Základním seznamem je seznam zaměstnanců. Pro správné zadání zaměstnance musíte předem naplnit několik seznamů.

Zaměstnanec musí mít přiřazeno identifikační médium (viz seznam identifikačních médií), aby mohl toto médium používat u terminálů. Pro stanovení fondu pracovní doby a jeho porovnání se skutečnou docházkou musíte naplnit seznam kalendářů a seznam směn, ze kterých jsou tyto kalendáře složeny. Vhodný kalendář přiřadíte zaměstnanci, čímž nastavíte velkou část chování programu při zpracování dat o docházce tohoto zaměstnance.

Zaměstnance máte zapsaného k použití v systému. Ještě jste ale nenastavili seznam terminálů a jejich chování.

Všechny terminály v docházkovém systému zapište do seznamu terminálů. Pro správnou funkci terminálů musíte vytvořit seznam operací terminálů (druhy přerušení pracovní doby). U každého terminálu nastavíte, kterou operaci může nebo nemůže používat. Možnosti nastavení závisí na typu použitého terminálu (kolik různých operací - přerušení), které může terminál registrovat. Detailní možnosti najdete v popisu vašeho terminálu a programu ADS.

Dalším nastavením terminálu je výběr zaměstnanců, kteří budou (mohou) terminál používat. Jelikož při větším počtu zaměstnanců by bylo náročné definovat pro každý terminál jmenovitě zaměstnance, lze v programu naplnit seznam skupin osob a do těchto skupin zaměstnance rozdělit. U terminálu potom volíte skupiny osob, které mohou terminál použít.

Komunikace s terminály

Data jste si připravili a nyní je můžete zaslat terminálům tak, aby přizpůsobily své chování Vašim požadavkům. Pro odeslání dat do terminálů použijete volbu "Terminály / Generování nastavení terminálů". Pokud proběhlo vygenerování dat do terminálů úspěšně, můžete prověřit, že terminál registruje identifikační média zaměstnanců, kteří jsou v terminálu povoleni. Pokud terminál identifikační média nepřijímá, není něco správně nastaveno a musíte chybu v zadání odstranit.

Změny v nastavení systému se projeví na terminálech až po provedení generování nastavení terminálů

Terminály jste nastavili a zaměstnanci je používají k registraci docházky a otevírání dveří, bran, závor atd. Princip používání terminálů zaměstnanci se může lišit podle typu terminálu. Podrobný popis pro váš terminál najdete v popisu k vašemu terminálu.

Druhou částí komunikace s terminály je vyčtení dat z těchto terminálů, abyste je mohli dále zpracovat. Pro tuto činnost použijte volbu "Terminály / Načtení historie operací". Program si postupně vyčte ze všech terminálů nasbíraná data a uloží je do seznamu původní docházky. Takto nasbírané údaje jsou základem pro zpracování dat o docházce.

TIP: Načtení historie operací můžete provádět ručně nebo v plánovači úloh nastavit automatické načítání ve zvoleném intervalu. Stejným způsobem můžete nastavit generování nastavení terminálů tak, aby se nastavení provedlo automaticky v zadaném intervalu bez nutnosti toto provádět ručně. Viz plánovač úloh.

Zpracování dat o docházce

Načtená data se ukládají do seznamu původní docházky, který je základem pro zpracování dat. V tomto seznamu není možné žádné záznamy měnit, přidávat nebo mazat.

POZOR: Seznam původní docházky zůstává vždy k dispozici beze změny pro porovnání s upravenými (editovanými) daty. Právo na úpravu tohoto seznamu nemá ani správce docházkového systému.

Načtená data jsou pouze jednotlivé údaje o tom kdo, kdy, u kterého terminálu použil určitou operaci. Pro zpracování těchto dat musíte použít volbu "Docházka/Zpracování původní docházky". Tato volba vytvoří z jednotlivých údajů původní docházky časové intervaly určující, jak dlouho který zaměstnanec prováděl zvolenou činnost. Zpracování původní docházky je potřeba provádět ke dni předcházejícímu dnešku. Pro korektnost údajů není vhodné zpracovávat původní docházku k dnešnímu dni, či dokonce "do budoucnosti".

Editace (úpravy) dat o docházce

Zpracované intervaly zobrazíte v části "Docházka/Editace zpracované docházky". V grafickém zobrazení můžete provádět úpravy záznamů (intervalů). Můžete vkládat doplňující údaje, mazat nesprávné údaje nebo upravovat časy a typy jednotlivých údajů. V tomto grafickém zobrazení vidíte také součty docházky a její výsledky.

TIP: Pokud ve formuláři editace docházky nevidíte žádné údaje, neprovedli jste zpracování dat původní docházky nebo jste za vybrané období provedli zpracování dat dříve, než jste měli data původní docházky.

Pro uzavření upravené docházky do výsledného tvaru můžete použít možností schvalování docházky. Ve schvalování docházky můžete nastavit pravomoci jednotlivým zaměstnancům pro 3 úrovně schválení.

Saldo odpracované doby

Program je schopen v závislosti na vlastnostech terminálů poskytnout těmto terminálům data o saldu odpracované doby. Pokud provádíte zpracování docházky pravidelně (každý den), můžete si nastavit automatické generování salda do terminálů tak, aby si každý zaměstnanec mohl u terminálu denně své saldo zjistit. Pro zprovoznění této funkce použijete volbu "Generování salda".

Výsledky a tisky

Po zpracování celého měsíce můžete tisknout výstupní sestavy poskytující maximum informací pro přehled o odpracované době a podklady pro mzdové systémy v tiskové i datové podobě. Viz. "Výstupy/Manažer výstupních sestav".

Uzavření období

Docházka je zpracována a vy můžete uzavřít zpracovávané období a založit období nové. V praxi doplňujete ještě několik dní záznamy starého měsíce a připravujete výsledky pro zpracování mezd. Nové období však musí umožňovat pokračování v práci. Proto budete nové období zakládat vždy dříve, než budete staré období definitivně uzavírat. Souběžná práce ve více obdobích není pro tento systém žádným problémem. To znamená, že můžete kontrolovat data starého měsíce a již sbírat a upravovat data v měsíci novém.

Tento popis postupu práce by Vám měl ujasnit logickou posloupnost jednotlivých kroků, které musíte provést pro zpracování docházky. Při ustáleném provozu systému se činnost týkající se nastavení systému velmi omezuje. Rutinní práce jsou pak zjednodušeny do činností načítání a zpracování původní docházky a editaci zpracovaných dat uživatelem. Pokud si nastavíte pomocí plánovače úloh automatické načítání a zpracování dat můžete potom svou činnost omezit pouze na editaci zpracované docházky. Nikdy se samozřejmě nevyhnete občasnému zásahu do nastavení systému a vygenerování nastavení terminálů.


Postup zpracování v bodech

Navigation: Princip práce s docházkovým systémem >

Postup zpracování v bodech

 Return to chapter overview

Samotné zpracování docházky si můžeme shrnout do bodů. Princip opakované práce s docházkovým systémem se skládá z několika samostatných operací, které však musí být realizovány v logickém sledu.

Pravidelná (denní) práce s docházkovým systémem:

1. Odesílání dat do terminálů

Pro správnou funkci docházkového systému musíte provést zaslání nastavených dat do terminálů. Po korektním provedení této operace je terminál schopen rozpoznávat identifikační média jednotlivých zaměstnanců a přiřazovat jim zvolené operace. Tuto akci provedete volbou v menu "Terminály/Generování nastavení terminálů". Pokud se v nastavení nic nemění, nemusíte tuto funkci pravidelně používat.

2. Registrace operací-událostí na terminálech

Pokud jsou terminály připraveny k práci, mohou zaměstnanci, kteří obdrželi své identifikační médium, registrovat jednotlivé události na těchto terminálech. Zaměstnanec vždy vybere požadovanou operaci a zaregistruje pomocí identifikačního média. Vždy se registruje operace, kterou zaměstnanec začíná provádět.

PŘÍKLAD: Při ranním příchodu do práce registruje "příchod", při odchodu na přestávku registruje operaci "přestávka" a při návratu na pracoviště registruje opět "příchod" jako při příchodu do zaměstnání.

3. Načítání historie operací

Takto nasbíraná data v terminálu jsou v nastaveném intervalu nebo ručně přenášena do počítače. Pokud proběhl přenos úspěšně, jsou data uložená v databázi z terminálu smazána.

4. Monitorování

Pokud načítáte data z terminálu často, můžete použít modul monitorování přítomnosti. Jestliže načítáte data např. každé 2 minuty, můžete v monitorování zobrazovat aktuální přítomnost zaměstnanců v práci se zpožděním maximálně 2 minuty.

5. Manuální vložení operace

Pokud z nějakého důvodu nemůžete aktuálně použít pro identifikaci médium (bylo ztraceno, poškozeno), máte možnost vložit operaci pomocí programu bez použití terminálu. Manuálně vkládat operaci lze pouze do období, které ještě nebylo zpracováno. Nepoužívejte tuto volbu jako náhradu za ruční editaci v Editaci zpracované docházky. Záznam vložený přes Manuální vložení operace se chová, jako by byl nasnímaný z terminálu a již ho nelze odstranit ze Seznamu původní docházky.

6. Zpracování původní docházky

Tato funkce provádí zpracování jednotlivých zaregistrovaných operací do časových intervalů, které již mají nastaveny další vlastnosti potřebné pro zpracování celkových hodnot o docházce. Zpracování může probíhat na povel obsluhy programu nebo ve zvoleném intervalu nastaveném v plánovači úloh. Pokud zpracováváte docházku na povel obsluhy, dodržujte zásadu o zpracování docházky ke dni předcházejícímu dnešku. Zpracování docházky k aktuálnímu dni, či "do budoucna", se může chovat nekorektně.

7. Editace docházky

Pokud je docházka zpracována, může ve zpracovaném období probíhat ruční editace docházky v grafickém režimu.

8. Saldo

Výsledky aktuálně zpracované docházky je možno u některých typů terminálů posílat zpět do těchto terminálů a pracovníci mohou zjistit saldo odpracované doby přímo na terminálu.

Těchto pár bodů popisuje logický postup jednotlivých operací. Detailní popis těchto operací najdete dále v příručce.


Ovládání programu

Navigation: »No topics above this level«

Ovládání programu

 Return to chapter overview

V následujících kapitolách naleznete instrukce k ovládání systému, tedy popis práce v seznamech a formulářích vyskytujících se v programu.

Seznam je tvořen několika záznamy, které lze filtrovat. Na základě zvolených filtrů se zobrazí v řádcích požadované údaje. Nepoužívejte seznam pro editaci.

Formulář zobrazuje data pouze jednoho vybraného záznamu ze seznamu a uvedené hodnoty můžete libovolně upravovat, rušit, popřípadě vkládat nové.


Ovládání seznamu

Navigation: Ovládání programu >

Ovládání seznamu

 Return to chapter overview

Každý seznam má ve své horní části zobrazena tlačítka pro ovládání. Po kliknutí na tlačítko program provede definovanou akci. Stejného výsledku dosáhnete kliknutím na nabídku "Aktuální okno" v menu a výběrem akce, kterou chcete provést. Každá akce má také přiřazenu klávesu nebo kombinaci kláves, kterou můžete akci vyvolat bez použití myši. Seznam slouží pouze pro zobrazení v řádcích. Nepoužívejte seznam pro přímou editaci. Vždy si otevřete okno s formulářem pomocí akce [image] Nový záznam nebo [image] Editace záznamu.

Ukázka nástrojové lišty:

Ovladani nastrojova lista seznamu

Používaná tlačítka - akce:

 | Nový záznam - otevře formulář pro zápis nového záznamu do seznamu. Klávesová zkratka ALT+INS nebo F4.
C_Novy zaznam z kopie | Nový záznam z kopie aktuálního - otevře formulář pro zápis nového záznamu do seznamu. Hodnoty položek nastaví podle záznamu, který byl v seznamu aktuálně označen. Vždy je nutné změnit alespoň klíčové položky, jinak nebude možné záznam zapsat kvůli duplicitě klíčové položky. Klávesová zkratka CTRL+K.
 | Editace záznamu - otevře formulář s aktuálním záznamem pro editaci (změnu údajů). Klávesová zkratka CTRL+ENTER nebo F5.
 | Zrušit záznam - provede zrušení záznamu ze seznamu. Před zrušením se vždy zobrazí dotaz, zda opravdu chcete akci provést. Po potvrzení je tato akce nevratná. V mnoha případech jsou na zvolené položce závislé další údaje v databázi. Proto ne vždy program umožní položku smazat a oznámí, že záznam nelze odstranit, protože obsahuje související záznamy. Klávesová zkratka ALT+DEL nebo F8.
 | Obnovit obsah seznamu - po použití této akce program obnoví obsah aktuálního seznamu. Pokud jste měli seznam otevřený a přes jiný seznam změnili jeho obsah, neprovádí program z časových důvodů automatické obnovení. Stejná situace nastává, pokud změníte parametry zobrazení seznamu. Vždy platí - pokud je seznam neaktuální, zvolte tuto akci. Klávesová zkratka CTRL+O.
 | Rychlé vyhledávání - po použití této akce, nebo stiskem CTRL+F, se ve spodní části seznamu zobrazí řádek s editačním polem pro zápis hledané hodnoty. Vedle editačního pole můžete mít nastavenu hodnotu "Vyhledávání" nebo "Výběr" a zaškrtnutou volbu "Vybírat podle podřetězce".

Ovladani lista rychleho vyhledavani v seznamu

· Zrušení výběru - po stisku tlačítka se řádek pro rychlé hledání uzavře.

· V poli - implicitně je zvolena nabídka (všechna textová pole), to znamená, že zadaná hodnota se hledá ve všech textových sloupcích. Po výběru některého z polí program hledá zadanou hodnotu jen v příslušném sloupci.

Vedle editačního pole můžete mít nastavenou hodnotu Vyhledávání nebo Výběr a zaškrtnutou volbu Vybírat podle podřetězce.

· Vyhledávání - pokud máte nastavenou tuto volbu, bude se seznam při zápisu do editačního pole posouvat na hodnotu, která začíná hledanou hodnotou nebo hodnotou blízkou.

· Výběr - pokud máte nastavenou tuto volbu, bude se seznam při zápisu do editačního pole omezovat a zobrazovat pouze hodnoty, které začínají hledanou hodnotou.

· Vybírat podle podřetězce - jestliže zaškrtnete tuto volbu, bude se seznam omezovat na hodnoty, které obsahují hledanou hodnotu. Tuto volbu velmi často použijete, když znáte jen část hledané hodnoty.

Nastavení řazení - řazení záznamů v seznamu lze nastavit několika způsoby.
· Způsoby řazení lze definovat v editoru řazení, který můžete vyvolat stisknutím daného tlačítka nebo kombinací kláves CTRL+R. V editoru řazení můžete vytvořit a pojmenovat vlastní způsoby řazení.

· Kliknete-li dvakrát (dvojklik) na nadpis zobrazeného sloupce v seznamu, nadpis se podtrhne a seznam se seřadí podle této položky. Dvojklikem na nadpis pole v seznamu se automaticky vytvoří (pokud již neexistuje) a vybere řazení podle daného pole.

· Přehled možných způsobů řazení nadefinovaných v editoru řazení lze vyvolat kliknutím na šipku vedle tlačítka pro nastavení řazení.

Nastavení filtru - tato volba umožňuje vyvolat seznam definovaných filtrů, ve kterém lze filtry vytvářet, editovat, případně rušit. Tyto filtry lze pak aktivovat jejich výběrem. Nadefinované filtry lze rychle volit kliknutím na šipku vedle tlačítka pro nastavení filtru.

Nastavení vzhledu - stiskem tohoto tlačítka, nebo stiskem CTRL+L, vyvoláte editor nastavení sloupců, který umožňuje nastavení vzhledu seznamu. Lze volit pořadí, viditelnost, editovatelnost, barvy a fonty sloupců a jejich nadpisů v seznamu. V editoru nastavení sloupců lze vytvářet více různých nastavení, která pak lze rychle volit pomocí rychlé volby (kliknutím na šipku vedle tlačítka editoru nastavení vzhledu).

Tiskové sestavy - stiskem tohoto tlačítka, nebo stiskem CTRL+T, se vyvolá seznam tiskových sestav, ve kterém můžete vytvářet, editovat, rušit a tisknout sestavy s aktuálně zobrazenými záznamy v seznamu. Tento seznam tiskových sestav ve skutečnosti obsahuje dvě záložky se dvěma seznamy pro dva druhy sestav.

Exporty - stiskem tohoto tlačítka, nebo stiskem CTRL+E, vyvoláte seznam exportních sestav, který umožňuje vytvářet, editovat, rušit exportní sestavy a exportovat data (aktuálně zobrazené záznamy v seznamu) ve formátu definovaném jednotlivými exportními sestavami.

Za posledním tlačítkem jsou zobrazeny názvy aktuálně zvoleného řazení a filtru.

Pokud není některá z akcí funkční (ikona je šedá a položka akce není v menu dostupná), nemáte přístupová práva tuto akci provádět, nebo v daném stavu není možné tuto akci provést.


Ovládání formuláře

Navigation: Ovládání programu >

Ovládání formuláře

 Return to chapter overview

Každý formulář má v dolní části zobrazenou lištu s tlačítky pro základní ovládání formuláře.

Ovladani nastrojova lista formulare

Malá tlačítka vlevo na liště:

 | Nový záznam - vytvoří nový záznam a umožní jeho vložení do seznamu. Klávesová zkratka ALT+INS nebo F4.
C_Novy zaznam z kopie1 | Nový záznam z kopie aktuálního - vytvoří nový záznam, kde hodnoty položek nastaví podle záznamu, který byl aktuální před vytvořením nového záznamu. Vždy je nutné změnit alespoň klíčové položky, jinak nebude možné záznam zapsat, a to kvůli duplicitě klíčové položky. Klávesová zkratka CTRL+K.
 | Zrušit záznam - provede zrušení záznamu ze seznamu. Před zrušením se vždy zobrazí dotaz, zda opravdu chcete akci provést. Po potvrzení je tato akce nevratná. V mnoha případech jsou na zvolené položce závislé další údaje v databázi. Proto ne vždy program umožní položku smazat a oznámí, že záznam nelze odstranit, protože obsahuje související záznamy. Klávesová zkratka ALT+DEL nebo F8.
C_Skok na privni zaznam | Skok na první záznam - zobrazí se první záznam v seznamu, ze kterého je formulář otevřen. Klávesová zkratka CTRL+Home.
C_Skok na predchozi zaznam | Skok na předchozí záznam - bude zobrazen předchozí záznam v seznamu, ze kterého je formulář otevřen. Klávesová zkratka CTRL+PgUp.
C_Papir se sipkou | Změna akt. záznamu výběrem ze seznamu - umožní skok na vybraný záznam ze zobrazeného seznamu. Klávesová zkratka CTRL+S.
C_Skok na nasledujici zaznam | Skok na následující záznam - bude zobrazen následující záznam v seznamu, ze kterého je formulář otevřen. Klávesová zkratka CTRL+PgDn.
C_Skok na posledni zaznam | Skok na poslední záznam - zobrazí se poslední záznam v seznamu, ze kterého je formulář otevřen. Klávesová zkratka CTRL+End.
 | Zapsat změny záznamu do databáze - provede se zápis změn záznamu do databáze. Formulář zůstane otevřen.
 | Obnovit původní hodnoty položek záznamu z databáze - obnoví hodnoty položek na původní hodnoty před změnou záznamu. Klávesová zkratka ALT+BkSp.
 | Tiskové sestavy - stiskem tohoto tlačítka, nebo stiskem CTRL+T, vyvoláte seznam tiskových sestav, ve kterém můžete vytvářet, editovat, rušit a tisknout sestavy s aktuálně zobrazenými záznamy v seznamu. Tento seznam tiskových sestav ve skutečnosti obsahuje dvě záložky se dvěma seznamy pro dva druhy sestav.

Velká tlačítka vpravo na liště:

OK - provede se zápis změn záznamu do databáze a uzavře se formulář. Klávesová zkratka F12.

Storno - budou obnoveny původní hodnoty položek záznamu z databáze a následně uzavřen formulář. Klávesová zkratka ESC.

Pokud není některá z akcí funkční (ikona je šedá), nemáte přístupová práva tuto akci provádět, nebo v daném stavu není možné tuto akci provést.


Editor řazení

Navigation: Ovládání programu >

Editor řazení

 Return to chapter overview

Editor řazení slouží k nastavení způsobů řazení a ukládání vytvořených nastavení pod zvolenými jmény. Editor řazení otevřete tlačítkem [image].

Ovladani editor razeni

· Seznam vlevo obsahuje seznam vytvořených nastavení řazení. Nové nastavení řazení lze vytvořit pomocí tlačítka: . Přejmenovat nastavení řazení lze pomocí tlačítka [image]. Zrušit nastavení řazení lze pomocí tlačítka [image].

· Seznam uprostřed obsahuje dostupná pole, ze kterých lze volit podle, kterých polí se bude řadit. Přidávat pole mezi vybraná je možno pomocí myši (dvojklikem nebo tažením), nebo pomocí tlačítek: , C_Sipka dvojita vpravo mezi seznamy dostupných polí a seznamem vybraných polí.

· Seznam vpravo obsahuje pole, podle kterých jsou řazeny záznamy při aktivovaném aktuálním nastavení řazení. U jednotlivých polí lze volit příznak C_Sipka zelena dolu, který znamená, že podle daného pole je řazeno sestupně. Rušit vybraná pole je možno pomocí myši (dvojklikem nebo tažením), nebo pomocí tlačítek: , C_Sipka dvojita vlevo mezi seznamy dostupných polí a seznamem vybraných polí. Přesunovat pozice vybraných polí lze pomocí tlačítek C_Sipka seda dvojita nahoru , C_Sipka seda nahoru, C_Sipka seda dolu, C_Sipka seda dvojita dolu .

· Pomocí tlačítka [image] lze aktivovat aktuálně zvolené nastavení řazení.

· Tlačítko [image] uzavře formulář a ponechá aktivováno stávající řazení.


Seznam filtrů

Navigation: Ovládání programu >

Seznam filtrů

 Return to chapter overview

Filtry slouží pro omezení seznamu na omezený počet záznamů, které splňují podmínky definované ve filtrech. Filtry lze definovat v zobrazovaných seznamech v aplikaci a také pro jednotlivé kategorie sestav v manažeru sestav. Každý seznam a kategorie sestav má vlastní seznam definovaných filtrů. Do tohoto seznamu lze filtry přidávat, editovat je a rušit. Filtry lze pak aktivovat jejich výběrem. Po aktivaci zadaného filtru budou v daném seznamu nebo kategorii sestav jen záznamy, které dané podmínky splňují. Seznam filtrů otevřete tlačítkem [image] .

Ovladani seznam filtru

Seznam definovaných filtrů obsahuje filtry definované uživateli pro daný seznam, nebo kategorii sestav v manažeru sestav.

Nad seznamem filtrů lze provádět následující operace:

 | Nový - vytvoření nového filtru. Zobrazí vstupní dialog pro zadání názvu nového filtru a po zadání jména zobrazí editor filtru, kde je možno zadat požadované nastavení filtru a uložit jej.
C_Novy z kopie | Nový z kopie - vytvoření nového filtru z kopie aktuálního filtru. Zobrazí vstupní dialog pro zadání názvu nového filtru a po zadání jména zkopíruje nastavení akt. filtru do nového a zobrazí editor filtru, kde je možno změnit nastavení filtru a uložit jej.
 | Editovat - editace aktuálního filtru. Zobrazí editor filtru, kde je možno změnit aktuální nastavení filtru a uložit jej.
 | Přejmenovat - umožní přejmenovat aktuální filtr.
 | Zrušit - umožní zrušení aktuálního filtru. Před zrušením se vždy zobrazí dotaz, zda opravdu chcete akci provést.
 | Použít - uzavře okno a aktivuje aktuálně zvolený filtr.
 | Nefiltrovat - uzavře okno a deaktivuje filtr nastavený v seznamu záznamů nebo kategorii sestav. To znamená, že v seznamu nebo kategorii sestav nebude nastaven žádný filtr (záznamy nebudou omezené žádným filtrem).
 | Načíst - zadejte cestu k načtení souboru s nastavením filtru.
 | Uložit - uloží filtr do vámi zadaného adresáře.

· Jen vlastní - po zatrhnutí pole se zobrazí jen filtry, které byly vytvořeny uživatelem.

Editor filtru slouží pro zadání omezujících podmínek pro daný seznam, nebo kategorii sestav v manažeru sestav. Po aktivaci zadaného filtru budou v daném seznamu nebo kategorii sestav jen záznamy, které dané podmínky splňují. Podmínky pro omezení záznamů lze zadat dvěma způsoby:

· Jednoduchý filtr - jednoduchý filtr (na záložce jednoduchý filtr) slouží pro zadání jednoduchých podmínek pomocí nastavení omezujících hodnot a intervalů hodnot pro jednotlivá pole (sloupce) tabulky (seznamu).

· Složitý filtr - složitý filtr (na záložce složitý filtr) slouží pro zadání složitějších omezujících podmínek záznamů, kde se jednotlivé podmínky vkládají do seznamů podmínek. Do seznamu podmínek se mohou vkládat další seznamy podmínek tak, že nastavení filtru tvoří hierarchickou strukturu podmínek, pomocí které lze vytvořit jakýkoli logický výraz.

Nastavení filtru lze uložit pomocí tlačítka [image]. Uložen je ten typ filtru (jednoduchý, složitý), jehož záložka byla aktivní při stisku tlačítka [image]. Po uložení filtru je okno editoru uzavřeno. Pokud je stisknuto tlačítko [image], pak je okno editoru uzavřeno a změny nastavení filtru nejsou uloženy.


Jednoduchý filtr

Navigation: Ovládání programu > Seznam filtrů >

Jednoduchý filtr

 Return to chapter overview

Jednoduchý filtr slouží pro zadání jednoduchých podmínek pomocí nastavení omezujících hodnot a intervalů hodnot pro jednotlivá pole (sloupce) tabulky (seznamu).

Ovladani seznam filtru podminky filtru jednoduchy filtr

V horní části jednoduchého filtru je seznam polí (sloupců) tabulky (seznamu). U každého pole je zobrazena zadána podmínka.

V dolní části je zobrazená podmínka pro akt. vybrané pole. Typ podmínky má tyto čtyři možnosti:

· Bez omezení - pole nemá žádné omezení. Díky tomuto filtru bude dané pole zobrazeno ve všech podobách, např. v poli Rodné číslo se zobrazí všechna rodná čísla.

· Bez zadané hodnoty - tuto podmínku splňují záznamy, které nemají v daném poli (sloupci) zadanou žádnou hodnotu.

· Libovolná neprázdná hodnota - tuto podmínku splňují záznamy, které mají v daném poli (sloupci) zadanou libovolnou neprázdnou hodnotu.

· Rozsah hodnot - pokud je zadán tento typ omezení, je potřeba zadat rozsah hodnot daného pole (sloupce), ve kterém hodnota daného sloupce musí být, aby záznam splnil podmínku. Zadaný rozsah nemusí být z obou stran ohraničený, tedy je možno zadat jen dolní nebo jen horní limit. Dolní limit rozsahu se zadává do pole Od a horní limit rozsahu se zadává do pole Do. Pokud je potřeba zadat více rozsahů nebo jen výčet jednotlivých hodnot splňující podmínku, je potřeba danou podmínku zapsat do pole Výčet.

Formát pole Výčet představuje řetězec možných hodnot oddělených středníkem. Možná hodnota může být buď jednoduchá hodnota (prvek omezení), nebo interval. Jednoduchá hodnota může být jakákoli hodnota vyhovující typu položky. Interval se skládá ze dvou prvků (hodnot) oddělených dvěma tečkami "..", pokud prvek (hodnota) na některé straně chybí, pak není interval na této straně omezen. Pro jednoduché hodnoty může být pro všechny typy použita konstanta NULL, která vyjadřuje, že hodnota dané položky může být i nedefinovaná (bez hodnoty). V intervalech by se konstanta NULL neměla vyskytovat.

Příklady výčtů pro pole různých typů:

PŘÍKLAD 1:

"2;5..10;20.." - číselné pole je omezeno na hodnoty 2, 5 až 10, a 20 a více.

PŘÍKLAD 2:

"Novák;Novotný" - textové pole je omezeno na hodnotu "Novák" a "Novotný"

PŘÍKLAD 3:

"..10;20" - číselné pole je omezeno na hodnotu menší rovno 10 a hodnotu 20

PŘÍKLAD 4:

"..23.8.1998" - datumové pole je omezeno na hodnotu data menší rovno 23.8.1998

PŘÍKLAD 5:

"10:30..12:00" - časové pole je omezeno na hodnotu času od 10:30 do 12:30

PŘÍKLAD 6:

"NULL;10" - číselné pole je omezeno na hodnotu 10 nebo nedefinovanou hodnotu

POZNÁMKA: Uvozovky (uvedené v příkladech) nejsou součástí textu zapsaného do pole Výčet, ty jsou jen v příkladech pro ohraničení textů.


Složitý filtr

Navigation: Ovládání programu > Seznam filtrů >

Složitý filtr

 Return to chapter overview

Složitý filtr (na záložce složitý filtr) slouží pro zadání složitějších omezujících podmínek záznamů, kde se jednotlivé podmínky vkládají do seznamů podmínek. Do seznamu podmínek se mohou vkládat další seznamy podmínek tak, že nastavení filtru tvoří hierarchickou strukturu podmínek. Pro každý seznam podmínek lze volit, zda podmínky v seznamu musí být splněny všechny nebo stačí splnit alespoň jednu podmínku, aby byl celý seznam jako podmínka splněn. Takto lze vytvořit jakýkoli logický výraz.

Ovladani seznam filtru podminky filtru slozity filtr

Celý složitý filtr zastřešuje hlavní seznam podmínek, do kterého se vkládají podmínky a další seznamy podmínek. U každého seznamu a podmínky je tlačítko pro vyvolání kontextového menu, přes které je možno provádět různé operace s daným seznamem nebo podmínkou. Tlačítka C_Sipka cervena dvojita vpravo, C_Sipka modra dvojita vpravo , C_Sipka ruzova dvojita vpravo, C_Sipka zluta dvojita vpravo a následující texty představují hlavičky seznamu, tlačítka C_Sipka modra vpravo, C_Sipka ruzova vpravo , C_Sipka zluta vpravo a následující texty představují podmínky, tlačítka C_Sipka modra plus vpravo , C_Sipka ruzova plus vpravo, C_Sipka zluta plus vpravo novou podmínku zadanou SQL výrazem.

Seznam podmínek:

Kontextové menu hlavičky seznamu podmínek C_Sipka cervena dvojita vpravo, C_Sipka modra dvojita vpravo , C_Sipka ruzova dvojita vpravo, C_Sipka zluta dvojita vpravo má tyto položky:

· Nová podmínka - vloží novou podmínku do aktuálního seznamu podmínek.

· Nová podmínka SQL výrazem - vloží do aktuálního seznamu novou podmínku, která se zadává formou logického výrazu jako podmínka WHERE klauzule SQL dotazu. Tato možnost zadání slouží pro definici složitých podmínek velmi pokročilým uživatelům se znalostí SQL jazyka a struktury databáze aplikace.

· Nový seznam podmínek - vloží do aktuálního seznamu nový seznam podmínek.

· Odstranit seznam - zruší aktuální seznam podmínek. Hlavní seznam podmínek obsahuje místo dané položky položku Odstranit vše, která zruší všechny podmínky v hlavním seznamu.

Další kontextové menu lze pro seznam podmínek vyvolat kliknutím na zvýrazněná slova v textu hlavičky seznamu podmínek. Toto kontextové menu umožňuje volit způsob splnění aktuálního seznamu jako podmínky. Kontextové menu má tyto položky:

· každá - určuje, že pro splnění seznamu musí být splněny všechny podmínky v seznamu.

· alespoň jedna - určuje, že pro splnění seznamu musí být splněna alespoň jedna podmínka v seznamu.

· žádná - určuje, že pro splnění seznamu nesmí být splněna žádná podmínka v seznamu. Pokud je splněna alespoň jedna podmínka v seznamu, pak seznam není jako podmínka splněn.

Podmínka:

Kontextové menu podmínky vyvolané přes úvodní tlačítko před podmínkou C_Sipka modra vpravo, C_Sipka ruzova vpravo , C_Sipka zluta vpravo obsahuje pouze položku odstranit podmínku, která umožňuje danou podmínku zrušit. Tělo podmínky se skládá ze tří částí, které jsou ohraničeny obdélníkem. Kliknutím na jednotlivé části podmínek lze vyvolat kontextová menu pro nastavení daných částí podmínek.

První část podmínky představuje pole tabulky, ke kterému bude nastavena logická podmínka. Druhá část podmínky představuje operátor, kterým se spolu s třetí částí podmínky, která představuje hodnotu, určuje omezení daného pole. Výběr operátorů podmínky je omezen podle typu daného pole. Hodnota v podmínce je rovněž omezena typem daného pole. To například znamená, že pokud pole představuje číselnou hodnotu, pak je možno do hodnoty v podmínce zadat jen číslo a ne libovolný text.

Podmínka SQL výrazem:

Kontextové menu podmínky vyvolané přes úvodní tlačítko před podmínkou C_Sipka modra plus vpravo , C_Sipka ruzova plus vpravo, C_Sipka zluta plus vpravo obsahuje pouze položku odstranit podmínku, která umožňuje SQL výraz zrušit.

POZNÁMKA: Možnost vytvoření podmínky SQL výrazem má pouze osoba přihlášená do aplikace jako správce.

Tělo podmínky se skládá z jedné části, která je ohraničena obdélníkem. Kliknutím na tuto část podmínky se vyvolá SQL editor pro nastavení podmínky.

Ovladani seznam filtru SQL editor

Přes tlačítko [image] otevřete seznam parametrů, ze kterého můžete použít nabízené parametry. Po vytvoření potřebných změn potvrďte tlačítkem [image].

POZNÁMKA: Vložení parametru umožňují jen vybrané browsery (seznamy) v programu.


Editor nastavení vzhledu

Navigation: Ovládání programu >

Editor nastavení vzhledu

 Return to chapter overview

Editor nastavení vzhledu slouží pro nastavení různých způsobů zobrazení sloupců a řádků v seznamu a otevřete jej pomocí tlačítka [image]. Editor nastavení vzhledu seznamu obsahuje také nastavení rychlých uživatelských filtrů.


Editor nastavení sloupců

Navigation: Ovládání programu > Editor nastavení vzhledu >

Editor nastavení sloupců

 Return to chapter overview

Editor nastavení sloupců slouží pro nastavení různých způsobů zobrazení sloupců v seznamu.

Ovladani editor nastaveni vzhledu nastaveni sloupcu

V horní části editoru je možno volit aktuální nastavení sloupců ze seznamu vytvořených nastavení. Aktuální nastavení je to nastavení, které bude editováno a při stisku tlačítka [image] bude aktivováno.

Nové - zobrazí dialog pro zadání názvu a vytvoření nového nastavení sloupců. Nově vytvořené nastavení sloupců bude nastaveno jako aktuální.

Přejmenovat - umožní změnu názvu aktuálního nastavení sloupců.

Zrušit - umožní zrušit aktuální nastavení sloupců. Pokud je zrušeno poslední nastavení sloupců, pak editor automaticky vytvoří implicitní nastavení sloupců.

OK - uzavře formulář editoru a aktivuje aktuální nastavení sloupců.

Storno - zruší naposledy provedené změny v aktuálním nastavení sloupců a uzavře formulář editoru.

V levé části editoru je seznam sloupců, pro které se nastavují různá nastavení v rámci akt. nastavení sloupců. Vedle seznamu sloupců, na pravé straně, je sada tlačítek C_Sipka seda dvojita nahoru, C_Sipka seda nahoru, C_Sipka seda dolu, C_Sipka seda dvojita dolu pomocí kterých lze upravovat pořadí sloupců v rámci aktuálního nastavení sloupců. Pod tlačítky pro úpravu pořadí sloupců jsou tlačítka pro nastavení zvolených sloupců jen pro čtení [image] a nastavení neviditelnosti sloupců [image]. Pokud má sloupec nastavenou volbu "jen pro čtení", nebo má nastavenou neviditelnost, pak jsou stejné ikony jako na tlačítkách zobrazeny v seznamu před názvem sloupce. Ikona volby "jen pro čtení" v červené barvě [image] znamená, že sloupec má v daném seznamu nastavenu volbu "jen pro čtení" natrvalo a nelze změnit. Pokud je u sloupce ikona volby "jen pro čtení" v zelené barvě [image] , znamená to, že sloupec je součástí primárního klíče dané tabulky a volba "jen pro čtení" je nastavena rovněž natrvalo a nelze ji změnit.

V prostřední části v sekci "Celý seznam" lze v rámci celého seznamu nastavovat, kliknutím na tlačítko [image], font titulků a font seznamu. V sekcích "Titulek" a "Sloupec" se nastavují vlastnosti titulků a sloupců aktuálně zvolených sloupců.

Tlačítko C_Obnovit implicitni nastaveni sloupcu slouží k obnovení implicitních hodnot aktuálního nastavení sloupců.


Editor nastavení řádků

Navigation: Ovládání programu > Editor nastavení vzhledu >

Editor nastavení řádků

 Return to chapter overview

V editoru nastavujete podmínky pro řádky a pro ně volíte barevné označení. Na základě nastavených podmínek řádků program postupně projde jejich seznam, a jestliže daný řádek vyhovuje podmínce, změní barvu řádku.

Ovladani editor nastaveni vzhledu nastaveni radku

Ve vrchní části editoru se zobrazí seznam vytvořených podmínek.

Ve střední části editoru jsou tlačítka, která slouží pro manipulaci se seznamem jednotlivých nastavení řádků:

 | Nové - zobrazí dialog pro zadání názvu a vytvoření nového nastavení řádků.
 | Zrušit - umožní zrušit aktuální nastavení řádků. Pokud je zrušeno poslední nastavení řádků, pak editor automaticky vytvoří implicitní nastavení řádků.
C_Sipka seda dvojita nahoru , C_Sipka seda nahoru , C_Sipka seda dolu , C_Sipka seda dvojita dolu | Šipky - pomocí těchto tlačítek upravíte pořadí řádků v rámci aktuálního nastavení řádků.
 | Načíst společné - načte společné nastavení řádků.
C_Ulozit pro vsechny | Uložit pro všechny - uloží nastavení pro všechny uživatele, kteří se do programu přihlásí.
 | Načíst nastavení ze souboru - načtete nastavení ze souboru např. v případě, že si necháte podmínku na zakázku vytvořit.
 | Uložit nastavení do souboru - uložíte aktuální nastavení do souboru.

Ve spodní části editoru nastavujete podmínky a omezení řádků:

· Popis - jednoduše popište nové nastavení.

· Ignorovat nastavení sloupců - zaškrtnutím políčka ignorujete nastavení sloupců. To znamená, že barevné označení se přednostně řídí podle řádku. Při opačném nastavení políčka se barevné označení (pokud je nastaveno) řídí podle sloupce.

· Omezení - zvolte omezení pro řádky.

o Všechny řádky - zatrhnutím políčka pracujete se všemi řádky. Nadefinované podmínky se vztahují na všechny řádky.

o Liché řádky - zatrhnutím políčka pracujete jen s lichými řádky. Nadefinované podmínky se vztahují na liché řádky.

o Sudé řádky - zatrhnutím políčka pracujete jen se sudými řádky. Nadefinované podmínky se vztahují na sudé řádky.

· Podmínka - zvolte typ podmínky.

o Bez podmínky - podmínku nedefinujete.

o Rozsah hodnot - z nabídky vyberte název sloupce. Ve vedlejším políčku doplňte rozsah hodnot, kterých se podmínka týká, například:

ž NULL - zobrazí řádky, které mají prázdné pole ve vybraném sloupci,

ž !NULL - zobrazí řádky, které nemají prázdné pole ve vybraném sloupci,

ž 1..5 - rozsah hodnot,

ž 1,5 - konkrétní hodnoty,

ž 1..5,8 - kombinace hodnot.

o Složitá podmínka - slouží pro zadání složitějších omezujících podmínek záznamů. Po zatrhnutí složité podmínky je možné použít tlačítko Otevřít vzorec editoru.

Otevřít vzorec v editoru - otevře se editor vzorce složité podmínky, ve kterém si pomocí operátorů a funkcí vytvoříte potřebný vzorec. Zda je napsaný vzorec korektní či nikoliv zjistíte tlačítkem [image]. Po zadání potřebných hodnot uložíte data tlačítkem [image].

Ovladani editor nastaveni vzhledu editor vzorcu

· Barva pozadí - zatrhněte políčko a stiskem tlačítka [image] vyberte barevné označení řádku. Tlačítko se zobrazí ve vybrané barvě.

· Barva textu - zatrhněte políčko a stiskem tlačítka [image] vyberte barevné označení textu. Tlačítko se zobrazí ve vybrané barvě.

OK - uzavře formulář editoru a aktivuje aktuální nastavení řádků.

Zrušit - zruší naposledy provedené změny v aktuálním nastavení řádků a uzavře formulář editoru.


Editor rychlých filtrů

Navigation: Ovládání programu > Editor nastavení vzhledu >

Editor rychlých filtrů

 Return to chapter overview

Nastavení rychlých filtrů slouží pro vytvoření ovládacích prvků pro zrychlený výběr (filtrování) dat v seznamu. Máte možnost vytvořit si následující ovládací prvky:

- zaškrtávací políčko (s „fajfkou“)

- pole pro zadání libovolného textu

- výběr hodnoty z databáze

- pole pro zadání kalendářního data

Ovladani editor nastaveni vzhledu rychle filtry seznam

Nový - pomocí tohoto tlačítka vytvoříte nový filtr.

Ovladani editor nastaveni vzhledu rychle filtry

· Kód - zadejte kód. Každý filtr musí mít jedinečný kód, který slouží jen k jeho identifikaci a nemá vliv na funkčnost.

· Podmínka - určuje pravidlo pro výběr záznamů. Text podmínky se použije v SQL výrazu pro výběr záznamů. Může obsahovat názvy jednotlivých databázových polí, která jsou dostupná v seznamu a SQL funkce. Kromě toho v něm mohou být použity parametry. Název parametru začíná vždy dvojtečkou a dále může obsahovat písmena anglické abecedy a čísla. Pro každý parametr se vytvoří ovládací prvek, kterým se nastavuje jeho hodnota. Jeden z parametrů může být použit ve výrazu vícekrát a může být použit i v různých filtrech. Po změně podmínky se nové parametry automaticky přidávají do seznamu parametrů.

· Parametry - v seznamu parametrů můžete měnit pořadí parametrů, přidávat a rušit parametry a především nastavovat typ a vlastnosti parametrů. Změna pořadí C_Sipka seda nahoru , C_Sipka seda dolu , přidání [image] a mazání [image] parametrů se provádí pomocí tlačítek vedle seznamu parametrů. Vlastnosti parametru se nastavují ve formuláři Nastavení parametru seznamu, které se zobrazí po dvojkliku na daný parametr. Nový parametr můžete vytvořit kliknutím na tlačítko [image] Nový parametr, kde zadáte kód nového parametru. Po potvrzení zadaného kódu se objeví formulář Nastavení parametru seznamu.

Ovladani editor nastaveni vzhledu rychle filtry formular parametru

· Kód parametru - při vytváření nového parametru zadáváte jeho kód.

· Typ - vyberte typ parametru. Na výběr máte z následujících:

o Text - pole pro zadání libovolného textu.

o Datum - pole pro zadání kalendářního data s možností výběru z kalendáře.

o Celé číslo - pole pro zadání čísla.

o Zaškrtávátko - zaškrtávací políčko s fajfkou. Parametr nabývá hodnot 0 nebo 1.

o Nový řádek - další parametr bude začínat na novém řádku.

o Oddělovač - (prázdné místo) zadejte šířku prázdného místa.

· Nadpis - nadpis filtru, např. Jen Okres. Nadpis se zobrazí u ovládacího prvku.

· Šířka - pokud máte zadán nadpis, můžete upravit také jeho šířku.

· SQL pro výběr - u parametrů typu text, datum a celé číslo můžete zadat SQL dotaz pro výběr hodnot. V takovém případě se hodnota parametru nebude zadávat přímo, ale bude se vybírat z roletky. SQL výraz musí obsahovat pole s názvem KOD a pole s názvem POPIS.

 | Nový - v seznamu vytvoříte nový záznam.
 | Zrušit - tlačítkem zrušíte dané nastavení vybraného záznamu.
C_Ulozit do souboru | Uložit do souboru - po načtení kliknete na tlačítko uložit.
C_Nacist ze souboru | Načíst ze souboru - načtete soubor obsahující nějaký seznam.
C_Ulozit pro vsechny | Uložit pro všechny - uloží současné nastavení pro všechny uživatele.
 | Načíst společné - načte společné nastavení uživatelů.
 | OK - tlačítkem potvrdíte nastavení.
 | Storno - tlačítkem uzavřete formulář.

PŘÍKLAD 1: (:FiltrovatNazevOd = 0 OR Mesto >= :NazevOd)

AND ( :FiltrovatNazevDo = 0 OR Mesto <= :NazevDo)

Parametry FiltrovatNazevOd a FiltrovatNazevOd jsou zaškrtávátka a parametry NazevOd a NazevDo jsou text. Tento filtr v seznamu měst umožní filtrovat města s názvem větším než NazevOd a menším než NazevDo.

PŘÍKLAD 2: FiltrovatOkres = 0 OR Okres = :okres

Parametr FiltrovatOkres je zaškrtávátko a parametr okres je text. Parametr okres má nastaven SQL výraz:

SELECT DISTINCT KodPosta AS Kod, Popis
FROM Okres ORDER BY Popis

Podmínka umožňuje vybírat jen města ze zvoleného okresu – zobrazí se roletka pro výběr okresu. U SQL výrazu je důležité, aby obsahoval pole KOD a POPIS. Pokud zdrojová databázová tabulka tato pole nemá, musí výraz obsahovat přejmenování pomocí klíčového slova AS.


Editor uzivatelskych sloupcu

Navigation: Ovládání programu > Editor nastavení vzhledu >

Editor uživatelských sloupců

 Return to chapter overview

Ve formuláři provedete nastavení uživatelských sloupců.

Ovladani editor nastaveni vzhledu uzivatelske sloupce

· Název - zadejte název uživatelského titulku.

· Titulek - vepište titulek nového sloupce.

· Aktivní - zaškrtnutím zvolte, zda je nastavení platné.

· Lookup SQL - může obsahovat názvy jednotlivých databázových polí, která jsou dostupná v seznamu a SQL funkce.

· Klíčová pole - zadejte jména polí seznamu, podle kterých se bude vyhledávat. Můžete zadat více polí oddělených středníkem.

· Klíč (lookup) - zadejte jména polí vyhledávací tabulky, podle kterých se bude vyhledávat. Jednotlivá pole musí odpovídat příslušným klíčovým polím ze seznamu.

· Výsledné pole - zadejte jméno pole vyhledávací tabulky, které bude zobrazeno.

 | Nový - v seznamu vytvoříte nový záznam.
 | Zrušit - tlačítkem zrušíte dané nastavení vybraného záznamu.
C_Ulozit do souboru | Uložit do souboru - tlačítko slouží pro uložení nastavení do souboru.
C_Nacist ze souboru | Načíst ze souboru - načtete soubor obsahující již vytvořený seznam.
C_Ulozit pro vsechny | Uložit pro všechny - uloží současné nastavení sloupců pro všechny uživatele.
 | Načíst společné - načte společné nastavení uživatelů.
 | Vložit parametr - tlačítkem se zobrazí okno, ve kterém můžete vybrat a vložit požadovaný parametr.
 | Test - tlačítkem otestujete nastavené parametry.
 | Ok - tlačítkem potvrdíte nastavení.
 | Storno - tlačítkem uzavřete formulář.


Tiskové sestavy

Navigation: Ovládání programu >

Tiskové sestavy

 Return to chapter overview

Tiskové sestavy slouží pro nastavení jednotlivých sestav pro dané seznamy a můžete je nadefinovat tak, aby co nejvíce odpovídaly vašim představám. Výsledek nastavení si můžete prohlédnout v náhledu nebo tisku této sestavy.

Seznam obsahuje tiskové sestavy definované uživateli pro daný seznam, nebo kategorii sestav v manažeru tiskových sestav. Jednotlivé sestavy můžete filtrovat podle toho, jestli jste sestavu vytvořili vy nebo jiný uživatel programu. Další možností je filtrování podle způsobu vytvoření sestavy, a to jestli jsou sestaveny sloupcově nebo editorově. Tiskové sestavy otevřete tlačítkem [image].

Ovladani tiskove sestavy

Vedle seznamu sestav lze provádět následující operace:

 | Nová - klávesová zkratka ALT+INS nebo F4. Otevře formulář pro výběr názvu sestavy a typu sestavy. Máte možnost vytvořit sestavu v editoru sestav nebo sloupcovou sestavu.
C_Nova z kopie | Nová z kopie - otevře formulář pro zápis nového záznamu do seznamu. Hodnoty položek nastaví podle záznamu, který byl v seznamu aktuálně označen. Vždy je nutné změnit alespoň klíčové položky, jinak nebude možné záznam zapsat kvůli duplicitě klíčové položky. Klávesová zkratka CTRL+K.
 | Editovat - otevře formulář s aktuálním záznamem pro editaci (změnu údajů). Klávesová zkratka CTRL+ENTER nebo F5. Pokud editujete sestavu vytvořenou v editoru sestav, potom se otevře FastReport, kde sestavu můžete editovat. Pokud editujete sestavu sloupcovou, potom se otevře formulář Editace sestavy. V editaci sestavy vyberete údaje, které chcete mít v sestavě. Ze sloupce Dostupná pole přesuňte požadovaná pole do Vybraných polí pomocí šipek [image] , C_Sipka dvojita vpravo , [image] , C_Sipka dvojita vlevo . Sami si můžete navrhnout vzhled titulků v sestavě, sloupců, stránky (velikost, okraje, číslování a datování stránek), nastavení sestavy či titulku celé sestavy.

Ovladani tiskove sestavy formular sloupcove sestavy

Přejmenovat - umožní přejmenovat aktuální tiskovou sestavu.

Zrušit - provede zrušení záznamu ze seznamu. Před zrušením se vždy zobrazí dotaz, zda opravdu chcete akci provést. Po potvrzení je tato akce nevratná. V mnoha případech jsou na zvolené položce závislé další údaje v databázi. Proto ne vždy program umožní položku smazat a oznámí, že záznam nelze odstranit, protože obsahuje související záznamy.

Náhled - zobrazí náhled dokumentu před tiskem. Můžete zobrazit více stránek najednou, zvětšit nebo zmenšit velikost stránky na obrazovce, kontrolovat konce stránek a provádět změny v textu i ve formátování.

Tisk - vytiskne aktivní vybrané položky.

Zobrazené - vytvoří tiskovou sestavu ze všech položek na aktuálním listu.

Vybrané - vytvoří tiskovou sestavu pouze u vybrané položky na aktuálním listu.

Načíst - zadejte cestu k načtení souboru s nastavením tiskových sestav.

Uložit - uloží aktuální tiskovou sestavu do vámi zadaného adresáře.

Zavřít - uzavře okno pro práci s tiskovými sestavami.


Seznam sestav pro export

Navigation: Ovládání programu >

Seznam sestav pro export

 Return to chapter overview

Seznam sestav pro export slouží pro nastavení exportů dat do Microsoft Word, Excel nebo jen do textového souboru. Tato data se poté dají dále zpracovávat. Exportní sestavy si můžete nadefinovat tak, aby co nejvíce odpovídaly vašim představám. Seznam sestav pro export obsahuje sestavy definované uživateli pro daný seznam, nebo kategorii sestav v manažeru sestav. Seznam sestav pro export otevřete tlačítkem [image].

Ovladani seznam sestav pro export

Vedle seznamu sestav lze provádět následující operace:

 | Nový - otevře formulář pro zápis nového záznamu do seznamu. Klávesová zkratka ALT+INS nebo F4.
C_Novy z kopie | Nový z kopie - otevře formulář pro zápis nového záznamu do seznamu. Hodnoty položek nastaví podle záznamu, který byl v seznamu aktuálně označen. Vždy je nutné změnit alespoň klíčové položky, jinak nebude možné záznam zapsat kvůli duplicitě klíčové položky. Klávesová zkratka CTRL+K.
 | Editovat - otevře formulář s aktuálním záznamem pro editaci (změnu údajů). Klávesová zkratka CTRL+ENTER nebo F5.

V editaci sestavy vyberete údaje, které chcete mít v sestavě. Ze sloupce Dostupná pole přesuňte požadovaná pole do Vybraných polí pomocí šipek [image] , C_Sipka dvojita vpravo, [image], C_Sipka dvojita vlevo. Dále si můžete vybrat, jaký formát sestavy pro export chcete: Microsoft Word, Microsoft Excel nebo Textový soubor. Vybraný formát máte možnost nastavit dle vašich požadavků. Definovanou sestavu můžete ihned exportovat do požadovaného formátu přes tlačítko [image] ve formuláři Editace sestavy nebo můžete sestavu [image] a podle potřeby exportovat z formuláře Manažer výstupních sestav.

Ovladani seznam sestav pro export formular exportni sestavy

Přejmenovat - umožní přejmenovat aktuální tiskovou sestavu.

Zrušit - provede zrušení záznamu ze seznamu. Před zrušením se vždy zobrazí dotaz, zda opravdu chcete akci provést. Po potvrzení je tato akce nevratná. V mnoha případech jsou na zvolené položce závislé další údaje v databázi. Proto ne vždy program umožní položku smazat a oznámí, že záznam nelze odstranit, protože obsahuje související záznamy.

Export - provede export aktuálně vybrané sestavy do vybraného formátu pro export (Word, Excel, Textový soubor).

Zobrazené - vytvoří tiskovou sestavu ze všech položek na aktuálním listu.

Vybrané - vytvoří tiskovou sestavu pouze u vybrané položky na aktuálním listu.

Zavřít - uzavře okno pro práci s tiskovými sestavami.

· Jen vlastní - po zatrhnutí pole se zobrazí jen sestavy, které byly vytvořeny uživatelem.


Systém

Navigation: »No topics above this level«

Systém

 Return to chapter overview

Menu Systém, které se nachází na hlavní liště, je velice důležitým prvkem programu pro uživatele i pro správce sítě:

 | Výběr období... |
 | Variabilní období |
 | Nastavení | Sipka doprava seznamy
 | Import/Export | Sipka doprava seznamy
 | Multilicence |
 | Správa databáze | Sipka doprava seznamy
 | Seznam počítačů připojených k databázi |
Fajfka | Stavový řádek |
Fajfka | Rychlé menu Ctrl+Q |
Fajfka | Plovoucí nápověda |
 | Konec Alt+F4 |

Pokud v menu "Systém/Správa databáze/Nastavení zabezpečení" zvolíte možnost Zabezpečení heslem, popřípadě Zabezpečení systémem uživatelů a práv, rozšíří se nabídka menu Systém o položky Změna hesla uživatele a Přihlášení jiného uživatele.


Výběr období

Navigation: Systém >

Výběr období

 Return to chapter overview

Systém standardně pracuje v měsíčním režimu zpracování dat. Nastavení období provedete v menu Systém/Výběr období. Zobrazí se seznam již založených období v systému. Pokud jste založili novou databázi, je seznam prázdný. Základní časovou jednotkou programu, podle které pracuje, je jeden měsíc. V seznamu období nemůžete mazat ani upravovat data období. Vytváření dalšího období automaticky vytvoří další měsíc. Nemáte tedy možnost se vrátit zpět nebo nějaké období vynechat.

Seznam Vyber obdobi

Formulář obsahuje v levé části seznam všech vytvořených období a na pravé straně tlačítka pro práci s nimi. Vámi požadované období si zvolíte kliknutím na řádek s obdobím a tlačítkem [image] volbu potvrdíte. Tlačítko [image] uzavře formulář a ponechá aktivováno stávající období. Tlačítko [image] vám otevře dané období. Tlačítko [image] jej naopak uzavře.

V levé části nad seznamem období najdete přepínání obsahu na Všechna období a Aktuální rok. Zvolíte-li všechna období, zobrazí se historie všech dříve vytvořených období. Zvolíte-li aktuální rok, budou se vám pro přehlednost zobrazovat pouze období aktuálního roku, která korespondují s daty v počítači.

Vytvoření prvního období:

Stiskněte tlačítko [image] Nový záznam v horní části seznamu období. Máte možnost zadat počátek a konec prvního období. Standardně Vám program nabídne aktuální měsíc. Pokud vše souhlasí, klikněte [image].

POZOR: Buďte opatrní při zakládání prvního období. Pokud špatně zvolíte první období, nemůže to již změnit!

Vytvoření dalšího období:

Pro vytvoření dalšího období používáte stejnou volbu jako u období prvního ovšem bez možnosti zadat datum období. Systém automaticky vytvoří následující měsíc k poslednímu evidovanému měsíci.

Výběr období:

Pro práci musíte mít vybráno aktuální období, se kterým chcete pracovat. Označte zvolené období a stiskněte tlačítko [image]. Volba období má vliv na zobrazení dat. Zobrazují se vždy data vybraného období.

Uzavření a otevření období:

V uzavřeném období není možné provádět úpravy dat. Pokud jsou data zpracovaná, proveďte uzavření období. Jedná se o bezpečnostní opatření zajišťující, že nikdo neprovede zpětně úpravy dat. Tato operace není nevratná, takže se nemusíte bát období uzavřít tlačítkem [image]. Pokud jste provedli uzavření a zjistíte, že musíte provést ještě nějaké úpravy, můžete jednoduše použít tlačítko [image] pro otevření období. Pokud chcete mít data pod kontrolou, můžete nastavit přístupová práva k možnostem otevírání a uzavírání období tak, aby tyto operace mohl provádět pouze oprávněný uživatel.

POZOR: Nezavírejte období za obdobím, které zpracováváte (např. zpracováváte září a následující vytvořená období jsou říjen, listopad a prosinec. Ta období NESMÍ být uzavřena).


Variabilní období

Navigation: Systém >

Variabilní období

 Return to chapter overview

Docházkový systém umožňuje pracovat také v jiných obdobích, než jsou kalendářní měsíce. Je tedy možné sledovat docházku za týden, 10 dní, ve 4týdenních cyklech, apod.

Seznam variabilních období umožňuje prohlížet a vytvářet nová variabilní období, která si uživatel definuje sám. Počátek a interval variabilních období je možno definovat ve formuláři nastavení aplikace na záložce Období. Výsledky a sestavy lze prohlížet a tisknout v manažeru výstupních sestav - variabilní období.

Vkládání údajů neprovádějte v seznamu, ale otevřete si tlačítkem Novy zaznam Nový záznam formulář Variabilní období.

· Délka období - délka variabilního období (např. 7 dnů, 14 dnů, 28 dnů). Položka se vyplňuje ve Společném nastavení/Období. Délku období je možné změnit na období, která ještě nejsou vytvořena v seznamu variabilních období.

· Datum prvního období - položka se vyplňuje v Nastavení aplikace/Společné nastavení/Období. Po vytvoření prvního období není změna počátku možná.

· Vytvořit nová období do data - zadejte datum, do kterého se mají vytvořit nová variabilní období.


Nastavení

Navigation: Systém >

Nastavení

 Return to chapter overview

Program Docházky umožňuje nastavení aplikace. Menu obsahuje tyto položky:

Nastavení aplikace...

Nastavení plánovače úloh...

Nastavení intrawebu...

Nastavení mobilního klienta


Nastavení aplikace

Navigation: Systém > Nastavení >

Nastavení aplikace

 Return to chapter overview

Hodnoty, které nastavíte v tomto nastavení, jsou shodné pro celou aplikaci.

Rozděleny jsou do několika částí podle logické příslušnosti.

Uživatelská nastavení

Vlastnosti formulářů

Lokální nastavení

Načítání ID média

Nastavení vrátnice pro evidenci návštěv

Společné nastavení

Období

Pracovní poměry

ID média

Uchovávání záznamů

Rozdělení docházky

Terminály

Stavy terminálů

Operace terminálu

Zpracování původní docházky

Generování přestávek

Editace docházky

Schvalování docházky

Generování salda

Monitorování

Export

Import

Evidence výroby

Zpracování výroby

Uživatelská pole osob

Seznam pracovních poměrů

Nastavení mzdových položek

Přehled příchodů a odchodů

Evidence návštěv

Služební cesty

Schvalování služebních cest

Kalendáře

Plánování kapacit

Plánování kapacit 2

Active directory

XML formuláře

Nastavení sestav

Výkaz odpracovaných směn (Grafický)

Výkaz odpracovaných směn (Textový)

Výkaz pro mzdové oddělení


Uživatelské nastavení

Navigation: Systém > Nastavení > Nastavení aplikace >

Uživatelské nastavení

 Return to chapter overview

Otevřením Uživatelského nastavení se vám zobrazí sdělení o tom, že uživatelské nastavení je ukládáno do databáze pro každého uživatele zvlášť.


Vlastnosti formulářů

Navigation: Systém > Nastavení > Nastavení aplikace > Uživatelské nastavení >

Vlastnosti formulářů

 Return to chapter overview

· Dotazy při přesunu mezi dvěma seznamy - pro názorné zobrazení dat je použito zobrazení dvou seznamů, mezi kterými můžete položky přesouvat (zleva doprava a zpět). Většinou se jedná o zobrazení všech položek seznamu v jednom okně a v druhém okně jsou vybrané položky z tohoto seznamu. Pro přesun mezi těmito seznamy, použijte tlačítko se šipkou umístěné uprostřed mezi seznamy nebo pomocí chycení dané položky a přetáhnutím do druhého seznamu. Pokud chcete přesunout všechny položky, stiskněte dvojitou šipku mezi seznamy. Šipky vždy názorně ukazují směr přesunu položek.

Pokud tuto volbu vypnete, nebude se program ptát, jestli má změnu skutečně provést a hned ji provede. Volba nastavení aplikace je zcela na vás. Při zapnuté volbě jsou všechny přesuny potvrzovány, a tudíž zabráníte nechtěným přesunům. Nevýhodou pro některé uživatele může být potřeba neustálého potvrzování přesunu kontrolním dotazem.

· Vypnout hlášení při editaci docházky - funkce se vztahuje pouze na editaci docházky. Pokud tuto volbu zapnete, nebude se program ptát, jestli má změněnou skutečnost provést a hned ji provede. Při vypnuté volbě jsou všechny přesuny potvrzovány, a tudíž zabráníte nechtěným úpravám v editaci docházky.

· Změnit časy při změně směny v editaci záznamu docházky - funkce automaticky změní čas počátku a konce směny v případě, že změníte směnu při editaci záznamu docházky.


Lokální nastavení

Navigation: Systém > Nastavení > Nastavení aplikace >

Lokální nastavení

 Return to chapter overview

Otevřením Lokálního nastavení se Vám ukáže sdělení o tom, že lokální nastavení se týká pouze počítače, na kterém je aplikace spuštěna, a je ukládána na lokální disk do adresáře Windows.


Načítání ID média

Navigation: Systém > Nastavení > Nastavení aplikace > Lokální nastavení >

Načítání ID média

 Return to chapter overview

Některé typy terminálů umožňují načítání čísla identifikačního média do seznamu identifikačních médií. Tato možnost je vhodná ve chvíli, kdy potřebujete do seznamu médií zapsat nová média, která jste k systému dostali nebo koupili.

Ze seznamu vyberte terminál pro načítání kódu ve formuláři ID média. Ten definujete v menu Terminály/Terminály.

Lokalni nastaveni nacitani ID media


Nastavení vrátnice pro evidenci návštěv

Navigation: Systém > Nastavení > Nastavení aplikace > Lokální nastavení >

Nastavení vrátnice pro evidenci návštěv

 Return to chapter overview

V tomto formuláři si můžete nastavit typ rozdělení a rozdělení, například Vrátnice 1 pro počítač, ze kterého je docházka spuštěna. To znamená, že každý počítač může mít své vlastní nastavení. Toto rozdělení se automaticky doplní při zadání nové návštěvy.

Lokalni nastaveni_Nastaveni vratnice pro evidenci navstev


Společné nastavení

Navigation: Systém > Nastavení > Nastavení aplikace >

Společné nastavení

 Return to chapter overview

Otevřením Společného nastavení se Vám ukáže sdělení o tom, že společné nastavení je ukládáno do databáze a je pro všechny uživatele společné.


Období

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Období

 Return to chapter overview

· První položka určuje, zda se bude při vytváření nového období (měsíce) automaticky vytvářet kopie směn podle nastavení v průvodci. Pokud chcete toto nastavení účelně využít, musíte mít nastaveny průvodce u všech kalendářů. Standardně nechávejte položku zapnutou a nastavte si průvodce v kalendářích.

· Svátky nastavovat podle země - vyberte zemi, podle které se budou v programu nastavovat svátky (Česká republika nebo Slovensko).

· Omezit počet zobrazených období standardním uživatelům (uživatelům, kteří nejsou správci) - pokud chcete uživatelům, kteří nemají v zabezpečení aplikace zatrženo pole správce, omezit počet zobrazených období, zatrhněte pole a pokračujte následující položkou:

· Počet zobrazených posledních období - nastavte počet období. Uživatelé potom mohou přepínat jen do nastaveného počtu posledních vytvořených období. Stejně i v editaci docházky.

· Používat uživatelsky definované období - volba určuje, zda se budou výsledky docházky počítat i v uživatelem definovaných obdobích. Jednotlivá období je pak možno vytvářet v seznamu variabilních období. Výsledky výpočtu docházky v rámci variabilních období je možno prohlížet a tisknout v manažeru výstupních sestav - variabilní období. Pokud je tato volba aktivována, pak je nutno zadat počáteční datum variabilních období a délku variabilního období (např. 7 dnů, 14dnů, 28 dnů). Důležitým bodem pro toto nastavení je datum počátku období. Pozdější změna totiž nebude možná. Pokud používáte variabilní období, potom při vytváření měsíčního období jsou vytvářena i variabilní období, která zasahují do daného měsíčního období (i automaticky ve službě v plánovači úloh).


Pracovní poměry

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Pracovní poměry

 Return to chapter overview

Toto nastavení umožňuje při zaškrtnutí daných polí v nastavení:

· Kontrolovat duplicitu osobních čísel - při zadávání zaměstnance do systému bude kontrolovat, zda je zadávané osobní číslo jedinečné. Při zapsání stejného čísla vás program upozorní "Toto osobní číslo je již použito. Povolit uložení duplicitního osobního čísla?". Dotaz můžete potvrdit tlačítkem ANO nebo odmítnout tlačítkem NE a osobní číslo přepsat na jiné.

· Ukončovat rozdělení dle pracovního poměru, Ukončovat kalendář dle pracovního poměru, Ukončovat ID médium dle pracovního poměru, Ukončovat pracovní místo dle pracovního poměru - v případě označení těchto možností se vše automaticky ukončí okamžikem ukončení pracovního poměru (zadáním data výstupu do karty zaměstnance).

POZNÁMKA: Pracovní místa jsou viditelná pokud je aktivní modul "XML šablony".

TIP: Pokud v aplikaci nebudete mít označenou volbu "Ukončovat kalendář dle pracovního poměru" - pracovní poměr se sice ukončí, ale kalendář zůstane přiřazen. Umožní to zpracování docházky i u zaměstnance, který např. ukončil pracovní poměr v průběhu měsíce.

· Automaticky číslovat osobní čísla zaměstnanců - po zaškrtnutí této volby a na základě nastavení se při vytvoření nového zaměstnance/pracovního poměru automaticky doplní osobní číslo.

o Maska osobního čísla - maska osobního čísla je ve formátu <Prefix> <numerická část> <postfix>. Prefix a postfix jsou pevné části osobního čísla. Numerická část je určena opakováním znaku #. Počet znaků # určuje velikost numerické části osobního čísla. Příklad masky: OS###, ####ZAM, ZAM###A1.

o Osobní číslo od - do - napište počáteční a koncové číslo řady (například 1 až 9999). Počet číslic musí být shodný s počtem zadaných křížků.

· Automaticky číslovat osobní čísla externích osob -po zaškrtnutí této volby a na základě nastavení se při vytvoření nového externí osoby automaticky doplní osobní číslo.

o Maska osobního čísla - maska osobního čísla je ve formátu <Prefix> <numerická část> <postfix>. Prefix a postfix jsou pevné části osobního čísla. Numerická část je určena opakováním znaku #. Počet znaků # určuje velikost numerické části osobního čísla. Příklad masky: EX###, ####EXT, EXT###B1.

o Osobní číslo od - do - napište počáteční a koncové číslo řady (například 1 až 9999). Počet číslic musí být shodný s počtem zadaných křížků.


ID média

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

ID média

 Return to chapter overview

Funkci využijete hlavně, pokud jste nuceni používat více druhů identifikačních médií, nebo pokud přecházíte z jednoho druhu médií na druhý a je tedy nutné používat více kódů identifikačních médií.

ID media spolecne nastaveni ID media

· Povolit zaměstnancům přiřazení více ID médií - pokud aktivujete tuto funkci, pak můžete přiřadit zaměstnancům více ID médií. V opačném případě aplikace odmítne přiřadit další ID médium s hláškou "Nelze přiřadit identifikační médium, dokud je platné jiné přiřazení", pokud již má jedno přiřazeno.

· Používat 2 kódy ID média - pokud kolonku zaškrtnete, pak v liště Terminály/Identifikační média ve formuláři Identifikační médium se zobrazí k vyplnění dvě kolonky pro vyplnění kódu.

ID media terminaly ID media identifikacni medium formular zaznamu

Více o identifikačních médiích v kapitole Identifikační média.


Uchovávání záznamů

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Uchovávání záznamů

 Return to chapter overview

Data jsou v databázi ukládána v souvislém bloku tak, aby bylo možné zpracovat statistiky za libovolné souvislé období. Jelikož po určité době se stará data již nepoužívají a databáze se zvětšuje, je potřebné staré záznamy zrušit.

Před zrušením starých dat zajistěte zálohování databáze tak, abyste mohli v případě potřeby tato data ze zálohy obnovit.

V nastavovaných položkách zadejte počet měsíců. Po tuto dobu se data uchovávají. Záznamy se ruší na pokyn uživatele v menu Docházka\Zrušení zpracované docházky.


Rozdělení docházky

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Rozdělení docházky

 Return to chapter overview

Pomocí rozdělení docházky můžete sledovat kolik odpracovaných a neodpracovaných hodin zaměstnanec strávil na jednotlivém rozdělení.

· Používat rozdělení docházky – pokud tuto funkci chcete používat, je ji potřeba zaškrtnout.

· Používat rozlišení docházky v sestavách – zaškrtněte, pokud chcete použít rozdělení docházky v sestavách.

· Automaticky vkládat rozdělení docházky podle rozdělení původní docházky - pokud je tato volba zapnutá, pak se při zpracování docházky vkládá rozdělení docházky podle rozdělení nastaveného v záznamu původní docházky. Tuto volbu je možno kombinovat s ostatními volbami vkládání rozdělení docházky.

· Automaticky vkládat rozdělení docházky podle přiřazení zaměstnance na rozdělení - tato volba bude automaticky vkládat rozdělení do původní docházky podle aktuálního přiřazeného rozdělení zaměstnance z vybraných typů rozdělení.

· Automaticky vkládat rozdělení docházky podle přiřazení rozdělení v plánování kapacit - tato volba určuje, zda se bude při zpracování docházky automaticky vkládat rozdělení do původní docházky podle přiřazeného rozdělení u daného dne v plánování kapacit. Pokud u daného dne v plánování kapacit nebude nastaveno rozdělení, pak se vkládat rozdělení docházky pro daný den nebude.

· Automaticky vkládat rozdělení docházky podle nastaveného rozdělení u terminálu v záznamu původní docházky - tato volba bude automaticky vkládat rozdělení do původní docházky podle vybraného rozdělení v nastavení terminálu.

o Vkládat podle rozdělení u terminálu jen v případě, že je odlišné od přiřazeného rozdělení zaměstnance - tato volba automaticky vkládá rozdělení do původní docházky, ale jen tehdy, pokud bude u zaměstnance a v nastavení terminálu rozdílné rozdělení.

o Pokud terminál nemá rozdělení, nebo záznam původní docházky nemá terminál, pak se vloží podle přiřazení zaměstnance - tato volba automaticky vkládá rozdělení do původní docházky podle přiřazení zaměstnance, pokud terminál nemá rozdělení, nebo záznam původní docházky nemá terminál.

· Automaticky vkládat rozdělení docházky podle nastaveného rozdělení u operace terminálu podle záznamu původní docházky - tato volba bude automaticky vkládat rozdělení do původní docházky podle vybraného rozdělení u operace terminálu.

o Vkládat podle rozdělení u operace terminálu jen v případě, že je odlišné od přiřazeného rozdělení zaměstnance - tato volba automaticky vkládá rozdělení do původní docházky, ale jen tehdy, pokud bude u zaměstnance a u operace terminálu rozdílné rozdělení.

o Pokud operace terminálu nemá rozdělení, nebo záznam původní docházky nemá terminál pak se vloží podle přiřazení zaměstnance - tato volba automaticky vkládá rozdělení do původní docházky podle přiřazení zaměstnance, pokud operace terminálu nemá rozdělení, nebo záznam původní docházky nemá terminál.

· Dostupné rozdělení - seznam všech dostupných rozdělení, které lze používat.

· Používané rozdělení - vybrané typy rozdělení, které se budou vkládat do docházky.

Tip: Dostupné rozdělení - hodnoty do tohoto seznamu naplníte v seznamech typů rozdělení.


Terminály

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Terminály

 Return to chapter overview

Hromadně přiřazuje terminálům vybraný typ rozdělení.


Stavy terminálů

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Stavy terminálů

 Return to chapter overview

Zapnutím funkce Hlásit nefunkčnost terminálů se bude systém, po zjištění závady na terminálu, automaticky pokoušet o znovu načtení docházky nebo o nastavení terminálů. Můžete si nastavit počet opakování těchto akcí. Program je schopen tyto chyby hlásit při přihlášení jen určitého uživatele např. správce systému, tomu jsou poté zasílány chybová hlášení terminálu.

Pokud chcete hlásit chyby emailem, musíte mít tuto položku aktivovanou a vyplněny tyto údaje: SMTP server, Uživatel, Heslo, a emailovou adresu, na kterou chcete tyto zprávy zasílat. Máte-li tyto údaje vyplněny je výhodné si je ověřit kliknutím na tlačítko [image] Test pošty. V případě, že jste zadali správné údaje, bude vám na vaši emailovou adresu zaslána potvrzující zpráva.


Operace terminálu

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Operace terminálu

 Return to chapter overview

Ve formuláři máte možnost zvolit rozdělení pro přiřazení operací. Rozdělení operaci přiřadíte v menu Terminály -> Operace terminálů -> Formulář vybrané operace -> Záložka Rozdělení.


Zpracování původní docházky

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Zpracování původní docházky

 Return to chapter overview

Zpracovani puvodni dochazky

· Max. délka záznamu zpracované docházky - v tomto nastavení zadejte maximální délku souvislého trvání jedné operace. Standardně je nastavena hodnota na 1 den. Pokud operace trvá déle, než je nastavená hodnota program provede automaticky ukončení této operace. Zadávejte hodnotu vždy ve dnech a hodinách. Hlavní využití je v případě, že zaměstnanec neprovede ukončení docházky a po dobu několika dnů se neobjeví v práci. Pokud by tato hodnota nebyla nastavena, bude systém interval neustále prodlužovat.

· Počet dnů pro zpětné zpracování - pokud je nastavená hodnota větší než 0, je při automatickém nebo hromadném zpracování původní docházky zpracován zadaný počet dnů zpět. Pokud v těchto dnech existuje ručně editovaný záznam, pak je docházka zpracována od konce posledního ručně zpracovávaného období. Toto nastavení je určeno pro řešení problémů s doplněním chybějících dat stažených z terminálů po zpracování docházky.

· Počítat omezení časových složek mzdy - systém umožňuje sledovat časové složky, které jsou uvedeny v Kalendáři v sekci Omezení. Tato funkce aktivuje sledování omezení časových složek.

· Zaokrouhlovat výsledky vzorců výpočtu podle nastavení zaokrouhlení ve vlastnostech časových složek mzdy - všechny vzorce zadané v časových složkách se budou zaokrouhlovat na základě nastavení zaokrouhlení časové složky, ve které je vzorec vložen.

· Operace ukončení absence / služební cesty - pokud používáte plánovaní absencí / služebních cest, je potřeba vybrat operaci odchod, aby byla plánovaná absence správně ukončena.


Generování přestávek

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Generování přestávek

 Return to chapter overview

Automatické vkládání přestávek se může provádět v několika situacích:

· Generovat přestávky při výpočtu docházky - pokud tuto volbu zaškrtnete, bude program automaticky při spuštění funkce zpracování původní docházky vkládat přestávky podle pravidel definovaných pro danou směnu.

· Generovat přestávky při výpočtu docházky v editaci - tato volba umožňuje automatické vkládání přestávek, pokud provádíte změny ve formuláři editace docházky. Pokud tuto volbu nezapnete, musíte použít tlačítko "Přestávky", které takto na povel vložení přestávek provede.

· Negenerovat přestávky na konci směny - v případě, že vychází vložení přestávky na konec směny, můžete touto volbou vypnout vložení této přestávky - i v případě, že zaměstnanec tím překročí maximální interval odpracované doby pro vložení přestávky.


Editace docházky

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Editace docházky

 Return to chapter overview

Tato nastavení se týkají chování programu ve formuláři Editace zpracované docházky.

· Povolit přepočet výsledků schválené docházky - pokud je tato volba aktivována, je možno přepočítávat výsledky zpracované docházky i když je v daném období již schválena (zpracována, kontrolována, schválena, zpracována ve mzdách).

· Povolit editaci docházky schválené nižší úrovní schvalování - pokud je tato volba aktivní, pak může uživatel editovat docházku ve dnech, které jsou schváleny nižší úrovní schválení než na jakou nejvyšší úroveň má právo. Tuto volbu je možno aktivovat, pokud je aktivní volba Povolit přepočet výsledků schválené docházky.

· Přepisovat záznamy docházky - zapnutí této volby vám umožní vložit nový interval docházky doprostřed již existujícího záznamu. Existující záznam se rozdělí vloženým intervalem na dvě části. Pokud tuto volbu nemáte zapnutou, není možné záznamy časově překrývat.

· Zapisovat uživatele jen při změně času v záznamu zpracované docházky – pokud uživatel přihlášený do programu provede změny v časových složkách zpracovávané docházky (např. manuálně upraví délku směny), jeho jméno se automaticky uloží do seznamu původní docházky pro aktuálního zaměstnance, u kterého byla změna prováděna. Pokud však uživatel, upravuje pouze operaci v daném časovém období (např. mění příchod za absenci, atp.), zůstává tato změna bez jakéhokoliv záznamu.

· Uzamknout měsíční výsledky při schválení úrovně – uzamkne měsíční výsledky, pokud schvalování dosáhne určité schvalovací úrovně (zpracováno, zkontrolováno, schváleno). Po uzamčení již není možnost výsledky jakkoliv měnit.

· Uzamknout mzdové položky při schválení úrovně - uzamkne mzdové položky, pokud schvalování dosáhne určité schvalovací úrovně (zpracováno, zkontrolováno, schváleno). Po uzamčení již není možnost výsledky jakkoliv měnit.

· Zakázat editaci docházky do budoucnosti - volba umožňuje zakázat editaci docházky, která je zpracována do budoucnosti. Nastavte požadovaný posun dnů od aktuálního data.

· Typ přiřazeného rozdělení zaměstnance pro zobrazení v seznamu pro editaci docházky - po nastavení typu rozdělení (mzdové středisko, personální středisko, skupina) je potom toto rozdělení zobrazováno u zaměstnance v seznamu zaměstnanců pro editaci docházky.

· Povolit uživatelské nastavení zobrazení denních a měsíčních výsledků - pokud má uživatel nastaveno právo nastavovat zobrazení denních a měsíčních výsledků v editaci docházky, pak stiskem klávesy Ctrl+Alt+D může zobrazit formulář nastavení zobrazení denních výsledků a stiskem klávesy Ctrl+Alt+M může zobrazit formulář nastavení zobrazení měsíčních výsledků.

· Graficky zobrazit počátek a konec směny - pokud zvolíte tento údaj, pak v editaci zpracované docházky bude svislou čárkou označen počátek a konec pracovní doby dle kalendáře.

· Graficky zobrazit počátek a konec pevného jádra směny - pokud zvolíte tento údaj, pak v editaci zpracované docházky bude svislou čárkou označen počátek a konec pevného jádra.

· Zobrazit součty denních výsledků v záhlaví - pokud zatrhnete tento údaj, potom v editaci zpracované docházky se pod nadpisem jednotlivých sloupců zobrazí součty denních výsledků.

Druhá část nastavení umožňuje zvolit, jak se budou zobrazovat Nastavení zobrazení denních výsledků v editaci docházky. Předmětem tohoto nastavení je rozhodnutí, které sloupce chcete zobrazit ve formuláři editace docházky. Takto nastavené mzdové složky se budou zobrazovat jako sloupce denních součtů v editaci docházky se součtem za celý měsíc. Počet sloupců v editaci docházky není omezen. Formulář můžete zobrazit i přímo v editaci docházky stiskem kláves Ctrl + Alt + D.

Editace dochazky nastaveni zobrazeni dennich vysledku

Potřebujete-li sledovat ve formuláři Editace zpracované docházky měsíční výsledek nějaké časové složky (např. dovolené), pak musíte mít v aplikaci nastaveno Nastavení zobrazení měsíčních výsledků v editaci docházky. Zde si zvolíte typ (číselný kód) a název časové složky. Formulář můžete zobrazit i přímo v editaci docházky stiskem kláves Ctrl + Alt + M.

Editace dochazky nastaveni zobrazeni mesicnich vysledku


Schvalování docházky

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Schvalování docházky

 Return to chapter overview

Schvalování docházky použijete v případě, že ve vaší firmě jsou definovány pravomoci pro schvalování údajů a existuje hierarchie tohoto schvalování.

· Dodržovat časovou hierarchii při schválení docházky - je-li tato volba zaškrtnuta, bude program vyžadovat posloupnost schválení, tj. po schválení docházky první úrovní musí následovat úroveň druhá. Není možné jednotlivé úrovně přeskakovat.

· Názvy úrovní schválení - jednotlivé úrovně si můžete pojmenovat dle vašich požadavků, standardně jsou zde nastaveny tyto:

o 1. úroveň - zpracováno

o 2. úroveň - zkontrolováno

o 3. úroveň - schváleno

· Používat schvalování absencí - přestože nemáte potřebu dodržovat časovou hierarchii, můžete použít schvalování absencí. Znamená to, že nemusíte schvalovat absenci v pořadí 1. až 3. úroveň, ale můžete se ve schvalování "předbíhat".


Generování salda

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Generování salda

 Return to chapter overview

Saldo odpracované doby vyjadřuje rozdíl mezi normou stanovenou kalendářem a skutečnou odpracovanou dobou vypočtenou ze záznamů docházky. Abyste mohli saldo zjistit, musíte mít provedeno zpracování docházky. Saldo je zajímavé hlavně pro zaměstnance, kteří chtějí v průběhu měsíce zjišťovat stav svých odpracovaných hodin.

Většina druhů terminálů podporuje zjišťování salda odpracované doby na terminálu. Jestli to umí váš terminál, zjistíte v popisu k tomuto terminálu.

Pokud máte nastaveno automatické denní zpracování docházky a generování salda, došlo by hned první den v měsíci k přepsání výsledného salda za předchozí měsíc. Pokud tedy chcete nechat výsledné saldo zaměstnancům k dispozici na terminálech delší dobu, zadejte, který den v následujícím měsíci se poprvé vygeneruje nové saldo pro aktuální (nový) měsíc.

· První saldo v měsíci zpracovávat - zadejte pořadí dne v měsíci, kdy bude v terminálech přepsáno saldo předchozího měsíce hodnotou aktuálního měsíce.

· Typ časové složky pro saldo - standardně se pod pojmem saldo používá hodnota "Přesčas". Je to rozdíl mezi odpracovanou dobou a normou definovanou kalendářem. Pokud se však rozhodnete zobrazovat na terminálu jinou časovou složku (např. odpracovanou dobu) nastavte tuto časovou složku.

· Generovat saldo z výsledků za variabilní období - tato volba je závislá na uživatelsky definovaném období, proto jestli tuto volbu nemáte nadefinovanou, je zapínání této funkce zcela zbytečné. Pokud však máte toto období nastavené, bude se zobrazovat saldo jen za toto období.

TIP: Je-li období zadáno po 7 dnech, tak vždy v pondělí se do terminálu zašle saldo 0.

Pro správnou funkci musíte mít správně nastaveny vlastnosti terminálů.

Generování salda můžete přidat do seznamu plánovaných úloh v plánovači úloh.

POZOR: Spuštění této funkce má smysl pouze na počítači, ke kterému je fyzicky připojen terminál nebo pokud terminál komunikuje přes TCP/IP.


Monitorování

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Monitorování

 Return to chapter overview

· Používat rychlé monitorování (pro aktuální stav) - pokud je tato volba vypnutá, vyčítají se data pro monitorování ze dvou seznamů (seznam původní docházky a historie průchodů), kde jsou uloženy všechny operace, které si zaměstnanec zaregistroval na terminálech. Díky vyhledávání v takovémto množství záznamů dochází ke zpomalení monitorování.

V případě, že chcete mít aktuální přehled o zaměstnancích, aktivujte si volbu rychlé monitorování pro aktuální stav. Po zapnutí této funkce se poslední zaregistrované informace na terminálu ukládají do oddělené tabulky TabPuvDoch (tabulka je systémově skrytá proto z ní nevyčtete žádné údaje). V této tabulce je každému zaměstnanci vyčítána vždy jen poslední provedená operace, kterou si na terminálu zaregistroval. Pokud však používáte ve firmě více terminálů, mohou být tyto údaje zkreslené.


Export

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Export

 Return to chapter overview

Data z programu je možné použít jako podklad pro zpracování mezd. Pokud je Váš mzdový systém schopen přijímat data z programu v textovém souboru, můžete si export do textového souboru pro mzdový systém nastavit. Program umožňuje nastavit libovolný počet exportovaných textových souborů s vlastním nadefinovaným formátem.

Pokud si na nastavení vlastního exportu netroufáte, kontaktujte linku podpory RON Software.

V jednoduché variantě stačí jedno nastavení exportu. Pokud je však export komplikovanější, může být zapotřebí nastavení více různých exportů (pro každou skupinu zaměstnanců jiný export). Z tohoto důvodu je možné nastavení exportů ukládat pod různými názvy - mít více různých exportů a k těmto exportům přiřazovat skupiny osob, které se budou exportovat.

Spolecne nastaveni export

Postup vytvoření nastavení exportu:

- stiskněte tlačítko [image] a zadejte název exportu (např. ABC_MZDY).

- vyplňte část Nastavení aktuálního exportu se všemi níže popsanými vlastnostmi - položkami (pokud chcete vytvořit více druhů exportů, opakujte předchozí kroky).

· Cílový soubor - toto pole slouží pro zadání názvu cílového souboru zobrazeného exportu. Do tohoto souboru se budou exportovaná data ukládat. Název souboru může obsahovat proměnné s definicí formátu datumu, které budou při provádění samotného exportu nahrazeny hodnotou podle aktuálního období. Proměnné s formátem datumu se do názvu vkládají tak, že se daný formát datumu ohraničí mezi znaky: %%. Jako formátovací znaky lze použít tyto řetězce: mm yy yyyy. Proměnných s formátem datumu je možno do názvu souboru vkládat libovolné množství.

PŘÍKLAD: Pro zadaný název cílového souboru: "c:\temp\export%mmyyyy%.txt" a aktuální období červen 2008, bude výsledný název souboru tento:

"c:\temp\export062008.txt".

· Přidávat záznamy do již existujícího souboru - pokud je tato volba aktivována, pak při provádění daného exportu bude provedena kontrola, zda daný soubor již existuje a pokud soubor existuje, pak původní obsah bude zachován a záznamy budou přidány na konec souboru. V opačném případě bude původní obsah souboru před exportem vymazán a bude naplněn novými daty.

· Povolit export v neuzavřeném období - po zatrhnutí je možné provést export v otevřeném období.

· Definice formátu - toto pole slouží pro definování jednotlivých řádků (záznamů) formátu exportu. Pro definici formátu stiskněte tlačítko [image].

· Platnost pracovních poměrů - zvolte, které pracovní poměry chcete exportovat (Aktivní, Ukončené, Všechny).

· Exportovat i zaměstnance jiné firmy - pokud je tato volba aktivována, pak při provádění exportu budou exportovány i údaje zaměstnanců jiné firmy.

· Exportovat jen zaměstnance jiné firmy - pokud je tato volba aktivována, pak při provádění exportu budou exportovány jen údaje zaměstnanců jiné firmy.

· Exportovat jen zaměstnance podle zvoleného rozdělení - pokud je tato volba aktivována, pak při provádění akt. exportu budou exportovány jen údaje zaměstnanců, kteří jsou přiřazeni do rozdělení nastavených v následujících dvou polích. Tuto volbu použijete, pokud potřebujete pro jednotlivé skupiny zaměstnanců definovat různé exporty. Například pro dělníky převádíte přesčasy a pro techniky přesčasy do exportu nedáváte.

o Typ rozdělení - toto pole určuje typ rozdělení, pro které bude omezen výběr zaměstnanců pro akt. export.

o Volba rozdělení před exportem - pomocí této volby aktivujete výběr konkrétních rozdělení podle přednastaveného typu, prostřednictvím formuláře ze seznamem rozdělení před provedením exportu. Pokud není volba aktivována, máte možnost zadat Seznam kódů rozdělení.

o Seznam kódů rozdělení - toto pole obsahuje kódy rozdělení zaměstnanců (oddělené středníkem). V položce Typ rozdělení jste vybrali nějaké rozdělení např. "Skupina". V této položce vypište seznam skupin, pro které se bude provádět tento export. Všichni zaměstnanci, kteří se během zpracovávaného období (měsíce) stali členy této "skupiny" budou obsaženi v exportu.

Další informace naleznete v kapitole POSTUPY.


Import

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Import

 Return to chapter overview

Standardně program komunikuje při importu se mzdových systémem RONMZDY. Import je prováděn z textových souborů. Pokud tedy máte mzdový systém, ze kterého byste chtěli importovat data do programu, můžete si formáty připravit podle implicitního formátu RONMZDY.

Nastavte cestu do adresáře, ze kterého program bude načítat data poskytovaná mzdovým systémem. Jde o určení místa na disku.

Spolecne nastaveni import pracovnich pomeru

· Identifikovat pracovní poměr podle: RČ, Osobní číslo, Pořadovné číslo PP - tato volba určuje, že při importu pracovního poměru se bude hledat již existující odpovídající pracovní poměr podle polí: RČ, Osobní číslo, Pořadové číslo PP. Ostatní pole včetně data nástupu budou aktualizována.


Evidence výroby

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Evidence výroby

 Return to chapter overview

· Typ časové složky zobrazení a kontroly denních součtů evidence výroby - ze seznamu časových složek je potřeba vybrat konkrétní časovou složku, která bude sloužit pro kontrolu odpracované doby a doby strávené výrobou. Přičemž vybraná časová složka bude sloužit jako norma.

· Typ rozdělení pro zadávání rozdělení v záznamech evidence výroby: - ze seznamu Typy rozdělení si vyberte, podle kterého rozdělení budete evidovat výrobu.

· Editovat a rušit jen vlastní záznamy výroby - po zatržení je možné editovat a rušit jen vlastní záznamy výroby.


Zpracování výroby

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Zpracování výroby

 Return to chapter overview

Zpracování výroby:

· Maximální délka záznamu výroby - maximální délka záznamu výroby při zpracování výroby.

· Omezovat výsledky výroby podle docházky - po zatrhnutí pole budou výsledky výroby omezeny podle docházky.

Operace výroby - seznam operací docházky pro omezení výsledků výroby.

Formulář je rozdělen do dvou seznamů. V levé části tabulky je zobrazen seznam všech dostupných operací výroby. V pravé části jsou povolené operace výroby. Pro přesun mezi seznamy použijte šipky umístěné mezi těmito seznamy.


Uživatelská pole osob, prac. poměrů

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Uživatelská pole osob, prac. poměrů

 Return to chapter overview

Nastavení těchto parametrů je vázané na kartu zaměstnance, konkrétně na položku Ostatní údaje. V tomto nastavení je možno upravit titulky pro zobrazení u jednotlivých uživatelských polí. V tomto formuláři se nastavují titulky uživatelských polí osob, ale také titulky uživatelských polí pracovního poměru.

Pokud zde nastavíte titulek (např. Typ řidičského oprávnění), bude ve formuláři zaměstnance v ostatních údajích zobrazeno pole s titulkem Typ řidičského oprávnění.

Pole osob spolecne nastaveni uzivatelska pole osob


Seznam pracovních poměrů

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Seznam pracovních poměrů

 Return to chapter overview

Zaškrtnutím rozdělení provedete výběr položek, které se následně zobrazí v seznamu typů pracovních poměrů.

Pole osob spolecne nastaveni seznam pracovnich pomeru


Nastaveni mzdových položek

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Nastavení mzdových položek

 Return to chapter overview

Vkládá automaticky pro typ rozdělení vybranou mzdovou položku, kterou v editaci docházky pak následně lze vyčíslit. Tato mzdová položka a její číselná hodnota se přenáší do sestav, případně do mezd.

Nastaveni mzdovych polozek

PŘÍKLAD: Do mzdového střediska - Sklad - je tímto automaticky přiřazena mzdová položka - Odměny - kterou v editaci docházky u daného zaměstnance lze následně vyčíslit v Kč.


Přehled příchodů a odchodů

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Přehled příchodů a odchodů

 Return to chapter overview

Nastavení platné při využití modulu docházky - Plánování kapacit. Při zatržení nastavení bude v menu Docházka/Přehled příchodů a odchodů zohledněno nastavení (cykly) směn z modulu Plánování kapacit a nikoliv z přednastavení směn v kalendáři.

Prehled prichodu a odchodu


Evidence návštěv

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Evidence návštěv

 Return to chapter overview

Tento formulář je funkční pouze v případě rozšíření software o modul Evidence návštěv.

· Typ rozdělení pro evidenci návštěv - k záznamu v evidenci návštěv lze zadat rozdělení vybraného typu. V seznamu návštěv je poté možné záznamy filtrovat.

· Typ rozdělení (Firma) - ze seznamu vyberte požadovaný typ rozdělení. Rozdělení vybraného typu se vám poté bude nabízet v seznamu ve formuláři Návštěvy v poli Firma.

· Nabízet výběr z již zadaných položek - tato volba určuje, zda se budou v polích (Kód návštěvníka, Příjmení, Jméno, Titul, Firma, Vozidlo, Doklad) nabízet již dříve uložené hodnoty. Vypnutím této volby lze urychlit načtení formuláře při velkém množství záznamů.

· Popis pro formulář zápisu návštěv - zadejte vlastní popis pro formulář zápisu návštěv.


Služební cesty

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Služební cesty

 Return to chapter overview

Ve formuláři nastavíte účtování služebních cest.

Cestovní náhrady

· Typ výpočtu cestovních náhrad - vyberte implicitní hodnotu, která bude automaticky vyplněna při vytvoření nové služební cesty. Na výběr máte z: Česká legislativa, Slovenská legislativa, Podle země s nejdelší strávenou dobou, Podle výchozí země, Každá země samostatně.

· Nevyžadovat vyplnění řádků služební cesty pro výpočet - pokud je volba aktivní, není nutné vyplňovat řádky služební cesty pro výpočet cestovních náhrad. V tomto případě se celá doba služební cesty vypočte z počátku a konce služební cesty v hlavičce.

· Implicitní šablona účtování cestovních náhrad - ze seznamu vyberte implicitní šablonu, podle které se automaticky předplní účtování služební cesty. Seznam šablon nadefinujete v menu Cestovní náhrady/Šablony účtování služební cesty.

· Automaticky předplňovat účtování cestovních náhrad - po zatrhnutí pole bude zvolená šablona automaticky předplněna v nově zadávané služební cestě.
· Povinný účel služební cesty - pokud je pole zatrhnuté, je nutné mít ve služební cestě vyplněné pole Účel. Jakmile nebude toto pole vyplněno a potvrdíte formulář, zobrazí se varovné okno s popisem "Není zadán účel služební cesty". Po jeho zadání, je možné formulář potvrdit.

· Určení data kurzu pro náhrady - z nabídky vyberte volbu, podle které se určí datum kurzu pro náhradu. Na výběr máte z následujících možností:

o Podle dne počátku služební cesty - datum kurzu bude podle dne počátku služební cesty.

o Podle dne konce služební cesty - datum kurzu bude podle dne konce služební cesty.

o Podle 1. dne v měsíci počátku služební cesty

o Podle data kurzu služební cesty (pokud není tak podle počátku)

o Podle data kurzu služební cesty (pokud není tak podle konce)

o Podle dne řádku účtování služební cesty

· Určení data kurzu pro ostatní doklady - z nabídky vyberte volbu, podle které se určí datum kurzu pro ostatní doklady.

o Podle dne počátku služební cesty - datum kurzu bude podle dne počátku služební cesty.

o Podle dne konce služební cesty - datum kurzu bude podle dne konce služební cesty.

o Podle 1. dne v měsíci počátku služební cesty

o Podle data kurzu služební cesty (pokud není tak podle počátku)

o Podle data kurzu služební cesty (pokud není tak podle konce)

o Podle dne řádku účtování služební cesty

kapesné

· Přednastavená sazba kapesného - při zadávání služební cesty se do pole Sazba kapesného automaticky doplní přednastavená sazba.

· Maximální sazba kapesného - maximální sazbu, kterou je možné zapsat ve formuláři služební cesty do pole Sazba kapesného. Jakmile do formuláře služební cesty zapíšete vyšší sazbu, než která je nastavená zde, zobrazí se varování, že sazba přesáhla maximální limit.

· Používat sazby kapesného pro rozdělení - pokud je nastaveno používání sazebníku kapesného pro rozdělení, pak se při vyúčtování služební cesty sazba kapesného služební cesty nastaví podle sazby pro rozdělení, ve kterém je zaměstnanec ke dni počátku služební cesty. Pokud sazba pro dané rozdělení není nalezena, pak se nastaví implicitní sazba z nastavení aplikace.

· Typ rozdělení pro sazby kapesného - pokud je zatrženo pole Používat sazby kapesného pro rozdělení, vyberte z nabídky požadované rozdělení.

TITULKY UŽIVATELSKÝCH POLÍ SLUŽEBNÍCH CEST

· Uživatelské pole - nastavení těchto parametrů je vázané na formulář služební cesty, konkrétně na záložku Ostatní údaje. V tomto nastavení je možno upravit jaké titulky budou zobrazeny u jednotlivých uživatelských polí. Dle tohoto nastavení se dají jednotlivé služební cesty dále filtrovat.

Přenos služebních cest do docházky

· Používat přenos služebních cest do docházky - pokud chcete přenášet služební cesty do docházky, zatrhněte pole.

· Implicitní typ přenosu služebních cesty do docházky - při vytváření nové služební cesty je možné typ přenosu služební cesty do docházky změnit. Z nabídky vyberte typ přenosu služebních cest do docházky:

o Po směnách - služební cesta se vloží jen podle nastavené směny v kalendáři.

o Podle rozpisu - jednotlivé části dne se vloží na základě vyplněných řádků služební cesty.

· Operace služební cesty - pokud jste v předchozí možnosti zvolili volbu "Po směnách", zvolte operaci, která se bude vkládat (například Služební cesta).

POZOR: Tato aplikace je dostupná, pokud máte zakoupen modul Cestovní náhrady.


Schvalování služebních cest

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Schvalování služebních cest

 Return to chapter overview

Ve formuláři nastavíte schvalování služebních cest.

Cestovni nahrady schvalovani

· Názvy úrovní schválení - názvy, které jsou přiřazeny jednotlivým úrovním schválení, se zobrazí v menu Cestovní náhrady/Služební cesty - v sekci Schvalování. Jednotlivé úrovně si můžete pojmenovat dle vašich požadavků, standardně jsou zde nastaveny tyto:

o 1. úroveň - zpracováno

o 2. úroveň - zkontrolováno

o 3. úroveň - schváleno

· Popisy úrovní schválení - k jednotlivým úrovním si můžete přidat popis, který se zobrazí ve služebních cestách v sekci Schvalování při najetí myší na okno schválení.

· Dodržovat hierarchii při schvalování služebních cest - tato volba určuje, zda při schválení vyšším stupněm schválení nepůjde editovat/zrušit nižší stupeň schválení.

· Uzamknout schválení služebních cest v uzavřeném období - tato volba určuje, zda pokud je uzavřeno období pak nepůjde změnit/zrušit schválení služební cesty dané úrovně které bylo schváleno datem v uzavřeném období.

· Úroveň schválení pro uzamčení - z nabídky vyberte úroveň schválení, pro kterou se budou uzamykat služební cesty v uzavřeném období.

POZOR: Tato aplikace je dostupná, pokud máte zakoupen modul Cestovní náhrady.


Kalendáře

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Kalendáře

 Return to chapter overview

· Zadávat pracovní dobu v kalendáři - po zatržení je možné zadávat v kalendáři (Seznamy/Kalendáře/Směny II) jednotlivým dnům pracovní dobu od - do a rozsah normohodin min. - max.


Plánování kapacit

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Plánování kapacit

 Return to chapter overview

· Typ rozdělení pro plánování - po vybrání rozdělení v menu Docházka/Plánování kapacit - odkaz Nastavení se ve formuláři Nastavení plánování kapacit zobrazí záložka Rozdělení. Tímto nastavením umožníte dočasně přeřadit zaměstnance na jiné rozdělení. Uživatelé pak mohou získat právo plánovat směny zaměstnancům z jiných rozdělení (např. středisek). Pro správnou funkčnost musí mít uživatel práva na přístupové skupiny se stejnými kódy.

Dále je možné podle rozdělení určit směny, které je možné zaměstnancům plánovat - na různých rozděleních mohou být povoleny různé směny.

· Povolit plánovat i podřízená rozdělení - určuje, jestli může uživatel plánovat i pro podřízená rozdělení.

· Přepočet provádět podle původní docházky - určuje, jestli se má přepočet v plánování kapacit provádět podle původní docházky.

· Provádět přepočet při plánování ve zpracovaných dnech - určuje, jestli se má během editace ve zpracovaných dnech ihned provést přepočet.

· Výběr směn pro plánování - z nabídky vyberte jaké směny bude možné zadávat v plánování kapacit:

o Vybírat směny povolené v kalendáři - umožní plánovat směny povolené v kalendáři. Pro správnou funkčnost musí mít všechna rozdělení zvoleného typu přiřazen kalendář!

o Vybírat pouze směny povolené v daném dni - umožní vybírat pouze směny povolené v daném dni.

o Vybírat ze všech existujících směn - možnost plánovat všechny směny, ne jen směny vybrané v kalendáři.

· Kontrola potvrzení při schvalování - určete, jestli musí být směny před schválením potvrzené (modrý pruh).
· Zakázat snížení data schválení pro nejvyšší povolenou úroveň uživatele (neplatí pro červenou) - po zaškrtnutí nemůže uživatel vrátit (snížit datum) nejvyšší povolenou úroveň schválení.

· Povolit dodatečné změny plánovaných kapacit - určete, jestli je možné provádět dodatečné změny v plánování kapacit i po schválení plánu. Při dodatečných změnách zůstane zachována informace o původním plánu. Pro výpočty docházky se použije upravená hodnota.

· Minimální úroveň schválení - vyberte, jaká minimální úroveň schválení musí být nastavena, aby bylo možné provádět dodatečné změny v plánu.

· Zobrazit denní výsledky v buňkách - po zadání kódů časových složek se v buňkách zobrazí výsledky. Uživatel si musí poté nastavit dostatečnou výšku políčka v plánování kapacit.

PŘÍKLAD: 100:H;#;200:D; ; ;300:K

V buňce se zobrazí: 100:H; - Odpracovaná doba (100) v hodinách (H),

#; - další hodnota v buňce bude zobrazena na dalším řádku,

200:D; - Dovolená (200) zobrazena v pracovních dnech (D),

; ; ; - vložení dvou mezer mezi zobrazené výsledky,

300:K - Nemoc (300) zobrazená v kalendářních dnech.


Plánování kapacit 2

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Plánování kapacit 2

 Return to chapter overview

Plánování kapacit - v plánování kapacit máte možnost zobrazit pro vybranou časovou složku měsíční výsledek výpočtu na řádku a součet časové složky ve sloupci. Pro režim plánování a režim dodatečných úprav máte možnost vybrat jinou časovou složku.

· Typy časových složek pro zobrazení měsíčních výsledků na řádku - v poli můžete zadat až tři časové složky ve formátu KOD1:Nadpis1;KOD2:Nadpis2. Viditelnost měsíčních výsledků vybraných časových složek v plánování kapacit můžete nastavit ve formuláři Nastavení součtů.

PŘÍKLAD: 100:OD;200:DOV:D;300:NEM:K

V buňce se zobrazí: 100:OD - Odpracovaná doba (100) a název sloupce (OD),

200:DOV:D - Dovolená (200) a název sloupce (DOV) zobrazena v pracovních dnech (D),

300:NEM:K - Nemoc (300) a název sloupce (NEM) zobrazená v kalendářních dnech.

· Typ časové složky pro zobrazení součtu ve sloupci - v prvním poli vyberte časovou složku a ve druhém poli zvolte nadpis sloupce. Časovou složku je možné nastavit jak pro režim plánování, tak pro režim dodatečných úprav. V každém režimu je možné zvolit jinou časovou složku.

o Kontrolovat limit - pokud není pole zaškrtnuté, kontroluje se celkový součet ve sloupci. Pokud chcete kontrolu limitu přepnout na jinou vybranou časovou složku, vyberte ji a zatrhněte pole. Kontrolu limitu je možné nastavit, jak pro režim plánování, tak pro režim dodatečných úprav.

Výchozí nastavení pro uživatele - uživatel si nastavení může změnit.

· Zobrazit osobní číslo - osobní číslo zaměstnance se zobrazí vedle jména osoby vlevo.

· Zobrazit kód rozdělení zaměstnance - kód rozdělení zaměstnance se zobrazí na levé straně od kódu pracovního místa.

· Zobrazit kód pracovního místa - kód pracovního místa zaměstnance se zobrazí na levé straně od osobního čísla. Kód se zobrazí pouze, pokud máte program RonMzdy nebo RonPersonalistiku.

· Zobrazit počet naplánovaných hodin zaměstnance - po zatrhnutí pole se vpravo od sloupce dle kal. zobrazí sloupec s počtem naplánovaných hodin zaměstnance.

· Zobrazit počet naplánovaných směn - po zatrhnutí pole se vlevo od seznamu naplánovaných kapacit zobrazí sloupec s počtem naplánovaných směn zaměstnance.

· Počítat i dny, ve kterých je zadána absence - pokud je v poli zobrazena směna i absence ( [image]), potom zatržením pole určíte, zda se například odpolední směna započítá v součtech, když je na daný den zadána dovolená.

· Zobrazit počet hodin podle kalendáře (Směny II v kalendáři) - po zatrhnutí pole se vpravo od jména zobrazí sloupec dle kal. s počty hodin podle kalendáře, který je nastaven v menu Seznamy/Kalendáře - formulář vybraného kalendáře/záložka Směny II.

· Filtrovat směny pro součet automaticky podle práv a zvoleného rozdělení - po zatrhnutí filtruje směny, které jsou zobrazeny u součtů v levém dolním rohu, podle práv a zvoleného rozdělení.

· Zobrazit značku "$", pokud má zaměstnanec zadané mzdové položky - pokud bude mít zaměstnanec zadanou mzdovou položku, zobrazí se ve sloupci Mzd. značka "$".

· Zobrazit součet mzdových položek - pokud zadáte zaměstnanci mzdovou položku, zobrazí se vpravo od značky "$" součet mzdových položek.

· Zobrazit značku "...", pokud je ke dni zadána poznámka docházky - pokud zadáte poznámku k naplánované směně, zobrazí se značka "...".

· Zobrazit texty poznámek - v dolní části okna plánování kapacit se zobrazí texty zadaných poznámek k docházce a absenci.

Plánování kapacit - detail

· Denní výsledky v detailu - zadejte kódy časových složek (oddělené středníkem), které se mají zobrazit/editovat v detailu plánování kapacit.


Active directory

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

Active directory

 Return to chapter overview

Formulář slouží k synchronizaci zaměstnanců, skupin a rolí s active directory.

Active directory_Nastaveni aplikace


XML formuláře

Navigation: Systém > Nastavení > Nastavení aplikace > Společné nastavení >

XML formuláře

 Return to chapter overview

V nastavení tohoto formuláře máte možnost nastavit následující funkce:

· Typ rozdělení - ze seznamu vyberte typ rozdělení, podle kterého se bude postupovat v rámci předávacího procesu.

· Webové formuláře zobrazovat v rámci aplikace - pokud se mají webové formuláře zobrazovat v rámci aplikace, zaškrtněte políčko.


Nastavení sestav (společné)

Navigation: Systém > Nastavení > Nastavení aplikace >

Nastavení sestav (společné)

 Return to chapter overview

Z nabídky vyberte rozdělení, které se bude zobrazovat v sestavách.


Výkaz odpracovaných směn (Grafický)

Navigation: Systém > Nastavení > Nastavení aplikace > Nastavení sestav (společné) >

Výkaz odpracovaných směn (Grafický)

 Return to chapter overview

V grafické výstupní sestavě můžete nastavit hodnoty pěti sloupců. Pro tyto sloupce můžete nastavit hodnoty časových složek a nadpisy sloupců s těmito hodnotami. Výsledek nastavení si můžete prohlédnout v náhledu nebo tisku této sestavy.

· Seznam typů časových složek - pro každý řádek zadejte kódy časových složek. Pokud chcete v jedné hodnotě zobrazit součet více časových složek, zadejte kódy časových složek oddělené čárkou.

· Titulek sloupce - pokud zadáte pro sloupec součet časových složek, budete pravděpodobně potřebovat výstižně tento sloupec se součtem nazvat. Nastavená hodnota se zobrazí jako název sloupce v sestavě.

Vykaz odpracovanych smen_Graficky

TIP: Pro zobrazení součtu je možno oddělit jednotlivé časové složky čárkou.

Nastaveni zvolenych mesicnich souctu

Nastavení zvolených měsíčních součtů - ve spodní části sestavy je automaticky generován seznam všech měsíčních výsledků, který u zaměstnance je vypočten. V tom to nastavení je možné specifikovat požadované výsledky, které budou na sestavě zobrazeny. Po stisku tlačítka se zobrazí formulář pro zadání kódu časové složky a titulku sloupce.

Seznam casovych slozek pro sestavu


Výkaz odpracovaných směn (Textový)

Navigation: Systém > Nastavení > Nastavení aplikace > Nastavení sestav (společné) >

Výkaz odpracovaných směn (Textový)

 Return to chapter overview

Nastavení pro tuto sestavu je shodné s nastavením popsané grafické sestavy.

Vykaz odpracovanych smen_textovy


Výkaz pro mzdové oddělení

Navigation: Systém > Nastavení > Nastavení aplikace > Nastavení sestav (společné) >

Výkaz pro mzdové oddělení

 Return to chapter overview

Pro výkaz dovolených v manažeru výstupních sestav musíte mít zadaná zdrojová data, ze kterých bude sestava vytvářena. Tyto hodnoty se nastavují ve výkazu pro mzdové oddělení v položce dovolená. V položce kódy operací zadejte kódy, které se mají pro danou sestavu vyhledávat.

Stejné nastavení platí pro Výkaz náhrad mzdy i Výkaz náhrad mzdy ostatní.

PŘÍKLAD: Ve výkazu pro mzdové oddělení je nastavena sestava pro náhradu mzdy. V této sestavě je pod kódy operací nastaveno 09;10;11;12 a pod časovými složkami mzdy 300;301;302;303. Při generování výstupní sestavy pro výkaz náhrad mzdy se budou ve výsledcích měsíční docházky vyhledávat pouze operace pod kódy 09;10;11;12 a jim budou přiřazeny časové složky 300;301;302;303.

Vykaz pro mzdove oddeleni

POZOR: Pokud se vám ve výstupních sestavách negenerují žádné výsledky, zkontrolujte, jestli máte správně zadané kódy operací.


Nastavení plánovače úloh

Navigation: Systém > Nastavení >

Nastavení plánovače úloh

 Return to chapter overview

V plánovači úloh je možno si nastavit automatické provádění zvolených činností ve zvoleném čase. Program poté sám provádí podle nastavení plánovače úloh operace, které by musel uživatel provádět ručně, aby připravil data pro ostatní uživatele docházkového systému. Plánovač umožňuje vkládání nových úloh, editaci (úpravu) již existujících úloh a jejich mazání.

Modul SLUŽBA obsahuje stejný plánovač úloh jako software DOCHÁZKA.

POZOR: Pro automatizované spouštění úloh je potřeba v konfiguraci služby zatrhnout "Aktivovat plánovač úloh".

Seznam planovace uloh

§ Jen úloha - po zatržení pole vyberte z nabídky, jakou úlohu chcete v seznamu zobrazit.

Po stisku tlačítka Novy zaznam3 Nový záznam se zobrazí dialog pro nastavení nové úlohy.

Formular planovani ulohy

· Kód - vepište kód. Volba kódu je na vás. Každý kód musí být jiný.

· Blokovat plánování - v případě, že zatrhnete, nebude se tato úloha spouštět.

· Úloha - vyberte úlohu, kterou chcete automaticky spouštět:

o Zálohování databáze - automaticky spustí zálohování databáze. Doporučujeme zálohování provádět jednou denně v nočních hodinách. Zálohu databáze uložte na jiný disk, než na kterém je umístěna databáze. Cestu nastavíte v zobrazeném okně. V případě použití SQL serveru se databáze ukládá na tento server. Popis parametrů:

ž -destination:<soubor/adresář> - určuje cílový soubor zálohy databáze (pro SQL databázi), nebo cílový adresář pro MDB databázi. Do názvu souboru/adresáře je možno vkládat proměnné formátující aktuální datum a čas mezi znaky: <"a">.

PŘÍKLAD:

"c:\backup\date<yyyymmdd>.bak",

"c:\bak\day<dd>_time<hhnnss>.bak",

"c:\bak\dayOfWeek<ddd>.bak".

o Načtení dat z terminálů - provádí vyčítání dat z docházkových terminálů. Pokud chcete mít aktuální přehled o zaměstnancích, nastavte krátký interval (např. 60 sekund). V tomto intervalu bude prováděno vyčítání dat z terminálů. V této úloze lze specifikovat, které terminály mají být vyčítány. Do zobrazeného okna zapište kódy terminálů oddělení čárkou nebo středníkem, pouze tyto terminály budou poté vyčítány. Popis parametrů:

ž -terminals:<seznam terminálů> - seznam kódů terminálů oddělených středníkem, pro které bude provedena úloha.

ž -lines:<seznam linek> - seznam linek terminálů oddělených středníkem, pro které bude provedena úloha.

o Generování nastavení terminálů - odesílá do terminálů seznam zaměstnanců s jejich identifikačními médii, a operace terminálů. Obsah zasílaných informací se liší podle typu terminálu. V této úloze lze specifikovat, které terminály mají generovány. Do zobrazeného okna zapište kódy terminálů oddělení čárkou nebo středníkem, pouze tyto terminály budou poté generovány. Popis parametrů:

ž -terminals:<seznam terminálů> - seznam kódů terminálů oddělených středníkem, pro které bude provedena úloha.

ž -lines:<seznam linek> - seznam linek terminálů oddělených středníkem, pro které bude provedena úloha.

o Nastavení aktuálního data a času do terminálů - pokud potřebujete automaticky nastavovat čas v terminálech, naplánujte si tuto úlohu. Nastavení data a času se provádí dle aktuálního času v počítači. Pokud provádíte pravidelně generování nastavení terminálů, nemusíte tuto úlohu plánovat. Generování nastavení terminálů rovněž nastavuje čas v terminálech. V této úloze lze specifikovat, které terminály mají být nastaveny. Popis parametrů:

ž -terminals:<seznam terminálů> - seznam kódů terminálů oddělených středníkem, pro které bude provedena úloha.

ž -lines:<seznam linek> - seznam linek terminálů oddělených středníkem, pro které bude provedena úloha.

TIP: Je možné použít pro nastavení letního a zimního času na terminálech.

o Zpracování původní docházky - automaticky spustí zpracování původní docházky. Zpravidla se docházka zpracovává jednou denně ve večerních hodinách. Toto zpracování samozřejmě předpokládá spuštěný docházkový systém na počítači. V zobrazeném poli lze specifikovat časový posun pro zpracování docházky – počet dnů dozadu, nebo dopředu vzhledem k aktuálnímu datu. Popis parametrů:

ž -threaddCount:<počet vláken> - určuje počet vláken, která budou provádět zpracování (Implicitní hodnota: 1).

ž -dateTimeTo:<yyyy-mm-dd[hh:mm[:ss]]> - původní docházka bude zpracována do daného data a času.

ž -dateTimeTo:[@[-]<posun dnů>] - pokud je den zadán posunem (uvozeným znakem "@"), pak je docházka zpracována do půlnoci dne zadaného posunem od aktuálního systémového data.

Pokud není datum, čas ani posun zadán, pak je docházka zpracována do aktuálního systémového data a času.

PŘÍKLAD: „@-2" – zpracuje docházku do „aktuální den" – 2 dny;

„@+1" – zpracuje docházku do „aktuální den" + 1 den.

ž -hist - původní docházka je zpracována maximálně do data nejstaršího korektního načtení historie z docházkových terminálů.

ž -RPD - výsledky jsou vypočteny jen do předchozího dne než je zpracována původní docházka. Takto je možno zahrnout do zpracování původní docházky i konce nočních směn, které patří k předchozímu dni tak aby poslední zpracovaný den nevznikaly záporné přesčasy u ještě nedokončených směn. Například, pokud zpracujete docházku v 7:00 (zpravidla kdy končí noční směna) a není zadaný tento parametr, zobrazí se v aktuální den záporné hodnoty (přesčas). Pokud zadáte tento parametr, zůstane aktuální den bez výsledků.

ž -subDiv:<typ/rozdělení> - určuje typ rozdělení a rozdělení, pro které bude úloha provedena.

o Přepočet výsledků zpracované docházky v aktuálním období do data zpracování - umožňuje automaticky přepočítat výsledky docházky. Například při změně zaokrouhlení výsledků je nutné provést přepočet výsledků, aby se tyto změny v nastavení programu projevily. Je možné tento přepočet naplánovat na dobu, kdy server nebo počítač je méně vytížen. Přepočet výsledků je možné provést pro specifikované období. Popis parametrů:

ž -threaddCount:<počet vláken> - určuje počet vláken, která budou provádět zpracování (Implicitní hodnota: 1).

ž -subDiv:<typ/rozdělení> - určuje typ rozdělení a rozdělení, pro které bude úloha provedena.

PŘÍKLAD: 10.05.2004;12.05.2004 – bude proveden přepočet výsledků od 10. do 12.5.2004.

o Přepočet výsledků zpracované docházky v minulém období - umožňuje automaticky přepočítat výsledky docházky za minulé období. Minulé období se určí jako minulý měsíc dle aktuálního data v počítači. Popis parametrů:

ž -threaddCount:<počet vláken> - určuje počet vláken, která budou provádět zpracování (Implicitní hodnota: 1).

ž -subDiv:<typ/rozdělení> - určuje typ rozdělení a rozdělení, pro které bude úloha provedena.

o Schválení docházky - pomocí této úlohy je možné automaticky provádět schvalování docházky dle nastavených pravidel. Lze nastavit následující parametry:

ž Úroveň schválení
ž Počet dní zpět – vzhledem k aktuálnímu datu
ž Typ rozdělení
ž Rozdělení

Popis parametrů:

ž -dateTimeTo:<yyyy-mm-dd[hh:mm[:ss]]> - docházka bude schválena do daného data a času.

ž -dateTimeTo:[@[-]<posun dnů>] - pokud je den zadán posunem (uvozeným znakem "@"), pak bude docházka schválena do dne zadaného posunem od aktuálního systémového data.

Pokud není datum, čas ani posun zadán, pak je docházka zpracována do aktuálního systémového data a času.

ž -apprLevel:<úroveň schválení> - určuje úroveň schválení zpracované docházky. Možné hodnoty: 1, 2, 3.

ž -subDiv:<typ/rozdělení> - určuje typ rozdělení a rozdělení, pro které bude úloha provedena.

PŘÍKLAD: 2;5;7;THP – dojde ke schválení docházky druhé úrovně (žlutá - zkontrolováno) pro skupinu zaměstnanců THP; 1;2; - dojde ke schválení docházky první úrovně (zelená - zpracováno) pro všechny zaměstnance.

o Synchronizace přístupových skupin podle rozdělení osob - umožňuje synchronizaci přístupových skupin podle rozdělení osob pro nastavení zabezpečení docházky. Popis parametrů:

ž -subDivType:<typ rozdělení> - určuje kód typu rozdělení, pro které bude úloha provedena.

ž applyHierarchy - určuje zda bude při synchronizaci skupin osob pro zabezpečení v aplikaci uplatněna hierarchie zdrojového rozdělení. Členové skupin odpovídajících podřízeným rozdělením budou i členy skupin odpovídajících nadřazeným rozdělením.

o Synchronizace skupin osob podle rozdělení osob - synchronizuje skupiny osob podle aktuálního rozdělení osob. Popis parametrů:

ž -subDivType:<typ rozdělení> - určuje kód typu rozdělení, pro které bude úloha provedena.

o Provedení SQL skriptu - slouží k automatickému provedení nastaveného SQL skriptu. Popis parametrů:

ž -script:<SQL soubor> - určuje soubor s SQL skriptem, který bude proveden. Jednotlivé SQL příkazy v souboru jsou oddělené středníkem.

o Import - slouží pro automatické spouštění importu dat do docházky z nadřazeného systému. Nastavuje se název importu, který chcete automaticky spouštět. Popis parametrů:

ž -name:<název> - určuje název importu, který bude proveden. Je možno definovat více názvů oddělených středníkem.

o Export - slouží pro automatické spouštění exportu dat z docházky do nadřazeného systému. Nastavuje se název exportu, který chcete automaticky spouštět. Popis parametrů:

ž -name:<název> - určuje název exportu, který bude proveden. Je možno definovat více názvů oddělených středníkem.

ž -period:<yyyy-mm> - určuje období pro export. Pokud není dáno, pak je období dáno aktuálním systémovým datem.

o Provedení skriptu - slouží k automatickému provedení vlastního definovaného skriptu, který jinak v docházce není obsažen. Popis parametrů:

ž -script:<Název kategorie>/<Název skriptu> - určuje název kategorie a název skriptu, který bude proveden.

o Provedení agenta - slouží k automatickému provedení vlastního definovaného agenta, který jinak v docházce není obsažen. Popis parametrů:

ž -Příkazový řádek pro spuštění agenta.

o Synchronizace rozdělení osob podle jiného typu rozdělení - synchronizuje skupiny osob podle jiného typu rozdělení. Popis parametrů:

ž -subDivType:<typ rozdělení> - určuje kód zdrojového typu rozdělení, pro které bude úloha provedena.

ž -srcSubDivList:<seznam rozdělení> - určuje zdrojový seznam kódů rozdělení, oddělený středníkem, pro které bude úloha provedena.

Pokud není zadán zdrojový seznam rozdělení, pak jsou všechny rozdělení zdrojového typu synchronizována do cílového typu.

ž -dstSubDivType:<typ rozdělení> - určuje kód cílového typu rozdělení, pro které bude úloha provedena.

ž -dstSubDiv:<rozdělení> - určuje kód cílového rozdělení, pro které bude úloha provedena.

Pokud je dáno cílové rozdělení, budou všichni členové zdrojových rozdělení přiřazeni na toto cílové rozdělení.

o DMR On-line server - úloha se nastavuje pro fungování on-line terminálů. Úloha u těchto terminálů běží nepřetržitě (On line). Popis parametrů:

ž -UDPPort:<UDP port> - určuje UDP port, na kterém bude naslouchat on-line server.

ž -LOGLevel:<Log level> - určuje úroveň logování událostí. 0 - nic se neloguje, 1 - logují se důležité události (implicitní), 2 - loguje se vše.

ž -threaddCount:<počet vláken> - určuje počet vláken, která budou provádět zpracování (Implicitní hodnota: 1).

ž -ThreadCount:<Počet vláken> - určuje počet vláken serveru, které obsluhují požadavky terminálů (implicitně 3).

ž -DataLog:<Datový LOG Soubor> - určuje cestu k Datovému log souboru.

ž -NSHost:<Hostitel notification serveru> - určuje hostitele (IP adresu) notification serveru.

ž -NSPort:<TCP port notification serveru> - určuje TCP port, na kterém naslouchá notification server (implicitně 15700).

o Zpracování původní výroby - automaticky spustí zpracování původní výroby. Zpravidla se výroba zpracovává jednou denně ve večerních hodinách. Toto zpracování samozřejmě předpokládá spuštěný docházkový systém na počítači. V zobrazeném poli lze specifikovat časový posun pro zpracování výroby – počet dnů dozadu, nebo dopředu vzhledem k aktuálnímu datu. Popis parametrů:

ž -dateTimeTo:<yyyy-mm-dd[hh:mm[:ss]]> - původní výroba bude zpracována do daného data a času.

ž -dateTimeTo:[@[-]<posun dnů>] - pokud je den zadán posunem (uvozeným znakem "@"), pak je výroba zpracována do půlnoci dne zadaného posunem od aktuálního systémového data.

Pokud není datum, čas ani posun zadán, pak je docházka zpracována do aktuálního systémového data a času.

ž -hist - původní výroba je zpracována maximálně do data nejstaršího korektního načtení historie z docházkových terminálů.

ž -subDiv:<typ/rozdělení> - určuje typ rozdělení a rozdělení, pro které bude úloha provedena.

o Přepočet výsledků zpracované výroby v aktuálním období do data zpracování - umožňuje automaticky přepočítat výsledky výroby. Například při změně zaokrouhlení výsledků je nutné provést přepočet výsledků, aby se tyto změny v nastavení programu projevily. Je možné tento přepočet naplánovat na dobu, kdy server nebo počítač je méně vytížen. Přepočet výsledků je možné provést pro specifikované období. Popis parametrů:

ž -subDiv:<typ/rozdělení> - určuje typ rozdělení a rozdělení, pro které bude úloha provedena.

o Přepočet výsledků zpracované výroby v minulém období - umožňuje automaticky přepočítat výsledky výroby za minulé období. Minulé období se určí jako minulý měsíc dle aktuálního data v počítači. Popis parametrů:

ž -subDiv:<typ/rozdělení> - určuje typ rozdělení a rozdělení, pro které bude úloha provedena.

o Vytvoření nového období - automaticky vytváří nové období. Pomocí parametru -dateTimeTo:@25, jsou nová období vytvářena do měsíce, ve kterém je den zadaný posunem od aktuálního systémového data. Pokud používáte variabilní období, potom při vytváření měsíčního období jsou vytvářena i variabilní období, která zasahují do daného měsíčního období. Popis parametrů:

ž -dateTimeTo:[@[-]<posun dnů>] - pokud je den zadán posunem (uvozeným znakem "@"), pak jsou nová období vytvořena do měsíce, ve kterém je den zadaný posunem od aktuálního systémového data.

o Generování přestávek - automaticky generuje přestávky. Pomocí parametru -dateFrom:@-5, jsou přestávky vygenerovány od počátku měsíce dne zadaného posunem od aktuálního systémového data. Popis parametrů:

ž -threaddCount:<počet vláken> - určuje počet vláken, která budou provádět zpracování (Implicitní hodnota: 1).

ž -dateTimeTo:[@[-]<posun dnů>] - pokud je den zadán posunem (uvozeným znakem "@"), pak jsou přestávky vygenerovány od počátku měsíce dne zadaného posunem od aktuálního systémového data.

o Výpočet cestovních náhrad - automaticky provede výpočet cestovních náhrad. Popis jednotlivých parametrů:

ž -allPeriods - cestovní náhrady budou zpracovány (0) ve všech obdobích.

ž -period:<yyyy-mm> - cestovní náhrady budou zpracovány (0) v daném období.

ž -period:[@[-]<posun dnů>] - pokud je období zadáno posunem (uvozený znakem "@"), pak jsou cestovní náhrady zpracovány v období, do kterého padne datum dne zadaného posunem od aktuálního systémového data například: -period:@-5. Pokud není datum ani posun zadán, pak jsou cestovní náhrady zpracovány v období, ve kterém je aktuální systémové datum.

ž -subDiv:<typ/rozdělení> - určuje typ rozdělení a rozdělení, pro které bude úloha provedena.

ž -onlyApproved:<úroveň schválení (1,2,3)> - určuje úroveň schválení, pro které bude úloha provedena. Tzn., provede zpracování jen služebních cest, které budou schváleny na dané úrovni.

ž -onlyNotApproved:<úroveň schválení (1,2,3)> - určuje úroveň neschválení pro které bude úloha provedena. Tzn., provede zpracování jen služebních cest, které nebudou schváleny na dané úrovni.

o Server vzdáleného spouštění - úloha spouští agenty z intrawebu. Intraweb nyní nepotřebuje práva ke spouštění příkazové řádky. Pro provedení úlohy je nutné nastavit, v menu Systém -> Nastavení -> Nastavení intrawebu -> Docházka, Cestu k programovým souborům Docházky, Vzdálené spouštění agentů - host a Číslo portu. Úloha musí být naplánovaná On line. Popis parametrů:

ž -TCPPort:<TCP port> - určuje TCP port na kterém bude naslouchat server.

ž -LOGLevel:<Log level> - určuje úroveň logování událostí. 0 - nic se neloguje, 1 - logují se důležité události (implicitní), 2 - loguje se vše.

o Komunikační server - komunikační server pro komunikaci s mobilním klientem. Popis parametrů:

ž -TerminalID:<ID Terminálu> - určuje kód terminálu s nastavením mobilních klientů/terminálů.

ž -TCPPort:<TCP port> - určuje TCP port na kterém bude naslouchat server.

ž -LOGLevel:<Log level> - určuje úroveň logování událostí. 0 - nic se neloguje, 1 - logují se důležité události (implicitní), 2 - loguje se vše.

ž -DataLog:<Datový LOG Soubor> - určuje cestu k Datovému log souboru.

o Obnova indexů v databázi - funkce slouží k základní údržbě databáze. Tato funkce je podporována na databázových platformách MSSQL a Firebird. Funkci je vhodné provádět pravidelně například přes víkend. V závislosti na velikosti databáze může funkce trvat delší dobu. Funkce je doplněna i do menu Systém -> Správa databáze -> Obnova indexů.

· Souběžné provádění - při zaškrtnutí se povolí souběžné provádění úlohy.

· Nesouběžné úlohy - seznam úloh, které nesmí být prováděny souběžně. Vepíšete seznam plánovaných úloh oddělených středníkem.

· Naplánovat úlohu - nastavte časový interval provádění úlohy:

o Jednou - zadejte datum a čas provedení úlohy.

o V intervalu - zadejte interval pravidelného spouštění ve formátu HH:MM:SS, zvolit můžete ještě omezení v rámci dne od-do.

o Denně - zadejte čas pro spuštění v každém dni.

o Týdně - zadejte čas pro spuštění a den v týdnu.

o Měsíčně - zadejte čas pro spuštění a číslo dne v měsíci.

o Ročně - zadejte čas pro spuštění, číslo dne v měsíci a měsíc.

o On line - v některých specifických případech úloha běží nepřetržitě.

· Opakovat v případě chyby - při zaškrtnutí této položky bude naplánovaná úloha spuštěna znovu. U dalších položek nastavíte parametry opakování.

· Prodleva před opakováním úlohy - zadejte číslo. V případě chyby bude naplánovaná úloha spouštěna až po zadaném intervalu (např.: 30s).

· Max. počet opakování úlohy - vepište číslo. V případě chyby bude naplánovaná úloha spuštěna znovu (např.: vepíšete 3, v případě opakovaných chyb bude naplánovaná úloha spuštěna maximálně 3x po sobě).

· Zapisovat do LOGu i úspěšně provedenou úlohu - zapíše do LOGu (záznam událostí) všechny provedené úlohy.

· Zpráva e-mailem - zvolte, zda si chcete nechat posílat e-mailové zprávy o provedené úloze. Na výběr máte z následujících možností:

o Neposílat - zpráva o provedené úloze vám nebude poslána.

o V případě chyby - zpráva bude poslána jen v případě, když se vyskytne chyba při provádění nastavené úlohy.

o Vždy po provedení úlohy - zpráva o provedené úloze vám dojde vždy bez ohledu na to, zda se vyskytne chyba nebo ne.

· Příjemce - v případě, že jste nastavili posílání zpráv, zadejte e-mailovou adresu, na kterou se budou odesílat zprávy.

POZOR: V případě zasílání zpráv e-mailem je nutné nastavit v seznamu naplánovaných úloh pomocí ikony Obalka SMTP server. Tyto údaje záleží na nastavení vašeho STMP serveru. S jejich nastavením vám pomůže váš správce sítě.


Nastavení intrawebu

Navigation: Systém > Nastavení >

Nastavení intrawebu

 Return to chapter overview

Intrawebová aplikace Docházka slouží k prohlížení a editaci docházky pomocí internetového prohlížeče. V tomto nastavení se definuje intrawebové prostředí pro všechny zaměstnance ze seznamu zaměstnanců, kteří mají nastavená práva pro intraweb ve formuláři Zaměstnanec/Intraweb. Programové prostředí je dále možno nastavit tak, aby uživatelé měli přístup jen k určitým informacím a nemohli tak ovlivňovat výsledky docházky.

Formulář Nastavení intrawebu obsahuje v levé části strom s výběrem, jehož částmi jsou:

Osobní údaje

Obecné

Docházka

Vkládání docházky

Denní výsledky

Měsíční výsledky

Monitorování

Plánování absence

Schvalování absence

Editace docházky

Editace docházky 2

Editace docházky 3

Editace měsíčních

Počty osob

Historie průchodů

Služební cesty

Plánování kapacit

Plánování kapacit_2

Předávací procesy, XML

Tisk

Uživatelské položky

Jména a hesla

Typy práv uživatelů

Skupiny uživatelů

Práva uživatelů

Pravá část zobrazí po výběru požadované nastavení.

POZOR: Tato aplikace je dostupná pokud máte zakoupen modul Intrawebu.


Osobní údaje

Navigation: Systém > Nastavení > Nastavení intrawebu >

Osobní údaje

 Return to chapter overview

Slouží k nastavení zobrazených informací, které přihlášený uživatel uvidí v osobních údajích. V pravé části je seznam všech dostupných polí a v levém je seznam vámi vybraných polí, které chcete zobrazit. Seznam přenesete do druhé části jeho označením a stiskem tlačítka se šipkou, které je umístěno uprostřed mezi jmenovanými seznamy.

Nastaveni intrawebu osobni udaje

· Zobrazit osobní údaje - zatržením políčka dojde k zobrazení odkazu na intrawebu.

Nadpis řádku lze editovat (předtím je potřeba na něj dvakrát kliknout myší).

POZNÁMKA: Nastavení je společné pro všechny aplikace, a proto nejsou některá pole v některých aplikacích dostupná!


Obecné

Navigation: Systém > Nastavení > Nastavení intrawebu >

Obecné

 Return to chapter overview

V obecném nastavení máte možnost zvolit, kolik období se zobrazí v intrawebu uživatelům.

Nastaveni intrawebu obecne

· Výběr aplikace v horním menu - v horním menu se zobrazují názvy aplikací Docházka, Personalistika, Jídelna. Z nabídky si vyberte požadované:

o Nezobrazovat - v levém horním rohu v RON Portálu nebudou názvy aplikací zobrazeny.

o Zapínat a vypínat jednotlivé moduly samostatně - v levém horním rohu v RON Portálu se zobrazí názvy aplikací (Docházka / Personalistika / Jídelna). Po stisku některého názvu aplikace zobrazíte/skryjete menu v RON Portálu. Pokud je menu dané aplikace skryto, je název aplikace šedý. Pokud je menu aplikace zobrazeno, je název aplikace černý.

o Přepínat aktivní modul - v levém horním rohu v RON Portálu je zapnutá vždy jen jedna aplikace (například Docházka). Ostatní aplikace (například Personalistika) jsou zobrazeny šedě. Pokud chcete zobrazit menu jiné aplikace (Personalistika), musíte na ni kliknout. Poté se menu docházky skryje a zůstane zobrazeno jen menu Personalistiky.

· Výchozí obrazovka po přihlášení - ze seznamu vyberte výchozí stránku, která bude zobrazena po přihlášení do intrawebu. Pro automatickou volbu výchozí stránky (podle zapnutých funkcí a práv uživatele) zadejte prázdný text.

· Výběr osob - před jménem zobrazit - v poli pro výběr osob je možné zobrazit další pole z tabulky Osoba nebo PracovniPomer. Vyberte z předdefinovaných nabídek nebo zadejte vlastní SQL pole.

· Výběr osob - za jménem zobrazit - v poli pro výběr osob je možné zobrazit další pole z tabulky Osoba nebo PracovniPomer. Vyberte z předdefinovaných nabídek nebo zadejte vlastní SQL pole.

o Osoba.Uzivatelska1 - před jménem/za jménem se zobrazí hodnota zadaná v Uživatelském poli 1 v kartě zaměstnance na záložce Ostatní údaje. Uživatelská pole je možné přejmenovat v nastavení aplikace na záložce Uživatelská pole osob.

o Osoba.Uzivatelska1 + ': ' - před jménem/za jménem se zobrazí hodnota zadaná v Uživatelském poli 1 s dvojtečkou za zobrazenou hodnotou.

o Osoba.IntrawebLogin - před jménem/za jménem se zobrazí přihlašovací jméno osoby.

o PracovniPomer.OsobniCislo - před jménem/za jménem se zobrazí osobní číslo zaměstnance.

· Typ rozdělení pro výběr 1, 2 - vyberte typ rozdělení pro filtrování dat (například v monitorování).

· Nadpis - zadání nadpisu není povinné. Pokud nebude nadpis zadán, zobrazí se výchozí text "Rozdělení".

o Výchozí nastavení

o Jen vlastní rozdělení - vyberete-li tuto funkci, zobrazí se údaje zaměstnanců patřících do příslušného rozdělení.

o Podle práv

· Typ rozdělení pro zobrazení - vyberte typ rozdělení, který se zobrazí u osob v seznamech, například v seznamu hodnocení, služebních cest, schvalování docházky.

Pozor! Zaměstnanci, kteří nebudou mít toto rozdělení přiřazeno, nemusí být v některých seznamech zobrazeni!

· Nadpis - zadejte nadpis sloupce. Pokud nadpis nebude zvolen, nebude zobrazen název sloupce.

· Položka, která se má zobrazit - zvolte, které údaje se mají zobrazit ve sloupci u osob v seznamech.

o Popis rozdělení - ve sloupci se zobrazí popis rozdělení.

o Kód rozdělení - ve sloupci se zobrazí kód rozdělení.

o Kód i popis rozdělení - ve sloupci se zobrazí kód i popis rozdělení.

· Maximální počet zobrazených období - při výběru období se nabídne jen zadaný počet starších období. Pokud zadáte hodnotu 0, nebude počet omezen.

· Výchozí měna - v intrawebu se přednastaví vybraná měna. S přednastavenou výchozí měnou se můžete například setkat ve služebních cestách v řádku účtování.

· URL adresa pro zobrazení intrawebu - použije se v aplikaci, pokud bude potřeba zobrazit nějakou stránku intrawebu.

· Povolit synchronizaci kalendářů (ical) - povolí synchronizaci kalendářů.

· Zobrazit vzkazy - zatržením pole se vám v intrawebu zobrazí odkaz Vzkazy.


Docházka

Navigation: Systém > Nastavení > Nastavení intrawebu >

Docházka

 Return to chapter overview

V docházce provedete nastavení pro intraweb.

· Povolit docházku v intrawebu - zaškrtnutím políčka se vám docházka zobrazí na intrawebu.

· Povolit docházku zaměstnance (původní docházka) - zatržením pole se vám v intrawebu zobrazí odkaz Docházka zaměstnance.

· Zobrazit kód terminálu v původní docházce - pokud pole zatrhnete, potom se vám zobrazí kód terminálu v závorce za provedenou operací. Tato funkce se zobrazuje v odkazu Docházka zaměstnance.

· Povolit historii průchodů - povolením historie průchodu se vám zobrazí odkaz Historie průchodů.

· Povolit zpracovanou docházku - zatržením pole se v intrawebu zobrazí odkaz Zpracovaná docházka.

· Povolit denní výsledky - v intrawebu se vám zobrazí odkaz Denní výsledky.

· Povolit měsíční výsledky - zatržením pole se vám zobrazí odkaz Měsíční výsledky.

· Povolit variabilní výsledky - povolením variabilních výsledků se vám v intrawebu zobrazí odkaz Variabilní výsledky. Pokud máte zároveň povoleny denní výsledky za variabilní období, budou ve variabilních výsledcích zobrazeny odkazy Variabilní výsledky a Denní výsledky.

· Povolit měsíční výsledky podle rozdělení - povolením měsíčních výsledků podle rozdělení se vám v intrawebu zobrazí u Měsíčních výsledků odkazy Přehled měsíčních výsledků a Přehled měsíčních výsledků podle rozdělení. V přehledu měsíčních výsledků podle rozdělení můžete sledovat kolik odpracovaných a neodpracovaných hodin zaměstnanec strávil na jednotlivém rozdělení. Používání rozdělení docházky je třeba mít nastaveno v menu Systém/Nastavení aplikace/Společné nastavení/Rozdělení docházky.

· Zobrazení zpracované docházky - z nabídky zvolte, jaké zobrazení se má ve zpracované docházce nastavit:

o Podle volby uživatele - nad seznamem zpracované docházky si uživatel může zvolit, jakou podobu zpracované docházky chce zobrazit. Uživatel může v seznamu zobrazit zpracovanou docházku v grafické i textové podobě (grafická i text), jen v textové (text), jen v grafické (grafická) nebo nezobrazovat ani textovou ani grafickou podobu (nic).

o Grafické zobrazení zpracované docházky - v seznamu se zobrazí jen grafická podoba zpracované docházky.

o Textové zobrazení zpracované docházky - v seznamu se zobrazí jen textová podoba zpracované docházky.

o Grafické i textové zobrazení - v seznamu se zobrazí grafická i textová podoba zpracované docházky.

o Nic - v seznamu se nezobrazí textová ani grafická podoba zpracované docházky.

· Vzdálené spouštění agentů - host - intraweb nyní nepotřebuje práva ke spouštění příkazové řádky. Pro správnou funkci je nutné nastavit Cestu k programovým souborům, Vzdálené spouštění agentů - host a Číslo portu. Potom je možné nastavit v plánovači úlohu Server vzdáleného spouštění. Úloha musí být naplánovaná On line.

· Číslo portu - zadejte číslo portu.

· Zobrazit kalendář - v intrawebu se vám zobrazí odkaz Kalendář.

· Povolit denní výsledky za variabilní období - povolením denních výsledků variabilního období se vám v intrawebu zobrazí odkaz Variabilní výsledky. Pokud ovšem máte zároveň povoleny variabilní výsledky, budou ve variabilních výsledcích zobrazeny odkazy Variabilní výsledky a Denní výsledky.

· Zobrazit omezení docházky - zatržením zobrazíte odkaz Omezení docházky zaměstnance, ve kterém se zobrazí seznam nastavených omezení. Omezení jste nastavili v menu Seznamy/Kalendáře - formulář Kalendáře - záložka Omezení.

· Zobrazit mzdové položky - v intrawebu se vám zobrazí odkaz Mzdové položky.

· Cesta k programovým souborům Docházky (pro spouštění agentů) - zadejte cestu k programovým souborům Docházky. Pro správnou funkčnost vyúčtování zkontrolujte práva na soubor cmd.exe! Uživatel musí mít práva na spouštění a čtení jednotlivých programových souborů. Například pro přepočet docházky musí mít uživatel právo na soubory ADS_Agent_Processing.exe a ADS.CCF.


Vkládání docházky

Navigation: Systém > Nastavení > Nastavení intrawebu >

Vkládání docházky

 Return to chapter overview

· Při vkládání docházky zkontrolovat - nepovolí vkládat docházku pokud je již daný den schválen/zkontrolován/zpracován.

· Při vkládání doplnit do pole karta - při vkládání se do pole karta může doplnit Název počítače, IP adresa počítače anebo může pole zůstat prázdné.

· Počet dnů pro zpětné vkládání - nastavte počet dnů pro zpětné vkládání dat docházky přes intraweb (od posledního zpracování docházky). Tím se umožní vložení do historie docházky. Nesmí to být více, než je počet dnů pro zpětné zpracování docházky (Nastavení aplikace/Společné nastavení/Zpracování původní docházky).

· Povolit výběr času z historie průchodů - po zatrhnutí pole bude možné při vkládání operací, které nemají povoleno ruční nastavení času, zadat datum a vybrat čas podle průchodu terminálem (tabulka HistoriePruchodu).

· Způsob určení terminálu - z nabídky vyberte způsob určení terminálu:

o Nevkládat kód terminálu - při vkládání docházky se nebude zadávat kód terminálu.

o Vybraný terminál

o Určení terminálu podle URL

o Uživatelská funkce z user_utils.php

· Povinné zadání terminálu při vkládání - pokud je při vkládání docházky povinné zadání terminálu, zatrhněte pole. Jedná se o kód terminálu, který se zapíše do původní docházky. Docházku nebude možné vkládat bez zadání tohoto parametru. Při vkládání je možné zadat v url adrese pomocí parametru terminalvkladani=<kod_terminalu>.


Denní výsledky

Navigation: Systém > Nastavení > Nastavení intrawebu >

Denní výsledky

 Return to chapter overview

Denní výsledky - slouží k nastavení zobrazených sloupců, které přihlášený uživatel uvidí v přehledu denních výsledků. V pravé části je seznam všech dostupných časových složek a v levém je seznam vámi vybraných časových složek, které chcete zobrazit. Seznam přenesete do druhé části jeho označením a stiskem tlačítka se šipkou, které je umístěno uprostřed mezi těmito seznamy. Rovněž lze povolit úpravu (editaci) jednotlivých výsledků časových složek, která se projeví v denních výsledcích docházky daného zaměstnance (nepřepíše však grafické znázornění pouze číselné vyjádření této složky). Zatržením zobrazování prázdných kolonek dojde k zobrazení všech dostupných sloupců sestavy tedy i těch s nulovou hodnotou výsledku.


Měsíční výsledky

Navigation: Systém > Nastavení > Nastavení intrawebu >

Měsíční výsledky

 Return to chapter overview

Měsíční výsledky - slouží k nastavení sloupců časových složek v přehledu měsíčních výsledků, které přihlášený uživatel uvidí.


Monitorování

Navigation: Systém > Nastavení > Nastavení intrawebu >

Monitorování

 Return to chapter overview

Monitorování - slouží k nastavení zobrazených sloupců, které přihlášený uživatel uvidí v položce monitorování.


Planovani absence

Navigation: Systém > Nastavení > Nastavení intrawebu >

Plánování absence

 Return to chapter overview

V docházce provedete nastavení pro Plánování absence.

· Počet dnů pro zpětné plánování absencí - nastavte počet dnů, pro které mohou uživatelé zpětně plánovat absenci. Můžete zadat i záporné číslo - v tom případě omezíte plánování i na příslušný počet budoucích dnů.

· Při plánování absence zobrazit hodnotu časových složek - hodnota vybrané časové složky se zobrazí ve formuláři pro plánování absence v intrawebu.

o Kódy složek - do pole zadejte kódy časových složek oddělené středníkem.

o Nadpisy - do pole zadejte nadpisy pro zvolené časové složky oddělené středníkem. Pokud chcete změnu, přepište stávající nadpis. Hodnota vybrané časové složky bude zobrazena u zvoleného nadpisu ve formuláři pro plánování absence v intrawebu.


Schvalování absence

Navigation: Systém > Nastavení > Nastavení intrawebu >

Schvalování absence

 Return to chapter overview

Pokud máte aktivován Intraweb Plus, potom můžete v programu Docházka nastavit odesílání oznámení o plánovaných, schválených a zamítnutých absencí emailem.

Před samotným nastavením v programu je nutné provést konfiguraci. Postup nastavení naleznete ke stažení na Helpdesku v odkazu Ke stažení -> Intraweb -> Instalace PHP a intrawebu. Potřebné nastavení je v manuálu v kapitole Odesílání emailů z intrawebu (cca 13 stránka). Po konfiguraci přejděte k samotnému nastavení odesílání emailů.

V programu Docházka je nutné zaměstnancům nastavit jejich emailové adresy, na které se budou odesílat potvrzení o schválených a zamítnutých absencí (karta zaměstnance -> Ostatní údaje).

· Používat schvalování absence - pokud chcete schvalovat v intrawebu absenci, je potřeba zaškrtnou toto pole.

· Při vkládání nových absencí skrýt zaškrtávátko "schváleno" - pokud zatrhnete pole, potom při vkládání nové absence bude skryto zaškrtávátko schváleno. Absence se bude muset vždy schválit dodatečně.

· Používat doporučování absence - po zatržení této funkce je možné v intrawebu nastavit příznak "doporučeno" nebo "nedoporučeno" jako mezikrok před schválením absence.

Odesílání emailu - naplánování absence

· Odesílat oznámení o naplánované absenci - pokud chcete plánování absencí využívat, zaškrtněte.

V dalším kroku nastavte emailové adresy, na které se odešle oznámení o naplánované absenci. Můžete nastavit konkrétní Příjemce emailu a/nebo vybrat Typ rozdělení pro email.

· Příjemce emailu - zadejte emailové adresy oddělené středníkem, na které se zašle zpráva o naplánované absenci.

· Typ rozdělení pro email - zadejte typ rozdělení pro určení emailové adresy. Email bude odeslán vedoucímu pracovníkovi na adresu rozdělení daného typu, do kterého je zaměstnanec (podřízený) zařazen. Emailové adresy nastavíte v programu Docházka (menu Seznamy -> Rozdělení).

· Odesílatel - zadejte emailovou adresu odesílatele. Pokud není adresa zadána, určí se podle osoby, pro kterou je absence zadána.

· Předmět emailu - zadaný text se zobrazí v přijatém emailu jako předmět zprávy (Docházka - plánování absence).

· Text emailu - zadejte text zprávy o oznámení naplánované absence. Můžete použít následující parametry:

%JMENO%

%OSOBNICISLO%

%RC%

%DATUMOD%

%DATUMDO%

%ABSENCE%

%POZNAMKA%

%LINK%

PŘÍKLAD nastavení textu emailu:

Zaměstnanec %JMENO% si naplánoval absenci:

Datum od: %DATUMOD%

Datum do: %DATUMDO%

Absence: %ABSENCE%

Poznámka: %POZNAMKA%

Link: http://JMENO_SERVERU/ads_new/ads.php%LINK%

Pokud chcete provedené změny v textu emailu vrátit na původní hodnoty, stiskněte tlačítko Vychozi text.

odesílání emailu - schválení a zamítnutí absence

· Odesílat oznámení o schválení a zamítnutí - pokud chcete odesílat informace zaměstnancům o schválení/zamítnutí absence, zaškrtněte.

· Odesílatel - zadejte emailovou adresu odesílatele. Pokud nebude adresa zadána, použije se emailová adresa přihlášeného uživatele.

· Předmět emailu o schválení/zamítnutí - zadejte text, který se zobrazí v přijatém emailu jako předmět zprávy u schválené a zamítnuté absence (Docházka - schválení/zamítnutí plánované absence).

· Příjemce kopie emailu - zadejte emailové adresy oddělené středníkem, na které se zašle kopie zprávy o schválení nebo zamítnutí absence.

· Text emailu schválení/zamítnutí - zadejte text zprávy pro schválení a zamítnutí naplánované absence. Můžete použít stejné parametry, které jsou uvedeny výše.

PŘÍKLAD nastavení textu emailu:

Vaše plánovaná absence byla schválena/zamítnuta.

Podrobnosti:

Datum od: %DATUMOD%

Datum do: %DATUMDO%

Absence: %ABSENCE%

Schválil/Zamítnul: %UZIVATEL%

http://JMENO_SERVERU/ads/ads.php%LINK%

Pokud chcete provedené změny v textu emailu vrátit na původní hodnoty, stiskněte tlačítko Vychozi text.

odesílání emailu - ŽÁDOST O ZRUŠENÍ ABSENCE / zrušení absence / zamítnutí žádosti o zrušení absence

· Předmět emailu - zadejte text, který se zobrazí v přijatém emailu jako předmět zprávy u schválené a zamítnuté absence (Docházka - žádost o zrušení absence / zrušení naplánované absence / zamítnutí žádosti o zrušení absence).

· Text emailu - zadejte text zprávy pro schválení a zamítnutí naplánované absence. Můžete použít stejné parametry, které jsou uvedeny výše.

PŘÍKLADY nastavení textu emailu:

Zaměstnanec %JMENO% zažádal o zrušení absence:

Datum od: %DATUMOD%

Datum do: %DATUMDO%

Délka: %DELKA%

Absence: %ABSENCE%

http://server/ads/ads.php%LINK%

Vaše plánovaná absence byla zrušena.

Podrobnosti:

Datum od: %DATUMOD%

Datum do: %DATUMDO%

Délka: %DELKA%

Absence: %ABSENCE%

Absenci zrušil: %UZIVATEL%

http://server/ads/ads.php%LINK%

Vaše žádost o zrušení plánované absence byla zamítnuta.

Podrobnosti:

Datum od: %DATUMOD%

Datum do: %DATUMDO%

Délka: %DELKA%

Absence: %ABSENCE%

Žádost zamítnul: %UZIVATEL%

http://server/ads/ads.php%LINK%

Pokud chcete provedené změny v textu emailu vrátit na původní hodnoty, stiskněte tlačítko Vychozi text.


Editace docházky

Navigation: Systém > Nastavení > Nastavení intrawebu >

Editace docházky

 Return to chapter overview

Editace docházky - ve formuláři nastavíte editování docházky v Intrawebu.

· Povolit editaci docházky - pokud chcete povolit editaci docházky, zatrhněte políčko. Pokud pole zatrhnete, potom můžete v intrawebu v odkazu Zpracovaná docházka upravovat intervaly denních záznamů.

· Sloupce zpracované docházky - nastavte sloupce, které se zobrazí ve zpracované docházce. Tlačítkem Vychozi nastaveni Výchozí nastavení přepíšete aktuální nastavení sloupců výchozím nastavením. Po stisku tlačítka se zobrazí dotaz zda si opravdu přejete přepsat aktuální nastavení sloupců výchozím nastavením. Po jeho potvrzení se zobrazí varování, že aktuální nastavení sloupců zpracované docházky bude přepsáno výchozím nastavením. Po stisku tlačítka Vysvetlivky Vysvětlivky se zobrazí internetové okno, kde naleznete vysvětlení k nastavení sloupců zpracované docházky (viz další popis).

Výchozí nastavení:

<?xml version="1.0" encoding="windows-1250"?>

<zpracovanadochazka editovatvzdycelyden="0" vkladatprestavky="0" grafickaminwidth="200" grafickamaxwidth="600">

<sloupeczpracovanedochazky typ="SCHVAL1" />

<sloupeczpracovanedochazky typ="SCHVAL2" />

<sloupeczpracovanedochazky typ="SCHVAL3" />

<sloupeczpracovanedochazky typ="DATUM" />

<sloupeczpracovanedochazky typ="DOCH_G" />

<sloupeczpracovanedochazky typ="DOCH_T" nadpis="" />

<sloupeczpracovanedochazky typ="EDIT" nadpis="" />

</zpracovanadochazka>

Vysvětlivky:

editovatvzdycelyden="1" - při kliknutí na interval se bude zobrazovat editace celého dne. Parametr není povinný, výchozí hodnota je "0".

vkladatprestavky - parametr určuje, jestli se mají při přepočtu docházky vkládat přestávky.

grafickaminwidth, grafickamaxwidth - nepovinné parametry určují minimální a maximální šířku grafického zobrazení docházky.

Sloupce pro zobrazení schválení - první (zelená), druhá (žlutá) a třetí (červená) úroveň - se přidají pomocí položek s typem SCHVAL1, SCHVAL2 a SCHVAL3. Pro sloupec s datumem slouží typ DATUM - lze u něj nastavit atributy class, style a nadpis.

<sloupeczpracovanedochazky typ="SCHVAL1" />

<sloupeczpracovanedochazky typ="SCHVAL2" />

<sloupeczpracovanedochazky typ="SCHVAL3" />

<sloupeczpracovanedochazky typ="DATUM" />

Grafické zobrazení intervalů docházky se zapne pomocí položky DOCH_G:

<sloupeczpracovanedochazky typ="DOCH_G" />

Textové zobrazení intervalů docházky se zapne pomocí položky DOCH_T:

<sloupeczpracovanedochazky typ="DOCH_T" nadpis="Záznamy docházky" />

Textové zobrazení s proměnnými %KOD%, %POPIS%, %ZKRATKA%:

<sloupeczpracovanedochazky typ="DOCH_G" format="%ZKRATKA% (%KOD%)"/>

Textový popis záznamů v jednom sloupci, oddělené čárkou:

<sloupeczpracovanedochazky typ="DOCH_Z" nadpis="Záznamy" format="%ZKRATKA%" style="white-space:nowrap" />

Zobrazení informací o směně (podle nastavení kalendáře se automaticky použije směna podle kalendáře nebo podle plánování kapacit):

<sloupeczpracovanedochazky typ="SMENA" nadpis="Směna" />

<sloupeczpracovanedochazky typ="SMENA_POPIS" nadpis="Směna" />

<sloupeczpracovanedochazky typ="SMENA_Z" nadpis="Směna od" />

<sloupeczpracovanedochazky typ="SMENA_K" nadpis="Směna do" />

<sloupeczpracovanedochazky typ="SMENA_ZK" nadpis="Směna od-do" />

<sloupeczpracovanedochazky typ="SMENA_DELKA" nadpis="Délka směny" />

Vysvětlivky:

SMENA - zobrazí kód směny,

SMENA_POPIS - zobrazí popis směny,

SMENA_Z, SMENA_K, SMENA_ZK - zobrazí začátek a/nebo konec směny,

SMENA_DELKA - zobrazí délku směny.

Podobně fungují i sloupce s typem KAL, KAL_POPIS, KAL_Z, KAL_K, KAL_ZK, KAL_DELKA - zobrazí údaje o směně podle kalendáře

a KAP, KAP_POPIS, KAP_Z, KAP_K, KAP_ZK, KAP_DELKA - zobrazí údaje o směně podle plánování kapacit.

Zobrazení editačních ikon (editace dne, nový záznam, smazání celého dne):

<sloupeczpracovanedochazky typ="EDIT" />

Zobrazení prvního příchodu a posledního odchodu dne - sloupce DOCH1 a DOCH2. Příchody a odchody se započítávají do dne přiřazení intervalu docházky!

<sloupeczpracovanedochazky typ="DOCH1" nadpis="Začátek" zapocitatoperace="01;10" hintpuvodni="0/1" hintpruchody="0/1" zobrazenycas="0/1"/>

<sloupeczpracovanedochazky typ="DOCH2" nadpis="Konec" zapocitatoperace="01;10" zobrazenycas="0/1" />

Vysvětlivky:

zapocitatoperace - nepovinný parametr omezí výpočet začátku a konce jen na vyjmenované operace. Pokud není zadán, započítají se všechny intervaly. Mohou tak být dva různé sloupce a každý z nich zobrazovat jinou operaci (nebo jinou skupinu operací).

hintpuvodni, hintpruchody - parametry určují, jestli se má v tooltipu pole (tj. při najetí myší na pole) zobrazit seznam původní docházky, respektive průchodů.

zobrazenycas - parametr určuje jestli se má zobrazit započtený čas (default) nebo zobrazený.

Příchody a odchody je možné také editovat:

<sloupeczpracovanedochazky typ="DOCH1" nadpis="Začátek" editace="1" operace="01" />

<sloupeczpracovanedochazky typ="DOCH2" nadpis="Konec" editace="1" />

Při editaci příchodu/odchodu se upraví první/poslední interval dne tak, aby začínal/končil v požadovanou dobu. Pokud jsou v daném dni intervaly, které jsou celé před zadaným příchodem/po zadaném odchodu, tak se celé odstraní. Pokud je u daného sloupce nastavena operace (např. operace="01"), a je zadán příchod před prvním existujícím intervalem, (respektive odchod po posledním intervalu), tak se na začátek/konec vloží nový interval s danou operací. V případě, že v daném dni není žádný interval, pak je možné vložit tímto způsobem nový záznam pouze v případě, že má alespoň jeden ze sloupců nastavenu operaci.

Sloupce pro zobrazení kalendáře přiřazeného zaměstnanci v daném dni se přidají pomocí položek s typem K_KOD a K_POPIS

<sloupeczpracovanedochazky typ="K_KOD" nadpis="Kalendář" />

<sloupeczpracovanedochazky typ="K_POPIS" nadpis="Kalendář" />

Zobrazení denních výsledků (hodiny, dny, kalendářní dny) včetně možnosti editace:

<sloupeczpracovanedochazky typ="DV" kod="105" jednotka="H" editace="1" nadpis="Prostředí." />

<sloupeczpracovanedochazky typ="DV" kod="993" jednotka="H" editace="0" nadpis="Přestávky" />

<sloupeczpracovanedochazky typ="DV" kod="999" jednotka="H" editace="0" nadpis="Norma" style="font-weight:bold; text-align:center"/>

Vysvětlivky:

Parametr kod určuje kód časové složky, jednotka může být "H" (hodiny), "D" (dny) nebo "K" (kalendářní dny). Pokud je zadáno editace="1", bude sloupec editovatelný.

Pro úpravu stylu sloupce je možné použít parametr style nebo parametr class v kombinaci s uživatelsky definovanými styly v souboru s_user.css.

Poznámka ke dni docházky může být pouze zobrazena, nebo editovatelná (parametr editace="1").

<sloupeczpracovanedochazky typ="P" editace="1" nadpis="Poznámka" />

Plánované absence a události

<sloupeczpracovanedochazky typ="ABSENCE" nadpis="Absence" style="font-size: 80%; color:blue;" class="sloupec_absence" />

Zobrazí seznam absencí naplánovaných na daný den. Standardně se zobrazuje popis operace, ale je možné zobrazit i jiný text pomocí parametru format, například takto:

format="&lt;span title='%POPIS%' &gt;%ZKRATKA% (%KOD%)&lt;/span&gt;"

Pokud se nastaví u kořenového tagu atribut absenceclass='1', bude mít každý řádek nastaven class podle kódu absence. To je možné použít pro obarvení buněk tabulky nebo celých řádků.

Rozdělení denních výsledků (tabulka DenniVysledek_R_E)

<sloupeczpracovanedochazky typ="DV_ROZDELENI" nadpis="Rozdělení výsledků" />

Původní docházka a průchody

<sloupeczpracovanedochazky typ="PUV1" nadpis="První" />

<sloupeczpracovanedochazky typ="PUV2" nadpis="Poslední" />

<sloupeczpracovanedochazky typ="PUV" nadpis="Puvodní docházka" style="font-size:80%; color:darkgray"/>

Nastavení zobrazených tlačítek - umístění může být "1" (vlevo nahoře), "2" (vpravo nahoře), "3" (vlevo dole) nebo "4" (vpravo dole). Pomocí parametru style je možné určit css styl tlačítka (například barvu). Nepovinný parametr text určuje nadpis tlačítka. Pokud není zadán, použije se výchozí text podle typu tlačítka.

<tlacitko typ='ulozit' umisteni='2' />

<tlacitko typ='schvalit' umisteni='2' style='background-color: #40C040'/>

<tlacitko typ='zrusitschvaleni' umisteni='2' style='background-color: #C04040'/>

<tlacitko typ='podlepuvodni' umisteni='2' text="Obnovit původní" />

<tlacitko typ='doplnitpuvodni' umisteni='2' text="Doplnit původní" />

<tlacitko typ='rozdelenidv' umisteni='3' />

<tlacitko typ='prepocitat' umisteni='4' />

<tlacitko typ="skript" umisteni="3" text="Spusť skript" id="s1" kategorie="kategorie_skriptu" skript="nazev_skriptu" />

Tlačítko ulozit - provede uložení editovaných dat.

Tlačítko schvalit - provede schválení docházky až do konce měsíce. Pokud uživatel může schvalovat více úrovněmi, použije se nejvyšší úroveň, na kterou má právo. Nezobrazuje se v případě, že už je docházka schválena do konce období.

Tlačítko dialogschvaleni - zobrazí formulář pro schválení docházky.

Tlačítko zrusitschvaleni - zruší schválení docházky (nejvyšší úroveň, na kterou má uživatel právo).

Tlačítko podlepuvodni - provede přegenerování celého měsíce podle původní docházky. POZOR! Všechny ruční úpravy docházky budou smazány!

Tlačítko rozdelenidv - umožňuje hromadnou editaci rozdělení denních výsledků.

Tlačítko prepocitat - provede přepočet výsledků za celý měsíc.

Tlačítko skript - provede zadaný skript (kategorie/skript). Musí mít zadané ID, aby se rozlišily různé tlačítka "skript".

· Zobrazit přehled měsíčních výsledků u zpracované docházky - po zatrhnutí pole se u zpracované docházky zobrazí přehled měsíčních výsledků.

· Nezobrazovat v editaci započtený čas - uživatel zadává pouze čas od - do.

· Povolit editaci schválené docházky - povolí editovat schválenou docházku uživatelům, kteří mají vyšší oprávnění pro schvalování. To znamená, že uživatel, který má práva na schvalování úrovně 2, může editovat docházku, která je schválena jen úrovní 1 a podobně.

· Přepisovat existující záznamy - zaškrtnutím tlačítka umožníte přepsat existující záznamy.

· Uzamknout měsíční výsledky při schválení docházky - vyberte úroveň schválení docházky, při které se uzamknou výsledky.

· Uzamknout mzdové položky při schválení docházky - vyberte úroveň schválení docházky při které se uzamknou mzdové položky.

· Při vložení nového intervalu vždy generovat přestávky - pokud zatrhnete pole, potom při vložení nového intervalu v docházce se vždy budou generovat přestávky.

· Počet dnů pro vkládání - nastavte omezení pro vkládání záznamů zpracované docházky - počet dnů od aktuálního data. Kromě tohoto nastavení se ověřuje také datum zpracované docházky!

Příklad:

0 = maximálně lze vkládat pro aktuální den,

5 = lze vkládat až 5 dnů dopředu,

-1 = maximálně lze vkládat na předchozí den.


Editace docházky 2

Navigation: Systém > Nastavení > Nastavení intrawebu >

Editace docházky 2

 Return to chapter overview

Ve formuláři můžete nastavit měsíční výsledky a mzdové položky, které bude možné editovat v přehledu zpracované docházky.

Řádky pro editaci měsíčních výsledků v přehledu zpracované docházky / 2 - pro nastavení použijte XML formulář s tagem <editacemesicnich>. Přes tlačítko Priklad zobrazíte příklad nastavení XML editace měsíčních výsledků a mzdových položek.

PŘÍKLAD: <?xml version="1.0" encoding="windows-1250"?>

<editacemesicnich sirkapole="40">

<radekeditacemesicnich typ="MV" kod="100" hodiny="1" dny="1" kalendarnidny="1" nadpis="Odprac." styl="font-weight:bold"/>

<radekeditacemesicnich typ="MV" kod="114" hodiny="2" dny="1" nadpis="Nařízený přesčas" />

<radekeditacemesicnich typ="MV" kod="997" hodiny="2" nadpis="Převáděný přesčas" />

</editacemesicnich>

<?xml version="1.0" encoding="windows-1250"?>

<editacemesicnich sirkapole="80">

<radekeditacemesicnich typ="MP" kod="125" castka="1" nadpis="Osobní příplatek" />

<radekeditacemesicnich typ="MP" kod="123" castka="2" nadpis="Zvláštní příplatek" />

<radekeditacemesicnich typ="MP" kod="243" castka="2" nadpis="Odměny za vynálezy a zlepšovací návrhy" />

</editacemesicnich>

Vysvětlivky: 1/2 - needitovatelná / editovatelná položka

MV/MP - měsíční výsledky/mzdové položky


Editace docházky 3

Navigation: Systém > Nastavení > Nastavení intrawebu >

Editace docházky 3

 Return to chapter overview

Ve formuláři je možné nastavit rozdělení záznamů docházky a denních výsledků.

Rozdělení záznamů docházky

· Typ rozdělení pro editaci - ze seznamu vyberte typ rozdělení pro editaci. Pokud je nastaven typ rozdělení a budete editovat interval denního záznamu, potom se v zobrazeném formuláři objeví položka "Rozdělení", ve které můžete (položka Zadání rozdělení je povinné není zaškrtnutá) nebo musíte (zaškrtnutá položka Zadání rozdělení je povinné) vybrat požadované rozdělení.

· Zadání rozdělení je povinné - určete zatržením, zda je zadání rozdělení povinné. Pokud je rozdělení povinné, je nutné požadované rozdělení vybrat z nabízeného seznamu. Pokud rozdělení v tomto případě nevyberete, zobrazí se vám hláška: "Není zadáno rozdělení docházky!".

· Nadpis políčka s rozdělením - umožní přiřadit rozdělení k záznamu zpracované docházky (tabulka RozliseniDochazky). Zadání nadpisu není povinné. Pokud nebude nadpis zadán, zobrazí se výchozí text "Rozdělení".

Rozdělení denních výsledků

· Typ rozdělení pro denní výsledky - ze seznamu vyberte typ rozdělení pro editaci. Pokud je nastaven typ rozdělení a budete editovat interval denního záznamu, potom se v zobrazeném formuláři objeví položka "Rozdělení", ve které můžete (položka Zadání rozdělení je povinné není zaškrtnutá) nebo musíte (zaškrtnutá položka Zadání rozdělení je povinné) vybrat požadované rozdělení.

· Vybírat pouze z vlastních (přiřazených) rozdělení - zatržením určete, zda se rozdělení bude vybírat pouze z přiřazených rozdělení.

· Povolit uživatelům výběr vlastních rozdělení - určete zatržením, zda uživatelům povolíte výběr vlastních rozdělení.

· Povolené časové složky - zadejte kódy časových složek (oddělené středníkem), které je možné v rozdělení denních výsledků zadat. První časová složka bude výchozí pro nový záznam. Pokud nechcete pevně nastavit výchozí složku, vložte na začátek nastavení středník.

· Časová složka pro kontrolu součtu - vyberte časovou složku pro kontrolní součet, například Odpracovaná doba (nepovinné).


Editace měsíčních

Navigation: Systém > Nastavení > Nastavení intrawebu >

Editace měsíčních

 Return to chapter overview

Ve formuláři můžete nastavit měsíční výsledky a mzdové položky, které bude možné editovat v přehledu zpracované docházky.

Hromadna editace mesicnich vysledku a mzdovych polozek

· Sloupce pro editaci měsíčních výsledků a mzdových položek - pro použijte XML formulář s tagem <editacemesicnich>. Nápověda k XML formuláři je v intrawebu v souboru install/xml_formular.html. Přes tlačítko Priklad zobrazíte příklad nastavení XML editace měsíčních výsledků a mzdových položek.

PŘÍKLAD: <?xml version="1.0" encoding="windows-1250"?>

<editacemesicnich datumpp="2" sirkapole="50" vcetnepodrizenych="1" prepocetdochazky="0">

<sloupeceditacemesicnich typ="R" nadpis="Středisko" />

<sloupeceditacemesicnich typ="MV" kod="100" jednotka="H" lzeeditovat="0" nadpis="Odprac." />

<sloupeceditacemesicnich typ="MV" kod="114" jednotka="H" lzeeditovat="1" nadpis="Nařízený přesčas" />

<sloupeceditacemesicnich typ="MP" kod="244" lzeeditovat="1" nadpis="Mimořádná odměna" />

</editacemesicnich>

Vysvětlivky: 1/0 - povolit / zakázat

H/D/K - hodiny / dny / kalendářní dny

MV/MP - měsíční výsledky/mzdové položky


Počty osob

Navigation: Systém > Nastavení > Nastavení intrawebu >

Počty osob

 Return to chapter overview

Počty osob - slouží k nastavení sloupců pro zobrazení počtu zaměstnanců s vybranou časovou složkou v daném období. Zatržením zobrazování prázdných kolonek dojde k zobrazení všech dostupných sloupců sestavy tedy i těch s nulovou hodnotou výsledku.


Historie průchodů

Navigation: Systém > Nastavení > Nastavení intrawebu >

Historie průchodů

 Return to chapter overview

Historie průchodů - nastavuje se zde odkaz pro manuální vkládání do historie průchodů v povoleném rozsahu.

Pro funkčnost odkazu je třeba nastavit:

· Položka v menu - položka, jejíž vložený název se zobrazí v menu intrawebu (Vložení historie průchodu).

· Nadpis - po stisku položky menu v intrawebu se v pravé části zobrazí vložený nadpis (Manuální vložení operace do historie průchodů).

· Terminál - ze seznamu zvolte terminál, který zaznamenává průchodové operace. Tyto operace budou zobrazeny k výběru při vkládání do historie průchodů.


Služební cesty

Navigation: Systém > Nastavení > Nastavení intrawebu >

Služební cesty

 Return to chapter overview

Služební cesty - slouží k nastavení a povolení služebních cest v Intrawebu.

· Povolit služební cesty v intrawebu - po zatrhnutí pole se v intrawebu zobrazí odkaz Služební cesty.

· Povolit editaci služebních cest v uzavřeném období - zatrhnutím pole povolíte editaci služebních cest v uzavřeném období.

· Používat vrácení služebních cest - po zatrhnutí pole může uživatel zrušit poslední úroveň schválení pomocí odkazu Vrátit.

· Nepoužívat schvalování služebních cest zaměstnancem - po zatrhnutí pole se nebude v intrawebu používat schvalování služebních cest zaměstnancem.

· Zobrazit kompaktní přehled řádků služebních cest - po zatrhnutí pole se zobrazí ve služebních cestách kompaktní přehled řádků služebních cest.

· Povolit editaci maximální počet dnů zpětně - v kolonce nastavte maximální počet dnů pro povolení zpětné editace (0 = bez omezení).

· Výpočet vzdálenosti startu a cíle (podle google maps) - z nabídky vyberte, zda se má provádět výpočet vzdálenosti startu a cíle.

o Zakázat - nepovolí se výpočet vzdálenosti startu a cíle. Při zadávání náhrady za použití vlastního vozidla se nezobrazí tlačítko Vzdálenost pro přepočet ujeté vzdálenosti a zaškrtávací pole Zpáteční cesta.

o Nejdříve podle vybraného místa pak podle popisu - při zadávání náhrady za použití vlastního vozidla se zobrazí tlačítko Vzdálenost, kterým provedete výpočet vzdálenosti nejprve podle vybraného místa a pak podle popisu. Data pro výpočet vzdálenosti jsou brány ze zapsaných údajů v polích Místo začátku a Cíl. Dále se zobrazí zaškrtávací pole Zpáteční cesta. Pokud je pole zaškrtnuté, potom se do ujeté vzdálenosti započítá i zpáteční cesta.

o Nejdříve podle vybraného popisu pak podle místa - při zadávání náhrady za použití vlastního vozidla se zobrazí tlačítko Vzdálenost, kterým provedete výpočet vzdálenosti nejprve podle vybraného popisu a pak podle místa. Data pro výpočet vzdálenosti jsou brány ze zapsaných údajů v polích, které jsou umístěny pod Místem začátku a pod Cílem. Dále se zobrazí zaškrtávací pole Zpáteční cesta. Pokud je pole zaškrtnuté, potom se do ujeté vzdálenosti započítává i zpáteční cesta.

UPOZORNĚNÍ: Po stisku tlačítka VZDÁLENOST se zobrazí informativní okno, kde si zkontrolujte, zda je Místo začátku a Cíl správný.

· Nadpisy pro uživatelská pole 1. až 5. - nastavené nadpisy uživatelských polí se vám zobrazí při zadávání nové služební cesty v intrawebu.

Výchozí hodnoty pro nově vložené záznamy

· Stát - jedná se o výchozí stát, podle kterého se provede vyúčtování služební cesty (obvykle stát sídla firmy nebo pobočky). Pokud nezadáte žádnou hodnotu, bude muset vybrat stát uživatel.

· Začátek služební cesty - z nabídky zvolte začátek služební cesty. Při vytváření nové služební cesty v intrawebu bude pole Místo začátku předvyplněno. Seznam míst služebních cest vytvoříte v menu Cestovní náhrady -> Místa služební cesty.

· Zakázat uživatelům změnit místo začátku - v případě zatrhnutí pole, nebude moci uživatel změnit místo začátku služební cesty. Vždy se použije vybrané místo.

· Čas začátku a konce služební cesty nastavit automaticky podle vyplněných řádků - po zatrhnutí pole se čas začátku a konce služební cesty nastaví automaticky podle vyplněných řádků. Po zaškrtnutí této volby nebude uživatel čas začátku a konce vůbec zadávat.

· Typ výpočtu cestovních náhrad - z nabídky zvolte výpočet, podle kterého se budou účtovat cestovní náhrady (Česká legislativa).

· Nepočítat základní sazbu - nastavte výchozí hodnotu při vkládání nového záznamu. Pokud bude pole zatržené, potom při vkládání náhrad za použití vlastního vozidla bude v intrawebu již zatržena položka Nepočítat základní sazbu.

· Zakázat uživatelům změnit nastavení - pokud nechcete, aby uživatelé měnili nastavení "Nepočítat základní sazbu", zatrhněte pole.

· Přenášení služebních cest do docházky - z nabídky vyberte jak se budou služební cest zadané přes Intraweb přenášet do docházky:

o Nepřenášet - služební cesta se nebude přenášet do docházky.

o Podle volby uživatele -

o Po směnách - služební cesta se vloží jen podle nastavené směny v kalendáři.

o Podle rozpisu - jednotlivé části dne se vloží na základě vyplněných řádků služební cesty.

· Pořadí operací služební cesty - slouží pro automatické předvyplnění operace. NULL zakáže editaci operací.

PŘÍKLAD nastavení:

04;*;02

· Povinný účel služební cesty - pokud je pole zatrhnuté, je nutné mít ve služební cestě vyplněné pole Účel. Jakmile nebude toto pole vyplněno a potvrdíte formulář, zobrazí se varovné okno s popisem "Není zadán účel služební cesty". Po jeho zadání, je možné formulář potvrdit.

· Povolit uživatelům zadat datum kurzu - pokud uživatelé mohou zadat datum kurzu, zatrhněte pole.

· Povolit uživatelům editovat sazbu kapesného - po zatrhnutí pole budou moci uživatelé v intrawebu ve formuláři služební cesty editovat sazbu kapesného (v %).

· Povolit zadávání částky DPH u řádku vyúčtování - po zatrhnutí pole budou moci uživatelé zadávat částku DPH u řádku vyúčtování.

· Pokud služební cesta obsahuje náhrady za vlastní vozidlo, musí být přiložen dokument - když služební cesta obsahuje řádek účtování "NVV", nepůjde provést vyúčtování, pokud není přiložen dokument.

· Typ rozdělení pro služební cesty - z nabídky vyberte typ rozdělení pro služební cesty.

· Zadání rozdělení je povinné - pokud je zadání rozdělení povinné, zaškrtněte pole.

· Vybírat pouze z vlastních (přiřazených) rozdělení - po zaškrtnutí pole bude možné vybírat rozdělení jen z rozdělení, které má uživatel přiřazeny.

· Povolit uživatelům výběr vlastních rozdělení - po zatrhnutí pole se při zadávání služební cesty zobrazí odkaz Vybrat používané. Po stisku odkazu si uživatel bude moci v tabulce vybrat používaná rozdělení.

· Typ rozdělení pro služební cesty 2 - vyberte typ rozdělení pro tuzemské služební cesty a zahraniční služební cesty.

· Vybírat pouze z vlastních (přiřazených) rozdělení - po zaškrtnutí pole bude možné vybírat rozdělení jen z rozdělení, které má uživatel přiřazeny.


Plánování kapacit

Navigation: Systém > Nastavení > Nastavení intrawebu >

Plánování kapacit

 Return to chapter overview

Plánování kapacit - slouží k nastavení a zobrazení plánovaných kapacit v Intrawebu.

· Zobrazit plánování kapacit - v intrawebu se vám zobrazí odkazy Přehled plánovaných směn a Plánování kapacit.

· Povolit editaci plánovaných kapacit - zaškrtnutím pole, můžete v intrawebu editovat naplánované kapacity. Zaškrtnutím pole se v Plánování kapacit nad filtry zobrazí tlačítko "Plánovat". Stiskem tlačítka se zobrazí okno, ve kterém můžete plánovat směny a absence.

· Zobrazit jen zaměstnance s docházkou "podle plánování kapacit" - po zatrhnutí pole se zobrazí v plánování kapacit jen zaměstnanci s docházkou podle plánování kapacit. Přiřazený kalendář musí mít zapnuto "Docházka podle plánování kapacit".

· Zobrazit jen zaměstnance v evidenčním stavu - po zatrhnutí pole se zobrazí v plánování kapacit jen zaměstnanci v evidenčním stavu.

POZOR: Funguje jen s programem Mzdy!

· Povolit editaci ve schválených dnech - určete, jestli může uživatel editovat i schválené dny, pokud má právo na vyšší úroveň schvalování (například pokud má právo schvalovat žlutou může editovat dny, které jsou schválené jen zelenou).

· Povolit plánování kapacit zaměstnanců z jiných rozdělení - určete, jestli uživatel může zobrazit a případně i plánovat směny zaměstnanců, kteří jsou přiřazení na rozdělení (středisko) pouze dočasně ("půjčování zaměstnanců").

· Tlačítko pro přepočet docházky - pokud je pole zaškrtnuté, zobrazí se vám v Plánování kapacit tlačítko "Přepočítat".

· Přepočet docházky při plánování zpracovaných dnů - z nabídky vyberte, zda chcete provádět přepočet docházky při plánování zpracovaných dnů. Pro správnou funkčnost vyúčtování musí být nastavena cesta k programovým souborům aplikace Docházka (záložka Docházka).

· Velikost buňky v aktivním režimu - nastavte šířku a výšku buňky v aktivním režimu.

· Podrobnosti zobrazené v aktivním režimu - vepište podrobnosti, které se zobrazí v aktivním režimu.


Plánování kapacit_2

Navigation: Systém > Nastavení > Nastavení intrawebu >

Plánování kapacit

 Return to chapter overview

Plánování kapacit 2 - slouží k nastavení časových složek pro zobrazení výsledků v Intrawebu.

· Typy časových složek pro zobrazení měsíčních výsledků na řádku - pro zobrazení požadovaných měsíčních výsledků na řádku, zadejte časové složky ve formátu KOD1:Nadpis1:H/D/K;KOD2:Nadpis2:H/D/K. Pro zobrazení kódu rozdělení zadejte R:Nadpis. Pro zobrazení uživatelské položky zadejte U<n>:Nadpis, kde <n> je číslo uživatelské položky (1-10).

PŘÍKLAD:

100:Odpracovaná doba:D;R:Mzdové středisko;U1:Telefonní číslo

· Typy časových složek pro zobrazení denních výsledků v jednotlivých buňkách - pro zobrazení požadovaných denních výsledků v jednotlivých buňkách, zadejte časové složky ve formátu KOD1:H/D/K;KOD2:H/D/K. Pokud není zadán kód, zobrazí se přímo zadaný text. Je možné použít i HTML značky. Pro nový řádek můžete zadat # nebo :<BR>.

PŘÍKLADY:

100:H;#;200:D; ;300:K

100:H;:<BR>;:<B>;981:H;:</B>

VYSVĚTLIVKY:

#, :<BR> - výsledek časové složky bude na novém řádku

H/D/K - hodiny / dny / kalendářní dny

:<B>;981:H;:</B> - výsledek časové složky vložen mezi znaky :<B> a :</B> bude zobrazen tučně

· Patička plánování kapacit - nastavte, které hodnoty z tabulky DenniCasovaSlozka_R se zobrazí v patičce plánování kapacit.

FORMÁT:

R:<kod_CS>:H/D/K:Nadpis;...

PŘÍKLAD:

R:100:D:Požadovaný počet zaměstnanců


Předávací procesy, XML

Navigation: Systém > Nastavení > Nastavení intrawebu >

Předávací procesy, XML

 Return to chapter overview

Záložka slouží pro nastavení XML formulářů v intrawebu.

· Typ rozdělení pro předávací procesy - z nabídky zvolte požadované rozdělení. Uživatel může hodnotit pouze zaměstnance ze svých rozdělení.

· Zobrazit jen vlastní a podřízená rozdělení - po zatrhnutí položky se v intrawebu zobrazí jen vlastní a podřízená rozdělení.

· Položka menu pro XML formuláře - položka, jejíž vložený název se zobrazí v menu intrawebu.

· Načíst do menu XML šablony - některé XML šablony mohou být součástí menu v intrawebu.

· Mapování standardních funkcí na XML formuláře - XML formulář nahradí standardní funkcionalitu. Zadejte řádky ve formátu <menuid>=<id XML formuláře>.


Tisk

Navigation: Systém > Nastavení > Nastavení intrawebu >

Tisk

 Return to chapter overview

Ve formuláři máte možnost nastavit tisk sestav z Intrawebu. Aplikace je dostupná, pokud máte program rozšířen o modul Intraweb Plus.

Nastaveni intrawebu tisk

Sestavy vám můžeme vytvořit na zakázku.


Uživatelské položky

Navigation: Systém > Nastavení > Nastavení intrawebu >

Uživatelské položky

 Return to chapter overview

Ve formuláři máte možnost nastavit položky, které uživatelé uvidí v aplikaci Intrawebu.

Nastaveni intrawebu uzivatelske polozky

Uživatelské položky vám můžeme naprogramovat na zakázku.


Jména a hesla

Navigation: Systém > Nastavení > Nastavení intrawebu >

Jména a hesla

 Return to chapter overview

Formulář slouží jako pomocná utilita pro hromadné nastavení přihlašovacích jmen, hesel a skupin uživatelů. Nastavení můžete provést pro osoby ze skupiny, nebo můžete požadované změny provést pouze u osob, které nemají tyto údaje vyplněné.

Intraweb nastaveni intrawebu jmena a hesla

· Typ kódování hesla - z nabídky vyberte typ kódování hesla.

POZOR: Pokud změníte typ kódování hesla, budou existující hesla neplatná! Všechna hesla bude nutné nastavit znovu!

· Provést požadované změny pouze pro osoby ze skupiny - při zaškrtnutí políčka provedete nastavení pro osoby ze skupiny, kterou vyberete z nabídky.

· Provést požadované změny pouze u osob, které nemají údaje vyplněné - při zaškrtnutí políčka provedete nastavení pro osoby, které nemají tyto údaje vyplněné.

Pokud nezaškrtnete žádnou z předešlých nabídek, nastaví se práva u všech zaměstnanců.

· Přihlašovací jméno - z nabídky vyberte formát přihlašovacího jméno.

· Bez diakritiky - zatrhnutím políčka musí být přihlašovací jméno bez diakritiky.

· Heslo - z nabídky vyberte formát hesla. V poli můžete nastavit i jednotné heslo pro všechny vybrané uživatele a potom nastavit vynucení změny hesla.

· Vynutit změnu hesla - pokud se zvolí vynucení hesla (vyberete položku Ano), potom po prvním přihlášení do intrawebu se zaměstnanci zobrazí informace o tom, že platnost hesla vypršela a je nutné zadat heslo nové. Vynucení hesla se projeví i v kartě zaměstnance na záložce Intraweb, zaškrtnutou položkou Vynutit změnu hesla při přihlášení. Po prvním přihlášení zaměstnance a zadání nového hesla pole již zaškrtnuté nebude a navíc se vyplní pole Poslední změna hesla ve formátu DD.MM.RRRR HH:MM:SS.

· Skupina uživatelů - zaměstnancům můžete přiřadit jejich skupinu. Seznam skupin uživatelů můžete vytvořit v nastavení intrawebu/Skupiny uživatelů.

Provést - pokud máte údaje ve formuláři vyplněné, stačí stisknout tlačítko a požadované změny se u vybraných osob nebo skupin provedou.


Typy práv uživatelů

Navigation: Systém > Nastavení > Nastavení intrawebu >

Typy práv uživatelů

 Return to chapter overview

U jednotlivých práv určete, podle kterého typu rozdělení se budou kontrolovat. Nastavený typ rozdělení u práva platí pro volby Vlastní rozdělení, Vlastní rozdělení kromě sebe, Vlastní a podřízená rozdělení, Vlastní a podřízená rozdělení kromě sebe, Podřízená rozdělení. Tyto volby se nastavují ve formuláři Skupiny uživatelů.

Typ rozdělení můžete nastavit pro všechny Typy práv hromadně pomocí tlačítka [image]. Po jeho stisku se zobrazí formulář Hromadné nastavení typu rozdělení pro práva, kde v poli vyberete požadované středisko a výběr potvrdíte tlačítkem OK.

Nastaveni intrawebu typy prav uzivatelu


Skupiny uživatelů

Navigation: Systém > Nastavení > Nastavení intrawebu >

Skupiny uživatelů

 Return to chapter overview

Skupinám uživatelů nastavíte práva pro intraweb. Skupinu uživatelů můžete zaměstnancům přiřadit v jejich kartě zaměstnance nebo hromadně v nastavení intrawebu ve formuláři Jména a hesla.

Novou skupinu uživatelů vytvoříte stiskem tlačítka [image] Nový záznam. Po stisku se zobrazí na levé straně nový řádek s přednastaveným kódem a popisem. Klikněte do pole a přepište hodnoty na požadované. Po zadání nové skupiny uživatelů potvrďte tlačítkem [image] (vpravo od skupiny uživatelů). K označené skupině uživatelů máte možnost vložit poznámku v pravé části formuláře. Vymazání nepotřebné skupiny uživatelů provedete označením skupiny a stiskem kláves Ctrl+Delete nebo tlačítkem [image]. Před samotným smazáním skupiny budete dotázáni, zda si aktuální záznam přejete zrušit.

Novou skupinu uživatelů můžete vytvořit z kopie včetně nastavených práv stiskem tlačítka C_Vytvorit novou skupinu z kopie Vytvořit novou skupinu z kopie. Po stisku tlačítka se zobrazí dotaz zda opravdu chcete vytvořit kopii skupiny uživatelů "Personální ředitel" (název skupiny) včetně práv. Pokud ano, dotaz potvrďte. Následně budete vyzváni k zadání nového kódu skupiny a novému popisu skupiny. Po zadání požadovaných údajů bude vytvořena nová skupina včetně nastavených práv.

Práva vybrané skupině nastavíte tak, že si nejprve označíte skupinu uživatelů. Potom ve střední části označíte vybraný řádek s právem a ve spodní části "Nastavení práva" vyberete požadovanou hodnotu ze seznamu. Po nastavení jednotlivých práv ukládejte údaje tlačítkem [image] (v pravé dolní části formuláře).

Nastaveni intrawebu skupiny uzivatelu

· Pouze vlastní - uživatelé s tímto povolením mají zobrazeny pouze vlastní údaje např. osobní údaje.

· Vybrané osoby a skupiny - uživatelům s tímto povolením musíte v dolní části formuláře vybrat osobu nebo skupinu. Kliknutím na podtržený popisek Vybrané osoby se zobrazí formulář Výběr osob pro práva v intrawebu, ze kterého vyberete požadovanou osobu. Novou osobu můžete vytvořit v menu Seznamy/Zaměstnanci. Kliknutím na podtržený popisek Vybrané skupiny zobrazíte formulář Výběr skupin pro práva v intrawebu, ze kterého vyberete požadovanou skupinu osob. Novou skupinu můžete vytvořit v menu Systém/Správa databáze/Skupiny osob pro zabezpečení v aplikaci. Osoba po nastavení práv uvidí údaje (například osobní údaje) vybrané osoby, vybrané skupiny (například Dělníků) v intrawebu.

· Vše - uživatelé s tímto povolením můžou v intrawebu prohlížet např. osobní údaje všech zaměstnanců.

· Zakázat - uživatelé s tímto povolením nemají právo prohlížet např. osobní údaje.

Pro volby Vlastní rozdělení, Vlastní rozdělení kromě sebe, Vlastní a podřízená rozdělení, Vlastní a podřízená rozdělení kromě sebe a Podřízená rozdělení je nutné mít nastaveno na záložce Typy práv uživatelů typ rozdělení u zvoleného práva. Pokud u zvoleného práva není nastaven typ rozdělení, potom se při přiřazení některé z uvedených voleb zobrazí hláška: "Pozor! Pro tento typ práva není nastaven typ rozdělení! (záložka Typy práv uživatelů)".

PŘÍKLAD: Na záložce Skupiny uživatelů nastavíte pro typ práva SCHVÁLENÍ ABSENCE hodnotu VLASTNÍ A PODŘÍZENÁ ROZDĚLENÍ KROMĚ SEBE. Na záložce Typy práv uživatelů pro typ práva SCHVÁLENÍ ABSENCE je nutné mít vybrán Typ rozdělení.

Pokud jste vybrali v horní části formuláře ze seznamu položku s typem práva Odblokování nebo Zablokování karty, potom se ve spodní části zobrazí popisek: Uživatel musí při odblokování/blokování karty zadat své heslo - při zaškrtnutí políčka musí uživatel při blokování nebo odblokování karty zadat své heslo.

Pokud jste v horní části formuláře vybrali ze seznamu položku s typem práva Prohlížení úkolů a nastavení splnění, potom se ve spodní části zobrazí popisek: Může ručně upravit datum splnění - při zaškrtnutí políčka může uživatel při splnění úkolu ručně editovat předvyplněné datum.

Práva a jejich hodnoty lze kombinovat.

Načíst nastavení práv skupiny ze souboru - stiskem tlačítka načtete soubor obsahující nastavení práv skupiny. Pokud v seznamu uživatelů je stejný kód nebo název souboru jako u načteného souboru, potom program zobrazí varování s popisem, že načtená skupina s kódem P/s názvem Prodejna již existuje a zda si přejete přepsat její nastavení. Po potvrzení se nastavení práv této skupiny přepíše načteným souborem.

Uložit nastavení práv skupiny do souboru - po stisku tlačítka se zobrazí okno, ve kterém zvolíte cestu pro uložení souboru, například Prodejna.iwgroup. Soubor obsahuje nastavení práv pro vybranou skupinu, kód a popis skupiny uživatelů.


Práva uživatelů

Navigation: Systém > Nastavení > Nastavení intrawebu >

Práva uživatelů

 Return to chapter overview

V tomto formuláři nastavíte práva pro prohlížení a editaci údajů vlastních, údajů vybrané skupiny nebo osoby, případně údajů všech dle vybraného rozsahu. Nastavují se zde tedy práva pro všechny uživatele intrawebu nebo pro vybrané skupiny uživatelů.

Intraweb nastaveni intrawebu prava uzivatelu

V horní části formuláře vyberte funkci, pro kterou chcete nastavit práva uživatelů (např. Prohlížení údajů). V dalším kroku vyberte, zda chcete vytvořit práva pro všechny uživatele nebo jen pro vybrané skupiny.

Nastavení práv pro všechny uživatele:

· Nastavení práv - z nabídky zvolte, jaká práva chcete, aby měli všichni zaměstnanci. Pro všechny zaměstnance budete nejčastěji volit Zakázat (osoby s tímto povolením nemají právo prohlížet např. osobní údaje) nebo Pouze vlastní (osoby s tímto povolením uvidí pouze vlastní údaje).

· Vybrané záznamy - z nabídky zvolte, co se má provést s právy zaměstnanců. Při prvním nastavení práv zaměstnanců použijete volbu Nastavit (všem zaměstnancům se nastaví zvolená práva do Formuláře zaměstnance).

Pokud jste vybrali v horní části formuláře Odblokování nebo Zablokování karty, potom se ve spodní části formuláře zobrazí Podrobnosti. V podrobnostech můžete provést následující nastavení. Ponechat beze změny - políčko je implicitně zaškrtnuto. Pokud potřebujete provést změnu, odškrtněte políčko u tohoto popisu. Následně budete moci zaškrtnout políčko: Uživatel musí při odblokování/blokování karty zadat své heslo - při zaškrtnutí políčka musí uživatel při blokování nebo odblokování karty zadat své heslo.

Nastavení práv pro vybrané skupiny:

Práva pro všechny zaměstnance máte již vytvořena, ale potřebujete ještě nastavit práva jen pro určitou skupinu uživatelů. Může se jednat o nastavení práv pro mistry, aby viděli potřebné údaje svých podřízených (dělníků).

· Provést požadované změny pouze pro osoby ze skupiny - zatrhnutím políčka a výběrem z nabídky zvolte, pro jakou skupinu uživatelů chcete nastavit práva (například skupina Mistři). Novou skupinu můžete vytvořit v menu Systém/Správa databáze/Skupiny osob pro zabezpečení v aplikaci.

· Nastavení práv - z nabídky zvolte, jaká práva chcete přidělit osobám ze skupiny (například Mistrům pro prohlížení údajů jejich podřízených - Dělníků). Pro jednotlivé skupiny zaměstnanců budete nejspíše volit Vybrané skupiny a osoby - po zvolení tohoto práva nastavte potřebné osoby a skupiny v následujících dvou řádcích Vybrané osoby a Vybrané skupiny (například Dělníci). Mistři po nastavení práv uvidí například osobní údaje vybrané osoby, vybrané skupiny (například Dělníků). Všechny - vybraná skupina osob s tímto povolením uvidí údaje všech (například osobní údaje všech zaměstnanců).

· Vybrané záznamy - z nabídky zvolte, co se má provést s právy vybraných osob ze skupiny. Jelikož již jsou nastavena nějaká práva, použijete volbu Přidat k právům zaměstnanců - vybraným osobám ze skupiny budou přidána zvolená práva.

Pokud jste vybrali v horní části formuláře Odblokování nebo Zablokování karty, potom se ve spodní části formuláře zobrazí Podrobnosti. V podrobnostech můžete provést následující nastavení. Ponechat beze změny - políčko je implicitně zaškrtnuto. Pokud potřebujete provést změnu, odškrtněte políčko u tohoto popisu. Následně budete moci zaškrtnout políčko: Uživatel musí při odblokování/blokování karty zadat své heslo - při zaškrtnutí políčka musí uživatel při blokování nebo odblokování karty zadat své heslo.

Pokud máte údaje ve formuláři vyplněné, stačí stisknout tlačítko [image] a požadované změny se provedou. Všechna provedená nastavení pro osoby se uloží do Formuláře zaměstnance - Intraweb.


Nastavení mobilního klienta

Navigation: Systém > Nastavení >

Nastavení mobilního klienta

 Return to chapter overview

RON klient slouží k prohlížení a editaci docházky na mobilních telefonech. V tomto nastavení se definuje mobilní prostředí pro všechny zaměstnance ze seznamu zaměstnanců, kteří mají nastavená práva pro mobilního klienta ve formuláři Zaměstnanec/Mobilní klient. Programové prostředí je dále možno nastavit tak, aby uživatelé měli přístup jen k určitým informacím a nemohli tak ovlivňovat výsledky docházky.

Formulář Nastavení mobilního klienta obsahuje v levé části strom s výběrem, jehož částmi jsou:

Mail server

Přehled docházky

Denní výsledky

Měsíční výsledky

Operace absence

Schvalování absence

Typy práv

Skupiny uživatelů

Pravá část zobrazí po výběru požadované nastavení.

POZOR: Tato aplikace je dostupná pouze pokud máte zakoupen modul Mobilní klient.

POZOR: Pro komunikaci mobilního klienta je nutné nastavit komunikační server v Nastavení plánovače úloh.


Mail server

Navigation: Systém > Nastavení > Nastavení mobilního klienta >

Mail server

 Return to chapter overview

Ve formuláři je nutné zadat údaje pro SMTP server. Tyto údaje záleží na nastavení vašeho SMTP serveru. S jejich nastavením vám pomůže váš správce sítě.


Přehled docházky

Navigation: Systém > Nastavení > Nastavení mobilního klienta >

Přehled docházky

 Return to chapter overview

V Přehledu docházky se nastaví počet zobrazených dnů zpětně.

· Počet zobrazených dnů zpětně - volba určuje kolik dnů zpětně bude mobilní klient načítat záznamy z přehledu docházky ze serveru. Čím více dnů bude mobilní klient načítat, tím bude načítání pomalejší.


Denní výsledky

Navigation: Systém > Nastavení > Nastavení mobilního klienta >

Denni výsledky

 Return to chapter overview

Denní výsledky - slouží k nastavení časových složek v přehledu denních výsledků, které přihlášený uživatel uvidí. V pravé části je seznam všech dostupných časových složek a v levém je seznam vámi vybraných časových složek, které chcete zobrazit. Seznam přenesete do druhé části jeho označením a stiskem tlačítka se šipkou, které je umístěno uprostřed mezi těmito seznamy.

· Počet zobrazených dnů zpětně - volba určuje kolik dnů zpětně bude mobilní klient načítat záznamy denních výsledků ze serveru. Čím více dnů bude mobilní klient načítat, tím bude načítání pomalejší.

· Typ časové složky - označená časová složka v pravém seznamu.

· Popis - v řádku můžete upravit popis časové složky.

· Zobrazit - zatrhnutím můžete vybrat jaká "měrná jednotka" (Kalendářní dny, Pracovní dny, Hodiny) se má v RON Klientovi zobrazit.


Měsíční výsledky

Navigation: Systém > Nastavení > Nastavení mobilního klienta >

Měsíční výsledky

 Return to chapter overview

Měsíční výsledky - slouží k nastavení časových složek v přehledu měsíčních výsledků, které přihlášený uživatel uvidí. V pravé části je seznam všech dostupných časových složek a v levém je seznam vámi vybraných časových složek, které chcete zobrazit. Seznam přenesete do druhé části jeho označením a stiskem tlačítka se šipkou, které je umístěno uprostřed mezi těmito seznamy.

· Počet zobrazených měsíců zpětně - volba určuje kolik měsíců zpětně bude mobilní klient načítat záznamy denních výsledků ze serveru. Čím více dnů bude mobilní klient načítat, tím bude načítání pomalejší.

· Typ časové složky - označená časová složka v pravém seznamu.

· Popis - v řádku můžete upravit popis časové složky.

· Zobrazit - zatrhnutím můžete vybrat jaká "měrná jednotka" (Kalendářní dny, Pracovní dny, Hodiny) se má v RON Klientovi zobrazit.


Operace absence

Navigation: Systém > Nastavení > Nastavení mobilního klienta >

Operace absence

 Return to chapter overview

Operace absence - z nabídky vyberte operace, které požadujete aby se zobrazovaly v nabídce pro plánování absence (např. nemoc, mateřská dovolená atd.). V pravé části je seznam všech dostupných operací a v levém je seznam vámi vybraných operací, které chcete zobrazit. Seznam přenesete do druhé části jeho označením a stiskem tlačítka se šipkou, které je umístěno uprostřed mezi těmito seznamy.

· Operace - označená operace v pravém seznamu.

· Popis - v řádku můžete upravit popis operace.


Schvalování absence

Navigation: Systém > Nastavení > Nastavení mobilního klienta >

Schvalování absence

 Return to chapter overview

V této sekci můžete nastavit odesílání oznámení o plánovaných, schválených a zamítnutých absencí emailem.

V programu Docházka je nutné zaměstnancům nastavit jejich emailové adresy, na které se budou odesílat potvrzení o schválených a zamítnutých absencí (karta zaměstnance -> Ostatní údaje).

· Používat schvalování absence - pokud chcete schvalovat v intrawebu absenci, je potřeba zaškrtnou toto pole.

Odesílání emailu - naplánování absence

· Odesílat oznámení o naplánované absenci - pokud chcete plánování absencí využívat, zaškrtněte.

V dalším kroku nastavte emailové adresy, na které se odešle oznámení o naplánované absenci. Můžete nastavit konkrétní Příjemce emailu a/nebo vybrat Typ rozdělení pro email.

· Příjemce emailu - zadejte emailové adresy oddělené středníkem, na které se zašle zpráva o naplánované absenci.

· Typ rozdělení pro email - zadejte typ rozdělení pro určení emailové adresy. Email bude odeslán vedoucímu pracovníkovi na adresu rozdělení daného typu, do kterého je zaměstnanec (podřízený) zařazen. Emailové adresy nastavíte v programu Docházka (menu Seznamy -> Rozdělení).

· Odesílatel - zadejte emailovou adresu odesílatele. Pokud není adresa zadána, určí se podle osoby, pro kterou je absence zadána.

· Předmět emailu - zadaný text se zobrazí v přijatém emailu jako předmět zprávy (Docházka - plánování absence).

· Text emailu - zadejte text zprávy o oznámení naplánované absence. Můžete použít následující parametry:

%JMENO%

%OSOBNICISLO%

%RC%

%DATUMOD%

%DATUMDO%

%ABSENCE%

%POZNAMKA%

%LINK%

PŘÍKLAD nastavení textu emailu:

Zaměstnanec %JMENO% si naplánoval absenci:

Datum od: %DATUMOD%

Datum do: %DATUMDO%

Absence: %ABSENCE%

Poznámka: %POZNAMKA%

Link: http://JMENO_SERVERU/ads_new/ads.php%LINK%

Pokud chcete provedené změny v textu emailu vrátit na původní hodnoty, stiskněte tlačítko Vychozi text.

odesílání emailu - schválení a zamítnutí absence

· Odesílat oznámení o schválení a zamítnutí - pokud chcete odesílat informace zaměstnancům o schválení/zamítnutí absence, zaškrtněte.

· Odesílatel - zadejte emailovou adresu odesílatele. Pokud nebude adresa zadána, použije se emailová adresa přihlášeného uživatele.

· Předmět emailu o schválení/zamítnutí - zadejte text, který se zobrazí v přijatém emailu jako předmět zprávy u schválené a zamítnuté absence (Docházka - schválení/zamítnutí plánované absence).

· Příjemce kopie emailu - zadejte emailové adresy oddělené středníkem, na které se zašle kopie zprávy o schválení nebo zamítnutí absence.

· Text emailu schválení/zamítnutí - zadejte text zprávy pro schválení a zamítnutí naplánované absence. Můžete použít stejné parametry, které jsou uvedeny výše.

PŘÍKLAD nastavení textu emailu:

Vaše plánovaná absence byla schválena/zamítnuta.

Podrobnosti:

Datum od: %DATUMOD%

Datum do: %DATUMDO%

Absence: %ABSENCE%

Schválil/Zamítnul: %UZIVATEL%

http://JMENO_SERVERU/ads/ads.php%LINK%

Pokud chcete provedené změny v textu emailu vrátit na původní hodnoty, stiskněte tlačítko Vychozi text.

odesílání emailu - ŽÁDOST O ZRUŠENÍ ABSENCE / zrušení absence / zamítnutí žádosti o zrušení absence

· Předmět emailu - zadejte text, který se zobrazí v přijatém emailu jako předmět zprávy u schválené a zamítnuté absence (Docházka - žádost o zrušení absence / zrušení naplánované absence / zamítnutí žádosti o zrušení absence).

· Text emailu - zadejte text zprávy pro schválení a zamítnutí naplánované absence. Můžete použít stejné parametry, které jsou uvedeny výše.

PŘÍKLADY nastavení textu emailu:

Zaměstnanec %JMENO% zažádal o zrušení absence:

Datum od: %DATUMOD%

Datum do: %DATUMDO%

Délka: %DELKA%

Absence: %ABSENCE%

http://server/ads/ads.php%LINK%

Vaše plánovaná absence byla zrušena.

Podrobnosti:

Datum od: %DATUMOD%

Datum do: %DATUMDO%

Délka: %DELKA%

Absence: %ABSENCE%

Absenci zrušil: %UZIVATEL%

http://server/ads/ads.php%LINK%

Vaše žádost o zrušení plánované absence byla zamítnuta.

Podrobnosti:

Datum od: %DATUMOD%

Datum do: %DATUMDO%

Délka: %DELKA%

Absence: %ABSENCE%

Žádost zamítnul: %UZIVATEL%

http://server/ads/ads.php%LINK%

Pokud chcete provedené změny v textu emailu vrátit na původní hodnoty, stiskněte tlačítko Vychozi text.


Typy práv

Navigation: Systém > Nastavení > Nastavení mobilního klienta >

Typy práv

 Return to chapter overview

U jednotlivých práv určete, podle kterého typu rozdělení se budou kontrolovat. Nastavený typ rozdělení u práva platí pro volby Vlastní rozdělení, Vlastní a podřízená rozdělení,atd. Tyto volby se nastavují ve formuláři Skupiny uživatelů.


Skupiny uživatelů

Navigation: Systém > Nastavení > Nastavení mobilního klienta >

Skupiny uživatelů

 Return to chapter overview

Skupinám uživatelů nastavíte práva pro mobilního klienta. Skupinu uživatelů můžete zaměstnancům přiřadit v jejich kartě zaměstnance.

Novou skupinu uživatelů vytvoříte stiskem tlačítka [image] Nový záznam. Po stisku se zobrazí v levé části nový řádek a v pravé části možnost doplnění kódu, popisu a poznámky. Po zadání nové skupiny uživatelů potvrďte tlačítkem [image] (v horní části nad seznamem skupin). Vymazání nepotřebné skupiny uživatelů provedete označením skupiny a stiskem kláves Alt+Delete nebo tlačítkem [image]. Před samotným smazáním skupiny budete dotázáni, zda si aktuální záznam přejete zrušit.

Práva vybrané skupině nastavíte tak, že si nejprve označíte skupinu uživatelů. Potom ve střední části označíte vybraný řádek s právem a ve spodní části vyberete požadovanou hodnotu ze seznamu.

· Povolit - uživatelé s povolením mohou např. zobrazovat stav přítomnosti pracovníků na pracovišti (monitorovat).

· Zakázat - uživatelé s tímto povolením nemají právo např. vkládat původní docházku.

Pro volby Vlastní rozdělení, Vlastní a podřízená rozdělení, je nutné mít nastaveno na záložce Typy práv uživatelů typ rozdělení u zvoleného práva. Pokud u zvoleného práva není nastaven typ rozdělení, potom se při přiřazení některé z uvedených voleb zobrazí hláška: "Pozor! Pro tento typ práva není nastaven typ rozdělení! (záložka Typy práv uživatelů)".

PŘÍKLAD: Na záložce Skupiny uživatelů nastavíte pro typ práva MONITOROVÁNÍ hodnotu VLASTNÍ A PODŘÍZENÁ ROZDĚLENÍ. Na záložce Typy práv uživatelů pro typ práva MONITOROVÁNÍ je nutné mít vybrán Typ rozdělení.

Pokud jste vybrali v horní části formuláře ze seznamu položku s typem práva Absence, potom se ve spodní části zobrazí popisek: Vkládat nové absence - pokud pole zaškrtnete, potom může vybraná skupina uživatelů vkládat nové absence; Rušit neschválené absence/žádat o zrušení - pokud pole zaškrtnete, potom může vybraná skupina uživatelů rušit neschválené absence nebo žádat o zrušení již schválených absencí.

Pokud jste v horní části formuláře vybrali ze seznamu položku s typem práva Vkládat původní docházku, potom se ve spodní části zobrazí popisek: Měnit datum a čas - při zaškrtnutí políčka může vybraná skupina uživatelů měnit datum a čas; Vkládat bez zeměpisné polohy - pokud pole zaškrtnete, potom se docházka bude vkládat bez informace kde zaměstnanec vložil záznam docházky z mobilního klienta.

právo:

· Registrace mobilního klienta, Povolení přístupu z mobilního klienta - tyto práva nahrazují přiřazení zaměstnance k terminálu s driverem "Mobile", který je přiřazen ke komunikačnímu serveru.

· Kontakty - doplněn seznam kontaktů načtený ze seznamu zaměstnanců. Z detailu kontaktu je možno vyvolat vytáčení telefonního čísla, psaní sms a napsání e-mailu. Přístup do kontaktů je možno povolit úplně, na vlastní rozdělení nebo na vlastní a podřízená rozdělení.

o Jen vyplněné kontakty

· Nastavit rozdělení při vkládání docházky - při vkládání docházky je možné u záznamu nastavit i rozdělení.

o Povinný údaj - pokud je tato volba aktivní, pak uživatel při vkládání docházky musí zadat rozdělení.

· Monitorování - v monitorování se zobrazuje stav přítomnosti pracovníků.

o Jen zaměstnanci

Práva a jejich hodnoty lze kombinovat.


Import/Export

Navigation: Systém >

Import/Export

 Return to chapter overview

Standardně program komunikuje při importu se mzdovým systémem RONMZDY, ale rovněž i s jinými mzdovými systémy.


Import dat z mezd

Navigation: Systém > Import/Export >

Import dat z mezd

 Return to chapter overview

Import RON je prováděn z textových souborů. Pokud tedy máte mzdový systém, ze kterého byste chtěli importovat data do programu, můžete si formáty připravit podle implicitního formátu RONMZDY. Pro komunikaci se používá adresář nastavený v Nastavení aplikace/Společné nastavení - Import.

Ostatní import - data lze importovat i z jiných ekonomických a mzdových systémů. Komunikace může být na úrovni .txt souboru nebo SQL tabulky. Informujte se prosím na možnost komunikace s vaším systémem.


Export dat do mezd

Navigation: Systém > Import/Export >

Export dat do mezd

 Return to chapter overview

Export výsledků programu do mezd je jednou ze základních výstupních funkcí tohoto systému. Správně nastavený program by Vám měl poskytnout kompletní přehled dat a export údajů pro Váš mzdový systém, pokud Váš mzdový systém je schopen data přijímat.

Program umožňuje definovat vlastní formáty exportu v Nastavení aplikace/Společné nastavení - Export.


Změna hesla

Navigation: Systém >

Změna hesla

 Return to chapter overview

Formulář změny hesla umožní aktuálnímu uživateli změnit jeho heslo.


Přihlášení jiného uživatele

Navigation: Systém >

Přihlášení jiného uživatele

 Return to chapter overview

Umožní přihlásit se do programu na stejném počítači jako jiný uživatel.


Multilicence

Navigation: Systém >

Multilicence

 Return to chapter overview

Menu Multilicence je přístupné v případě zakoupení multilicence, která umožňuje zpracovávat data více firmám. Okno obsahuje seznam vytvořených firem (databází):

Jednotlivé firmy zadávejte stisknutím tlačítka [image], případně C_Nova databaze z kopie . Vyplňte název nové firmy a pokračujte stiskem tlačítka [image].

Multilicence nova databaze

Poté definujte parametry databáze pomocí tlačítka [image].

Zvolte typ připojení:

MS SQL server - vyberte v případě síťové verze programu. Vyplňte pole a poté vytvořte databázi.

Multilicence MS SQL server

· Název serveru - název nebo IP adresa SQL serveru.

· Uživatel - uživatelské jméno ("sa" - systém administrator).

· Heslo - heslo pro přihlášení k serveru.

· Databáze - můžete vybrat ze seznamu již vytvořených databází nebo kliknout na tlačítko [image]. Otevře se okno, do kterého uvedete název databáze. Poté potvrdíte dotaz o provedení restrukturalizace připojené databáze. Program provede restrukturalizaci dat a vygeneruje základní nastavení databáze. Základní seznamy budou vyplněny standardními hodnotami. Tyto hodnoty můžete samozřejmě nahradit.

Po nastavení databáze již pouze volíte mezi jednotlivými databázemi (jeden řádek = jedna databáze). Pro volbu databáze je nutno vybrat řádek a potvrdit tlačítkem [image] .

Přejmenovat aktuální registraci databáze - přejmenujete vytvořenou databázi.

Zrušit aktuální registraci databáze - zrušíte již vytvořenou databázi.

Zavřít formulář - zrušíte poslední neuložené změny a uzavřete formulář.


Správa databáze

Navigation: Systém >

Správa databáze

 Return to chapter overview

Na následujících stránkách se dozvíte vše o správě databáze a o tom, co budete potřebovat k práci v tomto programu. Dozvíte se o zálohování databáze, aktivaci, a dalších tématech.

Menu Správa databáze obsahuje následující položky:

Zálohování databáze...

Obnova databáze ze zálohy...

Aktivace

Údaje zpracovávané firmy

Obnova indexů

Komprimace databáze

Restrukturalizace databáze

Obnova systémových sestav a skriptů

Nastavení zabezpečení...

Synchronizace skupin osob pro zabezpečení v aplikaci

Skupiny osob pro zabezpečení v aplikaci

Správce přesunu osob na rozděleních

Skupiny active directory

Role active directory

Rušení starých záznamů

Rušení budoucích záznamů

Export vzorku databáze Ctrl+Alt+E

Import vzorku databáze Ctrl+Alt+I

TIP: Co to je DATABÁZE?

Databáze je propracovaný systém pro ukládání dat a jejich následné zpracování. Databázi si můžete nejsnáze představit jako papírovou kartotéku známou z lékařských ordinací. Databáze obsahuje data (informace o pacientech) uložená na paměťovém médiu (papíry). Tato data mezi sebou mají určité vztahy (např. u jednoho pacienta chronologicky navazují) a jsou určitým způsobem členěna (desky jednotlivých pacientů, šuplíky podle příjmení).

V širším pojetí spadají do pojmu databáze i nástroje, které s daty pracují (ukládají je, mění je a mažou je) – v uvedeném případě je tedy součástí databáze i sestřička.


Zálohování databáze

Navigation: Systém > Správa databáze >

Zálohování databáze

 Return to chapter overview

Zálohování dat je jednou ze základních nutností při práci s počítačem. Je v zájmu vás, uživatelů, abyste si veškerá data (databázi) uložili pro případ ztráty dat z původní databáze.


Zálohování SQL databáze

Navigation: Systém > Správa databáze > Zálohování databáze >

Zálohování SQL databáze

 Return to chapter overview

Zálohovací médium:

Nejdříve je třeba nastavit cíl, kam se bude soubor zálohovat.

Pevný disk - automaticky je zvolena možnost zálohování na pevný disk. Zálohu provádějte v pravidelných intervalech, ale nezapomeňte občas udělat kopii zálohy na přenosné médium případně jiný počítač, abyste měli vaše data i v případě poruchy nebo odcizení počítače a databázi bylo možno z této zálohy obnovit.

Cílový soubor:

Vyberte cestu pro uložení souboru se zálohou dat a zadejte jméno tohoto souboru s příponou bak.

Soubor se automaticky uloží do podadresáře BACKUP v adresáři, kde je nainstalován MS SQL Server (např. C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Backup).

Pokud je SQL server na jiném PC, než provádíte zálohu, pak se soubor zálohy vytvoří na počítači, kde je SQL server. Pokud si nejste jisti, kontaktujte svého správce sítě.

Pokud máte provedeno nastavení, stiskněte tlačítko [image] . Pokud chcete režim zálohování opustit, stiskněte tlačítko [image] nebo klávesu Esc.

POZNÁMKA: V MS SQL Server Management Studiu můžete případně naplánovat vytváření záloh jednotlivých databází nebo archivovat celé databáze (soubory typu MDF a LDF) např. z C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data.


Zálohování FDB databáze

Navigation: Systém > Správa databáze > Zálohování databáze >

Zálohování FDB databáze

 Return to chapter overview

Zalohovani FBD databáze

Zálohovací médium:

Nejdříve je třeba nastavit cíl, kam se bude databáze ve firebirdu zálohovat.

Pevný disk - automaticky je zvolena možnost zálohování na pevný disk. Zálohu provádějte v pravidelných intervalech, ale nezapomeňte občas udělat kopii zálohy na přenosné médium případně jiný počítač, abyste měli vaše data i v případě poruchy nebo odcizení počítače a databázi bylo možno z této zálohy obnovit.

Cílový soubor:

Vyberte cestu pro uložení souboru se zálohou dat a zadejte jméno tohoto souboru s příponou fbk.

Pokud máte provedeno nastavení, stiskněte tlačítko [image] . Pokud chcete režim zálohování opustit, stiskněte tlačítko [image] nebo klávesu Esc.


Zálohování MDB databáze

Navigation: Systém > Správa databáze > Zálohování databáze >

Zálohování MDB databáze

 Return to chapter overview

Zalohovani MDB databaze

Cíl zálohování:

Nejdříve je třeba nastavit cíl, kam se bude soubor zálohovat.

Pevný disk - automaticky je zvolena možnost zálohování na pevný disk. Zálohu provádějte v pravidelných intervalech, ale nezapomeňte občas udělat kopii zálohy na přenosné médium případně jiný počítač, abyste měli vaše data i v případě poruchy nebo odcizení počítače a databázi bylo možno z této zálohy obnovit.

Cesta k souboru:

Vyberte cestu pro uložení souboru se zálohou dat a zadejte jméno tohoto souboru. Cestu můžete vybrat pomocí tlačítka [image].

· Existující zálohy přepisovat automaticky bez dotazu - pokud zatrhnete, bude program automaticky přepisovat existující zálohu bez dotazu: "Opravdu si přejete zálohovat databázi?"

· Při ukončení aplikace zobrazit formulář zálohování - pokud zatrhnete, zobrazí program při každém ukončení aplikace formulář pro zálohování dat.

Pokud máte provedeno nastavení, stiskněte tlačítko [image] . Pokud chcete režim zálohování opustit, stiskněte tlačítko [image] nebo klávesu Esc.


Obnova databáze ze zálohy

Navigation: Systém > Správa databáze >

Obnova databáze ze zálohy

 Return to chapter overview

Funkci použijte v případě, že máte databázi zálohovanou a v databázi, se kterou v současnosti pracujete, došlo k chybě. Pak je potřeba obnovit zálohovanou databázi.


Obnova SQL databáze ze zálohy

Navigation: Systém > Správa databáze > Obnova databáze ze zálohy >

Obnova SQL databáze ze zálohy

 Return to chapter overview

Zalohovani obnova databaze ze zalohy

Zdrojové médium:

Pevný disk - v aplikaci je automaticky zvolena možnost obnovy databáze z pevného disku.

Zdrojový soubor:

Vyberte cestu k záložnímu souboru, ze kterého bude provedena obnova databáze.

Pokud máte provedeno nastavení, stiskněte tlačítko [image] . Pokud si přejete režim obnovy opustit, stiskněte tlačítko [image] nebo klávesu Esc.


Obnova FDB databáze ze zálohy

Navigation: Systém > Správa databáze > Obnova databáze ze zálohy >

Obnova FDB databáze ze zálohy

 Return to chapter overview

Zalohovani obnova FBD databaze ze zalohy

Zdrojové médium:

Pevný disk - v aplikaci je automaticky zvolena možnost obnovy databáze z pevného disku.

Zdrojový soubor:

Vyberte cestu k záložnímu souboru, ze kterého bude provedena obnova databáze ve firebirdu.

Pokud máte provedeno nastavení, stiskněte tlačítko [image] . Pokud si přejete režim obnovy opustit, stiskněte tlačítko [image] nebo klávesu Esc.


Obnova MDB databáze ze zálohy

Navigation: Systém > Správa databáze > Obnova databáze ze zálohy >

Obnova MDB databáze ze zálohy

 Return to chapter overview

Zalohovani obnova MDB databaze ze zalohy

Zdroj obnovy:

Pevný disk - v aplikaci je automaticky zvolena možnost obnovy databáze z pevného disku.

Vyberte cestu k záložnímu souboru, ze kterého bude provedena obnova databáze. Cestu můžete vybrat pomocí tlačítka [image].

Seznam nalezených zálohových souborů:

Po vybrání cesty k záložnímu souboru se zobrazí seznam nalezených zálohovaných souborů. V seznamu vyberte zatržením soubor, kterým chcete obnovit databázi. Pokud není seznam aktuální, stiskněte tlačítko [image].

Pokud máte provedeno nastavení, stiskněte tlačítko [image] . Pokud si přejete režim obnovy opustit, stiskněte tlačítko [image] nebo klávesu Esc.


Aktivace

Navigation: Systém > Správa databáze >

Aktivace

 Return to chapter overview

Programy firmy RON Software se po instalaci chovají vždy jako demoverze, dokud nejsou aktivovány aktivačním kódem.

Demoverze programu je omezena maximálním počtem tří zaměstnanců. Další omezení demoverze nemá. Znamená to, že si můžete naplnit veškeré databáze platnými daty (avšak max. 3 zaměstnance) a program si můžete vyzkoušet ještě před tím, než se rozhodnete jej zakoupit. Pokud si chcete program vyzkoušet bez omezení, vyžádejte si u naší firmy dočasný aktivační kód.

Aktivační kód je posloupnost čísel a písmen, která je vypočtena šifrovacím algoritmem z názvu vaší firmy, IČO a rozsahu licence.

Důvody používání aktivačních kódů:

1. jednoduchá a okamžitá možnost zakoupení nebo rozšíření licence programu. Díky aktivačnímu kódu můžete od naší firmy nebo vašeho prodejce programu okamžitě (telefonem, faxem, e-mailem) obdržet plnou verzi programu nebo jeho rozšíření. Na základě údajů vaší firmy a potvrzení o provedení platby.

2. ochrana proti neoprávněnému používání.

POZOR: Povinné údaje (tučné) v aktivačním formuláři nesmíte měnit. Při provedení změny se program ihned převede do režimu demoverze!!!

Aktivace aktivace programu

Princip aktivace systému je popsán na začátku příručky v části Licence.

C_Pridat testovaci aktivacni kod

Přidat testovací aktivační kód - v případě zadání platného licenčního čísla a aktivačního kódu se nabídne možnost přidání testovacího aktivačního kódu. Ten můžete využít pro otestování vybraných funkcí programu. Po vypršení platnosti testovacího kódu nemusíte přepisovat aktivační údaje.


Údaje zpracovávané firmy

Navigation: Systém > Správa databáze >

Údaje zpracovávané firmy

 Return to chapter overview

Ve formuláři můžete doplnit další údaje o vaší firmě. Část údajů je převzata z aktivace. Můžete také nastavit logo vaší firmy dvojklikem na rámečku v pravém horním rohu formuláře. Logo musí být v poměru 2:1. Nastavené údaje jsou používány při tisku výstupních sestav.

Volbou typu daňového subjektu "Plátcova pokladna" aktivujete pole DIČ plátcovy pokladny.

Aktivace udaje zpracovavane firmy

POZOR: Pokud nemáte aktivován modul Multilicence, nemůžete změnit údaje zpracovávané firmy v této sekci, ale přejděte do menu "Systém/Správa databáze/Aktivace".


Obnova indexů

Navigation: Systém > Správa databáze >

Obnova indexů

 Return to chapter overview

V menu Systém -> Správa databáze -> Obnova indexů provedete základní údržbu databáze. Tato funkce je podporována na databázových platformách MSSQL a Firebird. Funkci je vhodné provádět pravidelně například přes víkend. V závislosti na velikosti databáze může funkce trvat delší dobu. Funkce je doplněna i do plánovače úloh.


Nastavení parametrů databáze

Navigation: Systém > Správa databáze >

Nastavení parametrů databáze

 Return to chapter overview

Zvolte typ připojení:

MS SQL server - vyplňte pole a poté vytvořte databázi.

Multilicence MS SQL server

· Název serveru - název nebo IP adresa SQL serveru.

· Uživatel - uživatelské jméno ("sa" - systém administrator).

· Heslo - heslo pro přihlášení k serveru.

· Databáze - můžete vybrat ze seznamu již vytvořených databází nebo kliknout na tlačítko [image]. Otevře se okno, do kterého uvedete název databáze. Poté potvrdíte dotaz o provedení restrukturalizace připojené databáze. Program provede restrukturalizaci dat a vygeneruje základní nastavení databáze. Základní seznamy budou vyplněny standardními hodnotami. Tyto hodnoty můžete samozřejmě nahradit.

SQL server a Soubor MDB - postup nastavení parametrů můžete najít v kapitole Instalace/První spuštění.


Komprimace databáze

Navigation: Systém > Správa databáze >

Komprimace databáze

 Return to chapter overview

Při používání MS SQL serveru tato funkce uvolní nepoužívané části databázového souboru a soubor tak zkrátí. Pokud je databáze provozována na "mdb" databázi, opraví a zmenší tato funkce databázi stejně jako je tomu u SQL databáze. Na jiných platformách není tato volba dostupná.

POZOR: Při provádění komprimace nesmí být k databázi připojen jiný uživatel.


Restrukturalizace databáze

Navigation: Systém > Správa databáze >

Restrukturalizace databáze

 Return to chapter overview

Restrukturalizace provede přegenerování struktury databáze podle .sdf souboru s definicí struktury databáze. Pokud je databáze prázdná, pak vytvoří novou strukturu databáze. Restrukturalizace se většinou provádí při instalaci nebo přechodu na novější verzi programu. Při běžném používání programu se restrukturalizace neprovádí.

Pokud restrukturalizaci provedete, nepoškodíte data. Pokud si tedy nejste jisti správností funkce databáze, zkuste restrukturalizaci bez obav provést. Na velkých databázích musíte samozřejmě počítat s delší dobou na provedení této operace.

Při restrukturalizaci je možno volit tyto možnosti:

· Rychlá restrukturalizace - provede přegenerování struktury jen změněných tabulek v databázi. Používá se hlavně po instalaci novější verze programu, který rozšiřuje obsah databáze o nové položky.

· Úplná restrukturalizace - provede přegenerování struktury u všech tabulek v databázi. Tato volba je pomalejší a má opodstatnění pouze v případě, že jsou s databází nějaké problémy.

Volba vygenerovat implicitní data určuje, zda jsou po restrukturalizaci do tabulek v databázi vloženy předdefinované záznamy. Tato volba se používá jen při vygenerování nové struktury databáze do prázdného .mdb souboru. Pokud jste omylem vymazali standardní položky v databázi a chcete je dostat zpět, můžete tuto operaci použít, ale musíte počítat s tím, že standardní hodnoty budou dopsány do všech seznamů tak, jak byly naplněny při vytvoření nové databáze.

Pokud je připojená databáze prázdná (nemá vytvořenou žádnou strukturu), pak nejsou nabídnuty v menu žádné volby a je potřeba provést úplnou restrukturalizaci s vygenerováním implicitních dat.

Při provádění restrukturalizace nesmí být k této databázi připojen žádný uživatel. Restrukturalizace musí být provedena vždy bez chyby. Pokud došlo k chybě, zkontrolujte, zda se někdo z uživatelů v průběhu restrukturalizace nepřipojil. Pokud se restrukturalizace nedaří, je pravděpodobně databáze poškozena. V tom případě použijte podpůrné utility pro opravu databáze (můžete je najít na Centru podpory zákazníků).

POZOR: Jestliže restrukturalizace neproběhla v pořádku (skončila chybovým hlášením), nesmíte na databázi pracovat. Špatně restrukturalizovaná databáze nepracuje korektně a může dojít k poškození dat, které se nemusí projevit okamžitě.

Při restrukturalizaci se zobrazí okno Změny v databázi, které vás informuje o všech změněných tabulkách. Pokud využíváte způsob zabezpečení přihlášení do aplikace systémem uživatelů ("Systém/Správa databáze/Nastavení zabezpečení"), můžete zkontrolovat, zda aktualizace databázových práv uživatelů a skupin proběhla v pořádku. Aktualizace databázových práv doplňuje práva uživatelům a skupinám pro nově vytvořené tabulky a nová pole existujících tabulek.


Obnova systémových sestav a skriptů

Navigation: Systém > Správa databáze >

Obnova systémových sestav a skriptů

 Return to chapter overview

V případě, že omylem smažete nějaké sestavy či skripty, můžete je pomocí této funkce nechat opět vytvořit. Pozměněné sestavy a skripty však nově vytvořeny nebudou.


Nastavení zabezpečení

Navigation: Systém > Správa databáze >

Nastavení zabezpečení

 Return to chapter overview

Ve formuláři nastavení zabezpečení je možno nastavit tyto způsoby zabezpečení:

Zabezpeceni nastaveni zabezpeceni

· Bez zabezpečení - při spuštění programu není vyžadováno žádné přihlášení uživatele. Data programu nejsou v tomto případě žádným způsobem chráněna proti zneužití cizí osobou. Tuto variantu byste měli používat opravdu výjimečně, a to pouze v případě, že k počítači nemá přístup nikdo nepovolaný.

· Zabezpečení heslem - při spuštění programu je po uživateli vyžadováno heslo, které lze nastavit přes tlačítko [image]. Tato varianta ochrání data programu před nepovolanými osobami, kterým nedovolí bez správného hesla pracovat s programem. Nezapomínejte však na to, že heslo může někdo vidět, když jej zapisujete při přihlašování do programu. Z tohoto důvodu je vhodné heslo občas změnit a rozhodně v případě, že máte pocit (nebo dokonce víte), že vaše heslo někdo nepovolaný zná. Tato varianta zabezpečení bývá nejčastěji používaná u malých firem.

· Zabezpečení systémem uživatelů a práv - při spuštění programu je po uživateli vyžadováno přihlašovací jméno a heslo. Jednotliví uživatelé a jejich práva se nastavují v editoru uživatelů, který lze vyvolat přes tlačítko: . Uživatele lze přiřazovat do skupin. Skupiny a jejich práva lze vyvolat tlačítkem: . Tato poslední a nejrozsáhlejší varianta zabezpečení umožní práci s programem více uživatelům. Jednotlivým uživatelům můžete přitom přidělovat různá práva k činnostem a datům v programu. Pokud přidělíte každému uživateli jeho jméno a heslo pro přístup do programu, můžete následně rovněž zjistit, kdo prováděl úpravy v datech. Tato varianta bývá nejčastěji používaná u středních a velkých podniků, kde s programem pracuje více pracovníků.

Pokud využíváte zabezpečení systémem uživatelů a práv, máte rovněž možnost zapnout funkce Automaticky přihlásit aktuálního uživatele systému (pokud je stejný uživatel vytvořen také v aplikaci v Editoru uživatelů) a Politika hesel. Pokud kliknete na tlačítko [image], otevře se stejnojmenné okno:

Zabezpeceni nastaveni zabezpeceni Politika hesel

Zde můžete nastavit minimální délku hesla, úroveň zabezpečení a platnost hesla ve dnech. Po vypršení platnosti hesla je po přihlášení uživatele vynucena změna hesla.


Editor uživatelů

Navigation: Systém > Správa databáze > Nastavení zabezpečení >

Editor uživatelů

 Return to chapter overview

V této části programu se vytváří jednotliví uživatelé, které je možno členit do skupin. Způsob vytváření přístupových práv pro jednotlivé uživatele je totožný s nastavením práv pro skupiny, proto zde naleznete pouze odlišnosti.


Editor uživatelů - Základní údaje

Navigation: Systém > Správa databáze > Nastavení zabezpečení > Editor uživatelů >

Editor uživatelů - Základní údaje

 Return to chapter overview

Zabezpeceni editor uzivatelu zakladni udaje

Aktivní - pokud nemá uživatel nastaven příznak aktivní, nepřihlásí se do aplikace. Ve filtru v levé části okna si můžete zobrazit požadované uživatele (všichni, aktivní, neaktivní).

Nastavení správce - standardně je v programu jeden uživatel s přihlašovacím jménem správce. Pokud zaškrtnete položku správce v nastavení uživatele, bude mít aktuální uživatel neomezená práva bez ohledu na jeho příslušnost ke skupině nebo nastavení individuálních přístupových práv.

Autentizace podle active directory - po zatrhnutí pole se bude provádět autentizace podle active directory. V opačném případě podle hesla zadaného přímo v Editoru uživatelů.

Nastavení Hesla - můžete nastavit pro jednotlivé uživatele, které si uživatel může sám měnit. Více v kapitole Změna hesla.

V seznamu můžete nastavit uživateli obecná práva, například vytváření, editování a rušení tiskových sestav v seznamech apod.

Pod seznamem zadáte uživateli jeho jméno a příjmení. Pokud potřebujete, můžete doplnit i poznámku.

Dále můžete přidat uživateli členství ve skupinách. Pro přidání použijte tlačítko C_Pridat clenstvi uzivatele ve skupine a pro vyřazení použijte tlačítko C_Zrusit clenstvi uzivatele ve skupine. Práva uživatelů přiřazených do více skupin se sčítají. Pokud si nejste jisti nastavenými právy, přejděte do editoru uživatelů a zde si zobrazte tlačítkem [image] formulář Efektivní práva uživatele.

Tlačítka pro práci v editoru uživatelů:

 | Nový - vytvoření nového uživatele.
C_Novy z kopie | Nový z kopie - vytvoření nového uživatele z kopie aktuálního uživatele.
 | Přejmenovat - přejmenování již vytvořeného uživatele.
 | Zrušit - smazání uživatele.
 | Načíst - načtení uživatele ze souboru.
 | Uložit - uložení uživatele do souboru.
 | Efekt. práva - zobrazí formulář s právy uživatele.
 | Vyhledat - vyhledá požadovaného uživatele.
 | Zavřít - uzavře okno pro práci s uživateli.


Editor uživatelů - Práva na menu

Navigation: Systém > Správa databáze > Nastavení zabezpečení > Editor uživatelů >

Editor uživatelů - Práva na menu

 Return to chapter overview

Princip s právy na menu je shodný s právy na menu u editoru skupin. Proto je ovládání popsáno v kapitole Editor skupin - Práva na menu.


Editor uživatelů - Práva na databázi

Navigation: Systém > Správa databáze > Nastavení zabezpečení > Editor uživatelů >

Editor uživatelů - Práva na databázi

 Return to chapter overview

Ve formuláři můžete na rozdíl od nastavení skupin použít omezení pro hodnoty pro jednotlivé sloupce tabulek. V praxi to znamená, že například můžete omezit přístup na editaci docházky na jednotlivé zaměstnance, nebo skupiny zaměstnanců (vedoucí skupiny vidí v programu jen pracovníky svého oddělení).

PŘÍKLAD: V programu jsou zaměstnanci rozděleni do skupin pod názvy AA, BB, CC. Vedoucí pracovník pan Karas je vedoucím oddělení AA a BB. Chceme zabezpečit, aby pan Karas mohl editovat docházku pouze pracovníkům svých oddělení. V editoru práv pro uživatele nastavte v záložce práva databáze, označte položku skupiny zaměstnanců a ve spodní části v poli - Omezení hodnoty sloupce vypište, pro které skupiny má mít práva AA;BB - záznamy je nutno oddělit středníkem.

Další ovládání a práce s právy na databázi je shodná s právy na databázi u editoru skupin. Proto je ovládání popsáno v kapitole Editor skupin - Práva na databázi.


Editor uživatelů - Práva na sestavy v manažeru sestav

Navigation: Systém > Správa databáze > Nastavení zabezpečení > Editor uživatelů >

Editor uživatelů - Práva na sestavy v manažeru sestav

 Return to chapter overview

Princip s právy na sestavy je shodný s právy na sestavy u editoru skupin. Proto je ovládání popsáno v kapitole Editor skupin - Práva na sestavy v manažeru sestav.


Editor uživatelů - Přístupové skupiny

Navigation: Systém > Správa databáze > Nastavení zabezpečení > Editor uživatelů >

Editor uživatelů - Přístupové skupiny

 Return to chapter overview

Přístupových skupin se využije nejčastěji v případech, kdy má firma více mzdových pracovnic. Jedna mzdová pracovnice zpracovává data firemním pracovníkům a druhá pracovnice zpracovává mzdy vedoucím pracovníkům. Každé pracovnici se přiřadí požadovaná skupina, ve které bude moci například editovat údaje a následně je zpracovávat.

V přístupových skupinách jsou dva sloupce se seznamy. Jeden sloupec obsahuje seznam všech dostupných přístupových skupin a ve druhém sloupci je seznam všech povolených přístupových skupin.

Zabezpeceni editor uzivatelu pristupove skupiny

Přiřazení proběhne tehdy, když přesunete přístupovou skupinu zleva doprava pomocí šipky C_Sipka seda vpravo ve středovém panelu. Pokud chcete provést přiřazení vybraných skupin osob pro zabezpečení, můžete využít funkci Drag & Drop ("uchopit" záznam myší a přetáhnout).


Editor skupin

Navigation: Systém > Správa databáze > Nastavení zabezpečení >

Editor skupin

 Return to chapter overview

Nastavení přístupových práv pro skupinu uživatelů využijete v případě, že máte skupiny uživatelů se stejnými nebo podobnými přístupovými právy. Při vytváření přístupových práv je vhodné nadefinovat skupiny pro vedoucí pracovníky, správce, běžné uživatele, apod. Těmto skupinám přiřadíte práva a uživatele budete přiřazovat do jednotlivých skupin. Přístupová práva je možno pro jednotlivé uživatele dále specifikovat.


Editor skupin - Základní údaje

Navigation: Systém > Správa databáze > Nastavení zabezpečení > Editor skupin >

Editor skupin - Základní údaje

 Return to chapter overview

Zabezpeceni editor skupin zakladni udaje

V horní části formuláře se nachází seznam s obecnými právy. Skupině můžete například nastavit vytváření, editování a rušení tiskových sestav v seznamech apod.

Ve spodní části formuláře přiřadíte jednotlivé uživatele do skupiny. Pro přiřazení použijte tlačítko C_Pridat uzivatele do skupiny a pro vyřazení použijte tlačítko C_Zrusit uzivatele ze skupiny. Práva uživatelů přiřazených do více skupin se sčítají. Pokud si nejste jisti nastavenými právy, přejděte do editoru uživatelů a zde si zobrazte tlačítkem [image] formulář Efektivní práva uživatele.

Tlačítka pro práci v editoru skupin uživatelů:

 | Nový - vytvoření nové skupiny uživatelů.
C_Nova z kopie | Nový z kopie - - vytvoření nové skupiny z kopie aktuální skupiny.
 | Přejmenovat - přejmenování již vytvořené skupiny uživatelů.
 | Zrušit - smazání skupiny uživatelů.
 | Načíst - načtení skupiny ze souboru.
 | Uložit - uložení skupiny do souboru.
 | Vyhledat - vyhledá požadovanou skupinu.
 | Zavřít - uzavře okno pro práci se skupinami uživatelů.


Editor skupin - Práva na menu

Navigation: Systém > Správa databáze > Nastavení zabezpečení > Editor skupin >

Editor skupin - Práva na menu

 Return to chapter overview

Jednou z možných variant omezení přístupů je omezení přístupů na jednotlivé položky v menu. V této části je zobrazeno kompletní menu programu a máte možnost pomocí tlačítek [image] , [image] umístěných v horní části okna sbalit nebo rozbalit větev nebo celý strom menu. Pomocí tlačítek [image] , [image] , [image] můžete nastavit viditelnost či neviditelnost jednotlivých větví nebo jednotlivých položek menu.

Zabezpeceni prava na menu

Tlačítko [image] je určeno k zapnutí práv na kompletní menu. Tlačítko [image] je určeno k vypnutí práv na kompletní menu.

Položky v menu, které nebudou mít nastaveno [image] nebudou v programu vidět a uživatel s takto nastavenými právy ani nezjistí, že program vypnutou funkci může obsahovat.


Editor skupin - Práva na databázi

Navigation: Systém > Správa databáze > Nastavení zabezpečení > Editor skupin >

Editor skupin - Práva na databázi

 Return to chapter overview

Další možností je omezit přístupová práva na jednotlivé datové tabulky a následně na sloupce tabulek. Můžete tedy zabezpečit, že uživatel v žádné části programu neuvidí kódy identifikačních médií (čísla karet, čipů,...). Na tabulky a sloupce můžete nastavit atributy čtení [image], editace [image], vytvoření nového záznamu [image], smazání záznamů [image]. Tlačítko [image] je určeno k zapnutí všech databázových práv a tlačítkem [image] vypnete všechna databázová práva.

Zabezpeceni prava na databazi

Jednotlivé způsoby nastavení přístupových práv se dají kombinovat, lze nastavit práva v menu na seznam čteček a současně můžete zakázat uživatelům vytvoření nové čtečky.

Při definování přístupových práv na menu buďte pečliví, abyste přílišným omezením práv neznemožnili uživateli systém smysluplně využívat.


Editor skupin - Práva na sestavy v manažeru sestav

Navigation: Systém > Správa databáze > Nastavení zabezpečení > Editor skupin >

Editor skupin - Práva na sestavy v manažeru sestav

 Return to chapter overview

Poslední z možností omezení práce s programem je omezení přístupu k jednotlivým tiskovým sestavám. Princip je stejný jako v kapitole Editor skupin - Práva na menu. Nastavujete viditelnost sestavy přiřazením [image] k jednotlivým sestavám. Pokud chcete zpřístupnit všechny sestavy, klikněte na tlačítko [image]. Pokud chcete u všech sestav zrušit viditelnost, klikněte tlačítko [image]. Tlačítka [image] , [image] sbalí nebo rozbalí větev nebo celý strom menu.

Zabezpeceni prava na sestavy v manazeru sestav


Editor skupin - Přístupové skupiny

Navigation: Systém > Správa databáze > Nastavení zabezpečení > Editor skupin >

Editor skupin - Přístupové skupiny

Return to chapter overview

Princip s přístupovými skupinami je shodný s přístupovými skupinami u editoru uživatelů. Proto je ovládání popsáno v kapitole Editor uživatelů - Přístupové skupiny.


Synchronizace skupin osob pro zabezpečení v aplikaci

Navigation: Systém > Správa databáze >

Synchronizace skupin osob pro zabezpečení v aplikaci

 Return to chapter overview

Pokud používáte skupiny zaměstnanců a přístupové skupiny shodné, stačí vám pouze spustit tuto funkci tlačítkem [image] a program zkopíruje nastavení skupin zaměstnanců do přístupových skupin (menu Systém/Správa databáze/Skupiny osob pro zabezpečení v aplikaci).

Pokud systém zavádíte, je seznam přístupových skupin prázdný. Naplňte seznam skupin zaměstnanců v sekci Skupiny osob pro zabezpečení v aplikaci a potom spusťte tuto funkci.

Sprava databaze synchronizace pristupovych skupin podle rozdeleni osob

· Uplatnit hierarchii rozdělení - volba určuje, zda bude při synchronizaci skupin osob pro zabezpečení v aplikaci uplatněna hierarchie zdrojového rozdělení. To znamená, že členové skupin odpovídajících podřízeným rozdělením budou i členy skupin odpovídajících nadřazeným rozdělením.


Skupiny osob pro zabezpečení v aplikaci

Navigation: Systém > Správa databáze >

Skupiny osob pro zabezpečení v aplikaci

 Return to chapter overview

Přístupovou skupinu osob zadejte v případě, že využíváte zabezpečení systémem uživatelů a skupin v menu "Systém/Správa databáze/Nastavení zabezpečení" a potřebujete uživatelům zpřístupnit pouze data některých zaměstnanců. Členství ve skupinách osob pro zabezpečení se nepřiděluje osobám, ale pracovním poměrům osob. Takto lze nastavit práva uživatelům aplikace tak, aby viděli jen některé pracovní poměry konkrétní osoby.

Skupiny osob pro zabezpeceni v aplikaci

Pokud neprovedete synchronizaci přístupových skupin podle rozdělení v menu "Systém/Správa databáze/Synchronizace skupin osob pro zabezpečení v aplikaci", můžete skupiny vytvořit kliknutím na tlačítko [image] Nový záznam. Jednotlivé vytvořené položky lze měnit tlačítkem [image] Editace záznamu. Otevře se formulář Přístupová skupina, který má záložky Formulář záznamu a Členové skupiny.

POZNÁMKA: Pokud provedete synchronizaci skupin osob pro zabezpečení v aplikaci, přepíše se skupina z rozdělení zaměstnance do nastavení skupin pro zabezpečení. Ruční zadávání v takovém případě neprovádějte, jelikož synchronizace vaše ruční nastavení vždy přepíše.


Skupiny osob pro zabezpečení v aplikaci - Formulář záznamu

Navigation: Systém > Správa databáze > Skupiny osob pro zabezpečení v aplikaci >

Skupiny osob pro zabezpečení v aplikaci - Formulář záznamu

 Return to chapter overview

Přístupové skupiny vytvořené v tomto menu naplní sloupec Dostupné přístupové skupiny v menu "Systém/Správa databáze/Nastavení zabezpečení/Editor uživatelů", v záložce Přístupové skupiny.

Skupiny osob pro zabezpeceni v aplikaci formular pristupove skupiny formular zaznamu

· Kód - zadejte povinný kód pro přístupovou skupinu.

· Popis - textové označení skupiny.


Skupiny osob pro zabezpečení v aplikaci - Členové skupiny

Navigation: Systém > Správa databáze > Skupiny osob pro zabezpečení v aplikaci >

Skupiny osob pro zabezpečení v aplikaci - Členové skupiny

 Return to chapter overview

Každý uživatel má definován přístup k určitým přístupovým skupinám a tím má přístup také k jejím členům. Ve formuláři vyberete jednotlivé osoby ze sloupce Osoby pro výběr členů a pomocí šipek (na obrázku v červeném rámečku) je přesunete do sloupce Členové skupiny. Pokud chcete přenést všechny položky, stiskněte tlačítko se zdvojenou šipkou. Stejný postup platí pro zařazení položek zpět na levou stranu.

Skupiny osob pro zabezpeceni v aplikaci formular pristupove skupiny clenove skupiny

Filtry ve sloupci Osoby pro výběr členů:

§ Všichni - filtr zobrazí všechny zaměstnance.

§ Aktivní PP - zatržením funkce zjistíte všechny osoby s neukončeným pracovním poměrem.

§ Nečlenové - výběrem filtru vytvoříte seznam osob, které nejsou členy vybrané přístupové skupiny.

Filtry ve sloupci Členové skupiny:

§ Všichni - filtr zobrazí všechny zaměstnance.

§ Aktivní - výběrem funkce získáte seznam zaměstnanců s neukončeným pracovním poměrem.

§ Neaktivní - zatržením filtru vytvoříte seznam osob, které mají již ukončený pracovní poměr.


Správce přesunů osob na rozděleních

Navigation: Systém > Správa databáze >

Správce přesunů osob na rozděleních

 Return to chapter overview

Správce přesunů osob na rozděleních slouží k hromadnému přesouvání osob mezi rozděleními z vybraných existujících rozdělení do nově vytvořených. Lze využít při změně vnitřní struktury daného rozdělení nebo při vytvoření nového typu rozdělení.

Spravce presunu osob na rozdelenich


Skupiny active directory

Navigation: Systém > Správa databáze >

Skupiny active directory

 Return to chapter overview

V této sekci je potřeba nadefinovat skupiny active directory, které se budou přiřazovat zaměstnancům (uživatelům v active directory) .

Skupiny active directory_Seznam

Novou skupinu active directory vytvoříte kliknutím na tlačítko [image] Nový záznam. Jednotlivé vytvořené položky lze měnit tlačítkem [image] Editace záznamu. Otevře se formulář Skupina active directory, který má záložky:

Skupina

Členové


Skupiny active directory - Skupina

Navigation: Systém > Správa databáze > Skupiny active directory >

Skupiny active directory - Skupina

 Return to chapter overview

Ve formuláři zadáte název skupiny a můžete dopsat libovolnou poznámku k vytvářené skupině.

Skupiny active directory_Skupina


Skupiny active directory - Členové

Navigation: Systém > Správa databáze > Skupiny active directory >

Skupiny active directory - Členové

 Return to chapter overview

Ve formuláři se přiřazují skupině její členové.

Skupiny active directory_Clenove


Role active directory

Navigation: Systém > Správa databáze >

Role active directory

 Return to chapter overview

Role active directory představuje jeden typ rozdělení nastavitelný v menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Active directory -> Typ rozdělení pro role v active directory. Roli active directory je možno přiřazovat skupiny active directory. To znamená, že zaměstnanci přiřazeni do dané role budou po synchronizaci nejen členy přímo přiřazených skupin, ale také skupin přiřazených dané roli. Skupiny vytvoříte v menu Systém -> Správa databáze -> Skupiny active directory.

Role active directory

Role můžete vytvořit kliknutím na tlačítko [image] Nový záznam. Jednotlivé vytvořené položky lze měnit tlačítkem [image] Editace záznamu. Otevře se formulář Role active directory, který má následující záložky:

Formulář záznamu

Členové role

Dokumenty

Skupiny active directory


Role active directory - Formulář záznamu

Navigation: Systém > Správa databáze > Role active directory >

Role active directory - Formulář záznamu

 Return to chapter overview

Formulář obsahuje identifikační údaje o roli active directory.

Role active directory_Formular zaznamu

· Kód - povinný údaj. Vyberte přijatelný kód, podle kterého se budete snadno orientovat.

· Kód nadřazeného umístění - kód rozdělení, které je nadřazené tomuto rozdělení.

· Popis - povinný údaj. Popište rozdělení.

· Vedoucí - vedoucí rozdělení.

· Datum vytvoření - povinná položka. Vložte datum vytvoření.

· Datum zrušení - vložte datum zrušení.

· Ulice - doplňte specifikující údaje, pokud se rozdělení nachází na určité adrese (např. pracoviště).

· Město / PSČ / Obec / Stát - výběrové položky. Můžete upravovat stávající nebo doplňovat nové záznamy, a to kliknutím na podtržený název.

· Telefon / Fax / e-mail - v případě potřeby uveďte kontaktní informace.


Role active directory - Členové role

Navigation: Systém > Správa databáze > Role active directory >

Role active directory - Členové role

 Return to chapter overview

Ve formuláři se přiřazují roli její členové.

Role active directory_Clenove role


Role active directory - Dokumenty

Navigation: Systém > Správa databáze > Role active directory >

Role active directory - Dokumenty

 Return to chapter overview

Záložka slouží k přiřazení, popřípadě odebrání stávajících dokumentů, které jsou u dané role vyžadovány.

Role active directory_Dokumenty

Okno je rozděleno na dva seznamy, mezi kterými můžete dokumenty přesouvat pomocí šipek. Ve sloupci Nevybrané záznamy označíte požadovaný záznam a pomocí ikony C_Sipka seda vpravo Šipka přesunete do sloupce Vybrané záznamy.

Tlačítkem [image] Editace záznamu otevřete formulář Dokumentu .

POZOR: V aplikaci Jídelna se záložka nezobrazuje!


Role active directory - Skupiny active directory

Navigation: Systém > Správa databáze > Role active directory >

Role active directory - Skupiny active directory

 Return to chapter overview

Na této záložce je možné přiřadit roli active directory skupiny active directory.

Role active directory_Skupiny active directory


Rušení starých záznamů

Navigation: Systém > Správa databáze >

Rušení starých záznamů

 Return to chapter overview

Funkce Rušení starých záznamů umožňuje zrušit stará data:

· Původní docházky
· Zpracované docházky
· Historie průchodů

Ruseni starych zaznamu z databaze

Nastavení počtu měsíců, které zůstanou zachovány, se provádí ve formuláři nastavení aplikace na záložce Uchovávaní záznamů.

Zrušení starších záznamů provede definitivní vymazání těchto záznamů z databáze. Zkontrolujte pečlivě datumy, do kterých budou data smazána. Pozdější obnova dat nebude možná. Doporučujeme před mazáním dat vytvořit zálohu databáze.


Rušení budoucích záznamů

Navigation: Systém > Správa databáze >

Rušení budoucích záznamů

 Return to chapter overview

Tato funkce umožňuje rušení budoucích záznamů, které byly do původní docházky chybně načteny z terminálu.

Ruseni chybnych zaznamu z budoucnosti

· Zrušit záznamy původní docházky po datu - pokud chcete zrušit budoucí záznamy z původní docházky, je nutné zadat, po jakém datu se mají dané záznamy zrušit.

· Zrušit záznamy historie průchodů po datu - chcete-li zrušit budoucí záznamy z historie průchodů, je opět nutné zadat, po jakém datu mají být dané záznamy zrušeny.

· Zrušit záznamy pro monitorování po datu - pokud chcete zrušit budoucí záznamy z monitorování, je potřeba zadat, po jakém datu se mají dané záznamy zrušit.


Export vzorku databáze

Navigation: Systém > Správa databáze >

Export vzorku databáze

 Return to chapter overview

Tato funkce umožní vyexportovat nastavení vašeho systému. Pomocí zaškrtávacích políček (checkboxů) [image] můžete zvolit položky, které budou tvořit vzorek.

Pro výběr všech položek použijte tlačítko [image] a tlačítko [image] pro zrušení všech dosud nastavených položek.

Pokud chcete do vzorku přidat i data některého ze zaměstnanců, zvolte jednu z následujících možností:

· Data osoby - vyberte jméno požadovaného zaměstnance. V exportu vzorku budou obsaženy data jedné osoby.

· Data všech osob za období - ve vzorku databáze budou data všech osob za aktuálně vybrané období. Období můžete změnit v menu Systém -> výběr období.

· Data osob v rozdělení za období - ve vzorku databáze budou data osob zvoleného rozdělení za aktuálně vybrané období.

POZNÁMKA: V některých programech může být tato nabídka omezena.

Pro export struktury mzdových a časových položek (pracovního poměru) je třeba současně exportovat číselníky mzdových a časových položek.

Stiskem tlačítka [image] ve spodní části okna vyvoláte dotaz, kam chcete soubor uložit. Soubor bude uložen s příponou ".dbs".

Vzorek databaze export vzorku databaze

TIP: V případě, že se setkáte s problémem, který se vám nedaří vyřešit, můžete tento vzorek spolu s popisem problému umístit na web technické podpory, kde se jím budou zabývat naši odborníci. Web technické podpory: "helpdesk.ron.cz".


Import vzorku databáze

Navigation: Systém > Správa databáze >

Import vzorku databáze

 Return to chapter overview

Pokud chcete přijmout data upravená našimi odborníky do vaší databáze, uložte soubor s příponou ".dbs" do vašeho počítače a načtěte jej pomocí tlačítka [image] .

Vzorek databaze import vzorku databaze prazdny

Dále si zvolíte všechny, nebo jen vybrané okruhy dat podobně jako u exportu vzorku databáze. Pokračujte stiskem tlačítka [image], čímž se automaticky opraví zvolené okruhy dat ve vaší databázi.

Vzorek databaze import vzorku databaze

POZOR: Mezi exportem a importem neprovádějte žádné změny exportovaného vzorku. Při importu vzorku se provedené změny upraví podle dat ve vzorku, který jste exportovali.


Seznam počítačů připojených k databázi

Navigation: Systém >

Seznam počítačů připojených k databázi

 Return to chapter overview

Pokud chcete mít přehled, které počítače jsou aktuálně připojené k databázi (pracující s programem), pak stiskněte tuto volbu. Správce systému může tímto způsobem zjistit, jestli je někdo aktuálně připojen k databázi v případě, že potřebuje provádět operace vyžadující uvolněnou databázi od všech uživatelů. Například při zálohování nebo restrukturalizaci je nutné, aby nebyl k databázi nikdo další připojen.


Aktuálně připojené počítače

Navigation: Systém > Seznam počítačů připojených k databázi >

Aktuálně připojené počítače

 Return to chapter overview

Záložka zobrazuje seznam počítačů, které jsou aktuálně připojeny k databázi:

Seznam pocitacu aktualne pripojene pocitace

Tlačítkem [image] obnovíte seznam aktuálně připojených počítačů a tlačítkem [image] seznam uzavřete.


Mapování popisů počítačů

Navigation: Systém > Seznam počítačů připojených k databázi >

Mapování popisů počítačů

 Return to chapter overview

Celkový seznam počítačů můžete vytvořit v tomto okně.

Seznam pocitacu mapovani popisu pocitacu

Stisknutím tlačítka [image] otevřete dialogové okno Vytvoření nového mapování popisu, do kterého zadáte tyto údaje:

Seznam pocitacu mapovani popisu pocitacu novy

· Počítač - uveďte, o jaký počítač jde. Záleží na vás, jestli ho pojmenujete jménem osoby, která s ním pracuje, nebo číslem.

· Popis - doplňte popis počítače. Údaje volte tak, abyste mohli snadno rozpoznat aktuálně připojené počítače.


Stavový řádek

Navigation: Systém >

Stavový řádek

 Return to chapter overview

Stavový řádek má tu výhodu, že je viditelný při otevřených seznamech, které se zobrazují ve střední části monitoru. Stavový řádek najdete v dolní části aplikace. V našem případě má stavový řádek řádky dva.

V druhém oddíle prvního stavového řádku se zobrazuje počet záznamů v aktivním seznamu. Třetí oddíl prvního stavového řádku zobrazuje krátkou nápovědu položek, na kterých se nachází kurzor.

Druhý stavový řádek zobrazuje v prvním oddíle název firmy, ve které jsou zpracovávána data, a v druhém oddíle zobrazuje aktuálně nastavené období, resp. období, se kterým momentálně pracujete.

Nepotřebujete-li stavový řádek sledovat, je možno jej vypnout v menu volbou Systém/Stavový řádek.


Rychlé menu

Navigation: Systém >

Rychlé menu

 Return to chapter overview

Účelem menu je rychlejší manipulace s často používanými položkami a zapíná se volbou Systém/Rychlé menu. Při práci s aplikací se aktivování rychlého menu projeví jako lišta s ikonami v levé části monitoru.

Lista rychleho menu

Ikony rychlého menu si můžete libovolně měnit - ubírat či přidávat. Kliknutím pravým tlačítkem myši na lištu s ikonami se zobrazí menu.

Zobrazit | C_Sipka doprava seznamy
Umístění | C_Sipka doprava seznamy
Přidat položku menu |
Zrušit položku menu |
Obnovit implicitní nastavení |

Zobrazit - v této položce máte možnost nastavit velikost (malou, střední, velkou) zobrazení ikony položky rychlého menu.

Umístění - v tomto odkazu umístíte rychlé menu na požadovanou stranu (vlevo, vpravo, nahoru, dolu).

Přidat položku menu - tímto odkazem přidáte položku rychlého menu. Postup přidání je popsán níže.

Zrušit položku menu - po označení požadované položky se zobrazí okno s varováním: "Opravdu si přejete zrušit akt. položku: "Název rušené položky rychlého menu"?". Po potvrzení je položka smazána z rychlého menu.

Obnovit implicitní nastavení - po výběru položky se zobrazí okno s varováním: "Všechny uživatelsky přidané položky a další úpravy rychlého menu budou ztraceny! Opravdu si přejete obnovit implicitní nastavení rychlého menu?" Po potvrzení je obnoveno výchozí nastavení rychlého menu.

Pro přidání položky stiskněte Přidat položku menu a otevře se okno se stromovým zobrazením standardního menu.

Nastaveni prostredi rychle menu vyber polozky menu

Požadovanou položku najděte ve struktuře a potvrďte tlačítkem [image]. Pro rozvinutí a svinutí stromu používejte kurzor myši a dvojité kliknutí na danou položku. Po výběru položky můžete zvolit z nabízeného seznamu nebo ze souboru ikonu položky rychlého menu.

Vyber obrazku ikony rychleho menu

Po potvrzení výběru se vybraná položka přidá do seznamu rychlého menu.

TIP: Pokud chcete v rychlém menu spouštět skript nebo uživatelský seznam, musíte ho nejdříve přidat do menu Uživatelských funkcí. To provedete v menu Uživatelské funkce/Nastavení uživatelských skriptů (Nastavení uživatelských seznamů).


Plovoucí nápověda

Navigation: Systém >

Plovoucí nápověda

 Return to chapter overview

Plovoucí nápověda zobrazuje popisky ("bubliny") k ikonám v programu pokaždé tehdy, když necháte kurzor myši na ikoně. Pokud chcete znát funkci jednotlivých ikon, zatrhněte si plovoucí nápovědu.


Konec

Navigation: Systém >

Konec

 Return to chapter overview

Pomocí tohoto menu ukončíte práce v programu. Program lze také uzavřít stisknutím kláves Alt+F4. Třetí možností, jak rychle vypnout mzdový program, je kliknout na tlačítko [image] v pravém horním rohu. Ve všech těchto případech se objeví okno, ve kterém potvrdíte dotaz na ukončení aplikace kliknutím na tlačítko ANO.


Seznamy

Navigation: »No topics above this level«

Seznamy

 Return to chapter overview

Správně naplněné seznamy jsou základem funkčního systému. Nezapomeňte, že zobrazený seznam neslouží k zápisu dat, ale musíte si vždy otevřít formulář pro editaci vybraného záznamu v seznamu (kliknout na tlačítko Editace zaznamu Editace záznamu). Pokud chcete přidávat nové položky do seznamu, klikněte na tlačítko Novy zaznam Nový záznam.

Menu Seznamy obsahuje následující položky:

Zaměstnanci

Zaměstnanci - pracovní poměry

Externí osoby

Kalendáře

Směny

Kalendáře - Příplatky

Kalendáře - Přesčasy

Kalendáře - Vzorce

Harmonogram směn

Typy pracovních poměrů

Typy časových složek

Typy mzdových položek

Skupiny osob

Seznam fotografií a obrázků

Typy rozdělení

Rozdělení

Typy umístění

Umístění

Kategorie

Typy kategorií

Typy dokumentů

Obecné dokumenty

XML formuláře

Vzkazy

Řádky, které jsou ve formulářích seznamů napsány tučně, jsou povinné!!! Bez vyplnění těchto řádků Vás systém nepustí k dalšímu kroku!!!


Zaměstnanci

Navigation: Seznamy >

Zaměstnanci

 Return to chapter overview

Seznam zaměstnanců je jedním ze základních seznamů pro řízení docházkového systému.

POZOR: Pouze zaměstnanci, kteří jsou aktuálně v pracovním poměru a mají správně zadány všechny potřebné údaje, mohou používat docházkové a přístupové terminály.

Seznam zaměstnanců obsahuje všechny zaměstnance, které jste do databáze zapsali, bez ohledu na to, zda již ukončili pracovní poměr nebo neukončili. Pokud chcete vybrat zobrazení pouze aktivních nebo neaktivních zaměstnanců, použijte volbu pro rychlé filtrování v horní části seznamu.

TIP: Smazat zaměstnance ze seznamu můžete, pouze pokud nemá žádný záznam v původní docházce (nepoužil ID, nebyla mu vložena operace přes Manuální vkládání). Pokud zaměstnanec již použil některý z terminálů, budete moci jeho záznam zrušit až po smazání dat za toto období. Což je až v době kdy jste si jisti, že data za zvolené období nepotřebujete a necháte je kompletně smazat.

Pro usnadnění, či zrychlení výběru ze seznamu, použijte filtry, které jsou umístěny nad seznamem:

Lupa

Vyhledat podle načtené karty - slouží pro rychlé vyhledávání osob. Po přiložení karty ke čtecí hlavě program vyhledá osobu, která má tuto kartu přiřazenou a otevře Formulář zaměstnance načtené osoby. Pokud tlačítko nefunguje, pak je nutné v menu Systém/Nastavení/Nastavení aplikace/Lokální nastavení/Načítání ID média vybrat název terminálu, který má tuto funkci využívat. Zkontrolujte, rovněž, zda máte nadefinovány parametry k tomuto terminálu v menu Terminály/Terminály.

§ Zobrazit hierarchii - odsouhlasíte-li tuto funkci, zobrazí se vedle seznamu vlevo personální větvení firmy s vybranými zaměstnanci, kteří patří do příslušné kategorie. Ukáže hierarchii všech nadřízených a podřízených středisek. Se středisky můžete libovolně manipulovat a přesouvat je podle svých potřeb. Zaměstnancům zůstane přiřazeno středisko, které jim je přiděleno v jejich kartě.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

Tuto strukturu můžete upravovat:

ú pokud podřízené rozdělení má být nadřízeným, označte jej a pravým tlačítkem aktivujte nabídku, ze které vyberte Přesunout na kořen stromu;

ú pokud nadřízené rozdělení má být podřízeným, označte jej levým tlačítkem myši a přetáhněte do rozdělení, kterému má být podřízeno.

POZNÁMKA: Tlačítko Pregenerovani tabulky slouží k aktualizaci tabulky s hierarchií rozdělení.

§ Typ rozdělení - výběrová položka poskytne seznam zaměstnanců podle jednotlivých středisek.

§ Jen rozdělení - vyberte rozdělení, pro které chcete zobrazit seznam.

§ Jen typ osoby - nabízí se varianta Zaměstnanec a Zaměstnanec jiné firmy.

§ Všichni - zobrazí seznam všech zaměstnanců bez ohledu na to, zda jsou nebo nejsou v pracovním poměru.

§ Aktivní - zobrazí zaměstnance, kteří jsou v aktivním pracovním poměru.

§ Neaktivní - zobrazí zaměstnance, kteří již nejsou v pracovním poměru.

Filtr standardně pracuje se seznamem zaměstnanců k aktuálnímu dni. Pokud chcete zobrazit stav k jinému dni, zrušte zaškrtnutí Akt. den a nastavte datum u funkce Ke dni, ke kterému chcete zobrazit seznam.

Vkládání nebo opravu jednotlivých údajů neprovádějte v tomto seznamu, ale otevřete si ikonou editace formulář Zaměstnanec (dvojklik na řádku se jménem zaměstnance). Přes ikonu Nový otevřete Průvodce přidáním nového zaměstnance. Po zadání údajů v průvodci se data zobrazí v Kartě zaměstnance.


Průvodce přidáním nového zaměstnance

Navigation: Seznamy > Zaměstnanci >

Průvodce přidáním nového zaměstnance

 Return to chapter overview

Průvodce otevřete kliknutím na ikonu Novy zaznam Nový záznam v seznamu zaměstnanců (Seznamy/Zaměstnanci).

· Rodné číslo - povinný údaj. Vyplňte rodné číslo zaměstnance. V případě, že nechcete vést evidenci dle rodných čísel, zadejte číslo jiné, libovolné, které bude sloužit jako identifikační.

· Titul - vyplňte titul před jménem.

· Jméno - vepište jméno zaměstnance.

· Příjmení - povinný údaj. Vyplňte příjmení.

· Titul za - vyplňte titul za jménem.

· Typ osoby - vyberte z nabídky, o jakého zaměstnance se jedná (zaměstnanec - zaměstnanec jiné firmy).

· Osobní číslo - povinný údaj. Identifikační číslo pracovního poměru.

· Datum nástupu - povinný údaj. Zadejte jej ve formátu D.M.RRRR. Od tohoto data lze se zaměstnancem v systému pracovat jako s aktivním.

· Identifikační médium - z nabídky vyberte identifikační médium.

Lupa

Načtení ID média (Ctrl+I) - slouží pro rychlé přiřazení karty nové osobě. Po přiložení karty ke čtecí hlavě program přiřadí načtenou kartu osobě. Pokud karta není v seznamu ID médií, zobrazí se formulář, ve kterém zadáte nové Identifikační médium. Pokud tlačítko nefunguje, pak je nutné v menu Systém/Nastavení/Nastavení aplikace/Lokální nastavení/Načítání ID média vybrat název terminálu, který má tuto funkci využívat. Zkontrolujte, rovněž, zda máte nadefinovány parametry k tomuto terminálu v menu Terminály/Terminály.

· Pin - máte možnost zadat pin ID média.

· Skupina zaměstnanců - vyberte skupinu zaměstnanců. Novou skupinu zaměstnanců vytvoříte v menu Seznamy/Skupiny osob.

· Kalendář - přiřaďte zaměstnanci kalendář. Bez přiřazení kalendáře zaměstnanci nebude program schopen počítat normu odpracované doby.

· Poznámka - zde si můžete vepsat libovolné, pro vás důležité, informace.

· Foto - dvojklikem do prostoru určeného pro fotografii se dostanete do vlastních adresářů, z nichž můžete fotografii načíst do formuláře.

Pokud již máte vše vyplněno, stiskněte tlačítko OK nebo tlačítko Novy pro přidání dalšího zaměstnance.

Položky s podtrženým názvem je možné v seznamu upravovat. Stačí kliknout na podtržený název pole - otevře se seznam pro Výběr ..., ve kterém můžete editovat stávající údaje tlačítkem Editace zaznamu Editace záznamu nebo vkládat nové tlačítkem Novy zaznam Nový záznam.


Formulář zaměstnance

Navigation: Seznamy > Zaměstnanci >

Formulář zaměstnance

 Return to chapter overview

Formulář zaměstnance je rozdělen na základní části (záložky) mezi kterými se můžete přepínat volbou v seznamu na levé části formuláře. Správné naplnění údajů o zaměstnanci je předpokladem správné funkčnosti docházkového systému. Pokud nebudete mít zadány potřebné údaje u zaměstnance, nebude docházkový systém s takto zadaným zaměstnancem pracovat.

POZOR: Je nutné vyplnit všechny tlustě zvýrazněné údaje, aby byl zadávaný zaměstnanec do systému vložen.

Seznam záložek:

Hlavní údaje | Hlavní identifikační údaje zaměstnance a základní údaje o pracovním poměru.
Ostatní údaje | V záložce je možno sledovat i jiné údaje, které standardně nejsou v přístupovém systému přednastaveny. Volbu uživatelských polí nastavíte v menu Systém/Nastavení/Nastavení aplikace/Společné nastavení/Uživatelská pole osob.
ID média | Přiřazení identifikačního média zaměstnanci ze seznamu ID médií. Nezapomeňte, že musíte mít naplněný seznam ID médií. Bez ID média není schopen zaměstnanec používat terminály.
Otisky | Tato záložka slouží pro práci s otisky prstů a přidávání načtených otisků prstů z terminálu konkrétním zaměstnancům.
Skupina osob | Zařazení zaměstnance do zvolených skupin. Skupinu potřebujete pro určení rozdělení zaměstnanců do jednotlivých terminálů. Zaměstnanec může být členem několika skupin, ale musí být alespoň v jedné skupině. Nezapomeňte naplnit seznam skupin.
Kalendář | Volba platného kalendáře pro období. Kalendářem nastavíte velkou část parametrů pro zpracování docházky. U kalendáře také zadáváte platnost od kdy, do kdy pro zaměstnance platí. Rovněž bez platného kalendáře program docházku zaměstnance nezpracuje.
Rozdělení | Kromě rozdělení zaměstnanců do skupin, je můžete členit podle dalších kritérií. Seznam těchto kritérií můžete nastavit v seznamu Typů rozdělení. Můžete použít například seznam pracovišť, středisek a personálních středisek, výplatních míst atd. Nastavení rozdělení nemá zásadní vliv na zpracování docházky. Umožní vám v případě vaší potřeby nahlížet na zpracovaná data z pohledu dalších rozdělení (rozlišení) docházky.
Intraweb, Práva | Tato aplikace je dostupná pokud máte zakoupen modul RON portál. V této části přiřazujete zaměstnanci jednotlivá práva pro přístup k datům v intrawebu. Dále je zde možné spojit zaměstnance s uživatelem aplikace a s uživatelem active directory. Pokud máte také zakoupen modul RON Klient přiřazujete zde zaměstnanci jednotlivá práva pro přístup k datům v mobilním klientovi.

Aby zaměstnanec mohl používat docházkový systém, musí mít vyplněn platný pracovní poměr, přiřazené ID médium a nastavený kalendář. Vhodné je také zaměstnance rozdělit do skupin pro lepší filtrování záznamů.

TIP: U mnoha zadávaných údajů je datum platnosti. Program při přidělování dat automaticky nastavuje aktuální datum. Pokud potřebujete, aby data o pracovníkovi platila zpětně, musíte data přiřazení upravit podle potřeby.


Formulář zaměstnance - Hlavní údaje

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance >

Formulář zaměstnance - Hlavní údaje

 Return to chapter overview

Při vytváření nového záznamu v Seznamu zaměstnanců (předešlá akce), se údaje z Průvodce přidání nového zaměstnance přenesou do této karty. Některé údaje je potřeba ještě vyplnit, abychom měli co nejlepší evidenci zaměstnanců.

Ve formuláři jsou uvedeny základní identifikační údaje zaměstnance - Osoba a Pracovní poměry - seznam pracovních poměrů zaměstnance.

osoba:

· Rodné číslo - povinný údaj. V případě, že nechcete vést evidenci dle rodných čísel, zadejte identifikační číslo zaměstnance.

· Titul - titul před jménem.

· Jméno - křestní jméno zaměstnance - považujte za povinný údaj - může se vyskytnout více zaměstnanců stejného příjmení.

· Příjmení - povinný údaj. Vyplňte příjmení.

· Titul za - titul za jménem.

· Datum narození - datum zadejte ve formátu D.M.RRRR.

· Poznámka - textová informace o pracovníkovi.

· Fotka - dvojklikem do prostoru určeného pro fotografii se dostanete do vlastních adresářů, z nichž můžete fotografii načíst do formuláře. Pokud stisknete v tomto prostoru pravé tlačítko myši, zobrazí se následující nabídka:

o Načíst fotku ze souboru - po výběru odkazu se zobrazí okno, ve kterém naleznete požadovanou fotografii.

o Uložit fotku do souboru - po výběru odkazu se zobrazí okno, ve kterém naleznete umístění pro uložení fotografie.

o Smazat fotku - po výběru odkazu smažete fotografii ve formuláři zaměstnance. Tuto akci můžete provést stiskem klávesnice F8.

o Vyfotit web kamerou - po výběru odkazu se aktivuje web kamera a zobrazí se formulář Camera. V poli Kamera vyberte požadované zařízení. Po potvrzení formuláře se fotografie zobrazí ve formuláři zaměstnance.

Pracovní poměry:

Zaměstnanec může mít několik souběžných pracovních poměrů nebo může postupně několikrát přijít a odejít. Většina zaměstnanců má však pouze jeden pracovní poměr.

· Osobní číslo - povinný údaj. Identifikační číslo pracovního poměru.

· Datum nástupu - povinný údaj. Zadejte jej ve formátu D.M.RRRR. Od tohoto data je možné zaměstnance aktivně používat při zpracování dat o docházce.

· Datum ukončení - pokud zaměstnanec ukončí pracovní poměr, zadejte jej ve formátu D.M.RRRR. Po generování terminálu nebude umožněno zaměstnanci používat docházkové a přístupové terminály. Údaj můžete zadat i dopředu pokud víte, kdy pracovní poměr skončí. V tom případě je nutno v menu Systém/Nastavení aplikace/Pracovní poměry - neoznačit volbu Ukončovat kalendář dle pracovního poměru. Jinak by zaměstnanec měl odepřen přístup a nebylo by možné mu zpracovat docházku.

· Pořadové číslo PP - vepište pořadové číslo pracovního poměru.

· Typ osoby - zde vyberte z lišty, zda jde o vlastního zaměstnance nebo o zaměstnance jiné firmy.

· Typ PP - z nabídky vyberte typ pracovního poměru. Nový typ pracovního poměru můžete vytvořit v menu Seznamy -> Typy pracovních poměrů.

· Zpracovat docházku - pokud je tato volba zaškrtnutá, pak se pro daný pracovní poměr bude zpracovávat docházka.

Novy | Nový - pokud zaměstnanec nastoupí na další pracovní poměr, pak tímto tlačítkem vyvoláte Průvodce přidáním nového zaměstnance.
Zrusit | Zrušit - tímto tlačítkem, pokud nemá zaměstnanec navazující záznamy, jednoduše smažete pracovní poměr.

Zaměstnanec může používat docházkový systém, pouze pokud je v aktivním pracovním poměru. Pokud má pracovník více aktuálně platných pracovních poměrů, označte ten, se kterým chcete pracovat. Ostatní části (záložky) formuláře zaměstnance se vztahují vždy k vybranému pracovnímu poměru.

Při ukončení pracovního poměru zaměstnance se neprovádí "smazání zaměstnance". Je potřeba pouze ukončit pracovní poměr a případně provést vrácení identifikačního média.

TIP: Dbejte na správné zadání datumů počátku a konce pracovního poměru. Pokud není zaměstnanec v pracovním poměru, není možné mu zpracovávat docházku za toto období.

Nezapomeňte nastavit další údaje o zaměstnanci: přiřazení ID media, zařazení do skupin, přiřazení kalendáře.


Formulář zaměstnance - Ostatní údaje

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance >

Formulář zaměstnance - Ostatní údaje

 Return to chapter overview

Formulář pro případné zadání dalších důležitých dat, která se v programu nevyskytují (např. váha, výška zaměstnanců apod.). Pojmenování jednotlivých kolonek provádějte v menu "Systém -> Nastavení aplikace -> Společné nastavení -> Uživatelská pole -> Uživatelská pole osob, prac. poměrů".


Formulář ostatních údajů - Údaje osoby

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance > Formulář zaměstnance - Ostatní údaje >

Formulář ostatních údajů - Údaje osoby

 Return to chapter overview

V této části můžete zaznamenat údaje týkající se vybrané osoby, například výška, číslo řidičského oprávnění, krevní skupina atd. Nastavení uživatelských polí provedete v menu Systém -> Nastavení aplikace -> Společné nastavení -> Uživatelská pole osob, prac. poměrů v sekci Titulky uživatelských polí osob. V programu Docházka a Přístupy jsou přednastavenými údaji E-mail a telefon.

Ostatni udaje_udaje osoby


Formulář ostatních údajů - Údaje pracovního poměru

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance > Formulář zaměstnance - Ostatní údaje >

Formulář ostatních údajů - Údaje pracovního poměru (není přiřazeno číslo pro help)

 Return to chapter overview

V této části můžete zaznamenat údaje týkající se pracovního poměru osoby, například telefon, pracovní pozice zaměstnance, speciální školení apod. Nastavení uživatelských polí provedete v menu Systém -> Nastavení aplikace -> Společné nastavení -> Uživatelská pole osob, prac. poměrů v sekci Titulky uživatelských polí pracovního poměru.

Ostatni udaje_udaje pracovniho pomeru


Formulář zaměstnance - ID média

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance >

Formulář zaměstnance - ID média

 Return to chapter overview

Přiřazením identifikačního média nastavíte zaměstnanci číslo karty, čipu nebo jiného média k používání. Přiřazené médium je zasláno do přístupových terminálů a zaměstnanec může začít používat systém se svým identifikačním médiem. Přiřazení médií zaměstnancům je řízeno datem přidělení a datem vrácení.

Každý zaměstnanec má zpravidla přiřazeno jedno ID médium. Pokud využíváte více kusů, nebo více druhů ID médií pro jednoho zaměstnance, pak si tuto skutečnost musíte nastavit v aplikaci. Zaměstnanci, kterému jste přiřadili více ID médií, musíte ve formuláři označit, které médium bude programem bráno jako primární. Tento příznak se nastaví jednoduchým kliknutím u konkrétního média.

Seznam volných ID médií je tvořen z nepřiřazených nebo vrácených karet k dnešnímu dni.

Přidělení ID média - v levé části formuláře jsou zobrazena Volná ID média = všechna nepřiřazená ID média. V tomto seznamu označte vybrané médium a stiskem šipky Sipka seda vpravo mezi seznamy proveďte přiřazení zaměstnanci. Vybrané médium se přesune do seznamu vpravo. Program automaticky přiřadí jako den přidělení datum nástupu zaměstnance.

Vrácení ID média - pokud médium jeden zaměstnanec vrátí (např. ukončí pracovní poměr), zadáte u něj datum vrácení tohoto média na pravé straně formuláře ve sloupci Vrácena. Od následujícího dne můžete toto médium přiřadit jinému zaměstnanci.

Ztráta, poškození ID média - u původního média zadáte datum vrácení a přidělíte zaměstnanci médium nové. Systém automaticky vloží aktuální datum. Pokud chcete ID zprovoznit v jiný den, přepište datum Přidělení. Jestliže chcete mít jistotu, že ztracené (poškozené) médium omylem někomu nepřiřadíte, proveďte vyřazení tohoto média ze systému.

POZOR: Při vrácení média nepoužívejte šipky pro přesun z pravé strany na levou. Zadejte datum vrácení a nechejte tento záznam vpravo. Pokud byste vrátili médium vlevo a zaměstnanec by toto médium v zadaném období používal, bude problematické dohledat historii přiřazení tohoto média.

Kliknutím na řádek přiděleného ID média se rozbalí formulář Přiřazené ID médium, ve kterém můžete definovat ID médium jako primární (jak je uvedeno výše).

· Datum přidělení - datum přiřazení ID média.

· Primární - zda je či není ID primární.

· Datum vrácení - datum vrácení ID média (pokud ho víte).

· PIN - pin ID média.

· Poznámku - poznámka k ID médiu (ztráta, poškození,...).

Pokud kliknete na řádek volného ID média, pak se rozbalí formulář Identifikačního média, který obsahuje základní informace o médiu a historii přiřazení jednotlivým zaměstnancům. Stejný formulář a bližší informace najdete v menu Terminály/Identifikační média.


Formulář zaměstnance - Otisky

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance >

Formulář zaměstnance - Otisky

 Return to chapter overview

Tato záložka slouží pro práci s otisky prstů a přidávání načtených otisků prstů z terminálu konkrétním zaměstnancům.

POZNÁMKA: Tuto volbu lze použít jen pro některé terminály podporující otisk prstů.

V první řadě je potřeba vybrat terminál, ze kterého se budou načítat nové otisky prstů, pomocí otevíracího seznamu vyberte jeden z nabízených terminálů, který podporuje otisky prstů.

Načtení otisku prstů: Vyberte si jeden z prstů a pomocí kontextového menu (pravé tlačítko myši), zvolte z nabídky Načíst.

§ Přiložením prstu ke čtecí hlavě - použijte v případě že máte terminál v blízkosti počítače, ze kterého načítání provádíte. Na terminálu se zobrazí pokyn k přiložení prstu k terminálu.

§ Vyčtením existující šablony uživatele - v tomto případě nejprve nahrajte do terminálu otisky prstů zaměstnance (postup načtení otisku do terminálu naleznete v manuálu pro Váš terminál), poté zvolte volbu vyčtení existující šablony uživatele.

Do pole vepište číslo, pod kterým jste uložili otisk zaměstnance v terminálu.

Vymazání otisku prstů: Vyberte prst, který chcete smazat, a pomocí kontextového menu (pravé tlačítko myši), vyberte vymazat.

TIP: Pokud použijete záložku otisky, nemusíte již vytvářet a přidělovat ID medium, to se vybere a přiřadí automaticky. Jestliže potřebujete posunout platnost otisku prstu, přejděte do záložky ID média.


Formulář zaměstnance - Skupina osob

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance >

Formulář zaměstnance - Skupina osob

 Return to chapter overview

Skupina osob slouží k definování přístupových práv, k jednotlivým terminálům. Zaměstnanec musí být přiřazen minimálně k jedné skupině osob, aby si mohl označit docházku/otevřít dveře. V nastavení terminálů jsou pak nadefinovány skupiny, které mohou daný terminál používat.

V nejjednodušší variantě docházkového systému si vystačíte pouze s jednou skupinou, ve které budou všichni zaměstnanci, a tuto skupinu přiřadíte do všech používaných terminálů. U rozsáhlejších systémů docházkového a přístupového systému je však potřeba jednotlivé přístupy diferencovat. Proto je důležité správné rozdělení zaměstnanců do skupin pečlivě promyslet.

TIP: Zaměstnanec může být zařazen ve více skupinách, ale i terminál může mít přiřazeno více skupin. Jednotlivé skupiny se mohou samozřejmě navzájem prolínat.

V levé části formuláře je seznam všech dostupných skupin. Pravá část je vyhrazena pro seznam skupin, ve kterých je daný zaměstnanec zařazen. Označením položky a stiskem šipky mezi seznamy můžete hodnoty přesouvat z jedné strany na druhou oběma směry. Po zařazení do skupiny zadejte datum Platnost od, kdy je členem skupiny a v případě ukončení členství ve skupině, zadejte datum Platnost do, kdy byl členem.

Přiřazení do skupin Vám ulehčí další práci se systémem při filtrování seznamu zaměstnanců. Podmínkou pro přiřazení do skupiny je naplnění seznamu skupin.

POZOR: Datum přiřazení do skupin je velmi důležité. Mimo období přiřazení není zaměstnanec odeslán do terminálů.


Formulář zaměstnance - Kalendář

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance >

Formulář zaměstnance - Kalendář

 Return to chapter overview

Přiřazením kalendáře je zaměstnanci nastavena norma (fond) pracovní doby. Součástí Kalendáře jsou i použité nastavené směny, jaké bude použito zaokrouhlení a další podmínky pro ovlivnění způsobu zpracování docházkových dat. Nastavení kalendáře je zásadní pro zpracování dat zaměstnance.

V levé části formuláře je seznam všech dostupných kalendářů. Vpravo je seznam přiřazených kalendářů. Označením položky a stiskem šipky mezi seznamy můžete hodnotu přesunout z leva doprava. Po přiřazení kalendáře zadejte datum, od kterého bude pro daného zaměstnance kalendář platný. Při prvním přiřazení kalendáře se automaticky vloží datum nástupu zaměstnance, proto je nutné tomuto údaji věnovat pozornost.

V případě ukončení platnosti kalendáře (například při přechodu zaměstnance na vícesměnný režim s jiným kalendářem) zadejte datum, kdy přestane tento kalendář pro zaměstnance platit.

POZOR: Aktuálně může být přiřazen vždy pouze jeden platný kalendář. Přiřazení kalendáře můžete měnit i v průběhu měsíce kde je nutné dodržet časovou návaznost mezi jednotlivými kalendáři.

Podmínkou pro přiřazení kalendáře je naplnění seznamu kalendářů.

TIP: Pokud jste již zpracovali data za období a potom zpětně upravíte nebo změníte kalendář, neprojeví se tyto změny automaticky. Pro správné zobrazení hodnot musíte provést nejprve přepočet výsledků zpracované docházky a poté nové zpracování podle původní docházky za potřebné období.

Tlačítkem [image] Editace záznamu v levé části okna se dostanete do formuláře Kalendář. Tlačítkem [image] Editace záznamu v pravé části okna zobrazíte formulář Používaný kalendář:

· Kalendář - kód editovaného kalendáře.

· Popis - název editovaného kalendáře.

· Platnost od - datum od kdy je kalendář přiřazen ve formátu D.M.RRRR.

· Platnost do - datum do kdy je kalendář přiřazen ve formátu D.M.RRRR.


Formulář zaměstnance - Vozidla

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance >

Formulář zaměstnance - Vozidla

 Return to chapter overview

Ve formuláři provedete přiřazení vozidla řidiči. V menu Cestovní náhrady -> Seznam vozidel na záložce Osoby můžete rovněž provést přiřazení řidiče vozidlu.

Záložka je rozdělena na dva seznamy. V levém seznamu je Seznam vozidel, v pravém seznamu jsou Přiřazená vozidla. Vozidla mezi seznamy můžete přesouvat pomocí šipek.


Formulář zaměstnance - Rozdělení

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance >

Formulář zaměstnance - Rozdělení

 Return to chapter overview

Již dříve bylo zmíněno, že v ADS existují Typy rozdělení, která si uživatel definuje sám, podle potřeby. Pokud zaměstnance přiřadíte do některého z vámi definovaných rozdělení, pak vám to umožní členit docházková data podle vámi požadovaných hledisek.

PŘÍKLAD: Založíte si typ rozdělení "pracoviště" v typech rozdělení. V seznamu rozdělení potom k tomuto typu nadefinujete jednotlivé hodnoty s názvy pracovišť. V této záložce nastavíte typ rozdělení pracoviště a přiřadíte (přesunem zleva doprava) od kdy do kdy pracoval zaměstnanec na tomto pracovišti. Podle zadaných rozdělení potom můžete nahlížet na výsledky docházky.

V levé části okna v šedé zóně se nachází rychlý filtr:

§ Všechny pracovní poměry osoby - filtr, který slouží k vytvoření přehledu za všechny nebo pouze za vybraný pracovní poměr zaměstnance.

V podkategoriích rozdělení jsou zobrazeny jednotlivé typy rozdělení (například: Pracoviště, Personální středisko apod.). Jednotlivé typy rozdělení můžete přidávat či ubírat, podle vašeho uvážení. Zvolený typ rozdělení přidáte (uberete) ve formuláři Typu rozdělení. Ve formuláři stačí zaškrtnout (nezaškrtnout) pole Aktivní.

Pro přiřazení zaměstnance k rozdělení je nutné nastavit datum počátku platnosti. Existují dvě možnosti:

1. Ikona Novy zaznam1 Nový záznam vyvolá formulář Rozdělení osoby:

Sekce pro vložení potřebných údajů:

· Typ rozdělení - z nabízeného seznamu vyberte požadovaný typ. Číselník můžete doplňovat v menu Seznamy/Typy rozdělení.

· Rozdělení - specifikujte konkrétní rozdělení.

· Pokračovat v posledním záznamu - přiřazením nového záznamu se automaticky ukončí platnost všech dosud platných rozdělení v rámci daného typu rozdělení.

· První záznam podle datumu nástupu - pokud zaměstnanec nemá ještě přiřazen žádný typ rozdělení, pak datum platnosti od, bude shodné s datem nástupu.

· Platnost od - zadejte nebo zvolte datum z kalendáře.

· Platnost do - datum označující ukončení platnosti přiřazení.

Historie přiřazení rozdělení:

Tabulka umožňuje sledovat historii přiřazení zaměstnance na rozdělení v rámci vybraného typu rozdělení.

2. Výběr požadovaného typu rozdělení:

Otevře se formulář, ve kterém z levého sloupce nepřiřazených rozdělení, pomocí tlačítka Sipka seda vpravo , přesunete vybrané rozdělení. Následně se objeví okno pro Nastavení datumů pro přiřazení rozdělení:

· Platnost od - zadejte nebo zvolte datum v kalendáři.

· Platnost do - datum označující ukončení platnosti přiřazení.

· Pokračovat v posledním záznamu - přiřazením nového záznamu se automaticky ukončí platnost všech dosud platných rozdělení v rámci daného typu rozdělení.

· První záznam podle datumu nástupu - pokud zaměstnanec nemá ještě přiřazen žádný typ rozdělení, pak datum platnosti od, bude shodné s datem nástupu.

Pokud chcete změnit datum přiřazení, přepište v řádku datum přidělení. Pokud zaměstnanec přejde na jiné rozdělení, zadáte mu datum ukončení platnosti na daném rozdělení (nebude ho přesouvat zpět doleva), tím si zachováte historii členství.


Formulář zaměstnance - Intraweb, Práva

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance >

Formulář zaměstnance - Intraweb, Práva

 Return to chapter overview

V následujících formulářích můžete uživateli nastavit práva pro RON portál (záložka Intraweb), spojit zaměstnance s uživatelem aplikace (záložka Aplikace), spojit zaměstnance s uživatelem active directory (záložka Active directory) a nastavit uživateli práva pro RON Klienta (záložka Mobilní klient).


Intraweb

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance > Formulář zaměstnance - Intraweb, Práva >

Intraweb

 Return to chapter overview

Intraweb slouží k:

- prohlížení mzdových údajů, srážek ze mzdy (program Mzdy),

- prohlížení a editaci docházky, služebních cest, plánování kapacit, přehledu a plánování absence (program Docházka),

- monitorování přítomnosti osob, vkládání do historie průchodů (program Docházka, Přístupy),

- prohlížení dokumentů, školení, příjímání a odesílání vzkazů, evidenci úkolů a hodnocení (program Personalistika),

- objednávání stravy, je zde přehled o odběrech stravy, přehled o pohybu na účtu (program Jídelna).

Intraweb spustíte pomocí internetového prohlížeče.

Záložka je přístupná, pokud máte zakoupen modul Intraweb. Ve formuláři přiřazujete zaměstnanci jednotlivá práva pro přístup k datům na intrawebu. V první řadě je to přihlašovací jméno a heslo, kterým se bude uživatel do systému přihlašovat. Dále to jsou jednotlivá práva přístupu.

Přihlašovací jméno, heslo a skupinu uživatelů lze přiřadit hromadně všem zaměstnancům v nastavení intrawebu a dále jen vedoucím pracovníkům nastavit rozšířená práva pro aplikaci.

· Přihlašovací jméno - jméno, pod kterým se uživatel přihlašuje do intrawebu.

Karta zam._Intraweb Tlac. Zmena hesla

Změna hesla - objeví se okno, ve kterém můžete změnit přístupové heslo zaměstnance.

· Vynutit změnu hesla při přihlášení - pokud chcete, aby si zaměstnanec změnil heslo na intrawebu, zaškrtněte pole. Po prvním přihlášení zaměstnance do intrawebu se zobrazí informace o tom, že platnost hesla vypršela a je nutné si zadat heslo nové. Jakmile bude heslo zaměstnancem změněné, pole "Vynutit změnu hesla při přihlášení" již zaškrtnuté nebude.

· Nesynchronizovat/neimportovat přihlašovací jméno - nastavení se zohledňuje při standartním importu zaměstnanců a při hromadném nastavení přístupových jmen uživatelů v menu Systém -> Nastavení -> Nastavení intrawebu -> Jména a hesla. Osobám s tímto nastavením se nebude aktualizovat přihlašovací jméno.

· Poslední změna hesla - poslední změna hesla provedená zaměstnancem v intrawebu ve formátu DD.MM.RRRR HH:MM:SS.

· Skupina uživatelů - vyberte zaměstnanci jeho skupinu uživatelů, podle které se mu v kartě nastaví práva pro intraweb. Skupiny uživatelů nastavíte v menu Systém/Nastavení/Nastavení Intrawebu/Skupiny uživatelů. Noví zaměstnanci budou mít po vybrání skupiny v kartě zaměstnance automaticky nastaveno Podle skupiny uživatelů.

Nejjednodušší je nastavení práv podle Skupiny uživatelů. Pokud potřebujete některé právo na intraweb změnit oproti Skupině uživatelů, tak vybranému zaměstnanci ve střední části označte vybraný řádek s právem a ve spodní části "Nastavení práva" vyberte požadovanou hodnotu ze seznamu. Po nastavení jednotlivých práv ukládejte údaje tlačítkem [image] (v pravé dolní části formuláře).

· Podle skupiny uživatelů - pokud vyberete skupinu uživatelů, potom bude vybrané právo nastaveno podle přiřazené skupiny uživatelů. Skupiny uživatelů nastavíte v menu Systém/Nastavení/Nastavení Intrawebu/Skupiny uživatelů. Noví zaměstnanci budou mít po vybrání skupiny v kartě zaměstnance automaticky nastaveno Podle skupiny uživatelů.

· Pouze vlastní - uživatelé s tímto povolením mají zobrazeny pouze vlastní údaje např. osobní údaje.

· Vybrané osoby a skupiny - uživatelům s tímto povolením musíte v dolní části formuláře vybrat osobu nebo skupinu. Kliknutím na podtržený popisek Vybrané osoby se zobrazí formulář Výběr osob pro práva v intrawebu, ze kterého vyberete požadovanou osobu. Novou osobu můžete vytvořit v menu Seznamy/Zaměstnanci. Kliknutím na podtržený popisek Vybrané skupiny zobrazíte formulář Výběr skupin pro práva v intrawebu, ze kterého vyberete požadovanou skupinu osob. Novou skupinu můžete vytvořit v menu Systém/Správa databáze/Skupiny osob pro zabezpečení v aplikaci. Osoba po nastavení práv uvidí údaje (například osobní údaje) vybrané osoby, vybrané skupiny (například Dělníků) v intrawebu.

· Vše - uživatelé s tímto povolením můžou v intrawebu prohlížet např. Osobní údaje všech zaměstnanců.

· Zakázat - uživatelé s tímto povolením nemají právo prohlížet např. osobní údaje.

Pro volby Vlastní rozdělení, Vlastní rozdělení kromě sebe, Vlastní a podřízená rozdělení, Vlastní a podřízená rozdělení kromě sebe a Podřízená rozdělení je nutné mít nastaveno na záložce Typy práv uživatelů typ rozdělení u zvoleného práva. Pokud u zvoleného práva není nastaven Typ rozdělení, potom se při přiřazení některé z uvedených voleb zobrazí hláška: "Pozor! Pro tento typ práva není nastaven typ rozdělení! (záložka Typy práv uživatelů)". Zda je Typ rozdělení u vybraného práva nastaven můžete ověřit ve sloupci Typ rozdělení. Pokud ve sloupci není žádná hodnota, není typ rozdělení nastaven.

PŘÍKLAD: Na záložce Skupiny uživatelů nastavíte pro typ práva SCHVÁLENÍ ABSENCE hodnotu VLASTNÍ A PODŘÍZENÁ ROZDĚLENÍ KROMĚ SEBE. Na záložce Typy práv uživatelů pro typ práva SCHVÁLENÍ ABSENCE je nutné mít vybrán Typ rozdělení.

Pokud jste vybrali v horní části formuláře ze seznamu položku s typem práva Odblokování nebo Zablokování karty, potom se ve spodní části zobrazí popisek: Uživatel musí při odblokování/blokování karty zadat své heslo - při zaškrtnutí políčka musí uživatel při blokování nebo odblokování karty zadat své heslo.

Pokud jste v horní části formuláře vybrali ze seznamu položku s typem práva Prohlížení úkolů a nastavení splnění, potom se ve spodní části zobrazí popisek: Může ručně upravit datum splnění - při zaškrtnutí políčka může uživatel při splnění úkolu ručně editovat předvyplněné datum.

Práva a jejich hodnoty lze kombinovat.

POZOR: Tato aplikace je dostupná pouze pokud máte zakoupen modul Intraweb.


Aplikace

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance > Formulář zaměstnance - Intraweb, Práva >

Aplikace

 Return to chapter overview

Ve formuláři je možné spojit zaměstnance s uživatelem aplikace a nastavovat mu práva k aplikaci.

· Název uživatele aplikace - z nabídky vyberte uživatele aplikace. Pokud chcete vytvořit nového uživatele, potom nejdříve zadejte "Název uživatele aplikace". Následně stiskněte tlačítko [image]. Po jeho stisku se zobrazí dotaz, zda si opravdu přejete vytvořit nového uživatele aplikace "SPRÁVCE" ("název uživatele aplikace"). Jestliže ano, dotaz potvrďte. Po potvrzení dotazu se dostanete do Editoru uživatelů v menu Systém -> Správa databáze -> Nastavení zabezpečení, ve kterém uživateli provedete požadovaná nastavení (heslo, práva apod.). Pokud je již uživatel aplikace vybrán, tlačítko [image] se změní na [image] . Po jeho stisku se dostanete do Editoru uživatelů v menu Systém -> Správa databáze -> Nastavení zabezpečení, ve kterém můžete uživateli upravit nastavení.


Active directory

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance > Formulář zaměstnance - Intraweb, Práva >

Active directory

 Return to chapter overview

V tomto formuláři spojíte zaměstnance s uživatelem active directory a nastavíte mu přihlašovací jméno a členství ve skupinách active directory.

· Přihlašovací jméno - zadejte přihlašovací jméno zaměstnance.

· Aktivní - pokud je uživatel aktivní, zaškrtněte políčko.

Synchronizovat - tlačítkem provedete synchronizaci uživatele s active directory. Pro provedení synchronizace je nutné mít funkční server a platný název cesty adresáře. Nastavení spojení k active directory provedete v menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Active directory.

Formulář je rozdělen do dvou seznamů. V levé části tabulky je zobrazen seznam všech dostupných skupin. V pravé části je seznam přiřazených skupin, do kterých je zaměstnanec přiřazen. Pro přesun mezi seznamy použijte šipky umístěné mezi těmito seznamy. Seznam skupin v active directory nadefinujete v menu Systém -> Správa databáze -> Skupiny active directory.


Mobilní klient

Navigation: Seznamy > Zaměstnanci > Formulář zaměstnance > Formulář zaměstnance - Intraweb, Práva >

Mobilní klient

 Return to chapter overview

Mobilní klient slouží k:

- zadávání, prohlížení a editaci docházky, přehledu a plánování absence,

- monitorování přítomnosti osob,

Mobilního klienta spustíte pomocí nainstalované ikony RON Klient na vašem zařízení.

Záložka je přístupná, pokud máte zakoupen modul Mobilní klient. Ve formuláři přiřazujete zaměstnanci jednotlivá práva pro přístup k datům v mobilním klientovi.

Přihlašovací údaje Osobní číslo a Heslo se zadávají při registraci zařízení např. telefonu. Dále se při registraci zařízení zadává Komunikační server a Port.

· Skupina uživatelů mobilního klienta - vyberte zaměstnanci jeho skupinu uživatelů, podle které se mu v kartě nastaví práva pro mobilního klienta. Skupiny uživatelů nastavíte v menu Systém -> Nastavení -> Nastavení mobilního klienta -> Skupiny uživatelů. Noví zaměstnanci budou mít po vybrání skupiny v kartě zaměstnance automaticky nastaveno Podle skupiny.

Karta zam._Mobilni klient Tlac. Zmena hesla pro registraci

Změna hesla - objeví se okno, ve kterém můžete změnit přístupové heslo zaměstnance.

· Poslední změna hesla - poslední změna hesla provedená zaměstnancem ve formátu DD.MM.RRRR HH:MM:SS.

Nejjednodušší je nastavení práv podle Skupiny uživatelů. Pokud potřebujete některé právo pro mobilního klienta změnit oproti Skupině uživatelů, tak vybranému zaměstnanci ve střední části označte vybraný řádek s právem a ve spodní části vyberte požadovanou hodnotu ze seznamu.

· Podle skupiny - pokud vyberete skupinu uživatelů, potom bude vybrané právo nastaveno podle přiřazené skupiny uživatelů. Skupiny uživatelů nastavíte v menu Systém -> Nastavení -> Nastavení mobilního klienta -> Skupiny uživatelů. Noví zaměstnanci budou mít po vybrání skupiny v kartě zaměstnance automaticky nastaveno Podle skupiny.

· Povolit - uživatelé s povolením mohou např. zobrazovat stav přítomnosti pracovníků na pracovišti (monitorovat).

· Zakázat - uživatelé s tímto povolením nemají právo např. vkládat původní docházku.

Pro volby Vlastní rozdělení, Vlastní a podřízená rozdělení, je nutné mít nastaveno na záložce Typy práv uživatelů typ rozdělení u zvoleného práva. Pokud u zvoleného práva není nastaven typ rozdělení, potom se při přiřazení některé z uvedených voleb zobrazí hláška: "Pozor! Pro tento typ práva není nastaven typ rozdělení! (záložka Typy práv uživatelů)".

PŘÍKLAD: Na záložce Skupiny uživatelů nastavíte pro typ práva MONITOROVÁNÍ hodnotu VLASTNÍ A PODŘÍZENÁ ROZDĚLENÍ. Na záložce Typy práv uživatelů pro typ práva MONITOROVÁNÍ je nutné mít vybrán Typ rozdělení.

Pokud jste vybrali v horní části formuláře ze seznamu položku s typem práva Absence, potom se ve spodní části zobrazí popisek: Vkládat nové absence - pokud pole zaškrtnete, potom může vybraná skupina uživatelů vkládat nové absence; Rušit neschválené absence/žádat o zrušení - pokud pole zaškrtnete, potom může vybraná skupina uživatelů rušit neschválené absence nebo žádat o zrušení již schválených absencí.

Pokud jste v horní části formuláře vybrali ze seznamu položku s typem práva Vkládat původní docházku, potom se ve spodní části zobrazí popisek: Měnit datum a čas - při zaškrtnutí políčka může vybraná skupina uživatelů měnit datum a čas; Vkládat bez zeměpisné polohy - pokud pole zaškrtnete, potom se docházka bude vkládat bez informace kde zaměstnanec vložil záznam docházky z mobilního klienta.

právo:

· Registrace mobilního klienta, Povolení přístupu z mobilního klienta - tyto práva nahrazují přiřazení zaměstnance k terminálu s driverem "Mobile", který je přiřazen ke komunikačnímu serveru.

· Kontakty - doplněn seznam kontaktů načtený ze seznamu zaměstnanců. Z detailu kontaktu je možno vyvolat vytáčení telefonního čísla, psaní sms a napsání e-mailu. Přístup do kontaktů je možno povolit úplně, na vlastní rozdělení nebo na vlastní a podřízená rozdělení.

o Jen vyplněné kontakty

· Nastavit rozdělení při vkládání docházky - při vkládání docházky je možné u záznamu nastavit i rozdělení.

o Povinný údaj - pokud je tato volba aktivní, pak uživatel při vkládání docházky musí zadat rozdělení.

· Monitorování - v monitorování se zobrazuje stav přítomnosti pracovníků.

o Jen zaměstnanci

Práva a jejich hodnoty lze kombinovat.

POZOR: Tato aplikace je dostupná pouze pokud máte zakoupen modul Mobilní klient.


Zaměstnanci - pracovní poměry

Navigation: Seznamy >

Zaměstnanci - pracovní poměry

 Return to chapter overview

Tento seznam je srovnatelný se seznamem zaměstnanců. Je rozšířen o sloupce - osobní číslo, datum nástupu, datum výstupu, pořadové číslo pracovního poměru, ID médium, kalendář. V nastavení aplikace je možné si určit typ rozdělení, které se následně zobrazí v tomto seznamu a bude možno zaměstnance podle tohoto rozdělení členit - mzdové středisko, personální středisko atd. dle typů rozdělení funkčních v docházkovém systému.

Nad seznamem můžete použít tyto filtry:

Lupa

Vyhledat podle načtené karty - slouží pro rychlé vyhledávání osob. Po přiložení karty ke čtecí hlavě program vyhledá osobu, která má tuto kartu přiřazenou a otevře Formulář zaměstnance načtené osoby. Pokud tlačítko nefunguje, pak je nutné v menu Systém/Nastavení/Nastavení aplikace/Lokální nastavení/Načítání ID média vybrat název terminálu, který má tuto funkci využívat. Zkontrolujte, rovněž, zda máte nadefinovány parametry k tomuto terminálu v menu Terminály/Terminály.

§ Zobrazit hierarchii - odsouhlasíte-li tuto funkci, zobrazí se vedle seznamu vlevo personální větvení firmy s vybranými zaměstnanci, kteří patří do příslušné kategorie. Ukáže hierarchii všech nadřízených a podřízených středisek. Se středisky můžete libovolně manipulovat a přesouvat je podle svých potřeb. Zaměstnancům zůstane přiřazeno středisko, které jim je přiděleno v jejich kartě.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení). Tuto strukturu můžete upravovat:

ú pokud podřízené rozdělení má být nadřízeným, označte jej a pravým tlačítkem aktivujte nabídku, ze které vyberte Přesunout na kořen stromu;

ú pokud nadřízené rozdělení má být podřízeným, označte jej levým tlačítkem myši a přetáhněte do rozdělení, kterému má být podřízeno.

§ Typ rozdělení - výběrová položka poskytne seznam zaměstnanců podle jednotlivých středisek.

Nastaveni

Nastavení - stiskem tlačítka se zobrazí formulář pro nastavení zobrazených rozdělení. Vyberte, která rozdělení se budou zobrazovat v seznamu pracovních poměrů. Provedené nastavení se projeví až při příštím otevření seznamu pracovních poměrů.

§ Jen rozdělení - vyberte rozdělení, pro které chcete zobrazit seznam.

§ Jen typ osoby - nabízí se varianta Zaměstnanec a Zaměstnanec jiné firmy.

§ Všichni - zobrazí seznam všech zaměstnanců bez ohledu na to zda jsou nebo nejsou v pracovním poměru.

§ Aktivní - zobrazí zaměstnance, kteří jsou v aktivním pracovním poměru.

§ Neaktivní - zobrazí zaměstnance, kteří již nejsou v pracovním poměru.

Filtr standardně pracuje se seznamem zaměstnanců k aktuálnímu dni. Pokud chcete zobrazit stav k jinému dni, zrušte zaškrtnutí Akt. den a nastavte datum u funkce Ke dni, ke kterému chcete zobrazit seznam.

Vkládání nebo opravu jednotlivých údajů neprovádějte v tomto seznamu, ale otevřete si ikonou Editace zaznamu Editace záznamu formulář Zaměstnanec (dvojklik na řádku se jménem zaměstnance).


Externí osoby

Navigation: Seznamy >

Externí osoby

 Return to chapter overview

Seznam externích osob obsahuje všechny osoby navštěvující objekt a užívající terminály docházkového a přístupového systému, které nejsou zaměstnanci.

Vyhledat podle načtené karty - slouží pro rychlé vyhledávání osob. Po přiložení karty ke čtecí hlavě program vyhledá osobu, která má tuto kartu přiřazenou a otevře Formulář zaměstnance načtené osoby. Pokud tlačítko nefunguje, pak je nutné v menu Systém/Nastavení/Nastavení aplikace/Lokální nastavení/Načítání ID média vybrat název terminálu, který má tuto funkci využívat. Zkontrolujte, rovněž, zda máte nadefinovány parametry k tomuto terminálu v menu Terminály/Terminály.

§ Zobrazit hierarchii - odsouhlasíte-li tuto funkci, zobrazí se vedle seznamu vlevo personální větvení firmy s vybranými zaměstnanci, kteří patří do příslušné kategorie. Ukáže hierarchii všech nadřízených a podřízených středisek. Se středisky můžete libovolně manipulovat a přesouvat je podle svých potřeb. Zaměstnancům zůstane přiřazeno středisko, které jim je přiděleno v jejich kartě.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

§ Typ rozdělení - výběrová položka poskytne seznam zaměstnanců podle jednotlivých středisek.

§ Jen rozdělení - vyberte rozdělení, pro které chcete zobrazit seznam.

§ Jen typ osoby - nabízí se varianta Zaměstnanec a Zaměstnanec jiné firmy.

§ Všichni - zobrazí seznam všech zaměstnanců bez ohledu na to, zda jsou nebo nejsou v pracovním poměru.

§ Aktivní - zobrazí zaměstnance, kteří jsou v aktivním pracovním poměru.

§ Neaktivní - zobrazí zaměstnance, kteří již nejsou v pracovním poměru.

Filtr standardně pracuje se seznamem zaměstnanců k aktuálnímu dni. Pokud chcete zobrazit stav k jinému dni, zrušte zaškrtnutí Akt. den a nastavte datum u funkce Ke dni, ke kterému chcete zobrazit seznam.

Pro vytvoření nového záznamu v seznamu, klikněte v panelu nástrojů na tlačítko [image] Nový záznam. Tím se zobrazí prázdný formulář Průvodce přidáním nové externí osoby, kde vyplníte požadované údaje o zaměstnanci. Tlačítkem [image] Editace záznamu stávajícího řádku se dostanete do Karty externí osoby.


Průvodce přidáním nové externí osoby

Navigation: Seznamy > Externí osoby >

Průvodce přidáním nové externí osoby

 Return to chapter overview

Pokud potřebuje do tohoto seznamu přidat zcela novou externí osobu, pak otevřete Průvodce přidáním nové externí osoby kliknutím na ikonu [image] Nový záznam v seznamu externích osob (Seznamy/Externí osoby).

· ID - povinný údaj. Vyplňte identifikační číslo externí osoby.

· Titul - vyplňte titul před jménem.

· Jméno - vepište jméno externí osoby.

· Příjmení - povinný údaj. Vyplňte příjmení.

· Titul za - vyplňte titul za jménem.

· Pořadové číslo - povinný údaj. Zadejte pořadové číslo, může být stejné jako identifikační číslo.

· Datum prvního zápisu - povinný údaj. Zadejte jej ve formátu D.M.RRRR. Od tohoto data lze s externí osobou v systému pracovat jako s aktivním.

· Identifikační médium - z nabídky vyberte identifikační médium.

Načtení ID média (Ctrl+I) - slouží pro rychlé přiřazení karty nové osobě. Po přiložení karty ke čtecí hlavě program přiřadí načtenou kartu osobě. Pokud karta není v seznamu ID médií, zobrazí se formulář, ve kterém zadáte nové Identifikační médium. Pokud tlačítko nefunguje, pak je nutné v menu Systém/Nastavení/Nastavení aplikace/Lokální nastavení/Načítání ID média vybrat název terminálu, který má tuto funkci využívat. Zkontrolujte, rovněž, zda máte nadefinovány parametry k tomuto terminálu v menu Terminály/Terminály.

· PIN - pokud má identifikační médium PIN, můžete ho zde zapsat.

· Skupina zaměstnanců - povinný údaj. Vyberte skupinu externích osob. Novou skupinu externích osob vytvoříte v menu Seznamy/Skupiny osob.

· Poznámka - zde si můžete vepsat libovolné, pro vás důležité, informace.

· Foto - dvojklikem do prostoru určeného pro fotografii se dostanete do vlastních adresářů, z nichž můžete fotografii načíst do formuláře.

Pokud již máte vše vyplněno, stiskněte tlačítko [image].

Položky s podtrženým názvem je možné v seznamu upravovat. Stačí kliknout na podtržený název pole - otevře se seznam pro Výběr ..., ve kterém můžete editovat stávající údaje tlačítkem [image] Editace záznamu nebo vkládat nové tlačítkem [image] Nový záznam.


Formulář externí osoby

Navigation: Seznamy > Externí osoby >

Formulář externí osoby

 Return to chapter overview

Formulář externí osoby je rozdělen na základní části (záložky), mezi kterými se můžete přepínat volbou v seznamu na levé části formuláře. Správné naplnění údajů o externí osobě je předpokladem správné funkčnosti docházkového systému. Pokud nebudete mít zadány potřebné údaje u externí osoby, nebude docházkový systém s takto zadaným zaměstnancem pracovat respektive je potřeba vyplnit všechny zvýrazněné údaje, aby byla zadávaná externí osoba do systému vložena.

Seznam záložek:

Hlavní údaje | Hlavní identifikační údaje externí osoby a základní údaje o registraci.
Ostatní údaje | V záložce je možno sledovat i jiné údaje, které standardně nejsou v přístupovém systému přednastaveny. Volbu uživatelských polí nastavíte v menu Systém/Nastavení/Nastavení aplikace/Společné nastavení/Uživatelská pole osob.
ID média | Přiřazení identifikačního média externí osoby, ze seznamu ID médií. Nezapomeňte, že musíte mít naplněný seznam ID médií. Bez ID média externí osoba není schopna používat terminály.
Skupina osob | Zařazení externí osoby do zvolených skupin. Skupinu potřebujete pro určení rozdělení externích osob do jednotlivých terminálů. Externí osoba může být členem několika skupin, ale musí být alespoň v jedné skupině. Nezapomeňte si naplnit seznam skupin.
Rozdělení | Kromě rozdělení externích osob do skupin, je můžete členit podle dalších kritérií. Seznam těchto kritérií můžete nastavit v seznamu Typů rozdělení. Můžete použít například seznam pracovišť, středisek a personálních středisek, výplatních míst atd. Nastavení rozdělení vám umožní, v případě vaší potřeby, nahlížet na zpracovaná data z pohledu dalších rozdělení (rozlišení) docházky.

Aby externí osoba mohla používat docházkový systém, musí mít vyplněnou platnou registraci a přiřazené ID médium. Vhodné je také externí osobu rozdělit do skupin pro lepší filtrování záznamů.

TIP: U mnoha zadávaných údajů je datum platnosti. Program při přidělování dat automaticky nastavuje aktuální datum. Pokud potřebujete, aby data o pracovníkovi platila zpětně, musíte data přiřazení upravit podle potřeby.


Formulář externí osoby - Hlavní údaje

Navigation: Seznamy > Externí osoby > Formulář externí osoby >

Formulář externí osoby - Hlavní údaje

 Return to chapter overview

Ve formuláři jsou údaje rozděleny na dvě části. V horní části jsou základní identifikační údaje externí osoby, v dolní části je seznam registračních údajů.

Identifikační údaje:

· ID - povinný údaj. Vyplňte identifikační číslo externí osoby.

· Titul - titul před jménem.

· Jméno - povinný údaj. Vepište křestní jméno externí osoby.

· Příjmení - povinný údaj. Vyplňte příjmení.

· Titul za - titul za jménem.

· Datum narození - datum zadejte ve formátu D.M.RRRR.

· Poznámka - textová informace o externím pracovníkovi.

· Fotka - dvojklikem do prostoru určeného pro fotografii se dostanete do vlastních adresářů, z nichž můžete fotografii načíst do formuláře.

Registrační údaje:

· Osobní číslo - povinný údaj. Zadejte pořadové číslo, může být stejné jako identifikační číslo.

· Datum registrace - povinný údaj. Zadejte jej ve formátu D.M.RRRR. Od tohoto data lze s externí osobou v systému pracovat jako s aktivním.

· Datum ukončení registrace - zadejte jej ve formátu D.M.RRRR, pokud externí osoba u Vás skončí. Údaj můžete zadat i dopředu pokud víte, kdy skončí. Jestliže si datum ukončení registrace nastavíte, bude při prvním generování nastavení terminálů po tomto datu, externí osobě znemožněno používat docházkové a přístupové terminály.

Nový záznam - pokud se externí osoba znovu registruje, pak tímto tlačítkem vyvoláte Průvodce přidáním nové externí osoby.

Zrušit záznam - tímto tlačítkem, pokud nemá externí osoba navazující záznamy, jednoduše smažete registraci.

Externí osoba může používat docházkový systém, pouze pokud má aktivní registraci. Pokud má externí osoba více aktuálně platných registrací, označte ten, se kterým chcete pracovat.

Ostatní části (záložky) formuláře externí osoby se vztahují vždy k vybrané registraci.

TIP: Dbejte na správné zadání datumů počátku a konce registrace. Pokud není externí osoba zaregistrovaná, není možné jí zpracovávat docházku za toto období. Při ukončení registrace externí osoby se neprovádí "smazání externí osoby". Je potřeba pouze ukončit registraci a případně provést vrácení identifikačního média.

Nezapomeňte nastavit další údaje o externí osobě: přiřazení ID media, zařazení do skupin.


Formulář zaměstnance - Ostatní údaje

Navigation: Seznamy > Externí osoby > Formulář externí osoby >

Formulář zaměstnance - Ostatní údaje

 Return to chapter overview

Formulář pro případné zadání dalších důležitých dat, která se v programu nevyskytují (např. váha, výška zaměstnanců apod.). Pojmenování jednotlivých kolonek provádějte v menu Systém -> Nastavení aplikace -> Společné nastavení -> Uživatelská pole -> Uživatelská pole osob.


Formulář ostatních údajů - Údaje osoby

Navigation: Seznamy > Externí osoby > Formulář externí osoby > Formulář zaměstnance - Ostatní údaje >

Formulář ostatních údajů - Údaje osoby

 Return to chapter overview

V této části můžete zaznamenat údaje týkající se vybrané osoby, například výška, číslo řidičského oprávnění, krevní skupina atd. Nastavení uživatelských polí provedete v menu Systém -> Nastavení aplikace -> Společné nastavení -> Uživatelská pole osob v sekci Titulky uživatelských polí osob.

Formular externi osoby_Ostatni udaje_Udaje osoby


Formulář ostatních údajů - Údaje registrace

Navigation: Seznamy > Externí osoby > Formulář externí osoby > Formulář zaměstnance - Ostatní údaje >

Formulář ostatních údajů - Údaje pracovního poměru (není přiřazeno číslo pro help)

 Return to chapter overview

V této části můžete zaznamenat údaje týkající se pracovního poměru osoby, například telefon, pracovní pozice zaměstnance, speciální školení apod. Nastavení uživatelských polí provedete v menu Systém -> Nastavení aplikace -> Společné nastavení -> Uživatelská pole osob v sekci Titulky uživatelských polí pracovního poměru.

Formular externi osoby_Ostatni udaje_Udaje registrace


Formulář externí osoby - ID média

Navigation: Seznamy > Externí osoby > Formulář externí osoby >

Formulář externí osoby - ID média

 Return to chapter overview

Přiřazením identifikačního média nastavíte externí osobě číslo karty, čipu nebo jiného média k používání. Přiřazené médium je zasláno do docházkových a přístupových terminálů a externí osoba může začít používat systém se svým identifikačním médiem.

Přiřazení médií externím osobám je řízeno datem přidělení a datem vrácení. Pokud médium jedna externí osoba vrátí (např. ukončí registraci), zadáte u něj datum vrácení tohoto média. Od následujícího dne můžete toto médium přiřadit jiné externí osobě.

Podobným způsobem postupujete, pokud externí osoba médium ztratí. U původního média zadáte datum vrácení a přidělíte externí osobě médium nové. Jestliže chcete mít jistotu, že ztracené médium omylem někomu nepřiřadíte, proveďte vyřazení tohoto média ze systému.

V levé části formuláře je zobrazen seznam všech nepřiřazených ID médií, tzn. médií, která nemá žádná externí osoba aktuálně přiřazené. Označte v levé části vybrané médium a stiskem šipky mezi seznamy proveďte přiřazení externí osobě. Vybrané médium se přesune do seznamu vpravo.

Program automaticky přiřadí jako den přidělení datum registrace externí osoby, v případě přidělení média dalšího, například po ztrátě prvního, pak systém automaticky vloží aktuální datum. Pokud chcete médium zprovoznit v jiný den, přepište datum přidělení. Pokud externí osoba médium vrátí nebo ztratí, zapište na pravé straně datum vrácení. Externí osobě je možno přidělit více ID médií, důležitým bodem při přiřazení více ID médií je označení, které médium bude programem bráno jako primární. Tento příznak se nastaví jednoduchým kliknutím u konkrétního média.

POZOR: Při vrácení média nepoužívejte šipky pro přesun z pravé strany na levou, ale zadejte datum vrácení a nechejte tento záznam vpravo. Pokud byste vrátili médium vlevo a externí osoba by toto médium v zadaném období používala, bude problematické dohledat historii přiřazení tohoto média.

Kliknutím na řádek přiděleného ID média se rozbalí formulář Přiřazené ID médium, ve kterém můžete mimo jiné definovat ID médium jako primární (jak je uvedeno výše).

· Datum přidělení - datum přiřazení ID média.

· Primární - zda je či není ID primární.

· Datum vrácení - datum vrácení ID média (pokud ho víte).

· PIN - PIN ID média.

· Poznámku - poznámka k ID médiu.

Pokud kliknete na řádek volného ID média, pak se rozbalí formulář Identifikační médium, který obsahuje základní informace o médiu a historii přiřazení jednotlivým zaměstnancům. Stejný formulář a bližší informace najdete v liště Terminály/Identifikační média.


Formulář zaměstnance - Otisky

Navigation: Seznamy > Externí osoby > Formulář externí osoby >

Formulář zaměstnance - Otisky

 Return to chapter overview

Tato záložka slouží pro práci s otisky prstů a přidávání načtených otisků prstů z terminálu konkrétním externím osobám.

POZNÁMKA: Tuto volbu lze použít jen pro některé terminály podporující otisk prstů.

Formular externi osoby_Otisky

V první řadě je potřeba vybrat terminál, ze kterého se budou načítat nové otisky prstů, pomocí otevíracího seznamu vyberte jeden z nabízených terminálů, který podporuje otisky prstů.

Načtení otisku prstů: Vyberte si jeden z prstů a pomocí kontextového menu (pravé tlačítko myši), zvolte z nabídky Načíst.

Formular externi osoby_Otisky_Volba cteni typu otisku

§ Přiložením prstu ke čtecí hlavě - použijte v případě že máte terminál v blízkosti počítače, ze kterého načítání provádíte. Na terminálu se zobrazí pokyn k přiložení prstu k terminálu.

§ Vyčtením existující šablony uživatele - v tomto případě nejprve nahrajte do terminálu otisky prstů zaměstnance (postup načtení otisku do terminálu naleznete v manuálu pro Váš terminál), poté zvolte volbu vyčtení existující šablony uživatele.

Formular externi osoby_Otisky_Nacteni sablony z terminalu

Do pole vepište číslo, pod kterým jste uložili otisk zaměstnance v terminálu.

Vymazání otisku prstů: Vyberte prst, který chcete smazat, a pomocí kontextového menu (pravé tlačítko myši), vyberte vymazat.

TIP: Pokud použijete záložku otisky, nemusíte již vytvářet a přidělovat ID medium, to se vybere a přiřadí automaticky. Jestliže potřebujete posunout platnost otisku prstu, přejděte do záložky ID média.


Formulář externí osoby - Skupina osob

Navigation: Seznamy > Externí osoby > Formulář externí osoby >

Formulář externí osoby - Skupina osob

 Return to chapter overview

Členění externích osob do skupin je dalším z nutných nastavení programu pro jeho správnou činnost. Je nutné jednotlivé externí osoby rozdělit do skupin neboť informace o daných skupinách se používají pro odesílání dat do terminálů. V nastavení každého terminálu volíte, která skupina nebo i více skupin zaměstnanců mohou tento terminál používat. V nejjednodušší variantě docházkového systému vytvoříte pouze jednu skupinu a všechny externí osoby do této skupiny přiřadíte. Tuto skupinu přiřadíte do všech používaných terminálů.

Většinou však u rozsáhlejších řešení docházkových systémů musíte tyto přístupy diferencovat. Proto je důležité si dělení externích osob do skupin pečlivě rozmyslet.

TIP: Externí osoba může být zařazena ve více skupinách, ale i terminál může mít přiřazeno více skupin. Jednotlivé skupiny se mohou samozřejmě navzájem prolínat.

V levé části formuláře je seznam všech dostupných skupin. Pravá část je vyhrazena pro seznam skupin, ve kterých je daná externí osoba zařazena. Označením položky a stiskem šipky mezi seznamy můžete hodnoty přesouvat z jedné strany na druhou oběma směry. Po zařazení do skupiny zadejte datum OD, kdy je členem skupiny a v případě ukončení členství ve skupině zadejte datum DO.

Přiřazení do skupin vám ulehčí další práci se systémem při filtrování seznamu externích osob i práci v sestavách. Podmínkou pro přiřazení do skupiny je naplnění seznamu skupin.

POZOR: Datum přiřazení do skupin je velmi důležité. Mimo období přiřazení není externí osoba odeslána do terminálů.


Formulář externí osoby - Rozdělení

Navigation: Seznamy > Externí osoby > Formulář externí osoby >

Formulář externí osoby - Rozdělení

 Return to chapter overview

Přiřazení rozdělení vám umožní členit docházková data podle dalších Vámi definovaných hledisek. Například si založíte typ rozdělení "pracoviště" v typech rozdělení. V seznamu rozdělení potom k tomuto typu nadefinujete jednotlivé hodnoty s názvy pracovišť. V této záložce nastavíte typ rozdělení pracoviště a přiřadíte (přesunem zleva doprava) od kdy do kdy pracoval zaměstnanec na tomto pracovišti. Podle zadaných rozdělení potom můžete nahlížet na výsledky docházky.

V levé části okna v šedé zóně se nachází rychlý filtr:

§ Všechny pracovní poměry osoby - filtr, který slouží k vytvoření přehledu za všechny nebo pouze za vybraný pracovní poměr externí osoby.

V podkategoriích rozdělení jsou zobrazeny jednotlivé typy rozdělení (například: Pracoviště, Personální středisko apod.). Jednotlivé typy rozdělení můžete přidávat či ubírat, podle Vašeho uvážení. Zvolený typ rozdělení přidáte (uberete) ve formuláři Typu rozdělení. Ve formuláři stačí zaškrtnout (nezaškrtnout) pole Aktivní.

Pro přiřazení externí osoby k rozdělení je nutné nastavit datum počátku platnosti. Existují dvě možnosti:

1. Ikona [image] Nový záznam vyvolá formulář Rozdělení osoby:

Sekce pro vložení potřebných údajů:

· Typ rozdělení - z nabízeného seznamu vyberte požadovaný typ. Číselník můžete doplňovat v menu Seznamy/Typy rozdělení.

· Rozdělení - specifikujte konkrétní rozdělení.

· Pokračovat v posledním záznamu - přiřazením nového záznamu se automaticky ukončí platnost všech dosud platných rozdělení v rámci daného typu rozdělení.

· První záznam podle datumu nástupu - pokud externí osoba nemá ještě přiřazen žádný typ rozdělení, pak datum platnosti od, bude shodné s datem nástupu.

· Platnost od - zadejte nebo zvolte datum v kalendáři.

· Platnost do - datum označující ukončení platnosti přiřazení.

Historie přiřazení rozdělení:

Tabulka umožňuje sledovat historii přiřazení externí osoby na rozdělení v rámci vybraného typu rozdělení.

2. Výběr požadovaného typu rozdělení:

Otevře se formulář, ve kterém z levého sloupce nepřiřazených rozdělení, pomocí tlačítka C_Sipka seda vpravo , přesunete vybrané rozdělení. Následně se objeví okno pro Nastavení datumů pro přiřazení rozdělení:

· Platnost od - zadejte nebo zvolte datum v kalendáři.

· Platnost do - datum označující ukončení platnosti přiřazení.

· Pokračovat v posledním záznamu - přiřazením nového záznamu se automaticky ukončí platnost všech dosud platných rozdělení v rámci daného typu rozdělení.

· První záznam podle datumu nástupu - pokud externí osoba nemá ještě přiřazen žádný typ rozdělení, pak datum platnosti od, bude shodné s datem nástupu.

Pokud chcete změnit datum přiřazení, přepište v řádku datum přidělení. Pokud externí osoba přejde na jiné rozdělení, zadáte mu datum ukončení platnosti na daném rozdělení (nebude ho přesouvat zpět doleva), tím si zachováte historii členství.


Kalendáře

Navigation: Seznamy >

Kalendáře

 Return to chapter overview

Nastavení kalendářů je velmi důležitým bodem docházkového systému. Vždy musí být definován alespoň jeden kalendář, který budou zaměstnanci používat. Bez přiřazení kalendáře zaměstnanci nebude program schopen počítat normu odpracované doby.

Kalendářem určíte fond pracovní doby, nastavíte pracovní dny a dny volna, zaokrouhlení, způsob výpočtu příplatků, přesčasů a časových omezení a jiné.

Před vytvářením kalendářů si pečlivě rozmyslete, jaké kalendáře a kolik jich budete potřebovat. Pokud založíte velké množství kalendářů, bude pro vás časem nepřehledné orientovat se v jejich rozdílech. Také doporučujeme pro snadnou orientaci co nejpřehlednější kód a popis kalendáře.

Každý kalendář je sestaven z jednotlivých směn, které musíte předem definovat v seznamu směn. Přiřazením směn do kalendáře definujete normu pracovní doby pro tento kalendář.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale vždy si otevřete konkrétní formulář kalendáře (viz ovládání seznamu).

TIP: Pokud používáte podobné nastavení přesčasů a příplatků můžete si usnadnit nastavování kalendářů kopírováním příplatků a přesčasů mezi jednotlivými kalendáři. Při zobrazeném seznamu kalendářů v menu Aktuální okno je poslední položka "Kopírování vlastnosti kalendářů". Vyberte zdrojový a cílový kalendář a dále vyberete, zda chcete kopírovat příplatky, přesčasy, mezní hodnoty časových složek, nastavení vlastností operací, denní omezení časových složek pro výpočet nebo nastavení výpočtu výsledků vzorcem.

Formulář má tyto záložky:

Kalendář

Směny

Směny II

Harmonogram směn

Příplatky

Přesčasy

Omezení

Osoby

Operace

Časové složky

Ostatní

Doporučujeme nejdříve vytvořit Směny, které následně budete vkládat do Kalendáře.

Formulář kalendáře je rozdělen na dvě základní části. Vlevo je seznam jednotlivých záložek (částí) s nastavením parametrů kalendáře. V pravé části se zobrazuje v závislosti na zvolené záložce její obsah.


Formulář kalendáře - Kalendář

Navigation: Seznamy > Kalendáře >

Formulář kalendáře - Kalendář

 Return to chapter overview

Záložka obsahuje základní identifikační parametry kalendáře.

· Kód - označení kalendáře (text maximálně 10 znaků). Libovolné označení, kterým se pokuste vyjádřit použití kalendáře ve zkratce. Povinná položka.

· Aktivní - pokud je kalendář aktivně využíván (je tedy platný), zatrhněte pole.

· Popis - stručný textový popis kalendáře vystihující jeho použití (např. "Kalendář THP - 8 hodin"). Povinná položka.

· Poznámka - libovolná doplňující informace ke kalendáři.

· Denní úvazek - denní úvazek slouží pouze pro informativní účely ve výstupních sestavách.

· Týdenní úvazek - slouží pro definici poměru krácení mezd ve mzdovém programu. Používáte-li pouze program ADS, není tento údaj povinný.

· Týdenní úvazek základní - slouží pro definici poměru krácení mezd ve mzdovém programu. Používáte-li pouze program ADS, není tento údaj povinný.

· Počet pracovních dnů v týdnu - počet pracovních dnů v jednom týdnu.

· Náběhová doba pro určení směn - definuje čas před a po směně, ve kterém případný počátek docházky bude zahrnut do určené směny. Tato položka usnadňuje rozlišení, na kterou směnu zaměstnanec přišel. Pokud příchod zaměstnance neodpovídá směně, kterou má pro tento den definovanou v kalendáři, hledá systém mezi povolenými směnami tu, která vyhovuje časem počátku včetně náběhové doby skutečnému příchodu zaměstnance.

PŘÍKLAD: Pokud směna začíná v 6:00 hod a náběhová doba je 00:30 hod (30 minut) je každý příchod od 5:30 automaticky přiřazen k této směně. Bez náběhové doby by systém rozhodl, že zaměstnanec přišel ještě na noční směnu, která končí až v 6 hodin.

· Použít úpravu času operace - u jednotlivých operací terminálů je nastavena možnost úpravy času. Pokud chcete pro tento kalendář nastavení ignorovat, zrušte zaškrtnutí.

· Použít zaokrouhlení času operace - u jednotlivých operací terminálů je nastavena možnost zaokrouhlení času. Pokud chcete pro tento kalendář nastavení ignorovat, zrušte zaškrtnutí.

· Použít omezení délky času operace - u jednotlivých operací terminálů je nastavena možnost omezení délky operace. Pokud chcete pro tento kalendář nastavení ignorovat, zrušte zaškrtnutí.

Zrušení používání vlastností operací závisí na používání tohoto kalendáře. Například pokud nechcete u techniků s pružnou pracovní dobou používat zaokrouhlování, můžete ho vypnout. Jednotlivé kombinace závisí na zvyklostech ve vaší firmě.

Zaokrouhlování časů při výpočtu:

· Zaokrouhlování příchodu - každý počátek intervalu, který nemá předchozí navazující operaci (tzn., předchozí operace nebyla počátkem intervalu nebo interval byl ukončen před časem zaznamenání této operace), bude zaokrouhlen podle tohoto nastavení. Možné volby: Normálně / Vždy nahoru / Vždy dolů / Nezaokrouhlovat. Standardní situací je příchod do práce na začátek směny.

· Zaokrouhlovat příchod na - zadejte hodnotu ve formátu HH:MM (např. 00:15 - zaokrouhlení na 15 minut) pro zaokrouhlení směrem určeným předchozí položkou. Pokud je položka "Zaokrouhlování příchodu" nastavena na hodnotu "Nezaokrouhlovat" není tato položka přístupná.

PŘÍKLAD: Příchod v 6:03 při zaokrouhlení "Vždy nahoru na 00:15" upraví příchod na 6:15.

· Zaokrouhlování odchodu - každé ukončení intervalu (odchod, označená operace není počátek intervalu), na který nenavazuje jiný interval, bude zaokrouhlen podle tohoto nastavení. Možné volby: Normálně / Nahoru / Dolů / Nezaokrouhlovat. Tato situace se týká všech registrovaných operací, které nejsou počátkem intervalu (viz nastavení vlastností operací terminálů - položka "Počátek intervalu").

· Zaokrouhlovat odchod na - zadejte hodnotu ve formátu HH:MM (např. 00:15 - zaokrouhlení na 15 minut) pro zaokrouhlení směrem určeným předchozí položkou. Pokud je položka "Zaokrouhlování odchodu" nastavena na hodnotu "Nezaokrouhlovat" není tato položka přístupná.

PŘÍKLAD: Odchod ve 14:09 při zaokrouhlení "Dolů na 0:15" upraví odchod na 14:00.

· Posun zaokrouhlení příchodu - volba slouží pro potřebu posunu zaokrouhlování příchodů, například pokud je zaokrouhlení na 30 minut s 10 minutovým posunem dopředu. Tzn., zaokrouhlení příchodů bude probíhat mezi 6:10 až 6:40.

· Posun zaokrouhlení odchodu - volba slouží pro potřebu posunu zaokrouhlování odchodů, například pokud je zaokrouhlení na 30 minut s 10 minutovým posunem dopředu. Tzn., zaokrouhlení odchodů bude probíhat mezi 14:10 až 14:40.

PŘÍKLAD: Pokud bude zaokrouhlení na 30 minut nahoru při příchodu a na 30 minut dolů při odchodu a posun zaokrouhlení bude 10 minut. Pak příchod v 6:20 bude zaokrouhlen na 6:40 a odchod v 14:35 bude zaokrouhlen na 14:10.

Výpočet přesčasů:

· Způsob výpočtu přesčasů - nastavení způsobu výpočtu přesčasů má několik možností:

o Průběžně - volba zaokrouhlí a krátí přesčasy za každý den, bez ohledu na nastavení pořadí krácení v sekci Přesčasy.

o Součtově - volba krátí přesčasy teprve na konci výpočtu (za celé zpracovávané období) a podle nastavení pořadí krácení v sekci Přesčasy. Touto volbou můžete velmi výrazně změnit výsledné hodnoty přesčasů za období.

PŘÍKLAD: Zaměstnanec pracuje každý den o 20 minut déle - nad rámec své normy. Zaokrouhlování přesčasů je nastaveno na 30 minut (počítá se každá celá půlhodina). V případě průběžného výpočtu přesčasů se každodenní hodnota zaokrouhlí a pracovník má na svém kontě po 10 dnech nulový přesčas. Pokud však nastavíte způsob výpočtu součtově, budete mít po 10 dnech přesčas 200 minut, což ve výsledku po zaokrouhlení na půlhodiny znamená výsledný přesčas 3 hodiny.

· Minimální a maximální přesčas - zadejte hodnotu v hodinách. Stanovuje minimální a maximální limit pro přenos do následujícího měsíce. Pokud skutečný přesčas pracovníka přesáhne tyto hodnoty je přesčas snížen.

· Dopočítávat - položka obsahuje dvě volby: proplacený přesčas a převáděný přesčas. Vliv tohoto nastavení se projeví při editaci docházky zaměstnance. V editaci docházky jsou zobrazeny dvě hodnoty - převáděný přesčas a proplacený přesčas. Hodnota, kterou nastavíte pro dopočítávání, se bude automaticky měnit při změně hodnoty přesčasů. Druhou z hodnot můžete ručně zadat. Program provede odečtení zadaného čísla a zbytek přesčasů opět automaticky doplní do dopočítávané položky.

· Dopočítávat max. do - je to limit. Po jeho překročení se bude sice přesčas evidovat, ale nebude ve výsledcích započítáván.

· Nadlimit převádět do propl./přev. přesčasu - zapnutím této funkce můžete nadlimit přesčasů převádět buď do proplaceného, nebo převáděného přesčasu, podle toho jak je nastavena volba dopočítávání.

PŘÍKLAD:

* Ve firmě může zaměstnanec mít proplaceno max. 20 hodin, ale odpracoval 40 hodin.

Minimální přesčas bude -20, maximální přesčas bude +20.

Dopočítávat - zvolíte 20 do proplaceného přesčasu. V editaci docházky budete mít podtržený převáděný přesčas, který můžete ručně editovat a rozhodnout tak, zda přesčasy navíc převedete na další období.

Nadlimit převádět... - tímto určíte, že se vše nad stanovený limit bude překlápět do převáděného přesčasu.

* Ve firmě potřebujete přesčasy jen sledovat, ale nic nebudete proplácet, ani převádět.

Minimální a maximální přesčas bude v hodnotě 0. Stejně tak i Nadlimit. Žádné další položky tohoto nastavení nebudete označovat.

· Limit dopočítávaného přesčasu určuje schválený přesčas - pokud je tato volba aktivována, limit dopočítávaného přesčasu v daný měsíc určuje hodnota měsíčního výsledku výpočtu časové složky schválený přesčas (981). Tuto volbu je možné použít k individuálnímu schvalování přesčasů prostřednictvím ručního vkládání denních výsledků výpočtů s časovou složkou schválený přesčas a aktivovanou volbou "nepřepočítávat denní výsledky" v nastavení dané časové složky.

stát pro určování svátků:

· Stát - z nabídky vyberte stát pro určování svátků.

Po vyplnění této záložky pokračujte další záložkou - Směny.


Formulář kalendáře - Směny

Navigation: Seznamy > Kalendáře >

Formulář kalendáře - Směny

 Return to chapter overview

Předpokladem pro další práci s nastavením kalendáře v této záložce je vyplněný seznam směn. Doporučujeme vytvořit nejdříve směny a ty pak vkládat do kalendářů.

Ve formuláři můžete vybrat ze seznamu všech typů směn definovaných v systému ty směny, které připadají do úvahy pro použití v tomto kalendáři.

PŘÍKLAD: Pro administrativní pracovníky vyberete jako používanou směnu pouze ranní, případně pružnou ranní. Pro kalendář určený zaměstnancům ve výrobě (ve směnném provozu) vyberete směny ranní, odpolední i noční. Pokud máte vybrané používané směny, umožní program tyto směny vkládat do kalendáře v jednotlivých dnech a definovat tím fond pracovní doby.

Formulář SMĚNY se skládá ze dvou částí:

Vlevo je zobrazen seznam všech dostupných směn v systému. Pokud Vám některá vyhovuje, označíte ji myší a pomocí šipky mezi sloupci ji přenesete vpravo - používané směny. Směny převedené na pravou stranu se stávají směnami, které budou zaměstnanci používat v jednom kalendáři.

Stejný postup platí pro vrácení položek zpět do seznamu dostupných směn (např. kdy zaměstnanec přešel ze 3směnného provozu na pouhé ranní směny).

Vytvoření nové směny - stiskněte ikonu Novy zaznam1 Nový záznam ve spodní liště tohoto formuláře a definujete pravidla směny.

Kopie ze stávající směny - chcete-li využít pravidla již vytvořené směny, ale potřebujete ji pozměnit pouze název, pak musíte stávající směnu otevřít a zvolit ikonu Kopie aktualniho Nový záznam z kopie stávajícího.

Pokud se potřebujete podívat na detaily nastavené směny, pak si na pravé straně pozorně přečtěte Kód a Popis směny a na levé straně si tuto konkrétní směnu dvojklikem otevřete. Na pravé straně nelze směny otevírat.

POZOR: Než spustíte průvodce vytvářením kalendáře, musíte mít vybrány používané (povolené) směny. Pokud nebude žádná směna povolena, nebudete při sestavování průvodce úspěšní.

TIP: Mezi používané směny dávejte opravdu jen ty, které může zaměstnanec použít. Pokud dáte povolených směn mnoho a budou mít podobné časové intervaly, může být pro systém problematické určit správnou směnu.


Formulář kalendáře - Směny II

Navigation: Seznamy > Kalendáře >

Formulář kalendáře - Směny II

 Return to chapter overview

Nastavení směn pro dny

V tomto formuláři je zobrazeno nastavení směn v měsíci pro jednotlivé dny. Zde vidíte, který den je přiřazena jaká směna, kdy je volno a kdy svátek. Pro korektní nastavení směn je bezpodmínečně nutné, abyste měli správně vytvořeny a definovány směny v předchozí sekci.

Formulář SMĚNY II je opět rozdělen na několik částí:

V levém sloupci je seznam vytvořených období ve formátu ROK, MĚSÍC.

Po označení období (kliknutí myší), se na pravé straně sloupce objeví detaily zvoleného období: Rok - Měsíc - počet Kalendářních dnů, Pracovních dnů, Placených svátků a celkový počet Hodin.

Můžete použít filtr:

§ Automatický posun - automaticky posune kurzor na další den při přidání a smazání směny.

§ Barevné pozadí - zobrazí v kalendáři dny se směnou v odlišné barvě.

§ Zobrazit ikony - zobrazí, nebo skryje ikony v kalendáři.

§ Aktuální rok - zobrazí seznam období pro aktuální rok podle období v programu.

V každém dni (pravá část formuláře) jsou použity symboly typu dne a označení přiřazené směny ke dni (kód směny). Den označený zelenou "fajfkou" má nastavenu směnu a počítá se jako den pracovní. Den s červeným křížkem směnu nemá a je považován za den volna. Symboly jsou zobrazeny i s popisem nad touto grafikou.

PRACOVNÍ DOBA - k jednotlivým dnům máte možnost zadávat pracovní dobu od - do a rozsah normohodin min. - max. Pokud chcete funkci využívat je potřeba ji povolit v Nastavení aplikace/Společné nastavení - Kalendáře. Po zatržení pole Zadávat pracovní dobu v kalendáři je možné tuto funkci využívat.

kalendare18

Průvodce - toto tlačítko spustí průvodce nastavením směn v kalendáři, který vám pomůže nastavit směny pro jednotlivé dny v měsíci. Směny se následně budou generovat automaticky. Nemusíte se tedy starat o nastavení kalendářů pro další období. Pokud se kalendář nemění, nastavuje ho program podle tohoto průvodce zcela automaticky. Detailní popis práce s Průvodce následuje v další sekci tohoto manuálu.

Ruční (individuální) způsob přiřazení směny:

- označte den nebo více dnů pomocí přidržení klávesy Shift,

- vyberte směnu,

- stiskněte tlačítko kalendare20 Pracovní den v horní části formuláře nebo šipku zobrazenou vedle seznamu směn pro přesun doprava.

Označení dne za svátek:

- označte den

- stiskněte tlačítko s typem svátku ( kalendare22, kalendare23), pokud chcete svátek zrušit, klikněte na tlačítko kalendare21 Den volna.

POZOR: Pro nastavení směn používejte průvodce. Ruční změny používejte pouze pro nastavení výjimek v kalendáři, které nelze v průvodci nastavit. Pokud je nastavený průvodce, budou vždy při vytvoření nového období automaticky nadefinovány směny pro toto období dle podmínek nastavených v průvodci. Pokud již máte průvodce nastaveného a chcete změnit jeho parametry, klidně ho spusťte znovu a hodnoty nastavte. Při vytvoření nového období se již použijí pravidla tohoto nového průvodce.


Průvodce nastavením směn

Navigation: Seznamy > Kalendáře > Formulář kalendáře - Směny II >

Průvodce nastavením směn

 Return to chapter overview

Způsoby použití průvodce:

a) použití definice pro jeden měsíc s automatickým opakováním

- při tomto nastavení zadáte v průvodci období jednoho měsíce a stanovíte pravidla pro vkládání směn,

- potom při vytvoření nového období program automaticky použije pravidla definovaná v průvodci pro nové období,

- podmínkou pro použití průvodce v dalším období je nastavení tohoto opakování v Nastavení aplikace/Společné nastavení/Období.

b) použití definice pro zvolené období

- nastavíte v průvodci zvolené období (např. celý rok),

- průvodce při tomto použití vygeneruje v kalendáři všechny měsíce pro zvolené období a nadefinuje směny.

Práce s průvodcem:

Po stisku tlačítka kalendare18 vyplňujete postupně všechny obrazovky a postupujete dále stiskem příslušného tlačítka Dalsi.

Krok 1 - v prvním formuláři průvodce zadejte datumy OD a DO určující rozsah definovaného období. V prostřední části vyberte, zda budou pracovníci, kterým nastavíte tento kalendář pracovat ve svátky. V dolní části nastavte způsob neboli rytmus vkládání směn.

- Definice směn podle dnů v týdnu - počet různých týdnů - rytmus je dán délkou týdne. Nastavte počet týdnů, které se budou střídat (střídání týdnů s ranní, odpolední a noční směnou = změňte číslo na 3).

- Definice směn podle pořadí návaznosti - počet dnů cyklu - zde můžete definovat takzvaný kolotoč. Definujete rytmus vkládání směn bez vazby na den v týdnu. Pokud definujete sedmidenní návaznost rytmu, můžete samozřejmě dosáhnout stejného výsledku jako při definici podle dnů v týdnu.

Krok 2 - v tomto kroku se průvodce rozděluje na dva různé směry v závislosti na zvoleném rytmu vkládání směn.

2A) Při nastavení rytmu Definice směn podle dnů v týdnu:

Na obrazovce jsou zobrazeny dva seznamy. Levý obsahuje seznam všech směn. Pravý obsahuje seznam zvolených dnů v týdnu. Pro každý den v týdnu přiřaďte směnu z levého sloupce: Označte směnu v levém sloupci a zvolený den nebo dny v pravém sloupci. Stiskem šipky mezi seznamy Sipka seda vpravo provedete přiřazení. Pokud chcete přiřazení zrušit, zvolte den a stiskněte opačnou šipku Sipka seda vlevo.

2B) Při nastavení rytmu Definice směn podle pořadí návaznosti:

Na obrazovce jsou zobrazeny dva seznamy. Levý obsahuje seznam všech směn. Pravý obsahuje seznam použitých směn v pořadí, v jakém se mají vkládat. Při definici nového průvodce je pravý seznam prázdný. Označte směnu v levém sloupci a stiskněte šipku Sipka seda vpravo pro zařazení na pravou stranu. Pokud chcete směnu opakovat dvakrát za sebou, stiskněte šipku znovu. Jestliže chcete směnu z pořadí v pravém sloupci zrušit, označte ji a stiskněte opačnou šipku Sipka seda vlevo.

Tlačítkem kalendare25 Rotace posouváte nastavené směny o zadaný počet dnů vpřed (+) nebo zpět (-).

Po ukončení kroku 2 program průvodce dokončí a vygeneruje směny pro zadané období a seznam období, která byla v průvodci zadána. Výsledek průvodce uvidíte v záložce Směny II - nastavení směn pro dny.


Formulář kalendáře - Harmonogram směn

Navigation: Seznamy > Kalendáře >

Formulář kalendáře - Harmonogram směn

 Return to chapter overview

Ve formuláři přiřadíte kalendáři požadovaný harmonogram směny nebo ve Formuláři harmonogramu směny - Kalendáře k harmonogramu směny přiřadíte kalendář.

Záložka je rozdělena na dva seznamy. V levém seznamu jsou dostupné harmonogramy, v pravém seznamu jsou harmonogramy nastavené pro kalendář. Položky mezi seznamy můžete přesouvat.

Tlačítkem [image] Editace záznamu v pravé části okna se zobrazí formulář Harmonogram kalendáře. Zobrazený formulář je shodný s formulářem Harmonogram kalendáře v záložce Kalendáře (menu Seznamy -> Harmonogramy směn).


Příplatky - používané v kalendáři

Navigation: Seznamy > Kalendáře >

Formulář kalendáře - Příplatky

 Return to chapter overview

Kalendář je přiřazován vždy určité skupině zaměstnanců. Každá skupina zaměstnanců může mít nastaveny rozdílné podmínky pro výpočet příplatků. Docházkový systém sleduje pouze nárok na příplatek ve smyslu odpracovaných hodin, nikoliv finanční náhradu.

V záložce PŘÍPLATKY se zobrazí seznam přiřazených příplatků. Pro vkládání a opravy položek použijte standardní funkce pro ovládání seznamu.

Počet příplatků není systémem omezen. Je na vás, abyste si zvolili Příplatky, které budete opravdu využívat a v jejichž počtu se časem neztratíte.

Nové příplatky vytvoříte v menu Seznamy/Kalendáře příplatky.


Formulář kalendáře - Přesčasy

Navigation: Seznamy > Kalendáře >

Formulář kalendáře - Přesčasy

 Return to chapter overview

Výpočet přesčasů v kalendáři

Kalendář je přiřazován vždy určité skupině zaměstnanců. Každá skupina zaměstnanců může mít nastaveny rozdílné podmínky pro výpočet přesčasů.

V záložce PŘESČASY se zobrazí seznam přiřazených přesčasů. Pro vkládání a opravy položek použijte standardní funkce pro ovládání seznamu.

Způsob zadání přesčasů v kalendáři je v podstatě shodný s nastavením příplatků.

Nové přesčasy definujete v menu Seznamy/Kalendáře přesčasy.


Omezení

Navigation: Seznamy > Kalendáře >

Formulář kalendáře - Omezení

 Return to chapter overview

Nastavení časových omezení

Mezní hodnota definuje maximální nebo minimální hodnotu pro určité časové složky mzdy, jako je například přesčas, odpracovaná doba aj. Tímto nastavením lze kontrolovat odpracované hodiny za den, týden nebo jiný časový úsek určený položkou "typ intervalu".

Jelikož kalendář je přiřazován určité skupině zaměstnanců, můžete v kalendáři této skupině nastavit podmínky pro omezování délky časové složky.

V této záložce se zobrazí seznam nastavených omezení.

Pro vkládání a opravy položek použijte standardní funkce pro ovládání seznamů. Pro vložení nového záznamu nebo opravu záznamu si otevřete formulář. Formulář příplatku má dvě záložky: Formulář záznamu, Sčítané operace dle časové složky.


Formulář omezení - Formulář záznamu

Navigation: Seznamy > Kalendáře > Formulář kalendáře - Omezení >

Formulář omezení - Formulář záznamu

 Return to chapter overview

Ve formuláři záznamu nastavujete základní vlastnosti a podmínky pro časové omezení.

· Časová složka mzdy - povinná položka. Vyberte časovou složku, pro kterou chcete nastavit omezení ze seznamu časových složek.

· Typ intervalu - vyberte časový interval, pro který se má časové omezení počítat.

· Hodiny min - zadejte minimální počet hodin pro vybranou časovou složku a časový interval.

· Hodiny max - zadejte maximální počet hodin pro vybranou časovou složku a časový interval.


Formulář omezení - Sčítané operace dle časové složky

Navigation: Seznamy > Kalendáře > Formulář kalendáře - Omezení >

Formulář omezení - Sčítané operace dle časové složky

 Return to chapter overview

V této záložce jsou zobrazeny operace, jejichž součet bude pro uvedený interval kontrolován. Tento seznam vychází ze seznamu operací určených u časové složky mzdy.

Pokud chcete využít této funkce programu, je potřeba ji aktivovat v menu Systém/Nastavení aplikace/Společné nastavení - Zpracování původní docházky - zatrhnutím pole Počítat omezení časových složek mzdy.


Formulář kalendáře - Osoby

Navigation: Seznamy > Kalendáře >

Formulář kalendáře - Osoby

 Return to chapter overview

Osoby v kalendáři

Kalendář je definován pro určitou skupinu pracovníků. Přiřadit pracovníky k tomuto kalendáři můžete v tomto formuláři. Většinou však tento seznam přiřazených a nepřiřazených pracovníků použijete pouze pro zobrazení stavu.

Skutečné přiřazení kalendáře pracovníkovi provedete ve formuláři zaměstnance.

POZOR: Při přiřazování kalendáře jsou velmi důležité data přiřazení (platnost od - platnost do). Pokud zaměstnance kalendář používá, ponechte pouze datum přiřazení. Ukončení platnosti ovlivní další práci v editaci.


Operace

Navigation: Seznamy > Kalendáře >

Formulář kalendáře - Operace

 Return to chapter overview

U každého kalendáře je možné individuálně nastavit jednotlivé vlastnosti operací terminálu.

Operace terminálu jsou nastaveny standardně v Terminály/Operace terminálu. V kalendáři si můžete upravit operace pro konkrétní skupinu lidí, resp. pro konkrétní kalendář. Pokud používáte více kalendářů, je možné u každého z nich nastavit, jak se jednotlivé operace budou chovat.

Pokud má zaměstnanec přiřazený daný kalendář a v sekci OPERACE má definováno nastavení pro daný kalendář, pak se zpracování původní docházky bude řídit nastavením operace pro ten konkrétní kalendář.

Operace terminálu musíte mít, v první řadě, správně nadefinované ve formuláři operace terminálů.

Formulář je rozdělen na dvě části. V levé části je zobrazen seznam s různými druhy Dostupných operací (činností, přerušení) pracovní doby. Tento seznam operací je závislý na druhu použitého hardware docházkových a přístupových terminálů. Druhá část formuláře obsahuje již vámi vybrané Operace s nastavením vlastností pro kalendář. K přesunu položek z jedné poloviny formuláře do druhé a naopak, stačí označit jednotlivé položky a stiskem šipky mezi seznamy se hodnoty přesouvají z jedné strany na druhou oběma směry.

Pokud chcete nastavit jednotlivé vybrané operace, stačí pouze danou operaci označit a stisknutím tlačítka Editace zaznamu Editace záznamu otevřít formulář Nastavení operace, kde provedete potřebná nastavení.

Základní nastavení:

· Počátek intervalu - po registraci operace na terminálu systém počítá část do další operace a vytváří časový interval. Počátek intervalu nesmí mít operace ODCHOD. U všech ostatních operací byste měli mít volbu zaškrtnutou.

· Nevkládat ve svátek - volba určuje, zda se operace nebude vkládat ve svátek při ručním a automatickém vkládání docházky podle kalendáře a při vkládání docházky podle plánování absencí (při zpracování docházky).

· Rozdělovat interval půlnocí - pokud má operace danou volbu zapnutou, pak při zpracování původní docházky je interval dané operace rozdělen na jednotlivé dny, přes které prochází a jednotlivé části intervalu jsou přiřazeny k daným dnům.

· Ukončit automaticky - v případě, že předpokládáte, že se pracovník nebude již vracet zpět, aby docházku za den ukončil, můžete nastavit možnost automatického ukončení operace. Nastavení automatického ukončení má několik možností:

o Neukončovat - operace bude pokračovat až do další registrace jiné operace.

o Délkou směny - pokud operace dosáhne délky přiřazené směny je ukončena.

o Délkou pevného jádra - pokud operace dosáhne délky pevného jádra přiřazené směny je ukončena.

o Koncem směny - pokud operace dosáhne času konce směny je ukončena.

o Koncem pevného jádra - pokud operace dosáhne času konce pevného jádra směny je ukončena.

o Délkou nebo koncem směny - pokud operace dosáhne času konce směny nebo délky směny je ukončena.

o Délkou nebo koncem pevného jádra - pokud operace dosáhne času konce pevného jádra směny nebo délky pevného jádra směny je ukončena.

o Po určené době - operace se ukončí po zadané době.

o Při neukončení do určené doby po směně ignorovat - pokud neukončí pracovník operaci do určené doby po směně, bude operace zkrácena na nulovou délku.

o V pevný čas - operace bude ukončena v nastavenou dobu.

o Koncem směny pokud není operace do doby po směně - dojde k ukončení operace koncem směny, pokud není nalezen nějaký záznam do nastavené době (příklad využití - požadujete ukončovat služební cestu koncem směny pokud již pracovník nevrátí zpět do kanceláře).

o Koncem pevného jádra pokud není operace do doby po konci pevného jádra - viz výše s rozdílem doby ukončení operace.

o V pevný čas - pokud není operace do doby 2 po pevném čase - pokud není interval ukončen odchodem, nebo do dané doby (Hodnota pole: "Doba 2") po pevném čase (Hodnota pole: "Doba pro automatické ukončení") nenásleduje další operace (počátek intervalu), pak je akt. interval docházky ukončen daným pevným časem.

o Součtem do délky směny+(určená doba-ruční přestávky)

o Součtem do délky směny+(určená doba-ruční přestávky) - pokud není operace do doby 2 po směně

· Doba pro automatické ukončení - zadejte hodnotu ve formátu HH:MM pokud máte nastavenu volbu automatického ukončení s definicí doby.

· Doba 2 - volba je aktivní pouze pro automatické ukončení operace V pevný čas - pokud není operace do doby 2 po pevném čase.

· Nezapočítat aut. ukončené operace s délkou menší, než - volba omezí počítání operací, které skončily dříve, než je stanoveno (dovolená ≥ 4 hod, lékař ≤ 4 hod apod.).

Úprava počátku a konce operace:

· Úprava času operace - nastavuje možnost posunu času zaregistrované operace. Umožňuje tyto volby:

o Neupravovat - standardní nastavení, čas operace zůstává podle skutečné registrace na terminálu.

o Posunout o délku směny zpět - posune čas o nastavenou délku přiřazené směny.

o Posunout o délku pevného jádra směny zpět - posune čas o nastavenou délku pevného jádra přiřazené směny.

o Posunout na počátek směny

o Posunout na počátek směny dopředu - princip stejný, jako u předchozí možnosti - systém zaregistruje operaci lékaře od začátku registrace do konce směny.

o Posunout na počátek směny dozadu - umožňuje zaregistrovat např. ranní návštěvu lékaře. Pracovník přijde od lékaře a zaregistruje operaci příchod od lékaře s tímto nastavením. Systém zaregistruje operaci lékaře od začátku směny až po čas registrace.

o Posunout na konec směny

o Posunout na konec směny dopředu

o Posunout na konec směny dozadu

o Posunout na počátek pevného jádra

o Posunout na počátek pevného jádra dozadu

o Posunout na konec pevného jádra

o Posunout na konec pevného jádra dopředu

o Posunout na konec pevného jádra dozadu

o Posunout o určitou dobu zpět - použijete např. v případě, že terminál pro registraci je mimo pracovní místo a pracovník si registruje odchod až po převlečení po ukončení práce. Můžete nastavit posun o 10 minut zpět, čímž odečtete předpokládaný čas strávený převlékáním.

o Posunout o určitou dobu dopředu

· Doba pro úpravu času operace - pokud je nastavena úprava času operace můžete zadat hodnotu pro posun ve formátu HH:MM.

· Jen pro první operaci směny - pokud je volba aktivována, pak je úprava času operace, provedena jen pokud je to první operace směny.

· Návazná operace - tato volba, při zpracování původní docházky, aktivuje vložení záznamu s operací nastavenou jako "Návazná operace" ihned za záznam s danou operací, pro který je "Návazná operace" nastavena.

· Automatické opakování - můžete nastavit automatické opakování poslední provedené operace. Např. při odchodu na dovolenou může systém automaticky opakovat operaci každou směnu až do chvíle, kdy pracovník zaregistruje jinou operaci. Volby opakování např.:

o Neopakovat

o Opakovat každý pracovní den - opakuje poslední operaci každý pracovní den (např. dovolená).

o Opakovat každý kalendářní den - opakuje kalendářní den (např. nemoc).

o Opakovat každou směnu - opakuje operaci ve dnech, kdy je v kalendáři definovaná směna.

o Opakovat každý počátek pevného jádra směny

o Opakovat každou směnu v pracovní den

· Ignorovat první operaci opakování - pokud je tato volba aktivována, pak je první zaregistrovaná operace, která uvádí automatické opakování, při výpočtu docházky přeskočena. První interval je vytvořen až od první automaticky vygenerované operace (následující den, následující kalendářní den, následující směnu).

· Ignorovat operace kratší než - zadejte čas ve formátu HH:MM, pokud bude časový interval s touto operací kratší, než zadaný čas bude interval zrušen. Jde například o chybné registrace s následnou opravou nebo velmi krátké intervaly.

· Min. délka operace - pokud bude vypočtený interval kratší než zadaná hodnota ve formátu HH:MM bude interval prodloužen na délku této hodnoty. Např. přestávka má být minimálně 30 minut. Pokud se pracovník vrátí za dobu kratší, doplní systém přestávku na 30 minut, pokud pracovník přestávku přetáhne, započítá se mu skutečná doba.

· Následující operace detekuje novou směnu - zatrhnutím pole určíte, že při zpracování docházky se bude pro operaci, která následuje po operaci s nastavenou danou volbou, vyhledávat směna pro přiřazení, i když to je uprostřed souvislého intervalu docházky, kdy se jinak přebírá směna z předchozí operace.

Zaokrouhlování:

· Zaokrouhlení počátku - můžete nastavit zaokrouhlení času operace (nezaokrouhlovat, nahoru, dolů, normálně), posune čas registrace operace na terminálu.

· Zaokrouhlení počátku na - pokud jste nastavili zaokrouhlování, zadejte hodnotu zaokrouhlení ve formátu HH:MM (např. 00:05 - zaokrouhlení na 5 minut).

· Zaokrouhlení délky - po vypočtení intervalů docházky můžete nastavit zaokrouhlení těchto intervalů.

· Zaokrouhlení délky na - pokud jste nastavili zaokrouhlování, zadejte hodnotu zaokrouhlení ve formátu HH:MM (např. 00:05 - zaokrouhlení na 5 minut).

Úprava a započítávání času:

· Výpočet délky operace - můžete omezit započítávání operace, např. služební cestu započítávat pouze v intervalu přeřazené směny.

· Maximální započitatelná doba - zadejte hodnotu ve formátu HH:MM, program omezí započítanou délku intervalu.

· Při nulové denní normě nezapočítat - pokud je tato volba aktivována, pak pokud je ve dni přiřazení záznamu nulová denní norma, potom záznam není vůbec započítáván do výsledků.


Formulář kalendáře - Časové složky

Navigation: Seznamy > Kalendáře >

Formulář kalendáře - Časové složky

 Return to chapter overview

Toto nastavení dává možnost definovat omezení výpočtu výsledků časových složek z ostatních vypočtených výsledků pro jednotlivé kalendáře. Tzn., nastavené výsledky se počítají zaměstnancům, kteří v daném období/dni mají přiřazený daný kalendář. Takto je možno pro různé skupiny zaměstnanců počítat různé výsledky výpočtu.


Formulář časové složky - Denní omezení

Navigation: Seznamy > Kalendáře > Formulář kalendáře - Časové složky >

Formulář časové složky - Denní omezení

 Return to chapter overview

Pokud je časová složka mzdy (pro názornost odpracovaná doba) omezena osmi hodinami, budou se zaměstnancům při výpočtu Denním omezením započítávat jen hodiny, které budou odpovídat tomuto limitu. Hodiny, které přesáhnou tento limit, nebudou mít na výpočet vliv. V grafickém zobrazení zpracované docházky však bude zobrazena celková doba, po kterou byly zaměstnanci na pracovišti.

Formular kalendare_Denni omezeni

Toto nastavení omezení časových složek se projeví až při samotném zpracování původní docházky, kde budou do výpočtu tato omezení zahrnuta.

Denní omezení určuje maximální hodnotu denního výsledku výpočtu docházky.

Pro vložení nového záznamu nebo opravu záznamu si otevřete formulář Denní omezení časové složky pro výpočet.

· Časová složka mzdy - vyberte časovou složku mzdy, u které se má omezení provádět.

· Hodiny max - zadejte maximální počet hodin.

· Dny max - zadejte maximální počet dnů.

· Kalendářní dny max - zadejte maximální počet kalendářních dnů.


Vzorcem

Navigation: Seznamy > Kalendáře > Formulář kalendáře - Časové složky >

Formulář časové složky - Vzorcem

 Return to chapter overview

Výpočet výsledků vzorcem se definuje v menu Seznamy/Kalendáře vzorce. Kde provádíte požadované nastavení vzorce pro danou časovou složku. V kalendáři pak lze z předem definovaných nastavení výpočtu vybrat pouze ty, které budete využívat pro daný kalendář.


Ostatní

Navigation: Seznamy > Kalendáře >

Ostatní

 Return to chapter overview

Automatické vkládání docházky ve svátek (placený) - při zapnutí této funkce bude kalendář generovat směny i pro tyto dny, musí však být ještě zadaná operace, která se v tento den bude do docházky započítávat.

V případě, že požadujeme, aby svátky byly také zahrnuty v odpracované době, je potřeba použít automatické vkládání docházky ve svátek. Nejdříve je potřeba vytvořit operaci např. Placený Svátek, která se započítává do časové složky odpracovaná doba. V této části kalendáře nastavte automatické vkládání operace v placený svátek a vyberte operaci, kterou jste vytvořili. Současně je potřeba zatrhnout "snižovat normu o normu ve svátek" - pro správné počítání přesčasů a rovněž je potřeba nastavit vzorec u časové složky placený svátek pro správné zobrazení výsledků.

Snižování skutečné normy o normu ve svátek - pokud je tato volba zapnutá, je automaticky odečítána od skutečné normy norma ve svátek.

Rovněž tato funkce je využívána v případech, kdy je potřeba, aby fond pracovní doby obsahoval také dny svátků. V tomto případě je potřeba v kalendáři v záložce Směny II přiřadit směnu také pro dny svátků (použijete k tomu Průvodce nastavením směn v kalendáři) a následně zatrhnout - snižovat skutečnou normu o normu ve svátek. Výsledkem je, že zaměstnanec má normu vyšší o svátky, ale nemusí si je nadpracovat.

Typ kalendáře pro statistiky (pouze pro mzdový systém).

Určování směn dle plánování kapacit (pouze pro docházkový systém) - volba určuje, zda zpracování docházky, pro daný kalendář, načítá zaměstnancům směny z formuláře plánování kapacit namísto směn v kalendáři. Takto lze pomocí modulu plánování kapacit realizovat individuální kalendáře (nastavení směn) jednotlivým zaměstnancům, bez toho, aby se jednotlivým zaměstnancům vytvářely a přiřazovaly jednotlivé kalendáře. Směny z plánování kapacit jsou pro takto nastavené kalendáře zobrazovány i ve formuláři editace docházky.


Směny

Navigation: Seznamy >

Směny

 Return to chapter overview

Směny jsou základním prvkem pro vytvoření kalendářů, a tím i pro definici normy pracovní doby.

Z definovaných směn vytvoříte jednotlivé kalendáře. Každá vytvořená směna může být použita v několika kalendářích. V seznamu směn vytváříte všechny typy směn, které budete používat. Můžete definovat směny podle denní doby (ranní, odpolední, noční), nebo délky (8 hodinové, 12 hodinové ...) a jejich jednotlivé kombinace.

V jednoduchých případech můžete vystačit pro celou firmu s jednou směnou (např. směna denní 8 hodin). V jiných případech máte provoz více směnný a s různými délkami úvazků. Můžete také definovat pružnou a pevnou část směny a podmínky pro vkládání přestávek do směny. Vlastnosti, které směně přiřadíte, si s sebou bere do kalendáře, ve kterém je použita.

Každý interval odpracované doby, který zaměstnanec zaznamená je přiřazen k určité směně. Program se snaží podle parametrů nastavených v kalendáři určit směnu, na kterou zaměstnanec přišel.

Samotné vkládání nebo opravu údajů neprovádíte v tomto seznamu, ale otevřete si formulář pro nový záznam, popř. otevřete stávající směnu (viz ovládání seznamu). Formulář má tyto záložky:

Hlavní údaje

Přiřazené kalendáře

Harmonogramy


Formulář směny - Hlavní údaje

Navigation: Seznamy > Směny >

Formulář směny - Hlavní údaje

 Return to chapter overview

Definice směny je podstatnou částí pro správnou funkci docházkového systému. Nadefinování směn je základní podmínkou pro správné vytvoření kalendářů. Vlastnosti směny jsou rozhodující při automatizovaném rozpoznávání a přiřazování směny k časovému intervalu v docházce.

Definice položek určujících vlastnosti směny:

· Kód - položka musí být vyplněna. Označení směny by mělo vystihovat její použití (například pro ranní směnu 8 hodinovou je vhodné použít kód R8). Textová položka maximálně 10 znaků.

· Aktivní - pokud je směna aktivně využívána (je tedy platná), zatrhněte pole.

· Popis - položka musí být vyplněna. V této položce můžete podrobněji popsat použití směny.

· Variabilní - pro zadávání individuálních časů směn v plánování kapacit. Norma u variabilních směn se počítá z délky zadané v plánování kapacit.

· Vždy dopočítávat délku a konec - při zadávání variabilních směn v plánování kapacit bude vždy dopočítávat délku a konec směny.

· Dělená - tento příznak určuje, zda je tato směna dělená. Tzn., že zaměstnanci po první části směny odcházejí z práce a pak přijdou zpět na druhou část směny.

· Směna od - zadejte standardní dobu začátku směny ve formátu HH:MM (např. 06:00).

· Směna do - zadejte standardní dobu konce směny ve formátu HH:MM (např. 14:00).

· Směna délka - zadejte délku směny v hodinách a minutách ve formátu HH:MM. Délka směny určuje počet hodin, které tvoří fond pracovní doby. Délka směny nemusí souhlasit (a většinou nesouhlasí) s výpočtem rozdílu mezi počátkem a koncem směny. Rozdíl je tvořen povinnými (evidovanými a neplacenými) přestávkami v práci.

· Pevná část od - tuto položku vyplňujete v případě, že používáte směnu s pružnou pracovní dobou a pevným jádrem - zadejte standardní dobu začátku pevného jádra směny ve formátu HH:MM (např. 08:00).

· Pevná část do - tuto položku vyplňujete v případě, že používáte směnu s pružnou pracovní dobou a pevným jádrem - zadejte standardní dobu konce pevného jádra směny ve formátu HH:MM (např. 12:00).

· Pevná část délka - tuto položku vyplňujete v případě, že používáte směnu s pružnou pracovní dobou a pevným jádrem - zadejte délku pevného jádra směny v hodinách a minutách ve formátu HH:MM.

Nastavení pevného jádra využijete například při sledování dob strávených u lékaře, která je u zaměstnanců s pružnou pracovní dobou placena pouze v intervalu pevného jádra.

· Den docházky podle konce směny - každá směna a tím i časové intervaly v této směně obsažené mají nastaven den, ke kterému patří a za tento den se potom počítají norma, přesčas a saldo odpracované doby. Při standardní ranní nebo odpolední směně tato položka nemá smysl, jelikož směna začíná i končí v jednom dni. Problém vzniká při směně noční. Standardně počítáme s tím, že směna by měla patřit ke dni, ve kterém začala. Z praxe však vyplývá potřeba v některých provozech přiřadit směnu ke dni, ve kterém končí a všechny výsledky se pak počítají do tohoto (následujícího) dne. Pokud tedy chcete směnu započítat do dne, ve kterém končí, zaškrtněte tuto položku.

POZOR: Při používání této volby si uvědomte všechny její důsledky. V průběhu měsíce problém nevzniká, maximálně se odpracovaná doba započítá o den později. Rozdíly však vznikají na začátcích a koncích měsíce kdy se může, díky tomuto nastavení, celá směna dostat do jiného měsíce. Buďte tedy v tomto nastavení opatrní.

· Nezapočítat docházku v době před směnou - jestliže chcete ignorovat předčasné příchody zaměstnanců na směnu (např. když si označí začátek směny a jdou se nasnídat) nastavte časový interval, ve kterém se až do začátku směny operace nezapočítávají.

PŘÍKLAD: Směna má začínat v 6:00 hodin, pracovník zaregistruje příchod v 5:35 hodin. Pokud chcete započítat směnu až od 6:00, zadejte do této položky hodnotu 00:30. V tomto případě budou příchody mezi 05:30 a 06:00 hodinou posunuty na 06:00. Příchody před 05:30 budou započítány normálně jako nadpracovaný čas před směnou.

· Nezapočítat docházku v době po směně - jestliže chcete ignorovat pozdní odchody zaměstnanců ze směny (např. zdržení v šatně) nastavte časový interval od konce směny, ve kterém se operace posouvají na konec směny.

PŘÍKLAD: Směna má končit ve 14:00 hodin, pracovník zaregistruje odchod ve 14:10 hodin. Pokud chcete započítat směnu pouze do 14:00, zadejte do této položky hodnotu 00:30. V tomto případě budou odchody mezi 14:00 a 14:30 započítány pouze do 14:00. Odchody po 14:30 budou započítány normálně jako odpracovaný přesčas po směně.

TIP: Pozor na zadávání této hodnoty. Nezadávejte čas, ale délku časového intervalu. Pokud chcete ignorovat dobu 30 minut po směně končící ve 14 hodin, zadáte 00:30 (rozhodně nezadávejte 14:30). Toto nastavení platí pro obě předcházející položky.

· Zkratka pro plánování - při plánování kapacit se použité směně přiřadí nastavená zkratka (N8 - Noční směna 8; R8 - Ranní směna 8 apod.).

· Barva pro vykreslení - nastavte barvu, která se přiřadí k použité směně (červená).

Definice PŘESTÁVEK VE SMĚNĚ:

· Typ vkládání přestávek - program umožňuje automatické vkládání přestávek do odpracované doby. Legislativní úprava nařizuje povinné sledování přestávek v pracovní době. Položka Typ vkládání přestávky má 4 možné varianty:

¬ Nevkládat přestávky - pokud si zaměstnanci chodí registrovat k terminálu začátek i konec přestávky, nastavte položku na hodnotu "Nevkládat přestávky". Program respektuje údaje zaregistrované na terminálu.

¬ V pevný čas - tato varianta nastavení položky se většinou používá pro pracovníky s pevnou pracovní dobou danou přesně počátkem a koncem směny. Při tomto nastavení se pod položkou zobrazí seznam pro zápis pevných přestávek ve směně. V seznamu zapisujete tyto hodnoty:

· Počátek přestávky - čas počátku přestávky ve formátu HH:MM:SS.

· Délka přestávky - délku přestávky ve formátu HH:MM:SS.

· Operace přestávky - typ operace, která bude použita pro přestávku. Seznam operací je omezen jen na nesystémové operace, tzn. operace, které nemají ve Formuláři operace terminálu - Hlavní údaje zaškrtnuto pole Systémová.

Možnosti vkládání, mazání a editování položek v tomto seznamu se řídí standardním ovládáním seznamu.

TIP: Pokud zaměstnanec používá směnu s pevně definovanými přestávkami a přijde do práce hodinu před touto přestávkou, systém mu vloží přestávku, i když má odpracovanou pouze tuto jednu hodinu. Pevný čas je přesně stanovená doba kdy se přestávka vloží. Pokud budete chtít tuto přestávku zrušit, musíte to provést až v editaci docházky.

¬ Po odpracovaném intervalu - tuto volbu použijete pro pracovníky s volnější pracovní dobou. Program počítá interval odpracované doby. Po uplynutí zadaného intervalu vloží přestávku definované délky a definovaného typu operace. Nezáleží tedy na tom, kdy pracovník přijde do práce. Program měří dobu od příchodu a po určeném intervalu přestávku vloží. Pokud si do vypršení intervalu zaměstnanec vyčerpal část přestávky, doplní program pouze zbývající část.

· Interval přestávky - přestávky budou vkládány po zvoleném odpracovaném intervalu. Zadejte hodnotu ve formátu HH:MM. (přestávka po 4,5 hodinách zadejte 04:30).

· Max. interval - přestávka bude vložena v zadaném intervalu pouze, pokud nebyla jiná přestávka v rozmezí maximálního intervalu. Program vloží přestávku například po 4,5 hodinách, ale zaměstnanec jde na přestávku po 5,5 hodinách. Jelikož automatické vložení již proběhlo, budete mít v tomto případě zaměstnanec 2 přestávky (jednu automatem a druhou si sám registroval na terminálu). Aby k této situaci nedocházelo, nastavte si právě tuto hodnotu max. interval.

PŘÍKLAD: Máte nastaveno automatické vložení přestávky po 4,5 hodinách v délce 30 minut. Max interval nastavíte na 6 hodin. V tomto případě program čeká po dobu 6 hodin, jestli si zaměstnanec nezaznamená přestávku. Pokud si přestávku do 6 hodin od počátku práce zaznamená tak automatické vložení nebude provedeno. Pokud si přestávku nezaznamená, bude přestávka vložena po 4,5 hodinách automatickým systémem.

· Délka přestávky - vložená přestávka bude mít zadanou délku. Hodnotu zadáváte ve formátu HH:MM. Většinou budete nastavovat 30 minut (00:30).

· Max. počet přestávek 1. typu - program umí vkládat přestávky dvou typů operace. Zadejte, kolikrát se má opakovat první typ.

· Operace přestávky 1. typu - zvolte typ operace ze seznamu operací terminálu. Seznam operací je omezen jen na nesystémové operace, tzn. operace, které nemají ve Formuláři operace terminálu - Hlavní údaje zaškrtnuto pole Systémová.

· Pokračovat druhým typem - pokud chcete použít i druhý typ, zaškrtněte tuto položku.

· Max. počet přestávek 2. typu - zadejte, kolikrát se má opakovat druhý typ.

· Operace přestávky 2. typu - zvolte typ operace ze seznamu operací terminálu. Seznam operací je omezen jen na nesystémové operace, tzn. operace, které nemají ve Formuláři operace terminálu - Hlavní údaje zaškrtnuto pole Systémová.

Standardní situace pro použití dvou typů přestávek: podle zákoníku jsou přestávky neplacené a povinné. Pokud se zaměstnavatel rozhodne první přestávku ve směně dát jako neplacenou a další potom jako placené použije přestávku prvního typu 1x a potom dále přestávky druhého typu, jejichž typ bude nastaven jako placený. Klasickou situací je zaměstnanec, který zůstane přesčas a musí si podle zákona vybrat přestávku každé 4,5 hodiny i v nadpracované době.

TIP: Nezapomeňte správně nastavit u jednotlivých operací terminálů položku "Nárok na přestávku". Odpracovaná doba a všechny operace, které musí být přestávkou přerušovány, musí mít tuto položku zaškrtnutou. Naopak operace přestávka nesmí mít tuto položku zaškrtnutou v žádném případě.

¬ Podle délky odpracované směny - tento typ generuje přestávky ve směně tak, že zjistí délku dané směny a vypočte odpovídající délku nároku na přestávku. Následně zjistí délku již existujících přestávek ve směně, a pokud je délka nároku na přestávku delší, pak doplní přestávky v délce rozdílu nároku a již vložených přestávek.

· Interval přestávky - přestávky budou vkládány po zvoleném odpracovaném intervalu. Zadejte hodnotu ve formátu HH:MM. (přestávka po 4,5 hodinách zadejte 04:30).

· Délka přestávky - vložená přestávka bude mít zadanou délku. Hodnotu zadáváte ve formátu HH:MM. Většinou budete nastavovat 30 minut (00:30).

· Max. počet přestávek - zadejte, kolikrát se má přestávka opakovat.

· Operace přestávky - zvolte typ operace ze seznamu operací terminálu. Seznam operací je omezen jen na nesystémové operace, tzn. operace, které nemají ve Formuláři operace terminálu - Hlavní údaje zaškrtnuto pole Systémová.

Pokud máte správně nastaveny a vytvořeny směny, můžete začít vytvářet kalendáře.


Formulář směny - Přiřazené kalendáře

Navigation: Seznamy > Směny >

Formulář směny - Přiřazené kalendáře

 Return to chapter overview

Ve formuláři máte možnost zobrazit a přiřadit kalendáře, které směna používá. V případě přiřazení kalendáře se směna doplní do kalendáře (Kalendář - Směny) nakonec, pokud jsou již nějaké směny v kalendáři přiřazeny.

V levé části formuláře je seznam všech dostupných kalendářů. Pravá část je vyhrazena pro seznam kalendářů, ve kterých je vybraná směna zařazena. Označením položky a stiskem šipky mezi seznamy můžete hodnoty přesouvat z jedné strany na druhou oběma směry. Editací záznamu pod seznamy se dostanete do Formuláře kalendáře.


Formulář směny - Harmonogramy

Navigation: Seznamy > Směny >

Formulář směny - Harmonogramy

 Return to chapter overview

Ve formuláři se zobrazí seznam harmonogramů, ve kterém je směna použita.


Kalendáře - Příplatky

Navigation: Seznamy >

Kalendáře - Příplatky

 Return to chapter overview

V této části lze definovat požadavky na vlastnosti příplatků, které pak budou přiřazeny do jednotlivých používaných kalendářů. Příplatky se definují ve dvou fázích a to ve formuláři záznamu a ve formuláři započtených operací. Dále pak je možno daný příplatek rovnou přiřadit požadovanému kalendáři v položce přiřazené kalendáře.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář Přesčasu. Formulář má záložky:

Formulář záznamu

Započtené operace

Přiřazené kalendáře


Karta příplatku - formulář záznamu

Navigation: Seznamy > Kalendáře - Příplatky >

Karta příplatku - formulář záznamu

 Return to chapter overview

Ve formuláři záznamu nastavujete základní vlastnosti a podmínky pro výpočet příplatku.

· Kód příplatku - označení příplatku, textová položka maximálně 10 znaků. Povinná položka.

· Aktivní - pokud je kalendář aktivně využíván (je tedy platný), zatrhněte pole.

· Popis - povinný údaj. Textový popis příplatku.

· Výsledek započítat do časové složky mzdy - vyberte typ časové složky ze seznamu časových složek (čs). Vypočtené hodnoty se budou připočítávat do vybrané časové složky mzdy. Přiřazujte Příplatky do časové složky, které se logicky nabízejí: Příplatek za svátek - čs Odpracováno ve svátek; Příplatek za sobotu - čs Odpracováno v sobotu; Příplatek Stravenka - čs Stravenka apod. Požadovanou časovou složku mzdy je možné vyhledat podle kódu.

POZOR: Časová složka použitá pro výpočet příplatků nesmí mít ve svém nastavení v Seznamu časových složek vybranou žádnou operaci pro započítávání.

· Částka za hodinu - zadejte hodinovou sazbu příplatku není povinné, jde pouze o evidenční údaj.

· Nepočítat v kombinaci s přesčasem - v případě, že volbu zaškrtnete a je ve stejném časovém intervalu nastaveno počítání přesčasů, nebude se tento příplatek počítat. Pokud je volba vypnutá můžete pro stejný časový interval počítat přesčas i příplatek.

· Započítat čas vyšší než - zadejte minimální časový interval, se kterým se má počítat ve formátu HH:MM:SS., například 15 minut = 00:15:00. Za čas pod 15 minut se nebudou příplatky počítat.

· Zaokrouhlení - nastavte způsob zaokrouhlení času příplatku (nahoru, dolů, normálně, nezaokrouhlovat).

· Zaokrouhlit na - pokud nastavíte nějaký způsob zaokrouhlení, nastavte také čas pro zaokrouhlení ve formátu HH:MM:SS. Pokud nastavíte 00:30, bude se příplatek zaokrouhlovat na celé půlhodiny směrem určeným v předchozí položce.

Dny a hodiny, za které bude příplatek poskytnut:

V této části zadejte časové rozlišení, kdy se mají příplatky počítat.

Čas od - zadejte denní dobu, od kdy se příplatek počítá, např. pro odpolední příplatek zadejte 14:00:00.

Čas do - zadejte denní dobu, do kdy se příplatek počítá, např. pro odpolední příplatek zadejte 22:00:00.

Dále zaškrtněte, jestli se počítá v pracovní nebo nepracovní den, případně ve svátky a který den v týdnu od pondělí do neděle.

Funkce den před, den po umožňují, započítávat vybrané operace do předešlého nebo následujícího dne. Pro využívání těchto funkcí musí být zaškrtnuta jen jedna z těchto položek (pracovní den, den volna, placený svátek nebo neplacený svátek) pro které se má vybraná funkce aktivovat.

POZOR: Pokud zaměstnanci pracují na třísměnný provoz, může nastat situace, že na sobotu nebo kterýkoliv jiný pracovní den vyjde svátek.

Při standardním nastavení příplatků by se ranní a odpolední směně příplatek započítal v plné výši, neboť směny začínají a končí v den svátku.

Noční směně by se započítal pouze interval od 22:00 do 23:59:59, neboť po půlnoci začíná nový pracovní den.

Abychom postihly celý interval směny, musí se vytvořit dva příplatky pro noční směnu. První příplatek od 22:00 do 23:59:59 a druhý od 0:00:01 do 6:00, ve kterém musí být nastaveno, jestli se má příplatek počítat do dne před nebo dne po.

· Poznámka - libovolná doplňující informace o příplatku.

Funguje-li vaše firma na třísměnný provoz, určitě u vás nastala situace, že zaměstnanci začínají noční směnou už v neděli večer, a vy chcete nastavit, aby se tato směna počítala do dne, ve kterém směna končí tj. pondělí. Musíte mít zaškrtnutou volbu den po. Druhým případem je přesný opak předchozí situace zaměstnanci začínají první směnou v pondělí ráno a poslední (noční) směna končí v sobotu ráno. Chcete-li, aby se docházka započítávala do dne, ve kterém poslední směna začala tj. pátek, musíte v této nabídce zaškrtnout den před.

Pomocí tohoto nastavení můžete definovat jakýkoliv časový úsek pro výpočet příplatku. Např. počítat příplatek pouze v sobotu a neděli od 14 do 22 hodin. Tím získáte odpolední víkendové odpracované hodiny. Kombinací v tomto smyslu můžete vytvořit, kolik chcete. Počet příplatků pro kalendář není omezen, nicméně vytvořte si takové množství příplatků, abyste se v nich sami vyznali.


Formulář příplatku - Započtené operace

Navigation: Seznamy > Kalendáře - Příplatky >

Formulář příplatku - Započtené operace

 Return to chapter overview

V započtených operacích nastavujete operace, které mají vliv na výpočet tohoto příplatku (jaké činnosti se započítávají).

Záložka je rozdělena na seznam nepoužitých operací (levá strana) a seznam započtených operací (pravá strana). Vyberte ty činnosti, při kterých se má příplatek počítat. Tím můžete kromě časového nastavení výpočtu příplatku z první záložky nastavit činnosti, které se budou do příplatku počítat. Pokud si nenastavíte započítávané operace, nebude se příplatek počítat.

TIP: Pokud používáte podobné nebo stejné nastavení přesčasů a příplatků můžete si usnadnit nastavování kalendářů kopírováním příplatků a přesčasů mezi jednotlivými kalendáři. Při zobrazeném seznamu kalendářů v menu Aktuální okno je poslední položka "Kopírování vlastností kalendářů". Vyberte zdrojový a cílový kalendář a dále vyberete, zda chce kopírovat příplatky nebo přesčasy případně obojí.


Formulář příplatku - Přiřazené kalendáře

Navigation: Seznamy > Kalendáře - Příplatky >

Formulář příplatku - Přiřazené kalendáře

 Return to chapter overview

Přiřaďte na pravou stranu všechny kalendáře, ve kterých se má daný příplatek počítat.


Kalendáře - Přesčasy

Navigation: Seznamy >

Kalendáře - Přesčasy

 Return to chapter overview

V této části docházkového systému definujeme požadavky na výpočet přesčasů v docházkovém systému.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář Přesčasu. Formulář má záložky:

Formulář záznamu

Započtené operace

Přiřazené kalendáře


Formulář přesčasu - Formulář záznamu

Navigation: Seznamy > Kalendáře - Přesčasy >

Formulář přesčasu - Formulář záznamu

 Return to chapter overview

Ve formuláři záznamu nastavujete základní vlastnosti a podmínky pro výpočet přesčasu.

· Kód přesčasu - označení přesčasu, textová položka maximálně 10 znaků. Povinná položka.

· Aktivní - pokud je kalendář aktivně využíván (je tedy platný), zatrhněte pole.

· Popis - textový popis přesčasu

· Výsledek započítat do časové složky mzdy - vyberte typ časové složky ze seznamu časových složek. Vypočtené hodnoty se budou připočítávat do vybrané časové složky mzdy. Požadovanou časovou složku mzdy je možné vyhledat podle kódu.

· Procento přesčasů - zadejte procento přesčasu.

· Pořadí pro krácení - nastavuje pořadí pro krácení přesčasů.

PŘÍKLAD: Firma sleduje pro jednotlivé dny různou výši %. V pracovní dny Po-Pá (25%) a pro dny volna So-Ne (50%).

Zaměstnanec má nastaven fond pracovní doby 37,5 hodin týdně. Během Po-Pá odpracuje pouze 35 hodin a systém mu vypočítá konečný přesčas 25% v délce -2,5 hodiny. Minusové hodnota vyjadřuje "dluh" do fondu pracovní doby. V sobotu přijde do práce a odpracuje 7,5 hodiny - má přesčas 50% = 7,5 hodiny.

Varianta A - přesčasy se nekrátí - výsledky zůstanou stejné a zaměstnance si nadpracuje záporný přesčas během příštího týdne a dostane sobotní přesčas proplacen v celkové výši. Výsledné hodnoty budou: Přesčas 25% = -2,5 hodin a Přesčas 50% = 7,5 hodin.

Varianta B - přesčasy se krátí - zaměstnanci bude doplněn přesčas 25% z přesčasu 50% tak, aby byl splněn fond pracovní doby, a zbylé hodiny budou proplaceny v 50%. Výsledné hodnoty budou: Přesčas 25% = 0 hodin a Přesčas 50% = 5 hodin.

Způsob krácení také určuje způsob výpočtu přesčasů - součtově nebo průběžně.

Varianta SOUČTOVĚ - provede se výpočet krácení přesčasů až na konci měsíce.

Varianta PRŮBĚŽNĚ - výpočet se provádí pro každý den a systém bere ke krácení první položku, na kterou narazí.

Pokud je již výpočet denního výsledku zvolené časové složky počítán vzorcem, zobrazuje se zde informativní text s odkazem Editovat vlastnosti .... Pokud odkaz stisknete, máte možnost nastavit další vlastnosti přesčasu:

· Počítat výsledný přesčas nad - zadejte minimální časový interval, se kterým se má počítat ve formátu HH:MM:SS., například 15 minut. Za časy pod 15 minut se nebudou přesčasy počítat. Minimální přesčas v jeden den bude minimálně 15 minut.

· Zaokrouhlení - nastavte způsob zaokrouhlení času přesčasu (nahoru, dolů, normálně, nezaokrouhlovat).

· Zaokrouhlit na - pokud nastavíte nějaký způsob zaokrouhlení, nastavte také čas pro zaokrouhlení ve formátu HH:MM:SS. Pokud nastavíte 00:30, bude se přesčas zaokrouhlovat na půlhodiny.

Dny a hodiny, za které bude poskytnut příplatek za přesčas:

V této části zadejte časové rozlišení, kdy se mají přesčasy počítat.

· Čas od - zadejte denní dobu od kdy se přesčas počítá. Např. pro odpolední přesčas zadejte 14:00:00.

· Čas do - zadejte denní dobu do kdy se přesčas počítá. Např. pro odpolední přesčas zadejte 22:00:00.

Dále zaškrtněte, jestli se počítá v pracovní nebo nepracovní den, případně ve svátky a který den v týdnu od pondělí do neděle.

Funkce den před, den po umožňují, započítávat vybrané operace do předešlého nebo následujícího dne. Pro využívání těchto funkcí musí být zaškrtnuta jen jedna z těchto položek (pracovní den, den volna, placený svátek nebo neplacený svátek) pro které se má vybraná funkce aktivovat.

· Poznámka - libovolná doplňující informace o přesčasu.


Formulář přesčasu - Započtené operace

Navigation: Seznamy > Kalendáře - Přesčasy >

Formulář přesčasu - Započtené operace

 Return to chapter overview

V započtených operacích nastavujete operace, které mají vliv na výpočet tohoto příplatku (jaké činnosti se započítávají).

Požadované operace, které se mají zahrnout do výpočtu přesčasů, přiřazujete pomocí šipek Sipka seda vlevo, Sipka seda vpravo, které jsou umístěny ve formuláři mezi dvěma seznamy. V levé části tabulky se nachází seznam všech dostupných operací. V pravé části je seznam vybraných operací, které jsou zahrnuty do výpočtu přesčasů.

TIP: Pokud používáte podobné nebo stejné nastavení přesčasů a příplatků můžete si usnadnit nastavování kalendářů kopírováním příplatků a přesčasů mezi jednotlivými kalendáři. Při zobrazeném seznamu kalendářů v menu Aktuální okno je poslední položka "Kopírování vlastností kalendářů". Vyberte zdrojový a cílový kalendář a dále vyberete, zda chce kopírovat příplatky nebo přesčasy případně obojí.


Formulář přesčasu - Přiřazené kalendáře

Navigation: Seznamy > Kalendáře - Přesčasy >

Formulář přesčasu - Přiřazené kalendáře

 Return to chapter overview

Přiřaďte na pravou stranu všechny kalendáře, ve kterých se má daný přesčas počítat.


Kalendáře - Vzorce

Navigation: Seznamy >

Kalendáře - Vzorce

 Return to chapter overview

V této části lze definovat vzorce, které pak budou přiřazeny do jednotlivých používaných kalendářů.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář Nastavení výpočtu výsledku vzorcem. Formulář má následující záložky:

Formulář záznamu

Přiřazené kalendáře


Formulář vzorce - Formulář záznamu

Navigation: Seznamy > Kalendáře - Vzorce >

Formulář přesčasu - Formulář záznamu

 Return to chapter overview

Výpočet výsledků vzorcem je možno definovat na úrovni denních výsledků nebo na úrovni měsíčních/variabilních výsledků. K tomu slouží volba Počítat denní výsledky u zvolené časové složky. Pokud je tato volba aktivována, pak se počítají vzorcem denní výsledky a měsíční výsledek je standardně jejich součtem. V opačném případě se počítá vzorcem jen měsíční/variabilní výsledek. Nastavení výpočtu vzorcem proveďte v menu Seznamy -> Kalendáře vzorce. Volba zrušit záznam s nulovým výsledkem nám při konečném výsledku časové složky, který bude nulový, tento výsledek nevloží do měsíčních výsledků docházky. Vzorce definuje v editoru vzorců pro zvolenou variantu výpočtu výsledku a to v hodinách, dnech nebo kalendářních dnech.

Variabilní výsledky se počítají jen v případě, že je v nastavení aplikace aktivována volba: Používat uživatelsky definované období. Na vypočtené výsledky vzorcem se nevztahují zaokrouhlení ani denní omezení časových složek.

Do vzorců je možné zapsat poznámky.

PŘÍKLAD: Kdyz(_H_100>4; //pokud je odpracovaná dobu větší než 4hodiny
1; //pokud je podmínka vyhodnocena pravdivě, je výsledkem hodnota 1
0) // pokud je podmínka vyhodnocena nepravdivě, je výsledkem hodnota 0

VYSVĚTLIVKY: // - začátek poznámky

konec poznámky je na konci řádku


Formulář vzorce - Přiřazené kalendáře

Navigation: Seznamy > Kalendáře - Vzorce >

Formulář přesčasu - Přiřazené kalendáře

 Return to chapter overview

Přiřaďte na pravou stranu všechny kalendáře, ve kterých se má daný vzorec použít.


Harmonogramy směn

Navigation: Seznamy >

Harmonogramy směn

 Return to chapter overview

V harmonogramu zvolíte rytmus vkládání směn a nastavíte směny pro jednotlivé dny harmonogramu. Harmonogramu směny následně přiřadíte požadovaný kalendář.

Vkládání nebo opravu údajů neprovádějte v seznamu, ale otevřete si Novy zaznam Nový záznam nebo tlačítkem Editace zaznamu Editace záznamu formulář Harmonogram směn. Formulář má následující záložky:

Hlavní údaje

Dny harmonogramu

Kalendáře


Harmonogram směny - Hlavní údaje

Navigation: Seznamy > Harmonogramy směn >

Harmonogram směny - Hlavní údaje

 Return to chapter overview

Formulář obsahuje identifikační údaje harmonogramu směny.

Harmonogram smeny_hlavni udaje

· Kód - označení harmonogramu směny. Povinná položka.

· Popis - stručný textový popis harmonogramu směny vystihující jeho použití (např. "Týdenní harmonogram", "Měsíční harmonogram").

· Počet dnů cyklu - zde definujete takzvaný kolotoč. Definujete rytmus vkládání směn bez vazby na den v týdnu. Pokud definujete sedmidenní návaznost rytmu, můžete samozřejmě dosáhnout stejného výsledku jako při definici podle dnů v týdnu v průvodci nastavením směn.

· Zkratka pro plánování - při plánování kapacit se použitému harmonogramu směny přiřadí nastavená zkratka.

· Poznámka - libovolný pro vás důležitý údaj.


Harmonogram směny - Dny harmonogramu

Navigation: Seznamy > Harmonogramy směn >

Harmonogram směny - Dny harmonogramu

 Return to chapter overview

Ve formuláři nastavujete harmonogramu směny.

Harmonogram smeny_dny harmonogramu

Na obrazovce jsou zobrazeny dva seznamy. Levý obsahuje seznam všech aktivních směn. Pravý obsahuje seznam použitých směn v pořadí, v jakém se mají vkládat. Označte směnu v levém sloupci a stiskněte šipku Sipka seda vpravo pro zařazení na pravou stranu. Jestliže chcete směnu z pořadí v pravém sloupci zrušit, označte ji a stiskněte opačnou šipku Sipka seda vlevo.


Harmonogram směny - Kalendáře

Navigation: Seznamy > Harmonogramy směn >

Harmonogram směny - Kalendáře

 Return to chapter overview

Ve formuláři přiřadíte harmonogramu směny požadovaný kalendář nebo ve Formuláři kalendáře - Harmonogram směn ke kalendáři přiřadíte harmonogram směny.

Záložka je rozdělena na dva seznamy. V levém seznamu jsou Dostupné Nepřiřazená rozdělení, v pravém seznamu jsou rozdělení zařazená do vybrané kategorie. Položky mezi seznamy můžete přesouvat.

Tlačítkem [image] Editace záznamu v pravé části okna se zobrazí formulář Harmonogram kalendáře.

Harmonogram smeny_kalendare_Harmonogram kalendare

· Harmonogram - vybraný harmonogram.

· Kalendář - přiřazený kalendář harmonogramu.

· Počet - zadejte počet osob. Jedná se o počet osob, které by měly mít současně tento harmonogram přiřazený (počet lidí pracující na stejné směně). Slouží pro přiřazování zaměstnanců k harmonogramu.


Typy časových složek

Navigation: Seznamy >

Typy časových složek

 Return to chapter overview

Časová složka je složka, ve které se shromažďují požadované výsledky. Časová složka má tři etapy výsledků - denní, měsíční a za variabilní (uživatelem definované) období. Dle časových složek se provádí tisky a exporty do nadřazených systémů.

Časové údaje o docházce můžete získat ve dvou základních pohledech. Prvním pohledem je sčítání časových intervalů podle operací zaznamenaných na terminálu. Ne vždy rozdělení podle operací dostačuje. Často je nutné sčítat údaje několika operací do jednoho součtu a naopak započítat jednu operaci do více různých součtů. Abychom mohli sčítat intervaly zpracované docházky, nastavuje se u každé operace docházky, do jaké časové složky se započítává.

Časový interval se může současně započítávat do více časových složek. Například pro operaci "Služební cesta" můžete nastavit, že se má započítávat do časové složky odpracovaná doba a zároveň doba strávená na služebních cestách.

Do seznamu Časových složek vložíte časové složky, kterým nastavíte jejich vlastnosti. Seznam časových složek může obsahovat libovolné množství záznamů.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář Typ časové složky. Formulář se skládá z následujících záložek:

Název

Vlastnosti

Operace

Kalendáře

Typy pracovních poměrů

POZOR: Časové složky, které mají kód od 900, jsou systémové a není možno je mazat.


Formulář typu časových složek - Název

Navigation: Seznamy > Typy časových složek >

Formulář typu časových složek - Název

 Return to chapter overview

Časová složka mzdy představuje výsledný součet započítaných operací za určité období (týden, měsíc, rok) Podle započítaných operací se provede součet vybraných dob (kalendářní a pracovní dny, hodiny). Výsledná hodnota bude upravena podle tohoto nastavení. Správné nastavení časových složek má zásadní vliv na zpracování statistik o docházce.

Typy cas sloz_Nazev

· Kód - označení časové složky, textová položka maximálně 10 znaků. Povinná položka.

· Popis - stručný textový popis časové složky vystihující její použití (např. "Odpracovaná doba", "Odpracováno v noci"). Povinná položka.

· Zkratka - nastavená zkratka bude zobrazena v sestavách.

· Poznámka - libovolný pro vás důležitý údaj.


Formulář typu časových složek - Vlastnosti

Navigation: Seznamy > Typy časových složek >

Formulář typu časových složek - Vlastnosti

 Return to chapter overview

Časovou složku lze měřit v kalendářních dnech, pracovních dnech nebo v hodinách. Můžete tak vyhodnocovat denní, měsíční nebo variabilní období. Variabilní období však můžete vyhodnocovat pouze v tom případě, že toto období máte definované.


Formulář vlastnosti - Zaokrouhlování

Navigation: Seznamy > Typy časových složek > Formulář typu časových složek - Vlastnosti >

Formulář vlastnosti - Zaokrouhlování

 Return to chapter overview

Pro každou "měrnou jednotku" (Kalendářní dny, Pracovní dny, Hodiny) můžete nastavit způsoby zaokrouhlení.

Typy cas sloz_Vlastnosti_Zaokrouhlovani

· Způsob zaokrouhlení - nahoru, dolů, normálně nebo nezaokrouhlovat.

· Zaokrouhlit na - pokud chcete zaokrouhlit na polovinu, zadejte hodnotu 0,5 atp.


Formulář vlastnosti - Rozšířené nastavení

Navigation: Seznamy > Typy časových složek > Formulář typu časových složek - Vlastnosti >

Formulář vlastnosti - Rozšířené nastavení

 Return to chapter overview

V záložce rozšířené nastavení definujeme, zda se budou výsledky (denní, měsíční) této složky přepočítávat či ne a rovněž definujete viditelnost ve výpočtu a výpisu.

Typy cas sloz_Vlastnosti_Rozsirene nastaveni

výpočet časové složky (jen v docházkovém programu)

· Nepřepočítávat denní výsledky - pokud je tato volba aktivována, pak nejsou rušeny a přepočítávány denní výsledky tohoto typu časové složky mzdy při zpracování původní docházky (přepočtu výsledků). Tato volba je například určena pro použití v případě importu denních výsledků z externího zdroje dat, nebo při ručním zadávání denních výsledků výpočtu. Měsíční výsledek je pak normálně vypočten jako součet již existujících denních výsledků.

· Nepřepočítávat měsíční výsledky - pokud je tato volba aktivována, pak nejsou rušeny a přepočítávány měsíční výsledky tohoto typu časové složky mzdy při zpracování původní docházky (přepočtu výsledků). Tato volba je například určena pro použití v případě importu měsíčních výsledků z externího zdroje dat, nebo při ručním zadávání měsíčních výsledků výpočtu.

Rozdělení časové složky (jen v docházkovém programu)

· Manuální editace rozdělení denních výsledků - pokud je tato volba aktivována, pak rozdělení denních výsledků časové složky mzdy není počítáno z rozdělení záznamů zpracované docházky, ale je zadáváno ručně v editaci rozdělení denních výsledků.

· Sčítat denní výsledky dle editace rozdělení DV - pokud je tato volba aktivní, pak se denní výsledek časové složky počítá součtem hodin z manuálně vložené editace rozdělení denního výsledku dané časové složky mzdy. Tato volba se používá, pokud není daná časová složka vypočítána (byla zadávána manuálně).

· Manuální editace rozdělení měsíčních výsledků - pokud je tato volba aktivována, pak rozdělení měsíčních výsledků časové složky mzdy není počítáno z rozdělení denních výsledků, ale je zadáváno ručně v editaci rozdělení měsíčních výsledků.

· Sčítat měsíční výsledky dle editace rozdělení MV - pokud je tato volba aktivní pak se měsíční výsledek dané časové složky počítá součtem hodin z manuální editace rozdělení měsíčního výsledku dané časové složky mzdy. Tato volba se používá, pokud není daná časová složka vypočítána (byla zadávána manuálně).


Formulář vlastnosti - Vzorce

Navigation: Seznamy > Typy časových složek > Formulář typu časových složek - Vlastnosti >

Formulář vlastnosti - Vzorce

 Return to chapter overview

V záložce vzorce je možno definovat vzorcem požadavek na výpočet výsledků dané časové složky.

Typy cas sloz_Vlastnosti_Vzorce

Přestože je možné upravovat vzorce časových složek pomocí níže uvedeného rozhraní, doporučujeme se s úpravami obracet na naše centrum technické podpory, kde vám bude poskytnut návrh řešení.

Adresa: www.helpdesk.ron.cz

Příklad vzorce, jenž zajistí přidělení stravenky dle následujících kritérií.

1. Na stravenku má nárok zaměstnanec, který v pracovní den, nebo den volna odpracoval směnu delší než 6 hodin.

2. Zároveň má zaměstnanec nárok na 2 stravenky, pokud odpracuje ve směně více než 9 hodin.

KDYZ(_currDayType=0 NEBO _currDayType=1;KDYZ(_H_100>6 A _H_100<9;1;KDYZ (_H_100>9;2;0));0)

Vysvětlení: Když(pracovní den nebo den volna;KDYZ(odpracovaná doba je větší než 6 hodin a zároveň menší než 9 hodin tak se počítá 1;Když(odpracovaná doba je větší než 9 hodin tak počítej 2; jinak 0));jinak 0).

Vyberte, kam se má vzorec vkládat. V tomto příkladě bude umístěn do denních výsledků.

Typy cas sloz_Vlastnosti_Vzorce1

V tomto rozhraní je možné snadno vytvořit požadovaný vzorec.


Formulář typu časových složek - Operace

Navigation: Seznamy > Typy časových složek >

Operace

 Return to chapter overview

Určují, které operace se budou pro tuto časovou složku mzdy sčítat. Tyto součty budou zobrazovány ve výpisech a slouží k převodu časových údajů do mzdových programů. Záložka se skládá ze dvou seznamů, mezi nimiž můžete položky přesouvat. V levém seznamu jsou operace, které se do této časové složky nezapočítávají. V pravém seznamu jsou operace, které se do této časové složky započítávají.

Typy cas sloz_Operace


Formulář typu časových složek - Kalendáře

Navigation: Seznamy > Typy časových složek >

Formulář typu časových složek - Kalendáře

 Return to chapter overview

U časové složky máte možnost zobrazit a nastavit seznam příplatků, přesčasů a vzorců. Tato nastavení obsahují i nastavení kalendářů, pro které má být toto nastavení použito.


Formulář kalendáře - Příplatky

Navigation: Seznamy > Typy časových složek > Formulář typu časových složek - Kalendáře >

Formulář kalendáře - Příplatky

 Return to chapter overview

V tomto formuláři se zobrazí seznam nastavených příplatků u vybrané časové složky.

Tlačítkem Novy zaznam1 Nový záznam nebo [image] Editace záznamu se dostanete do Formuláře příplatku.


Formulář kalendáře - Přesčasy

Navigation: Seznamy > Typy časových složek > Formulář typu časových složek - Kalendáře >

Formulář kalendáře - Přesčasy

 Return to chapter overview

V tomto formuláři se zobrazí seznam nastavených přesčasů u vybrané časové složky.

Tlačítkem Novy zaznam1 Nový záznam nebo [image] Editace záznamu se dostanete do Formuláře přesčasu.


Formulář kalendáře - Vzorce

Navigation: Seznamy > Typy časových složek > Formulář typu časových složek - Kalendáře >

Formulář kalendáře - Vzorce

 Return to chapter overview

V tomto formuláři se zobrazí seznam nastavených vzorců u vybrané časové složky.

Tlačítkem Novy zaznam1 Nový záznam nebo [image] Editace záznamu se dostanete do Formuláře vzorce.


Formulář typu časových složek - Typy pracovních poměrů

Navigation: Seznamy > Typy časových složek >

Formulář typu časových složek - Typy pracovních poměrů

 Return to chapter overview

Položka je přístupná pouze v kombinaci použití RON docházky a RON mzdy.


Typy mzdových položek

Navigation: Seznamy >

Typy mzdových položek

 Return to chapter overview

Kromě časových údajů o docházce, můžete zadávat jednoduchou formou mzdové položky (prémie, odměny podle výkonů apod.). Tyto mzdové položky lze tisknou a exportovat do nadřazených systémů.

Mzdové položky nemají žádný vliv na zpracování docházky. Jedná se o rozšiřující funkci. Můžete je použít v případě, že pracovníci, kteří mají přístup k docházkovému systému, mohou zaměstnancům přidělovat příplatky a odměny nevztahující se k docházce (výkonnostní odměny, prémie). Takto zadané příplatky můžete použít při přenosu dat do mzdového systému.

Filtry:

§ Jen součtové mzdové položky - volba filtru aktivuje seznam, ze kterého můžete vybrat typ položky (typ je nastaven v sekci Vlastnosti mzdové položky).

§ Jen mzdové položky sekce - filtr můžete využít, pokud chcete zobrazit položky jen určité mzdové sekce.

§ Vše - zobrazí položky bez platné vlastnosti i položky s aktuálním nastavením.

§ Bez platné vlastnosti - zatržením funkce zobrazíte seznam mzdových položek, které nemají zadáno datum platnosti (záložka Vlastnosti typu mzdové položky).

§ Pouze aktuální nastavení - zobrazí položky s aktuálním nastavením.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář Typ mzdové položky. Formulář má následující záložky: Typ mzdové položky a Vlastnosti typu mzdové položky.


Formulář typu mzdových položek - Typ mzdové položky

Navigation: Seznamy > Typy mzdových položek >

Formulář typu mzdových položek - Typ mzdové položky

 Return to chapter overview

Je potřeba naplnit seznam typů mzdových položek. Typ mzdové položky obsahuje dva základní údaje:

· Kód - povinný údaj. Označení mzdové položky.

· Popis - povinný údaj. Textová informace.

· Povolit zadávání v docházce - zaškrtnutím políčka povolíte zadávání v docházce.

· Poznámka - libovolná doplňující informace ke mzdové položce.


Formulář typu mzdových položek - Vlastnosti typu mzdové položky

Navigation: Seznamy > Typy mzdových položek >

Formulář typu mzdových položek - Vlastnosti typu mzdové položky

 Return to chapter overview

Ve vlastnostech zadáváte k vybranému typu mzdové položky její data platnosti a hodnoty jako je počet jednotek, název jednotky, cenu této jednotky apod.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si tlačítkem Novy zaznam1 Nový záznam formulář Vlastnosti typu mzdové položky.

· Kód typu mzdové položky - číselné označení mzdové položky.

· Platnost od - zadejte datum platnosti od.

· Platnost do - zadejte datum platnosti do.

· Počet jednotek - zadejte počet jednotek. Např. 5 (jednotek) za určitou cenu, poté se cena (za jednotku) vynásobí pěti.

· Název jednotky - zadejte název, např. v Kč.

· Cena za jednotku - zadejte cenu za jednotku.

· Počet jednotek vypočítat vzorcem - počet jednotek lze také zadávat pomocí vzorce, v tom případě zatrhněte položku.

· Cenu za jednotku vypočítat vzorcem - cena za jednotku lze také vypočítat pomocí vzorce, v tom případě zatrhněte položku.

· Součtová - položka je výsledkem součtu jiných mzdových položek.


Typy pracovních poměrů

Navigation: Seznamy >

Typy pracovních poměrů

 Return to chapter overview

Vytvořený číselník druhů pracovních poměrů je součástí instalační sady programu. Další typy pracovních poměrů, jejichž počet není omezen, můžete podle potřeby doplňovat.

Typy pracovnich pomeru_Seznam

Otevřením vybraného typu pracovního poměru se zobrazí formulář Typ pracovního poměru. Ve formuláři vyplňte následující údaje:

Typy pracovnich pomeru_Formular

· Kód - zkrácené označení typu pracovního poměru.

· Popis - podrobnější popis typu pracovního poměru.


Skupiny osob

Navigation: Seznamy >

Skupiny osob

 Return to chapter overview

V celém systému můžete pracovat se zaměstnanci rozdělenými do skupin. Skupiny jsou vytvořeny a definovány pro komunikaci s terminály.

Nepleťte si s pojmem "Typy rozdělení" a "Rozdělení".

Pomocí tohoto členění můžete rychleji vyhledat zaměstnance a zpracovávat jejich data. Jeden zaměstnanec může být současně v několika skupinách. Skupin si můžete vytvořit libovolné množství. Můžete definovat skupiny podle hierarchie firmy (vedení, technici, dělníci) nebo podle pracoviště (kancelář, dílna, sklad apod.). Hledisek pro členění může být libovolné množství. Jeden pracovník může potom být členem skupiny dělníci a zároveň může být ve skupině dílna. Potom záleží jen na Vás, zda chcete zobrazit všechny dělníky nebo všechny zaměstnance pracující v dílně.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář Skupina osob. Formulář Skupina osob je rozdělen do třech záložek: Formulář záznamu, Členové skupiny, Povolené terminály.


Formulář skupiny osob - Formulář záznamu

Navigation: Seznamy > Skupiny osob >

Formulář skupiny osob - Formulář záznamu

 Return to chapter overview

Skupiny osob určují, do kterých terminálů budou načteni její členové. Data vytvoření a zrušení určují období platnosti skupiny v systému. Pokud není datum zrušení vyplněno, je skupina platná.

· Kód - označení skupiny (povinný údaj).

· Popis - textový popis skupiny.

· Datum vytvoření - datum ve formátu DD.MM.RRRR.

· Datum zrušení - datum ve formátu DD.MM.RRRR.

· Nesynchronizovat - pokud je volba nesynchronizovat u skupiny aktivována, pak je při synchronizaci skupin osob podle zvoleného rozdělení osob, daná skupina synchronizace vyloučena.


Formulář skupiny osob - Členové skupiny

Navigation: Seznamy > Skupiny osob >

Formulář skupiny osob - Členové skupiny

 Return to chapter overview

Členové jsou určeni v záložce "Členové skupiny". Každý člen má určeno datum, od kdy je členem dané skupiny. Osoba může mít i několik členství. V takovém případě se započítává vždy jen jednou. Při vložení mezi seznam členů je automaticky nastaveno datum platnosti na aktuální den. Pro rychlejší práci používejte filtry a rychlé vyhledávání.

Formulář obsahuje dva seznamy. V levém seznamu jsou všichni pracovníci, v pravém seznamu jsou pracovníci vybraní jako členové skupiny. Důležitými údaji v pravém seznamu jsou data od kdy, do kdy je pracovník členem této skupiny. Pro přesun mezi seznamy se používají šipky umístěné mezi seznamy.

Opačným pohledem na nastavení členů skupin se můžete podívat ve formuláři pracovníka na jeho členství ve skupinách. Tam uvidíte, ve kterých skupinách je zaměstnanec zařazen.


Formulář skupiny osob - Povolené terminály

Navigation: Seznamy > Skupiny osob >

Formulář skupiny osob - Povolené terminály

 Return to chapter overview

Formulář obsahuje dva seznamy. V levém seznamu jsou nepovolené terminály, v pravém seznamu jsou povolené terminály.

Povolené terminály určují, do kterých terminálů budou načteni členové této skupiny.

Pokud nastavujete skupinu, která nemá vliv na definici přístupu k terminálům, nenastavujte v této záložce nic.

Přehlednější nastavení terminálu provedete ve formuláři terminálu, kde ze všech skupin nastavíte, které skupiny mohou nebo nemohou terminál používat.

Používá-li se terminál k přístupům, je možno navolit detailní nastavení přístupu terminálu tlačítkem [image] Podrobné nastavení přístupu.

· Terminál - zvolte terminál.

· Platnost od - zadejte datum platnosti od.

· Platnost do - zadejte datum platnosti do.

· Přístup - na výběr máte z následujících možností:

o Úplný přístup - povoluje každému zaměstnanci ve skupině neomezený přístup pro tento terminál. Přístup je povolen pro každý den a každou dobu.

o Přístup podle kalendáře - definuje dobu před a po směně, po kterou má osoba přístup. Směna je určena podle přiřazeného kalendáře osobě a definované směny v den přístupu.

o Přístup pro jednotlivé dny - definuje přístup skupiny pro daný den v týdnu a časový úsek určený ve sloupcích "Čas od" a "Čas do". Pro jeden den je možno určit více intervalů, které se mohou vzájemně překrývat. Nový záznam vytvoříte klávesou "Insert" nebo stiskem klávesy "dolů" na posledním řádku.


Seznam fotografií a obrázků

Navigation: Seznamy >

Seznam fotografií a obrázků

 Return to chapter overview

Seznam fotografií a obrázků je seznamem, který je napojen na formulář zaměstnance. To znamená, že při vložení obrázku do formuláře zaměstnance program automaticky vyplní řádek a přiřadí fotografii v seznamu fotografií a obrázků. Nad seznamem je filtr, dle kterého si můžete zobrazit fotografii dotyčného zaměstnance.

Seznam fotografii a obrazku

Novou fotografii/obrázek vložíte kliknutím na tlačítko [image] Nový záznam a v otevřeném formuláři Fotografie (obrázek) vyplníte potřebné údaje. Záznamy můžete upravovat tlačítkem [image] Editace záznamu.

Seznam fotografii a obrazku_Formular

· Popis - povinný údaj. Vepište název fotografie/osoby.

· ID - po potvrzení zadaných údajů program ID obrázku doplní.

· Červený rámeček - dvojklikem v červeném rámečku zobrazíte okno, ve kterém vyberete požadovaný obrázek.

· Typ - po vybrání fotografie/obrázku se zobrazí její typ (png, jpg).


Typy rozdělení

Navigation: Seznamy >

Typy rozdělení

 Return to chapter overview

Číselník typů rozdělení slouží k vytvoření různých organizačních schémat v organizaci. Je výhodný také při tvorbě sestav, kdy můžete využít dělení dle dalších kritérií. Jednotlivým typům rozdělení můžete přiřadit uživatelsky definovaná rozdělení v menu "Seznamy/Rozdělení".

POZOR: Nezaměňujte se seznamem v menu "Seznamy/Skupiny osob", který slouží k vložení členů do povolených terminálů a dále pro zpřehlednění práce v programu. Samozřejmě můžete stejné skupiny jako ve Skupinách osob definovat i pro Typy rozdělení.

Nový typ rozdělení vložíte kliknutím na tlačítko [image] Nový záznam a v otevřeném formuláři Typ rozdělení vyplníte potřebné údaje. Záznamy můžete upravovat tlačítkem [image] Editace záznamu.

Typy rozdeleni formular typ rozdeleni

· Kód - doplňte číselný kód rozdělení.

· Popis - specifikujte typ rozdělení.

· Aktivní - pokud je typ rozdělení aktivně využíván (je tedy platný), zatrhněte.

Další volby se týkají ochrany před vznikem chyb:

· Zakázat duplicitní záznamy - zaškrtnutím této položky zakážete překrývání platností rozdělení s tímto typem rozdělení. To znamená, že v jeden den budete moci zaměstnanci přiřadit pouze jedno rozdělení.

· Zakázat mezery - aktivováním kolonky zamezíte vzniku časových mezer mezi záznamy platností rozdělení s tímto typem rozdělení. Pokud bude mít zaměstnanec příslušnost k jednomu rozdělení ukončenou např. k 1. 3. 2009 a počátek přiřazení k dalšímu např. od 1. 6. 2009, mohla by vzniknout časová mezera, čemuž můžete zaškrtnutím položky zabránit.

· Zakázat změny v uzavřeném období - výběrem položky program neumožní provádět změny příslušnosti zaměstnance k jinému rozdělení v uzavřených obdobích.

POZOR: Pokud již máte v databázi zavedeny záznamy, u kterých vznikla časová mezera nebo duplicita, a zároveň chcete aktivovat uvedené kontroly, budete na chybné záznamy upozorněni. Jestliže zobrazené chyby neodstraníte, program neumožní požadované kontroly zapnout.

Podobná opatření jsou zavedena také při přidělování rozdělení v kartě zaměstnance, v záložce Rozdělení.


Rozdělení

Navigation: Seznamy >

Rozdělení

 Return to chapter overview

Seznam slouží k vytváření rozdělení ve firmě. Například pro typ rozdělení Pracoviště zadáte seznam pracovišť. Každý zaměstnanec musí být přiřazen k nějakému rozdělení. Větší firmy mohou vytvořit složitější organizační schéma.

Základními předdefinovanými typy rozdělení jsou např. mzdové středisko, personální středisko, skladové středisko, výplatní místo atd. Přiřaďte rozdělení k jednotlivým typům.

Seznam zobrazí záznamy odpovídající vybranému typu.

Rychlý filtr:

§ Typ rozdělení - pokud potřebujete vyfiltrovat zaměstnance podle určitého druhu rozdělení, vyberete jej z nabízeného seznamu. V záložce Členové rozdělení se nachází seznam přiřazených zaměstnanců. Číselník typů rozdělení můžete doplňovat v menu "Seznamy/Číselníky/Typy rozdělení".

Můžete samozřejmě vytvořit vlastní rozdělení. Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale tlačítkem [image] Nový záznam nebo tlačítkem [image] Editace záznamu otevřete formulář Rozdělení, který má záložky: Formulář záznamu, Členové rozdělení a Dokumenty. Jednotlivé záznamy vyplňujte podle následujícího popisu.


Formulář rozdělení - Formulář záznamu

Navigation: Seznamy > Rozdělení >

Formulář rozdělení - Formulář záznamu

 Return to chapter overview

Formulář obsahuje identifikační údaje o rozdělení.

Rozdeleni formular zaznamu

· Kód - povinný údaj. Vyberte přijatelný kód, podle kterého se budete snadno orientovat.

· Kód nadřazeného umístění - kód rozdělení, které je nadřazené tomuto rozdělení.

· Popis - povinný údaj. Popište rozdělení.

· Vedoucí - vedoucí rozdělení.

· Datum vytvoření - povinná položka. Vložte datum vytvoření.

· Datum zrušení - vložte datum zrušení.

· Ulice - doplňte specifikující údaje, pokud se rozdělení nachází na určité adrese (např. pracoviště).

· Město / PSČ / Obec / Stát - výběrové položky. Můžete upravovat stávající nebo doplňovat nové záznamy, a to kliknutím na podtržený název.

· Telefon / Fax / e-mail - v případě potřeby uveďte kontaktní informace.

Další funkce jsou v současnosti dostupné v rámci docházkového systému ADS.

Po vyplnění kolonek, uložte data tlačítkem [image] v dolní části formuláře.


Formulář rozdělení - Členové rozdělení

Navigation: Seznamy > Rozdělení >

Formulář rozdělení - Členové rozdělení

 Return to chapter overview

Členství v rozdělení slouží k rozdělení osob podle různých dělení firmy (např. mzdové středisko, dílna, zakázka, apod.). Záložka je rozdělena na dva seznamy. V levém seznamu jsou všichni pracovníci, v pravém seznamu jsou zaměstnanci zařazení do tohoto rozdělení. Položky mezi seznamy můžete přesouvat. Každý člen má určeno datum, od kdy je členem dané skupiny. Při vložení do seznamu členů je automaticky nastaveno datum platnosti na aktuální den. Proto pokud chcete počátek používání rozdělení posunout na jiné datum, nezapomeňte toto datum přepsat.

Rozdeleni clenove rozdeleni

Osoby pro výběr členů:

Seznam osob je tvořen nepřiřazenými zaměstnanci. Filtry lze kombinovat:

§ Všichni - zobrazí všechny zaměstnance, kteří nejsou členy žádného rozdělení.

§ Aktivní PP - pouze zaměstnanci v aktivním pracovním poměru.

§ Nepřiřazení - seznam zaměstnanců, kteří nejsou členy vybraného rozdělení.

Členové:

Členy rozdělení přiřadíte pomocí tlačítek C_Sipka seda vpravo, C_Sipka seda dvojita vpravo ve středovém panelu. Před samotným přesunem (máte-li takto nastaven program v Nastavení aplikace, viz Nastavení aplikace/Vlastnosti formulářů) se vás program zeptá, zda chcete opravdu přidat označené osoby mezi členy. Dávejte pozor na datum přiřazení!

Rozdeleni nastaveni datumu pro prirazeni rozdeleni

· Pokračovat v posledním záznamu - existuje-li neukončený záznam pro daný typ rozdělení, přiřazením nového rozdělení se naplní pole Platnost do u platného rozdělení k předchozímu dni (zohledňuje se datum zadané v poli Platnost od, které můžete podle potřeby měnit).

POZOR: Program automaticky ukončí všechna předchozí rozdělení v rámci stejného typu rozdělení.

· První záznam podle datumu nástupu - nemá-li zaměstnanec žádný vytvořený záznam pro daný typ rozdělení, vyplní se pole Platnost od podle data nástupu.

· Platnost do - zatržením se aktivuje položka pro ruční vložení data ukončení platnosti.

Záznamy můžete filtrovat:

§ Všichni - zobrazí se všichni zaměstnanci vybraného rozdělení (i v ukončeném pracovním poměru).

§ Aktivní - pouze zaměstnanci, kteří mají nebo měli přiřazeno dané rozdělení, v aktivním pracovním poměru.

§ Neaktivní - seznam zaměstnanců, kteří nejsou v aktivním pracovním poměru.

Rozdělení můžete zaměstnanci přiřadit také v jeho kartě, v záložce Rozdělení.


Formulář rozdělení - Dokumenty

Navigation: Seznamy > Rozdělení >

Formulář rozdělení - Dokumenty

 Return to chapter overview

Záložka slouží k přiřazení, popřípadě odebrání stávajících dokumentů, které jsou na daném středisku vyžadovány.

Okno je rozděleno na dva seznamy, mezi kterými můžete dokumenty přesouvat pomocí šipek. Ve sloupci Nevybrané záznamy označíte požadovaný záznam a pomocí ikony C_Sipka seda vpravo Šipka přesunete do sloupce Vybrané záznamy.


Formulář rozdělení - Kategorie

Navigation: Seznamy > Rozdělení >

Formulář rozdělení - Kategorie

 Return to chapter overview

Ve formuláři k rozdělení přiřadíte kategorii nebo můžete ve Formuláři kategorie - Rozdělení zařadit rozdělení do požadované kategorie.

POZNÁMKA: Pokud je použita MDB databáze nejsou Kategorie dostupné.

Záložka je rozdělena na dva seznamy. V levém seznamu jsou Nepřiřazené kategorie, v pravém seznamu jsou kategorie zařazené do vybraného rozdělení. Položky mezi seznamy můžete přesouvat.


Typy umístění

Navigation: Seznamy >

Typy umístění

 Return to chapter overview

Program nabízí definovaný seznam typů umístění, který lze využít ke členění organizace. Jednotlivým typům můžete poté přiřadit umístění, která založíte v menu "Seznamy/Umístění".

Můžete samozřejmě zadat vlastní typ umístění kliknutím na tlačítko [image] Nový záznam. Jednotlivé vytvořené položky lze měnit tlačítkem [image] Editace záznamu.

Otevřením vybraného typu umístění se zobrazí formulář Typ umístění, který má záložky Formulář záznamu a Přiřazené objekty.


Formulář typu umístění - Formulář záznamu

Navigation: Seznamy > Typy umístění >

Formulář typu umístění - Formulář záznamu

 Return to chapter overview

Formulář poskytuje přehled základního nastavení daného typu úrovně:

Typy umisteni formular zaznamu

· Kód - doplňte číselný kód typu umístění.

· Popis - specifikujte typ umístění.

· Úroveň - číselná hodnota určující postavení v hierarchii typů umístění.

· Obrázek - kliknutím na podtržené označení pole se otevře okno, v němž vyberte obrázek typu umístění v podporovaném formátu.


Formulář typu umístění - Přiřazené objekty

Navigation: Seznamy > Typy umístění >

Formulář typu umístění - Přiřazené objekty

 Return to chapter overview

Seznam objektů spadajících pod vybraný typ umístění:

Typy umisteni formular prirazene objekty

Po stisku tlačítka [image] Nový záznam nebo tlačítka [image] Editace záznamu se dostanete do formuláře Umístění.


Umístění

Navigation: Seznamy >

Umístění

 Return to chapter overview

Seznam umístění (budov, podlaží, místností firmy apod.) poskytuje přehled fyzického rozdělení firmy. V případě, že budete toto menu využívat, musíte vložit potřebné informace.

Tlačítkem [image] Nový záznam nebo [image] Editace záznamu otevřete formulář Umístění, ve kterém vyplníte následující položky:

Umisteni formular umisteni

· Kód - povinné označení položky.

· Typ umístění - vyberte vhodný typ z předdefinovaného seznamu, který můžete rozšiřovat.

· Popis - podrobnější popis umístění.

· Používán od - zadejte (ve formátu DD.MM.RRRR) nebo zvolte datum v kalendáři.

· Používán do - datum vymezující konec používání daného umístění.

· Určení - nepovinná textová položka.

· Ulice / Město / PSČ / Stát - doplňte adresu.

· Telefon / Fax / E-mail - v případě potřeby uveďte kontaktní informace.

· Patro / Číslo místnosti / Kapacita místnosti / Vybavení místnosti - specifikace místnosti.


Typy kategorií

Navigation: Seznamy >

Typy kategorií

 Return to chapter overview

Číselník typů kategorií slouží k vytvoření různých organizačních schémat v organizaci. Jednotlivým typům kategorií můžete přiřadit uživatelsky definované kategorie v menu Seznamy -> Kategorie.

POZNÁMKA: Pokud je použita MDB databáze, nejsou Kategorie dostupné.

Nový Typ kategorie vytvoříte kliknutím na tlačítko [image] Nový záznam. Jednotlivé vytvořené položky lze měnit tlačítkem [image] Editace záznamu. Otevře se formulář Typ kategorie, ve kterém zadáte následující položky:

· Kód - doplňte kód typu kategorie.

· Popis - specifikujte typ kategorie.

· Poznámka - libovolná doplňující informace k typu kategorie.


Kategorie

Navigation: Seznamy >

Kategorie

 Return to chapter overview

Seznam slouží k vytváření kategorií ve firmě. Kategorie může například spojovat více rozdělení napříč různými typy rozdělení.

POZNÁMKA: Pokud je použita MDB databáze, nejsou Kategorie dostupné.

Rychlý filtr:

§ Jen typ kategorie - v seznamu se zobrazí kategorie přiřazené vybranému typu. Číselník typů kategorií můžete doplňovat v menu Seznamy -> (Číselníky) -> Typy kategorií.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale tlačítkem [image] Nový záznam nebo tlačítkem [image] Editace záznamu otevřete formulář Kategorie, který má záložky:

Základní údaje

Rozdělení

Zaměstnanci


Formulář kategorie - Základní údaje

Navigation: Seznamy > Kategorie >

Formulář kategorie - Základní údaje

 Return to chapter overview

Formulář obsahuje identifikační údaje o kategorii.

Kategorie_Formular Zakladni udaje

· Kód - povinný údaj. Vyberte přijatelný kód, podle kterého se budete snadno orientovat.

· Popis - povinný údaj. Popište vytvářený záznam.

· Typ kategorie - z nabídky vyberte typ kategorie. Typy kategorií vytvoříte v menu Seznamy -> (Číselníky) -> Typy kategorií.

· Poznámka - libovolná doplňující informace o vytvářeném záznamu.


Formulář kategorie - Rozdělení

Navigation: Seznamy > Kategorie >

Formulář kategorie - Rozdělení

 Return to chapter overview

Ve formuláři zařadíte rozdělení do požadované kategorie nebo ve Formuláři rozdělení - Kategorie k rozdělení přiřadíte kategorii.

Záložka je rozdělena na dva seznamy. V levém seznamu jsou Nepřiřazená rozdělení, v pravém seznamu jsou rozdělení zařazená do vybrané kategorie. Položky mezi seznamy můžete přesouvat.

V okně máte možnost záznamy filtrovat podle typu rozdělení a stanovit, jestli rozdělení mají být platná k aktuálnímu nebo jinému dni.


Formulář kategorie - Zaměstnanci

Navigation: Seznamy > Kategorie >

Formulář kategorie - Zaměstnanci

 Return to chapter overview

Po přiřazení rozdělení se ve formuláři zobrazí osoby, které jsou v tomuto rozdělení.


Typy dokumentů

Navigation: Seznamy >

Typy dokumentů

 Return to chapter overview

Seznam typů dokumentů, které budete u zaměstnanců evidovat. Vytvořený číselník bude sloužit jako třídící kritérium přiřazených dokumentů zaměstnancům.

Editací nebo zvolením ikony pro vložení nového záznamu se otevře formulář Typ dokumentu, který obsahuje tyto položky:

Dokumenty_Typ dokumentu formular

· Kód - povinné evidenční označení typu dokumentu.

· Popis - stručná specifikace daného typu dokumentu. Povinná položka.

· Kategorie dokumentu - z nabídky vyberte kategorii dokumentu (například Dokument osoby, Dokument napomenutí apod.). V závislosti na typu vybrané položky se případně aktivují další položky ve formuláři Dokument osoby (menu "Dokumenty/Dokumenty osob/Základní údaje"). Pokud nastavíte např. kategorii "Dokument vzdělání", zobrazí se ve formuláři dokumentu (typu s touto nastavenou kategorií) dodatečné pole "Vzdělání".

· Řízený dokument - u dokumentu, který podléhá řízení, zatrhněte políčko.

· Zobrazit na intrawebu - pokud je dokument možné distribuovat na intrawebu, zaškrtněte políčko. Poté se na intrawebu zobrazí všechny dokumenty s přiřazeným typem, u kterého je toto pole zaškrtnuté.

· Distribuce - distribuovat lze pouze řízené dokumenty a dokumenty s přiřazenou kategorií dokument typu pracovního místa a dokument rozdělení! Z nabídky vyberte požadované:

o Dokument bez distribuce

o Distribuovaný dokument, u kterého se vyžaduje potvrzení o přečtení

o Distribuovaný dokument, u kterého se nevyžaduje potvrzení o přečtení.


Obecné dokumenty

Navigation: Seznamy >

Obecné dokumenty

 Return to chapter overview

Seznam je vytvořen z dokumentů, které ve firmě evidujete:

Filtr:

§ Typ dokumentu - v seznamu se zobrazí dokumenty vybraného typu.

Nový Dokument vložíte kliknutím na tlačítko [image] Nový záznam a v otevřeném formuláři Dokument vyplníte potřebné údaje. Záznamy můžete upravovat tlačítkem [image] Editace záznamu. Formulář má následující záložky: Základní údaje a Historii rozesílání.


Formulář dokumentu - Základní údaje

Navigation: Seznamy > Obecné dokumenty >

Formulář dokumentu - Základní údaje

 Return to chapter overview

Ve formuláři zadáte základní údaje o dokumentu a cestu k souboru.

DOCH_Obecne dokumenty_Formular Dokument

· Popis - povinná definice daného dokumentu.

· Typ - povinný údaj. Z nabídky zvolte požadovaný typ dokumentu.

Nový Dokument vložíte kliknutím na tlačítko [image] Nový záznam a v otevřeném formuláři Dokument s definovanou platností vyplníte potřebné údaje.

DOCH_Obecne dokumenty_Formular Dokument_Dokument s definovanou platnosti

· Datum od - povinný údaj. Zadejte datum přiřazení nebo založení dokumentu.

Dokument může být definovaný právě jednou ze 3 možností:

· Odkaz - do řádku zadejte (webový) odkaz na soubor. Pomocí ikony [image] Otevřít stránky s definovaným odkazem stránky otevřete.

· Cesta k souboru - pomocí ikony C_Cesta k souboru Cesta k souboru zadejte cestu k uloženému souboru nebo načtěte soubor přímo do databáze.

 | Otevřít - tlačítko slouží pro náhled na vybraný dokument. Pokud soubor nelze správně zobrazit, zkontrolujte zadaný odkaz nebo kontaktujte vašeho správce. Pokud soubor nenačtete do databáze a použijete propojení pomocí odkazu, musí soubor zůstat uložený na disku počítače.
 | Zrušit - kliknutím na toto tlačítko se objeví dotaz. Jestliže ho potvrdíte, dokument již nebude v databázi, ani nebude zadán odkaz na soubor.
C_Nacist do databaze | Načíst do databáze - tlačítko vyvolá dotaz, zda opravdu chcete nahradit dokument v databázi jiným dokumentem. Po potvrzení najděte požadovaný dokument a otevřete jej. Tím se dokument zkopíruje do databáze. Současně se zobrazuje, jméno souboru a kolik místa uložený soubor zabírá (Velikost v databázi). I když soubor z disku smažete, dokument bude stále k dispozici v databázi programu.
C_Ulozit do souboru | Uložit do souboru - pro export do libovolného souboru na disku. Postupujte obdobně jako u tlačítka Načíst do databáze.


Formulář dokumentu - Historie rozesílání

Navigation: Seznamy > Obecné dokumenty >

Formulář dokumentu - Historie rozesílání

 Return to chapter overview

V záložce naleznete historii rozeslaných dokumentů.

Dokumenty_Seznam dokumentu Formular Historie rozesilani


XML formuláře

Navigation: Seznamy >

XML formuláře

 Return to chapter overview

V menu se provádí nastavení předávacího procesu, podle kterého se v RON portálu předávají XML šablony. Tyto XML šablony jsou vytvářeny na zakázku.

Seznam obsahuje následující položky:

XML šablony

Vyplněné XML šablony

Předávací proces

Kategorie pracovních míst


XML šablony

Navigation: Seznamy > XML formuláře >

XML šablony

 Return to chapter overview

V seznamu se nachází šablony XML formulářů pro intraweb. Tyto šablony jsou vytvářeny na zakázku.


Vyplněné XML šablony

Navigation: Seznamy > XML formuláře >

Vyplněné XML šablony

 Return to chapter overview

V seznamu najdete šablony, se kterými se pracuje v intrawebu. Nad seznamem vyplněných XML šablon můžete použít rychlé filtry pro lepší orientaci v seznamu.

Vyplnene XML formulare_Seznam

Formulář šablony otevřete tlačítkem [image] Editace záznamu.

Vyplnene XML formulare_Formular

Šablony mohou mít stavy Rozpracováno, Zamítnuto, Vráceno a Uzavřeno. Z vyplněného formuláře se dozvíte, na jaké úrovni předávacího procesu se šablona nachází a který řešitel ji má zpracovat. Stiskem odkazu XML ... se dostanete do XML formuláře.

Vyplnene XML formulare_XML formular


Předávací proces

Navigation: Seznamy > XML formuláře >

Předávací proces

 Return to chapter overview

Předávací proces obecně představuje definici posloupnosti předávání mezi kategoriemi pracovních míst. Nejdříve musíme určit počáteční (vstupní) kategorii pracovního místa (které bude hodnoceno), následně konkrétní posloupnost, která je vždy svázaná s danou vstupní kategorií. Před definicí předávacího procesu je nutné mít vytvořené kategorie pracovních míst jako základní elementy předávacího procesu. Tuto funkcionalitu využijete například při hodnocení zaměstnanců. Hodnocení se vyplňuje, předává a schvaluje na základě předávacího procesu podle pracovního místa uživatele a hierarchie (například středisek).

V případě, že máme vytvořené kategorie pracovních míst, můžeme přistoupit k definici předávacího procesu. Nový záznam vložíte kliknutím na tlačítko [image] Nový záznam a v otevřeném formuláři Předávací proces vyplníte potřebné údaje. Záznamy můžete upravovat tlačítkem [image] Editace záznamu.

Kromě základních identifikačních a popisných údajů definujeme pořadí předávání (formuláře jednotlivým zaměstnancům pro zpracování hodnocení), a to kliknutím na tlačítko [image] Nový záznam (v červeném rámečku na obrázku).

Predavaci proces_Formular_Poradi predavani

Vytvořený předávací proces má v praxi následující význam:

Při aplikaci předávacího procesu na pracovní místa sdružená do vstupní kategorie Prodejce (v jehož rámci budou osoby na pracovním místě, které spadá do vytvořené vstupní kategorie PM, podléhat hodnocení) budou první v pořadí předávaní všechny osoby na pracovních místech sdružených do kategorie Zástupce vedoucího, dalšími v pořadí pak budou osoby na pracovních místech v kategorii Vedoucí prodejny, atd. až po kategorii pracovního místa Finanční ředitel. Definici pořadí posloupnosti lze prostřednictvím šipek v pravé části okna jednoduše měnit. Každá kategorie může být zastoupena vícekrát – na různé úrovni pořadí.

Ke každé vstupní kategorii pracovního místa se definuje jedinečná posloupnost předávání.


Kategorie pracovních míst

Navigation: Seznamy > XML formuláře >

Kategorie pracovních míst

 Return to chapter overview

Kategorie pracovních míst představuje spojení libovolných typů pracovních míst (nebo i jednoho) do skupiny, která představuje elementární krok v rámci předávacího procesu. Číselník kategorií pracovních míst je uživatelský seznam, to znamená, že si jej vytvoříte sami na základě vašich potřeb. Kategorie pracovních míst je nutné nadefinovat před definicí předávacího procesu.

Kategorie pracovnich mist

Nový údaj vytvoříte ikonou [image] Nový záznam a v zobrazeném formuláři Kategorie pracovních míst vyplníte potřebné údaje v záložkách Základní údaje a Pracovní místa.


Formulář kategorie pracovního místa - Základní údaje

Navigation: Seznamy > XML formuláře > Kategorie pracovních míst >

Formulář kategorie pracovního místa - Základní údaje

 Return to chapter overview

Ve formuláři zadejte základní údaje o kategorii pracovního místa.

Kategorie pracovnich mist_Zakladni udaje

· Kód - uveďte kód pro kategorii.

· Popis - textová položka pro označení dané kategorie.


Formulář kategorie pracovního místa - Pracovní místa

Navigation: Seznamy > XML formuláře > Kategorie pracovních míst >

Formulář kategorie pracovního místa - Pracovní místa

 Return to chapter overview

Ve formuláři přiřadíte pracovní místa dané kategorii pomocí šipek umístěných mezi seznamy.

Kategorie pracovnich mist_Pracovni mista

Tlačítkem [image] Editace záznamu se dostanete do formuláře Pracovní místo.


Vzkazy

Navigation: Seznamy >

Vzkazy

 Return to chapter overview

Sekce slouží k přijímání a odesílání vzkazů, hlášení změn údajů o zaměstnanci apod. Tato položka menu je propojena s aplikací RON portál.

Menu obsahuje následující položky:

Vzkazy

Příjemci vzkazů


Vzkazy

Navigation: Seznamy > Vzkazy >

Vzkazy

 Return to chapter overview

Seznam zobrazuje odeslané a přijaté vzkazy. Řádky mají různé barevné odlišení podle toho, zda se jedná o vzkaz zpracovaný, pro osobu nebo od zaměstnance apod. Toto barevné nastavení lze měnit pomocí tlačítka Editor nastavení vzhledu. Vzkazy máte možnost vytvářet v programu Mzdy a v aplikaci Intraweb.

Rychlé filtry:

§ Jen příjemce - v případě aktivování tohoto filtru se zobrazí seznam se vzkazy vybraného příjemce.

§ Jen nezpracované - zatržením kolonky se zobrazí nezpracované vzkazy (ve formuláři Vzkaz nemají zatrženo pole Zpracováno).

Vkládání, úpravu nebo odpověď na vzkaz provádějte ve formuláři Vzkaz, který otevřete tlačítkem pro editaci nebo pro vložení nového záznamu.

· Datum odeslání - automatické zobrazení data a času vytvoření vzkazu.

· Zpracováno - pokud je vzkaz zpracován, pole zatrhněte. Návaznost na rychlý filtr v Seznamu vzkazů.

· Odesílatel - ze seznamu, který vytvoříte v menu "Personalistika/Vzkazy/Příjemci vzkazů", vyberte odesílatele vzkazu.

· Zobrazit na intrawebu - zatrhnutím políčka se vzkaz zobrazí i na intrawebu, kde bude zobrazen příjemce/odesílatel, předmět zprávy, obsah vzkazu a případné vyjádření.

· Předmět - uveďte předmět vzkazu, například: Přijďte si vyzvednout výplatní lístky.

· Příjemce - zvolte příjemce pro doručení vzkazu:

o Zpráva určená pro všechny zaměstnance - vzkaz se zobrazí všem zaměstnancům.

o Zpráva určená pro jednu osobu - zpráva se odešle vybrané osobě ze seznamu zaměstnanců.

o Zpráva určená pro skupinu osob (rozdělení) - z nabídky zvolte typ rozdělení a rozdělení.

o Zpráva určená pro vybraného příjemce - vyberte příjemce, kterému chcete odeslat vzkaz. Seznam vytvoříte v menu "Personalistika/Vzkazy/Příjemci vzkazů".

· Prostor pro vzkaz

· Vyjádření - můžete se vyjádřit k dané zprávě. Pouze v případě volby Příjemce: Zpráva určená pro jednu osobu se v intrawebu zobrazí také možnost vložení vyjádření k přijatému vzkazu. Pokud se jedná o vzkaz hromadný, nelze v intrawebu vložit vyjádření jednotlivce.

· Poznámka (nezobrazuje se v intrawebu) - poznámka se nezobrazuje v intrawebu.

Vzkazy_Vzkazy v intrawebu


Příjemci vzkazů

Navigation: Seznamy > Vzkazy >

Příjemci vzkazů

 Return to chapter overview

Seznam příjemců vzkazů je uživatelský seznam, to znamená, že si jej vytvoříte sami na základě vašich potřeb.

Nového příjemce vytvoříte ikonou [image] Nový záznam. V seznamu se zobrazí prázdný řádek (červeně ohraničený), ve kterém vyplníte následující pole:

· Kód - uveďte kód, např.: personalni.

· Popis - textová položka pro označení daného příjemce, např.: Personální oddělení.


Terminály

Navigation: »No topics above this level«

Terminály

 Return to chapter overview

Základem docházkového systému je sběr dat. Ke sběru dat slouží docházkové a přístupové terminály. Software ADS spolupracuje s řadou tuzemských i zahraničních výrobců docházkových a přístupových terminálů.

Menu Terminály slouží již pro samotnou práci s terminály, generování a načítání dat a obsahuje následující položky:

Terminály

Typy identifikačních médií

Identifikační média

Operace terminálů

Generování nastavení terminálů

Nastavení data a času terminálů

Načtení dat z terminálů

Stav terminálů

Import LOG souboru terminálu


Terminály

Navigation: Terminály >

Terminály

 Return to chapter overview

Seznam terminálů obsahuje všechny připojené docházkové a přístupové terminály. Každý terminál má nastaveny podrobné vlastnosti.

Vzhledem k tomu, že docházkový systém je schopen spolupracovat s více typy terminálů různých výrobců, dbejte na správné nastavení parametrů komunikace. Tyto parametry jsou popsány v příručce ke konkrétnímu typu terminálu.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář Terminál. Jelikož potřebných údajů o terminálu je mnoho a není možné je zobrazit v jednom formuláři, je rozdělen do následujících záložek:

Terminál

Parametry

Spínání relé

E-mail

Operace terminálu

Časy operací

Činnosti

Zakázky

Výrobky

Přístupy

Skupiny

Osoby

Operace skupiny

Seznam osob

Stav

V levé části je seznam záložek (částí formuláře) a v pravé části je zobrazen obsah zvolené záložky. Kliknutím na zvolenou záložku se v pravé části zobrazí veškeré údaje odpovídající této záložce.


Formulář terminálu - Terminál

Navigation: Terminály > Terminály >

Formulář terminálu - Terminál

 Return to chapter overview

V tomto formuláři nastavíte základní identifikaci a vlastnosti terminálu.

· Kód - označení terminálu, musí se shodovat s fyzickým číslem terminálu. Pokud nastavíte špatně kód terminálu, nepodaří se zprovoznit komunikaci programu s terminálem.

· Popis - textový popis terminálu, název nebo umístění.

· Text na terminálu - zadejte text, který bude zobrazen na terminálu (např. Zvolte operaci).

· Určení terminálu - terminály jsou rozděleny na několik základních typů, na základě kterých se záznamy z terminálu zaznamenávány do různých seznamů.

Samostatné

1. Docházkový - záznamy z terminálu mají vliv pouze na docházku.

2. Průchodový - záznamy z terminálu nemají vliv na docházku ani výrobu, ale pouze na průchody.

3. Výrobní - záznamy z terminálu mají vliv pouze na výrobu, nikoliv na docházku či průchod.

Kombinované

4. Docházkový a průchodový - záznamy z terminálu mají vliv na docházku i průchody, ne však na výrobu.

5. Docházkový a výrobní - záznamy z terminálu nemají vliv na průchody, ale pouze na docházku a výrobu.

· Umístění - pokud máte definovány objekty firmy, můžete nastavit objekt, čímž určíte umístění terminálu v areálu firmy. Nastavení této položky není povinné.

· Rozdělení - z nabídky vyberte rozdělení. V menu Systém -> Nastavení aplikace -> Společné nastavení -> Terminály nastavíte typ rozdělení, který se bude nabízet u terminálům.

· Typ ID média - z nabídky vyberte typ ID média. Nový typ identifikačního média vytvoříte v menu Terminály -> Typy identifikačních médií.

· Používat kód média č. 2 - pokud jste si v nastavení aplikace zatrhli, že chcete používat 2 kódy ID médií, tak máte tuto kolonku aktivní. Zde si můžete zvolit, který ze dvou kódů chcete používat na daném terminálu. Nastavení více ID médií provedete v menu Systém/Společné nastavení - ID média.

· Ignorovat neznámá ID média - při načítání historie operací z terminálu nebude program hlásit nenalezená / nepřiřazená ID média.

· Bez monitorování - pokud nechcete monitorovat zaměstnance, kteří používají tento terminál, zaškrtněte tuto položku.

· Negenerovat datum a čas - při generování nastavení terminálu se nebude do terminálu posílat aktuální datum a čas.

· Negenerovat přístupová práva/saldo - zaškrtnutím této volby se nebudou do terminálu odesílat salda. Závisí pouze na vlastnostech typu terminálu, jestli umí zpracovávat a poskytovat pracovníkům údaje o saldu odpracované doby.

· Negenerovat biometrické šablony - při zaškrtnutí této volby nebudou do terminálu generovány šablony s otisky prstů.

· Použít jen ID média daného typu - po zatrhnutí pole, bude terminál přijímat jen ID média vybraného typu.

terminaly16

Test spojení - po stisku tlačítka se program pokusí podle nastavených parametrů ověřit funkčnost komunikace mezi terminálem a počítačem. Funkci nepodporují všechny typy terminálů, proto se u některých typů můžete setkat s informací, že požadovaná funkce není podporována. U těchto typů terminálů musíte přímo vyzkoušet zaslání dat do terminálu a jejich vyčtení abyste zjistili, zda je spojení funkční.

· Zapisovat do Logu - určuje zda při načítání historie operací budou jednotlivé záznamy zapisovány do log souboru.

· Log soubor - cesta k log souboru kde se budou zapisovat záznamy při načítání historie operací. Takový soubor lze pak načíst znovu do docházky přes terminál typu datalog (driver: datalog).

· Poznámka - libovolná doplňující informace k terminálu.


Formulář terminálu - Parametry

Navigation: Terminály > Terminály >

Formulář terminálu - Parametry

 Return to chapter overview

Tato záložka slouží k nastavení parametrů pro komunikaci s terminálem.

· Název počítače - pokud používáte systém v síti, nastavte název počítače, ke kterému je terminál fyzicky připojen. Pokud necháte tuto položku volnou, budou se všechny stanice připojené k databázi pokoušet o komunikaci s terminálem.

· On-line identifikátor - on-line identifikátor slouží pro identifikaci terminálů při on-line komunikaci s více terminály sdružených pod jednu IP adresu za firewallem.

· Driver - dle zakoupeného typu hardware je potřeba přiřadit k terminálu driver pro jeho komunikaci se software.

terminaly17

Editovat parametry - po stisku tohoto tlačítka se zobrazí formulář driveru, ve kterém nastavíte parametry komunikace terminálu. Každý driver má jiný formulář s nastavením jiných parametrů.

· Parametry - editační pole, ve kterém jsou vypsány veškeré nastavené parametry. Máte možnost ruční úpravy parametrů. Měli byste ale vždy používat formulář pro editaci parametrů driveru příslušný k vašemu hardware.

· Typ komunikace - TCP/IP nebo převodník.

· Hostitel (IP) - zde zadáte IP adresu přidělenou terminálu.

· Port - sériový port, na kterém komunikace probíhá.

Obecné nastavení je obsaženo v návodu u jednotlivých druhů terminálů.

TIP: Způsob nastavení čtečky ID médií naleznete v kapitole Postupy.


Formulář terminálu - Spínání relé

Navigation: Terminály > Terminály >

Formulář terminálu - Spínání relé

 Return to chapter overview

Nastavení zvoleného relé provede dle zadaných požadavků pro sepnutí trvalé otevření nebo zavření dveří, branky, závory.


Formulář terminálu - E-mail

Navigation: Terminály > Terminály >

Formulář terminálu - E-mail

 Return to chapter overview

Jednou z možností jak vyčítat data ze vzdálených poboček, které nejsou připojeny do centrální počítačové sítě, je možnost zasílání těchto dat e-mailem. V tom případě je nutné, aby na jednotlivých pobočkách byly nastaveny e-mailové adresy, kam se mají daná data zasílat a na druhou stranu na centrálním serveru je potřeba nastavit e-mailovou adresu, ze které se mají daná data vyčítat. Touto cestou je možné data z terminálu pouze vyčíst ne je do terminálu zaslat.

POZOR: Je nutné, aby tyto adresy byly vyčleněny pouze pro účely docházkového systému.

· Odesílat načtená data e-mailem - zaškrtnutím tohoto políčka se budou odesílat načtená data z terminálů na níže zadanou adresu.

· Mail soubor - cesta k vyčtenému souboru z terminálů.

· SMTP server - váš SMTP server.

· Port - standardně je zde uveden port 25.

Pokud Váš SMTP server požaduje vložení uživatelského jména a hesla, je potřeba vyplnit tyto údaje do níže uvedených polí, naopak nevyžaduje-li SMTP server tyto údaje ponechte tato pole prázdná.

· Uživatel - uživatelské jméno.

· Heslo - uživatelské heslo pro přístup na SMTP server.

· Odesílatel - například: ADS_pobočka_I.

· Příjemce - e-mailová schránka sloužící ke sběru vyčtených dat z jednotlivých terminálů například: test@ron.cz Na tuto adresu budou zasílány veškerá vyčtená data z terminálů.

--------------------------------------------------------------------

Nastavení terminálu Datalog pro stahování dat z e-mailu:

Stahovat data přes e-maily: po aktivování a nastavení se budou stahovat data z příchozích e-mailů

Nastavení údajů o POP3 serveru je závislé na originálním nastavení tohoto serveru. Je potřeba zadat adresu POP3 serveru dále port serveru uživatelské jméno a heslo.

Není-li nastaven žádný uživatel ani heslo není potřeba tyto údaje zadávat.

· POP3 server - váš POP3 server.

· Port - port POP3 serveru.

· User - uživatelské jméno POP3 serveru.

· Password - heslo pro přístup na POP3 server.

· Maska souboru přílohy - aby program vyhledal a vyčetl správný typ souboru, je nutné do tohoto řádku zadat tuto masku přílohy: *.txt. Tímto program vyhledá v příchozí poště pouze soubory s koncovkou txt.


Formulář terminálu - Operace terminálu

Navigation: Terminály > Terminály >

Formulář terminálu - Operace terminálu

 Return to chapter overview

Ze seznamu všech operací (přerušení) docházky evidovaných v systému, můžete nastavit pro daný terminál výběr operací, které se budou na tomto terminálu používat. Tímto způsobem můžete nadefinovat různé chování pro různé terminály.

Např. na terminálu ve výrobní hale můžete použít jiné operace, než jaké použijete na terminálu v administrativní budově. Každá klávesa může mít na terminálu programově přidělenu jinou operaci a tím také jiný způsob zpracování v docházce.

Formulář je rozdělen do dvou seznamů. V levém seznamu jsou zobrazeny všechny operace evidované v systému, v pravém seznamu jsou povolené operace pro tento terminál. Pro přesun mezi seznamy použijte šipky umístěné mezi těmito seznamy. V pravém seznamu můžete vybraným operacím přiřadit kód pro použití v terminálu. Tímto způsobem můžete například operaci s kódem 5 přiřadit tlačítko s číslem 1 na terminálu. Dále můžete přiřazené operaci nastavit, jestli má nebo nemá spínat relé pro otevírání zámku a vybrat umístění.

Nastavením operací pro terminál přiřazujete jednotlivým klávesám jejich funkci. Pokud máte terminál s displejem zobrazujícím textový popis funkce tlačítka a chcete, aby se změna projevila, musíte provést generování nastavení terminálů.

Pokud chcete, aby se nastavení projevilo na terminálu, musíte provést generování nastavení terminálů. V dokumentaci k terminálu můžete zjistit, jestli Váš terminál podporuje změny textů na displeji tímto docházkovým systémem. Tato funkce není podporována všemi terminály.


Formulář terminálu - Časy operací

Navigation: Terminály > Terminály >

Formulář terminálu - Časy operací

 Return to chapter overview

Tato funkce se používá pouze pro docházkové terminály ovládané klávesnicí.

Některé typy terminálů umožňují nastavení standardních operací v určitý čas.

Například ráno terminál nabízí pracovníkům standardně operaci příchod, odpoledne odchod atp. Pokud je tato operace nastavena a terminál funkci podporuje, přepne se terminál na standardní operaci po zaregistrování každé události.

PŘÍKLAD: Ráno máte nastavenu standardní operaci příchod. Zaměstnanci přicházejí a registrují příchod bez nutnosti operaci volit. Pokud mezi nimi někdo zvolí jinou operaci (odchází k lékaři) a zaregistruje se, terminál se po jeho registraci ihned přepne na standardní operaci příchod.

Jestli váš terminál tuto funkci podporuje, zjistíte v dokumentaci k terminálu.

Formulář je rozdělen do dvou seznamů. V levém seznamu jsou zobrazeny všechny povolené operace, v pravém seznamu jsou operace s nastaveným implicitním časem. Pro přesun mezi seznamy použijte šipky umístěné mezi těmito seznamy.


Formulář terminálu - Činnosti

Navigation: Terminály > Terminály >

Formulář terminálu - Činnosti

 Return to chapter overview

Používáte-li výrobní terminál, nastavte v této záložce činnosti, které budou na terminálu povoleny. Všechny ostatní činnosti tak nebude možné na terminálu použít.

Po přesunutí operace z levé strany tabulky do pravé je důležité neopomenout nastavit kód v terminálu, tedy číslo tlačítka, pod kterým bude operace dostupná.


Zakázky

Navigation: Terminály > Terminály >

Zakázky

 Return to chapter overview

Používáte-li výrobní terminál, nastavte v této záložce zakázky, které budou na terminálu povoleny. Všechny ostatní zakázky tak nebude možné na terminálu použít.


Výrobky

Navigation: Terminály > Terminály >

Výrobky

 Return to chapter overview

Používáte-li výrobní terminál, nastavte v této záložce výrobky, které budou na terminálu povoleny. Všechny ostatní výrobky tak nebude možné na terminálu použít.


Skupiny

Navigation: Terminály > Terminály > Formulář terminálu - Přístupy >

Skupiny

 Return to chapter overview

Povolené skupiny určují, kteří členové skupin budou načteni do tohoto terminálu.

Používá-li se terminál k přístupům, je možno navolit detailní nastavení přístupu skupiny tlačítkem "Podrobné nastavení přístupu".

Pokud nepřiřadíte terminálu skupinu, nebudou pracovníci této skupiny načteni do terminálu a terminál nebude přijímat jejich identifikační médium.

Formulář je rozdělen do dvou seznamů. V levém seznamu jsou zobrazeny všechny skupiny pracovníků, v pravém seznamu vybrané skupiny a nastavení data od kdy do kdy může tato skupina terminál používat. Pro přesun mezi seznamy použijte šipky umístěné mezi těmito seznamy. Nezapomeňte povolené skupině vždy nastavit datum, od kdy skupina může používat tento terminál. Datum do kdy není nutné vyplňovat.


Formulář přístupu - Osoby

Navigation: Terminály > Terminály > Formulář terminálu - Přístupy >

Formulář přístupu - Osoby

 Return to chapter overview

Povolené osoby určují, kteří zaměstnanci budou načteni do tohoto terminálu a nemusí být nutně přiřazeni v povolených skupinách.

PŘÍKLAD: Máte vytvořenu Skupinu osob "Revizní technici" a patří do ní 10 zaměstnanců. Ovšem 1 zaměstnanec provádí revize i na jiných budovách, či pracovištích. Proto ho uvedete jmenovitě v sekci PŘÍSTUPY / OSOBY.


Formulář terminálu - Operace skupiny

Navigation: Terminály > Terminály >

Formulář terminálu - Operace skupiny

 Return to chapter overview

Na této záložce lze určit výběr operací, které se u dané skupiny zapíší jako docházka nebo jako průchod. Pracuje se s povolenými operacemi a skupinami, které jsou definovány v předcházejících záložkách. Terminál musí mít nastaveno určení terminálu: "docházkový a přístupový".


Formulář terminálu - Seznam osob

Navigation: Terminály > Terminály >

Formulář terminálu - Seznam osob

 Return to chapter overview

Tento seznam pouze zobrazuje seznam zaměstnanců povolených pro používání tohoto terminálu. Seznam zaměstnanců je vytvořen sjednocením záznamů všech povolených skupin v terminálu. Jestliže zaměstnanec není zobrazen v tomto seznamu, nebude jeho identifikační médium funkční na terminálu. Příčinou může být nesprávné zařazení zaměstnance do skupiny nebo chybné zadání základních dat o zaměstnanci (datum nástupu, datum přiřazení kalendáře, datum přiřazení identifikačního média.

Tento formulář zobrazuje pouze seznam zaměstnanců povolených pro používání tohoto terminálu. Seznam zaměstnanců je vytvořen sjednocením záznamů všech povolených skupin a osob v terminálu. Jestliže zaměstnanec není zobrazen v tomto seznamu, nebude jeho identifikační médium funkční na terminálu. Příčinou může být nesprávné zařazení zaměstnance do skupiny nebo chybné zadání základních dat o zaměstnanci (datum nástupu, datum přiřazení identifikačního média).

TIP: Pokud změníte přiřazení skupin do terminálu, nezapomeňte použít tlačítko Obnova seznamu pro obnovu tohoto seznamu zaměstnanců nebo klávesy CTRL+O.


Formulář terminálu - Stav

Navigation: Terminály > Terminály >

Formulář terminálu - Stav

 Return to chapter overview

V přehledu je zaznamenán aktuální stav terminálu např. poslední úspěšné načtení, čas posledního úspěšného nastavení apod.


Typy identifikačních médií

Navigation: Terminály >

Typy identifikačních médií

 Return to chapter overview

Rozdělením identifikačních médií na různé typy lze předcházet problémům při kombinování různých technologií terminálů a formátů kódů identifikačních médií a biometrických šablon. Po naplnění seznamu můžete každému ID médiu nastavit jeho typ a u terminálu (menu Terminály -> Terminály -> Formulář terminálu - Terminál) nastavit se kterým typem ID médií bude pracovat.

Typy identifikacnich medii

Tlačítkem [image] Nový záznam nebo [image] Editace záznamu otevřete formulář Typ ID média, ve kterém vyplníte následující položky:

Typy identifikacnich medii_Formular

· Kód - zadejte kód typu ID média.

· Popis - popis typu identifikačního média, například Čip dallas, MIFARE.

· Poznámka - libovolná doplňující informace k typu identifikačního média, například kontaktní ID médium.


Identifikační média

Navigation: Terminály >

Identifikační média

 Return to chapter overview

Číselník identifikačních médií slouží k evidenci médií, která máte k dispozici pro přiřazení zaměstnancům (v kartě zaměstnance v záložce ID média). Jedná se o součást systému, kdy jedno ID médium může být použito pro více činností, a to: docházka, otevírání dveří, objednávka stravy, apod. Platnost přiřazení identifikačního média zaměstnanci je řízeno daty počátku a konce přiřazení. V zadaném časovém období systém identifikuje pod tímto médiem zvoleného pracovníka. Při navrácení média můžete provést přiřazení dalšímu pracovníkovi.

Filtry pro rychlou práci se záznamy:

§ Všechny - pokud zvolíte tento filtr, zobrazí se všechna ID média, přiřazená i nepřiřazená.

§ Přiřazené - tímto filtrem zobrazíte jen přiřazená ID média.

§ Nepřiřazené - volbou tohoto filtru omezíte záznamy jen na nepřiřazená ID média.

§ Ke dni - výše uvedené filtry můžete současně nechat nastavit k určitému datu, které vyberete z kalendáře (aktivní jen v případě nezatržení následující kolonky).

§ Aktuální den - výše uvedené filtry můžete současně nastavit k aktuálnímu datu.

Seznam ID médií:

Nová ID média vložíte tlačítkem [image] Nový záznam a v otevřeném formuláři Identifikační médium vyplníte následující záložky: Formulář záznamu a Historie přiřazení osobám. Parametry můžete upravovat tlačítkem [image] Editace záznamu.

POZNÁMKA: Podle typu použitých terminálů je možno používat tato identifikační média:

- kontaktní čipy DALLAS,

- bezkontaktní karty,

- bezkontaktní přívěsky (různé tvary a barvy),

- karty s magnetickým proužkem,

- karty s čárovým kódem,

- otisky prstů.


Formulář identifikační média - Formulář záznamu

Navigation: Terminály > Identifikační média >

Formulář identifikační média - Formulář záznamu

 Return to chapter overview

Ve formuláři vyplňujete základní parametry identifikačního média.

Identifikacni media formular identifikacniho media

· ID - číselné označení ID média, doplněné programem.

· Kód - číslo identifikačního média, jde o jednoznačný identifikátor přiřazený médiu při jeho výrobě. Kód můžete načíst pomocí tlačítka [image] Načtení kódu média z terminálu.

· Kód 2 - druhé číslo identifikačního média. U jednotlivých terminálů lze určit, který kód má být používán. Tento kód lze využít např. u bezkontaktní karty, která je navíc potištěná čárovým kódem. Pak je tento čárový kód možno uvést v tomto poli a u terminálů, které čtou čárový kód, nastavit používání kódu 2.

· Označení média - textové označení nebo pořadové číslo ID média (nemusí být shodné s kódem média).

· Typ - z nabídky vyberte o jaký typ ID média se jedná (čipy dallas, mifare, biometrická šablona apod.) Nový Typ vytvoříte v menu Terminály -> Typy identifikačních médií.

· Biometrická šablona - pokud máte modul zakoupen, je tato položka aktivní. Načtení (otisků prstů) provedete tlačítkem [image] Načtení biometrické šablony z terminálu.

· Index šablony - označení šablony.

· Datum pořízení - zadejte ve formátu DD.MM.RRRR nebo vyberte z kalendáře datum zavedení média do evidence.

· Datum vyřazení - zadejte nebo vyberte z kalendáře datum vyřazení média z evidence (v případech jeho ztráty, vady, poškození nebo ostatních důvodů).

· Způsob vyřazení - vyberte z nabízených možností způsob vyřazení ID média (poškozená, ztracená, vadná, ostatní).

· Blokována - zatržením určíte, že chcete pozastavit funkčnost média v systému. Např. pokud existuje podezření, že médium je používáno neoprávněnou osobou.

POZOR: Pokud je tato volba zaškrtnutá, není ID médium zasíláno do terminálů! Blokace bude aktivní až po ručním zadání na terminálu!

· Záloha na médium - zadejte cenu média, nepovinný údaj.

· Poznámka - prostor pro doplňující informace.


Formular identifikační média - Historie přiřazení osobám

Navigation: Terminály > Identifikační média >

Formular identifikační média - Historie přiřazení osobám

 Return to chapter overview

Každé ID médium musí být přiřazeno vždy pouze jedné osobě! Přiřazení ID média zaměstnanci lze také sledovat v kartě zaměstnance, v záložce ID média. Pohled je však opačný. V tomto okně vybíráte ze seznamu zaměstnanců, kteří nemají ID médium přidělené, a přiřazujete konkrétní ID médium. Naopak ve formuláři zaměstnance se přidělí volné ID médium konkrétnímu zaměstnanci.

Identifikacni media formular historie prirazeni osobam

Záložka obsahuje dva sloupce. Seznam aktivních zaměstnanců bez přiřazeného média k dnešnímu dni je zobrazen ve sloupci Osoby bez ID média. Ve sloupci Osoby s přiřazeným ID médiem je uvedena osoba, které je přiděleno dané ID médium.

Pomocí šipek uprostřed formuláře přiřazujete nebo rušíte přiřazení:

C_Sipka seda vpravo , C_Sipka seda vlevo | Šipky - pomocí těchto tlačítek se přesunou vybrané záznamy požadovaným směrem.
C_Sipka seda dvojita vpravo , C_Sipka seda dvojita vlevo | Šipky - pomocí těchto tlačítek se přesunou všechny záznamy požadovaným směrem.

POZOR: Výměnu osoby je vhodnější provést jako vrácení předchozího přidělení ID média osobě a nové přidělení jiné osobě. Pokud budete výměnu provádět pouze šipkami uprostřed formuláře, neuchová se historie a v pravém okně se bude vždy zobrazovat jen jméno zaměstnance s aktuálně přiřazeným ID médiem.

Výměnu provedete rozkliknutím řádku se jménem zaměstnance, kterému chcete ukončit platnost ID média (v pravém okně), a do otevřeného formuláře Přiřazené ID médium uvedete Datum vrácení (média):

Identifikacni media formular prirazeneho ID media

Totéž lze provést také pomocí ikony [image] Označit kartu jako vrácenou. Program vloží aktuální datum a označí ID médium jako vrácené. Poté můžete přiřadit toto ID médium dalšímu zaměstnanci. Pokud zadáte datum vrácení např. aktuální den, ID médium můžete ve stejný den přiřadit dalšímu zaměstnanci.

Filtry ve sloupci Osoby bez ID média:

§ Aktivní - zobrazí se seznam zaměstnanců v pracovním poměru, kteří nemají přiděleno ID médium.

§ Neaktivní - výběrem filtru bude seznam omezen na zaměstnance s ukončeným pracovním poměrem bez přiřazeného ID média.

Filtry ve sloupci Osoby bez ID média:

§ Všechny - zobrazí se i ti zaměstnanci, kteří měli ID médium přiřazené v minulosti.

§ Jen přiřazené - zobrazí se zaměstnanec, kterému je ID médium aktuálně přiřazeno.


Operace terminálů

Navigation: Terminály >

Operace terminálů

 Return to chapter overview

Tento seznam definuje různé druhy operací (činností, přerušení) pracovní doby.

Vždy definujete jeden příchod a několik různých přerušení-odchodů. Při příchodu si pracovník na terminálu zaregistruje vždy příchod a při odchodu volí, kam jde (domů, oběd, lékař, apod.). Seznam operací je také závislý na druhu použitého hardware docházkových a přístupových terminálů.

1. typ terminálu - na terminálech můžete definici provádět kompletně v programu a poslat nastavení do terminálu. Definuje tím funkce kláves na terminálu.

2. typ terminálu - terminály mají operace definovány pevně určenými klávesami (klávesa na terminálu má definovaný symbol). V tomto případě musíte nastavit operace terminálu v programu podle hardware.

3. typ terminálu - terminál je možno programovat, ale pouze pomocí software dodaného výrobcem terminálu. V tomto případě si můžete vybrat, jestli nastavíte software podle standardního dodaného nastavení terminálu nebo přizpůsobíte nastavení terminálu podle připravené definice v programu.

Popisy funkčnosti jednotlivých typů terminálů najdete v přílohách k této příručce nebo v dokumentaci k hardware docházkového systému.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář Operace terminálu. Formulář je rozdělen do následujících záložek:

Hlavní údaje

Rozšířené nastavení

Kam se operace započítává

Kalendáře

Rozdělení


Formulář operace terminálu - Hlavní údaje

Navigation: Terminály > Operace terminálů >

Formulář operace terminálu - Hlavní údaje

 Return to chapter overview

Ve formuláři operace terminálu nastavte základní vlastnosti.

Operace terminalu_Hlavni udaje

· Kód - povinný údaj. Jednoznačný identifikátor operace, často shodný s kódem operace na klávese terminálu.

· Popis - povinný údaj. Textový popis operace pro použití v programu.

· Text na terminálu - povinný údaj. Textový popis operace pro použití na displeji terminálu (pokud terminál podporuje programovou definici textů). Popis a text na terminálu mohou být shodné.

· Popis tlačítka terminálu - textový popis operace pro použití tlačítka terminálu, tento popis tlačítek lze pro podporované terminály vytisknout. Popis a text na terminálu mohou být shodné.

· Systémovápokud je operace systémová, potom se například nebude zobrazovat v seznamu operací přestávky ve Formuláři směny - Hlavní údaje v sekci Nastavení typu vkládání přestávky.

· Manuálně vkládat - pokud volbu zatrhnete, můžete operaci použít při manuálním vkládání operace.

· Manuálně vkládat přes intraweb - pokud volbu zatrhnete, můžete operaci použít při manuálním vkládání operace přes intraweb.

· Povolit nastavit čas v intrawebu - u zvolené operace bude možné po zaškrtnutí pole vložit v intrawebu čas a datum k této operaci.

· Vkládat v editaci docházky - pokud volbu zatrhnete, můžete operaci vložit při editaci docházky.
· Povinné zadání rozdělení u docházky - pokud volbu zatrhnete, je potřeba při editaci nebo vložení nové operace v editaci docházky zadat rozdělení docházky, jinak se operace nevloží.

· Počátek intervalu - po registraci operace na terminálu systém počítá čas do další operace a vytváří časový interval (vytváří grafický náhled docházky). Jedinou operací, kdy by měla být tato volba vypnuta je operace Odchod (domů), po kterém již nechcete časový interval měřit. U všech ostatních operací by měla být tato volba zatrhnuta.

· Rozdělovat interval půlnocí - pokud má operace danou volbu zapnutou, pak při zpracování původní docházky je interval dané operace rozdělen na jednotlivé dny, přes které prochází a jednotlivé části intervalu jsou přiřazeny k daným dnům.

· Nevkládat ve svátek - volba určuje, zda se operace nebude vkládat ve svátek při ručním a automatickém vkládání docházky podle kalendáře a při vkládání docházky podle plánování absencí (při zpracování docházky).

· Přítomnost pro monitorování - nabízí tři možnosti pro nastavení. V okně monitorování se na základě registrované operace zobrazí stav přítomnosti zaměstnance. U operací "Příchod, Práce ve ztíženém prostředí apod." je zpravidla nastavena hodnota přítomen. V případě operací "Přestávka, Odchod, Služební cesta, K lékaři apod." je zpravidla nastaveno nepřítomen, neboť v této době se zaměstnanec nenachází na pracovišti. Pakliže není potřeba rozlišovat, zdali je či není zaměstnanec přítomen, můžete u operace nastavit "Ignorovat". Pokud budete chtít některou operaci úplně vyloučit z monitorování, nastavte u této operace "Nemonitorovat".

PŘÍKLAD: Je-li operace příchod nastavena na přítomen a zaměstnanec zvolí operaci "Příchod" bude v monitorování veden jako přítomen.

· Ukončit automaticky - v případě, že předpokládáte, že se pracovník již nebude po zvolené operaci vracet zpět, aby docházku za den ukončil, můžete nastavit možnost automatického ukončení operace. Nastavení automatického ukončení má několik možností:

o Neukončovat - operace bude pokračovat až do další registrace jiné operace.

o Délkou směny - pokud operace dosáhne délky přiřazené směny je ukončena.

o Délkou pevného jádra - pokud operace dosáhne délky pevného jádra přiřazené směny je ukončena.

o Koncem směny - pokud operace dosáhne času konce směny je ukončena.

o Koncem pevného jádra - pokud operace dosáhne času konce pevného jádra směny je ukončena.

o Délkou nebo koncem směny - pokud operace dosáhne času konce směny nebo délky směny je ukončena.

o Délkou nebo koncem pevného jádra - pokud operace dosáhne času konce pevného jádra směny nebo délky pevného jádra směny je ukončena.

o Po určené době - operace se ukončí po zadané době.

o Při neukončení do určené doby po směně ignorovat - pokud neukončí pracovník operaci do určené doby po směně, bude operace zkrácena na nulovou délku.

o V pevný čas - operace bude ukončena v nastavenou dobu.

o Koncem směny - pokud není další operace do doby po směně - dojde k ukončení operace koncem směny, pokud není nalezen nějaký záznam do nastavené doby (příklad využití - požadujete ukončovat služební cestu koncem směny, pokud se již pracovník nevrátí zpět do kanceláře).

o Koncem pevného jádra - pokud není operace do doby po konci pevného jádra směny - viz výše s rozdílem doby ukončení operace.

o V pevný čas - pokud není operace do doby 2 po pevném čase - pokud není interval ukončen odchodem, nebo do dané doby (Hodnota pole: "Doba 2") po pevném čase (Hodnota pole: "Doba pro automatické ukončení") nenásleduje další operace (počátek intervalu), pak je akt. interval docházky ukončen daným pevným časem.

o Součtem do délky směny plus (určená doba-ruční přestávky)

o Součtem do délky směny plus (určená doba-ruční přestávky) - pokud není operace do doby 2 po směně

· Doba pro automatické ukončení - zadejte hodnotu ve formátu HH:MM pokud máte nastavenu volbu automatického ukončení s definicí doby.

· Doba 2 - volba je aktivní pouze pro automatické ukončení operace V pevný čas - pokud není operace do doby 2 po pevném čase.

· Nezapočítat automaticky ukončené operace s délkou menší než - nastavte délku operace. Operace, jejíž délka je menší než nastavená se automaticky nezapočítají.

· Nárok na přestávku - nastavte pokud mají být do operace vkládány automatické přestávky (operace má nárok na přestávku).

· Operace přestávky - určuje zda je daná operace přestávkou v pracovní době. Volba je využita při automatickém ukončování operací součtem za celkovou délku od počátku směny.

· Úprava normy - povinný údaj. Z nastaveného kalendáře má pracovník napočítanou normu odpracované doby pro měsíc. Skutečná norma se může podle zvolené operace měnit (např. při operaci nemocenská se norma snižuje).

· Snížit normu za pevné jádro - pokud je nastaveno snižování normy můžete nastavit, že se snížení týká pouze intervalu pevného jádra.

· Druh dávky - vyberte druh dávky při absenci pokud používáte i mzdy spol. RON (při absenci nemoc zvolte dávku nemocenská apod.).

· Absence/Plánovaná operace - zatrhněte položku v případě, že chcete, aby se tato operace zobrazovala v nabídce pro plánování absence (např. nemoc, mateřská dovolená atd.).

· v Intrawebu - pokud chcete, aby se operace zobrazovala v intrawebu, zatrhněte položku. Poté bude možné operaci vybrat v odkazu Plánování absence v položce Absence.

· Automaticky schvalovat - pokud chcete operaci automaticky schvalovat, zatrhněte pole. Pokud chcete funkci využívat, je nutné v menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Schvalování docházky zatrhnout pole Používat schvalování absencí.

· Typ vkládání absence - tato volba slouží k úpravě vkládání absence pomocí plánovaní absencí.
o Ve dny bez původní docházky - plánovaná absence bude vložena, pouze pokud v daný den není vložena operace původní docházky (vložena manuálně, označena na terminálu).
o Pokud není v intervalu absence jiná docházka - plánovaná absence bude vložena, pouze pokud v zadaném intervalu není žádná operace.
o Vkládat i v případě částečného překrytí docházkou - plánovaná absence bude vložena vždy, pokud byla v době absence jiná operace docházky, vloží se přes tuto operaci.

o Nevkládat - operace, které mají toto nastavení, jsou pak vynechány při vkládání absencí při zpracování docházky.

· Vkládat absenci v 2. polovině směny hned za 1. - tato volba určuje, zda se absence, která se vkládá do 2. poloviny směny, bude vkládat hned za 1. polovinu směny a ne zpětně od konce směny.

· Barva pro vykreslení - povinný údaj. Docházka se upravuje v grafickém režimu, pro který si můžete zvolit zobrazení barev jednotlivých operací.

· Legenda přiřazení - po stisku zobrazí legendu již přiřazených barev k operacím.

· Zkratka pro plánování - používá se pro modul plánování kapacit, kde podle použití dané operace přiřadí použitou zkratku.

· Událost služební cesty - po zatržení pole bude možné vybrat v Intrawebu tuto Operaci při zadávání cestovních náhrad.


Formulář operace terminálu - Rozšířené nastavení

Navigation: Terminály > Operace terminálů >

Formulář operace terminálu - Rozšířené nastavení

 Return to chapter overview

V této části můžete nastavit podrobné vlastnosti operace, které mohou ovlivnit zpracování docházky.

Operace terminalu_Rozsirene nastaveni

Úprava počátku a konce operace:

· Úprava času operace - nastavuje možnost posunu času zaregistrované operace. Umožňuje např. tyto volby:

o Neupravovat - standardní nastavení, čas operace zůstává podle skutečné registrace na terminálu.

o Posunout o délku směny zpět - posune čas o nastavenou délku přiřazené směny.

o Posunout o délku pevného jádra směny zpět - posune čas o nastavenou délku pevného jádra přiřazené směny.

o Posunout na počátek směny

o Posunout na počátek směny dopředu - princip stejný, jako u předchozí možnosti - systém zaregistruje operaci lékaře od začátku registrace do konce směny.

o Posunout na počátek směny dozadu - umožňuje zaregistrovat např. ranní návštěvu lékaře. Pracovník přijde od lékaře a zaregistruje operaci příchod od lékaře s tímto nastavením. Systém zaregistruje operaci lékaře od začátku směny až po čas registrace.

o Posunout na konec směny

o Posunout na konec směny dopředu

o Posunout na konec směny dozadu

o Posunout na počátek pevného jádra

o Posunout na počátek pevného jádra dozadu

o Posunout na konec pevného jádra

o Posunout na konec pevného jádra dopředu

o Posunout na konec pevného jádra dozadu

o Posunout o určitou dobu zpět - použijete např. v případě, že terminál pro registraci je mimo pracovní místo a pracovník si registruje odchod až po převlečení po ukončení práce. Můžete nastavit posun o 10 minut zpět, čímž odečtete předpokládaný čas strávený převlékáním.

o Posunout o určitou dobu dopředu

· Doba pro úpravu času operace - pokud je nastavena úprava času operace, můžete zadat hodnotu pro posun ve formátu HH:MM.

· Jen pro první operaci směny - pokud je volba aktivována, pak je úprava času operace provedena, jen pokud je to první operace směny.

· Návazná operace - tato volba, při zpracování původní docházky, aktivuje vložení záznamu s operací nastavenou jako "Návazná operace" ihned za záznam s danou operací, pro který je "Návazná operace" nastavena. Tuto volbu lze nastavit i pro jednotlivé kalendáře zvlášť ve Formuláři kalendáře - Operace.

· Automatické opakování - můžete nastavit automatické opakování poslední provedené operace. Např. při odchodu na dovolenou může systém automaticky opakovat operaci každou směnu až do chvíle, kdy pracovník zaregistruje jinou operaci. Volby opakování např.:

o Neopakovat

o Opakovat každý pracovní den - opakuje poslední operaci každý pracovní den (např. dovolená).

o Opakovat každý kalendářní den - opakuje kalendářní den (např. nemoc).

o Opakovat každou směnu - opakuje operaci ve dnech, kdy je v kalendáři definovaná směna.

o Opakovat každý počátek pevného jádra směny

o Opakovat každou směnu v pracovní den

· Ignorovat první operaci opakování - Pokud je tato volba aktivována, pak je první zaregistrovaná operace, která uvádí automatické opakování, při výpočtu docházky přeskočena. První interval je vytvořen až od první automaticky vygenerované operace (následující den, následující kalendářní den, následující směnu).

· Ignorovat operace kratší než - zadejte čas ve formátu HH:MM, pokud bude časový interval s touto operací kratší, než zadaný čas bude interval zrušen. Jde například o chybné registrace s následnou opravou nebo velmi krátké intervaly.

· Minimální délka operace - pokud bude vypočtený interval kratší, než zadaná hodnota ve formátu HH:MM, bude interval prodloužen na délku této hodnoty. Např. přestávka má být minimálně 30 minut. Pokud se pracovník vrátí za dobu kratší, doplní systém přestávku na 30 minut, pokud pracovník přestávku přetáhne, započítá se mu skutečná doba.

· Následující operace detekuje novou směnu - zatrhnutím pole určíte, že při zpracování docházky se bude pro operaci, která následuje po operaci s nastavenou danou volbou, vyhledávat směna pro přiřazení, i když to je uprostřed souvislého intervalu docházky, kdy se jinak přebírá směna z předchozí operace.

Zaokrouhlování:

· Zaokrouhlení počátku - můžete nastavit zaokrouhlení času operace (nezaokrouhlovat, nahoru, dolů, normálně), posune čas registrace operace na terminálu.

· Zaokrouhlení počátku na - pokud jste nastavili zaokrouhlování, zadejte hodnotu zaokrouhlení ve formátu HH:MM (např. 00:05 - zaokrouhlení na 5 minut).

· Zaokrouhlení délky - po vypočtení intervalů docházky můžete nastavit zaokrouhlení těchto intervalů.

· Zaokrouhlení délky na - pokud jste nastavili zaokrouhlování, zadejte hodnotu zaokrouhlení ve formátu HH:MM (např. 00:05 - zaokrouhlení na 5 minut).

Úprava a započítávání času:

· Výpočet délky operace - omezit délku operace lze také zvolením intervalu, ve kterém má být operace započítána.

o Bez omezení - neprovede žádnou změnu.

o Pouze v intervalu směny - započítá délku operace pouze v délce směny.

o Pouze v intervalu pevného jádra - započítá délku operace pouze v délce pevného jádra.

· Maximální započitatelná doba - zadejte hodnotu ve formátu HH:MM, program omezí započítanou délku intervalu.

· Při nulové denní normě nezapočítat - pokud je tato volba aktivována, pak pokud je ve dni přiřazení záznamu nulová denní norma, potom záznam není vůbec započítáván do výsledků.


Formulář operace terminálu - Kam se operace započítává

Navigation: Terminály > Operace terminálů >

Formulář operace terminálu - Kam se operace započítává

 Return to chapter overview

Systém z registrované operace vypočítá podle nastavených vlastností interval a tento interval připočítá do zvolených časových složek. V této části musíte nastavit, do kterých časových složek se interval (operace) bude započítávat.

Operace terminalu_Kam se operace zapocitava

V levém seznamu máte zobrazen seznam všech časových složek, v pravé části je seznam vybraných časových složek pro tuto operaci.

NAPŘÍKLAD: Příchod - započítat do odpracované doby.

Služební cestu - započítat do odpracované doby a do služební cesty.

Tímto způsobem můžete každé operaci přiřadit více časových složek. Systém na konci měsíce poskytne přehled o dobách započtených celkem do jednotlivých časových složek. Pro nastavení používaných časových složek použijte šipky mezi oběma seznamy. Toto nastavení má zásadní vliv na celkové výsledky docházky za měsíc.


Formulář operace terminálu - Kalendáře

Navigation: Terminály > Operace terminálů >

Formulář operace terminálu - Kalendáře

 Return to chapter overview

V operaci terminálu můžete zobrazit a nastavit operace pro kalendáře. Po přiřazení kalendáře operaci, lze editací záznamu nastavit vlastnost operace pro přiřazený kalendář. Je to obdoba nastavení jako operace u kalendáře.

V levé části formuláře je seznam všech dostupných kalendářů. Pravá část je vyhrazena pro seznam kalendářů, které mají nastavenou vlastnost pro operaci. Označením položky a stiskem šipky mezi seznamy můžete hodnoty přesouvat z jedné strany na druhou oběma směry. Editací záznamu pod seznamy se dostanete do Formuláře nastavení operace.


Formulář operace terminálu - Rozdělení

Navigation: Terminály > Operace terminálů >

Formulář operace terminálu - Rozdělení

 Return to chapter overview

Ve formuláři máte možnost přiřadit operaci terminálu rozdělení. Typ rozdělení pro operace nastavíte v menu Systém -> Nastavení aplikace -> Společné nastavení -> Operace terminálu.

V levé části formuláře je seznam všech dostupných rozdělení. Pravá část je vyhrazena pro seznam rozdělení, které má vybraná operace terminálu přiřazena. Označením položky a stiskem šipky mezi seznamy můžete hodnoty přesouvat z jedné strany na druhou oběma směry.


Generování nastavení terminálů

Navigation: Terminály >

Generování nastavení terminálů

 Return to chapter overview

Tuto volbu použijete pro zaslání informací do terminálu.

Generování nastavení terminálů slouží k zasílání seznamů operací (texty na displej - nepodporují všechny typy terminálů), seznamy identifikačních médií se jmény pracovníků, přístupová práva pro terminály, saldo, nastavení terminálů. Pro správnou funkci musíte mít správně nastaveny vlastnosti terminálů.

Generování nastavení terminálů můžete přidat do seznamu plánovaných úloh v plánovači úloh.

Spuštění této funkce má smysl pouze na počítači, ke kterému je připojen terminál nebo pokud terminál komunikuje přes TCP/IP. Na ostatních počítačích vyvolání této funkce nahlásí chyby při komunikaci.

Před provedením generování se zobrazí seznam všech dostupných terminálů v systému a vy můžete zvolit, do kterých terminálů chcete nastavení generovat. Pokud vám program nenabízí žádné terminály nebo jen některé, máte u nezobrazených terminálů nastaveno jméno počítače, které není shodné s vaším počítačem.

Generovani nastaveni terminalu

V průběhu generování program zobrazuje popisy své činnosti.

Po ukončení následuje hlášení o výsledku generování. Pokud nastanou nějaké problémy, nabídne vám program zobrazení seznamu chyb, které při komunikaci vznikly. Seznam chyb si zobrazte a zjistěte, k jakým chybám došlo. Každé chybové hlášení nemusí být pro funkčnost systému kritické. Vzniklé chyby se snažte nastavením systému odstranit.


Nastavení data a času terminálů

Navigation: Terminály >

Nastavení data a času terminálů

 Return to chapter overview

Tuto volbu použijete pro zaslání aktuálního data a času do terminálu. Pro správnou funkci musíte mít správně nastaveny vlastnosti terminálů.

Nastavení data a času terminálů můžete přidat do seznamu plánovaných úloh v plánovači úloh. Spuštění této funkce má smysl pouze na počítači, ke kterému je připojen terminál nebo pokud terminál komunikuje přes TCP/IP. Na ostatních počítačích vyvolání této funkce nahlásí chyby při komunikaci.

Před provedením nastavení se zobrazí seznam všech dostupných terminálů v systému a vy můžete zvolit, do kterých terminálů chcete nastavit akt. datum a čas. Pokud vám program nenabízí žádné terminály nebo jen některé máte u nezobrazených terminálů nastaveno jméno počítače, které není shodné s vaším počítačem.

Nastaveni data a casu terminalu

V průběhu nastavování program zobrazuje popisy své činnosti.

Po ukončení následuje hlášení o výsledku nastavování. Pokud nastanou nějaké problémy, nabídne vám program zobrazení seznamu chyb, které při komunikaci vznikly. Seznam chyb si zobrazte a zjistěte, k jakým chybám došlo. Každé chybové hlášení nemusí být pro funkčnost systému kritické. Vzniklé chyby se snažte nastavením systému odstranit.


Načtení dat z terminálů

Navigation: Terminály >

Načtení dat z terminálů

 Return to chapter overview

Tato funkce provede načtení informací z terminálů připojených k tomuto počítači. Informace vyčtené z terminálů se zapíší do seznamu původní docházky nebo seznamu historie průchodů. Tato funkce je jednou ze základních komunikačních funkcí. Pokud nenačítáte historii operací, neuvidíte žádné údaje v docházkovém systému.

Nacteni dat z terminalu

Tato funkce se nejčastěji nastavuje do plánovače úloh k pravidelnému spouštění. Terminály v sobě uchovávají registrované informace. Jejich paměť však není neomezená. Podle počtu zaměstnanců a velikosti paměti terminálu musíte zvolit interval vyčítání dat z terminálů. Pokud totiž dojde k zaplnění paměti terminálu, přestane tento další data přijímat.

Spuštění této funkce má smysl pouze na počítači, ke kterému je fyzicky připojen terminál nebo pokud terminál komunikuje přes TCP/IP.


Stav terminálů

Navigation: Terminály >

Stav terminálů

 Return to chapter overview

Tuto volbu použijete, pokud chcete zjistit stav Vašich terminálů. Po otevření tohoto okna se zobrazí všechny dostupné terminály, které jsou připojeny k ADS. Z přehledné tabulky zjistíte kód terminálu, popis terminálu, poslední načtení, nastavení, počet neúspěšných načtení a nastavení.

Seznam stavu terminalu


Import LOG souboru terminálu

Navigation: Terminály >

Import LOG souboru terminálu

 Return to chapter overview

Tato funkce slouží k importu LOG souboru generovaného při načítání dat z terminálů.


Docházka

Navigation: »No topics above this level«

Docházka

 Return to chapter overview

Menu je určeno k vedení a zpracovávání záznamů docházky a obsahuje následující položky:

Manuální vložení operace do původní docházky

Seznam původní docházky

Zpracování původní docházky

Plánování absencí

Plánování kapacit

Editace zpracované docházky

Editace denních výsledků

Editace měsíčních výsledků

Přepočet výsledků zpracované docházky

Zrušení zpracované docházky

Přehled záznamů zpracované docházky

Přehled měsíčních výsledků výpočtu

Přehled rozdělení měsíčních výsledků výpočtu

Denní výsledky výpočtů

Přehled rozdělení denních výsledků výpočtu

Přehled mzdových položek

Hromadné zadávání mzdových položek

Historie průchodů

Manuální vložení operace do historie průchodů

Přehled příchodů a odchodů

Fotografie z terminálů

Monitorování


Manuální vložení operace do původní docházky

Navigation: Docházka >

Manuální vložení operace do původní docházky

 Return to chapter overview

Tato funkce umožňuje ruční zápis operace docházky. Všechny údaje vložené pomocí této funkce se zapisuji do Seznamu původní docházky a nelze je z tohoto seznamu nikdy odstranit. Jde o registraci docházky shodné s registrací na docházkovém terminálu.

Tuto funkci použijete pouze v případě, že zaměstnanec zapomene operaci zaznamenat nebo zapomene identifikační médium nebo nemůže k terminálu z organizačních důvodů.

Uživatel může vybrat ze seznamu osobu, zadat datum operace, čas a druh operace. Pokud zaškrtnete volbu "pro více dnů" můžete zadat datum do kdy se má operace opakovaně vložit.

Manualni vlozeni operace do puvodni dochazky

Operace lze také hromadně vkládat pouze pro pracovní dny nebo pouze pro dny, ve kterých má zaměstnanec v kalendáři přiřazenou směnu. Ve výběru operací vám umožní vložit pouze operace, které mají v seznamu operací terminálu nastavenu volbu "Manuálně vkládat". Pole terminál je potřeba vyplnit v případě, že používáte dotykové terminály s monitorováním zaměstnanců pro konkrétní umístění, například budovu. Do pole poznámka můžete zadat krátkou textovou poznámku, například z jakého důvodu byla docházka vložena manuálně.

Vkládat operace můžete pouze do období, které ještě není zpracováno funkcí "Zpracování původní docházky", tj. na dnešní den, nebo budoucí dny.

TIP: Pomocí horké klávesy F11 můžete kdekoliv v programu vyvolat formulář pro manuální vkládání operace do původní docházky.


Seznam původní docházky

Navigation: Docházka >

Seznam původní docházky

 Return to chapter overview

Tento seznam zobrazuje základní údaje o docházce načtené z docházkových terminálů. V tomto seznamu není možné údaje měnit ani je mazat. Je to základní seznam, který je podkladem pro následné zpracování docházky.

Seznam puvodni dochazky

Seznam původní docházky lze snadno filtrovat a vyhledat požadované záznamy. V horní části seznamu můžete vybrat skupinu pracovníků, kterou chcete zobrazit. Pokud chcete tento filtr zapnout, musíte stisknout tlačítko "Jen skupina". Další volbou v horní části seznamu je nastavení zobrazeného období. Tyto rychlé filtry usnadní práci se seznamem.

Ikonou editace se dostanete do formuláře Záznam původní docházky.

Seznam puvodni dochazky_01

Ve formulář je možné upravit položku Poznámka - textová informace o záznamu.


Zpracování původní docházky

Navigation: Docházka >

Zpracování původní docházky

 Return to chapter overview

Program načte z terminálů jednotlivé časové údaje o tom, který zaměstnanec (nebo jeho identifikační médium) označil na určitém terminálu vybranou operaci. Tyto jednotlivé informace vám však neposkytnou přehlednou informaci, jak dlouho trvala a jaká činnost to byla. Proto musíte provést zpracování původní docházky. V této volbě zadejte datum, do kdy chcete zpracovat záznamy docházky. Systém najde pro každého pracovníka jeho poslední zpracovaný interval docházky a zpracuje intervaly až do zadaného data. Zpracované intervaly mají definovaný počátek, konec, skutečnou délku i započtenou délku, přiřazenou směnu, podle které se může lišit zaokrouhlení tohoto intervalu. Všechny tyto vlastnosti systém nastaví podle definovaných podmínek. Úpravy tohoto automatizovaného zpracování můžete provádět v editaci zpracované docházky.

Pokud nemáte provedeno zpracování původní docházky, neuvidíte v editaci docházky ani ve výstupních sestavách žádné výsledky.

Program provede zpracování původní docházky do zvoleného data. Do zpracovaného období není možné vkládat záznamy funkcí "Manuální vložení operace docházky" (viz Manuální vložení operace docházky). Pokud jste zpracovali docházku předčasně a chtěli byste toto zpracování zrušit, spusťte znovu zpracování původní docházky a zadejte nižší datum. Tím se zpracované záznamy po tomto datu zruší.

Při nastavování data zpracování vždy volte datum předchozího dne. Pokud dáte docházku zpracovat ke včerejšímu dni, budou údaje kompletní a budete znát správné hodnoty odpracované doby i salda ke včerejšímu dni.

Pokud dáte zpracovat docházku k aktuálnímu dni, mohou být výsledky zkresleny o právě probíhající práce. Započítá se Vám celá dnešní norma, ale pouze část z rozpracované směny zaměstnance, který je ještě v práci. Pokud zpracováváte docházku odpoledne a nikdo již v práci není a nebude, dostanete hodnoty také správné. Pokud Váš systém běží nepřetržitě, můžete si nastavit v plánovači úloh automatické zpracování (většinou jednou denně v noci).

· Počet vláken zpracování - podpora vícevláknového zpracování původní docházky. Nastavte počet vláken, která budou zpracovávat úlohu.


Plánování absencí

Navigation: Docházka >

Plánování absencí

 Return to chapter overview

Funkce Plánování absencí umožňuje individuálně, ale i hromadně plánovat nepřítomnost v zaměstnání. Už název jasně vytyčuje, že se jedná o vkládání absencí, které teprve nastanou - v budoucnosti, tj. od zítřka.

Systém projde tabulku Plánování absencí a porovná s příchozími daty z terminálu. Pokud nenajde u osoby žádný záznam nasnímaný na docházkovém terminálu, načte data docházky podle plánování. K načtení Plánovaných absencí dojde jedině v případě, že jsme je do systému vložili!

Abyste mohli bez problémů tuto variantu v ADS využívat, musí mít operace terminálu povoleno vkládání Absencí, např. TERMINÁLY/OPERACE TERMINÁLŮ/Dovolená - Absence (zaškrtnout).

Pro zúžení výběru a zvýšení přehlednosti v tabulce plánovaných absencí je možno použít filtry:

§ Jen rozdělení - chcete-li vyhledat absence pouze pro osoby v konkrétním rozdělení je potřeba toto rozdělení vyhledat ze seznamu.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

§ Jen absence - ze seznamu absencí vyhledejte, jaká absence se má dané skupině v daném období zobrazit.

§ Jen období - potřebujete-li zobrazit absence pouze za určité období, zaškrtněte tuto položku a zadejte období, které chcete v seznamu zobrazit.

§ Jen osoba - potřebujete-li zobrazit absence pouze jedné osoby, zaškrtněte tuto položku a vyberte ze seznamu požadovaného zaměstnance.

Hromadné operace - přes tlačítko můžete vložit hromadně absenci.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si Novy zaznam Nový záznam, resp. kartu Absence, dovolená.

Ve formuláři je potřeba vybrat Zaměstnance, pro kterého zvolíte ze seznamu potřebnou Absenci s Datem trvání od - do. Dále vyberte v jaké fázi je zadávaná absence, zda je již Schválena/Neschválena a nebo je Bez určení. Máte možnost zatrhnout políčko, jestli Zaměstnanec vzal na vědomí takto naplánovanou absenci. Absenci máte možnost naplánovat na půl směny, přesné časy od - do nebo celé směny.

Stiskem tlačítka [image] Hromadné operace otevřete formulář Hromadné operace s absencemi.

V horní části formuláře máte možnost zvolit zda:

- vkládaná operace bude do seznamu Vložena jako nová,

- jedná se o Opravu již vložené absence,

- je třeba již zadanou absenci Odstranit ze seznamu.

Vložení nové absence - funkce hromadně vytvoří absenci dle zadání.

· Datum od - do - nastavte období pro vložení absence do docházky vybrané skupině zaměstnanců.

· Absence - z nabízeného seznamu zvolte konkrétní absenci.

· Délka - absence máte možnost plánovat na půl směny, přesné časy od - do nebo celé směny.

· Jen pro rozdělení - pokud filtr neaktivujete, vytvoří se záznam všem zaměstnancům.

· Vložit absenci i pokud se překrývá s existující absencí v daném období - v případě existující absence v daném období bude stávající absence přepsána nově zadávanou.

· Vloží absenci jen do volných dnů - jestliže se ve vybraném období nevyskytují žádné volné dny, požadavek nebude proveden.

· V případě překrývání vkládané absence se dotázat - pokud by došlo k překrývání absencí, objeví se formulář pro řešení kolize:

Vyber typu vlozeni absence

o Vložit absenci i pokud se překrývá s existující absencí - v případě existující absence v daném období bude stávající absence přepsána nově zadanou.

o Vložit absenci jen do volných dnů - jestliže se ve vybraném období nevyskytují žádné volné dny, požadavek nebude proveden.

o Nevkládat - akce se neuskuteční.

o Platí pro všechny - nastavený způsob řešení kolize se uplatní u všech osob.

· Nevkládat, pokud v zadaném období již existuje absence - v případě existující absence v zadané období se vložení neuskuteční.

Po provedení operace se vygeneruje Protokol hromadné operace s absencemi:

Protokol hromadne absence s absencemi

Protokol hromadne absence s absencemi_Tlac. Ulozit do souboru | Uložit do souboru - ikona otevře okno pro výběr souboru pro uložení protokolu.
Protokol hromadne absence s absencemi_Tlac. Zavrit prohlizec | Zavřít prohlížeč - ikona má stejnou funkci jako červený křížek v pravém horním rohu.

Oprava absence - funkce provede hromadnou opravu. Automaticky se nabídne naposledy vkládaná operace.

Formulář je rozdělen do dvou sekcí:

· Údaje pro výběr absencí - absence vyhovující zadaným podmínkám budou změněny - nastavte hodnoty, které mají být změněny.

· Údaje pro opravu absencí - nové hodnoty - vyplňte údaje, kterými se přepíšou původní záznamy.

Odstranění absence - funkce pro hromadné zrušení absence, nabídne se poslední zadané nastavení.

Ve formuláři zadejte Datum od kdy, do kdy se mají absence odstranit, o jakou Absenci se jedná (Dovolená apod.) a vyberte rozdělení, pro které se má smazání absencí provést. Ve formuláři máte možnost nastavit, zda má být smazána Celá směna nebo jen její první nebo druhá půlka, případně čas od - do. Absence vyhovující nastaveným podmínkám budou smazány.

Pro vkládání, opravu i pro mazání absencí je možné použít tlačítko pro potvrzení zadaných údajů [image] nebo pro uzavření formuláře [image]. Po potvrzení a provedení hromadných operací s absencemi se zobrazí okno Protokolu se seznamem provedených změn.


Plánování kapacit

Navigation: Docházka >

Plánování kapacit

 Return to chapter overview

Program Docházka je možno rozšířit o modul Plánování kapacit. Pomocí tohoto modulu nahradíte komplikované plánování směn nepřetržitých a vícesměnných provozů v tabulkách Excelu apod.

Pomocí přehledného zobrazení budete schopni naplánovat směny zaměstnanců (ranní, odpolední, noční, …) a jejich plánované absence (dovolené, služební cesty, …). Naplánované kapacity jsou graficky zobrazeny v přehledné tabulce a výsledné hodnoty součtů směn jsou zobrazeny v dolní části náhledu.

Vše podstatné o plánování kapacit se dozvíte v kapitole Modul PLÁNOVÁNÍ KAPACIT.


Editace zpracované docházky

Navigation: Docházka >

Editace zpracované docházky

 Return to chapter overview

Funkce zpracování původní docházky připravila jednotlivé časové intervaly definované dnem a časem počátku a konce. Další vlastnosti zpracovaného intervalu určují délku započítané operace, druh operace, přiřazenou směnu. Takto standardně vygenerované záznamy jsou zobrazeny v grafickém editoru, který umožňuje ruční úpravu (editaci) těchto údajů. Při provedení ruční editace se k záznamu připíše údaj o uživateli, který provedl tuto úpravu.

Prvním krokem pro editaci je zobrazení všech zaměstnanců v seznamu pro editaci docházky. Z tohoto seznamu se dostanete k individuálním údajům o docházce jednotlivých zaměstnanců ve formuláři editace docházky.

Tento seznam zobrazuje všechny aktuální pracovníky pro zpracování docházky.

V horní části seznamu můžete zapnout rychlé filtry pro zobrazení vybrané skupiny, časové složky v docházce, kalendáře nebo typu osoby. Stiskem tlačítka "Jen rozdělení" zapnete omezení pro vybrané rozdělení, které nastavíte v poli vedle tohoto tlačítka. Pokud chcete filtr zrušit, stiskněte zaškrtávátko "Jen rozdělení" znovu. U filtru "Jen s časovou složkou" můžete volit druh výsledku (Měsíční/Denní), typ hodnoty (Hodiny/Dny/Kalendářní dny), operátor porovnání a hodnotu (případně hodnoty od-do).

Lupa

Vyhledat podle načtené karty - po přiložení karty ke čtecí hlavě program vyhledá osobu, která má tuto kartu přiřazenou a zároveň se otevře formulář pro prohlížení a editaci docházky pro konkrétního zaměstnance.

Položky datum od 1.10.2009 do 31.10.2009

Všechny následující funkce budou provedeny pro zde nastavené období.

Tlačítko Schvalování - můžete provést hromadné schválení zpracované docházky k zadanému datu. Umožní vám provedení schválení pro všechny zaměstnance, kteří jsou zobrazeni v seznamu (respektuje aktuální filtr tohoto seznamu). Schválení můžete provést v úrovních, na které máte přístupová práva. Více informací najdete v kapitole schvalování docházky.

Tlačítko Hromadné vložení docházky - tato funkce umožní hromadně vložit záznam zpracované docházky všem nebo vybraným pracovním poměrům v seznamu.

Tlačítko Zpracování podle původní docházky - tato funkce provede zrušení zpracovaných intervalů docházky a jejich nové sestavení za období zadané v záhlaví seznamu. Pokud provedete tuto funkci, přijdete o všechny ruční úpravy docházky v tomto období. Tuto možnost použijete v případech, kdy chcete změnit základní vlastnosti operací terminálů nebo kalendářů, které ovlivňují způsob sestavování intervalů z původní docházky (zaokrouhlení počátku apod.).

Tlačítko Generovat přestávky - můžete provést vygenerování automaticky vkládaných přestávek do zpracované docházky za období zadané v záhlaví seznamu. Vložení přestávek se řídí pravidly definovanými v seznamu směn.

Tlačítko Podle kalendáře - můžete provést automatické vygenerování docházky dle nastavených směn. V následném zobrazeném formuláři vyberte operaci, kterou požadujete vložit a následně můžete využít následující volby:

Bez dalšího nastavení - program vloží pro zobrazený seznam zaměstnanců a nastavené období požadovanou operaci v délce denní normy.

Položka "Použít počátek a konec směny" - pokud je tato položka při vkládání dat vypnuta provede se vložení od času počátku směny a v délce nastavené v definici směny. Pokud je položka zaškrtnuta provede se vložení intervalu omezeného počátkem a koncem směny.

Položka "Použít časy pevného jádra" - změní podmínky vkládání na časy určené pevným jádrem směny.

Položka "Vkládat přestávky" - pokud je tato volba aktivní tak se po vložení docházky podle kalendáře vloží přestávky podle směn. Pokud je tato volba aktivní a délka intervalu není určena podle konce směny, ale délkou, pak se délka intervalu natáhne o délku vložených přestávek, tak aby nebyl záporný přesčas.

Položka "Automaticky opakovat v dalších dnech" - v první den opakování se vloží záznam původní docházky.

TIP: Tímto způsobem je možné hromadně vkládat např. celozávodní dovolenou.

Tlačítko Přepočet výsledků - můžete provést přepočet výsledků docházky dle zpracovaných intervalů všech zaměstnanců najednou. Intervaly zůstávají zachovány, provádí se přepočet výsledků časových složek. Zachovány zůstanou všechny ručně editované záznamy. Tuto funkci použijte v případě, že provádíte změny v nastavení započítávání jednotlivých operací do časových složek.

Všechny popsané operace se vždy týkají pouze zaměstnanců aktuálně zobrazených v seznamu. Funkce respektují aktuálně nastavený filtr. Pokud byste chtěli provést operaci pro všechny zaměstnance, musíte zrušit všechny filtry na tomto seznamu.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář (viz ovládání seznamu). Ve formuláři uvidíte přehledně graficky údaje o docházce.


Formulář editace

Navigation: Docházka > Editace zpracované docházky >

Formulář editace

 Return to chapter overview

Tento formulář je tím nejpoužívanějším, který vám usnadní zpracování dat o docházce. V přehledném grafickém zobrazení vidíte údaje o docházce v barevných intervalech. V menu Systém/Nastavení aplikace/Společné nastavení - Editace docházky můžete provést nastavení týkající se chování programu v tomto formuláři.

Formulář editace docházky se skládá z několika základních částí.

Část první - záhlaví formuláře

V záhlaví formuláře jsou základní identifikační údaje zaměstnance. Kromě těchto údajů, je zde dále zobrazeno období, přiřazení kalendáře a zaškrtávátko zpracováno ve mzdách (viz schvalování docházky - uzavření pro mzdy).

§ Období - Tato položka je aktivní. Můžete přepnout zobrazení docházky zaměstnance do jiného období. Přepnutí je aplikováno pouze na aktuálního zaměstnance. Pokud požadujete změnu období pro všechny zaměstnance, je možné to provést v menu Systém/Výběr období.

Část druhá - zobrazení intervalů docházky

V této části je zobrazena docházka zaměstnance do dne, kdy byla zpracována. Vodorovná osa zobrazuje čas od 0 do 24 hodiny. Svislá osa první sloupec - Datum - zobrazuje dny v měsíci, druhý sloupec - Směna - označuje přiřazenou směnu k danému pracovnímu dni a graficky zobrazuje její počátek a konec. V jednotlivých řádcích jsou pak zobrazeny intervaly docházky. Plnobarevné intervaly jsou počítány z původní docházky a nebyly v programu ručně upravovány. Šrafované intervaly jsou upraveny uživatelem. V pravé části tohoto pole můžete volitelně nastavit sloupce s vybranými údaji. Nastavení provedete v menu Systém - Nastavení - Nastavení aplikace - Editace docházky - Nastavení zobrazení denních výsledků. Zde si můžete vybrat a nastavit, kterou časovou složku chcete ve formuláři jako součtovou hodnotu za každý den vidět, jejich počet není nijak omezen.

V levém rohu editace docházky (pod jménem zaměstnance) je možné docházku přepnout z grafického zobrazení na zobrazení textové.

Dvojklikem na vykresleném barevném intervalu zobrazíte formulář Záznam docházky.

V tomto okně je možné upravit daný interval denního záznamu dle potřeby. Máte zde i možnost vkládat půl směny podle kalendáře. Upravuje se buď v řádku zobrazený čas a tato oprava následně upraví graficky celou docházku daného dne ve zvoleném intervalu nebo se opravuje interval v řádku započtený čas, kde výsledek bude upraven tak, že nedojde k umazání/přidání grafického záznamu celé části, ale zobrazí se daná úprava jako zub a bude vidět původní délka odpracované doby, ale započtena bude pouze její část. Rozdíl po této opravě je pak zapsán v řádku Úprava.

Část třetí - výsledky

Pod grafickým polem s intervaly docházky jsou zobrazeny záložky s údaji docházky, původní docházky, průchody, absencemi, měsíčními výsledky, mzdovými položkami a výrobou.

Ø Záložka Docházka - pro zvolený den (rozsah dní) v grafické části zobrazuje jednotlivé časové intervaly položek docházky a zároveň, byla-li provedena jakákoliv úprava časového intervalu, zobrazuje i uživatele, který danou úpravu provedl. Tlačítkem Novy zaznam1 Nový záznam nebo Editace zaznamu1 Editací záznamu se dostanete do formuláře Záznam docházky.

Ø Záložka Původní docházka - seznam původních záznamů příchodů, odchodů a operací provedených na terminálu kartou/čipem/otiskem daného zaměstnance. Tyto údaje nelze měnit. Jsou informativní.

Ø Záložka Průchody - seznam průchodů dveřmi, bránami, turnikety atd.

Ø Záložka Absence - seznam všech plánovaných absencí uživatele z tabulky Plánování absencí, nemusí být shodný s výslednou docházkou v případě, že zaměstnanec místo naplánované dovolené přijde do práce, v tomto případě má přednost docházka nasnímaná z terminálu. Tlačítkem Novy zaznam1 Nový záznam nebo Editace zaznamu1 Editací záznamu se dostanete do formuláře Absence.

Ø Záložka Měsíční výsledky - přehled všech výsledků časových složek dosažených zaměstnancem za aktuálně zobrazený měsíc. Přehled je v hodinách, dnech případně kalendářních dnech, dle nastavení příslušné časové složky. Všechny výsledky docházky jsou přepočítány do jednotlivých časových složek – např. odpracovaná doba, přesčas 25%, přesčas 50%, nemocenská, … Program umožňuje editaci měsíčních výsledků (časových složek). Je tedy možné měsíční vypočtené hodnoty dále upravovat.

Úprava měsíčních výsledků se provádí v záložce Měsíční výsledky v grafickém zobrazení docházky jednotlivého zaměstnance. Po stisku bude zobrazen seznam aktuálních časových složek. Dvojklikem na požadované časové složce se zobrazí okno s možností editace jednotlivých výsledků (hodiny, pracovní dny a kalendářní dny). Upravené výsledky potvrďte stiskem ikony OK.

POZOR: Úpravu měsíčních výsledků provádějte (pokud je to nutné), až po provedení všech úprav v editaci docházky a po všech přepočtech a zpracováních. Po jakékoli změně v editaci docházky budou u aktuálního zaměstnance přepočteny jeho měsíční výsledky.

Ø Záložka Denní výsledky - přehled všech výsledků časových složek dosažených zaměstnancem za aktuálně vybraný den, případně za celý měsíc po zatržení "Zobrazit data za celé období".

Ø Záložka Měsíční výsledky R - tato záložka se zobrazuje, pokud používáte Rozdělení docházky. Zobrazí se měsíční výsledky časových složek za jednotlivá rozdělení.

Ø Záložka Denní výsledky R - tato záložka se zobrazuje, pokud používáte Rozdělení docházky. Zobrazí se denní výsledky časových složek za jednotlivá rozdělení.

Ø Záložka Editace rozdělení MV - tuto funkci využijí zákazníci, kteří potřebují rozdělit měsíční výsledky časových složek na jednotlivé rozdělení (zakázky). Formulář Rozdělení měsíčního výsledku výpočtu otevřete stiskem tlačítka Novy zaznam1 Nový záznam.

· Rodné číslo, Osobní číslo, Datum nástupu - údaje o zaměstnanci.

· Měsíc - měsíc, ve kterém se provádí úpravy rozdělení měsíčního výsledku výpočtu.

· Typ časové složky - ze seznamu vyberte požadovanou časovou složku. Pokud v seznamu není na výběr žádná časová složka, proveďte nastavení v menu Seznamy -> Typy časových složek -> Formulář Typu časové složky -> Záložka Vlastnosti -> Podzáložka Rozšířené nastavení -> pole Manuální editace rozdělení měsíčních výsledků.

· Typ rozdělení, Rozdělení - ze seznamu zvolte požadovaný typ rozdělení a rozdělení.

· Hodiny, Dny, Kalendářní dny - vyplňte požadované hodnoty.

Ø Záložka Editace rozdělení DV - tuto funkci využijí zákazníci, kteří potřebují rozdělit denní výsledky časových složek na jednotlivé rozdělení (zakázky). Formulář Rozdělení denního výsledku výpočtu otevřete stiskem tlačítka Novy zaznam1 Nový záznam. Ve formuláři vyplňujete stejná pole jako v případě formuláře Rozdělení měsíčního výsledku výpočtu. Navíc je zde nutné vybrat požadovaný Den.

Ø Záložka Výsledky za variabilní období - tato záložka se zobrazuje, jen pokud používáte Variabilní období. V záložce se zobrazí přehled všech výsledků časových složek dosažených zaměstnancem za variabilní období.

Ø Záložka Výsledky omezení - je zde zobrazen seznam časových složek, pro které je nastaveno časové omezení. Nastavením časového omezení kontrolujete například odpracované hodiny za den, dobu strávenou u lékaře za rok apod. Mezní hodnoty vybrané časové složky nastavíte v menu Seznamy/Kalendáře/Formulář kalendáře/Záložka omezení. Pokud chcete využít této funkce programu, je potřeba ji aktivovat v menu Systém/Nastavení aplikace/Společné nastavení/Zpracování původní docházky - Počítat omezení časových složek mzdy.

Ø Záložka Mzdové položky - seznam všech mzdových položek, které lze zadávat v docházkovém systému a které jsou následně převáděny do mzdového systému. Např. Odměny, osobní příplatek apod.

Mzdovou položku můžete přidat kliknutím na tlačítko Novy zaznam1 Nový záznam a v otevřeném formuláři Mzdová položka vyplníte potřebné údaje. Záznamy můžete upravovat tlačítkem Editace zaznamu1 Editace záznamu.

Formulář obsahuje následující položky:

· Kód mzdové položky - zadejte položku, pro kterou se má daná operace započítávat (základní mzda, příplatky, atp.).

· Počet jednotek - množství jednotek, za které má být operace proplacená.

· Cena za jednotku - cena jedné jednotky.

· Celková částka - celková cena za všechny jednotky.

· Poznámka - libovolná informace o vkládané mzdové položce.

V rozlišení mzdové položky můžete vložit Typ rozdělení a rozdělení.

Ø Záložka Výroba - zde jsou zobrazeny výsledky činnosti daného zaměstnance v případě, že je v docházce používán modul Evidence výroby. Tlačítkem Novy zaznam1 Nový záznam nebo Editace zaznamu1 Editací záznamu se dostanete do formuláře Záznam výroby.

Ø Záložka Původní výroba - seznam původních záznamů činností, které zaměstnanec (nebo jeho identifikační médium) označil na výrobním terminálu. Tyto údaje nelze měnit. Jsou informativní.

Ø Záložka Výsledky výroby - jsou zde zobrazeny časové intervaly jednotlivých výrobních činností.

Ø Záložka Služební cesty - pokud se ve zvoleném dni (rozsahu dní) vyskytují služební cesty, potom se zobrazí v tomto seznamu. Seznam je zobrazen, pokud je aktivován modul Cestovní náhrady. Tlačítkem Novy zaznam1 Nový záznam nebo Editace zaznamu1 Editací záznamu se dostanete do formuláře Služební cesta.

Ø Záložka Fotografie z terminálu - seznam operací včetně fotografie, které byli označeny na terminálu umožňující vyfotografování osoby, která přiložila identifikační médium.

Ø Záložka Dokumenty - záložka je dostupná pouze pro SQL verzi. Dokumenty jsou vázány na pracovní poměr a vybrané období v editaci docházky. Tlačítkem Novy zaznam1 Nový záznam nebo Editace zaznamu1 Editací záznamu se dostanete do formuláře Dokument.

Část čtvrtá - Tabulka měsíčních výsledků

V této části lze jednoduchým nastavení zobrazit vybrané měsíční výsledky nezávisle na měsíčních výsledcích zobrazovaných v záložce měsíční výsledky. Nastavení provedete v menu - Systém - Nastavení - Nastavení aplikace - Editace docházky - Nastavení zobrazení měsíčních výsledků. Takto nastavené položky budou následně zobrazeny v této tabulce. U měsíčních výsledků označených v pravém horním rohu je možné editovat konečný měsíční výsledek.

Část pátá - tlačítka

Seznam a šipky posuvu - slouží k rychlejšímu přesunu v editaci docházky mezi jednotlivými zaměstnanci aniž by bylo potřeba vypínat okno editace.

Podle původní docházky - provede znovu sestavení intervalů docházky podle původních záznamů terminálů a přepočet výsledků docházky za období označené v grafické části. Označení více dnů proveďte tažením myší v seznamu. Při použití této funkce přijdete o všechny ruční editace ve zvoleném časovém intervalu.

Podle kalendáře - nabídne vložení údajů o docházce podle směn přednastavených v kalendáři. Označte v grafické části den nebo dny pro které chcete údaje vložit. Klikněte na toto tlačítko, zvolte operaci, případně rozsah datumů. Systém vloží takto zvolenou operaci.

Položka "Použít počátek a konec směny" - pokud je tato položka při vkládání dat vypnuta provede se vložení od času počátku směny a v délce nastavené v definici směny. Pokud je položka zaškrtnuta provede se vložení intervalu omezeného počátkem a koncem směny.

Položka "Použít časy pevného jádra" - změní podmínky vkládání na časy určené pevným jádrem směny.

Položka "Vkládat přestávky" - pokud je tato volba aktivní tak se po vložení docházky podle kalendáře vloží přestávky podle směn. Pokud je tato volba aktivní a délka intervalu není určena podle konce směny, ale délkou, pak se délka intervalu natáhne o délku vložených přestávek, tak aby nebyl záporný přesčas.

Položka "Automaticky opakovat v dalších dnech" - v první den opakování se vloží záznam původní docházky.

Přestávky - vloží automatické přestávky do zvolených dnů podle podmínek nastavených u přiřazené směny.

Přepočet - provede přepočet výsledků docházky dle zpracovaných údajů, ale pouze pro daného zaměstnance

Schválení - zobrazí formulář pro schvalování docházky tak, abyste mohli provádět uzavírání a schvalování docházky podle nastavených přístupových práv.

Tisk sestav - v této položce se zobrazí manažer tiskových sestav, aniž by bylo potřeba opouštět formulář editace docházky a tisknout docházku daného zaměstnance.

Zavřít - uzavře okno s editací zpracované docházky.


Schvalování docházky

Navigation: Docházka > Editace zpracované docházky >

Schvalování docházky

 Return to chapter overview

Funkce schvalování docházky použijete v případě, že ve vaší firmě jsou definovány pravomoci pro schvalování údajů a existuje hierarchie tohoto schvalování.

Základní stupeň hierarchie zpracovaní docházky ve firmě nastavíte přístupovými právy tak, aby byli definováni uživatelé, kteří mají nastaveno, kdo může vidět nebo editovat docházku a kterým pracovníkům.

Dalším stupněm je nastavení úrovní schvalování. Systém umožňuje zavedení 3 stupňů schvalování docházky s možností ještě dalšího stupně, který může editaci docházky kompletně zablokovat.

Přístupová práva pro jednotlivé stupně schvalování je nutné nastavit v přístupových právech k systému.

Tři úrovně schvalování - první úroveň je zelená (zpracováno), druhá žlutá (zkontrolováno) a třetí červená (schváleno).

Pracovník, který má právo na zelenou úroveň schválení, provede schválení k určitému datu a tím dá najevo uživatelům schvalujícím ve vyšší úrovni, že jsou údaje o docházce zpracovány. Uživatel se žlutou úrovní záznamy prohlédne a může přidat svou úroveň zkontrolováno. Pokud je docházka zkontrolována nemůže uživatel, který docházku zpracoval již tento příznak zrušit, aby provedl opravy. Pokud by chtěl opravy provést, musí mu to uživatel s vyšší úrovní povolit tím, že zruší svou úroveň schválení.

Stejný postup pokračuje s úrovní červenou - schválení. Pokud potřebujete upravit údaje v docházce, musí vám to povolit uživatel, který docházku po vás schválil vyšší úrovní.

Samozřejmě není nutné, aby byla dodržována celá hierarchie třístupňového schvalování, záleží pouze na vás, kolik úrovní budete používat.

TIP: Pokud je docházka schválena některou z úrovní není možné ji již editovat. Nezapomeňte také na to, že pro schválení docházky musíte mít dostatečná uživatelská práva.

Tři způsoby schvalování:

Jednotlivě - ve formuláři editace stiskněte tlačítko "Schvalování" a do zobrazeného okna můžete zadat datum, do kdy chcete docházku schválit. Pokud chcete schválení zrušit, přepište datum na nižší nebo datum zcela vymažte. Tímto způsobem schvalujete docházku u jednotlivých zaměstnanců.

Jednotlivě - ve formuláři editace označte den, ke kterému chcete docházku schválit. Potom klikněte pravý tlačítkem myši na tomto označeném řádku a vyberte z nabízených úrovní schválení. Tímto způsobem schvalujete docházku u jednotlivých zaměstnanců.

Hromadně - pokud budete chtít provést hromadné schválení, použijte tlačítko "Schvalování" v seznamu zaměstnanců pro editaci docházky. Schválení proběhne pro všechny zaměstnance zobrazené v seznamu. To znamená, pokud máte nastavený filtr např. pro skupinu, můžete jednorázově provést schválení pro celou skupinu.

TIP: Pro urychlení práce se schvalováním docházky je možné použít pravé tlačítku myši, označením daného dne a kliknutím pravým tlačítkem myši se zobrazí menu, ve kterém je možno nastavit jak schválení docházky tak i upravení docházky.

Uzavření pro mzdy

Poslední úrovní je uzavření docházky příznakem, že je již převedena do mezd. Tato úroveň není řízena datem v průběhu měsíce. Provádí pouze kompletní uzavření celého měsíce. Jedná se o nejvyšší úroveň. Pokud jsou data převedena do mezd, neměli byste již do docházky zasahovat (pokud mzdová účetní tento příznak nezruší).


Editace denních výsledků

Navigation: Docházka >

Editace denních výsledků

 Return to chapter overview

V tomto menu máte možnost editovat denní výsledky zaměstnanců. Editaci můžete provádět v jednom vybraném dni nebo ve zvolené časové složce. Editovat lze jen ty složky, které mají v menu Seznamy/Typy časových složek/formulář Časové složky/záložka Vlastnosti/záložka Rozšířené nastavení zaškrtnutou položku Nepřepočítávat denní výsledky.


Jedna časová složka

Navigation: Docházka > Editace denních výsledků >

Jedna časová složka

 Return to chapter overview

Pro přehlednější pohyb v zadaných datech je vhodné využít filtrů, které jsou k dispozici nad seznamem.

§ Jen rozdělení - vyberte rozdělení, pro které chcete zobrazit seznam.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

§ Jen s kalendářem - výběrová položka poskytne seznam zaměstnanců s vybraným kalendářem.

§ Jen typ osoby - nabízí se varianta Zaměstnanec a Zaměstnanec jiné firmy.

§ Jedna časová složka - zobrazí seznam pro jednu časovou složku.

§ Jeden den - zobrazí seznam pro jeden den.

§ Časová složka - vyberte časovou složku, pro kterou chcete zobrazit seznam.

§ Období - vyberte měsíc, pro který chcete zobrazit data. V nabídce budete mít jen ty měsíce (období), které jsou vytvořeny v menu Systém/Výběr období.

§ Skrýt nulové hodnoty - zatržením zvolte, zda chcete skrýt nulové hodnoty v tabulce.

§ Hodiny - v seznamu se zobrazí hodinové hodnoty.

§ Dny - v seznamu se zobrazí dny.

§ Kalendářní dny - v seznamu se zobrazí kalendářní dny.

Kliknutím na podtržený nadpis Jména osoby se dostanete do formuláře Editace zpracované docházky.


Jeden den

Navigation: Docházka > Editace denních výsledků >

Jeden den

 Return to chapter overview

Pro přehlednější pohyb v zadaných datech je vhodné využít filtrů, které jsou k dispozici nad seznamem. Kliknutím na podtržený nadpis Jména osoby se dostanete do formuláře Editace zpracované docházky.

§ Jen rozdělení - vyberte rozdělení, pro které chcete zobrazit seznam.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

§ Jen s kalendářem - výběrová položka poskytne seznam zaměstnanců s vybraným kalendářem.

§ Jen typ osoby - nabízí se varianta Zaměstnanec a Zaměstnanec jiné firmy.

§ Jedna časová složka - zobrazí seznam pro jednu časovou složku.

§ Jeden den - zobrazí seznam pro jeden den.

§ Datum - vyberte datum, pro které chcete zobrazit seznam.

§ Nastavení časových složek - zde můžete provést nastavení časových složek.

V editaci denních výsledků pro jeden den máte možnost zobrazit datum schválení docházky, nastavit barvu textu a pozadí pro jednotlivé sloupce a barevné rozlišení záporných hodnot.


Editace měsíčních výsledů

Navigation: Docházka >

Editace měsíčních výsledků

 Return to chapter overview

V tomto menu máte možnost editovat měsíční výsledky zaměstnanců. Editaci můžete provádět ve zvolené časové složce. Editovat lze jen ty složky, které mají v menu Seznamy/Typy časových složek/formulář Časové složky/záložka Vlastnosti/záložka Rozšířené nastavení zaškrtnutou položku Nepřepočítávat měsíční výsledky. Pro přehlednější pohyb v zadaných datech je vhodné využít filtrů, které jsou k dispozici nad seznamem. Pod seznamem jsou zobrazeny celkové součty.

§ Jen rozdělení - vyberte rozdělení, pro které chcete zobrazit seznam.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

§ Jen s kalendářem - výběrová položka poskytne seznam zaměstnanců s vybraným kalendářem.

§ Jen typ osoby - nabízí se varianta Zaměstnanec a Zaměstnanec jiné firmy.

§ Období - vyberte datum, pro které chcete zobrazit seznam.

§ Nastavení sloupců - zde můžete provést nastavení časových složek.

V editaci měsíčních výsledků máte možnost zobrazit datum schválení docházky, nastavit barvu textu a pozadí pro jednotlivé sloupce a barevné rozlišení záporných hodnot.


Přepočet výsledků zpracované docházky

Navigation: Docházka >

Přepočet výsledků zpracované docházky

 Return to chapter overview

Touto funkcí můžete provést přepočet výsledků zpracované docházky všem zaměstnancům v seznamu pro dané období. Přepočítáváním nedochází ke změnám ve zpracovaných intervalech, provede se pouze přepočet časových složek za nastavené období.

Funkci využijete hlavně v počátcích používání tohoto systému, kdy po zpracování docházky zjistíte, že potřebujete některé události jinak započítat (do jiných časových složek). Po provedení změny v nastavení započítávání se totiž již zpracované výsledky zpětně automaticky nepřepočítávají, ale musíte k tomuto přepočtu dát pokyn.

Prepocet vysledku zpracovane dochazky


Zrušení zpracované docházky

Navigation: Docházka >

Zrušení zpracované docházky

 Return to chapter overview

Tato funkce provede zrušení vytvořených intervalů docházky za zvolené období. Pokud provedete tuto funkci, zruší se vypočtené intervaly i všechny změny provedené v editaci docházky. Proto s touto funkcí zacházejte velmi opatrně a práva ke spuštění dejte opravdu zodpovědné osobě.

Ani v tomto případě však nezrušíte seznam původní docházky, takže docházku můžete nechat znovu zpracovat. Nenávratně pryč jsou pouze vaše ruční zásahy ve zpracované docházce. Pokud jste v zadaném období žádné ruční úpravy nedělali, nemusíte se obávat tuto funkci použít.

Zruseni zpracovane dochazky


Přehled záznamů zpracované docházky

Navigation: Docházka >

Přehled záznamů zpracované docházky

 Return to chapter overview

Tento seznam zobrazuje celkový přehled záznamu zpracované docházky. V tomto seznamu není možné údaje měnit ani je mazat. V horní části seznamu můžete vybrat skupinu pracovníků, kterou chcete zobrazit. Pokud chcete tento filtr zapnout, musíte stisknout tlačítko "Jen skupina". Další volbou v horní části seznamu je nastavení zobrazeného období. Tyto rychlé filtry usnadní práci se seznamem.

Prehled zaznamu zpracovane dochazky


Přehled měsíčních výsledků výpočtu

Navigation: Docházka >

Přehled měsíčních výsledků výpočtu

 Return to chapter overview

Tento seznam zobrazuje celkový přehled záznamu zpracované docházky za určitý měsíc. V tomto seznamu není možné údaje měnit ani je mazat.

V horní části seznamu můžete vybrat skupinu pracovníků, kterou chcete zobrazit. Pokud chcete tento filtr zapnout, musíte stisknout tlačítko "Jen rozdělení". Další volbou v horní části seznamu je nastavení zobrazeného období. Tyto rychlé filtry usnadní práci se seznamem.

Prehled mesicnich vysledku vypoctu

Tento seznam představuje mocný nástroj na "dohledání požadovaných výsledků". Pomocí jednoduchých filtrů je možno se snadnou cestou dopracovat k hledaným údajům, případně rozdílům ve výsledcích docházky.

viz též denní výsledky výpočtu, přehled zpracované docházky


Přehled rozdělení měsíčních výsledků výpočtu

Navigation: Docházka >

Přehled rozdělení měsíčních výsledků výpočtu

 Return to chapter overview

Tento seznam je srovnatelný s přehledem měsíčních výsledků výpočtu. Seznam obsahuje oproti předcházejícímu seznamu údaje o typu rozdělení a rozdělení. V seznamu není možné údaje měnit ani je mazat. V horní části seznamu můžete vybrat skupinu pracovníků, kterou chcete zobrazit. Pokud chcete tento filtr zapnout, musíte zatrhnout pole u popisu "Jen rozdělení". Další volbou v horní části seznamu je nastavení zobrazeného období. Tyto rychlé filtry usnadní práci se seznamem.

Prehled rozdeleni mesicnich vysledku vypoctu


Denní výsledky výpočtů

Navigation: Docházka >

Denní výsledky výpočtů

 Return to chapter overview

Tento seznam zobrazuje celkový přehled záznamu zpracované docházky za určitý den. V tomto seznamu není možné údaje měnit ani je mazat. V horní části seznamu můžete vybrat skupinu pracovníků, kterou chcete zobrazit. Pokud chcete tento filtr zapnout, musíte stisknout tlačítko "Jen skupina". Další volbou v horní části seznamu je nastavení zobrazeného období. Tyto rychlé filtry usnadní práci se seznamem.

Denni vysledky vypoctu

viz přehled měsíčních výsledků výpočtu, přehled záznamů zpracované docházky


Přehled rozdělení denních výsledků výpočtu

Navigation: Docházka >

Přehled rozdělení denních výsledků výpočtu

 Return to chapter overview

Tento seznam je srovnatelný s přehledem denních výsledků výpočtu. Seznam obsahuje oproti předcházejícímu seznamu údaje o typu rozdělení a rozdělení. V seznamu není možné údaje měnit ani je mazat. V horní části seznamu můžete vybrat skupinu pracovníků, kterou chcete zobrazit. Pokud chcete tento filtr zapnout, musíte zatrhnout pole u popisu "Jen rozdělení". Další volbou v horní části seznamu je nastavení zobrazeného období. Tyto rychlé filtry usnadní práci se seznamem.

Prehled rozdeleni dennich vysledku vypoctu


Přehled mzdových položek

Navigation: Docházka >

Přehled mzdových položek

 Return to chapter overview

Přehled mzdových položek je ucelený seznam všech zaměstnanců v docházkovém systému, kteří mají zadanou jakoukoliv mzdovou položku, která je povolena vkládat v editaci docházky.

Prehled mzdovzch polozek

V seznamu je možno zvolit zobrazení jen jednotlivého vybraného zaměstnance, určité mzdové složky, vybraného rozdělení či zobrazení všech se mzdovou složkou za vybrané období případně kombinace jednotlivých filtrů.


Hromadné zadávání mzdových položek

Navigation: Docházka >

Hromadné zadávání mzdových položek

 Return to chapter overview

Formulář slouží k hromadnému zadávání mzdových položek zaměstnancům. Pro usnadnění, či zrychlení vyhledávání záznamů v seznamu, použijte filtry, které jsou umístěny v horní části formuláře.

Ve střední části formuláře jsou kolonky pro zadávání nových mzdových položek (prémie, osobní příplatky). Pro zadávání mzdových položek musí být nastaveno v menu Seznamy/Typy mzdových složek:

- povolení zadávání v docházce,

- druh mzdové položky musí být "Zadávací".

Hromadne zadavani mzdovych polozek

§ Období - kliknutím na podtržený měsíc zobrazíte seznam vytvořených období a vyberete měsíc, pro který se mají hromadně zadat mzdové položky.

§ Jen osoba - tímto filtrem můžete zvolit osobu, které chcete zadat mzdovou položku.

§ Jen mzdová položka - další možností je vložení dané mzdové položky u více zaměstnanců najednou.

§ Jen rozdělení - zatržením políčka se aktivuje seznam typů rozdělení a jednotlivých rozdělení. Tím se zobrazí jen struktura mzdy zaměstnanců, kteří mají v kartě přiřazeno vybrané rozdělení.

§ Pro nové záznamy použít hodnoty podle nastavení filtru - filtry můžete libovolně kombinovat a v závislosti na zvoleném filtru se vytvoří nový záznam (vybraná mzdová položka se přiřadí zaměstnancům, nebo zvolenému pracovníkovi vložíte mzdové položky, apod.).

§ Pro nové záznamy použít hodnoty poslední zadané - vloží takovou novou mzdovou položku, která byla zadána jako poslední.

§ Upozorňovat na již existující stejné položky - v případě zatržení této funkce budete programem upozorněni na vkládání již existující položky u daného pracovního poměru.

Vkládání nových údajů:

Hromadne zadavani mzdovych polozek_Tlac. Novy zaznam | Nový záznam - tlačítkem můžete vkládat nové údaje. Pokud chcete provést změny, označte mzdovou položku v seznamu a doplňte údaje v editační zóně.
Hromadne zadavani mzdovych polozek_Tlac. Potvrdit | Potvrdit - změny potvrďte.
Hromadne zadavani mzdovych polozek_Tlac. Zrusit | Zrušit - pokud chcete poslední úpravy stornovat, použijte toto tlačítko.

· Osoba - vyberte osobu, které chcete přiřadit/editovat strukturu mzdy. Automaticky se doplní i osobní číslo, rodné číslo a den nástupu.

· Položka - ze seznamu zvolte vkládanou/editovanou mzdovou položku. Nabídnou se pouze položky, které mají nastaven typ zadávací.

· Částka - pokud vyplníte kolonky počet jednotek a cena za jednotku, program již spočítá celkovou částku sám.


Historie průchodů

Navigation: Docházka >

Historie průchodů

 Return to chapter overview

Tento seznam je velmi podobný seznamu původní docházky. Rozdíl je v tom, že zde jsou záznamy z průchodových terminálů. Tyto záznamy se dále nijak nezpracovávají do docházky. Slouží pouze pro sledování přítomnosti (monitorování) a sledování přístupu do hlídaných prostor. Ovládání seznamu je shodné se seznamem původní docházky.

Ikonou editace se dostanete do formuláře Záznam historie průchodů.

Ve formulář je možné upravit položku Poznámka - textová informace o záznamu.


Manuální vložení operace do historie průchodů

Navigation: Docházka >

Manuální vložení operace do historie průchodů

 Return to chapter overview

Tato funkce umožňuje ruční zápis operace do historie průchodů. Tuto funkci použijete v případě, že zaměstnanec zapomene operaci zaznamenat nebo zapomene identifikační médium.

Manualni vlozeni operace do historie pruchodu

Uživatel může vybrat ze seznamu terminál, osobu, zadat datum operace, čas a druh operace. Pokud zaškrtnete volbu "pro více dnů" můžete zadat datum do kdy se má operace opakovaně vložit. Operace lze také hromadně vkládat pouze pro pracovní dny nebo pouze pro dny, ve kterých má zaměstnanec v kalendáři přiřazenou směnu. Ve výběru operací vám umožní vložit pouze operace, které mají v seznamu operací terminálu nastavenu volbu "Manuálně vkládat". Do pole poznámka můžete zadat krátkou textovou poznámku, například z jakého důvodu byla operace vložena manuálně.

Jakmile budete mít formulář vyplněn, klikněte na tlačítko Vlozit. Pokud budete vkládat více záznamů najednou, použijte tlačítko Vlozit bez uzavreni.


Přehled příchodů a odchodů

Navigation: Docházka >

Přehled příchodů a odchodů

 Return to chapter overview

Seznam zaměstnanců kontrolující dle přiřazené směny v kalendáři případně dle směny přiřazené v Plánování kapacit zda zaměstnanec přicházející na směnu má pozdní příchod či odchod případně nepřišel vůbec. Je zde rovněž možno využít filtrů pro větší přehlednost v záznamech.


Fotografie z terminálů

Navigation: Docházka >

Fotografie z terminálů

 Return to chapter overview

Seznam zobrazuje základní údaje o docházce. Záznamy jsou načteny z docházkových terminálů umožňující vyfotografování osoby, která přiložila identifikační médium. V seznamu není možné údaje měnit ani je mazat.

§ Jen rozdělení - vyberte rozdělení, pro které chcete zobrazit seznam.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení). Tuto strukturu můžete upravovat:

ú pokud podřízené rozdělení má být nadřízeným, označte jej a pravým tlačítkem aktivujte nabídku, ze které vyberte Přesunout na kořen stromu;

ú pokud nadřízené rozdělení má být podřízeným, označte jej levým tlačítkem myši a přetáhněte do rozdělení, kterému má být podřízeno.

§ Jen období - vyberte měsíc, pro který chcete zobrazit seznam.

§ Jen terminál - vyberte terminál, pro který chcete zobrazit seznam.

§ Jen datum čas od do - zadejte konkrétní data a časy, od kdy do kdy chcete nechat zobrazit data v seznamu.

§ Zobrazit fotografii - pokud chcete pro vybraný záznam zobrazit fotografii, zaškrtněte políčko.

TIP: Pravým tlačítkem myši na fotografii si můžete snímek uložit na pevný disk počítače.

Tlačítkem Editace zaznamu Editace záznamu se dostanete do formuláře Záznam fotografie z terminálu.

Do formuláře je možné doplnit poznámku. Další údaje není možné měnit.

Hromadné rušení záznamů fotografií

Fotografie v terminálů můžete vymazat v menu Aktuální okno -> Hromadné rušení záznamů fotografií.

V zobrazeném okně vyberte datum od - do. V zadaném intervalu se smažou všechny fotografie z terminálů uložené v docházce.

POZOR: Vymazané fotografie nelze zpět obnovit!


Monitorování

Navigation: Docházka >

Monitorování

 Return to chapter overview

Tento seznam zobrazuje stav přítomnosti pracovníků. Můžete zobrazit aktuální stav nebo stav k vybranému dni a času. Nezapomeňte vždy po změně nastavení použít ikonu Obnoveni seznamu pro obnovu obsahu seznamu. Po poklepání záznamu se zobrazí fotka pracovníka s jeho základními údaji.

Monitorovani pritomnosti osob

Lupa

Vyhledat podle načtené karty - slouží pro rychlé vyhledávání osob. Po přiložení karty ke čtecí hlavě program vyhledá osobu, která má tuto kartu přiřazenou a zobrazí Formulář zaměstnance načtené osoby. Pokud tlačítko nefunguje, pak je nutné v menu Systém/Nastavení/Nastavení aplikace/Lokální nastavení/Načítání ID média vybrat název terminálu, který má tuto funkci využívat. Zkontrolujte, rovněž, zda máte nadefinovány parametry k tomuto terminálu v menu Terminály/Terminály.

Pokud chcete sledovat aktuální stav zaměstnanců, musíte také pravidelně načítat historii operací z terminálů. Pokud nastavíte v plánovači načítání historie každých pět minut, bude stav monitorování vždy se zpožděním maximálně pět minut. Pokud chcete mít stav s kratším zpožděním, nastavte kratší interval.

TIP: Pokud si zadáte pro načítání dat z terminálu krátký interval, budete mít stav v monitorování aktuální, ale nezapomeňte, že tím můžete velmi zatížit počítač, který data vyčítá.


Návštěvy

Navigation: »No topics above this level«

Návštěvy

 Return to chapter overview

Program Docházka je možno rozšířit o modul Evidence návštěv. Modul slouží k zaznamenávání návštěv ve vaší firmě v elektronické podobě. Menu Návštěvy obsahuje následující položku:

Evidence návštěv


Evidence návštěv

Navigation: Návštěvy >

Evidence návštěv

 Return to chapter overview

Seznam plníte zaznamenáváním návštěv ve vaší firmě. V seznamu evidence návštěv lze snadno filtrovat a vyhledat požadované záznamy.

Seznam evidence navstev

Seznam je možné filtrovat podle typu návštěvy. K výběru se nabízejí položky Vše (typ návštěvy), Návštěva nebo Zaměstnanec. Dále je možné data filtrovat z hlediska vybraného časového úseku. V této sekci se nabízejí položky Přítomni, Akt. den (aktuální den), Akt. týden (aktuální týden), Vše a K datu (k vybranému datu).

Odchod - při odchodu návštěvy z firmy vám tato vrací ID médium a recepční/vrátný ukončuje v evidenci přítomnost stiskem tohoto tlačítka. Odchod se automaticky zapíše k vybrané osobě v seznamu.

Odchod - ID médium - v případě, že k zaznamenání odchodu použijete terminál, lze k načtení tohoto záznamu použít toto tlačítko. Lze použít i klávesovou zkratku Alt+C.

Odchod - čtečka dokladů - v případě, že k zaznamenání odchodu použijete čtečku dokladů, lze lze k načtení tohoto záznamu použít toto tlačítko. Můžete použít i klávesovou zkratku Alt+D.

§ Automatická obnova - seznam návštěv se automaticky obnoví.

§ Jen rozdělení (zaměstnanec) - z nabídky vyberte rozdělení zaměstnance, u kterého chcete zobrazit seznam návštěv. Pokud není rozdělení nastaveno v menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Evidence návštěv v poli Typ rozdělení pro evidenci návštěv, potom je zde zobrazen popis Typ rozdělení není nastaven. Pokud rozdělení nastavíte, zobrazí se zde vybrané rozdělení, například (Mzdové středisko).

§ Jen rozdělení (navštívená osoba) - seznam pro výběr navštívené osoby se filtruje podle zvoleného rozdělení. Pokud není rozdělení nastaveno v menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Evidence návštěv v poli Typ rozdělení pro evidenci návštěv, potom je zde zobrazen popis Typ rozdělení není nastaven. Pokud rozdělení nastavíte, zobrazí se zde vybrané rozdělení, například (Mzdové středisko).

§ Jen rozdělení (vrátnice) - v seznamu se zobrazí osoby, které prošli vybraným rozdělením (vrátnicí). Pokud není nastaven Typ rozdělení a rozdělení v menu Systém -> Nastavení -> Nastavení aplikace -> Lokální nastavení -> Nastavení vrátnice pro evidenci návštěv, potom je zde zobrazen popis Typ rozdělení (vrátnice) není nastaven. Pokud rozdělení nastavíte, zobrazí se zde vybrané rozdělení, například (Pracoviště).

§ Jen předem očekávané návštěvy - v seznamu se zobrazí jen záznamy, které mají ve formuláři Návštěvy zaškrtnuto pole Předem očekávaná návštěva.

§ Jen datum čas - pokud chcete záznamy třídit podle data a času, zaškrtněte pole. Následně se zobrazí pro výběr další nabídka. Zaškrtněte požadované pole Příchod nebo Očekávaný příchod nebo Odchod a následně vyberte datum a čas v polích od - do. Záznamy v seznamu se podle zvoleného vyfiltrují.

Vkládání nebo opravu údajů neprovádějte v seznamu, ale otevřete si Novy zaznam Nový záznam nebo tlačítkem Editace zaznamu Editace záznamu formulář Návštěva. Při kopírování starého záznamu stiskem tlačítka Kopie aktualniho1 Nový záznam z kopie aktuálního se nastaví příchod na aktuální čas a odchod se vynuluje. Nový záznam lze také vložit stiskem klávesy F12. Současně s otevřením formuláře se otevře i okno k načtení dokladu.

Zadáváte tučně zvýrazněné položky tedy nejméně příjmení, datum a čas příchodu, které se zapisují automaticky.

NÁVŠTĚVA

· Typ návštěvy - zvolte o jaký typ návštěvy se jedná, zda jde o Návštěvu nebo Zaměstnance.

· Vrátnice - v případě, že máte v menu Systém -> Nastavení -> Nastavení aplikace -> Lokální nastavení -> Nastavení vrátnice pro evidenci návštěv nastaven typ rozdělení a rozdělení, potom se při zadání nové návštěvy pole doplní automaticky.

Pokud jde o Návštěvu je možné zadat tyto údaje:

· Kód návštěvníka - identifikační číslo návštěvníka. Pokud máte v menuv menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Evidence návštěv zaškrtnuto pole Nabízet výběr z již zadaných položek, potom se v poli budou nabízet již dříve uložené záznamy. Vypnutím této volby lze urychlit načtení formuláře při velkém množství záznamů.

· Příjmení / Jméno / Titul - jeho příjmení, jméno a titul. Pokud máte v menuv menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Evidence návštěv zaškrtnuto pole Nabízet výběr z již zadaných položek, potom se v polích budou nabízet již dříve uložené záznamy. Vypnutím této volby lze urychlit načtení formuláře při velkém množství záznamů.

Doklad

Doklad (F11) - nové zadání návštěvy do systému je možné rovněž pomocí přídavné externí čtečky dokladů (OP, pas), kdy po navolení nového záznamu místo ručního vkládání údajů je možné použít ve formuláři toto tlačítko. Ve formuláři pro načtení dokladu lze rovněž použít klávesovou zkratku F11. Po uzavření formuláře návštěvy je "uvolněna" klávesová zkratka pro vkládání docházky.

· Firma - zadejte název firmy nebo ze seznamu vyberte požadovaný typ rozdělení pro firmu. Vybraný typ rozdělení nastavíte v menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Evidence návštěv v poli Typ rozdělení (Firma). V poli se po nastavení bude zobrazovat rozdělení vybraného typu. Pokud máte v menuv menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Evidence návštěv zaškrtnuto pole Nabízet výběr z již zadaných položek, potom se v poli budou nabízet již dříve uložené záznamy. Vypnutím této volby lze urychlit načtení formuláře při velkém množství záznamů.

Pokud se jedná o zaměstnance je možné zadat (bez možnosti zadat Firmu a načíst Doklad) tyto údaje:

· Zaměstnanec - vybranou osobu je možné načíst do formuláře kliknutím na "Zaměstnanec". Poté se zobrazí seznam zaměstnanců a zaměstnanců jiné firmy k aktuálnímu datu. Po zvolení záznamu se předvyplní údaje Jméno, Příjmení, Titul, Osobní číslo, Datum nástupu a rozdělení (Mzdové středisko) dle nastaveného Typu v menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Evidence návštěv v poli Typ rozdělení pro evidenci návštěv. Pokud chcete doplnit identifikační číslo návštěvníka, zadejte jej v poli Kód návštěvníka.

· Předem očekávaná návštěva - pokud se jedná o předem očekávanou návštěvu, zaškrtněte pole. Po zaškrtnutí pole je možné vyplnit očekávané datum a čas příchodu. Podle těchto záznamů je možné filtrovat data v seznamu.

· Očekávaný příchod - pole se zaktivní zatrhnutím pole Předem očekávaná návštěva. Poté je pole povinné, proto zadejte datum a čas očekávaného příchodu.

· Příchod - příchod návštěvy se vyplní automaticky otevřením formuláře Návštěva.

· Odchod - pole se vyplní automaticky, pokud použijete jedno ze tří tlačítek Odchodu v seznamu Evidence návštěv.

· Vozidlo - zadejte vozidlo, kterým návštěva přijela. Pokud máte v menuv menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Evidence návštěv zaškrtnuto pole Nabízet výběr z již zadaných položek, potom se v poli budou nabízet již dříve uložené záznamy. Vypnutím této volby lze urychlit načtení formuláře při velkém množství záznamů.

· Doklad - zadejte číslo dokladu totožnosti. Pokud máte v menuv menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Evidence návštěv zaškrtnuto pole Nabízet výběr z již zadaných položek, potom se v poli budou nabízet již dříve uložené záznamy. Vypnutím této volby lze urychlit načtení formuláře při velkém množství záznamů.

NAVŠTÍVENÁ OSOBA

· Mzdové středisko - pokud není rozdělení nastaveno v menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Evidence návštěv v poli Typ rozdělení pro evidenci návštěv, potom je zde zobrazen popis Rozdělení a pole je šedé (nelze vyplňovat). Pokud rozdělení nastavíte, zobrazí se zde vybrané rozdělení, například (Mzdové středisko). V seznamu se nabídnou pro výběr rozdělení vybraného typu. Stiskem podtrženého názvu pole Mzdové středisko zobrazíte okno se seznamem středisek.

· Navštívená osoba - výběr ze seznamu zaměstnanců vaší firmy. Seznam navštívené osoby (při vkládání návštěvy) se filtruje podle zvoleného rozdělení. Stiskem podtrženého názvu pole Navštívená osoba zobrazíte okno se seznamem zaměstnanců.

· Podrobnosti - stiskem podtrženého odkazu Podrobnosti: máte možnost zobrazit podrobnosti navštívené osoby. Například Rodné číslo, Jméno, Příjmení, Titul, Email, Telefon, Uživatelská pole. V zobrazeném seznamu klikněte na položky, které požadujete v podrobnostech zobrazit. Zatržítkem (modrou fajfkou) je položka vybraná.

· Důvod návštěvy - vepište důvod návštěvy.

· Vydání karty návštěvě - pokud je nastaveno Typ rozdělení a Rozdělení pro danou vrátnici v menu Systém -> Nastavení -> Nastavení aplikace -> Lokální nastavení -> Nastavení vrátnice pro evidenci návštěv, potom budou nabízeny jen karty těch externích osob, které mají přiřazeno dané rozdělení vrátnice.

· Příště přiřadit stejné médium - příště se přiřadí osobě stejné ID médium.

· Vyhledat osobu - osobu je možné vyhledat podle ID média Lupa (Alt+C) nebo podle čtečky dokladů Lupa (Alt+D).

· Povolit vyhledávání podle - pokud chcete vyhledávat v seznamu již dříve zadané záznamy, zaškrtněte pole. Ve spodní části formuláře se zobrazí záznamy podle povoleného vyhledávání (Kódu, Příjmení, Firmy, Vozidla). Požadovaná pole zaškrtněte. Vypnutím vyhledávání lze urychlit načítání formuláře.

V případě, že návštěvy nemají povolen přístup do celé budovy je možné po přiřazení média tímto povolit přístup jen do těch částí firmy, pro které je u ID média přiřazeno toto právo, čímž povolíme vstup i dané osobě (nastavení provádíme přiřazením práv osob a skupin pro terminály).

Všechny tyto údaje zůstanou zaznamenány v databázi a při další návštěvě dané osoby ve firmě je možné tyto údaje použít znovu, kdy vytvoříte nový záznam, ale tento již nově nevypisujete, pouze vybíráme z nabídky, kterou máme k dispozici z v minulosti načtených dat návštěv, tímto dojde k načtení nového data návštěvy, a následně je takto možné v historii dohledat, kdo a kdy přišel do vaší firmy.

Celý seznam návštěv je možno seřadit podle příjmení, podle data a času příchodu nebo odchodu, podle firmy – setřídění provedete dvojklikem na název sloupce, dle kterého chcete řadit. V případě velké cirkulace návštěv lze pomocí filtrů vybrat zobrazení pouze přítomných osob, případně pouze aktuální týden či den.

Pro rychlý výběr konkrétní osoby v seznamu použijte klávesovou zkratku CTRL+S - kdy se v dolním levém rohu objeví zadávací řádek, do kterého je možné zadat (podle druhu řazení) buď počátek příjmení hledané osoby nebo firmu apod. po tomto zadání dojde k výběru všech osob(firem), které zadání odpovídají a tím usnadnění hledání v datech (viz Ovládání seznamu).

Jednoduchým nasdílením aplikace docházky a navolením přístupových práv je možné tento modul spravovat na recepci/vrátnici Vaší firmy bez zásahu zaměstnanců do docházky.


Evidence výroby

Navigation: »No topics above this level«

Evidence výroby

 Return to chapter overview

Modul Evidence výroby je určen k vedení záznamů o práci na jednotlivých zakázkách a vykazování činností a prací na vybraném druhu výrobku se zakázkou souvisejících.

Menu Evidence výroby obsahuje tyto položky:

Výroba

Původní výroba

Zpracování původní výroby

Přepočet výsledků výroby

Činnosti

Typy výrobních činností

Vlastnosti výrobních činností

Tarify výrobních činností

Výrobky

Pracoviště

Výrobní zakázky

Typy výrobních zakázek

Pro správnou funkci tohoto modulu je potřeba nejprve naplnit číselníky - Výrobky, Činnosti a Výrobní zakázky.


Výroba

Navigation: Evidence výroby >

Výroba

 Return to chapter overview

Po naplnění číselníků je možné v Evidenci výroby zadávat u vybrané osoby, pro určitý den, zvolenou činnost, výrobek, zakázku a hodiny strávené při vybrané činnosti s daným výrobkem. Systém pak kontroluje odpracovanou dobu zaměstnance a výkaz jeho práce v evidenci výroby.

Pro přehlednější pohyb v zadaných datech je vhodné využít filtrů, které jsou k dispozici nad seznamem. Použitím filtrů zobrazíte pouze data např. vybrané osoby, činnosti, výrobku, zakázky či jejich kombinací.

Nad seznamem můžete použít následující filtry:

§ Jen osoba - po zatrhnutí této volby vyberte ze seznamu osobu, pro kterou chcete zobrazit seznam výroby. Osobu můžete vyhledat také v seznamu osob. Stačí kliknout na podtržený název pole Jen osoba - otevře se seznam pro Výběr ..., ve kterém po stisku tlačítek Ctrl+F na klávesnici můžete vyhledávat.

§ Jen výrobek - po zatrhnutí této volby se zobrazí pouze výrobek, který vyberete v rolovacím menu.

§ Jen činnost - po zatrhnutí této volby se zobrazí pouze činnost, kterou vyberete v rolovacím menu.

§ Jen zakázka - po zatrhnutí této volby se zobrazí pouze zakázka, kterou vyberete v rolovacím menu.

§ Jen rozdělení - po zatrhnutí této volby se zobrazí pouze dle rozdělení, které vyberete v rolovacím menu.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

§ Jen období - po zatrhnutí této volby se zobrazí data za období, které vyberete v rolovacím menu.

§ Jen den - zaškrtnutím políčka Jen den aktivujete roletku, kde vyberete požadované datum dne, pro které chcete zobrazit seznam výroby.

§ Jen zpracoval - po zatrhnutí této volby se zobrazí pouze data, která zpracoval uživatel vybraný v rolovacím menu.

§ Jen datum a čas od - do - vyberte datum a časový interval, pro který chcete zobrazit seznam výroby.

Pro korektní naplnění dat je v levé dolní části obrazovky zobrazen stav naplnění údaji z docházky a výroby. V případě zadání více hodin výroby než je součet hodin odpracované doby v docházce je stav řádku Výroba zbarven červeně.

Vkládání nebo opravu údajů neprovádějte v seznamu, ale otevřete si kliknutím na tlačítko Novy zaznam Nový záznam formulář Záznam výroby. Záznamy můžete upravovat tlačítkem Editace zaznamu Editace záznamu.

· Osoba - povinný údaj. Vyberte osobu, která na dané zakázce pracovala. Osobu můžete vyhledat také v seznamu osob. Stačí kliknout na podtržený název pole Osoba - otevře se seznam pro Výběr ..., ve kterém po stisku tlačítek Ctrl+F na klávesnici můžete vyhledávat.

· Den - povinný údaj. Vepište den práce na zakázce.

· Zakázka - zvolte zakázku, ke které se výrobek vztahuje.

· Mzdové středisko - rozdělení podle kterého evidujete výrobu. Nastavení provedete v menu Systém -> Nastavení aplikace -> Společné nastavení -> Evidence výroby.

· Činnost - povinný údaj. Vyberte činnost, kterou provádíte na výrobku (např. Obrábění).

· Výrobek - zvolte výrobek, na kterém se pracovalo.

· Datum čas od - do - zadejte datum a čas začátku a konce práce na výrobku.

· Hodiny - po vyplnění polí Datum čas od - do se pole Hodiny automaticky vypočte a vyplní. Po změně jednoho z polí Datum čas od - do se provede automatický přepočet hodin.

· Hmotnost - zadejte hmotnost. Při zpracování původní výroby se pole hmotnost přenese do výroby.

· Množství dobré - zadejte kolik výrobků bylo dobrých.

· Množství špatné - zadejte kolik výrobků bylo špatných.

· Datum schválení - schválení výroby vám umožní uzamknout výrobu do dne, který zvolíte (takto schválenou výrobu nebude program upravovat a zároveň ji jiný uživatel nebude moci upravit, pokud neodstraní schválení).

· Popis - do pole Popis můžete doplnit výkaz práce o libovolný popis.

· Prémie - zadejte prémie za odvedenou práci.

· Zpracoval - jméno uživatele, který výrobu zpracoval.

Výsledky výroby

Do seznamu výsledků výroby máte možnost přidávat další záznamy přes tlačítko Novy zaznam1 Nový záznam nebo editovat stávající záznamy přes tlačítko Editace zaznamu1 Editace záznamu. Po stisku tlačítka se zobrazí formulář Výsledek výroby.

Ve formuláři se vyplňují následující údaje:

· Zakázka - povinný údaj. Zvolte zakázku, ke které se výrobek vztahuje.

o kliknutím na podtržený nadpis Zakázka - otevře se seznam pro Výběr zakázky, ve kterém můžete editovat stávající údaje tlačítkem Editace zaznamu Editace záznamu nebo vkládat nové tlačítkem Novy zaznam Nový záznam. Více o výrobní zakázce naleznete v kapitole Výrobní zakázky.

o kliknutím na Vyberove tlacitko - otevře se výběrový seznam.

· Čas od - do - zadejte datum a čas začátku a konce práce na výrobku ve formátu DD.MM.RRRR HH:MM:SS.

· Hodiny - zadejte počet hodin práce na výrobku.

Položky s podtrženým názvem je možné v seznamu upravovat. Stačí kliknout na podtržený název pole - otevře se seznam pro Výběr ..., ve kterém můžete editovat stávající údaje tlačítkem Editace zaznamu Editace záznamu nebo vkládat nové tlačítkem Novy zaznam Nový záznam. V seznamu můžete po stisku tlačítek Ctrl+F na klávesnici také vyhledávat potřebné záznamy.


Původní výroba

Navigation: Evidence výroby >

Původní výroba

 Return to chapter overview

Jedná se soupis dat, která byla vyčtena z výrobního terminálu.

Nad seznamem můžete použít následující filtry:

§ Jen osoba - po zatrhnutí této volby vyberte ze seznamu osobu, pro kterou chcete zobrazit seznam původní výroby.

§ Jen výrobek - po zatrhnutí této volby se zobrazí pouze seznam původní výroby s vybraným výrobkem.

§ Jen činnost - po zatrhnutí této volby vyberte činnost, pro kterou chcete zobrazit seznam původní výroby.

§ Jen zakázka - po zatrhnutí této volby se zobrazí pouze seznam původní výroby s vybranou zakázkou.

§ Jen rozdělení - po zatržení této volby se zobrazí pouze dle rozdělení, které vyberete v rolovacím menu.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

§ Jen období - označením této volby se zobrazí data pouze za období, které zvolíte v rolovacím menu.

§ Jen terminál - v seznamu se zobrazí

§ Jen datum a čas - zatržením vám tato volba umožní nastavit rozsah zobrazovaných dat (Dny od-do, Hodiny od-do).

vyroba35

Manuální vkládání - tato funkce umožňuje ruční zápis činnosti do původní výroby. Všechny údaje vložené pomocí této funkce se zapisují do Seznamu výroby. Jde o registraci činnosti shodné s registrací na výrobním terminálu.

Tuto funkci použijete pouze v případě, že zaměstnanec zapomene operaci zaznamenat nebo zapomene identifikační médium nebo nemůže k terminálu z organizačních důvodů.

Puvodni vyroba_Manualni vlozeni zaznamu

Uživatel vybere ze seznamu terminál, osobu, zadá datum činnosti, čas a druh operace. Pokud zaškrtnete volbu "pro více dnů" zadejte datum do kdy se má operace opakovaně vkládat.

· Pro více dnů - pokud chcete činnost vložit pro více dnů, zatrhněte. Zároveň tím aktivujete položky Datum do a Jen v pracovní dny. Položka Datum se změní na položku Datum od.

· Terminál - povinná položka. Zvolte terminál, na kterém má být činnost zaznamenána.

· Osoba - povinná položka. Vyberte požadovanou osobu. Osobu můžete vyhledat také v seznamu osob. Stačí kliknout na podtržený název pole Jen osoba - otevře se seznam pro Výběr ..., ve kterém po stisku tlačítek Ctrl+F na klávesnici můžete vyhledávat.

· Datum/Datum od - povinná položka. Zadejte datum, na které má být činnost zaznamenána.

· Datum do - pokud jste zvolili vložení činnosti pro více dnů, je nutné vyplnit datum do.

· Čas - povinná položka. Zadejte čas činnosti.

· Činnost - povinná položka. Zvolte činnost, která se prováděla.

· Výrobek - vyberte výrobek, na kterém byla zvolená činnost prováděna.

· Hmotnost - zadejte hmotnost. Při zpracování původní výroby se pole hmotnost přenese do výroby.

· Poznámka - libovolná doplňující informace ke vkládanému záznamu, například z jakého důvodu byl záznam vložen manuálně.

· Jen v pracovní dny - pokud jste zvolili vložení činnosti pro více dnů, zvolte zaškrtnutím, zda chcete činnost vložit jen v pracovní dny.

· Ve směny - zaškrtnutím zvolte, zda chcete, aby činnost byla vložena pouze ve dnech, ve kterých má zaměstnanec v kalendáři přiřazenou směnu.

Pokud vkládáte jen jeden záznam do původní výroby, tak po vyplnění požadovaných údajů stiskněte tlačítko Vlozit. Pokud vkládáte záznamy pro více osob, vyberte si pro vložení záznamů jednu z následujících možností:

vyroba36 | Vložit bez uzavření - vloží záznam původní výroby do databáze bez uzavření formuláře pro manuální vkládání záznamu původní výroby.
vyroba37 | Vkládat načítáním ID média - po nastavení požadovaných údajů stiskněte toto tlačítko. Po té se zobrazí okno s informací, že se mají přikládat karty ke čtečce ID médií. Po přiložení karty se záznam vloží do databáze.
vyroba38 | Vkládat zadáním osobního čísla - po nastavení požadovaných údajů stiskněte toto tlačítko. Po té se zobrazí formulář, kde se zadávají osobní čísla. Zadejte osobní číslo a stiskněte tlačítko OK. Pokud chcete zadávání ukončit, stiskněte tlačítko Storno.

Opravu údajů neprovádějte v seznamu, ale otevřete si kliknutím na tlačítko Editace zaznamu Editace záznamu formulář Záznam výroby.

Puvodni vyroba_Zaznam vyroby

Informativní položky, které nelze měnit, jsou:

· Osoba - jméno a příjmení osoby včetně osobního čísla uvedeného v závorce.

· Vloženo manuálně - pokud je pole zaškrtnuté, byl záznam vložen manuálně.

· Datum a čas - datum a čas vložení nebo upravení záznamu ve formátu DD.MM.RRRR HH:MM:SS.

· Vložil manuálně - informace o uživateli, kterým byl záznam vložen nebo upraven.

· Terminál - v poli se zobrazí kód terminálu, na kterém byla zaznamenaná činnost.

· Karta - číslo ID média.

· Vloženo on-line - pokud je pole zaškrtnuté, byl záznam vložen manuálně.

Další položky, které můžete editovat, jsou:

· Činnost - výrobní činnost, která se prováděla.

· Výrobek - výrobek, na kterém byla zvolená činnost prováděna.

· Zakázka - zakázka, ke které se výrobek vztahuje.

· Mzdové středisko - pokud má záznam původní výroby nastaveno rozdělení, pak při zpracování výroby přebírá odpovídající záznam zpracované výroby přednostně dané rozdělení namísto rozdělení přiřazeného u terminálu. Vybrané rozdělení (například Mzdové středisko) jste nastavili v menu Systém -> Nastavení -> Nastavení aplikace -> Evidence výroby v poli Typ rozdělení pro zadávání rozdělení v záznamech evidence výroby.

· Výrobní číslo - identifikační číslo výrobku.

· Množství dobré - kolik výrobků bylo dobrých.

· Množství špatné - kolik výrobků bylo špatných.

· Hodiny - počet hodin práce na výrobku.

· Hmotnost - při zpracování původní výroby se pole hmotnost přenese do výroby.

· Poznámka - lze vložit libovolnou poznámku (např. proč byl záznam opraven apod.).


Zpracování původní výroby

Navigation: Evidence výroby >

Zpracování původní výroby

 Return to chapter overview

Program načte z terminálů jednotlivé údaje o činnostech, které zaměstnanec (nebo jeho identifikační médium) označil na výrobním terminálu. Tyto jednotlivé informace vám však neposkytnou přehlednou informaci o činnostech a jejich trvání. Proto je potřeba provést zpracování původní výroby.

Po spuštění zpracování původní výroby je nutné zadat datum, do kdy si přejete výrobní činnosti zpracovat.

Systém najde pro každého pracovníka jeho záznamy činností a zpracuje je do zadaného data. Všechny informace systém vyhodnotí na základě předem definovaných podmínek. Úpravy tohoto automatizovaného zpracování můžete provádět ve výrobě.

Pokud nemáte provedeno zpracování původní výroby, neuvidíte ve výrobě ani ve výstupních sestavách žádné výsledky.

Pokud bude zpracování původní bez chyby, zobrazí se tato informace:


Přepočet výsledků výroby

Navigation: Evidence výroby >

Přepočet výsledků výroby

 Return to chapter overview

Touto funkcí můžete provést přepočet výsledků zpracovaných činností všem zaměstnancům v seznamu pro dané období.

Přepočítáváním nedochází ke změnám ve zpracovaných informacích, provede se pouze přepočet časových složek za nastavené období.

Funkci využijete hlavně v počátcích používání tohoto systému, kdy po zpracování činností zjistíte, že potřebujete některé události jinak započítat (do jiných časových složek). Po provedení změny v nastavení započítávání se totiž již zpracované výsledky zpětně automaticky nepřepočítávají, ale musíte k tomuto přepočtu dát pokyn.


Činnosti

Navigation: Evidence výroby >

Činnosti

 Return to chapter overview

Zde lze nadefinovat činnosti, které jsou při výrobě použity. V případě výroby nábytku to může být například: "řezání, broušení, klížení/lepení, natírání, montáž výrobku, balení, příprava expedice apod.". Každé odvětví obsahuje jiné činnosti, v případě jejich nadefinování lze činnosti přiřadit k úkonům jednotlivých zaměstnanců ve výrobě.

V seznamu se nachází přehled všech činností.

Vkládání nebo opravu údajů neprovádějte v seznamu, ale otevřete si kliknutím na tlačítko Novy zaznam Nový záznam formulář Činnosti vyplníte potřebné údaje. Záznamy můžete upravovat tlačítkem Editace zaznamu Editace záznamu. Formulář má následující záložky:

Výrobní činnost

Nastavení v terminálu

Vlastnosti


Formulář činnosti - Výrobní činnost

Navigation: Evidence výroby > Činnosti >

Formulář činnosti - Výrobní činnost

 Return to chapter overview

Ve formuláři zadáte základní identifikační údaje o výrobní činnosti.

· Kód - povinný údaj. Označení činnosti.

· Aktivní - pokud je činnost aktivně využívána (je tedy platná), zatrhněte.

· Popis - povinný údaj. Krátký popis činnosti.

· Druh zpracování - povinný údaj. Vyberte druh zpracování (začátek, konec apod.).

· Typ - zvolte z číselníku typy výrobních činností požadovanou činnost.

· Tarif - zvolte tarif z číselníku tarify výrobních činností, kterých odpovídá vykonávané činnosti.

· Cena za jednotku - lze definovat cenu za jednotku.

· Normohodiny - uveďte v normohodinách jak dlouho se činnost provádí.

· Poznámka - lze vložit libovolnou poznámku (např. podrobnější popis činnosti apod.).


Formulář činnosti - Nastavení v terminálu

Navigation: Evidence výroby > Činnosti >

Formulář činnosti - Nastavení v terminálu

 Return to chapter overview

Ve formuláři zadáte základní nastavení výrobní činnosti v terminálu.

Cinnosti_Nastaveni v terminalu

· Popis v terminálu - text, který se bude zobrazen v terminálu.

· Popis tlačítka terminálu - popis tlačítka, Vám umožní tisknout popisky klávesnice terminálu.

· Zadávat kód výrobku - v případě zatrhnutí se bude terminál dotazovat na číslo zakázky.

· Zadávat výrobní číslo - v případě zatrhnutí se bude terminál dotazovat na výrobní číslo.

· Zadávat číslo zakázky - v případě zatržení bude tento údaj terminál vyžadovat.

· Zadávat množství dobré - umožní do terminálu vkládat informaci o počtu dobrých výrobků.

· Zadávat množství špatné - umožní do terminálu vkládat informaci o počtu špatných výrobků.

· Zadávat čas - terminál bude vyžadovat zadání času, během kterého byla činnost prováděna.

· Typ zadávání času - formát, ve kterém se bude čas do terminálu udávat:

o hh:mm - hodiny:minuty,

o hh - hodiny,

o mm - minuty.

· Povinná ukončovací činnost - pokud je zadání ukončení činnosti povinné, potom z nabídky vyberte činnost, kterou se předcházející činnost ukončí.


Formulář činnosti - Vlastnosti

Navigation: Evidence výroby > Činnosti >

Formulář činnosti - Vlastnosti

 Return to chapter overview

Výrobní činnosti v tomto formuláři můžete přiřadit její vlastnost. Seznam vlastností jste vytvořili ve Vlastnostech výrobních činností.

Požadované vlastnosti přiřazujete pomocí šipek Sipka seda vlevo, Sipka seda vpravo, které jsou umístěny ve formuláři mezi dvěma seznamy. V levé části tabulky se nachází seznam všech dostupných vlastností. V pravé části je seznam vybraných vlastností, které jsou přiřazeny k této činnosti.

Tlačítkem Editace zaznamu1 Editace záznamu se dostanete do formuláře Vlastnosti výrobních činností.


Typy výrobních činností

Navigation: Evidence výroby >

Typy výrobních činností

 Return to chapter overview

Do tohoto seznamu můžete přidávat nové typy výrobních činností. Tento číselník pak můžete využít v seznamu činnosti.

Vkládání nebo opravu údajů neprovádějte v seznamu, ale otevřete si kliknutím na tlačítko Novy zaznam Nový záznam formulář Typ výrobní činnosti. Záznamy můžete upravovat tlačítkem Editace zaznamu Editace záznamu.

· Kód - povinný údaj. Označení typu činnosti.

· Popis - povinný údaj. Krátký popis typu činnosti.

· Poznámka - lze vložit libovolnou poznámku.


Vlastnosti výrobních činností

Navigation: Evidence výroby >

Vlastnosti výrobních činností

 Return to chapter overview

V tomto seznamu se nachází číselník vlastností vyvíjených činností. Každá činnost, která je např. ve výrobním procesu, se vyznačuje určitou vlastností, tyto pak můžete použít v seznamu činnosti.

Vkládání nebo opravu údajů neprovádějte v seznamu, ale otevřete si kliknutím na tlačítko Novy zaznam Nový záznam formulář Vlastnost výrobní činnosti. Záznamy můžete upravovat tlačítkem Editace zaznamu Editace záznamu.

· Kód - povinný údaj - označení vlastnosti činnosti.

· Popis - povinný údaj - krátký popis vlastnosti činnosti.

· Poznámka - lze vložit libovolnou poznámku (např. podrobnější popis vlastnosti činnosti apod.).


Tarify výrobních činností

Navigation: Evidence výroby >

Tarify výrobních činností

 Return to chapter overview

V tomto seznamu lze vytvářet výrobní činnosti a přiřazovat k nim finanční ohodnocení. Každá činnost může být jinak fyziky či manuálně náročná a z tohoto důvodu i finančně jinak hodnocena. Pro snazší přehled je možné ke každé činnosti zvolit libovolný tarif.

Vkládání nebo opravu údajů neprovádějte v seznamu, ale otevřete si kliknutím na tlačítko Novy zaznam Nový záznam formulář Tarif výrobní činnosti. Záznamy můžete upravovat tlačítkem Editace zaznamu Editace záznamu.

· Kód - povinný údaj. Zadejte kód výrobní činnosti.

· Popis - povinný údaj. Vyplňte název výrobní činnosti.

· Cena za jednotku - uveďte cenu za jednotku (například za jeden kus).

· Poznámka - zde si můžete vepsat libovolné, pro vás důležité, informace.


Výrobky

Navigation: Evidence výroby >

Výrobky

 Return to chapter overview

Seznam naplňte všemi výrobky, které vyrábíte ať již pravidelně či na zakázku.

Vkládání nebo opravu údajů neprovádějte v seznamu, ale otevřete si kliknutím na tlačítko Novy zaznam Nový záznam formulář Výrobek. Záznamy můžete upravovat tlačítkem Editace zaznamu Editace záznamu.

· Kód - povinný údaj. Zadejte kód výrobku.

· Aktivní - zatržením políčka můžete definovaný výrobek používat při zadávání výroby. Pokud pole nebude zatrženo, potom nelze tento výrobek použít při zadávání výroby.

· Popis - povinný údaj. Vyplňte název výrobní činnosti.

· Minimální/Maximální počet - minimální/maximální počet výrobků.

· Jednotka - zadejte jednotku, například Ks (kus).

· Norma za hodinu - zadejte normu za hodinu.

· Cena za jednotku - zadejte cenu za jednotku.

· Poznámka - zde si můžete vepsat libovolné, pro vás důležité, informace.


Pracoviště

Navigation: Evidence výroby >

Pracoviště

 Return to chapter overview

Seznam naplňte pracovišti, které používáte ve vaší firmě (například: Obrobna, Kontrola).

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář Pracoviště. Formulář Pracoviště má následující záložky:

Formulář záznamu

Členové pracoviště

Rozvrh zakázek


Formulář pracoviště - Formulář záznamu

Navigation: Evidence výroby > Pracoviště >

Formulář pracoviště - Formulář záznamu

 Return to chapter overview

Ve formuláři zadáváte základní identifikační údaje o pracovišti.

· Kód - povinný údaj. Zadejte kód pracoviště.

· Popis - povinný údaj. Vyplňte název pracoviště.

· Datum vytvoření - povinný údaj. Vepište datum vytvoření pracoviště.

· Datum zrušení - vepište datum zrušení pracoviště.

· Nesynchronizovat - pokud je volba nesynchronizovat u pracoviště aktivována, pak je při synchronizaci pracoviště podle zvoleného rozdělení osob, dané pracoviště ze synchronizace vyloučeno.


Formulář pracoviště - Členové pracoviště

Navigation: Evidence výroby > Pracoviště >

Formulář pracoviště - Členové pracoviště

 Return to chapter overview

Ve formuláři vybíráte osoby, které mají být přiřazeny tomuto pracovišti.

Formulář je rozdělen do dvou seznamů. V levé části tabulky je zobrazen seznam všech dostupných osob. V pravé části je seznam vybraných osob, které jsou přiřazeny tomuto pracovišti. Pro přesun mezi seznamy použijte šipky umístěné mezi těmito seznamy.


Formulář pracoviště - Rozvrh zakázek - produkce

Navigation: Evidence výroby > Pracoviště >

Formulář pracoviště - Rozvrh zakázek - produkce

 Return to chapter overview

V seznamu je zobrazen plán zakázek pro vybrané pracoviště.

Nový plán zakázky vytvoříte stisknutím tlačítka Novy zaznam1 Nový záznam. Zadané hodnoty můžete editovat tlačítkem Editace zaznamu1 Editace záznamu.

· Pracoviště - povinný údaj. Z nabídky zvolte pracoviště. Nové pracoviště vytvoříte v menu Evidence výroby -> Pracoviště.

· Zakázka - povinný údaj. Položka umožňující výběr z definovaného seznamu, a to:

o kliknutím na podtržený nadpis Zakázka - otevře se seznam pro Výběr zakázky, ve kterém můžete editovat stávající údaje tlačítkem Editace zaznamu Editace záznamu nebo vkládat nové tlačítkem Novy zaznam Nový záznam. Více o výrobní zakázce naleznete v kapitole Výrobní zakázky.

o kliknutím na Vyberove tlacitko - otevře se výběrový seznam.

· Datum čas od - do - datum a čas od kdy do kdy se na zvoleném pracovišti pracovalo na výrobku.

· Výrobní norma - z nabídky vyberte požadovanou výrobní normu.

· Výrobek - z nabídky vyberte požadovaný výrobek. Výrobek můžete vytvořit v menu Evidence výroby -> Výrobky.

· Vyrobeno množství - povinný údaj. Zadejte, kolik výrobků bylo vyrobeno.

· Režijní čas - povinný údaj. Zadejte režijní čas.

· Poznámka - libovolná doplňující informace k produkci pracoviště.


Výrobní zakázky

Navigation: Evidence výroby >

Výrobní zakázky

 Return to chapter overview

Seznam naplňte všemi zakázkami, na kterých aktuálně pracujete.

Vkládání nebo opravu údajů neprovádějte v tomto seznamu, ale otevřete si formulář Výrobní zakázka. Formulář má následující záložky:

Zakázka

Harmonogram prací

Provedené práce

Záznamy výroby

Výrobky


Formulář výrobní zakázky - Zakázka

Navigation: Evidence výroby > Výrobní zakázky >

Formulář výrobní zakázky - Zakázka

 Return to chapter overview

Ve formuláři zadáváte základní identifikační údaje o výrobní zakázce.

· Číslo zakázky - povinný údaj. Zadejte číslo zakázky.

· Popis - povinný údaj. Vyplňte název výrobní zakázky.

· Typ - můžete zvolit typ výrobní zakázky.

· Datum přijetí zakázky - povinný údaj. Zadejte datum ve formátu D.M.RRRR, kdy byla zakázka přijata.

· Počátek práce - zadejte datum počátku práce.

· Termín dokončení - zadejte termín dokončení výrobní zakázky.

· Zodpovědný pracovník - položka umožňující výběr z definovaného seznamu, a to:

o kliknutím na podtržený nadpis Zodpovědný pracovník - otevře se seznam pro Výběr osoby, ve kterém po stisku tlačítek Ctrl+F na klávesnici můžete vyhledávat.

o kliknutím na Vyberove tlacitko - otevře se výběrový seznam.

· Kontaktní osoba zákazníka - kontaktní údaje na osobu zákazníka.

· Popis pro výrobu - doplňující informace pro výrobu.

· Poznámka - libovolná doplňující informace k výrobní zakázce.


Formulář výrobní zakázky - Harmonogram prací

Navigation: Evidence výroby > Výrobní zakázky >

Formulář výrobní zakázky - Harmonogram prací

 Return to chapter overview

Ve formuláři přiřazujete činnosti, které se budou provádět ve výrobní zakázce.

Vyrobni zakazky_Harmonogram praci

Formulář je rozdělen do dvou seznamů. V levé části tabulky se nachází seznam všech dostupných činností. Do pravé části přiřazujete práce, které se budou provádět ve výrobní zakázce. Pro přesun mezi seznamy použijte šipky umístěné mezi těmito seznamy.

Tlačítkem Editace zaznamu1 Editace záznamu v levé části tabulky se dostanete do Formuláře činnosti. Tlačítkem Editace zaznamu1 Editace záznamu v pravé části tabulky se dostanete do formuláře Činnosti výrobní zakázky.


Formulář činnosti výrobní zakázky - Formulář záznamu

Navigation: Evidence výroby > Výrobní zakázky > Formulář výrobní zakázky - Harmonogram prací >

Formulář činnosti výrobní zakázky - Formulář záznamu

 Return to chapter overview

Ve formuláři máte možnost upravit potřebné záznamy o činnosti výrobní zakázky.

Ve formuláři je třeba mít vyplněny položky:

· Zakázka a prováděnou

· Činnost na výrobní zakázce. Položka umožňující výběr z definovaného seznamu, a to:

o kliknutím na podtržený nadpis Činnost - otevře se seznam pro Výběr činnosti, ve kterém můžete editovat stávající údaje tlačítkem Editace zaznamu Editace záznamu nebo vkládat nové tlačítkem Novy zaznam Nový záznam.

o kliknutím na Vyberove tlacitko - otevře se výběrový seznam.

Další položky, které můžete vyplnit, jsou:

· Popis prováděné činnosti,

· Množství - počet kusů ve výrobní zakázce,

· Normohodiny - čas práce na jednom kusu,

· Celkem - po vyplnění polí Množství a Normohodiny se pole automaticky vyplní,

· Pracoviště, na kterém je činnost prováděna,

· Datum a čas od - do - údaje zadané ve formátu D.M.RRRR H:MM.


Formulář činnosti výrobní zakázky - Pracovníci

Navigation: Evidence výroby > Výrobní zakázky > Formulář výrobní zakázky - Harmonogram prací >

Formulář činnosti výrobní zakázky - Pracovníci

 Return to chapter overview

V této záložce přiřazujete pracovníky, kteří se na výrobní činnosti podílejí.

Formulář je rozdělen do dvou seznamů. V levé části tabulky se nachází seznam všech dostupných osob. Do pravé části přiřazujete osoby, které budou provádět výrobní činnost. Pro přesun mezi seznamy použijte šipky umístěné mezi těmito seznamy.


Formulář výrobní zakázky - Provedené práce

Navigation: Evidence výroby > Výrobní zakázky >

Formulář výrobní zakázky - Provedené práce

 Return to chapter overview

Ve formuláři je zobrazen seznam provedených prací na výrobní zakázce.

Vyrobni zakazky_Provedene prace

Tlačítkem Novy zaznam1 Nový záznam se dostanete do formuláře Záznamu výroby.


Formulář výrobní zakázky - Záznamy výroby

Navigation: Evidence výroby > Výrobní zakázky >

Formulář výrobní zakázky - Záznamy výroby

 Return to chapter overview

Ve formuláři je zobrazen seznam záznamů výroby k výrobní zakázce.

Vyrobni zakazky_Zaznamy vyroby


Formulář výrobní zakázky - Výrobky

Navigation: Evidence výroby > Výrobní zakázky >

Formulář výrobní zakázky - Výrobky

 Return to chapter overview

Ve formuláři je zobrazen seznam přiřazených výrobků k výrobní zakázce.

Tlačítkem Novy zaznam1 Nový záznam se dostanete do formuláře Výrobku.


Typy výrobních zakázek

Navigation: Evidence výroby >

Typy výrobních zakázek

 Return to chapter overview

Pomocí tohoto seznamu lze nadefinovat typy výrobních zakázek. Tyto pak lze vybrat v seznamu výrobní zakázky.

Vkládání nebo opravu údajů neprovádějte v seznamu, ale otevřete si kliknutím na tlačítko Novy zaznam Nový záznam formulář Typ výrobní zakázky. Záznamy můžete upravovat tlačítkem Editace zaznamu Editace záznamu.

· Kód - povinný údaj. Zadejte kód výrobní zakázky.

· Popis - povinný údaj. Vyplňte popis výrobní zakázky.

· Poznámka - zde si můžete vepsat libovolné, pro vás důležité, informace.


Cestovní náhrady

Navigation: »No topics above this level«

Cestovní náhrady

 Return to chapter overview

V modulu cestovních náhrad zadáváte služební cesty a vytváříte pro tyto cesty vyúčtování. V prvním kroku je třeba naplnit seznamy, které jsou potřeba pro zadávání služebních cest.

Menu Cestovní náhrady obsahuje tyto položky:

Služební cesty

Přehled účtování služebních cest

Místa služební cesty

Účely služební cesty

Typ řádku účtování služební cesty

Způsoby platby

Státy

Měny

Dopravní prostředky

Sazby za používání vlastního vozidla

Druhy PHM

Seznam vozidel

Šablony účtování služební cesty

Sazby kapesného

Nejprve je potřeba nastavit výchozí nastavení vyúčtování cestovních náhrad. Nastavení provedete v menu Systém/Nastavení aplikace/Společné nastavení.

Dále je potřeba naplnit následující seznamy:

Cíle služební cesty

Účely služební cesty

Měny

Státy

Typy řádku účtování služební cesty.


Služební cesty

Navigation: Cestovní náhrady >

Služební cesty

 Return to chapter overview

Seznam obsahuje všechny zadané služební cesty. Služební cesty je možné vytvářet v programu Docházka v menu Cestovní náhrady/Služební cesty nebo v intrawebu.

Nad seznamem můžete použít následující filtry:

§ Jen rozdělení - vyberte rozdělení, pro které chcete zobrazit přehled služebních cest.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

§ Jen období - v seznamu se zobrazí údaje pro vybraný měsíc.

§ Jen den od - do - zaškrtnutím políčka Jen den aktivujete roletky, kde vyberete data od - do. V seznamu se po té zobrazí seznam služebních cest pro vybraný rozsah.

§ Jen osoba - ze seznamu vyberte osobu, pro kterou chcete zobrazit přehled účtování. Osobu můžete vyhledat také v seznamu osob. Stačí kliknout na podtržený název pole Jen osoba - otevře se seznam pro Výběr ..., ve kterém po stisku tlačítek Ctrl+F na klávesnici můžete vyhledávat.

§ Všechny - v seznamu se zobrazí všechny zadané služební cesty.

§ Ne-Zpracováno - v seznamu se zobrazí všechny záznamy služební cesty, které nemají potvrzenou (vyplněné datum) první úroveň schvalování (Zpracováno). Název filtru můžete změnit v menu Systém -> Nastavení aplikace -> Společné nastavení -> Cestovní náhrady ve sloupci Názvy úrovní schválení, na řádku 1. úroveň. Zvolený název se zobrazí i ve formuláři Služební cesta.

§ Ne-Zkontrolováno - v seznamu se zobrazí všechny záznamy služební cesty, které nemají potvrzenou (vyplněné datum) druhou úroveň schvalování (Zkontrolováno). Název filtru můžete změnit v menu Systém -> Nastavení aplikace -> Společné nastavení -> Cestovní náhrady ve sloupci Názvy úrovní schválení, na řádku 2. úroveň. Zvolený název se zobrazí i ve formuláři Služební cesta.

§ Ne-Schváleno - v seznamu se zobrazí všechny záznamy služební cesty, které nemají potvrzenou (vyplněné datum) třetí úroveň schvalování (Schváleno). Název filtru můžete změnit v menu Systém -> Nastavení aplikace -> Společné nastavení -> Cestovní náhrady ve sloupci Názvy úrovní schválení, na řádku 3. úroveň. Zvolený název se zobrazí i ve formuláři Služební cesta.

Sluzebni cesty_Tla. Hromadny prepocet vyuctovani | Hromadný přepočet vyúčtování - po stisku tlačítka se zobrazí dotaz, zda si opravdu přejete přepočítat vyúčtování všech služebních cest v seznamu. Po potvrzení dotazu se spustí přepočet vyúčtování. Po ukončení se vám zobrazí okno s informací, zda přepočet vyúčtování proběhl bez chyb. Pokud by se nějaké chyby ve vyúčtování objevili, můžete si zobrazit seznam těchto chyb.
Sluzebni cesty_Tla. Hromadne schvalovani | Hromadné schvalování - stiskem tlačítka můžete provést hromadné schválení služebních cest k zadanému datu. Můžete provést schválení pro všechny služební cesty, které jsou zobrazeny v seznamu (respektuje aktuální filtr tohoto seznamu). Schválení můžete provést v úrovních, na které máte práva.

Pro vytvoření nového záznamu v seznamu stiskněte tlačítko Novy zaznam Nový záznam, pro editaci je třeba stisknout tlačítko Editace zaznamu Editace záznamu. Zobrazí se formulář Služební cesta, která má následující záložky:

Služební cesta

Účtování

Ostatní údaje

Dokumenty

Předpoklad nákladů


Formulář služební cesty - Služební cesta

Navigation: Cestovní náhrady > Služební cesty >

Formulář služební cesty - Služební cesta

 Return to chapter overview

V této části formuláře budete vytvářet služební cestu.

Část služební cesta - zde se zadávají základní údaje o služební cestě.

SC_Sluzebni cesty formular sluzebni cesty

· Osoba - povinný údaj. Vyberte osobu, u které chcete vložit služební cestu.

· Sazba kapesného - pole bude automaticky vyplněno přednastavenou sazbou kapesného v nastavení aplikace. Pokud chcete sazbu kapesného změnit, přepište v poli jeho hodnotu v %. Po zadání procenta kapesného dostane zaměstnanec navíc zadané procento z vypočtených náhrad. Hodnota maximální sazby, kterou je možné zapsat do pole, je nastavena v menu Systém/Nastavení aplikace/Společné nastavení/Cestovní náhrady. Jakmile se do pole Sazba kapesného zapíše vyšší sazba, zobrazí se varování o tom, že sazba přesáhla maximální limit.

· Přenést do docházky - pokud není v Nastavení aplikace -> Cestovní náhrady zatrhnuté pole Používat přenos služebních cest do docházky, potom se pole nezobrazí ve formuláři Služební cesty. V případě, že je pole zatrhnuté a je vyplněno pole Implicitní typ přenosu služební cesty do docházky, potom se ve formuláři služební cesty přednastaví vybraná volba. Pokud nebude pole Přenést do docházky zatrhnuté, potom se zadaná služební cesta nepřenese do docházky. Služební cesty můžete vkládat do docházky dvěma způsoby:

o Po směnách - služební cesta se vloží jen podle nastavené směny v kalendáři.

o Podle rozpisu - jednotlivé části dne se vloží na základě vyplněných řádků služební cesty, zatrhněte pole.

· Dopravní prostředek - zadejte dopravní prostředek výběrem ze seznamu. Toto pole nahrazuje pole vlastní vozidlo. Záznamy, které měl zaškrtnuto pole vlastní vozidlo budu mít nastaven implicitní záznam - Automobil vlastní. Seznam dopravních prostředků můžete doplňovat v menu Cestovní náhrady -> Dopravní prostředky.

· Typ výpočtu - povinný údaj. Typ výpočtu cestovních náhrad je do výběrové položky doplněn automaticky, pokud jste provedli její výběr v programu Docházka (Systém -> Nastavení aplikace -> Společné nastavení -> Cestovní náhrady).

· Vyplatit hotově - pokud chcete cestovní náhrady za služební cestu proplatit v hotovosti, zaškrtněte pole.

· Datum čas od - do - povinný údaj. Zadejte datum a čas začátku a konce služební cesty ve formátu D.M.RRRR pro datum a pro čas ve tvaru H:MM (20.3.2011 16:50).

· Datum kurzu - podle daného data se zjišťuje kurz při převodu mezi měnami. Pokud není datum vyplněno, pak se kurz zjišťuje podle konce služební cesty.

· Stát - povinný údaj. Zvolte z menu výchozí stát služební cesty (ČR).

· Místo začátku - zvolte místo začátku služební cesty. Seznam míst služebních cest vytvoříte v programu Docházka (Cestovní náhrady -> Místa služební cesty). Do kolonky za zvolené místo začátku služební cesty můžete přidat jakoukoliv poznámku.

· Cíl - zadejte cíl cesty (Bratislava, Pobočka Bratislava apod.). Seznam cílů služebních cest je potřeba nastavit v programu Docházka (Cestovní náhrady -> Místa služební cesty). Do kolonky za zvolený cíl můžete přidat jakoukoliv poznámku, například cílovou ulici služební cesty.

· Přes - do pole si můžete doplnit místa, kterými zaměstnanec projížděl.

· Účel - zadejte účel služební cesty (školení docházkového systému). Seznam účelů služebních cest je potřeba nastavit v programu Docházka (Cestovní náhrady -> Účely služební cesty).

· Popis - popis služební cesty, například na jakou firmu zaměstnanec jede.

· Poznámka - libovolná doplňující informace k zadané služební cestě.

Část schvalování - funkce schvalování služebních cest použijete v případě, že ve vaší firmě jsou definovány pravomoci pro schvalování údajů a existuje hierarchie tohoto schvalování. Systém umožňuje zavedení 3 stupňů schvalování služebních cest.

Přístupová práva pro jednotlivé stupně schvalování je nutné nastavit v přístupových právech systému (Systém -> Správa databáze -> Nastavení zabezpečení).

Názvy (na obrázku v modrém rámečku), které jsou přiřazeny jednotlivým úrovním schválení, můžete změnit v menu Systém -> Nastavení aplikace -> Společné nastavení -> Cestovní náhrady ve sloupci Názvy úrovní schválení. U jednotlivých úrovní schválení se může při najetí myší na okno zobrazit popis (na obrázku v červeném rámečku). Nastavení tohoto popisu provedete v menu Systém -> Nastavení aplikace -> Společné nastavení -> Cestovní náhrady ve sloupci Popisy úrovní schválení.

SC_Sluzebni cesty formular schvalovani

· Schváleno zaměstnancem - po zatrhnutí pole, daný zaměstnanec souhlasí s tím, že vyjede na služební cestu. Po uložení dat tlačítkem [image] (tlačítko je umístěno v dolní části formuláře) se v pravé části zobrazí uživatelské jméno osoby, která je přihlášena do programu, datum a čas ve formátu D.M.RRRR HH:MM:SS.

· Schváleno nadřízeným - z nabídky vyberte zda je služební cesta schválena Bez rozhodnutí, Schválena nebo Zamítnuta. Po uložení dat se v pravé části zobrazí uživatelské jméno osoby, která je přihlášena do programu, datum a čas ve formátu D.M.RRRR HH:MM:SS.

· Zaúčtování - pokud je provedeno zaúčtování služební cesty, například v účetním softwaru, zatrhněte pole. Po uložení dat se v pravé části zobrazí uživatelské jméno osoby, která je přihlášena do programu, datum a čas ve formátu D.M.RRRR HH:MM:SS.

Tři úrovně schvalování - první úroveň je zelená (zpracováno), druhá žlutá (zkontrolováno) a třetí červená (schváleno).

Pracovník, který má právo na zelenou úroveň schválení, provede schválení k určitému datu a tím dá najevo uživatelům schvalujícím ve vyšší úrovni, že jsou údaje o služební cestě zpracovány. Uživatel se žlutou úrovní záznamy prohlédne a může přidat svou úroveň zkontrolováno. Pokud je služební cesta zkontrolována nemůže uživatel, který docházku zpracoval již tento příznak zrušit, aby provedl opravy. Pokud by chtěl opravy provést, musí mu to uživatel s vyšší úrovní povolit tím, že zruší svou úroveň schválení. Stejný postup pokračuje s úrovní červenou - schválení. Pokud potřebujete upravit údaje ve služební cestě, musí vám to povolit uživatel, který služební cestu po vás schválil vyšší úrovní.

Samozřejmě není nutné, aby byla dodržována celá hierarchie třístupňového schvalování, záleží pouze na vás, kolik úrovní budete používat.

TIP: Pokud je služební cesta schválena některou z úrovní, není možné ji již editovat. Nezapomeňte také na to, že pro schválení služební cesty musíte mít dostatečná uživatelská práva.

Do pole pro schválení zadejte datum dokdy, chcete služební cestu schválit a to vepsáním nebo vybráním přes tlačítko [image]. Pokud chcete schválení zrušit, přepište datum na nižší nebo datum zcela vymažte.

Část řádky - tato část slouží k rozepsání služební cesty a musí mít minimálně jeden řádek. Pokud se bude jednat o zahraniční služební cestu, je zde potřeba rozepsat překročení hranic (tam i zpátky). Pokud bude chtít zadávat v jedné služební cestě různě dlouhé časy výkonu práce, můžete použít operaci odchod k ukončení výkonu práce v daný den. A pro další den přidáte další řádek s operací Služební cesta. Nový záznam přidáte stiskem tlačítka [image].

SC_Sluzebni cesty formular radku

· Datum čas od - povinný údaj. Po stisku tlačítka [image] Nový záznam se automaticky doplní začátek služební cesty. Zadané hodnoty musí být v rozsahu služební cesty.

· Stát - povinný údaj. Vyberte stát, pro výpočet cestovních náhrad.

· Počet poskytnutých jídel - Snídaně, Obědy, Večeře - povinný údaj. Zadejte počty k jednotlivým typům denních jídel.

· Místo - místo které určuje, zda je to počátek/průjezd/konec služební cesty podle toho zda se shoduje s výchozím místem služební cesty.

· Dopravní prostředek - ze seznamu vyberte požadovaný dopravní prostředek. Seznam dopravních prostředků můžete doplňovat v menu Cestovní náhrady -> Dopravní prostředky.

· Událost - povinný údaj. Vyberte operaci (Služební cesta). Pokud nemáte na výběr žádnou operaci, je potřeba je nastavit v programu Docházka (Terminály -> Operace terminálu -> Formulář operace terminálu -> zaškrtnout položku Událost služební cesty).

· Popis - popis zadávané cestovní náhrady (stravné).

Zadané údaje uložíte tlačítkem [image]. Potvrzené údaje se zobrazí v seznamu.

SC_Sluzebni cesty_Tla. Prenest do dochazky

Přenést do docházky - po stisku tlačítka se zobrazí dotaz o tom, že aktuální zpracovaná docházka od - do (například do: 31.3.2011 7:25:00 do: 31.3.2011 17:25:00) bude zrušena, a zda si opravdu přejete přenést služební cestu do zpracované docházky. Po potvrzení dotazu se služební cesta přenese do zpracované docházky.


Formulář služební cesty - Účtování

Navigation: Cestovní náhrady > Služební cesty >

Formulář služební cesty - Účtování

 Return to chapter overview

V této části formuláře provedete vyúčtování služební cesty.

Pokud máte v menu Systém -> Nastavení aplikace -> Společné nastavení -> Cestovní náhrady vybranou šablonu účtování služební cesty a zatrhnuté pole automaticky předplňovat účtování cestovních náhrad, budou řádky účtování již vyplněny. Další možnost jak doplnit řádky účtování podle šablony je přes tlačítko SC_Sluzebni cesty_Tla. Predplnit. Po jeho stisku se zobrazí okno Předplnění vyúčtování, ve kterém vyberte z nadefinovaného seznamu šablonu a potvrďte stiskem tlačítka OK. Pro přidání dalších řádků do seznamu, stiskněte tlačítko [image] a vyplňte následující údaje:

SC_Sluzebni cesty formular vyuctovani

· Částka - povinný údaj. Zadejte částku pro vyúčtování. Výdaje zaměstnance zadávejte zápornou hodnotou (-). Zálohy a ostatní příjmy zaměstnance zadávejte kladnou hodnotou (+). Pokud použijete kalkulátor náhrad za použití vlastního vozidla, částka se po potvrzení formuláře doplní.

· DPH - nepovinný údaj. Doplňte sazbu DPH.

· Měna - povinný údaj. Zvolte měnu pro vyúčtování.

· Typ - povinný údaj. Vyberte typ pohybu k zadávanému účtování. Typy pro výběr pohybů nastavíte v programu Docházka (Cestovní náhrady -> Typy řádku účtování služební cesty).

· Den - nepovinný údaj.

· Způsob platby - povinný údaj. Z nabídky vyberte způsob platby služební cesty (Hotově, Služební kartou).

· Popis - popis vyúčtování (záloha).

SC_Sluzebni cesty_Tla. Kalkulator nahrad za pouziti vlastniho vozidla

Kalkulátor náhrad za použití vlastního vozidla - pokud máte vybraný typ řádku účtování, ve kterém je zaškrtnuta položka Náhrada za použití vlastního vozidla, bude ve formuláři zobrazeno toto tlačítko. Aby bylo možné použít kalkulátor náhrad za použití vozidla na služební cestě, musí být nastaveny sazby (Cestovní náhrady -> Sazby za používání vlastního vozidla) a zaškrtnuta položka Náhrada za použití vlastního vozidla (Cestovní náhrady -> Typ řádku účtování služební cesty). Jakmile vyplníte pole Den, je možné stisknout toto tlačítko. Po jeho stisku se zobrazí formulář Kalkulátor náhrad za použití vlastního vozidla.

SC_Sluzebni cesty Kalkulator nahrad za pouziti vlastniho vozidla

· Vozidlo - z nabídky vyberte požadovaný automobil. Seznam vozidel naplníte v menu Cestovní náhrady -> Seznam vozidel.

· Spotřeba automobilu dle TP - povinná položka. Z technického průkazu vozidla zapište jeho spotřebu v litrech/100 km.

· Počet ujetých km - povinná položka. Zadejte počet ujetých kilometrů na služební cestě.

· Nepočítat základní sazbu - pokud pole zatrhnete, neprojeví se do celkové částky výpočtu její složka "Základní náhrady za používání silničních motorových vozidel".

· Zaměstnance cenu pohonných hmot - zvolte jednu z následujících možností:

o neprokáže - pokud se zaměstnanec neprokáže cenu pohonných hmot, potom vyberte Druh pohonných hmot.

o prokáže - pokud se zaměstnanec prokáže skutečně zaplacenou cenou předložením paragonu, vyplňte Cenu pohonných hmot.

SC_Sluzebni cesty_Tla. Vypocet

Výpočet - stiskem tlačítka provedete výpočet celkových náhrad za použití vlastního vozidla na služební cestě. Po výpočtu se vyplní Náhrady celkem.

· Náhrady celkem - po výpočtu náhrad spojených s použitím vlastního vozidla na služební cestě se doplní celková částka. Celková částka obsahuje 2 složky:

o Základní náhrady za používání silničních motorových vozidel - počet ujetých km * sazba,

o Náhrady za spotřebované pohonné hmoty - spotřeba automobilu dle TP * počet ujetých km * cena pohonných hmot nebo Druh pohonných hmot.

Po potvrzení formuláře se vypočtené náhrady doplní do pole Částka v sekci Účtování.

· Měna - povinný údaj. Zvolte měnu pro vyúčtování.

· Typ - povinný údaj. Vyberte typ pohybu k zadávanému vyúčtování. Typy pro výběr pohybů nastavíte v programu Docházka (Cestovní náhrady -> Typy řádku účtování služební cesty).

· Den - zadané datum musí být v rozsahu služební cesty.

· Popis - popis vyúčtování (záloha).

Zadané údaje uložíte tlačítkem [image] do seznamu vyúčtování.

Po přidání všech potřebných záznamů stiskněte tlačítko [image]. Po tomto kroku se v seznamu zobrazí další pohyby provedeného vyúčtování. Zobrazí se náhrady za služební cestu a v případě poskytnuté stravy, bude tato částka snížena podle pravidel nastavených ve výpočtu cestovních náhrad (Cestovní náhrady -> Státy).

SC_Sluzebni cesty seznam vyuctovani

Seznam vyúčtování cestovních náhrad

V dolní části formuláře je vyúčtována částka, kterou má zaměstnanec vrátit. V opačném případě je zde uvedena částka, která má být zaměstnanci vyplacena.

SC_Sluzebni cesty konecne vyuctovani


Formulář služební cesty - Ostatní údaje

Navigation: Cestovní náhrady > Služební cesty >

Formulář služební cesty - Ostatní údaje

 Return to chapter overview

Chcete-li u služebních cest zaměstnanců sledovat i jiné údaje, které standardně nejsou v docházkovém systému přednastaveny, potom můžete využít tuto záložku. Volbu uživatelských polí nastavíte v menu Systém/Nastavení aplikace/Společné nastavení/Cestovní náhrady.

SC_Sluzebni cesty Ostatni udaje


Formulář služební cesty - Dokumenty

Navigation: Cestovní náhrady > Služební cesty >

Formulář služební cesty - Dokumenty

 Return to chapter overview

Záložka obsahuje seznam dokumentů spojených se služební cestou.

SC_Sluzebni cesty seznam dokumentu

Tlačítkem [image] Nový záznam otevřete formulář Dokument .


Formulář služební cesty - Předpoklad nákladů

Navigation: Cestovní náhrady > Služební cesty >

Formulář služební cesty - Předpoklad nákladů

 Return to chapter overview

V této části formuláře zadáváte předpokládané výdaje zaměstnance na služební cestě.

SC_Sluzebni cesty predpoklad nakladu

· Částka - povinný údaj. Zadejte částku předpokládaného výdaje.

· Měna - povinný údaj. Zvolte měnu předpokládaného výdaje.

· Typ - povinný údaj. Vyberte typ pohybu předpokládaného výdaje. Typy pro výběr pohybů nastavíte v programu Docházka (Cestovní náhrady -> Typy řádku účtování služební cesty).


Přehled účtování služebních cest

Navigation: Cestovní náhrady >

Přehled účtování služebních cest

 Return to chapter overview

V přehledu naleznete vyúčtování všech služebních cest. Záznamy slouží pouze pro čtení, není možné zde provádět editaci či vkládání nových dat. Vyúčtování služební cesty je možné provést v menu Cestovní náhrady/Služební cesty nebo v modulu Intraweb.

Prehled uctovani sluzebnich cest

Nad seznamem můžete použít následující filtry:

§ Jen rozdělení - vyberte rozdělení, pro které chcete zobrazit přehled účtování.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

§ Jen období - v seznamu se zobrazí údaje pro vybraný měsíc.

§ Jen den od - do - zaškrtnutím políčka Jen den aktivujete roletky, kde vyberete data od - do. V seznamu se po té zobrazí údaje pro zadaný rozsah.

§ Jen osoba - ze seznamu vyberte osobu, pro kterou chcete zobrazit přehled účtování. Osobu můžete vyhledat také v seznamu osob. Stačí kliknout na podtržený název pole Jen osoba - otevře se seznam pro Výběr ..., ve kterém po stisku tlačítek Ctrl+F na klávesnici můžete vyhledávat.

§ Jen Typ - ze seznamu vyberete typ řádku účtování služební cesty, pro který chcete zobrazit seznam.


Místa služební cesty

Navigation: Cestovní náhrady >

Místa služební cesty

 Return to chapter overview

V menu Cestovní náhrady/Cíle služební cesty nadefinujete cíle služebních cest. Cílem cesty může být město, do kterého jedete za zákazníkem, apod.

Cile sluzebni cesty

Po výběru se zobrazí seznam cílů služebních cest, který naplníte přes tlačítko Novy zaznam Nový záznam. Ve formuláři Cíl služební cesty je potřeba vyplnit následující pole:

Cile sluzebni cesty formular cile

· Kód - povinný údaj. Zadejte kód cíle služební cesty (BRA).

· Popis - povinný údaj. Doplňte název cíle služební cesty (Bratislava).

· Aktivní - zatržením políčka můžete definovaný cíl používat při zadávání služebních cest. Pokud pole nebude zatrženo, potom nelze tento cíl použít při zadávání služebních cest.

· Stát - povinný údaj. Zvolte stát, ve kterém se nachází cíl služební cesty (Slovensko).

· Počátek - zaškrtnutím políčka se bude zde zadaný počátek objevovat na výběr při vyplňování pole Místo začátku ve formuláři služební cesty.

· Cíl - zaškrtnutím políčka se bude zde zadaný cíl objevovat na výběr při vyplňování pole Cíl ve formuláři služební cesty.

· Poznámka - libovolná pro vás důležitá informace.

Po nastavení potvrďte tlačítkem OK.


Účely služební cesty

Navigation: Cestovní náhrady >

Účely služební cesty

 Return to chapter overview

V menu Cestovní náhrady/Účely služební cesty nadefinujete, z jakého důvodu se služební cesta koná. Účelem služební cesty může být školení, jednání apod.

Ucely sluzebni cesty

Po výběru se zobrazí seznam účelů služebních cest, který naplníte přes tlačítko Novy zaznam Nový záznam. Ve formuláři Účel služební cesty zadejte následující údaje:

Ucely sluzebni cesty formular ucelu sluzebni cesty

· Kód - povinný údaj. Zadejte kód účelu služební cesty (ŠD).

· Popis - povinný údaj. Doplňte název účelu služební cesty (Školení docházkového systému).

· Aktivní - zatržením políčka můžete definovaný účel používat při zadávání služebních cest. Pokud pole nebude zatrženo, potom nelze tento účel použít při zadávání služebních cest.

· Poznámka - libovolná pro vás důležitá informace.

· Povinný cíl - po zatrhnutí pole je zadání cíle pro vybraný účel povinné.

Po nastavení potvrďte tlačítkem OK.


Typ řádku účtování služební cesty

Navigation: Cestovní náhrady >

Typ řádku účtování služební cesty

 Return to chapter overview

Program je dodáván s přednastaveným seznamem. Předdefinované typy řádku účtování služební cesty se použijí při vyúčtování služební cesty. Seznam otevřete v menu Cestovní náhrady/Typ řádku účtování služební cesty.

Typy radku uctovani pracovni cesty

Zde ho můžete v případě potřeby přejmenovat tlačítkem Editace zaznamu Editace záznamu. Ve formuláři Typ řádku účtování služební cesty zadejte následující údaje:

Typy radku uctovani pracovni cesty formular typu radku

· Kód - povinný údaj. Zadejte kód typu řádku (0).

· Popis - povinný údaj. Doplňte název typu řádku (Standardní pohyb peněz +/-).

· Druh pohybu - při zápisech řádků účtování služební cesty se podle druhu pohybu u zvoleného typu řádku automaticky upraví znaménko u částky. U příjmu se automaticky nastavuje kladná hodnota, u výdeje se automaticky nastavuje záporná hodnota.

· 1. Účet - do pole zadejte číslo účtu (MD - má dáti).

· 2. Účet - do pole zadejte číslo účtu (D - dal). Položky 1. Účet a 2. Účet můžou sloužit například jako podklad pro zaúčtování.

· Aktivní - zatržením políčka aktivujete typ řádku účtování služební cesty pro vyúčtování.

· Poznámka - libovolná pro vás důležitá informace.

· Náhrada za použití vlastního vozidla - po zaškrtnutí pole, můžete u služební cesty v záložce účtování vyúčtovat náhrady za použití vlastního vozidla.

· Zadávat v předpokládaných výdajích - pokud chcete ve služební cestě předem zjišťovat předpokládané výdaje zaměstnance, zaškrtněte pole. Potom se bude řádek účtování služební cesty nabízet k vybrání ve formuláři Předpokládaných nákladů.

Po nastavení potvrďte tlačítkem OK.


Způsoby platby

Navigation: Cestovní náhrady >

Způsoby platby

 Return to chapter overview

Program je dodáván s přednastaveným seznamem. Předdefinované způsoby platby služební cesty se použijí při účtování služební cesty.

Vkládání nebo opravu údajů neprovádějte v seznamu, ale otevřete si kliknutím na tlačítko Novy zaznam Nový záznam nebo Editace zaznamu Editace záznamu formulář Způsob platby služební cesty.

· Kód - povinný údaj. Zadejte kód způsobu platby.

· Popis - povinný údaj. Zadejte popis způsobu platby (služební kartou, hotově).

· Nezahrnovat do vyúčtování služební cesty - pokud je tato volba aktivní, pak řádky účtování služební cesty nebudou zahrnuty do celkových součtů účtování služební cesty.

· Poznámka - libovolná pro vás důležitá informace.


Státy

Navigation: Cestovní náhrady >

Státy

 Return to chapter overview

Program je dodáván s přednastaveným seznamem států. Všechny položky číselníku jsou součástí výběrových seznamů v jiných částech programu. V menu Cestovní náhrady/Státy je možné nadefinovat nové ( Novy zaznam Nový záznam) nebo editovat ( Editace zaznamu Editace záznamu) stávající.

Ve formuláři státu je potřeba mít zadané následující údaje:

Staty formular zakladni udaje

· Kód - povinný údaj. Zadejte kód identifikující stát, obvykle textový formát.

· Popis - povinný údaj. Doplňte název státu.

· Číselný kód - jedná se o číselný kód státu.

· Číselný kód ISO 3166 - definuje kódy jmen zemí, závislých území a zvláštních oblastí geografického zájmu.

· Měna - měna musí být u státu vybrána z důvodu vyúčtování služební cesty. V případě, že chcete číselník doplnit o další měnu, klikněte na položku Měna a v otevřeném formuláři Měna stiskněte tlačítko Novy zaznam Nový záznam.

· Povolit ve služební cestě - aby bylo možné zadávat stát, ve kterém se uskuteční služební cesta, je potřeba zatrhnout toto políčko. Nastavení je třeba provést pouze pro intraweb.

Ve formuláři státu jsou pod základními údaji o vybraném státu zobrazeny dvě záložky. V první záložce nastavujete kurzy a ve druhé nastavujete účtování cestovních náhrad dle cílového státu služební cesty.


Formulář státu - Kurzy

Navigation: Cestovní náhrady > Státy >

Formulář státu - Kurzy

 Return to chapter overview

Staty formular statu kurzy

V levé části záložky je seznam Aktuálních kurzů. V pravé části je zobrazena veškerá historie zadaných kurzů. Nový kurz do seznamu přidáte přes tlačítko Novy zaznam1 Nový záznam.

Staty formular kurzu

Ve formuláři zadejte datum počátku Platnosti kurzu. Datum ukončení platnosti není potřeba vyplňovat, automaticky se jeho platnost ukončí po zadání nového kurzu. Dále nastavte kurzové hodnoty pro jeden řádek například EUR -> Kč - Množství Kč (24,465) a Kurz (1) EUR a potvrďte tlačítkem Ok1. Po potvrzení řádku se druhý doplní automaticky Kč -> EUR - Množství EUR (1) a Kurz (24,465) Kč.

Po nastavení potvrďte tlačítkem OK.


Formulář státu - Nastavení výpočtu cestovních náhrad

Navigation: Cestovní náhrady > Státy >

Formulář státu - Nastavení výpočtu cestovních náhrad

 Return to chapter overview

Staty formular statu nastaveni vypoctu cestovnich nahrad

U států ČR a SK jsou již přednastaveny seznamy pro účtování cestovních náhrad dle cílového státu služební cesty. Tento seznam je možné v případě potřeby rozšířit o další cílové státy, do kterých podnikáte své služební cesty. Nastavení cestovních náhrad pro nový cílový stát vytvoříte přes tlačítko Novy zaznam Nový záznam.

Staty formular nastaveni vypoctu cestovnich nahrad

V zobrazeném formuláři Nastavení výpočtu cestovních náhrad je potřeba zadat následující údaje:

· Cílový stát - vyberte cílový stát, pro který chcete nadefinovat hodnoty pro výpočet cestovních náhrad.

· Limit nad - po překročení zadané doby v hodinách se budou cestovní náhrady účtovat dle nastavených pravidel tohoto řádku.

PŘÍKLAD: Pokud budete na služební cestě déle jak pět hodin, ale méně jak dvanáct, potom dle pravidel je Sazba 66 Kč a Srážky za poskytnuté jídlo jsou pro snídani 70%, oběd 70%, večeři 70%. Příklad je uveden pro Českou republiku.

· Sazba - sazba pro účtování cestovních náhrad je závislá na době trvání pracovní cesty a její výše je stanovena zákoníkem o cestovních náhradách. Sazba se zadává v peněžních jednotkách vybraného státu.

· Srážka za poskytnuté jídlo - je-li na pracovní cestě poskytnuta strava formou snídaně, oběda nebo večeře (nikoli poskytnuté občerstvení), krátí zaměstnavatel zaměstnanci stravné. Horní hranice krácení stravného je stanovena zákoníkem o cestovních náhradách. Stravné se krátí v závislosti na délce pracovní cesty za každé jídlo. Hodnoty krácení stravy jsou zadány v %.

· Srážet za poskytnuté jídlo z maximální sazby - pokud je pole zatržené, potom se srážka za poskytnuté jídlo zaměstnanci vypočte z maximální sazby.

PŘÍKLAD: Pracovník byl na služební cestě 6 hodin, měl oběd a nedostal zálohu. Těmto hodinám odpovídá sazba 66 Kč.

Pokud NENÍ pole zatrhnuté, potom se srážka za poskytnuté jídlo vypočte ze sazby 66 Kč * 0,7 (srážka za poskytnuté jídlo oběd) = 46,2 Kč. Zaměstnanci bude vyplaceno 66 Kč (nárok zaměstnance) - 46,2 Kč (srážka za poskytnuté jídlo) = 19,8 Kč.

Pokud JE pole zatrhnuté, potom se srážka za poskytnuté jídlo vypočte z maximální sazby 157 (sazba v Kč) * 0,25 (srážka za poskytnuté jídlo oběd) = 39,25 Kč. Zaměstnanci bude vyplaceno 66 Kč (nárok zaměstnance) - 39,25 Kč (srážka za poskytnuté jídlo) = 26,75 Kč.

Po nastavení potvrďte tlačítkem OK.


Měny

Navigation: Cestovní náhrady >

Měny

 Return to chapter overview

Jelikož je v programu nejpoužívanější měnou koruna, je záznam již vytvořen.

V případě, že budete používat i jinou měnu, klikněte na tlačítko [image] Nový záznam a v otevřeném formuláři Měna vyplňte následující údaje:

· Kód - kód používaný v bankovním styku.

· Aktivní - pokud měnu používáte na služebních cestách, potom zatrhněte políčko. Pokud není měna aktivní, nebude se nabízet k výběru ve formuláři služební cesty.

· Popis - název měny. Pole prodlouženo na 40 znaků.


Způsob dopravy

Navigation: Cestovní náhrady >

Způsob dopravy

 Return to chapter overview

Program nabízí definovaný seznam způsobů dopravy. V programu Personalistika a Mzdy se jedná o dopravu do zaměstnání, která je součástí formuláře zaměstnance, záložky Adresy. V programu Sklad se jedná o způsob doručení jednotlivých zásilek. S výběrem nadefinované položky se setkáte například ve formuláři Vydané objednávky. V programu Docházka se jedná o dopravu na služební cestě. S výběrem položky se setkáte ve formuláři Služební cesta.

Zpusob dopravy do zamestnani

Číselník můžete rozšířit o další způsoby dopravy kliknutím na tlačítko [image] Nový záznam a v otevřeném formuláři Způsob dopravy do zaměstnání vyplňte potřebné údaje. Záznamy můžete upravovat tlačítkem [image] Editace záznamu.

Zpusob dopravy formular

· Kód - povinný číselný kód.

· Popis - textové označení způsobu dopravy.


Sazby za používání vlastního vozidla

Navigation: Cestovní náhrady >

Sazby za používání vlastního vozidla

 Return to chapter overview

V seznamu definujete sazbu a průměrné ceny pohonných hmot za použití vlastního vozidla na služební cestě.

Sazby za pouzivani vlastniho vozidla

Pro vytvoření nového záznamu v seznamu stiskněte tlačítko Novy zaznam Nový záznam, pro editaci stiskněte tlačítko Editace zaznamu Editace záznamu. Zobrazí se formulář Sazba náhrad za použití vlastního vozidla, který má záložky Sazba a Průměrné ceny PHM.


Formulář sazby za používání vlastního vozidla - Sazba

Navigation: Cestovní náhrady > Sazby za používání vlastního vozidla >

Formulář sazby za používání vlastního vozidla - Sazba

 Return to chapter overview

Ve formuláři zadáte základní údaje o sazbě náhrad za používání vlastního vozidla.

Sazby za pouzivani vlastniho vozidla Sazba

· Stát - povinný údaj. Zvolte z menu výchozí stát (ČR).

· Platnost od - povinný údaj. Zadejte datum, od kdy je sazba platná.

· Platnost do - povinný údaj. Zadejte datum, do kdy je sazba platná.

· Sazba náhrady za 1 km jízdy - povinný údaj. Zadejte sazbu náhrady za 1 km jízdy v Kč. Pro použití kalkulátoru je nutné mít nastavenou sazbu za použití vlastního vozidla.


Formulář sazby za používání vlastního vozidla - Průměrné ceny PHM

Navigation: Cestovní náhrady > Sazby za používání vlastního vozidla >

Formulář sazby za používání vlastního vozidla - Průměrné ceny PHM

 Return to chapter overview

Ve formuláři jsou nastaveny průměrné ceny pohonných hmot za použití vlastního vozidla na služební cestě. Nastavená cena se použije v kalkulátoru, pokud se zaměstnanec nemůže prokázat zaplacenou cenou.

Sazby za pouzivani vlastniho vozidla Prumerne ceny PHM


Druhy PHM

Navigation: Cestovní náhrady >

Druhy PHM

 Return to chapter overview

V seznamu jsou již přednastaveny druhy pohonných hmot. Číselník využijete v seznamu Sazby za používání vlastního vozidla. Seznam můžete, v případě potřeby, rozšířit o další položky.

Pro vytvoření nového záznamu v seznamu stiskněte tlačítko Novy zaznam Nový záznam, pro editaci stiskněte tlačítko Editace zaznamu Editace záznamu. Zobrazí se formulář Druh PHM, kde vyplníte následující pole:

Druhy PHM formular

· Kód - povinný údaj. Zadejte kód druhu pohonné hmoty (B98).

· Popis - povinný údaj. Doplňte název druhu pohonné hmoty (Benzín automobilový 98 oktanů).

· Poznámka - libovolná pro vás důležitá informace.

Po nastavení potvrďte tlačítkem OK.


Seznam vozidel

Navigation: Cestovní náhrady >

Seznam vozidel

 Return to chapter overview

V seznamu nadefinujete všechna vozidla, která používáte na služební cesty. Může se jednat o vozidla soukromá i firemní.

Pro nadefinování nového vozidla stiskněte tlačítko Novy zaznam Nový záznam, pro editaci stiskněte tlačítko Editace zaznamu Editace záznamu. Zobrazí se formulář Vozidla, který má tyto záložky:

Základní údaje

Osoby

Dokumenty


Formulář vozidla - Základní údaje

Navigation: Cestovní náhrady > Seznam vozidel >

Formulář vozidla - Základní údaje

 Return to chapter overview

Ve formuláři zadáte základní údaje o vozidlu.

Seznam vozidel_Zakladni udaje

· Registrační značka - povinný údaj. Zadejte registrační značku vozidla.

· Soukromé - v případě, že je vozidlo soukromé, zatrhněte pole.

· Popis - povinný údaj. Doplňte typ vozidla.

· Druh PHM - z nabídky vyberte na jaký druh pohonných hmot vozidlo jezdí. Druhy PHM nastavíte v programu Docházka (Cestovní náhrady -> Druhy PHM).

· Spotřeba - uveďte spotřebu pohonných hmot.

· Poznámka - libovolná pro vás důležitá informace.


Formulář vozidla - Osoby

Navigation: Cestovní náhrady > Seznam vozidel >

Formulář vozidla - Osoby

 Return to chapter overview

Ve formuláři přiřadíte vozidlu řidiče. V menu Seznamy -> Zaměstnanci na záložce Vozidla můžete rovněž provést přiřazení vozidla řidiči.

Záložka je rozdělena na dva seznamy. V levém seznamu jsou Nepřiřazené osoby, v pravém seznamu jsou Přiřazené osoby. Osoby mezi seznamy můžete přesouvat pomocí šipek.


Formulář vozidla - Dokumenty

Navigation: Cestovní náhrady > Seznam vozidel >

Formulář vozidla - Dokumenty

 Return to chapter overview

Ve formuláři zadáváte požadované dokumenty k automobilu.

Tlačítkem [image] Nový záznam otevřete formulář Dokument .


Šablony účtování služební cesty

Navigation: Cestovní náhrady >

Šablony účtování služební cesty

 Return to chapter overview

Do seznamu přidáváte šablony, které využijete při účtování služební cesty. Šablona se vám může automaticky předplnit při vytváření služební cesty nebo předplnění můžete provést ručně pomocí tlačítka Predplnit. Nastavení automatického předplnění provedete v nastavení aplikace.

Sablony uctovani sluzebni cesty

Pro vytvoření nové šablony stiskněte tlačítko Novy zaznam Nový záznam, pro editaci stiskněte tlačítko Editace zaznamu Editace záznamu. Zobrazí se formulář Šablona účtování služební cesty, která má záložky Šablona a Řádky účtování.


Formulář šablony účtování služební cesty - Šablona

Navigation: Cestovní náhrady > Šablony účtování služební cesty >

Formulář šablony účtování služební cesty - Šablona

 Return to chapter overview

Ve formuláři zadáváte základní údaje o šabloně.

Sablony uctovani sluzebni cesty Sablona

· Kód - povinný údaj. Zadejte kód šablony.

· Popis - povinný údaj. Doplňte název šablony.

· Poznámka - libovolná pro vás důležitá informace.

Po nastavení potvrďte tlačítkem OK.


Formulář šablony účtování služební cesty - Řádky účtování

Navigation: Cestovní náhrady > Šablony účtování služební cesty >

Formulář šablony účtování služební cesty - Řádky účtování

 Return to chapter overview

V této části formuláře přiřadíte šabloně řádky, které se použijí při vyúčtování služební cesty (při použití šablony). Stejné řádky definujete i při vytváření služební cesty v záložce Účtování.

Sablony uctovani sluzebni cesty Radky uctovani

Stiskem tlačítka Novy zaznam2 a vyplněním požadovaných polí v horní části formuláře vytváříte jednotlivé řádky účtování. Stiskem tlačítka Ok1 uložíte vytvořené řádky do seznamu, který je umístěn ve spodní části formuláře.

· Částka - povinný údaj. Zadejte částku pro vyúčtování.

· Měna - povinný údaj. Zvolte měnu pro vyúčtování.

· Typ - povinný údaj. Vyberte typ pohybu k zadávanému vyúčtování. Typy pro výběr pohybů nastavíte v programu Docházka (Cestovní náhrady -> Typy řádku účtování služební cesty).

· Popis - popis vyúčtování (záloha).


Sazby kapesného

Navigation: Cestovní náhrady >

Sazby kapesného

 Return to chapter overview

V seznamu máte možnost definovat výši kapesného pro každé rozdělení v jednom typu rozdělení. Pokud chcete sazby kapesného používat, je nutné provést potřebná nastavení v menu Systém -> Nastavení -> Nastavení aplikace -> Společné nastavení -> Cestovní náhrady. Na záložce je potřeba zaškrtnout volbu Používat sazby kapesného pro rozdělení a zvolit Typ rozdělení pro sazby kapesného. Pokud je provedeno toto nastavení, potom se při vyúčtování služební cesty sazba kapesného nastaví podle sazby pro rozdělení, ve kterém je zaměstnanec ke dni počátku služební cesty. Pokud sazba pro dané rozdělení není nalezena, potom se nastaví implicitní sazba z nastavení aplikace.

Nad seznamem můžete použít následující filtry:

§ Jen Mzdové středisko - název se zobrazí podle zvoleného rozdělení v cestovních náhradách v poli Typ rozdělení pro sazby kapesného. Po zatrhnutí pole vyberte z nabídky rozdělení, pro které chcete zobrazit sazby kapesného.

Pro vytvoření nového záznamu v seznamu stiskněte tlačítko Novy zaznam Nový záznam, pro editaci stiskněte tlačítko Editace zaznamu Editace záznamu. Zobrazí se formulář Sazba kapesného, ve kterém vyplňte požadovaná pole.

· Mzdové středisko - povinný údaj. Název se zobrazí podle zvoleného rozdělení v cestovních náhradách v poli Typ rozdělení pro sazby kapesného. Z nabídky vyberte rozdělení, pro které chcete nastavit sazbu kapesného.

· Platnost od - zadejte datum, od kterého je sazba kapesného platná.

· Platnost do - datum, do kterého je sazba platná. Datum není nutné vyplňovat.

· Sazba kapesného - povinný údaj. Zadejte sazbu kapesného v procentech.

· Poznámka - libovolná pro vás důležitá informace.

Po nastavení potvrďte tlačítkem OK.


Výstupy

Navigation: »No topics above this level«

Výstupy

 Return to chapter overview

V této části programu se nacházejí všechny výstupní sestavy a exporty dat. Menu Výstupy obsahuje následující položku:

Manažer výstupních sestav


Manažer výstupních sestav

Navigation: Výstupy >

Manažer výstupních sestav

 Return to chapter overview

V manažeru naleznete tiskové sestavy, které jsou rozděleny do kategorií (Zpracovaná docházka, Pracovní výkazy apod.). Předdefinované tiskové sestavy jsou vytvořeny tak, aby vyhovovaly co největšímu počtu zákazníků. V případě, že máte zájem o vytvoření nové sestavy dle vašich požadavků, kontaktujte firmu RON Software.

POZOR: Při restrukturalizaci jsou aktualizovány pouze systémové sestavy (černým písmem), ne sestavy uživatelské (červeným písmem).

Formulář Manažer výstupních sestav má několik částí:

Manazer vystupnich sestav

POZNÁMKA: Nezapomeňte, že pokud chcete vytisknout či zobrazit všechny údaje (všechny zaměstnance, rozdělení), musíte mít všechny filtry vypnuté!!!

levá část formuláře:

Ne vždy je potřeba zahrnout do výstupní sestavy všechny záznamy, proto si můžete zadat rozsahy pro vytváření jednotlivých tiskových sestav. K tomu slouží na levé straně okna Manažera výstupních sestav tzv. Panely. Všechny panely nemusí být u každé sestavy/kategorie zobrazeny.

Dvojita sipka doprava | Panel skrývá možnosti nastavení filtru.
Dvojita sipka dolu | Panel zobrazuje možnosti nastavení zvoleného filtru.

Řazení

§ Řazení - údaje zobrazované na vybrané sestavě můžete seřadit např. podle jména, příjmení, osobního čísla apod. Kliknutím na tlačítko Razeni Nastavení řazení aktuální kategorie nebo klávesami Ctrl + R otevřete formulář pro provedení úprav. Více o aktuálním řazení v kapitole Ovládání programu - Editor řazení.

Filtr

§ Filtr - zvolenou sestavu můžete libovolně filtrovat. Nabídku tohoto seznamu můžete upravit. Filtry definujete, popřípadě editujete kliknutím na tlačítko Filtr Nastavení filtru aktuální kategorie nebo klávesami Ctrl + F. Více o filtrech v kapitole Ovládání seznamu - Seznam filtrů.

Období

§ Měsíc - ve vybrané sestavě se zobrazí údaje aktuální pro zvolený měsíc. Standardně je nastaven aktuální měsíc, pokud požadujete tisknout sestavu za jiné období, proveďte změnu.

§ Čtvrtletí - ve vybrané sestavě se zobrazí údaje aktuální pro zvolené čtvrtletí.

§ Rok - ve vybrané sestavě se zobrazí údaje aktuální pro zvolený rok.

§ Období - ve vybrané sestavě se zobrazí údaje aktuální pro zvolené období, tj. vyplníte data Od Do.

§ V. Období - ve vybrané sestavě se zobrazí údaje za vybrané variabilní období.

Osoba

§ Osoba - pro výběr jedné osoby pro tisk postačuje zaškrtnout volbu „jen osoba" a vybrat požadovanou osobu ze seznamu. Pokud je seznam dlouhý a špatně se vám v něm orientuje, můžete kliknout na podtržený text Osoba. V zobrazeném okně je možné seřadit seznam osob podle požadovaného sloupce a to tak, že se provede dvojklik na požadovaném záhlaví sloupce (pokud požaduji seřadit seznam dle příjmení, provedu dvojklik na záhlaví příjmení). Je také možné použít rychlé vyhledávání stiskem kláves CTRL+F.

TIP: Tisk sestav jednoho zaměstnance můžete také uskutečnit z editace docházky, kdy po stisku tlačítka „Tisk" je nastaven filtr dle aktuálně editovaného zaměstnance.

§ Jen typ osoby - vyšší stupeň rozdělení (filtrování). Slouží k výběru podle rozdělení na zaměstnance nebo zaměstnance jiné firmy v případě, že máte zaměstnance například z pracovní agentury.

§ Jen typ PP - z nabídky vyberte typ pracovního poměru. Filtr může sloužit například pro zobrazení zaměstnanců, kteří mají HPP (hlavní pracovní poměr) apod.

Osoba - výčet

§ Osoby - pokud chcete v sestavě zobrazit jen některé osoby, zatrhněte pole. Potom stiskněte na podtržený název Osoby. Zobrazí se seznam pro výběr osob. Zatržením polí ve sloupci Výběr zvolte osoby, které chcete zobrazit v požadované sestavě. Po potvrzení výběru se u filtru zobrazí řádky s vybranými osobami. V řádku je zobrazeno Rodné číslo; Osobní číslo; Datum nástupu ve formátu RRRR.MM.DD. Na konci posledního řádku je zobrazeno číslo s celkovým počtem vybraných osob například: (3).

kalendář

§ Kalendář - v případě použití filtru zvolte z nabízeného seznamu kalendář, kterého se budou týkat data v načtené sestavě.

§ Do - v tomto filtru lze nastavit rozmezí údajů, které chcete v rámci kalendářů zobrazit.

1. Rozdělení

§ Typ rozdělení - pokud zaškrtnete tento filtr, aktivují se další výběrové filtry v této zóně. Vyberte typ rozdělení (například mzdové středisko) a

§ Rozdělení - vyberte rozdělení, které chcete v sestavě zobrazit.

§ Do - v tomto filtru lze nastavit rozmezí údajů, které chcete v rámci rozdělení zobrazit.

§ Včetně podřízených rozdělení - filtr nechá zobrazit také podřízená rozdělení vybraného rozdělení.

2. Rozdělení

Zde máte možnost nastavit filtr pro druhé rozdělení.

1. Rozdělení - výčet

§ Typ rozdělení - vyberte typ rozdělení.

§ Rozdělení - vyberte rozdělení, které chcete v sestavě zobrazit.

2. Rozdělení - výčet

Možnost nastavení druhého filtru rozdělení - výčet.


Seznam všech sestav

Navigation: Výstupy > Manažer výstupních sestav >

Seznam všech sestav

 Return to chapter overview

V seznamu jsou uvedeny sestavy, které jsou zařazeny do kategorií. Okno je rozděleno do dvou částí. Pravá část formuláře obsahuje seznam všech sestav, ve druhé části je možné nastavit filtr nebo řazení pro vybranou sestavu.

pravá část formuláře:

část I

C_MVS_Tlac. Zobrazit_skryt rozsirujici informace

Zobrazit/Skrýt rozšiřující informace - u jednotlivých kategorií a sestav se zobrazí/skryje rozšiřující informace. V zobrazené informaci může být uvedeno jméno přihlášeného uživatele, datum a čas poslední změny sestavy/kategorie a atributy sestavy (S - systémová sestava/kategorie, M - sestava/kategorie vytvořená uživatelem, P - pokud má sestava/kategorie příznak "veřejná", Q, F. U jednotlivých sestav můžou být zobrazeny jejich kombinace, například SQ, MFP apod.). Sestavě/kategorii můžete Zapnout/Vypnout příznak "veřejná" pomocí kontextového menu (stiskem pravého tlačítka na označené sestavě). Ze zobrazené nabídky zvolte Zapnout/Vypnout příznak "veřejná".

· Typ zobrazení - stiskem tlačítka, zobrazeného vedle popisu, se zobrazí seznam, ze kterého si můžete vybrat požadované zobrazení:

C_MVS Typ zobrazeni

Podle zvoleného výběru (Kategorie, Seznam nebo Oblíbené) se vám zobrazí tlačítko a seznam sestav/kategorií.

C_MVS_Tlac. Typ zobrazeni Kategorie | Kategorie - v seznamu se zobrazí seznam kategorií, do kterých jsou zařazeny sestavy. Sestavy uložené v kategorii můžete zobrazit dvojklikem na kategorii. Další možností je kliknout vedle kategorie na tlačítko +, které se stiskem změní na - a zobrazí seznam sestav přiřazených kategorii.
C_MVS_Tlac. Typ zobrazeni Seznam | Seznam - v okně se zobrazí seznam sestav. Pokud chcete vidět, ke které kategorii sestava náleží, stiskněte tlačítko C_MVS_Tlac. Zobrazit_skryt rozsirujici informace . Stiskem se zobrazí další sloupce s informacemi o sestavách včetně sloupce Kategorie.
C_MVS_Tlac. Typ zobrazeni Oblibene | Oblíbené - v seznamu se zobrazí oblíbené sestavy, které máte přidány do seznamu. Více o oblíbených v seznamu oblíbených sestav.

· Oblíbené - pokud každý měsíc po uzávěrce tisknete stále stejné sestavy, můžete si do tohoto seznamu přidat vaše oblíbené sestavy. Sestavu přidáte do oblíbených pomocí kontextového menu (stiskem pravého tlačítka na označené sestavě). Ze zobrazené nabídky zvolte Přidat do seznamu oblíbených sestav. Více o oblíbených sestavách v následující kapitole Seznam oblíbených sestav. Stiskem tlačítka, zobrazeného vedle popisu, se zobrazí seznam, ze kterého si můžete vybrat požadované zobrazení:

Podle zvoleného výběru se vám zobrazí tlačítko a seznam sestav/kategorií.

C_MVS_Tlac. Oblibene Vsechny sestavy | <Všechny sestavy> - v seznamu budou zobrazeny všechny sestavy vybraného typu zobrazení.
C_MVS_Tlac. Oblibene Faktury | Faktury - název jste vytvořili při vkládání nové sestavy mezi oblíbené v poli Seznam oblíbených sestav. V seznamu se zobrazí oblíbené sestavy, které jste si přidali do seznamu.

část II

Tato část formuláře obsahuje seznam tematických kategorií [image] , [image] . Každá složka (kategorie) obsahuje jednotlivé sestavy ( [image] - sestava vytvořená v editoru sestav (FastReport), [image] - sloupcová sestava, [image] - exportní sestava, [image] - OLAP Tabulky). Rozkliknutím se označená sestava zobrazí. Pokud použijete filtry, nezapomeňte, že sestava bude obsahovat údaje, které splňují podmínky filtru. Jestliže tedy sestava nezobrazí požadovaná data, zkontrolujte nastavení filtrů.

Pokud v seznamu nemáte zobrazeny oblíbené sestavy, můžete pomocí stisku pravého tlačítka na sestavě/kategorii zobrazit následující menu:

- označená kategorie:

C_MVS Kontextove menu Kategorie1

Zapnout/Vypnout příznak "veřejný" - po výběru se zapne/vypne příznak "veřejná". Veřejné kategorie může vidět i uživatel, který nemá právo na sestavy v manažeru sestav. Veřejná kategorie bude mít u ikony zobrazen příznak [image] (zelený čtvereček s černým panáčkem).

- označená sestava:

C_MVS Kontextove menu Sestavy1

Přidat do seznamu oblíbených sestav - sestavu můžete přemístit do seznamu oblíbených sestav. Po výběru se zobrazí formulář Přidat do seznamu oblíbených sestav, ve kterém můžete zvolit požadovaný seznam, do kterého sestavu přemístíte. Sestava zůstane i v seznamu, ze kterého jste ji přemístili.

Zapnout/Vypnout příznak "veřejná" - po výběru se zapne/vypne příznak "veřejná". Veřejné sestavy může vidět i uživatel, který nemá právo na sestavy v manažeru sestav. Veřejná sestava bude mít u ikony zobrazen příznak [image] (zelený čtvereček s černým panáčkem). Aby oblíbenou sestavu viděli i ostatní uživatelé, je potřeba, aby byla veřejná i její kategorie.

V horní části se nacházejí funkční ikony pro práci se sestavami:

C_MVS_Tlac. Vytvorit novou sestavu_kategorii

Vytvořit novou sestavu/kategorii (Alt+Ins) - otevře se formulář Vytvoření nové sestavy/kategorie, ve kterém vyplněním potřebných údajů vytvoříte novou kategorii nebo sestavu. Zvolte, jestli bude vytvořena kategorie nebo sestava.

1. Vytvořit novou kategorii:

· Název - zadejte název (kategorie).

C_MVS Seznam vsech sestav podle kategorii formular vytvoreni nove kategorie

Tlačítkem [image] otevřete následující okno Kategorie sestav, v němž zadáte SQL dotaz. Přes tlačítko [image] otevřete seznam parametrů, ze kterého můžete použít nabízené parametry. Po vytvoření potřebných změn potvrďte tlačítkem [image].

C_MVS Seznam vsech sestav podle kategorii formular kategorie sestav novy

2. Vložit do kategorie (v případě, že vytváříte sestavu):

Program automaticky vyplní kategorii podle toho, kde v Seznamu všech sestav podle kategorií zrovna máte umístěn kurzor.

C_MVS Seznam vsech sestav podle kategorii formular vytvoreni nove sestavy

Vyberte typ sestavy:

· Sestava v editoru sestav - je nejsložitější a vytvořit ji může jen odborník. Zadejte Název (sestavy) a potvrďte tlačítkem [image]. Otevře se FastReport, ve kterém můžete sestavu vytvořit.

· Sloupcová sestava - tento typ sestavy můžete vytvořit také sami. Nejprve zadejte Název (sestavy) a potvrďte tlačítkem [image]. Otevře se formulář Editace sestavy, kde vyberete údaje, které chcete v sestavě zobrazit. Ze sloupce Dostupná pole přesuňte požadovaná pole pomocí šipek [image] , C_Sipka dvojita vpravo, [image], C_Sipka dvojita vlevo do sloupce Vybraná pole. Můžete si sami navrhnout vzhled titulků, sloupců, stránky (formát, okraje, číslování a datování stránek), titulku sestavy atd. Více o sloupcových sestavách se dozvíte v kapitole Ovládání - Tiskové sestavy.

· Exportní sestava - zadejte Název (sestavy) a potvrďte tlačítkem [image]. Otevře se formulář Editace sestavy, kde vyberete údaje, které chcete v sestavě zobrazit. Ze sloupce Dostupná pole přesuňte požadovaná pole pomocí šipek [image] , C_Sipka dvojita vpravo, [image], C_Sipka dvojita vlevo do sloupce Vybraná pole. Vyberte formát, do kterého se má sestava exportovat: Microsoft Word, Microsoft Excel nebo Textový soubor. Definovanou sestavu můžete ihned exportovat do požadovaného formátu tlačítkem [image] nebo můžete sestavu [image] a podle potřeby exportovat z formuláře Manažer výstupních sestav. Více o exportních sestavách v Ovládání programu - Seznam sestav pro export.

· OLAP Tabulka - vytvoření této sestavy je jednoduší než v případě vytvoření sestavy v editoru sestav. Přesto Vám s jejím vytvořením může pomoci odborník. Zadejte Název (sestavy) a potvrďte tlačítkem [image]. Otevře se OLAP Tabulka, ve které můžete, po vytvoření SQL dotazu, sestavu vytvořit. SQL dotaz vytvoříte, po uzavření OLAP Tabulky, pomocí ikony C_MVS_Tlac. Vlastnosti sestavy_kategorie Vlastnosti sestavy/kategorie. K úpravě OLAP Tabulky se po vytvoření SQL dotazu dostanete pomocí ikony C_MVS_Tlac. Editace sestavy_kategorie Editace sestavy/kategorie.

C_MVS_Tlac. Vytvorit novou sestavu_kategorii z kopie aktualni sestavy_kategorie

Vytvořit novou sestavu/kategorii z kopie aktuální sestavy/kategorie - ikonu použijete při vytváření podobné sestavy té, která již existuje. Označte sestavu, z níž chcete duplikát vytvořit, a pak klikněte na tuto ikonu. V otevřeném okně Vytvoření nové sestavy z kopie sestavy vyplníte Název sestavy a potvrdíte tlačítkem [image] , čímž se dostanete do FastReportu, kde provedete úpravy sestavy.

Tlačítko použijete i v případech, kdy chcete vytvořit obdobnou kategorii té, kterou již máte. Označte kategorii, z níž chcete duplikát vytvořit, a pak klikněte na tuto ikonu. Tím se otevře formulář Vytvoření nové kategorie z kopie kategorie, kde vyplníte pole Název sestavy a potvrdíte [image]. Následně se otevře formulář Kategorie sestav, v němž zadáte SQL dotaz. Tlačítkem [image] otevřete seznam parametrů, ze kterého můžete použít nabízené parametry. Po vytvoření potřebných změn potvrďte tlačítkem [image] .

C_MVS Seznam vsech sestav podle kategorii formular kategorie sestav

C_MVS_Tlac. Editace sestavy_kategorie

Editace sestavy/kategorie - v případě, že chcete změnit sestavu (jen nesystémovou), označte ji a kliknutím na editační ikonu se otevře jeden z formulářů: FastReport nebo Editace sestavy, kde provedete potřebné změny.

Tlačítko použijete i v případech, kdy chcete změnit kategorii. Označte danou kategorii (lze pouze vámi vytvořenou), poté klikněte na tuto ikonu, čímž se otevře formulář Kategorie sestav, v němž změníte SQL dotaz. Tlačítkem [image] otevřete seznam parametrů, ze kterého můžete použít nabízené parametry. Po vytvoření potřebných změn potvrďte tlačítkem [image].

C_MVS_Tlac. Prejmenovat sestavu_kategorii

Přejmenovat sestavu/kategorii - pokud chcete změnit název sestavy (popř. kategorie - lze pouze u vámi vytvořené kategorie/sestavy), označte danou sestavu/kategorii a klikněte na toto tlačítko. V okně Změna názvu sestavy (kategorie) uveďte nový Název sestavy (kategorie) a potvrďte.

C_MVS_Tlac. Vlastnosti sestavy_kategorie

Vlastnosti sestavy/kategorie - klikněte na sestavu (popř. kategorii - lze pouze na vámi vytvořenou kategorii), o které zjišťujete podrobnosti, a pak na tuto ikonu. Ve formuláři Vlastnosti sestavy/kategorie se dozvíte, kdo je vlastníkem, kdy byla sestava/kategorie vytvořena, kdy proběhly poslední změny, můžete si přečíst poznámky k sestavě/kategorii (popř. je tam doplnit).

C_MVS Seznam vsech sestav podle kategorii formular vlastnosti sestavy

C_MVS_Tlac. Viditelnost panelu | Viditelnost panelů - stiskem tlačítka můžete nastavit viditelnost některých panelů, které se zobrazují v okně manažera výstupních sestav na levé straně. Pokud se má použít viditelnost panelů z kategorie, nechte políčko zaškrtnuté. V případě vlastního nastavení nesmí být pole zaškrtnuté.
 | Překlad - stiskem tlačítka se otevře formulář Překlad sestavy, který se využívá pro jazykové mutace do slovenštiny, angličtiny apod. Funkci můžete využít jen u sestav, které jsou vytvořeny v editoru sestav.

C_MVS Seznam vsech sestav podle kategorii formular preklad sestavy

Nový - přidáte sloupec pro nový překlad. Do formuláře je třeba vyplnit kód jazyka pro překlad.

Přejmenovat - přejmenujete aktuální sloupec. Do formuláře zadejte nový kód jazyka pro překlad.

Zrušit - zrušíte aktuální sloupec s překladem.

Načíst - načtete řetězce ze souboru.

Uložit - uložíte přeložené řetězce do souboru.

 | Heslo - pokud budete chtít sestavu, která je zabezpečená heslem, Editovat nebo vytvářet kopii z této sestavy, zobrazí se formulář pro zadání hesla.
C_MVS_Tlac. Editovat SQL dotaz | Editovat SQL dotaz - po stisku tlačítka můžete zadat nebo editovat SQL dotaz sestavy. Tlačítkem [image] otevřete seznam parametrů, ze kterého můžete použít nabízené parametry. Po vytvoření potřebných změn potvrďte tlačítkem [image] .

C_MVS_Tlac. Zrusit sestavu_kategorii | Zrušit sestavu/kategorii - zruší se vybraná sestava (kategorie - pouze nesystémová).
C_MVS_Tlac. Nacist sestavu_kategorii ze souboru | Načíst sestavu/kategorii ze souboru - do manažeru sestav je možno importovat vytvořené sestavy v editoru sestav (sestavu například vytvoří naši programátoři a zašlou vám ji emailem). Import sestav lze provést také stiskem kláves CTRL+L a výběrem souboru *.RMR.
C_MVS_Tlac. Ulozit sestavu_kategorii do souboru | Uložit sestavu/kategorii do souboru - libovolnou sestavu (kategorii vámi vytvořenou) můžete uložit do adresáře v počítači a dále ji např. přenést do jiného počítače.

část III

Po označení některé sestavy/kategorie v seznamu se zobrazí ve třetí části podrobnější informace o vybrané sestavě/kategorii.

Sestava - pokud je kurzor v pravé části okna na konkrétní sestavě (ve složce), objeví se název označené sestavy.

Kategorie - pokud je kurzor v pravé části okna na konkrétní složce nebo sestavě, objeví se v této kolonce název kategorie.

Atributy - atributy sestavy/kategorie (S - systémová sestava/kategorie, SP - pokud má systémová sestava/kategorie příznak "veřejná", M - sestava/kategorie vytvořená uživatelem, MP - pokud má sestava/kategorie vytvořená uživatelem příznak "veřejná"). Sestavě/kategorii můžete Zapnout/Vypnout příznak "veřejná" pomocí kontextového menu (stiskem pravého tlačítka na označené sestavě). Ze zobrazené nabídky zvolte Zapnout/Vypnout příznak "veřejná". Atributy se zobrazí v seznamu u všech sestav/kategorií stisknutím tlačítka C_MVS_Tlac. Zobrazit_skryt rozsirujici informace.

Poslední změna - poslední provedená změna v sestavě/kategorii (5.2.2008 11:55:44). Datum a čas poslední změny se zobrazí v seznamu u všech sestav/kategorií po stisku tlačítka C_MVS_Tlac. Zobrazit_skryt rozsirujici informace.

Uživatel - u sestav/kategorií vytvořených uživatelem se v poli zobrazí jeho jméno, podle přihlašovacích údajů. Uživatelské jméno bude zobrazeno i v seznamu sestav/kategorií u jeho vytvořené sestavy/kategorie po stisku tlačítka C_MVS_Tlac. Zobrazit_skryt rozsirujici informace.

Uzamčeno heslem - pokud je uživatelem vytvořená sestava uzamčena, zobrazí se zde popis ANO. V opačném případě zde bude zobrazen popis NE. Vkládat hesla je možné jen u sestav vytvořených uživatelem.

Popis - pod podrobnějšími informacemi o sestavě/kategorii se zobrazí popis označené kategorie/sestavy.

část IV

Náhled - slouží k zobrazení vybrané tiskové sestavy. V horní části okna tiskové sestavy se nachází tlačítka pro další práci se sestavou, mimo jiné:

Tisknout - ikona pro otevření okna Tisk, ve kterém lze definovat nastavení tiskárny a rozvržení sestavy určené pro tisk.

Export - použitím tohoto tlačítka se objeví nabídka pro výběr formátu exportované tiskové sestavy.

Odeslat E-mailem - slouží pro přenos sestavy emailem. Musíte vyplnit všechny požadovaná pole, a to komu odesíláte, kdo odesílá, hostitel (případně i jméno a heslo uživatele s oprávněním).

Tisk - spustíte samotný tisk vybrané sestavy. U většiny sestav se program v závislosti na typu sestavy zeptá, co přesně chcete vytisknout. V případě, že máte označenou exportní sestavu (při vytváření nové sestavy jste zvolili možnost Exportní sestava), pak se místo tohoto tlačítka zobrazí tlačítko pro export.

Export - v případě, že budete mít označenou exportní sestavu, tak se tlačítko zobrazí místo tlačítka pro tisk. Můžete exportovat sestavu, kterou máte uloženou v Seznamu všech sestav.

Pokud máte zvolenou výstupní sestavu, případně nastaveny potřebné filtry, můžete tiskopis zpracovat tlačítkem [image] nebo přímo tlačítkem [image].

Vytvoření vlastních sestav předpokládá znalosti jazyka SQL. Výsledky lze také exportovat do textového souboru (využitím stávajícího exportu nebo definicí vlastního).


Seznam oblíbených sestav

Navigation: Výstupy > Manažer výstupních sestav >

Seznam oblíbených sestav

 Return to chapter overview

Pokud každý měsíc po uzávěrce tisknete stále stejné sestavy, můžete si do seznamu Oblíbené přidat vaše oblíbené sestavy. Sestavu přidáte do seznamu oblíbených pomocí kontextového menu (stiskem pravého tlačítka na označené sestavě). Ze zobrazené nabídky zvolte Přidat do seznamu oblíbených sestav. Po vybrání se zobrazí formulář Přidat do seznamu oblíbených sestav:

C_MVS Pridat do seznamu oblibenych sestav

· Seznam oblíbených sestav - pro vytvoření nového seznamu oblíbených sestav zadejte název. Pro vložení oblíbené sestavy do existujícího seznamu oblíbených sestav vyberte název ze seznamu.

· Název oblíbené sestavy - v poli je předvyplněný převzatý název sestavy ze seznamu. Pokud chcete název změnit, přepište jej.

Po potvrzení zadaných údajů stiskem tlačítka [image] se nově vytvořený seznam oblíbených sestav přidá do seznamu Oblíbené.

Pokud máte v Typu zobrazení vybráno tlačítko C_MVS_Tlac. Typ zobrazeni Oblibene, můžete pomocí stisku pravého tlačítka na sestavě/kategorii zobrazit následující menu:

- označená kategorie:

C_MVS Kontextove menu Kategorie

Zrušit seznam oblíbených sestav - po výběru se zobrazí dotaz, zda si přejete zrušit seznam oblíbených sestav. Po potvrzení dotazu bude seznam oblíbených sestav zrušen včetně všech oblíbených sestav.

Přejmenovat seznam oblíbených sestav - po výběru se zobrazí formulář Změna názvu seznamu oblíbených sestav, ve kterém změníte název kategorie.

Zapnout/Vypnout příznak "veřejný" - po výběru se zapne/vypne příznak "veřejná". Veřejné kategorie může vidět i uživatel, který nemá právo na sestavy v manažeru sestav. Veřejná kategorie bude mít u ikony zobrazen příznak [image] (zelený čtvereček s černým panáčkem).

- označená sestava:

C_MVS Kontextove menu Sestavy

Přidat do seznamu oblíbených sestav - sestavu můžete přemístit do jiného oblíbeného seznamu. Po výběru se zobrazí formulář Přidat do seznamu oblíbených sestav, ve kterém můžete zvolit požadovaný seznam, do kterého sestavu přemístíte. Sestava zůstane i v seznamu, ze kterého jste ji přemístili.

Zrušit sestavu ze seznamu oblíbených sestav - po výběru se zobrazí dotaz, zda si přejete zrušit oblíbenou sestavu ze seznamu oblíbených. Po potvrzení dotazu bude sestava ze seznamu oblíbených odstraněna.

Přejmenovat oblíbenou sestavu - po výběru se zobrazí formulář Změna názvu oblíbené sestavy, ve kterém změníte název oblíbené sestavy.

Zapnout/Vypnout příznak "veřejná" - po výběru se zapne/vypne příznak "veřejná". Veřejné sestavy může vidět i uživatel, který nemá právo na sestavy v manažeru sestav. Veřejná sestava bude mít u ikony zobrazen příznak [image] (zelený čtvereček s černým panáčkem). Aby oblíbenou sestavu viděli i ostatní uživatelé je potřeba, aby byla veřejná i její kategorie.

POZNÁMKA: Každý uživatel může mít svůj vlastní seznam oblíbených sestav. Přiřazení do seznamu oblíbených sestav neznamená, že by se sestava "ztratila" ze seznamu všech sestav. Uživatelské nastavení sestavy se ukládá jen v aktuálně používané databázi, tudíž nelze sestavu vyexportovat do jiné databáze a přenést vytvořené nastavení.


Uživatelské funkce

Navigation: »No topics above this level«

Uživatelské funkce

 Return to chapter overview

Volba Uživatelské seznamy, nabízí možnost vytvoření vlastních seznamů s údaji dle vašich požadavků. Z něj si pak můžete vytvořit sestavy k tisku. Pro vznik seznamu je nutné znát SQL příkazy. S vytvořením je tedy nutné oslovit správce ve vaší firmě.

V případě vytvoření nějakého seznamu se tento stane součásti nabídky menu Uživatelské funkce.


Nastavení uživatelských seznamů

Navigation: Uživatelské funkce >

Nastavení uživatelských seznamů

 Return to chapter overview

V tomto formuláři budou změny pravděpodobně provádět správci vašeho systému. Nový seznam vytvoříte přes tlačítko [image].

Uzivatelske funkce nastaveni uzivatelskych seznamu

· Kód - zadejte kód.

· Jen k prohlížení (data nelze editovat) - zaškrtávací položka. V případě její volby je nemožné ve vytvořeném seznamu provádět změnu a naopak. Existují však výjimky u některých tabulek, u kterých nelze provádět změnu ani při nezaškrtnutí kolonky.

· Kontrolovat databázová práva podle uživatele - po zaškrtnutí pole kontroluje databázová práva podle uživatele.

· Nadpis - doplňte název seznamu.

· SQL - zadejte SQL příkaz.

· Parametry - kliknutím na tlačítko [image] Nový budete zadávat kód nového parametru. Po potvrzení zadaného kódu se objeví formulář Nastavení parametru seznamu, kde zadáte typ parametru (Datum, Text, Celé číslo, Zaškrtávátko, Nový řádek, Oddělovač), nadpis parametru, šířku a SQL pro výběr a potvrďte. Tím jste zadali nový parametr. Pro laiky v oblasti SQL dotazů: parametr je jakási podmínka, která je v kolonce SQL napsána za dvojtečkou. Zde se tyto parametry zobrazují.

· Parametry aplikace - do této kolonky nelze zapisovat.

 | Nový - v seznamu vytvoříte nový záznam.
C_Novy z kopie | Nový z kopie - nový záznam vytvoříte také tak, že zkopírujete stávající záznam a jen přepíšete požadované údaje. Zjednodušíte si tak práci, protože nemusíte vypisovat všechna nastavení formuláře.
 | Zrušit - tlačítkem zrušíte dané nastavení vybraného záznamu.
 | Načíst - načtete soubor obsahující nějaký seznam.
 | Uložit - po načtení kliknete na tlačítko uložit.
 | OK - tlačítkem potvrdíte nastavení.
 | Storno - tlačítkem uzavřete formulář.

Pokud chcete uživatelský seznam poslaný našimi odborníky přidat do menu Uživatelské funkce, proveďte následující kroky:

- soubor uložte do PC,

- otevřete si program,

- jděte do menu Uživatelské funkce/Nastavení uživatelských seznamů,

- ve formuláři stiskněte tlačítko [image] Načíst,

- načtěte uložený soubor, který vám byl zaslán,

- formulář potvrďte tlačítkem [image],

- poté se v menu Uživatelské funkce zobrazí vámi přidaný uživatelský seznam,

- po stisku položky se uživatelský seznam spustí.


Nastavení uživatelských skriptů

Navigation: Uživatelské funkce >

Nastavení uživatelských skriptů

 Return to chapter overview

V tomto formuláři budou provádět změny pravděpodobně správci systému.

Uzivatelske funkce nastaveni uzivatelskych skriptu

· Kategorie - kategorii skriptů.

· Skript - popis skriptu.

· Titulek - titulek skriptu. Tento titulek můžete přepsat.

Nový - přes toto tlačítko vytvoříte nový záznam.

Oddělovač

Zrušit - tlačítkem smažete dané nastavení, vytvořený seznam.

OK - tlačítkem potvrdíte nastavení.

Storno - tlačítkem uzavřete formulář bez provedených změn.

Přes tlačítko [image] otevřete formulář Výběr skriptu, kde vyberete požadovaný skript. Po potvrzení tlačítkem [image] se vybraný skript vyplní do výše jmenovaných políček.

POZOR: Při restrukturalizaci jsou aktualizovány pouze systémové skripty (černým písmem), ne skripty uživatelské (červeným písmem). Toto barevné rozlišení zjistíte v menu "Výstupy/Manažer skriptů".

Pokud chcete skript poslaný našimi odborníky přidat do menu Uživatelské funkce, uložte soubor do vašeho počítače. Načtení do programu provedete v Manažeru skriptů po stisku tlačítek Ctrl+Alt+S. V tomto okně proveďte načtení skriptu ze souboru (Ctrl+L) a nastavte zde požadované parametry skriptu. Přidání uživatelského skriptu do menu Uživatelských funkcí provedete následovně:

- v programu v menu Uživatelské funkce zvolte volbu Nastavení uživatelských skriptů,

- v zobrazeném formuláři stiskněte tlačítko [image] Nový uživatelský skript,

- v okně Výběr skriptu vyberte ve složce načtený skript a potvrďte dvakrát tlačítkem [image],

- poté se v menu Uživatelské funkce zobrazí vámi přidaný skript,

- po stisku položky se skript spustí.


Okno

Navigation: »No topics above this level«

Okno

 Return to chapter overview

Položky tohoto menu jsou určeny pro práci s okny. Jednotlivými volbami z menu docílíte přehlednějšího zobrazení, což vám může usnadnit práci v oknech. Když nejsou v programu žádná okna otevřená, je seznam položek neaktivní.

Jakmile však otevřete jakékoli okno v programu, tak se toto menu aktivuje a vytvoří pod poslední standardní položkou menu Uzavřít vše další seznam právě otevřených oken. Okno, se kterým právě pracujete, je označeno [image].

Na následujících stránkách se budeme věnovat jednotlivým funkcím menu.


Kaskáda

Navigation: Okno >

Kaskáda

 Return to chapter overview

Máte-li otevřeno více oken, s nimiž chcete pracovat, pak existuje několik možností, jak okna zobrazit. Formuláře můžete uspořádat kaskádně. U jednotlivých oken lze vidět nadpisy tabulek. Kliknutím na kterékoli z nich přesune okno do popředí a formulář je tedy vidět celý. Pro takovou úpravu oken stačí kliknout na položku Kaskáda.


Dlaždice vodorovně

Navigation: Okno >

Dlaždice vodorovně

 Return to chapter overview

Máte-li otevřeno více oken, s nimiž chcete pracovat, můžete je uspořádat do vodorovných dlaždic. Kliknutím na kterékoli z nich se okno aktivuje a můžete s ním pracovat, aniž by ostatní okna zmizela. Pro toto zobrazení stačí kliknout na položku Dlaždice vodorovně.


Dlaždice svisle

Navigation: Okno >

Dlaždice svisle

 Return to chapter overview

Další možností je uspořádat okna ve svislých dlaždicích. Kliknutím na kterékoli z nich se okno aktivuje a můžete s ním pracovat, aniž by ostatní okna zmizela. Pro toto zobrazení stačí kliknout na položku Dlaždice svisle.


Maximalizovat vše

Navigation: Okno >

Maximalizovat vše

 Return to chapter overview

Tato funkce souvisí s prací s okny. Pokud jste již použili volbu Minimalizovat vše, a chcete s okny opět pracovat, použijte volbu Maximalizovat vše. Tím se všechna původně otevřená okna opět objeví na obrazovce.


Minimalizovat vše

Navigation: Okno >

Minimalizovat vše

 Return to chapter overview

Tato funkce souvisí s prací s okny. Pokud chcete všechna okna, se kterými aktuálně pracujete, minimalizovat (ať už z jakéhokoli důvodu), klikněte na tuto volbu. Všechna okna se "srolují" na spodní okraj základní plochy programu.


Uzavřít vše

Navigation: Okno >

Uzavřít vše

 Return to chapter overview

Poslední možnost v tomto menu je Uzavřít vše. Tato funkce má stejný důsledek, jako když zavřete všechna okna postupně. Výhodou je, že všechna okna, s nimiž pracujete, zavřete jedním příkazem. Po uzavření oken zůstane program spuštěn.


Nápověda

Navigation: »No topics above this level«

Nápověda

 Return to chapter overview

Cílem nápovědy v aplikaci je usnadnění práce s programem. Položku Nápověda naleznete na horní liště úplně vpravo.


Obsah nápovědy

Navigation: Nápověda >

Obsah nápovědy

 Return to chapter overview

Tato volba otevře soubor nápovědy na stránce obsahu. V něm si můžete vybrat požadovanou kapitolu a přepnout se na odpovídající stránku.


Kontextová nápověda

Navigation: Nápověda >

Kontextová nápověda

 Return to chapter overview

Zobrazuje nápovědu vzhledem k místu, kde se nachází program. To znamená, že stisknete-li klávesu F1 (nebo tlačítko nápověda), zobrazí se na aktuálním formuláři odpovídající stránka v nápovědě. Na zprovoznění funkce se stále pracuje.


Helpdesk

Navigation: Nápověda >

Helpdesk

 Return to chapter overview

Formulář můžete využít v případech, kdy budete potřebovat vložit nový dotaz nebo odeslat vzorek databáze na Helpdesk.

· Adresa - zadejte internetovou adresu serveru - http://helpdesk.ron.cz.

· Přihlašovací jméno - zadejte přihlašovací jméno, které používáte pro přihlášení na helpdesk. Přihlašovací jméno najdete na aktivační kartě programu.

· Heslo - zadejte heslo, které používáte pro přihlášení na helpdesk. Heslo najdete na aktivační kartě programu.

Test - po stisku tlačítka proběhne ověřování přihlašovacích údajů. Po ověření přihlašovacích údajů program zobrazí informaci, například: "Přihlášení na Helpdesk bylo úspěšné".

Nastavit výchozí - nastaví výchozí adresu a heslo. Přihlašovací jméno musíte nastavit sami. Správné přihlašovací údaje najdete na aktivační kartě programu.

· Moje dotazy - po stisku odkazu budete přihlášeni na helpdesk, kde se zobrazí seznam s vašimi dotazy.

· Vložit nový dotaz - stiskem odkazu se přihlásíte na helpdesk a načte se formulář pro vložení nového dotazu.

· Odeslat vzorek databáze - po stisku odkazu se otevře formulář pro odeslání dotazu. Vyplňte Předmět a Text dotazu a stiskněte tlačítko C_Vytvorit a odeslat vzorek. Následně se zobrazí formulář pro Export vzorku databáze. Zde vyberte, která data chcete odeslat ve vzorku a potvrďte tlačítkem [image]. Potvrzením odešlete dotaz se vzorkem na Helpdesk.

Helpdesk odeslat vzorek databaze

· Dotazník spokojenosti - odkaz provede přihlášení na helpdesk, kde můžete vyplnit zobrazený dotazník.

· Nastavení osobních údajů - stiskem odkazu se přihlásíte na helpdesk a načte se formulář pro nastavení osobních údajů.

Zavřít - uzavřete formulář.


Co je v programu nového?

Navigation: Nápověda >

Co je v programu nového?

 Return to chapter overview

Volba je přístupná v případě, že existuje soubor obsahující informace o nových vlastnostech a funkcích programu. Zvolením této volby zobrazíte text souboru pomocí programu Poznámkový blok nebo WordPad.


Zprávy z RSS kanálu

Navigation: Nápověda >

Zprávy z RSS kanálu

 Return to chapter overview

Volba je přístupná v případě, že uživatel má právo na odebírání zpráv z RSS kanálu. Tuto volbu lze uživateli/skupině vypnout/zapnout nastavením práva "Neodebírat zprávy z RSS kanálu" v menu Systém -> Správa databáze -> Nastavení zabezpečení -> Zabezpečení systémem uživatelů a práv -> Uživatelé/Skupiny -> záložka Základní údaje -> sekce Práva uživatele/Práva skupiny.

Touto volbou otevřete seznam zpráv:

Zpravy z RSS kanalu >

Tlac._Oznacit jako prectene

Označit vše jako přečtené - označí všechny zprávy jako přečtené. To znamená, že u zpráv nebude zobrazen červený popis NOVÁ!

Pokud dojde nová zpráva z RSS kanálu, potom po spuštění aplikace se zobrazí v pravém dolním rohu informační okno:

Nova zprava z RSS kanalu


O aplikaci

Navigation: Nápověda >

O aplikaci

 Return to chapter overview

Zobrazí formulář Informace o aplikaci s informacemi o verzi programu, jeho konfiguraci, vlastníkovi licence a adresy výrobce programu a vašeho prodejce.


Postupy

Navigation: »No topics above this level«

Postupy

 Return to chapter overview

V postupech se vám budeme snažit co nejjednodušším způsobem přiblížit nastavení základních funkcí docházkového systému.

Postupy:

Instalace Docházky na MSDE

Instalace docházky na Interbase

Postup při práci s docházkovým terminálem

Mobilní jednotky ONI

Způsob nastavení čtečky ID médií RD3 a RD3B

Postup práce s ID médii od dodání po používání v systému

Načítání ID médií z terminálu do software

Načítání ID médií ze souboru do software

Nastavení popisu tlačítek terminálu

Import zaměstnanců

Nastavení přístupových práv

Instalace nové verze programu

Zadávání aktivací

Nastavení exportu


Instalace Docházky na MSDE

Navigation: Postupy >

Instalace Docházky na MSDE

 Return to chapter overview

Instalace MSDE

Z instalačního CD z adresáře \servis\msde spusťte setup.exe. Po instalaci proveďte restart počítače.

Vytvoření prázdné databáze

Pomocí utility osql ("C:\Program Files\Microsoft SQL Server\80\Tools\Binn\osql.exe") proveďte vytvoření prázdné databáze:

1. C:\Program Files\Microsoft SQL Server\80\Tools\Binn\OSQL.EXE" -S nazev_serveru -U sa.

2. následuje dotaz na heslo - potvrďte ENTER.

3. zapište: create database nazev_database (například ads_ron) - potvrďte ENTER.

4. potvrďte stiskem CTRL Z - potvrďte ENTER.

5. následuje informace o vytvoření databáze.

6. zavřete okno s command shell.

Instalace a připojení k databázi programem DOCHÁZKA

1. Nainstalujte program docházka dle standardního postupu a proveďte aktivaci programu s modulem SQL.

2. Ukončete program a spusťte ads.exe s parametrem -ncd - "ADS.EXE - ncd".

3. V programu vyberte menu systém\správa databáze\nastavení parametrů databáze a vyberte sestavit.

4. V záložce "Zprostředkovatel" vyberte "Microsoft OLE DB Provider for SQL Server".

5. V záložce "Připojení" nastavte následující hodnoty:

Ad 1 - název nebo IP adresu SQL serveru.

Ad 2 - zapište uživatelské jméno - "sa" - systém administrator.

Ad 3 - zapište nebo vyberte název databáze.

Ad 4 - proveďte test spojení, po úspěšném testu potvrďte OK.


Instalace Docházky na Interbase

Navigation: Postupy >

Instalace Docházky na Interbase

 Return to chapter overview
1. Nakopírujte do adresáře s Windows\system32 následující soubory:

_IBProvider.dll,

_IBProvider_register.bat,

_IBProvider_v2.dll,

cc3250mt.dll

2. Spusťte _IBProvider_register.bat

3. V programu DOCHÁZKA nastavíte připojení k databázi - menu systém\správa databáze\nastavení parametrů databáze - viz obrázky

4. V Záložce Vše - změňte následující parametry:

- Bicursor = True

- Dialect = 3

- Free_threading = False


Postup při práci s docházkovým terminálem

Navigation: Postupy >

Postup při práci s docházkovým terminálem

 Return to chapter overview

Pokyny pro používání identifikačních karet (čipů) docházkového systému

Postup identifikace na docházkovém terminálu – registrace události

1. Stiskněte příslušnou klávesu výběrem z níže uvedených operací - na displeji se zobrazí příslušná vybraná operace.

2. Přiložte bezkontaktní kartu (čip) k docházkovému terminálu – při úspěšné registraci se na displeji zobrazí jméno zaměstnance a zazní zvukový signál.

3. Kartu přikládejte ke spodní části terminálu.

Postup při zobrazení informace o saldu odpracovaných hodin:

Stiskněte klávesu „saldo“ a přiložte kartu (čip). Na displeji se objeví saldo odpracovaných hodin ( + nebo – do fondu odpracované doby).

Při zadání chybné operace postupujte následujícím způsobem:

Například zadáte operaci příchod místo odchod a zaregistrujete událost kartou (čipem). Tuto chybu eliminujete znovu vybráním správné operace a opětovným přiložením karty (čipu) k terminálu.

Pokud zvolíte chybnou operaci a kartu jste nepřiložili, můžete opětovným stiskem vybrat správnou operaci a poté provést registraci kartou (čipem).

Příklady typů průchodů a přerušení pracovní doby:

· Příchod (začátek pracovní doby) – při příchodu do zaměstnání stiskněte klávesu Příchod a následně přiložte kartu (čip) k terminálu – zobrazí se zvolená operace a jméno zaměstnance.

· Přestávka (oběd) – při odchodu na oběd stiskněte klávesu Přestávka a následně přiložte kartu (čip) k terminálu. Po příchodu z přestávky stiskněte klávesu Příchod (stejný příchod jako do zaměstnání) a opět přiložte kartu (čip) k terminálu.

· Odchod – při odchodu ze zaměstnání stiskněte klávesu Odchod a následně přiložte kartu (čip) k terminálu.

· Služebně, Školení, Lékař, Soukromě, Dovolená, Nemoc – při přerušení pracovní doby z těchto uvedených důvodů postupujte následujícím způsobem – vyberte si z uvedené nabídky potřebnou operaci a stiskněte příslušnou klávesu a přiložte kartu (čip). Při příchodu zpět do zaměstnání stiskněte klávesu Příchod. Pokud se již ten den nevrátíte do zaměstnání, následující den si zvolte klávesu Příchod a postupujte podle bodu 1.


Mobilní jednotky ONI

Navigation: Postupy >

Mobilní jednotky ONI

 Return to chapter overview

Mobilní terminály ONI systému umožňují kromě identifikace řidiče ve vozidlech také evidenci docházky. Evidenci docházky můžete vést ve vozidlech (osobních i nákladních), mobilních objektech a mimo stabilní pracovní místa (dočasná staveniště, přechodná pracoviště).

Systém obsahuje:

· jednotku ONI systému,

· komunikační terminál nebo GPS navigaci s možností určení kódu volby události (přestávka, jízda, příchod, ukončení ...),

· čtecí zařízení umožňující identifikaci uživatelů pomocí identifikačních médií (čipy Dallas, bezkontaktní čipy RFID).


Princip ovládání

Navigation: Postupy > Mobilní jednotky ONI >

Princip ovládání

 Return to chapter overview

Obsluha

Obsluha ONI Docházka je stejná jako obvykle používaný způsob identifikace v docházkovém systému. Zaměstnanec zvolí na komunikačním terminálu číselný kód operace (jízda, práce u zákazníka, přestávka, ukončení …) a následně přiloží identifikační čip ke čtecímu zařízení. Systém údaje o typu události a identifikátor čipu zpracuje a odešle je do zabezpečeného technologického centra, kde jsou uloženy do databáze. Z databáze technologického centra jsou události dostupné přes webové služby pro načtení do docházkového systému.

Přenos zpráv do docházkového systému

Po přiložení Dallas čipu, případně RFID čipu v režimu docházkový systém, je jednotkou vygenerována zpráva, která je bezodkladně odeslána do technologického centra ONI systému. Zabezpečené technologické centrum ONI systému provádí zpracování dat z jednotek ONI systému a zajišťuje šifrovaný export dat pro docházkový systém.

Zpráva obsahuje tyto údaje:

· čas identifikace,

· číselný kód události zadaný na klávesnici nebo navigaci,

· identifikační kód čipu,

· GPS souřadnice místa identifikace,

· název místa identifikace.

Chování ONI systému při vícenásobném přiložení čipu

Pokud dojde bezprostředně za sebou k opakované identifikaci uživatele přiložením stejného čipu bez změny čísla operace, je druhé a další přiložení čipu ignorováno. Do technologického centra ONI systému je odeslána zpráva pouze o prvním přiložení čipu.

PŘÍKLAD: Volba čísla operace X,

- první přiložení čipu A - zpráva je odeslána,

- druhé přiložení čipu A - přiložení čipu je ignorováno,

- N-té přiložení čipu A - přiložení čipu je ignorováno.

Pokud mezi přiložením stejného čipu dojde k identifikaci jiným čipem nebo ke změně čísla operace, je opakované přiložení prvního čipu systémem vyhodnoceno a zpráva o události je odeslána do technologického centra ONI systému.

PŘÍKLAD: Volba čísla operace X,

- první přiložení čipu A - zpráva je odeslána,

- první přiložení čipu B - zpráva je odeslána,

- druhé přiložení čipu A - práva je odeslána,

- třetí přiložení čipu A - přiložení čipu je ignorováno,

Volba čísla operace Y,

- čtvrté přiložení čipu A - zpráva je odeslána.


Režimy ONI systému

Navigation: Postupy > Mobilní jednotky ONI >

Režimy ONI systému

 Return to chapter overview

Jednotka ONI systému je vybavena prostředky pro snímání kódů identifikačních médií jako jsou kontaktní Dallas čipy nebo bezkontaktní RFID čipy. Identifikační čipy se používají v jednotkách ONI systému jak pro identifikaci řidiče (přiřazení řidiče ke konkrétní jízdě), tak rovněž pro sledování docházky.

Přiložení identifikačního čipu ke čtečce je doprovázeno zvukovým signálem. Přihlášení řidiče je potvrzeno odlišným tónem zvukové signalizace než identifikace osoby pro docházkový systém.

Z pohledu jednotky ONI systému je potřeba rozlišit, zda jedinečný identifikátor čipu bude použit pro účely identifikace řidiče anebo pro docházkový systém.

ONI jednotka rozlišuje dva stavy z hlediska zpracování identifikačních čipů:

1) Identifikace osoby pro docházkový systém - jednotka se přepne do režimu docházkový systém a v tomto režimu jsou všechny přijaté kódy považovány za kódy pro docházkový systém.

2) Identifikace řidiče - jednotka má definovány vyhrazené kódy pro identifikaci řidiče a všechny ostatní kódy jsou považovány za kódy určené pro zpracování docházkovým systémem.

Postup přepnutí prostřednictvím klávesnice

Přepnutí z Identifikace řidiče -> Identifikace osoby pro docházkový systém

Do režimu pro docházkový systém se přepnete pomocí znaku . (tečka), za kterým následuje číslo operace. Potvrzení kódu se provádí klávesou ENTER na klávesnici a je doprovázeno zvukovým signálem.

Přepnutí z Identifikace osoby pro docházkový systém -> Identifikace řidiče

Přepnutí zpět se provede klávesou BS nebo postupným stisknutím kláves . (tečka) a ENTER. Návrat do režimu identifikace řidiče je potvrzen zvukovým signálem.

Postup přepnutí prostřednictvím navigace

Přepnutí z Identifikace řidiče -> Identifikace osoby pro docházkový systém

Přepnutí do režimu docházkového systému se provede odesláním textové zprávy, která začíná znakem . (tečka) a za ním následuje číslo operace.

Přepnutí z Identifikace osoby pro docházkový systém -> Identifikace řidiče

Přepnutí zpět se provede odesláním textové zprávy se samostatným znakem . (tečka). K přechodu do režimu identifikace řidiče dojde automaticky také po odpojení navigace od jednotky.


Postup práce v docházkovém režimu

Navigation: Postupy > Mobilní jednotky ONI >

Postup práce v docházkovém režimu

 Return to chapter overview

Obecně lze operace docházky do jednotek ONI vkládat buď prostřednictvím speciálně dodávané klávesnice, nebo prostřednictvím GPS navigace.

ONI jednotky jsou v naší docházce nadefinované jako terminály včetně příslušného nastavení (čísla terminálů odpovídají číslům příslušných ONI jednotek). Operace z těchto jednotek se pak zapisují přímo do původní docházky.

V docházce se budou evidovat tyto operace:

· Jízda kód v terminálu: 1

· Přestávka kód v terminálu: 2

· Práce u zákazníka kód v terminálu: 3

· Ukončení kód v terminálu: 4

Postup zadávání operace prostřednictvím klávesnice

V klidovém stavu je u klávesnice vypnutý displej (kvůli šetření akumulátoru vozu). Pokud chcete zadávat číslo nebo jinak s klávesnicí pracovat, zapnete ji stiskem tlačítka + (plus). Obdobně přidržením klávesy - na cca 1 sekundu se klávesnice vypne. Operace docházky se obecně do ONI jednotky zapisují prostřednictvím zadání znaku . (tečka) a za ním následuje číslo operace.

Po zapnutí displeje u klávesnice, proveďte následující:

1. na klávesnici zapište kód, který se skládá ze znaku . (tečka) a čísla operace 1 (například .1),

2. zadaný kód odešlete stiskem tlačítka ENTER,

3. ONI jednotka, po úspěšném odeslání kódu, potvrdí přepnutí do režimu docházky zvukovým signálem,

4. následně identifikujte potřebný počet uživatelů přiložením identifikačního čipu - každé přiložení čipu je potvrzeno zvukovým signálem,

5. operace s identifikací osoby je odeslána na server.

Postup zadávání operace prostřednictvím gps navigace

Operace docházky se obecně do ONI jednotky zapisují prostřednictvím zadání znaku . (tečka) a za ní následuje číslo operace. Textovou zprávu je možno zadat na virtuální klávesnici, nebo zvolit z rychlých zpráv.

Zadání kódu volby události přímou volbou

Po zapnutí navigace (po připojení navigace by mělo dojít také automaticky k jejímu zapnutí), proveďte následující:

1. v menu zvolte volbu Vyřídit -> Zprávy -> Vytvořit zprávu,

2. na virtuální klávesnici vložte kód, který se skládá ze znaku . (tečka) a čísla operace 1 (například .1),

3. zadaný kód odešlete stiskem tlačítka Hotovo,

4. na displeji se poté zobrazí text: Chcete odeslat zprávu? ".1", který potvrďte tlačítkem Ano.

5. ONI jednotka, po úspěšném odeslání textu, potvrdí přepnutí do režimu docházky zvukovým signálem,

6. následně identifikujte potřebný počet uživatelů přiložením identifikačního čipu - každé přiložení čipu je potvrzeno zvukovým signálem,

7. operace s identifikací osoby je odeslána na server.

Zadání kódu volby události z menu rychlých zpráv

Podstatně jednodušší způsob zadávání operací prostřednictvím navigace je využitím předdefinovaných - tzv. rychlých zpráv. Po zapnutí navigace (po připojení navigace by mělo dojít také automaticky k jejímu zapnutí), proveďte následující:

1. v menu zvolte volbu Vyřídit -> Zprávy -> Rychlá zpráva,

2. v zobrazeném seznamu zvolte typ události:

.

.1 - Prichod

.2 - Prestavka

.3 - Odchod

.4 - Ukonceni

3. na displeji se poté zobrazí text: Chcete odeslat zprávu? ".1 - Prichod", který potvrďte tlačítkem Ano,

4. ONI jednotka, po úspěšném odeslání textu, potvrdí přepnutí do režimu docházky zvukovým signálem,

5. následně identifikujte potřebný počet uživatelů přiložením identifikačního čipu - každé přiložení čipu je potvrzeno zvukovým signálem,

6. operace s identifikací osoby je odeslána na server.


Způsob nastavení čtečky ID médií RD3 a RD3B

Navigation: Postupy >

Způsob nastavení čtečky ID médií RD3 a RD3B

 Return to chapter overview

Čtečku karet nastavíte v menu Terminály/Terminály. V seznamu terminálů stiskněte tlačítko [image] Nový záznam. Otevře se Formulář terminálu. V záložce Terminál vyplníte následující položky:

· Kód - povinný údaj. Vepište název kódu, např.: CK1 (čtečka karet 1).

· Popis - povinný údaj. Popište, o jaký terminál se jedná. Popis slouží pro vaši potřebu rychlé orientace mezi terminály, např.: Čtečka karet 1.

· Určení terminálu - z nabídky zvolte jednu z nabízených možností, např.: Průchodový.

Po provedeném nastavení uložte údaje tlačítkem [image] a přejdete na záložku Parametry, ve které vyplníte následující položky:

· Název počítače - pokud používáte systém v síti, nastavte název počítače, ke kterému je terminál fyzicky připojen. Pokud necháte tuto položku volnou, budou se všechny stanice připojené k databázi pokoušet o komunikaci s terminálem.

· Driver - dle zakoupeného typu hardware je potřeba přiřadit k terminálu driver pro jeho komunikaci se software. Pro čtečku karet zvolte z nabídky ACSLine.

· Typ terminálu - z nabídky zvolte RD2/RD3.

· Typ komunikace - z nabídky vyberte RS232.

· Com Port - sériový port, na kterém probíhá komunikace. Sériový port, který máte vybrat, zjistíte následovně:

- na ploše počítače klikněte na ikonu Tento počítač pravým tlačítkem myší,

- v zobrazené nabídce vyberte Vlastnosti,

- v otevřeném formuláři Vlastnosti systému zvolte záložku Hardware a stiskněte tlačítko Správce zařízení,

- v zobrazeném okně Správce zařízení rozbalte tlačítkem [image] položku Porty (COM a LPT),

- u položky CP210x USB to UART Bridge Controller (COM4) je v závorce uveden sériový port, který vyberete v položce Com Port.

Po provedeném nastavení uložíte údaje tlačítkem [image].

Přes tlačítko [image] Test spojení zjistíte, zda je čtečka karet správně nastavena. Pokud se po stisku tlačítka a následném přiložení karty ke čtečce zobrazí okno Testu komunikace s číslem karty, potom je zařízení nastaveno správně.

TIP: Po nastavení čtecího zařízení máte možnost načítat nová ID média do programu, vyhledávat podle ID médií čísla ID médií, osoby apod. Nejprve je potřeba vybrat terminál pro čtení ID médií v programu. Terminál vyberete v menu Systém/Nastavení aplikace/Lokální nastavení/Načítání ID média. Poté můžete v seznamech, kde je zobrazeno tlačítko [image] Vyhledat podle načtené karty, vyhledávat potřebné údaje pomocí ID médií.


Postup práce s ID médii od dodání po používání v systému

Navigation: Postupy >

Postup práce s ID médii od dodání po používání v systému

 Return to chapter overview

Postup načtení ID médii

Postup načtení ID médii v případě objednávky od společnosti RON Software naleznete v kapitole Načítání ID médií ze souboru do software. Pokud jste textový soubor obsahující seznam karet neobdrželi, máte možnost karty načíst z terminálu do software.

Přiřazení karty zaměstnanci

1. Otevřete menu Seznamy/Zaměstnanci.

2. Dvojklikem na řádku vybraného zaměstnance otevřete Formulář zaměstnance.

3. Přejděte na záložku ID médium.

3a. Pokud má zaměstnance přidělené ID médium a toto ID je nefunkční. Otevřete dvojklikem v pravém sloupci ID médium a zapište datum vrácení, poté postupujte bodem 3b.

3b. V seznamu dostupných ID médií (levý sloupec), označte ID médium a pomocí šipky doprava jej přidělte zaměstnanci.

Generování ID médií do terminálu

Následně je potřeba provést generování nastavení terminálů, aby terminály dostaly informace o nových ID médiích a přiřazení k osobám. Tento krok provedete v menu Terminály/generování nastavení terminálů. V otevřeném formuláři zaškrtněte všechny terminály a potvrďte.

Tento krok je potřeba provést vždy při změně ID médií.


Nacitani ID medii z terminalu

Navigation: Postupy >

Načítání ID médií z terminálu do software

 Return to chapter overview

Postup při načítání ID médií z terminálů je popsáno v následujících kapitolách pro terminály RT310, RT300B a DT1000 a pro čtečku ID médií RD3 a RD3B.


Import ID médií z terminálu

Navigation: Postupy > Načítání ID médií z terminálu do software >

Import ID médií z terminálu

 Return to chapter overview

Formulář slouží k načtení nových ID médií z terminálu. Pro otevření formuláře je nutné nejprve otevřít seznam Identifikačních médií. Následně v menu Aktuální okno vyberte Import ID médií z terminálu. Jak provést načtení nových ID médií z terminálu se dozvíte v následující kapitole.

Import ID medii z terminalu

· Terminál - povinný údaj. Nastavte terminál, ze kterého budete načítat ID média.

· Označení média číslovat od - povinný údaj. Vepište počáteční (pořadové) číslo, od které chcete číslovat ID média. Pokud máte poslední číslo např. 10, začněte číslovat od 11.

· Datum pořízení - povinný údaj. Zadejte datum pořízení ID média.

Načíst - stiskem tlačítka načtete všechny ID média z terminálu. ID média se načtou do seznamu Identifikačních médií, kde můžete provést potřebné úpravy.

Načítat postupně - karta je po nasnímání do terminálu ihned načtena do programu. ID média se načtou do seznamu Identifikačních médií, kde můžete provést potřebné úpravy. Po načtení karet do programu stiskněte tlačítko [image].

Storno - stiskem tlačítka uzavřete formulář načítání ID médií z terminálu.


Terminaly RT310, RT300B

Navigation: Postupy > Načítání ID médií z terminálu do software >

Terminály RT310, RT300B

 Return to chapter overview

Pro usnadnění zápisu ID médií do programu je možno použít následující postup:

A) Zobrazení čísla ID média na displeji terminálu a zápis do programu:

1. na terminálu stiskněte modré tlačítko i

2. na displeji se zobrazí číslo, které si opište

3. v programu v seznamu Identifikačních médií – stiskněte F4 pro vytvoření nového záznamu

4. do položky Kód ID média zapište opsané číslo

5. do položky Označení média libovolné číslo, podle kterého budete moci vyhledat konkrétní ID médium

6. do položky Datum pořízení zapište datum, kdy jste ID médium pořídili

7. potvrďte tlačítkem

8. nyní máte ID médium zapsáno v programu

B) Přímé načítání ID médií z terminálu do software (rychlejší pro více kusů)

1. v programu si zobrazte seznam ID médií - Identifikační média

2. v menu Aktuální okno/Import ID médií z terminálu otevřete formulář pro načítání ID médií

3. ve formuláři zvolte Terminál, ze kterého budete načítat ID média

4. do pole Označení média číslovat od, nastavte počáteční (pořadové) číslo pro označení média

5. do pole Datum pořízení vyplňte datum pořízení

6. ve formuláři stiskněte tlačítko [image] pro načítání ID médií postupně do programu

7. označte si pořadovým číslem ID média, která chcete do programu načíst

8. na terminálu stiskněte modré tlačítko i - terminál přejde do režimu načtení nového ID média

9. přiložte ID médium k terminálu v označeném pořadí - na displeji je po načtení zobrazeno číslo ID média

10. na terminálu stiskněte 2x po sobě modré tlačítko i - terminál se vrátí do základního režimu a následně přejde do režimu načtení nového ID média

11. body 9 a 10 opakujte do doby, než načtete všechna požadovaná ID média do programu

12. po načtení ID médií do programu stiskněte tlačítko [image] pro ukončení načítání ID médií

13. stiskem tlačítka [image] opustíte formulář pro načítání ID médií

14. pokud vše proběhne v pořádku, tak ID média budou načtena v seznamu Identifikačních médií

Doporučujeme vyzkoušet postup na několika kusech ID médií a následně pro zbytek.


Terminál DT1000

Navigation: Postupy > Načítání ID médií z terminálu do software >

Terminál DT1000

 Return to chapter overview

Pro usnadnění zápisu ID médií do programu je možno použít následující postup:

Přímé načítání ID médií z terminálu do software (rychlejší pro více kusů)

1. označte si pořadovým číslem ID média, která chcete do programu načíst

2. na terminálu stiskněte tlačítka J 2 4 6 - terminál přejde do režimu čtení nových ID médií

3. přikládejte jednotlivá ID média k terminálu v označeném pořadí - na displeji je po načtení zobrazeno číslo ID média

4. v programu si zobrazte seznam ID médií - Identifikační média

5. v menu Aktuální okno/Import ID médií z terminálu otevřete formulář pro načítání ID médií

6. ve formuláři zvolte Terminál, ze kterého budete načítat ID média

7. do pole Označení média číslovat od, nastavte počáteční (pořadové) číslo pro označení média

8. do pole Datum pořízení vyplňte datum pořízení

9. načtěte ID média tlačítkem

10. pokud vše proběhne v pořádku, tak ID média budou načteny v seznamu Identifikačních médií

11. režim čtení ID médií na terminálu přerušíte stiskem libovolného tlačítka a terminál se vrátí do základního režimu

Doporučujeme vyzkoušet postup na několika kusech ID médií a následně pro zbytek.


Čtečka ID médií RD3 a RD3B

Navigation: Postupy > Načítání ID médií z terminálu do software >

Čtečka ID médií RD3 a RD3B

 Return to chapter overview

Pro usnadnění zápisu ID médií do programu je možno použít následující postup:

Přímé načítání ID médií ze čtečky ID médií do software

1. označte si pořadovým číslem ID média, která chcete do programu načíst

2. v programu si zobrazte seznam ID médií - Identifikační média

3. v menu Aktuální okno/Import ID médií z terminálu otevřete formulář pro načítání ID médií

4. ve formuláři zvolte Terminál, ze kterého budete načítat ID média

5. do pole Označení média číslovat od, nastavte počáteční (pořadové) číslo pro označení média

6. do pole Datum pořízení vyplňte datum pořízení

7. ve formuláři stiskněte tlačítko [image] pro načítání ID médií postupně do programu

8. přikládejte postupně ID média ke čtečce ID médií v označeném pořadí

9. po načtení ID médií do programu stiskněte tlačítko [image] pro ukončení načítání ID médií

10. stiskem tlačítka [image] opustíte formulář pro načítání ID médií

11. pokud vše proběhne v pořádku, tak ID média budou načteny v seznamu Identifikačních médií

Doporučujeme vyzkoušet postup na několika kusech ID médií a následně pro zbytek.


Načítání ID médií ze souboru do software

Navigation: Postupy >

Načítání ID médií ze souboru do software

 Return to chapter overview

Pro usnadnění zápisu ID médií do programu je možno použít načtení dat z textového souboru.

Postup načtení:

1. Otevřete seznam ID médií - Identifikační média.

2. V menu vyberte položku „Aktuální okno/Import ID médií ze souboru".

3. Vyberte textový soubor obsahující seznam karet.

POZOR: Seznam karet obsahuje položku označení. Pokud již v seznamu karet existuje karta se stejným označením, nebude nová karta do systému importována. Pokud chcete karty importovat s jiným označením, upravte obsah textového souboru dříve, než budete import provádět.

Struktura textového souboru:

Kod1;Kod2;Oznaceni_media;Datum_porizeni;Datum_vyrazeni;Blokovana;Zpusob_vyrazeni;Zaloha_na_medium

PŘÍKLAD:

0AF8017700000000;0AF8017700000000;259;20090817;20100930;1;0;100

Pokud některou položku v textovém souboru nemáte (například Kod2, Datum_vyrazeni, Blokovana, Zpusob_vyrazeni, Zaloha_na_medium), potom struktura textového souboru bude vypadat následovně:

Kod1;;Oznaceni_media;Datum_porizeni;;;;

PŘÍKLAD:

0AF8017700000000;;259;20100921;;;;


Nastavení popisu tlačítek terminálu

Navigation: Postupy >

Nastavení popisu tlačítek terminálu

 Return to chapter overview

Pokud potřebujete vytvořit popisy tlačítek terminálu, postupujte následovně:

· otevřete si program (Docházka, Jídelna),

· zobrazte seznam terminálů v menu Terminály -> Terminály,

· stiskněte ikonu [image] tiskárny v nástrojové liště,

· v zobrazeném formuláři Tiskové sestavy označíte požadovanou sestavu pro tisk šablon na klávesnici terminálu,

· stisknete tlačítko [image] Náhled,

· podle zvolené sestavy se vám zobrazí formulář Editace tlačítek terminálu s požadovaným rozmístěním tlačítek,

Terminaly_Editor tlacitek terminalu

Doporučený postup nastavení popisu tlačítek terminálu:

o v režimu editace zvolte Editovat text tlačítka,

o kliknutím na tlačítko nastavte vybraným tlačítkům text,

o u ostatních tlačítek text smažte,

o zvolte styl písma stiskem požadovaného tlačítka (VELKÁ PÍSMENA, malá písmena, První velké),

o v režimu editace zvolte Editovat písmo a barvu tlačítka,

o nastavte tlačítkům barvy, případně písmo (písmo a barvu lze nastavit všem tlačítkům najednou nebo nastavit všem písmo a zachovat nastavené barvy volbou níže),

· po nastavení tlačítek terminálu potvrďte formulář tlačítkem [image],

· po potvrzení se zobrazí sestava pro tisk popisu tlačítek terminálu,

· stiskem tlačítka [image] Tisknout, vytiskněte sestavu,

· vytištěné popisy tlačítek terminálu zasuňte pod kryt tlačítek terminálu.


Import zaměstnanců

Navigation: Postupy >

Import zaměstnanců

 Return to chapter overview

Umožňuje načtení seznamu osob z textového souboru. Tento import je také možno využít pro aktualizaci (např. pravidelné přebírání dat z jiných systémů, …).

Postup importu:

1. Vytvořte textový soubor podle uvedené struktury.

Pro import zaměstnanců do docházkového systému je nutné vytvořit textový soubor v následujícím tvaru:

Rodné číslo; Příjmení; Jméno; Titul před; Titul za; Rodné jméno; Datum narození; Zaměstnanec 1; Osobní číslo; Datum nástupu; Datum výstupu; Typ pracovního poměru; Kalendář; Středisko; Popis střediska; Personální; Popis personální; Platnost kalendáře od; Typ mzdy; Kód karty; Označení karty; Datum přidělení karty

Položky označeny tučně jsou v textovém souboru povinné, všechny ostatní položky jsou volné.

PŘÍKLAD:

8760085624;Benčíková;Marie;Bc.;;Horká;08.10.1987;;357;06.06.2006;;;;;;;;;;;;;

2. V menu "Systém/Nastavení aplikace/Společné nastavení/Import pracovních poměrů", nastavte potřebné údaje importu.

3. V menu "Systém/Import-Export/Import dat z mezd" spusťte import dat.


Nastavení přístupových práv

Navigation: Postupy >

Postup nastavení přístupových práv pro skupinu uživatelů

 Return to chapter overview

Cíl nastavení:

Firma je rozdělena na střediska THP a VÝROBA. Vedoucí střediska TPH je pan Karas a vedoucí oddělení VÝROBA je pan Novák. Každý vedoucí střediska má práva editovat docházku pouze svým přímým podřízeným. Ekonom firmy pan Janáček může editovat docházku všem zaměstnancům firmy

Postup nastavení:

1. rozdělte zaměstnance do přístupových skupin - menu SYSTÉM/SPRÁVA DATABÁZE/PŘÍSTUPOVÉ SKUPINY (pokud je již máte rozdělené ve skupinách osob (MENU/SEZNAMY/SKUPINY OSOB) – můžete použít synchronizaci přístupových skupin se skupinami osob)

2. nastavte typ zabezpečení na - Zabezpečení systémem uživatelů a práv

3. vytvořte skupinu uživatelů MISTŘI a nastavte jim práva na menu, databázi, sestavy dle Vaší potřeby. Standardně nastavujeme v první záložce následující:

V záložce „práva na menu" nastavte práva, abyste mistrům zamezil vstup do částí programu, kde se provádí nastavení programu, komunikace s terminály. Menu „Seznamy" a „Terminály" nemusí mít žádná práva.

V záložce "práva na databázi" můžete povolit práva na všechny datové tabulky. Případně je možno nastavit omezená práva na tabulku období – mistři nebudou moci vytvářet ani uzavírat období v docházce a znepřístupnit je ostatním uživatelům.

V nastavení práv na "manažer sestav" můžete povolit nebo zamezit tisk jednotlivých výstupních sestav a exportů data.

4. Pokud máte nastavena Práva pro skupinu uživatelů, stiskněte tlačítko zavřít v základních údajích skupiny uživatelů a pokračujte vytvářením jednotlivých uživatelů (tlačítko uživatelé).

Vytvoříte nového uživatele a přiřazením do skupiny mu nastavíte všechny práva skupiny, do které patří. Pro omezení práv na skupinu zaměstnanců patřící do skupiny THP se přepněte do záložky „práva na databázi" nalistujte položku přístupová skupina osob, v pravé části „práva na sloupce" vyberte kód a ve spodní části „Omezení hodnoty sloupce" nastavte požadovanou přístupovou skupinu osob. Pokud je skupin více oddělte je středníkem (uživatel Karas bude mít nastavenu THP, uživatel Novák nastaveno VÝROBA a uživatel Jelínek – THP;VÝROBA nebo žádné omezení).

5. Pokud chcete nastavit práva uživateli pouze na sebe samého, vyberte v záložce „práva na databázi" nalistujte položku osoba, v pravé části „práva na sloupce" vyberte příjmení (rodné číslo) a ve spodní části „Omezení hodnoty sloupce" nastavte požadované příjmení (rodné číslo).

6. Je možné také nastavit, aby zaměstnanec mohl pouze prohlížet svou docházku a nemohl ji editovat. Nastavení se provádí podobným způsobem. Doporučujeme vytvořit skupinu uživatelů „Osoba". Této skupině omezíte základní práva, viz obrázek.

Nastavíte práva na menu (dle Vašeho uvážení) a v právech na databázi omezte práva na čtení pouze u následujících tabulek: Denní výsledek výpočtu, Docházka, Měsíční výsledek výpočtu, Mzdová položka ve mzdě (možno zakázat úplně), Období a období s určenou délkou (povolte také editaci – zaměstnanec může přepínat období), Schválení docházky, Výsledek výpočtu za období.


Instalace nové verze programu

Navigation: Postupy >

Instalace nové verze programu

 Return to chapter overview

Informaci o zveřejnění nové verze byste měli dostávat do e-mailu a zároveň se dozvíte, jestli je pro vás aktualizace zajímavá, nebo případně nutná. Aktualizace aplikací jsou vždy k dispozici na našem centru podpory zákazníků „helpdesk.ron.cz“.

Při instalaci nové verze programu postupujte následovně:

1. Je zapotřebí, aby si všichni uživatelé vypnuli program (případně všechny programy, pracující na společné databázi). Seznam připojených uživatelů naleznete v menu Systém -> Seznam aktuálně přihlášených uživatelů.

2. V adresáři s nainstalovaným programem vytvořte nový textový soubor maintenance.txt (pravé tlačítko myši -> v zobrazeném menu Nový -> vybrat Textový dokument -> přejmenovat na maintenance.txt). Do textového souboru maintenance.txt uveďte název počítače (serveru), ze kterého budete poprvé spouštět novou verzi programu, a uložte. Vytvořením toho souboru zabráníte spuštění programu z jiného počítače, než který je v tomto textovém souboru zapsán. Textový soubor je potřeba nakopírovat do adresářů ke všem nainstalovaným programům RON.

3. Vypněte na serveru služby související s aplikacemi RON -> ADS_Service, APS_Service, JIDELNA_Service, apod.

4. Zálohujte stávající databázi. Zálohu databáze provedete v menu Systém -> Správa databáze -> Zálohování databáze. Pokud máte více programů RON a programy jsou napojeny na jednu databázi, stačí provést zálohu jen v jedné aplikaci. Zálohu lze provést pouze na lokální disk počítače, na kterém se databáze nachází.

5. Z centra podpory zákazníků helpdesk.ron.cz -> sekce Ke stažení -> stáhněte a uložte do počítače nové verze programů.

6. Postupně spusťte stažené instalační programy a proveďte instalace nových verzí. Instalujte přímo do složky, ve které máte stávající verzi programu. Nová verze ji přepíše. Nezáleží na pořadí, v jakém budou aplikace instalovány.

7. Spusťte nainstalovaný program.

8. Po instalaci budete vyzváni k potvrzení restrukturalizace databáze, klikněte na tlačítko ANO.

9. V případě, že provádíte instalaci více nových verzí, po restrukturalizaci program vypněte a spusťte další nainstalovaný program. Opakujte proces s restrukturalizací.

10. Po úspěšném ukončení restrukturalizace databáze spusťte na serveru zastavené služby související s aplikacemi RON - ADS_Service, APS_Service, JIDELNA_Service, apod.

11. Odstraňte textový soubor maintenance.txt nakopírovaný do adresářů u nainstalovaných programů RON.

Body 2 a 11 - jsou nutné pouze v případě, že program používá více uživatelů v síti a nejste schopni zajistit, aby se před dokončením instalace a restrukturalizace databáze k této databázi někdo nepřipojil.

Body 3 a 10 - jsou nutné v případě, pokud jsou služby nainstalovány na serveru (nebo PC).


Zadávání aktivací

Navigation: Postupy >

Zadávání aktivací

 Return to chapter overview

Registrační karta

Registrační karta je dokument, který jste obdrželi ve formátu PDF přílohou v e-mailu, či jinou formou. Tento dokument obsahuje několik důležitých údajů. V první řadě údaje pro správnou aktivaci programu. Dále pak uživatelské jméno a heslo pro přihlášení na helpdesk společnosti RON. Registrační karta může mít omezenou platnost (Datum dočasnosti na registrační kartě), v případě, že dochází k zápůjčce programu nebo aktivaci programu pro období mezi objednávkou a zaplacením všech faktur.

Aktivace

Aktivace je uvedení programu do funkčního stavu dle vámi zakoupené licence. Pomocí aktivace se nejen program aktivuje na plnou verzi, ale zároveň budou zpřístupněny případné moduly, které lze k programu libovolně dokoupit.

Aktivaci je potřeba provést v následujících případech:

1. Při prvním spuštění aplikace - první Aktivační kód vám poskytne (technik/konzultant) při instalaci programu. Tento kód je pouze dočasný. Další aktivační kód dostanete po zaplacení faktury.

2. Změna názvu vaší firmy – změní-li vaše firma název, který se má zobrazovat v tiskových sestavách apod., je potřeba požádat o změnu spol. RON Software s.r.o., která vám zašle novou registrační kartu.

3. Po zakoupení nových modulů – pokud zakoupíte nové moduly pro některý z programů spol. RON Software s.r.o.

4. Dokoupení licencí – jestli-že zakoupíte licenci na větší počet zaměstnanců.

5. Nová, nebo prodloužená servisní smlouva – pokud jste uzavřeli novou servisní smlouvu, popřípadě jste zakoupili prodloužení, obdržíte novou registrační kartu.

6. Při přechodu z generačně staršího typu programu na novější – pokud zakoupíte generačně novější typ programu, je zapotřebí změnit kód v nově nainstalované verzi programu (nejedná se o běžnou aktualizaci verze).

Postup zadání aktivačního kódu: V menu Systém -> Správa databáze -> Aktivace -> zde vyplňte všechny údaje z registrační karty. Povinné jsou údaje, které jsou tištěny tučně. Při zadávání aktivačního kódu je nutné mít práva pro zápis do složky, kde je program nainstalován. Pokud je program nainstalován na serveru, bude pravděpodobně muset provést aktivaci jeho správce.

Helpdesk

Helpdesk je nástroj, pomocí kterého je možné zadávat dotazy přímo na konzultanty jednotlivých programů. Pokud máte platnou servisní smlouvu, je možné se přihlásit pomocí webové stránky zadané ve vašem oblíbeném prohlížeči: „helpdesk.ron.cz“. Tato forma podpory je přístupná výhradně těm zákazníkům, kteří mají platnou servisní smlouvu.


Nastavení exportu

Navigation: Postupy >

Nastavení exportu

 Return to chapter overview

Data z docházkového systému je možné použít jako podklad pro zpracování mezd. Pokud je Váš mzdový systém schopen přijímat data o docházce v textovém souboru, můžete si export do textového souboru pro mzdový systém nastavit. Docházkový systém umožňuje nastavit libovolný počet exportovaných textových souborů s vlastním nadefinovaným formátem.

Pokud si na nastavení vlastního exportu netroufáte, kontaktujte linku podpory RON Software.

V jednoduché variantě stačí jedno nastavení exportu. Pokud je však export komplikovanější může být zapotřebí nastavení více různých exportů (pro každou skupinu zaměstnanců jiný export). Z tohoto důvodu je možné nastavení exportů ukládat pod různými názvy - mít více různých exportů a k těmto exportům přiřazovat skupiny osob, které se budou exportovat.

Postup exportu:

1. V menu "Systém/Nastavení aplikace/Společné nastavení/Export" nastavte potřebná data pro export.

2. V menu "Systém/Import-Export/Export" spusťte export dat.

Nastavení exportu obsahuje následující podkapitoly:

· Export
· Formát exportu
· Proměnné základního seznamu zaměstnanců
· Proměnné seznamu mzdových položek
· Proměnné seznamu výsledků výpočtu docházky
· Proměnné seznamu intervalových výsledků
· Formátování datumových proměnných
· Formátování číselných proměnných


Export

Navigation: Postupy > Nastavení exportu >

Export

 Return to chapter overview

Postup vytvoření nastavení exportu:

- stiskněte tlačítko Vytvorit a zadejte název exportu (např. ABC_MZDY).

- vyplňte část Nastavení aktuálního exportu se všemi níže popsanými vlastnostmi (položkami).

Pokud chcete vytvořit více druhů exportů, opakujte předchozí kroky.

Jestliže nastavení exportu neprovádíte sami a exportní soubor vám byl doručen, použijte možnost načtení exportu ze souboru.

Horní část nastavení představuje prvky, pomocí kterých lze ovládat seznam nadefinovaných exportů.

· Název - toto pole zobrazuje název aktuálního nastavení exportu. Pomocí tlačítka Vyberove tlacitko lze volit ze seznamu již uložených exportů.
Vytvorit | Vytvořit - toto tlačítko umožní vytvořit nové nastavení exportu pod zvoleným názvem.
Odstranit | Odstranit - toto tlačítko umožňuje odstranit aktuálně nastavený exportu. Odstranění je nevratný krok.
Ulozit | Uložit nastavení aktuálního exportu do souboru - tlačítko umožňuje uložit akt. nastavení exportu do souboru. Vytvoří se soubor s názvem exportu a příponou "nex"
Nacist | Načíst nastavení ze souboru - tlačítko umožňuje načíst nastavení exportu ze souboru.

Dolní část formuláře obsahuje nastavení aktuálně vybraného exportu.

· Cílový soubor - toto pole slouží pro zadání názvu cílového souboru zobrazeného exportu. Do tohoto souboru se budou exportovaná data ukládat. Název souboru může obsahovat proměnné s definicí formátu datumu, které budou při provádění samotného exportu nahrazeny hodnotou podle aktuálního období. Proměnné s formátem datumu se do názvu vkládají tak, že se daný formát datumu ohraničí mezi znaky: %%. Jako formátovací znaky lze použít tyto řetězce: m mm yy yyyy. Proměnných s formátem datumu je možno do názvu souboru vkládat libovolné množství.

PŘÍKLAD: Pro zadaný název cílového souboru: "c:\temp\export%mmyyyy%.txt" a aktuální období červen 2008, bude výsledný název souboru tento:

"c:\temp\export062008.txt".

· Přidávat záznamy do již existujícího souboru - pokud je tato volba aktivována, pak při provádění daného exportu bude provedena kontrola, zda daný soubor již existuje a pokud soubor existuje, pak původní obsah bude zachován a záznamy budou přidány na konec souboru. V opačném případě bude původní obsah souboru před exportem vymazán a bude naplněn novými daty.

· Povolit export v neuzavřeném období - pokud je tato volba aktivována, není potřeba před exportem uzavírat období.

· Definice formátu - toto pole slouží pro definování jednotlivých řádků (záznamů) formátu exportu. Pro definici formátu stiskněte tlačítko Editovat.

· Platnost pracovních poměrů - zvolte, které pracovní poměry chcete exportovat (Aktivní, Ukončené, Všechny).

· Exportovat i zaměstnance jiné firmy - pokud je tato volba aktivována, pak při provádění exportu budou exportovány i údaje zaměstnanců jiné firmy.

· Exportovat jen zaměstnance podle zvoleného rozdělení - pokud je tato volba aktivována, pak při provádění akt. exportu budou exportovány jen údaje zaměstnanců, kteří jsou přiřazeni do rozdělení nastavených v následujících dvou polích. Tuto volbu použijete, pokud potřebujete pro jednotlivé skupiny zaměstnanců definovat různé exporty. Například pro dělníky převádíte přesčasy a pro techniky přesčasy do exportu nedáváte.

o Typ rozdělení - toto pole určuje typ rozdělení, pro které bude omezen výběr zaměstnanců pro akt. export.

o Volba rozdělení před exportem - pomocí této volby aktivujete výběr konkrétních rozdělení podle přednastaveného typu, prostřednictvím formuláře ze seznamem rozdělení před provedením exportu. Pokud není volba aktivována, máte možnost zadat Seznam kódů rozdělení.

o Seznam kódů rozdělení - toto pole obsahuje kódy rozdělení zaměstnanců (oddělené středníkem). V položce Typ rozdělení jste vybrali nějaké rozdělení např. "Skupina". V této položce vypište seznam skupin, pro které se bude provádět tento export. Všichni zaměstnanci, kteří se během zpracovávaného období (měsíce) stali členy této "skupiny" budou obsaženi v exportu.

související: Formát exportu, Proměnné základního seznamu zaměstnanců, Proměnné seznamu mzdových položek, Proměnné seznamu výsledků výpočtu docházky, Proměnné seznamu intervalových výsledků, Formátování datumových proměnných, Formátování číselných proměnných, Formátování řetězcových proměnných


Formát exportu

Navigation: Postupy > Nastavení exportu >

Formát exportu

 Return to chapter overview

Formát exportu popisuje, jak budou vypadat jednotlivé řádky (záznamy) exportního souboru. Jeden řádek formátu popisuje jeden nebo více výsledných řádků pro jednoho zaměstnance v exportním souboru. Tzn., že pro každého zaměstnance je proveden překlad a dosazení hodnot každého řádku formátu daného exportu.

Formátovací značky v popisu formátu uzavřené do hranatých závorek nejsou povinné. Uvozovky v příkladech nejsou součástí formátu a složí jen pro ohraničení textu, který bude součásti definice formátu.

Popis definice formátu exportu:

Základní formát řádku vypadá takto:

<zdroj dat>[<posun vzhledem k akt. období>]:<formát řádku>

<zdroj dat> - určuje zdroj dat řádku exportu. Aktuálně jsou možné tyto zdroje dat:

<zdroj dat> = Z

Tento zdroj dat určuje, že zdrojem dat je základní seznam zaměstnanců se základními údaji. Tento typ řádku bude vložen do výsledného souboru jednou pro každého zaměstnance. Do formátu řádku mohou být vkládány proměnné základního seznamu zaměstnanců.

Příklady (Z):

· Příklad řádku definice formátu pro vypsání jména, příjmení a data narození oddělených středníkem:

"Z:%jmeno%;%prijmeni%;%datumNarozeni&dd.mm.yyyy%"

· Příklad řádku definice formátu pro vypsání jména, příjmení a data narození s pevnou délkou 20 znaků každé proměnné zarovnané doprava:

"Z:%jmeno@-20%%prijmeni@-20%%datumNarozeni&dd.mm.yyyy@-20%"

· Příklad řádku definice formátu pro vypsání jména, příjmení a data narození s pevnou délkou 20 znaků každé proměnné zarovnané doleva:

"Z:%jmeno@20%%prijmeni@20%%datumNarozeni&dd.mm.yyyy@20%"

<zdroj dat> = M

Tento zdroj dat určuje, že zdrojem dat je seznam mzdových položek zaměstnance. Tento typ řádku bude opakován pro každou mzdovou položku každého zaměstnance. Do formátu řádku mohou být vkládány proměnné základního seznamu zaměstnanců a proměnné seznamu mzdových položek.

Příklady (M):

· Příklad řádku definice formátu pro výpis mzdových položek oddělených čárkou:

"M:%rc%,%osobniCislo%,%datumNastupu%,%MzdovaPolozka%,%popis%,%PocetJednotek%,%CenaZaJednotku&##0.00%

<zdroj dat> = V[?<typ časové složky mzdy>]

· Tento zdroj dat určuje, že zdrojem dat je seznam výsledků výpočtu docházky zaměstnance. Do formátu řádku mohou být vkládány proměnné základního seznamu zaměstnanců a proměnné seznamu výsledků výpočtu docházky.

· Pokud je potřeba dosadit součty nebo rozdíly více časových složek mzdy v jednom řádku, pak je možno na místo jednoho kódu časové složky mzdy dosadit více kódů časových složek mzdy oddělených operátorem + nebo operátorem -. V daném případě pak proměnné: hodiny, dny, kalendarniDny budou výsledkem daného vzorce z kódů časových složek mzdy. Např. pokud potřebujeme součet odpracované doby (kód 100) a dovolené (kód 200) pak daný text, pro popis požadovaných č. složek mzdy, bude vypadat takto: "?100+200". Pokud je řádek součtem časových složek, budou numerické proměnné součtem těchto časových složek, ale textové proměnné budou naplněny první nalezenou hodnotou ze sčítaných časových složek.

· Proměnné hodiny, dny, kalendarniDny mohou mít index dne v měsíci v hodnotě 1 až 31 uzavřený do hranatých závorek. Např. "%hodiny[15]%" znamená, že na místo proměnné bude dosazen počet hodin z výsledku výpočtu odpovídající časové složce z 15. dne zpracovávaného období (nebo jiného, nastavením posunu v definici zdroje dat).

· Pokud má daný datový zdroj nastavený požadovaný kód časové složky nebo více požadovaných kódů, pak tento řádek bude vložen do výsledného souboru pro každého zaměstnance jednou pro požadovaný kód časové složky mzdy (nebo výsledek podle vzorce s kódy časových složek). V opačném případě, pokud není definován žádný požadovaný kód časové složky, bude tento řádek vložen do výsledného souboru pro každý záznam měsíčních výsledků každého zaměstnance. Pokud jsou ve formátu řádku proměnné s indexem dne, pak musí být vždy definován požadovaný kód časové složky mzdy, nebo výsledek podle více časových složek vzorcem.

Příklady (V):

· Příklad řádku definice formátu pro výpis odpracovaných dob zaměstnanců v hodinách:

"V?100:%rc%,%osobniCislo%,%datumNastupu%,100,%hodiny%"

· Příklad řádku definice formátu pro výpis součtů dovolených a nemocenských zaměstnanců ve dnech:

"V?200+300:%rc%,%osobniCislo%,%datumNastupu%,<externí kód>,%dny%"

· Příklad řádku definice formátu pro výpis převáděných přesčasů zaměstnanců z minulého měsíce v hodinách:

"V?997@-1:%rc%,%osobniCislo%,%datumNastupu%,997,%dny%"

· Příklad řádku definice formátu pro výpis odpracovaných hodin zaměstnanců (v minutách) v jednotlivých dnech v měsíci oddělených svislou čárkou: "V?100:%rc%,%osobniCislo%,%datumNastupu%,100|%hodiny[1]&m%|%hodiny[2]&m%|... ...|%hodiny[31]&m%"

· Příklad stejného řádku jako předchozí, pouze osobní číslo je zarovnáno na deset znaků doprava a doplněno před řazenými nulami:

"V?100:%rc%,%osobniCislo&0@-10%,%datumNastupu%,100|%hodiny[1]&m%|%hodiny[2]&m%|... ...|%hodiny[31]&m%"

<zdroj dat> = I[?<typ časové složky mzdy>]

· Tento zdroj dat určuje, že zdrojem dat je seznam intervalových výsledků výpočtu docházky zaměstnance. Tento typ řádku bude opakován pro každý požadovaný (parametr <typ časové složky mzdy>) intervalový výsledek výpočtu v daném období pro každého zaměstnance. Do formátu řádku mohou být vkládány proměnné základního seznamu zaměstnanců a proměnné seznamu intervalových výsledků výpočtu.

<posun vzhledem k akt. období> - pokud je potřeba dat z období jiného než aktuálního, pak je možno za datovým zdrojem určit posun požadovaného období ve formátu: @[+|-]n, kde n je počet měsíců vzhledem k akt. období. Znaménko + určuje posun o n měsíců (období) dopředu a znaménko - určuje posun o n měsíců (období) dozadu (znaménko je nepovinné).

<formát řádku> - určuje výslednou podobu řádku (záznamu) exportu. Celý formát řádku bude pro každého zaměstnance překopírován do cílového souboru s tím, že proměnné uzavřené do znaků: %% ve tvaru: %<definice proměnné>%, budou nahrazeny podle příslušného zdroje dat.

<definice proměnné> - každá proměnná může mít uveden formát, ve kterém se bude exportovat. Formát je možné zadat za jménem proměnné za znakem &. Dále může být uvedena šířka, na kterou se daná proměnná zarovná (počet znaků). Šířka se zadává za znakem @. V případě, že je kladná (větší než nula), doplní se znaky na konec exportované hodnoty, pokud je záporná, doplní se na začátek.

Formát definice proměnné: %<název proměnné>[&<formát>][@[-]<výsledná šířka>]%

definice proměnné je složená ze tří částí:

1. Název proměnné. Názvy proměnných lze dosazovat podle datových zdrojů.

Viz proměnné základního seznamu zaměstnanců, proměnné seznamu mzdových položek, proměnné seznamu výsledků výpočtu docházky

2. Formát proměnné. Formát proměnné lze definovat v závislosti podle typu proměnné. Definovat formátování má význam jen pro datumové nebo číselné proměnné. U textové proměnné je možné nastavit pouze vyplňovací znak při zarovnání

3. Výsledná šířka proměnné (a zarovnání). Normálně je hodnota proměnné zarovnána doleva, pokud je před šířkou znaménko: - pak je hodnota zarovnána doprava.

Komentář:

Jelikož popis exportu vypadá mnohdy velmi nepřehledně, můžete v popisu exportu nalézt (nebo si vytvořit) řádky začínající lomítkem ("/").

Řádek začínající lomítkem je celý považován za komentář a není při exportu vůbec používán.

související: Export, Proměnné základního seznamu zaměstnanců, Proměnné seznamu mzdových položek, Proměnné seznamu výsledků výpočtu docházky, Proměnné seznamu intervalových výsledků, Formátování datumových proměnných, Formátování číselných proměnných, Formátování řetězcových proměnných


Proměnné základního seznamu zaměstnanců

Navigation: Postupy > Nastavení exportu >

Proměnné základního seznamu zaměstnanců

 Return to chapter overview

Ve formátovacím řetězci řádku se zdrojem dat: základní seznam zaměstnanců, mohou být tyto proměnné:

Název proměnné | Typ | Popis
cisloRadku | N | Číslo akt. řádku ve výstupním souboru
aktObdobi | D | Aktuální období (datum prvního dne)
aktDatumCas | D | Aktuální datum a čas
rc | C | Rodné číslo zaměstnance
titul | C | Titul
jmeno | C | Jméno
prijmeni | C | Příjmení
titulZa | C | Titul za
datumNarozeni | D | Datum narození
osobniCislo | C | Osobní číslo
datumNastupu | D | Datum nástupu do pracovního poměru
datumUkonceni | D | Datum ukončení pracovního poměru
typPracovnihoPomeru | C | Kód typu pracovního poměru
mzdoveStredisko | C | Kód mzdového střediska
poradovecislopp | N | Pořadí pracovního poměru

Značení typů:

· C - Textová hodnota
· D - Datum
· N - číselná hodnota

související: Export, Formát exportu, Proměnné seznamu mzdových položek, Proměnné seznamu výsledků výpočtu docházky, Proměnné seznamu intervalových výsledků, Formátování datumových proměnných, Formátování číselných proměnných, Formátování řetězcových proměnných


Proměnné seznamu mzdových položek

Navigation: Postupy > Nastavení exportu >

Proměnné seznamu mzdových položek

 Return to chapter overview

Ve formátovacím řetězci řádku se zdrojem dat: seznam mzdových položek, mohou být tyto proměnné:

Název proměnné | Typ | Popis
Obdobi | D | První den aktuálního období
MzdovaPolozka | C | Kód typu mzdové položky
Popis | C | Popis typu mzdové položky
PocetJednotek | N | Počet jednotek
CenaZaJednotku | N | Cena za jednotku

Značení typů:

· C - Textová hodnota
· D - Datum
· N - číselná hodnota

související: Export, Formát exportu, Proměnné základního seznamu zaměstnanců, Proměnné seznamu výsledků výpočtu docházky, Proměnné seznamu intervalových výsledků, Formátování datumových proměnných, Formátování číselných proměnných, Formátování řetězcových proměnných


Proměnné seznamu výsledků výpočtu docházky

Navigation: Postupy > Nastavení exportu >

Proměnné seznamu výsledků výpočtu docházky

 Return to chapter overview

Ve formátovacím řetězci řádku se zdrojem dat: seznam výsledků výpočtu docházky, mohou být tyto proměnné:

Název proměnné | Typ | Popis
Mesic | D | Datum prvního dne období
TypCasoveSlozkyMzdy | C | Kód typu časové složky mzdy
PopisCasoveSlozkyMzdy | C | Popis typu časové složky mzdy
Hodiny | N | Počet hodin pro dané období v daném záznamu výsledku pro danou časovou složku mzdy. Pokud je potřeba jen počet hodin pro určitý den v měsíci pak je možno použít index za názvem proměnné ve tvaru Hodiny[n] kde n je číslo 1 až 31. Pro danou proměnnou lze kromě standardního formátování čísla využít i formátovacího řetězce: "hh:mm" který způsobí, že výsledný text proměnné bude v daném tvaru hodiny:minuty. Dále lze využít formátovacího řetězce: "m" který způsobí, že hodiny budou převedeny na minuty a výsledný text bude celkový počet minut.
Dny | N | Počet dnů pro dané období v daném záznamu výsledku pro danou časovou složku mzdy. Pro jednotlivé dny v měsíci lze rovněž využít indexu dne u proměnné.
KalendarniDny | N | Počet kalendářních dnů pro dané období v daném záznamu výsledku pro danou časovou složku mzdy. Pro jednotlivé dny v měsíci lze rovněž využít indexu dne u proměnné.

Značení typů:

· C - Textová hodnota
· D - Datum
· N - číselná hodnota

související: Export, Formát exportu, Proměnné základního seznamu zaměstnanců, Proměnné seznamu mzdových položek, Proměnné seznamu intervalových výsledků, Formátování datumových proměnných, Formátování číselných proměnných, Formátování řetězcových proměnných


Proměnné seznamu intervalových výsledků výpočtu

Navigation: Postupy > Nastavení exportu >

Proměnné seznamu intervalových výsledků výpočtu

 Return to chapter overview

Ve formátovacím řetězci řádku se zdrojem dat: seznam intervalových výsledků výpočtu docházky, mohou být tyto proměnné:

Název proměnné | Typ | Popis
DatumOd | D | Počáteční datum intervalového výsledku
DatumDo | D | Koncové datum intervalového výsledku
TypCasoveSlozkyMzdy | C | Kód typu časové složky mzdy
PopisCasoveSlozkyMzdy | C | Popis typu časové složky mzdy
Hodiny | N | Počet hodin pro daný interval v období v daném záznamu výsledku pro danou časovou složku mzdy. Pro danou proměnnou lze kromě standardního formátování čísla využít i formátovacího řetězce: "hh:mm" který způsobí, že výsledný text proměnné bude v daném tvaru hodiny:minuty. Dále lze využít formátovacího řetězce: "m" který způsobí, že hodiny budou převedeny na minuty a výsledný text bude celkový počet minut.
Dny | N | Počet dnů pro daní interval v období v daném záznamu výsledku pro danou časovou složku mzdy.
KalendarniDny | N | Počet kalendářních dnů pro daný interval v období v daném záznamu intervalového výsledku pro danou časovou složku mzdy. Pro jednotlivé dny v měsíci lze rovněž využít indexu dne u proměnné.

Značení typů:

· C - Textová hodnota
· D - Datum
· N - číselná hodnota

související: Export, Formát exportu, Proměnné základního seznamu zaměstnanců, Proměnné seznamu mzdových položek, Proměnné seznamu výsledků výpočtu docházky, Formátování datumových proměnných, Formátování číselných proměnných, Formátování řetězcových proměnných


Formátování datumových proměnných

Navigation: Postupy > Nastavení exportu >

Formátování datumových proměnných

 Return to chapter overview

Formátovací řetězec datumových proměnných řídí výsledné zobrazování hodnot proměnných.

Formátovací řetězec je složen ze specifikátorů, které reprezentují hodnoty jednotlivých částí data zobrazené ve výsledném tvaru proměnné. Dále je složen z ostatních formátovacích znaků, které budou zobrazeny nezměněny.

Tabulka specifikátorů:

Specifikátor | Popis
d | Dosadí číslo dne bez úvodní nuly (1 - 31).
dd | Dosadí číslo dne s úvodní nulou (01 - 31).
ddd | Dosadí zkratku dne v týdnu akt dne (Po - Ne).
dddd | Dosadí celý název dne v týdnu (Pondělí - Neděle).
m | Dosadí číslo měsíce bez úvodní nuly (1 - 12).
mm | Dosadí číslo měsíce s úvodní nulou (01 - 12).
mmm | Dosadí zkratku měsíce v roce (Led - Pro).
mmmm | Dosadí celý název měsíce (Leden - Prosinec).
yy | Dosadí dvou místně rok.
yyyy | Dosadí čtyř místně rok.
/ | Oddělovač - na danou pozici dosadí oddělovač data nastavený v systému.
'xx'/"xx" | Znaky uzavřené v uvozovkách nebo apostrofech jsou dosazeny nezměněny, tak jak jsou.

Příklady formátování datumové proměnné:

d.m.yyyy -> 6.3.2003

d/m/yy -> 6.3.03 (pokud je jako oddělovač nastavena tečka)

dd.mm.yyyy -> 06.03.2003

yyyy-mm-dd -> 2003-03-06

související: Export, Formát exportu, Proměnné základního seznamu zaměstnanců, Proměnné seznamu mzdových položek, Proměnné seznamu výsledků výpočtu docházky, Proměnné seznamu intervalových výsledků, Formátování číselných proměnných, Formátování řetězcových proměnných


Formátování číselných proměnných

Navigation: Postupy > Nastavení exportu >

Formátování číselných proměnných

 Return to chapter overview

Formátovací řetězec číselných proměnných řídí výsledné zobrazování hodnot proměnných.

Formátovací řetězec je složen ze specifikátorů, které reprezentují jednotlivé části číslo zobrazené ve výsledném tvaru proměnné.

Tabulka specifikátorů:

Specifikátor | Popis
0 | Představuje místo pro číslici ve výsledném řetězci. Pokud je na dané pozici čísla číslice, pak je kopírována i na danou pozici do výsledného tvaru, pokud ne pak je ve výsledném tvaru dosazená 0.
# | Představuje místo pro číslici ve výsledném řetězci. Pokud je na dané pozici čísla číslice, pak je kopírována i na danou pozici do výsledného tvaru, pokud ne pak je ve výsledném tvaru tato pozice prázdná.
. | (tečka) Přestavuje oddělovač desetinné části čísla. Na danou pozici je vložen oddělovač desetinné části nastavený v systému. Pokud chcete striktně použít vámi definovaný oddělovač, zadejte oddělovač v uvozovkách.
[xx] | Náhradní oddělovač desetinné části. Pokud je do formátovacího řetězce vložen řetězec uzavřený v hranatých závorkách místo oddělovače desetinné části, pak je daný řetězec (bez závorek) vložen místo desetinného oddělovače nastaveného v systému. Pokud je použit náhradní oddělovač desetinné části pak nesmí být ve formátovacím řetězci použit normální znak oddělovače desetin (tečka).
, | (čárka) Představuje oddělovač tisíců. Na danou pozici je vložen oddělovač tisíců nastavený v systému.
E+ | Vědecká notace. Číslo je dosazeno ve vědecké notaci. E+ můžou následovat až čtyři 0 určující minimální počet číslic v exponentu. E- určuje že bude zobrazeno jen negativní znaménko u exponentu.
'xx'/"xx" | Znaky uzavřené v uvozovkách nebo apostrofech jsou dosazeny nezměněny, tak jak jsou.
; | (středník) Odděluje sekce pro kladnou, zápornou, a nulovou hodnotu čísla ve formátovacím řetězci.

Příklady formátování číselné proměnné:

Formátovací řetězec 1234 -1234 0.5 0

1234 -1234 0.5 0

0 1234 -1234 1 0

0.00 1234.00 -1234.00 0.50 0.00

#.## 1234 -1234 .5

#,##0.00 1,234.00 -1,234.00 0.50 0.00

#,##0.00;(#,##0.00) 1,234.00 (1,234.00) 0.50 0.00

#,##0.00;;Zero 1,234.00 -1,234.00 0.50 Zero

0.000E+00 1.234E+03 -1.234E+03 5.000E-01 0.000E+00

#.###E-0 1.234E3 -1.234E3 5E-1 0E0

související: Export, Formát exportu, Proměnné základního seznamu zaměstnanců, Proměnné seznamu mzdových položek, Proměnné seznamu výsledků výpočtu docházky, Proměnné seznamu intervalových výsledků, Formátování datumových proměnných, Formátování řetězcových proměnných


Formátování řetězcových proměnných

Navigation: Postupy > Nastavení exportu >

Formátování řetězcových proměnných

 Return to chapter overview

Formátovací řetězcových proměnných řídí výsledné zobrazování hodnot proměnných.

Tabulka specifikátorů:

Specifikátor | Popis
TRIM | Ořeže hodnotu o mezery a kontrolní znaky z obou stran. např.: %OsobniCislo&TRIM%
LTRIM | Ořeže hodnotu o mezery a kontrolní znaky z levé strany. např.: %OsobniCislo&LTRIM%
RTRIM | Ořeže hodnotu o mezery a kontrolní znaky z pravé strany. např.: %OsobniCislo&RTRIM%
LCUT(X) | Ořeže hodnotu o X znaků zleva. %OsobniCislo&LCUT(3)%
RCUT(X) | Ořeže hodnotu o X znaků zprava. %OsobniCislo&RCUT(2)%
CUT(X,Y) | Ořeže hodnotu o X znaků zleva a Y zprava. %OsobniCislo&CUT(3,2)%

související: Export, Formát exportu, Proměnné základního seznamu zaměstnanců, Proměnné seznamu mzdových položek, Proměnné seznamu výsledků výpočtu docházky, Proměnné seznamu intervalových výsledků, Formátování datumových proměnných, Formátování číselných proměnných


Modul PLÁNOVÁNÍ KAPACIT

Navigation: »No topics above this level«

Modul PLÁNOVÁNÍ KAPACIT

 Return to chapter overview

Pomocí přehledného zobrazení budete schopni naplánovat směny zaměstnanců (ranní, odpolední, noční, …) a jejich plánované absence (dovolené, služební cesty, …). Naplánované kapacity jsou graficky zobrazeny v přehledné tabulce a výsledné hodnoty součtů směn jsou zobrazeny v dolní části náhledu.


Nastavení plánování kapacit

Navigation: Modul PLÁNOVÁNÍ KAPACIT >

Nastavení plánování kapacit

 Return to chapter overview

V modulu plánování kapacit je možné plánovat směny i operace. Proto je nutné provést nastavení jednak pro směny, ale také pro operace (dovolená, nemoc apod.).

1) Nastavení směn pro plánování provedete v menu Seznamy/Směny. V seznamu vyberte směnu a otevřete formulář směny tlačítkem [image] Editace záznamu. Ve formuláři je potřeba vyplnit následující pole:

· Zkratka pro plánování - při plánování kapacit se použité směně přiřadí nastavená zkratka (N8 - Noční směna 8; R8 - Ranní směna 8 apod.),

· Barva pro vykreslení - nastavte barvu, která se přiřadí k použité směně (červená).

Po nastavení potvrďte tlačítkem [image].

Výsledné zobrazení nastavené směny v plánování kapacit bude vypadat například takto: .

Nastavení polí provedete u všech směn, které chcete plánovat.

2) Po nastavení směn nastavte operace, které budete chtít plánovat. Potřebné nastavení provedete v menu Terminály/Operace terminálu. V seznamu vyberte operaci a otevřete formulář operace terminálu tlačítkem [image] Editace záznamu. Ve formuláři je potřeba vyplnit následující pole:

· Zkratka pro plánování - při plánování kapacit se použité operaci přiřadí nastavená zkratka (A - Nemoc; L - Lékař; D - Dovolená apod.),

· Barva pro vykreslení - nastavte barvu, která se přiřadí k použité operaci (modrá).

Po nastavení potvrďte tlačítkem [image].

Výsledné zobrazení nastavené operace v plánování kapacit bude vypadat například takto: .

Nastavení polí provedete u všech operací, které chcete plánovat.

POZOR: Volbu zkratek pro plánování si promyslete. Nesmí nastat situace, kdy se budou zkratky překrývat. Situace nesmí nastat ve směně, v operaci ani v jejich kombinaci.

PŘÍKLAD správného zadání zkratek: A1; A2; A3 - ano - za předpokladu, že neexistuje A (ani ve směně ani v operaci).

PŘÍKLAD špatného zadání zkratek: D; D1 - ne.


Postup plánování kapacit

Navigation: Modul PLÁNOVÁNÍ KAPACIT >

Postup plánování kapacit

 Return to chapter overview

V kapitole naleznete návod, jak postupovat při plánování kapacit.


Režim plánování

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Postup plánování kapacit >

Režim plánování

 Return to chapter overview

Režim slouží k naplánování směn/operací pro budoucí období, například pro příští měsíc.

1) Vkládání Směn/operací do plánovače kapacit:

– vyberte myší pole, pro které chcete vložit směnu/operaci. Stiskem klávesy Ctrl je možné označit více nesouvislých polí.

Ø Zadání směny/operace z klávesnice

– do označených polí zadejte z klávesnice nastavenou zkratku. Například pro plánování odpolední směny stiskněte písmeno O.
= směna/operace se vyplní ve vybraných polích.

Ø Zadání směny/operace přes Legendu

– klikněte na ikonu plánované směny/operace v Legendě (v pravé části okna)
= směna/operace se vyplní ve vybraných polích.

Ø Zadání směny stiskem tlačítka

– po výběru polí stiskněte tlačítko
= do vybraných polí se vyplní směny podle kalendáře.

Naplánované směny/operace je možné přepisovat novými hodnotami a mazat tlačítkem Delete (hromadně, jednotlivě).

2) Zapůjčení zaměstnance na jiné středisko:

– vyberte období, pro které chcete zapůjčit vašeho zaměstnance na jiné středisko,
– stiskněte pravé tlačítko myší ve vybraném období,
– v zobrazené roletce zvolte středisko, na které se má zaměstnanec přesunout.

Po přesunu pracovníka se v seznamu naplánovaných kapacit zobrazí následující:

Ø pro středisko, které zaměstnance zapůjčilo:

= zapůjčený zaměstnanec je přiřazen na jiné středisko a nemá naplánovanou směnu. Pro dny jejichž pole je šedé není možné plánovat kapacity.

= zapůjčený zaměstnanec je přiřazen na jiné středisko a má již naplánovanou směnu.

Ø pro středisko, které si zaměstnance zapůjčilo:

= přeřazenému zaměstnanci ještě nebyla naplánována směna.

= zobrazení po naplánování směny přeřazenému zaměstnanci.

3) Potvrzení naplánovaných kapacit:

Potvrdit naplánované směny je možné pro každé pole v seznamu plánovaných kapacit zvlášť (na rozdíl od Schválení plánovaných kapacit). Funkci je nutné využít v případě, kdy plánujete kapacity zaměstnanci, který je přeřazen (zapůjčen) z jiného střediska. Tímto krokem dáte najevo, že vedoucí, který zaměstnance přeřadil, může schválit naplánované kapacity (viz Schvalování naplánovaných kapacit). Funkci je možné využít také jako poznámku pro směny, které jsou již hotové a naplánované.

– vyberte období, pro které chcete potvrdit naplánované kapacity,
– stiskněte pravé tlačítko myší ve vybraném období,
– v zobrazené roletce vyberte Potvrdit naplánované směny.

= ukázka potvrzení naplánované směny. Potvrzení je vyznačeno modrým pruhem v horní části obrázku.

4) Schvalování naplánovaných kapacit:

Schválení je prováděno pro období od prvního dne v měsíci po zvolené (vybrané) datum.

– označte více řádků ve sloupci (pro více zaměstnanců), případně vyberte řádek (pro jednoho zaměstnance),

– v zobrazené roletce zvolte:

o pro první úroveň schválení: Zpracováno do …. Barevné označení této úrovně schválení je [image] .

o pro druhou úroveň schválení: Zkontrolováno …. Barevné označení této úrovně schválení je [image] .

o pro třetí úroveň schválení: Schváleno …. Barevné označení této úrovně schválení je [image] .


Režim dodatečných úprav

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Postup plánování kapacit >

Režim dodatečných úprav

 Return to chapter overview

Režim dodatečných úprav slouží k zaznamenání skutečného stavu oproti naplánovanému. Změny mohou nastat z důvodu onemocnění či dovolené zaměstnanců.

Dodatečné změny se nemůžou provádět, pokud není původní plán schválen.

1) Vkládání Směn/operací do plánovače kapacit:

Vkládání směn/operací je shodné s Režimem plánování.

Provedená úprava směny/operace se projeví:

– změnou v označení směny/operace ( [image] -> [image] ),
– v pravém dolním rohu se zobrazí čárečka označující provedenou změnu.

Další body 2 až 4 jsou shodné s Režimem plánování.


Prostředí Plánování kapacit

Navigation: Modul PLÁNOVÁNÍ KAPACIT >

Prostředí Plánování kapacit

 Return to chapter overview

V menu Docházka/Plánování kapacit budete plánovat směny zaměstnancům. Prostředí plánování kapacit je možné rozdělit do pěti částí:

1. část - nástrojová lišta k ovládání seznamu.

2. část - filtry, kterými můžete zobrazit požadované v seznamu pro plánování.

3. část- informační řádek

4. část - seznam osob, plánování kapacit,

5. část - okno s texty poznámek.


1. část

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit >

1. část - Nástrojová lišta

 Return to chapter overview

Nástrojová lišta k ovládání seznamu

PK_Obnovit obsah seznamu | Obnovit obsah seznamu - tlačítkem po provedených změnách obnovíte obsah seznamu.
 | Rychlé vyhledávání - ve spodní části seznamu se zobrazí řádek s editačním polem pro zápis hledané hodnoty.
 | Nastavení řazení - editoru řazení slouží k nastavení způsobů řazení a ukládání vytvořených nastavení pod zvolenými jmény.
 | Tiskové sestavy - v seznamu tiskových sestav můžete vybrat sestavu a vytisknout naplánované kapacity.

Zobrazit/Skrýt legendu - kliknutím na odkaz zobrazíte/skryjete legendu na pravé straně:

Zobrazit/Skrýt součty - kliknutím na odkaz zobrazíte/skryjete součty pod seznamem naplánovaných kapacit.

PK_Soucty planovanych kapacit

1) na řádku se zobrazí celkový součet směn ve sloupci.

2) vybraná časová složka, kterou jste nastavili v menu Systém/Nastavení aplikace/Společné nastavení/Plánování kapacit 2 - Typ časové složky pro zobrazení součtu ve sloupci. Časovou složku je možné nastavit jak pro režim plánování, tak pro režim dodatečných úprav. V každém režimu je možné zvolit jinou časovou složku. Pro zvolenou časovou složku můžete kontrolovat limit - více v bodě 6 a 5.

3) seznam směn, pro které se na řádku zobrazuje součet. Seznam směn, pro které chcete zobrazovat součty, nastavíte v Nastavení součtů.

4) seznam operací, pro které se na řádku zobrazuje součet. Seznam směn, pro které chcete zobrazovat součty, nastavíte v Nastavení součtů.

5) součet naplánovaných směn neleží v zadanému intervalu hodnot Min a Max, a proto jsou jeho hodnoty v celkovém součtu označeny červenou barvou. Rozsah normohodin (hodnoty Min, Max) nastavíte v menu Seznamy/Kalendáře -> Formulář kalendáře -> Směny II. Barevné označení celkového součtu naplánovaných směn, jejichž součet neleží v intervalu hodnot Min a Max nastavíte v Nastavení vzhledu v poli Označit normohodiny mimo povolený limit barvou. Zadané maximální a minimální hodnoty se zobrazují v Informačním řádku. Kontrolu limitu lze přepnout na jinou vybranou časovou složku - viz bod 2.

6) součet naplánovaných směn je v povoleném intervalu zadaných hodnot Min a Max, a proto nejsou jeho hodnoty v celkovém součtu označeny červenou barvou. Rozsah normohodin (hodnoty Min, Max) nastavíte v menu Seznamy/Kalendáře -> Formulář kalendáře -> Směny II. Barevné označení celkového součtu naplánovaných směn, jejichž součet neleží v intervalu hodnot Min a Max nastavíte v Nastavení vzhledu v poli Označit normohodiny mimo povolený limit barvou. Zadané maximální a minimální hodnoty se zobrazují v Informačním řádku. Limit lze kontrolovat i pro jinou vybranou časovou složku - viz bod 2.

7) barevné označení naplánované směny (ranní, odpolední, noční) v součtech. Výslednou hodnotu ve sloupci můžete mít zobrazenou buď v hodinách, nebo součtem směn naplánovaných v daném dni. Přepnutí mezi hodinami a počtem provedete ve filtrech (ne)zaškrtnutím pole Součet směn zobrazit v hodinách. Barevné označení absence jste nastavili v menu Seznamy/Směny - formulář Směny - pole Barva pro vykreslení.

8) barevné označení naplánované absence (nemoc, dovolená) v součtech. Výslednou hodnotu ve sloupci můžete mít zobrazenou buď v hodinách, nebo součtem absencí naplánovaných v daném dni. Přepnutí mezi hodinami a počtem provedete ve filtrech (ne)zaškrtnutím pole Součet absencí zobrazit v hodinách podle přiřazené směny. Barevné označení absence jste nastavili v menu Terminály/Operace terminálu - formulář operace terminálu - pole Barva pro vykreslení.

Nastavení - kliknutím na odkaz zobrazíte formulář, ve kterém můžete nastavit další možnosti zadávání plánovaných kapacit.


Nastavení chování

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit > 1. část - Nástrojová lišta >

Nastavení chování

 Return to chapter overview

PK_Planovani kapacit chovani

Mnohonásobný výběr:

· Povolit výběr více polí najednou - podržením klávesy Shift při posunu nebo pomocí myši vybere více polí najednou.

· Dotaz při mazání více polí najednou - při mazání více polí najednou se zobrazí varování: "Opravdu chcete vymazat všechny vybrané směny?".

· Dotaz při přepsání více polí najednou - při přepsání více polí najednou se zobrazí varování: Opravdu chcete přepsat obsah všech vybraných buněk?".

Automatický posun:

· Povolit automatický posun po zapsání hodnoty - po zapsání směny/operace se pole posune ve směru nastaveného automatického posunu:

o Vpravo - na další den,

o Dolů - na další osobu,

o Vlevo - na předchozí den,

o Nahoru - na předchozí osobu.

· Přeskakovat víkendy - po zatrhnutí pole se při automatickém posunu, budou přeskakovat víkendy - pole se přesune z pátku na pondělí.


Nastavení vzhledu

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit > 1. část - Nástrojová lišta >

Nastavení vzhledu

 Return to chapter overview

PK_Planovani kapacit vzhled

Barvy:

V této sekci nastavujete barevné rozlišení tabulky pro plánování kapacit. Například data víkendů jsou zobrazena červeně.

· Označit normohodiny mimo povolený limit barvou - při zatržení program označí normohodiny mimo povolený limit nastavenou barvou. Rozsah normohodin nastavíte v menu Seznamy/Kalendáře -> Formulář kalendáře -> Směny II.

· Označit needitovatelné dny cizích osob barvou - dny, které není možné u přesunutých osob (z jiného rozdělení) editovat, se označí vybranou barvou ( [image]).

· Přeškrtnout needitovatelné dny cizích osob - dny, které není možné u přesunutých osob (z jiného rozdělení) editovat, se přeškrtnou ( [image]).

· Zobrazit název dne - po zatrhnutí pole se nad datem zobrazí název dne.

· Zvýraznit začátek dne - po zatržení pole se od sebe oddělí konec a začátek týdne černou čárou.

Vzhled:

· Výška/Šířka mřížky - nastavení výšky a šířky mřížky v tabulce pro plánování kapacit.

· Velikost fontu - velikost písma v plánování kapacit.

· Font pro další text - velikost písma pro ostatní text, například seznam osob, názvy dnů

· Zobrazit osobní číslo - osobní číslo zaměstnance se zobrazí vedle jména osoby vlevo.

· Zobrazit kód rozdělení zaměstnance - kód rozdělení zaměstnance se zobrazí na levé straně od kódu pracovního místa.

· Zobrazit kód pracovního místa - kód pracovního místa zaměstnance se zobrazí na levé straně od osobního čísla. Kód se zobrazí pouze, pokud máte program RonMzdy nebo RonPersonalistiku.

· Zobrazit denní výsledky - po zatrhnutí pole se zobrazí výsledky nastavených časových složek v plánovaných kapacitách (v poli pod naplánovanou směnou). Časové složky, které se mají zobrazovat, nastavíte v menu Systém/Nastavení aplikace/Společné nastavení/Plánování kapacit - Zobrazit denní výsledky v buňkách.

· Zobrazit značku "...", pokud je ke dni zadána poznámka docházky - pokud zadáte poznámku k naplánované směně, zobrazí se značka "...".

· Zobrazit texty poznámek - v dolní části okna plánování kapacit se zobrazí texty zadaných poznámek k docházce a absenci.

· Zobrazit absence - zatržením pole se vám v plánování kapacit zobrazí zadané absence (dovolená, nemoc apod.).

· Jednořádkové zobrazení - pokud nebude pole zatržené, zobrazí se naplánované směny na jednom řádku a absence na druhém. V opačném případě budou směny i absence zobrazeny na jednom řádku.

· Zobrazit schvalování - po zatržení pole můžete schvalovat naplánované kapacity. Schvalování provedete v seznamu plánování kapacit způsobem uvedeným na konci této kapitoly.

o v jednom řádku - po zatržení pole se potvrzené naplánované kapacity zobrazí v jednom řádku - [image]. Pokud pole nezatrhnete, zobrazí se potvrzení ve třech úrovních - [image].


Nastavení součtů

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit > 1. část - Nástrojová lišta >

Nastavení součtů

 Return to chapter overview

PK_Planovani kapacit soucty

· Zobrazovat součty pro směny/operace - v seznamu zatrhněte pole u směn/operací, pro které chcete zobrazovat součty. Součty se zobrazují pod seznamem plánovaných kapacit.

· Filtrovat směny pro součet automaticky podle práv a zvoleného rozdělení - po zatrhnutí filtruje směny, které jsou zobrazeny u součtů v levém dolním rohu, podle práv a zvoleného rozdělení.

· Zobrazit počet naplánovaných hodin zaměstnance - po zatrhnutí pole zobrazí sloupec s počtem naplánovaných hodin zaměstnance.

· Zobrazit počet naplánovaných směn zaměstnance - po zatrhnutí pole se vlevo od seznamu naplánovaných kapacit zobrazí sloupec s počtem naplánovaných směn zaměstnance.

· Počítat i dny, ve kterých je zadána absence - pokud je v poli zobrazena směna i absence ( [image]), potom zatržením pole určíte, zda například odpolední směna bude započtena v součtech, když je na daný den zadána dovolená.

· Zobrazit počet hodin podle kalendáře (Směny II v kalendáři) - po zatrhnutí pole se vpravo od jména zobrazí sloupec s počtem hodin podle kalendáře, který je nastaven v menu Seznamy/Kalendáře - formulář vybraného kalendáře/záložka Směny II.

· Zobrazit značku "$", pokud má zaměstnanec zadané mzdové položky - pokud bude mít zaměstnanec zadanou mzdovou položku, zobrazí se ve sloupci Mzd. značka "$".

· Zobrazit součet mzdových položek - pokud zadáte zaměstnanci mzdovou položku, zobrazí se vpravo od značky "$" součet mzdových položek.

· Zobrazit měsíční výsledek 1, 2, 3 - zobrazí měsíční výsledky časových složek, které jste zadali v Nastavení aplikace/Společné nastavení/Plánování kapacit 2.


Nastavení rozdělení

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit > 1. část - Nástrojová lišta >

Nastavení rozdělení

 Return to chapter overview

Pokud má zaměstnanec oprávnění plánovat kapacity více rozdělením, potom se ve formuláři Nastavení plánování kapacit zobrazí záložka Rozdělení.

PK_Planovani kapacit rozdeleni

Po zatržení políček a potvrzení formuláře můžete zaměstnance přesunovat na zvolená rozdělení rychleji. Tato zaškrtnutá rozdělení se zobrazí na výběr v nabídce.


2. část

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit >

2. část - Filtry

 Return to chapter overview

Pro zúžení výběru a zvýšení přehlednosti v tabulce plánovaných kapacit je možno použít filtry.

§ Jen rozdělení - chcete-li zobrazit pouze osoby v konkrétním rozdělení, je potřeba toto rozdělení vyhledat ze seznamu a zaškrtnout políčko.

§ Jen s kalendářem - chcete-li zobrazit pouze osoby s konkrétním kalendářem, je nutné tento kalendář vyhledat ze seznamu a zatrhnout políčko.

§ Jen typ osoby - nabízí se varianta Zaměstnanec a Zaměstnanec jiné firmy.

§ Období - období, ke kterému jsou zobrazeny naplánované kapacity.

§ Včetně podřízených rozdělení - funkce zobrazí hierarchii kategorií včetně dalších podkategorií (vytvoří se "strom", ve kterém je možno dobře se orientovat a sledovat osoby v rozdělení).

§ Součet směn zobrazit v hodinách - pokud není pole zaškrtnuté, zobrazí se součet směn naplánovaných v daném dni. Po zaškrtnutí bude tento součet zobrazen v hodinách dle naplánovaných směn v daném dni.

§ Součet absencí zobrazit v hodinách podle přiřazené směny - pokud není pole zaškrtnuté, zobrazí se součet naplánovaných absencí v daném dni. Po zaškrtnutí bude tento součet zobrazen v hodinách dle naplánovaných směn v daném dni.

Dle kalendáře - do vybraných polí se vloží směny podle přiřazeného kalendáře.

Přepočítat - provede přepočet docházky.


3. část - Informační řádek

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit >

3. část - Informační řádek

 Return to chapter overview

Jestliže v plánovaných kapacitách kliknete do buňky, tak v informačním řádku se zobrazí následující informace:

· Patří do – zobrazí se kód a název rozdělení, do kterého vybraný zaměstnanec patří.

· Směna – zobrazí se kód směny vybraného pole.

· Min, Max – údaje jsou zobrazeny v hodinách. Informace o minimálním a maximálním počtu naplánovaných hodin nastavíte v menu Seznamy/Kalendáře/Formulář kalendáře - Směny II. Pokud chcete funkci využívat je potřeba ji nejprve povolit v Nastavení aplikace/Společné nastavení - Kalendáře. Po zatržení pole Zadávat pracovní dobu v kalendáři je možné tuto funkci využívat.


Plánování kapacit

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit > 4. část >

Plánování kapacit

 Return to chapter overview

Funkce v plánovaných kapacitách:

1) Ctrl + klik myší do buňky – označí se nesouvislé oblasti. Po označení můžete hromadně vkládat/mazat směny/absence.

2) Klik myší do buňky + tah myší – označení souvislé oblasti. Po označení můžete hromadně vkládat/mazat směny/absence.

3) Klik myší do buňky + scrollování myši – označení souvislé oblasti kolečkem myši mimo viditelnou oblast. Po označení můžete hromadně vkládat/mazat směny/absence.

4) Ctrl + C – kopírování vybraných oblastí.

5) Ctrl + V - do požadovaných polí můžete vybrané oblasti vložit.

6) Delete - vymaže označené směny. Pokud je více záznamů, které chcete vymazat, budete před jejich odstraněním dotázáni, zda opravdu chcete všechny vybrané směny vymazat. Pokud pole obsahuje směnu i absenci zobrazí se vám následující okno:

Oblast, ve které chcete rušit záznamy, obsahuje naplánované směny i absence. Co si přejete smazat? Zatržením požadovaných polí (Smazat naplánované směny, Smazat naplánované absence) a stiskem tlačítka [image] vymažete vybrané záznamy.

7) vybráním příslušného pole (polí) v seznamu plánovaných kapacit a stisknutím pravého tlačítka myší se vám zobrazí následující nabídka:

Je možné provést schválení bez nutnosti použít formulář Schvalování plánovaných kapacit. Na rozdíl od formuláře zde nemáte možnost zadat datum. Stačí označit řádek vybraného dne (pro jednoho zaměstnance), případně vybrat více řádků ve sloupci (pro více zaměstnanců), kliknout pravým tlačítkem myší a zvolit jednu z následujících možností:

· Zpracováno do 12.3.2011 - v seznamu se zobrazí zelená úroveň [image].

· Zkontrolováno do 12.3.2011 - v seznamu se zobrazí žlutá úroveň [image].

· Schváleno do 12.3.2011 - v seznamu se zobrazí červená úroveň [image].

Po výběru se v seznamu zobrazí barevné označení, podle zvolené úrovně schválení, od prvního dne v měsíci po označený den. Barevné označení se zobrazí u zaměstnanců, u kterých byl označen řádek.

TIP: Pokud potřebujete jakoukoliv úroveň schválení upravit, je potřeba to provést ve formuláři Schvalování plánovaných kapacit, kde stačí upravit/vymazat datum u vybrané úrovně schválení. Po provedených změnách formulář potvrďte tlačítkem [image].

· Schválení - schválení je prováděno pro období od prvního dne v měsíci po zvolené (vybrané) datum. Označte řádek (pro jednoho zaměstnance), případně vyberte více řádků ve sloupci (pro více zaměstnanců), klikněte pravým tlačítkem myší a zvolte odkaz Schválení. Po vybrání se zobrazí formulář pro schvalování plánovaných kapacit. V tomto formuláři máte možnost zadat datum, do kdy budou data zpracována, zkontrolována, schválena. Po zadání potřebných údajů potvrďte formulář stiskem tlačítka [image]. Po potvrzení se v seznamu zobrazí barevné označení, podle zvolené úrovně schválení, od prvního dne v měsíci po zadaný den. Barevné označení se zobrazí u zaměstnanců, u kterých byl označen řádek.

· Potvrdit naplánované směny Ctrl+P - potvrdit naplánované směny je možné pro každé pole v seznamu plánovaných kapacit zvlášť (na rozdíl od Schválení plánovaných kapacit). Funkci je možné využít například při potvrzení naplánované kapacity zaměstnance přiřazeného z jiného střediska. Také ji můžete využít jako poznámku pro směny, které jsou již hotové a naplánované.

- ukázka potvrzení naplánované směny. Potvrzení je vyznačeno modrým pruhem v horní části obrázku.

· Zrušit potvrzení směn - zruší potvrzení naplánovaných směn pro vybraná pole.

· Editace docházky - po vybrání tohoto odkazu, se vám otevře formulář Editace docházky zaměstnance, u kterého jste v řádku označili pole. Editaci docházky také můžete zobrazit po kliknutí provedeném na jméně vybrané osoby.

· Přesun na jiné rozdělení - přesun osoby na jiné rozdělení můžete provést například v případě, že Středisku 1 chybí z důvodu nemoci 1 zaměstnanec. Na Středisku 2 je zrovna 1 pracovník volný. Středisko 2 v plánování kapacit v řádku zaměstnance, kterého chce přesunout na Středisko 1, označí potřebné dny, stiskne pravé tlačítko myší a vybere Přesun na jiné rozdělení. Po výběru se zobrazí formulář Plánování kapacit - přeřazení zaměstnance na jiné rozdělení, kde je potřeba vybrat rozdělení, na které má být pracovník přeřazen - Středisko 1. Po potvrzení zvoleného rozdělení se na Středisku 1 zobrazí přesunutý pracovník.

Po přesunu pracovníka se v seznamu naplánovaných kapacit zobrazí následující:

- pro Středisko 2:

- zaměstnanec je přiřazen na jiné středisko (Středisko 1) a nemá naplánovanou směnu. Pro dny jejichž pole je šedé (viz Nastavení/Vzhled - Označit needitovatelné dny cizích osob barvou) není možné plánovat kapacity.

- zaměstnanec je přiřazen na jiné středisko (Středisko 1) a má naplánovanou směnu.

- pro Středisko 1:

- přeřazenému zaměstnanci ještě nebyla naplánována směna.

- zobrazení po naplánování směny přeřazenému zaměstnanci.

TIP: Barvu čtverečku v levém dolním rohu můžete nastavit pro každé rozdělení v menu Seznamy/Rozdělení/formulář Rozdělení - záložka Formulář záznamu - Barva pro vykreslení.

· Přesunout na: Středisko 1 - pokud jste v Nastavení/Rozdělení zaškrtli pole u zobrazených rozdělení, potom se takto zaškrtnutá rozdělení zobrazí v nabídce. Po vybrání zaměstnance a označení potřebných dnů stisknete pravé tlačítko myší a z nabídky zvolíte například Přesunout na: Středisko 2. Zaměstnanec bude poté přesunut na vybrané rozdělení.

8) vyberte příslušné pole, pro které chcete zobrazit detail plánovaných kapacit a proveďte dvojklik v tomto poli.

Pokud se pohybujete v režimu plánování kapacit, zobrazí se vám následující formulář:

Detail planovanych kapacit

Ve formuláři se můžete pohybovat po jednotlivých dnech šipkami PK_Sipka seda vlevo, PK_Sipka seda vpravo.

· Směna - k zadané směně můžete dopsat poznámku k docházce. Po zadání poznámky a potvrzení formuláře se v editovaném poli zobrazí značka "...". Nastavení značky provedete ve formuláři Nastavení vzhledu (zobrazit značku "...", pokud je ke dni zadána poznámka docházky). Pokud jste ve formuláři směny zaškrtli políčko Variabilní, potom je možné zadat počátek, konec a délku směny. Pokud jste navíc zatrhli pole Vždy dopočítávat délku a konec, potom po vyplnění počátku směny a dalšího pole se třetí dopočítá a vyplní automaticky. Norma se u variabilních směn počítá ze zadané délky.

· Absence - pokud je k vybranému dni naplánovaná absence, můžete zadat poznámku i k absenci. Po potvrzení formuláře se zobrazí u absence příznak (tlustá šikmá čára v pravém horním rohu).

Pokud se pohybujete v režimu dodatečných úprav, zobrazí se vám formulář, ve kterém budete mít navíc zobrazeny Denní výsledky a Mzdové položky:

Denní výsledky:

Detail Denni vysledky

Časové složky, které chcete zobrazit v denních výsledcích, případně editovat v detailu plánování kapacit, nastavíte v menu Systém/Nastavení/Nastavení aplikace/Společné nastavení/Plánování kapacit - Detail.

Mzdové položky:

Detail Mzdove polozky

Pokud chcete zadat novou mzdovou položku stiskněte tlačítko [image] Nový záznam. Pokud chcete vložit mzdové položky podle nastavení rozdělení, stiskněte tlačítko [image] Dle rozdělení. Do seznamu, budou po té vloženy mzdové položky podle nastavení pro rozdělení. Mzdové položky dle rozdělení nastavíte v menu Systém/Nastavení/Nastavení aplikace/Společné nastavení - Nastavení mzdových položek.

Pokud chcete zadat novou mzdovou položku (bez ohledu na rozdělení), stiskněte tlačítko [image] Nový záznam. Zobrazí se formulář Mzdové položky, do kterého vepíšete potřebné údaje.

Detail Mzdove polozky formular

Formulář obsahuje následující položky:

· Kód mzdové položky - zadejte položku, pro kterou se má daná operace započítávat (základní mzda, příplatky, atp.)

· Počet jednotek - množství jednotek, za které má být operace proplacená.

· Cena za jednotku - cena jedné jednotky.

· Celková částka - v poli se zobrazí celková cena za všechny jednotky.

· Poznámka - libovolná doplňující informace ke mzdové položce.

Ukázka naplánovaných kapacit:

1) měsíc a rok.

2) den v měsíci. Pro víkendy lze nastavit barevné odlišení, viz kapitola Nastavení vzhledu.

3) datum v měsíci.

4) , [image] , [image] - naplánované směny (ranní, odpolední, noční). Písmeno a barvu pozadí nastavíte u směn v menu Seznamy/Směny - formulář Směny - pole Zkratka pro plánování a Barva pro vykreslení.

5) , [image] - naplánované absence (dovolená, nemoc). Písmeno a barvu pozadí nastavíte u absencí v menu Terminály/Operace terminálu v polích Zkratka pro plánování a Barva pro vykreslení.

6) čtvereček s barevným označením v levém dolním rohu označuje středisko, do kterého zaměstnanec patří. Označení se zobrazí v případě, že jste zaměstnance půjčili na jiné středisko, nebo vám jiné středisko zaměstnance zapůjčilo. Barvu pro vykreslení střediska nastavíte v menu Seznamy/Rozdělení.

7) šikmá čárka v pravém dolním rohu se zobrazí, pokud jste v režimu dodatečných úprav provedli změnu směny/operace.

8) pokud je ke dni zadána poznámka docházky, zobrazí se v dolní části tři tečky "...". Pokud chcete tuto značku zobrazovat, je potřeba v Nastavení vzhledu zatrhnout Zobrazit značku "...", pokud je ke dni zadána poznámka docházky.

9) [image] - barevné označení pro první úroveň schválení (Zpracováno do ...).

10) [image] - barevné označení pro druhou úroveň schválení (Zkontrolováno do ...).

11) [image] - barevné označení pro třetí úroveň schválení (Schváleno do ...).

12) - zobrazení pro středisko, které si zaměstnance zapůjčilo. Přeřazenému zaměstnanci nebyla ještě naplánována směna.

13) - zobrazení pro středisko, které si zaměstnance zapůjčilo. Přeřazenému zaměstnanci byla již naplánována směna.

14) - zobrazení pro středisko, které zaměstnance zapůjčilo. Zapůjčený zaměstnanec je přiřazen na jiné středisko a nemá naplánovanou směnu.

15) - zobrazení pro středisko, které zaměstnance zapůjčilo. Zapůjčený zaměstnanec je přiřazen na jiné středisko a již mu byla naplánována směna.

16) , [image] - tlustá šikmá čára v pravém horním rohu se zobrazí, pokud je zadána poznámka k naplánované absenci.

17) - ukázka potvrzení naplánované směny. Potvrzení je vyznačeno modrým pruhem v horní části obrázku.

18) - dny, které není možné u přesunutých osob (z jiného rozdělení) editovat, se označí šedou barvou. Barvu lze změnit v Nastavení vzhledu.

19) - ukázka zobrazení denního výsledku v plánovaných kapacitách. Které denní výsledky se mají v buňkách zobrazit, nastavíte v menu Systém/Nastavení aplikace/Společné nastavení/Plánování kapacit - Zobrazit denní výsledky v buňkách.


Seznam osob

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit > 4. část >

Seznam osob

 Return to chapter overview

Funkce v seznamu osob:

1) kliknutím na příjmení osoby se dostanete do Editace docházky vybraného zaměstnance.

2) podle jména nebo osobního čísla je možné seznam osob seřadit.

Ukázka sloupců zobrazených v seznamu osob:

PK_Zobrazeni dat v leve casti

1) v prvním sloupci je zobrazen kód rozdělení zaměstnance. Zobrazení tohoto sloupce nastavíte v Nastavení vzhledu (zobrazit kód rozdělení zaměstnance).

2) v dalším sloupci je zobrazen kód pracovního místa. Zobrazení sloupce s kódem pracovního místa nastavíte v Nastavení vzhledu (zobrazit kód pracovního místa). Kód pracovního místa se zobrazí jen, pokud máte program RonMzdy nebo RonPersonalistiku.

3) ve třetím sloupci je zobrazeno osobní číslo zaměstnance. Jeho zobrazení nastavíte v Nastavení vzhledu (zobrazit osobní číslo).

4) příjmení a jméno zaměstnance je zobrazeno automaticky.

5) pokud má zaměstnanec zadanou mzdovou položku, zobrazí se ve sloupci Mzd. značka "$". Zobrazení sloupce nastavíte v Nastavení součtů (zobrazit značku "$", pokud má zaměstnanec zadané mzdové položky).

6) když zadáte zaměstnanci mzdové položky, zobrazí se v tomto sloupci jejich součet. Zobrazení sloupce provedete v Nastavení součtů (zobrazit součet mzdových položek).

7) ve sloupci se zobrazí měsíční výsledek nastavené časové složky. Pro režim plánování a režim dodatečných úprav máte možnost zvolit jinou časovou složku. Nadpis sloupce a výběr časové složky provedete v menu Systém/Nastavení aplikace/Společné nastavení/Plánování kapacit - detail - Typ časové složky pro zobrazení měsíčního výsledku na řádku. Viditelnost měsíčních výsledků nastavíte ve formuláři Nastavení součtů zatrhnutím pole Zobrazit měsíční výsledek 1, 2, 3.

8) sloupec zobrazuje počet hodin podle kalendáře (Směny II v kalendáři), který je nastaven v menu Seznamy/Kalendáře - formulář vybraného kalendáře - záložka Směny II. Zobrazení sloupce provedete v Nastavení součtů (Zobrazit počet hodin podle kalendáře (Směny II v kalendáři)).

9) předposlední sloupec zobrazuje počet naplánovaných hodin zaměstnance. Zobrazení sloupce nastavíte v Nastavení součtů (zobrazit počet naplánovaných hodin zaměstnance).

10) v posledním sloupci je zobrazen počet naplánovaných směn zaměstnance. Jeho zobrazení nastavíte v Nastavení součtů (zobrazit počet naplánovaných směn zaměstnance).


5. část - Okno s texty poznámek

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit >

5. část - Okno s texty poznámek

 Return to chapter overview

Zobrazení okna s texty poznámek můžete nastavit v menu Systém/Správa databáze/Společné nastavení/Plánování kapacit 2 - Zobrazit texty poznámek. Po nastavení se vám zobrazí pod seznamem naplánovaných kapacit následující obrázek:

PK_Okno s texty poznamek

V okně se zobrazí poznámky zadané k docházce i k absenci.


6. část - Odkaz na Dokumenty

Navigation: Modul PLÁNOVÁNÍ KAPACIT > Prostředí Plánování kapacit >

6. část - Odkaz na Dokumenty

 Return to chapter overview

V pravém dolním rohu se nachází odkaz na Dokumenty ... . Po kliknutí na tento odkaz se dostanete do seznamu Dokumentů rozdělení. Dvojklikem na vybraném řádku se otevře dokument.

Planovani kapacit_Dokumenty rozdeleni

Seznam dokumentů rozdělení přiřadíte v menu Seznamy -> Rozdělení -> Formulář Rozdělení -> Záložka Dokumenty.


Chybové hlášky v plánovaných kapacitách

Navigation: Modul PLÁNOVÁNÍ KAPACIT >

Chybové hlášky v plánovaných kapacitách

 Return to chapter overview
Ø Nelze plánovat ve schválených dnech - ve dnech, ve kterých chcete naplánovat směnu/absenci máte potvrzené (modrý pruh) nebo schválené směny (zelený, žlutý, červený pruh).

Ø Nelze provádět dodatečné změny, pokud není původní plán schválen - pro dodatečné změny je nutné nejdříve schválit původní plán. Minimální úroveň, která musí být schválena v původním plánu je nastavena v menu Systém/Nastavení aplikace/Společné nastavení/Plánování kapacit - položka Minimální úroveň schválení. Zobrazené číslo zde označuje:

1 - je potřeba mít schváleno první úrovní Zpracováno - barva této úrovně: zelená,

2 - je nutné mít schváleno druhou úrovní Zkontrolováno - barva této úrovně: žlutá,

3 - je nutné mít schválenou třetí úrovní Schváleno - barva této úrovně: červená.

V dodatečných úpravách je potom úroveň schválení zobrazena šedou barvou.


Modul SLUŽBA

Navigation: »No topics above this level«

Modul SLUŽBA

 Return to chapter overview

Modul SLUŽBA umožňuje automaticky provádět naplánované úlohy na pozadí Windows. Je určena pro Windows NT, 2000 a XP. Modul SLUŽBA má vlastní plánovač úloh, který umožňuje naplánovat spouštěné úlohy. Pro spouštění úloh nemusí být na počítači (serveru) přihlášen žádný uživatel.


Instalace a konfigurace

Navigation: Modul SLUŽBA >

Instalace a konfigurace

 Return to chapter overview

Službu nainstalujte spuštěním souboru ADS_Service.exe (nachází se v instalaci docházky) s parametrem /install. Po provedení instalace služby se zobrazí potvrzení nainstalování služby.

Následně je potřeba službu spustit. Službu spustíte v administraci počítače, kde v službách naleznete úlohu ADS Service. Tlačítkem spustit tuto službu spustíte.

V instalaci docházky se pak nachází aplikace ADS_ServiceManager, díky které můžete vytvořit a nastavit jednotlivé úlohy. Po spuštění manažeru je v Tray zobrazena ikona. Pravým tlačítkem myši klikněte na ikonu a zvolte Editor plánovače.

POZOR: V případě, že na stejném počítači není nainstalován program DOCHÁZKA, je nutné, aby v adresáři, kde službu budete používat, byl také adresář drivers s ovladači pro komunikaci s terminály. Současně na počítači je potřeba nainstalovat mdac, případě další komponenty dle operačního systému a typu databáze docházkového systému. Viz kapitola Požadavky na software.


Plánovač úloh

Navigation: Modul SLUŽBA >

Plánovač úloh

 Return to chapter overview

Modul SLUŽBA obsahuje stejný plánovač úloh jako software DOCHÁZKA. Postup nastavení jednotlivých úloh naleznete v kapitole Nastavení plánovače úloh.


Modul INTRAWEB

Navigation: »No topics above this level«

Modul INTRAWEB

 Return to chapter overview

Modul INTRAWEB umožňuje sledování docházky v internetovém prohlížeči. Tato kapitola se zabývá instalací www serveru, php a připojení k databázi docházkového systému.

POZOR: Pro provoz intrawebu je nutná verze docházky která pracuje s SQL databázi.


Instalace www serveru s PHP

Navigation: Modul INTRAWEB >

Instalace www serveru s PHP

 Return to chapter overview

Instalaci Intrawebu lze provést dle následujících několika kroků, nicméně doporučujeme tuto instalaci svěřit odborníkům, kteří pro Vás obstarávají IT technologie (IT oddělení, spol. poskytující Vám IT outsourcing, případně zkušení kolegové).

Základní kroky instalace

- Než započnete instalaci, doporučujeme se informovat, zdali u vás již nějaký webový server neexistuje. Jestliže existuje, konzultujte další kroky s IT specialistou, který vám umožní Intraweb zprovoznit.

- Pokud má být Intraweb dostupný z internetu, je nutné, aby měl počítač veřejnou IP adresu, nebo správně nasměrovány porty (80) směrem do vnitřní sítě.

- Nainstalujte www server Apache nebo IIS.

- Nakopírujte Intraweb na www server (DocumentRoot, Domovský adresář www serveru).

- Otestujte, jestli se správně zobrazí stránka test.html.

- Nainstalujte PHP a nakonfigurujte www server, aby s PHP spolupracoval (pokud se tak již nestalo při instalaci www serveru). V případě potřeby nakonfigurujte PHP v php.ini.

- Otestujte, zdali se správně zobrazí stránka info.php

- Pokud vše funguje správně, pokračujte dále, v opačném případě doporučujeme zkontrolovat postup, případně se poradit s odborníky v oblasti IT.

- Ve složce Intrawebu umístěné na webovém serveru se nachází podsložka Install, která obsahuje soubory "_appdbset.php" a "_coding.php", tyto nakopírujte o adresář výše, tzn. do root adresáře intrawebu (např. z C:\interpub\www\intraweb\install\vybrané_soubory do C:\interpub\www\intraweb\vybrané_sosubory).

- Dále pokračujte nastavením připojení k databázi. Pro snadnější nastavení doporučujeme použít připojení pomocí ODBC.

- Přidat systémový DSN v ODBC - Ovládací panely -> Nástroje pro správu -> Datové zdroje ODBC.

- Nastavit připojení k databázi v souboru _appdbset.php.

- Otestovat funkčnost.

Web server, PHP, Intraweb

Princip:

Na serveru (počítači) běží aplikace www server (jiné názvy jsou http server, web server). Podobně jako například SQL server i webový server naslouchá na síťovém portu (nejčastěji port 80) a čeká na požadavky z jiných počítačů. Adresa webového serveru je "http://ADRESA_POČÍTAČE:PORT". Pokud je číslo portu 80, tak se v adrese nemusí zadávat.

Příklady:

http://192.168.1.1 (www server běží na počítači s IP adresou 192.168.0.1 na portu 80)

http://192.168.1.1:8080 (www server běží na portu 8080)

http://ronserver

http://www.google.com

http://localhost (www server běží na lokálním počítači s portem 80)

http://127.0.0.1 (IP adresa 127.0.0.1 je totéž jako localhost)

WWW server

Podobně jako existují různé SQL servery (Microsoft SQL server, Oracle, Interbase, MySQL, …), existují i různé webové servery – nejčastěji IIS (Microsoft) a Apache (open source).

Www server naslouchá na síťovém portu, a pokud přijde požadavek, odešle data klientovi. Na počítači může běžet i více serverů najednou – v tom případě ale musí běžet každý na jiném portu. Samotný www server umí předat pouze statické soubory – např. HTML, nebo obrázky. Pro dynamický obsah je nutná nějaká nadstavba – my používáme PHP.

PHP

PHP je skriptovací jazyk, který umožňuje vytváření dynamického obsahu – například podle dat v databázi. Modul PHP je nutné doinstalovat k www serveru. WWW server se nastaví tak, že soubory s příponou .php nejdříve předá "PHP-aplikaci" a teprve zpracovaná data předá klientovi.

Intraweb

Intraweb je naše aplikace napsaná v PHP. Nakopírujte ji na www server do příslušné složky, čímž se zpřístupní dalším počítačům v síti.

Instalace www serveru

Nejprve kontaktujte vašeho správce sítě a pozeptejte se, zdali můžete využít nějaký stávající webový server. Dále je potřeba konzultovat následující:

- na kterém počítači Intraweb poběží. Pokud má být Intraweb přístupný z internetu, musí mít počítač (server) veřejnou IP adresu (zpravidla nutno domluvit s poskytovatelem internetového připojení).

- pakli-že už na www serveru běží nějaká aplikace, je potřeba brát na tuto ohled a zvolit postup, který nebude vytvářet konflikt (pomocí virtual hosts apod.).

- pokud už má zákazník www server s PHP není nutné nic instalovat.

S pomocí aplikace XAMPP (Apache + PHP)

Pro instalaci jsme zvolili aplikaci XAMPP – tato obsahuje Apache, PHP a MySQL. Při instalaci stačí zadat cestu, kam se má nainstalovat.

Postup:

1. Spustíte instalační balíček.

Pokud chcete instalovat aplikaci do C:\xampp\ pokračujte stiskem [image]. Chcete-li změnit cílovou složku instalace, stiskněte tlačítko [image] a vyberte jinou, vhodnou složku a pokračujte pomocí tlačítka [image].

2.

Pokračujte stiskem klávesy ENTER na všechny otázky až do následujícího okna níže.

V případě, že potřebujete upravit spouštění aplikace, stiskněte klávesu "1" a ENTER, jinak pokračujte stiskem klávesy "x" a ENTER.

Po ukončení instalace lze spustit Apache. Je-li port 80 obsazený, Apache se nespustí (zobrazí se chybová hláška) a je nutné upravit jeho konfiguraci – nastavit jiný port. Konfigurační soubor webového serveru Apache je httpd.conf, ten se nachází v podadresáři apache -> conf (cesta byla zadána při instalaci a v případě použití jiného balíku než xampp se může lišit). Pokud je obsazen port 80 upravte soubor httpd.conf je nutné upravit řádek „Listen 80“ a nahradit jej například "Listen 8080"

Příklad:

C:\xampp\apache\conf\httpd.conf

C:\Program Files\xampp\apache\conf\httpd.conf

V konfiguračním souboru je také nastavená cesta, pro úložiště obsahu dat www serveru (tedy webové stránky, webové aplikace apod.).

Příklady:

DocumentRoot "C:/xampp/htdocs"

DocumentRoot "C:/xampp/www"

DocumentRoot "C:/www"

Nastavení PHP

Při instalaci XAMPP se zároveň nainstalovalo PHP, u kterého je nutné zapnout podporu MSSQL. Toto provedete v souboru php.ini (výchozí umístění jev adresáři C:\xampp\php\php.ini). Na řádku, kde je uvedeno "; extension=php_mssql.dll" je nutné odstranit středník na začátku řádku. Pokud se středník po instalaci na začátku řádku nevyskytuje, není potřeba zasahovat.

V tuto chvíli by měl být server nastaven a připraven pro provoz Intrawebu.

S pomocí WWW serveru IIS

Jedná se o součást OS Windows, která se instaluje z instalačního CD Windows. U Windows Vista/7 již CD není potřeba. Windows XP obsahují verzi IIS 6, Visty/7 mají IIS 7.

Postup pro Windows XP, Windows Server 2003:

Ovládací panely -> Přidat nebo odebrat programy -> záložka "Přidat nebo odebrat součásti systému"

Zatrhnout „Internetová Informační Služba“. Stisknout tlačítko „Podrobnosti“ a zkontrolovat, zdali je zatrhnuto „Webová služba“ dále pokračujte stiskem "ok".

Postup pro Windows Vista, Windows Server 2008:

Ovládací panely -> Programy a funkce -> Zapnout nebo vypnout funkce systému windows. Je potřeba zatrhnout políčko „Internetová informační služba“ a vnořené položky „Webové služby“ a „Nástroje webové správy“.

Po instalaci IIS vznikne v počítači složka C:\inetpub a v ní podsložka wwwroot. Jedná se o domovský adresář www serveru. Obsah tohoto adresáře bude www server zobrazovat. IIS pracuje jako služba „Služba publikování na webu“ nebo „Publikování na webu“. Zkontrolujte, zdali tato služba běží.

Nyní by měl www server fungovat. Doporučuji však funkci serveru otestovat. Nakopírujte do domovského adresáře obsah intrawebu (zazipovaný intraweb rozbalte). Webová adresa se skládá z adresy serveru a relativní cesty k souboru vzhledem k domovskému adresáři.

Příklad:

Domovský adresář je C:\inetpub\wwwroot

Umístění souboru je C:\inetpub\wwwroot\intraweb.php

Webová adresa je http://localhost/intrraweb.php

Vyzkoušejte zobrazení souboru test.html.

Instalace PHP

Pokud se PHP nenainstalovalo zároveň s www serverem, je nutné jej doinstalovat.

Odkaz ke stažení instalátoru: "http://www.php.net" – záložka "download" - stáhněte aktuální verzi "PHP x.x.xx installer" ze sekce "Windows Binares".

Spusťte instalaci PHP. V jejím průběhu budete dotázání, pro kterou verzi IIS se má PHP konfigurovat (např. IIS 6 na Windows XP nebo Windows Server 2003, IIS 7 na Vistách/7 nebo Windows Server 2008), dále pak je potřeba zvolit, zdali poběží jako ISAPI modul, nebo jako CGI modul.

ISAPI

- Zavádí se jednou při spuštění www serveru

- Je lépe zabezpečený

- Měl by být rychlejší

CGI

- Načítá se při každém zobrazení www stránky.

- Pokud se upraví konfigurace PHP v php.ini, není nutný restart webového serveru.

- Zpravidla je nutné po instalaci dokonfigurovat www server. Konfigurace v IIS 6 a IIS 7 je rozdílná – viz následující podkapitoly.

- V případě nutnosti je možné upravit konfiguraci PHP (při instalaci intrawebu a použití napojení na databázi pomocí ODBC to obvykle není nutné). PHP se konfiguruje v souboru "php.ini" – nachází se v adresáři, kde je PHP nainstalováno. Všechny řádky, které začínají středníkem, se ignorují – jsou to různé poznámky, nebo příklady a možnosti nastavení. Jednotlivé volby jsou v souboru okomentovány (zpravidla anglicky).

Někdy se může stát, že se nepovede nainstalovat PHP z instalačního balíku (windows installer) – pravděpodobně se tak děje v případě, že je na počítači nějaká starší nebo neaktualizovaná verze Windows. V tom případě je možné nainstalovat PHP přímo ze ZIPu. Postupujte takto:

- Stáhněte aktuální verzi balíku PHP zip package ze sekce Windows binaries a rozbalte ho na disk – např. Do "C:\PHP", nebo do "C:\Program Files\PHP".

- V rozbalených souborech najděte soubor "php.ini-recommended" a přejmenujte jej na "php.ini"

- V "php.ini" najděte řádek, ve kterém je nastaveno "cgi.force_redirect" a nastavte "cgi.force_redirect = 0" pokud řádek začíná středníkem, odstraňte jej z řádku.

- Dále proveďte konfiguraci IIS serveru – popsáno níže

Konfigurace IIS 6 (Windows XP, Windows Server 2003)

Ovládací panely -> Nástroje pro správu -> Správce Internetové informační služby

Je tam položka Výchozí webový server nebo Default web site

Zobrazit Vlastnosti

Na záložce Webový server se nastavuje číslo portu. Pokud to není nutné, ponechte výchozí port 80.

Dále je tam záložka Domovský adresář – opět není nutné nic měnit, ale zjistíte tady, kde je domovský adresář umístěn.

Místní cesta – umístění domovského adresáře na počítači.

Zkontrolujte, jestli je zatrhnuta položka „Číst“.

Dále klikněte na tlačítko Konfigurovat.

Zobrazí se dialog, ve kterém se nastavuje server, aby správně pracoval se soubor .php

Jsou zde nastavení pro jednotlivé typy souborů. U každého typu je uveden program, který má daný soubor zpracovat.

Pokud není v seznamu .php, tak klikněte na přidat.

Vyhledejte nainstalovaný program php-cgi.exe

Zadejte příponu .php

Konfigurace II7 (Windows Vista, Windows Server 2008)

Princip konfigurace stejný jako u IIS 6, pouze dialogy vypadají rozdílně a jinak se k nim proklikává.

Ovládací panely -> Nástroje pro správu -> Správce Internetové informační služby

Vyhledejte položku Výchozí webový server nebo Default web site

Vpravo jsou umístěny akce – klikněte na "Základní nastavení"

Nastavte fyzickou adresu – umístění domovské složky. Není nutné měnit.

Pokračujte stiskem tlačítka OK.

Dále ve správci IIS klikněte (uprostřed) na ikonu „Mapování obslužných rutin“. Pokud zde není PHP, klikněte na „Přidat mapování modulů“.

V dalším dialogu zadejte:

Cesta požadavku: *.php

Modul: FastCgiModule

Spustitelný program: najděte nainstalované php-cgi.exe

Název: PHP

Nyní by mělo správně fungovat PHP. Otestujte funkčnost pomocí zobrazení stránky info.php – zobrazí nastavení a konfiguraci PHP.

Příklad: http://localhost/info.php

Důležité položky jsou:

Loaded Configuration File – cesta k souboru php.ini, ve kterém se konfiguruje PHP

Sekce Session a v ní položka session.save_path

Session.save_path určuje cestu, kde se ukládá session – dočasná data platná pro uživatele, který se k www serveru připojí (např. zadané přihlašovací jméno a heslo).

Nastavení práv

Uživatel, pod kterým běží www server (v IIS je to IUSR_JMENOPOCITACE, v Apache je to uživatel System) musí mít dostatečná práva.

- Pro domovský adresář musí mít právo pro čtení

- Musí mít právo spouštět php-cgi.exe

- Musí mít právo číst php.ini

Instalace a konfigurace intrawebu

Pokud jste to ještě neudělali, nakopírujte intraweb na www server do domovského adresáře. Z podadresáře install zkopírujte soubory _appdbset.php a _coding.php o adresář výše – k souboru app.php. Soubory jsou umístěny v podadresáři install, aby nedošlo k přepsání konfigurace při aktualizaci na novou verzi.

V souboru _appdbset.php (v tom, který je u souboru app.php) nastavte připojení k databázi.

Pro připojení pomocí ODBC:

Vytvořte datový zdroj ODBC:

- Ovládací panely => Nástroje pro správu => Zdroje dat ODBC

- Na záložce Systémové DSN vytvořte nový

- Vyberte driver pro SQL server

- Zadejte jednoduchý název – např. INTRAWEB – tento název použijete při nastavení připojení v souboru _appdbset.php

- Doplňte popis (např. Docházka RON) a vyberte SQL server

- Na další stránce zvolte možnost ověřování serverem SQL, zadejte přihlašovací jméno a heslo (sa / ***)

- Na další stránce zaškrtněte „Změnit výchozí databázi“ a vyberte databázi.

- Ostatní hodnoty mohou zůstat na výchozích hodnotách, takže vše proklikejte a na poslední stránce klikněte na „Dokončit“.

V _appdbset.php na konci souboru proveďte nastavení připojení. Soubor obsahuje spoustu příkladů pro nastavení připojení k různým SQL serverům – příklady začínají znaky /* a končí */. Vyberte příklad, který odpovídá vašemu nastavení – nejčastěji je to

// odbc – mssql (připojení přes ODBC)

$db_utils = "db/odbc.php";

$db_connectionstring = "INTRAWEB"; - zadejte název zdroje dat, který jste zvolili při vytváření ODBC zdroje

$db_user = "sa"; - zadejte jméno uživatele SQL serveru

$db_password = "HESLO"; - zadejte heslo uživatele SQL serveru

nebo

// mssql (připojení přímo na MSSQL) – pokud vím, tak to nefunguje pro SQLExpress

$db_utils = "db/mssql.php";

$db_connectionstring = "SQLSERVER"; - zadejte název SQL serveru

$db_name = "JMENO_DATABAZE"; - zadejte jméno databáze

$db_user = "sa"; - zadejte jméno uživatele SQL serveru

$db_password = "HESLO"; - zadejte heslo uživatele SQL serveru

V tuto chvíli by měl být Intraweb funkční a připraven k použití. Samotné nastavení oprávnění a nastavení zobrazení provedete v aplikaci (Systém / Nastavení / Nastavení Intrawebu).


Konfigurace www serveru

Navigation: Modul INTRAWEB >

Konfigurace www serveru

 Return to chapter overview

Po instalaci PHP je nutné zapnout podporu MSSQL. To se provede v souboru php.ini (měl by být v adresáři C:\WINNT\PHP.INI nebo podobně). Na řádku, kde je uvedeno

; extension=php_mssql.dll

je nutné odstranit středník na začátku. Pokud tam ten středník není, tak je to OK.

Pokud při startu Apache hlásí, že nemůže najít knihovnu ./php_mssql.dll, tak zkusit v php.ini nastavit cestu k balíčkům:

extension_dir = ...

Po instalaci Apache doporučujeme restartovat počítač i v případě, že to nebude instalace vyžadovat.


Instalace php klienta docházky

Navigation: Modul INTRAWEB >

Instalace php klienta docházky

 Return to chapter overview

Do adresáře, kde jsou webové stránky se nakopíruje adresář ads s PHP klientem.


Nastavení php klienta DOCHÁZKY

Navigation: Modul INTRAWEB >

Nastavení php klienta DOCHÁZKY

 Return to chapter overview

V php klientovi je soubor _appdbset.php. V něm musí být nastaven přístup k databázi podle nastavení v aplikaci. Všechno co je mezi znaky /* a */ jsou pouze poznámky - slouží jako příklad, jak má to nastavení vypadat pro jednotlivé servery. Platné jsou řádky na konci.

Nastavení pro přístup k MSSQL

// mssql

$db_utils = "db/mssql.php"; - tuto položku neměnit

$db_connectionstring = "JMENOSQLSERVERU"; - nastavit jméno serveru

$db_name = "JMENODATABAZE"; - nastavit jméno databáze

$db_user = "sa"; - nastavit uživatele pro přístup k databázi

$db_password = ""; - nastavit heslo pro přístup k databázi


Test funkčnosti

Navigation: Modul INTRAWEB >

Test funkčnosti

 Return to chapter overview

Adresa pro přístup z prohlížeče závisí na nastavení www serveru a adresáři, kde je klient nakopírován. Hlavní stránka php klienta je ads/ads.php.

celá adresa může být tato:

jmenowwwseveru.domenawwwserveru/ads/ads.php

TIP: Nastavení funkcí modulu INTRAWEB naleznete v kapitole Nastavení intrawebu.


Výpočet nároku na stravu a strav. lístky

Navigation: Otázky a odpovědi >

Výpočet nároku na stravu a strav. lístky

 Return to chapter overview

Zadání:

Je potřeba vypočítat jaký je celkový nárok na stravu a kolik z tohoto nároku je tvořeno dobou kdy má zaměstnanec možnost se stravovat v jídelně a na kolik stravovacích (Gastro) lístků má za dobu, kdy se v jídelně strava nevydává nárok.

To znamená, že jídelna vydává stravu přes pracovní den od pondělí do pátku v době od 6:00 do 22:00 hodin. Ve dnech od Pondělí do pátku v době od 22:00 do 06:00 hodin a v době víkendů či svátků, kdy jídelna nevaří vzniká zaměstnanci nárok na stravovací (Gastro) lístek.

Řešení:

Výpočet nároku stravy, strav. lístků a stravného:

1. Nastavit příplatek "Nárok na stravu celkem".

Běžně nastavit příplatek od Pondělí do Neděle a ve všechny typy dní.

Započítáno do časové složky 994.

2. Vytvořit časovou složku s kódem 501 (nebo jiným pokud je tento obsazen, je potřeba změnit ostatní kódy v tomto postupu).

Časovou složku vytvoříte kliknutím v menu na "Seznamy" -> Typy časových složek -> kliknete na ikonku "Nový záznam" -> zadáte kód "501" -> a dále postupujete dle obrázku.

Zaokrouhlení ve Vlastnostech nastavte takto:

Dále pokračujte nastavením příplatku "Vydaná strava", která se bude počítat do časové složky s kódem "501".

Příplatek je potřeba nastavit takto:

Pouze v pracovní den a den volna od Pondělí až Pátek (za předpokladu že pouze v pracovní den od Pondělí do pátku vzniká nárok na stravu) a to od 6:00 do 22:00 hodin.

Výsledek započítat do časové složky mzdy: 501

3. Vytvořit časovou složku s kódem 500 (nebo jiným pokud je tento obsazen, je potřeba změnit ostatní kódy v tomto postupu).

Časovou složku vytvoříte kliknutím v menu na "Seznamy" -> Typy časových složek -> kliknete na ikonku "Nový záznam" -> zadáte kód "500" -> a dále postupujete dle obrázku.

Časovou složku nastavte takto:

Vložte vzorec do "Denní výsledky" -> "Kalendářní dny" -> max(0;_KV_994-_KV_501)

Tímto vzorcem zajistíte že celkový nárok na stravu bude snížen o stravu vydanou a vznikne tak počet nároků na stravovací lístky (Gastro lístky).

Výsledek:

Rozdělení celkového počtu nároku na stravu (čas. složka "994") na další dvě položky a to nárok na vydání stravy v jídelně dle provozní doby (čas. složka "501") a na nárok vydání stravovacích (Gastro) lístků (čas. složka "500").


Nechci platit předčasné příchody a pozdní odchody

Navigation: Otázky a odpovědi >

Nechci platit předčasné příchody a pozdní odchody

 Return to chapter overview

Pokud máte problém s nadpracovanými minutami, můžete to řešit těmito způsoby:

· zaokrouhlení - nastavte zaokrouhlení příchodů a odchodů u kalendáře. Pracovníci s tímto kalendářem budou mít zaokrouhleny počátky a konce směn. Problém tohoto nastavení vzniká, pokud nechcete zaokrouhlovat vždy, ale pouze přesahy přes definovanou směnu na začátku a na konci
· ignorování příchodu před směnou od určeného času a odchodu po směně do určeného času. Toto nastavení najdete v definici směny. Pro každou směnu můžete nastavit jinou práci na začátku a konci směny (viz formulář směna).


Rozdíl mezi zpracováním podle původní docházky a přepočtem výsledků

Navigation: Otázky a odpovědi >

Rozdíl mezi zpracováním podle původní docházky a přepočtem výsledků

 Return to chapter overview

Zpracování docházky probíhá ve dvou cyklech:

Ø V prvním cyklu program sestaví z jednotlivých zaznamenaných operací intervaly, na kterých uplatní nastavená pravidla pro zaokrouhlování a posuny operací. Výsledkem je interval s definovaným počátkem a koncem.

Ø V druhém cyklu se již s vytvořeným intervalem nic nemění a provádí se přepočet výsledků podle nastavení započítávání operací do jednotlivých časových složek, jejich zaokrouhlování a výpočet celkových hodnot (odpracované doby, přesčasy atd.).

Zpracování podle původní docházky:

V tomto případě se za zvolené období provede úplné zrušení vypočtených intervalů, intervaly se vytvoří znovu a provede se přepočet výsledků. Probíhají tedy oba cykly. Při zpracování podle původní docházky se zruší i intervaly vložené ručně v editaci docházky. Proto pokud jste již prováděli větší množství úprav v editaci docházky, buďte při použití této funkce opatrní.

Pokud jste změnili způsob zaokrouhlování, který ovlivňuje sestavování intervalů, nemáte jinou možnost. Bez opakovaného zpracování podle původní docházky se změny ve zpracovaném období již neprojeví.

Přepočet výsledků:

Při této funkci probíhá pouze druhý cyklus. Intervaly se nemění a přepočítává se pouze nastavení započítávání a omezení. Pokud v určitém dni provádíte editaci docházky (něco měníte) probíhá tento přepočet automaticky.


Změna letního a zimního času

Navigation: Otázky a odpovědi >

Změna letního a zimního času

 Return to chapter overview

Automatický přechod z letního času na zimní je možný pouze u terminálů TD5 a TD6, u těchto terminálů je v editoru parametrů možné nastavit datum a čas automatického posunu. Tento posun je možné provést jak směrem nahoru tak směrem dolů, podle hodnot, které si nastavíte.

Druhou možností jak docílit změny letního času na zimní je mít v plánovači úloh naplánovanou úlohu pro Nastavení akt. data a času terminálů. Tato úloha musí být aktivována.

V případě, že používáte terminál RT300, RT300B firmy ACS-Line je možnost nastavení automatické změny z letního nebo zimního času v editaci parametrů terminálu. Tato možnost je možná pouze s firmware 1,56 a vyšším.


Vytvoření vzorku databáze

Navigation: Otázky a odpovědi >

Vytvoření vzorku databáze

 Return to chapter overview

Pro ověření správnosti nastavení docházkového systému, případně pro zjištění důvodu chyb v zaznamenaných datech docházky je možno v Docházce provést export vzorku databáze.

Postupujeme takto:

menu Systém/Správa databáze/Export vzorku databáze – dostanete se do formuláře pro Export vzorku databáze. Ve formuláři nechejte zatrženy všechny údaje a k těmto navíc zatrhněte položku Data osoby a vyberete z nabízeného seznamu zaměstnance, u kterého jste zaznamenali problém a potvrďte tlačítkem OK.

Potvrzením výběru se nám otevře další okno s cestou, kam se nám vzorek databáze uloží. Do Názvu souboru (pro uložení) vepište identifikaci ukládaného souboru (vzorek, data, jméno zaměstnance apod.). Nic dalšího nedopisujte, žádné přípony!!! Soubor se sám uloží s příponou .dbs.

Tento soubor můžete následně vložit jako přílohu k dotazu na stránkách naší podpory.


Vkládání absencí v editaci zpracované docházky

Navigation: Otázky a odpovědi >

Vkládání absencí v editaci zpracované docházky

 Return to chapter overview

Standardně vygenerované záznamy jsou zobrazeny v grafickém editoru, který umožňuje ruční úpravu (editaci) těchto údajů. Při provedení ruční editace se k záznamu připíše údaj o uživateli, který provedl tuto úpravu a barevné pole se změní na křížkované.

Cesta: Docházka / Editace zpracované docházky /vyberete daného zaměstnance…

Vložení absencí do Editace zpracované docházky můžete provést dvěma způsoby:
1) Celodenní absence
a) Označíte si den, který potřebujete upravit a odstraníte všechny záznamy daného dne.
b) Zvolíte tlačítko ve spodní liště „Dle kalendáře“ a vložíte celodenní absenci. Tento způsob lze využít pro úpravu jednoho a více dnů najednou.

2) Absence části dne
a) Vyberete si den, ve kterém potřebujete upravit docházku, resp. její časový úsek. Poklepem levým tlačítkem myši na časový interval, se v docházce otevře okno, které je možné upravit podle potřeby.

Ruční editaci docházky musíte provádět v měsíci, do kterého je opravovaný den započten. Po ručních úpravách není nutné provést propočet výsledků za celý měsíc, protože se propočet provede automaticky.


Nelze naplánovat absenci v Plánování absencí

Navigation: Otázky a odpovědi >

Nelze naplánovat absenci v Plánování absencí

 Return to chapter overview

Ve formuláři operace terminálu není povolena možnost plánovat absenci. Seznam operací terminálu definuje různé druhy operací (činností, přerušení) pracovní doby.

Vždy definujete jeden příchod a několik různých přerušení-odchodů. Těmto operacím můžete nastavit parametr, který umožní jejich plánování.

Cesta: TERMINÁLY – OPERACE TERMIÁLU – Dovolená - ve formuláři musí být zatrhnuta možnost v položce ABSENCE.


Nelze vkládat absenci v Editaci zpracované docházky

Navigation: Otázky a odpovědi >

Nelze vkládat absenci v Editaci zpracované docházky

 Return to chapter overview

Ve formuláři operace terminálu není povolena možnost plánovat absenci. Seznam operací terminálu definuje různé druhy operací (činností, přerušení) pracovní doby.

Vždy definujete jeden příchod a několik různých přerušení-odchodů. Těmto operacím můžete nastavit parametr, který umožní jejich vkládání v editaci docházky.

Cesta: TERMINÁLY – OPERACE TERMIÁLU – Dovolená - ve formuláři musí být zatrhnuta možnost v položce VKLÁDAT V EDITACI DOCHÁZKY.


Nepočítá se příplatek

Navigation: Otázky a odpovědi >

Nepočítá se příplatek

 Return to chapter overview

Podmínky pro výpočet příplatků jsou stanoveny v kalendáři, který přiřazujeme určité skupině zaměstnanců. Aby výpočet příplatků byl korektní, musí být nastaveny obě základní části příplatku.

V první části nastavujete základní vlastnosti a podmínky pro výpočet příplatku a v druhé části nastavuje, které operace mají vliv na výpočet tohoto příplatku (jaké činnosti se započítávají)

Časová složka použitá pro výpočet příplatků nesmí mít ve svém nastavení v seznamu časových složek vybranou žádnou operaci pro započítávání.

Př.: SEZNAMY – TYPY ČASOVÝCH SLOŽEK – Odpracovaná doba v noci - sloupec Započítávané operace (pravý sloupec) zůstává nevyplněn.


Zaměstnanci nefunguje ID médium na terminálu

Navigation: Otázky a odpovědi >

Zaměstnanci nefunguje ID médium na terminálu

 Return to chapter overview

Menu TERMINÁLY – TERMINÁLY – dvojklikem zobrazte formulář a v záložce osoby proveďte kontrolu, zda je zaměstnanec v tomto seznamu. Pokud není, může být příčinou špatné přiřazení zaměstnance do skupiny osob, datum ukončení pracovního poměru zaměstnance, označení čipu pro vyřazení (seznam ID médií).

Menu SEZNAMY – ZAMĚSTNANCI – otevřete si kartu zaměstnance a v položce ID média si zkontrolujte, zda je korektně nastaveno přidělení média.
Přiřazení je řízeno dnem počátku a konce přiřazení. V zadaném časovém období systém identifikuje pod tímto médiem zvoleného pracovníka. Po vrácení média můžete provést přiřazení dalšímu pracovníkovi. Pokud není médium v aktuálním období nikomu přiřazeno, nebude funkční na žádném terminálu.

Změny v přiřazení osobám se projeví na terminálech až po provedení generování nastavení terminálů.


Fond odprac. doby je 7:30, ale vkládá se 8 hodin

Navigation: Otázky a odpovědi >

Fond odprac. doby je 7:30, ale vkládá se 8 hodin

 Return to chapter overview

Chyba může být v nesprávném nastavení operace terminálu.
Při volbě UKONČIT AUTOMATICKY je zvolen chybný parametr. Zvolte správný parametr a volba NÁROK NA PŘESTÁVKU nesmí být zatržen.

Rovněž mohlo dojít ke špatnému vložení při ruční editaci docházky, kdy byla vložena směna dle kalendáře s použitím počátku a konce směny, nebo omylem vložena přestávka.


Zaokrouhlování příchodu a odchodu ve prospěch firmy

Navigation: Otázky a odpovědi >

Zaokrouhlování příchodu a odchodu ve prospěch firmy

 Return to chapter overview

Cesta: SEZNAMY – KALENDÁŘE – vyberu konkrétní kalendář a upravím dle potřeb firmy v bloku ZAOKROUHLOVÁNÍ ČASŮ PRI VÝPOČTU:

Zaokrouhlování příchodu - Vždy nahoru
Zaokrouhlovat příchod na - 00:15 (příklad)
Zaokrouhlování odchodu - Vždy dolů
Zaokrouhlovat příchod na - 00:30 (příklad)

PŘÍKLAD: Příchod v 6:03 zaokrouhlí nahoru na 6:15 a odchod ve 14:03 zaokrouhlí dolů na 14:00.


Povinný nástup 10 min před směnou - jinak nadpracovat 30 min.

Navigation: Otázky a odpovědi >

Povinný nástup 10 min před směnou - jinak nadpracovat 30 min.

 Return to chapter overview

Zaměstnanci výroby, kteří mají stejný kalendář, mají povinnost nastoupit 10 minut přes směnou. Pokud přijdou pozdě, musí nadpracovat 30 minut.

Tuto situaci ošetřím na cestě:
TERMINÁLY - OPERACE TERMINÁLU - PŘÍCHOD - zvolím záložku ROZŠÍŘENÉ NASTAVENÍ, kde v řádku Úprava času operace zvolím POSUNOUT O URČITOU DOBU DOPŘEDU. V řádku Doba pro úpravu času operace zapíšu 10 minut.

V bloku ZAOKROUHLOVÁNÍ zvolím zaokrouhlování počátku - vždy nahoru a vepíšu zaokrouhlování počátku na 30 minut.


Příplatek za soboty a neděle

Navigation: Otázky a odpovědi >

Příplatek za soboty a neděle

 Return to chapter overview

Máte-li požadavek počítat příplatek za soboty a neděle pouze v délce trvání těchto dní, můžete jej snadno nastavit pomocí vzorce.

Zadání:

Je potřeba, aby se příplatek za sobotu nepočítal do směny, která začíná v pátek a počítá se do páteční noční směny. Zároveň je žádoucí, aby noční směny, které začínají v neděli, byly započítány v délce celého svého trvání do nedělní směny.

Příklad:

Zaměstnanec přijde v pátek ve 22:00 hod. na noční směnu, kde pracuje až do 6:00 následujícího dne (soboty), protože se noční směna započítává do dne, kdy začíná, nemá tento člověk nárok na příplatek za odpracovanou směnu v sobotu.

Postup řešení:

V menu Seznamy -> Typy časových složek -> zvolte časovou složku, kterou používáte pro výpočet příplatku za práci o víkendu, pokud takovou nenajdete, nebo nepoužíváte, vytvořte si novou časovou složku. -> v této časové složce zvolte záložku Vlastnosti -> a dále záložku Vzorce. Zde dle obrázku níže klikne na odkaz "Hodiny" v tabulce "Denní výsledky".

Do otevřeného okna vložte tento vzorec:

KDYZ(_currDayOfWeek=6 NEBO _currDayOfWeek=7;_H_100;0)

Ve srozumitelnějším překladu je ve vzorci napsáno toto:

Když je typ dne v týdnu sobota (6) nebo je typ dne v týdnu neděle (7) tak započítej celou odpracovanou dobu (_H_100) jinak počítej 0.

Vzorec zapsán v tabulce:

Po stisknutí tlačítka [image] se provede otestování Vámi zadaného vzorce. Pokud je vzorec výrazově správně zobrazí se


Nárok na stravenky

Navigation: Otázky a odpovědi >

Nárok na stravenky

 Return to chapter overview

U stravenek obecně, je důležité, aby byly povoleny v příplatcích a počítali se do časové složky "Stravenky 994" a zároveň, aby bylo ve vlastnostech této časové složky nastaveno sledování zaokrouhlování kalendářních dnů.

Vzorce lze zadávat takto: V menu Seznamy -> Typy časových složek -> rozklikněte časovou složku -> zvolte v levé nabídce "Vlastnosti" -> a v pravé části okna zvolte záložku "Vzorce" (viz obrázek níže). Pro zadání vzorce je doporučeno kliknout na podtržený název pole Kalendářní dny, Dny nebo Hodiny.

1. Zadání:

Pokud zaměstnanec odpracuje více než 6 hodin a zároveň méně nebo rovno 9 hodinám dostane 1 stravenku, pokud odpracuje více než 9 hodin dostane 2 stravenky.

Použit vzorec:

KDYZ(_H_100>6 A _H_100<=9;1;KDYZ(_H_100>9;2;0))

Srozumitelněji řečeno, když je odpracováno více než 6 hodin a zároveň méně nebo rovno 9 hodinám, je počítána 1, pokud není podmínka splněna pokračuje vzorec další podmínkou, když je odpracováno více než 9 hodin je počítána 2 jinak nula.

2. Zadání:

Stravenky zaměstnanec dostane, jen pokud je typ dne pondělí - pátek a platí i podmínka z předchozího zadání č. 1.

Použit vzorec:

KDYZ(NE (_currDayOfWeek=6 NEBO _currDayOfWeek=7);KDYZ(_H_100>6 A _H_100<=9;1;KDYZ(_H_100>9;2;0));0)

Zjednodušeně řečeno, když není sobota ani neděle tak pokračuj na další podmínku, viz zadání č. 1 jinak počítej 0.

3. Zadání

Stravenku zaměstnanec dostane jen v případě, že na služební cestě bude méně než 5 hodin a platí i podmínky z obou předchozích zadání.

Použit vzorec:

KDYZ(_H_121<5;KDYZ(NE (_currDayOfWeek=6 NEBO _currDayOfWeek=7);KDYZ(_H_100>6 A _H_100<=9;1;KDYZ(_H_100>9;2;0));0);0)

Volně přeloženo, když je odpracovaná doba na služební cestě menší než 5 hodin tak pokračuj podmínkami, viz minulá zadání, jinak počítá 0.


Přenos ADS na jiný počítač

Navigation: Otázky a odpovědi >

Přenos ADS na jiný počítač

 Return to chapter overview

Postup pro přenos aplikace je následující:

1) proveďte zálohu databáze na starém PC,
2) nainstalujte SQL server na novém PC - po té vytvořte prázdnou databázi,
3) nainstalujte aplikaci ADS na novém PC - po té zadejte aktivační údaje,
4) připojte ADS k SQL serveru (k již zmíněné prázdné databázi),
5) po té proveďte v ADS obnovu databáze ze zálohy (obnova zálohy ze starého PC),
6) na starém PC smazat/odinstalovat ADS a pro jistotu přejmenovat starou databázi.

Jestliže je součástí instalace i Služba pro komunikaci s terminály, je přenos následující:

1) zálohujte nastavení služby na starém PC (ikona Uložit nastavení plánovače do souboru),
2) nainstalujte službu na novém PC (je nutné spustit soubor ADS_service s parametrem /instal - po té se zobrazí potvrzovací okno),
3) spusťte službu ADS service v ovládacích panelech,
4) služba je nyní aktivní

Intraweb:

Pokud na novém PC máte již nainstalovaný webový server, PHP balík a máte nastavené propojení intrawebu s SQL serverem, tak po té stačí jen zkopírovat složku s intrawebem.


Rozdělení

Navigation: »No topics above this level«

Rozdělení

 Return to chapter overview

Enter topic text here.